Sei sulla pagina 1di 29
V 1.0 Introduzione generale a EC u M anager 2001 Ecm2001, prodotto da AlienTech Srl,
V 1.0 Introduzione generale a EC u M anager 2001 Ecm2001, prodotto da AlienTech Srl,

V 1.0

Introduzione generale a ECuManager2001

Ecm2001, prodotto da AlienTech Srl, racchiude in se stesso tutto il necessario per rimappare una centralina caricata sul pc. Permette di visualizzare e modificare le mappe in grafica 2D, 3D, esadecimale oppure in comodissime tabelle decimali ricalcolando automaticamente il checksum. Per la modifica tramite tabelle decimali necessita di drivers che sono dei file con estensione DRV o DRU posti nella cartella “drivers” all’interno della cartella principale del programma (di solito “c:\ecm2001\”). Ogni driver contiene al suo interno informazioni utilissime per il programma che ci permettono di semplificare al massimo il nostro lavoro.

il tipo di checksum (parziale,

Le più importanti sono gli indirizzi delle varie mappe (tra cui anticipo, iniezione, ecc 8bit, 16bit, ecc…) e il formato dei dati (8bit, 16bit, ecc…).

),

ecc 8bit, 16bit, ecc…) e il formato dei dati (8bit, 16bit, ecc…). ), Ecm2001 dalla A

Apertura di file e riconoscimento del driver da caricare

Lanciamo il nostro ecm2001.

del driver da caricare Lanciamo il nostro ecm2001. Nel riquadro “EPROM Originale” clicchiamo su

Nel riquadro “EPROM Originale” clicchiamo su “Sfoglia”.

nostro ecm2001. Nel riquadro “EPROM Originale” clicchiamo su “Sfoglia”. Ecm2001 dalla A alla Z - v1.0

Ci apparirà l’avviso “Nessun driver selezionato: confermi?”, clicchiamo su “Si”.

driver selezionato: confermi?”, clicchiamo su “Si”. Selezioniamo il file originale da caricare e clicchiamo su

Selezioniamo il file originale da caricare e clicchiamo su “Ok”.

il file originale da caricare e clicchiamo su “Ok”. Noteremo che la schermata principale del programma

Noteremo che la schermata principale del programma sarà cambiata e sulla destra saranno apparsi due riquadri bianchi contenenti le informazioni sul file originale e su quello modificato.

bianchi contenenti le informazioni sul file originale e su quello modificato. Ecm2001 dalla A alla Z

Tra quelle informazioni dobbiamo annotarci le versioni dell’ecu e del software della centralina.

le versioni dell’ecu e del software della centralina. Adesso dobbiamo caricare nell’ecm2001 il driver esatto

Adesso dobbiamo caricare nell’ecm2001 il driver esatto della centralina. Nel riquadro “Driver” clicchiamo su “Sfoglia”.

Nel riquadro “Driver” clicchiamo su “Sfoglia”. Ci apparirà l’avviso “I dati contenuti in memoria

Ci apparirà l’avviso “I dati contenuti in memoria verranno cancellati: vuoi continuare?”, clicchiamo su “Si”.

in memoria verranno cancellati: vuoi continuare?”, clicchiamo su “Si”. Ecm2001 dalla A alla Z - v1.0

Adesso abbiamo di fronte a noi il contenuto della cartella “Drivers” di ecm2001, scegliamo la casa produttrice della nostra auto e successivamente scegliamo il modello dell’auto.

auto e successivamente scegliamo il modello dell’auto. Per riconoscere il driver giusto tra quelli in elenco

Per riconoscere il driver giusto tra quelli in elenco dobbiamo trovare uno che abbia le stesse cifre delle versioni che abbiamo ricavato prima; precisamente dobbiamo prendere le ultime tre cifre della versione dell’hardware e le ultime tre cifre della versione del software e trovare un driver con un nome formato da queste sei cifre. Selezioniamo il driver e clicchiamo su “Ok”.

Ricarichiamo il file originale come abbiamo fatto prima e adesso siamo pronti per la visualizzazione/modifica.

Ricarichiamo il file originale come abbiamo fatto prima e adesso siamo pronti per la visualizzazione/modifica.

come abbiamo fatto prima e adesso siamo pronti per la visualizzazione/modifica. Ecm2001 dalla A alla Z

Visualizzazione e modifica dei valori tramite le tabelle

Appena caricato il driver e il file della centralina, l’ecm2001 crea dei menu sotto la barra del titolo in base alle informazioni presenti nel driver caricato. I menu per le macchine benzina e diesel (aspirati) di solito sono “Iniezione”, “Anticipo” e “Limitatori”. Le macchine turbo (sia benzina che diesel) hanno un’ulteriore menu “Turbo”.

benzina che diesel) hanno un’ulteriore menu “Turbo”. Clicchiamo su “Pressione turbo” nel menu “Turbo”. Si

Clicchiamo su “Pressione turbo” nel menu “Turbo”.

Clicchiamo su “Pressione turbo” nel menu “Turbo”. Si aprirà una nuova finestra che ci mostrerà la

Si aprirà una nuova finestra che ci mostrerà la mappa o tabella relativa alla pressione del turbo.

Ecm2001 dalla A alla Z - v1.0 - Pagina 8

Questa tabella (come la maggior parte delle tabelle in ecm2001) è formata da due assi. L’asse orizzontale rappresenta il “Load” (tradotto in italiano significa “caricamento”) e corrisponde allo sforzo dell’auto in percentuale da 0 a 100. L’asse verticale rappresenta gli “RPM” e corrisponde al numero dei giri del motore. I valori nelle celle bianche della tabella sono espressi in base 10 (numeri decimali), alcune volte è possibile visualizzare i valori effettivi della pressione della turbina in “bar” cliccando sul menu “Calcolo pressione” e successivamente su “EDC Common Rail”. Questa funzione è utile dopo aver fatto modifiche ai valori per controllare che la pressione della turbina non sia troppo elevata (è raccomandato non superare mai i 2bar).

troppo elevata (è raccomandato non superare mai i 2bar). Ritorniamo alla visualizzazione decimale cliccando su

Ritorniamo alla visualizzazione decimale cliccando su “Nessuno” nel menu “Calcolo pressione”. Adesso è arrivato il momento di aumentare la pressione della turbina. Selezioniamo tutte le celle dall’ 80% al 100% di “Load”.

della turbina. Selezioniamo tutte le celle dall’ 80% al 100% di “Load”. Ecm2001 dalla A alla

Adesso incrementiamo i valori del 10% circa (quindi 16 unità) per tutte le celle cliccando due volte sul bottone in alto “+5” oppure tramite il menu “Variazione manuale” > “Aggiungi 5”.

il menu “Variazione manuale” > “Aggiungi 5”. Noteremo una differenza di colore nelle celle modificate.

Noteremo una differenza di colore nelle celle modificate. Selezioniamo le celle dal 40% al 100% di “Load” e dai 1100 fino ai 4500 RPM.

le celle dal 40% al 100% di “Load” e dai 1100 fino ai 4500 RPM. Ecm2001

Aumentiamo nuovamente i valori del loro 10% circa (in questo caso dobbiamo aumentare di altre 10 unità).

(in questo caso dobbiamo aumentare di altre 10 unità). La modifica del turbo adesso è terminata.

La modifica del turbo adesso è terminata. Clicchiamo su “Conferma” nel menu “File”.

terminata. Clicchiamo su “Conferma” nel menu “File”. Siamo nella schermata iniziale del programma. Ecm2001 dalla

Siamo nella schermata iniziale del programma.

Adesso modificheremo l’iniezione parzializzata. La procedura è uguale a quella del turbo ma cambieremo le celle e i valori da modificare.

Le operazioni da effettuare sono le seguenti:

- Selezionare le celle da 900 fino a 4500 RPM e dallo 0% al 100% di Load

- Incrementare di due punti quindi premere due volte il bottone “+1” in alto oppure “Aggiungi 1” nel menu “Variazione manuale”

- Selezionare le celle da 1100 fino a 4500 RPM e dal 40% al 100% di Load

- Incrementare di due punti

- Selezionare le celle da 1100 fino a 4500 RPM e dal 60% al 100% di Load

- Incrementare di due punti

- Selezionare le celle da 1000 fino a 4500 RPM e dall’ 80% al 100% di Load

- Incrementare di due punti

- Selezionare le celle da 900 fino a 4500 RPM e dal 90% al 100% di Load

- Incrementare di due punti

- Selezionare le celle da 800 fino a 4500 RPM e dal 95% al 100% di Load

- Incrementare di due punti

- Selezionare le celle da 700 fino a 4500 RPM solo al 100% di Load

- Incrementare di due punti

Seguiti tutti questi passi abbiamo modificato l’iniezione parzializzato. Clicchiamo sul pulsante “D” (oppure su “Differenze” nel menu “Visualizza”) e poi sul pulsante “I” (oppure su “Incrementi” nel menu “Visualizza”.

(oppure su “Incrementi” nel menu “Visualizza”. Il pulsante “D” serve per riconoscere le celle

Il pulsante “D” serve per riconoscere le celle modificate da quelle originali. Quelle modificate hanno lo sfondo grigio mentre quelle bianche sono rimaste invariate. Il punsante “I” serve per visualizzare gli incrementi nelle celle. Attivandolo, le celle non modificate hanno come valore “0” mentre le altre hanno valori diversi che non devono mai superare i 25. Attivando entrambe le funzioni (Differenze + Incrementi) si ha una panoramica migliore della mappa e ci rendiamo conto facilmente se abbiamo sbagliato qualcosa.

Gli incrementi che dobbiamo ottenere nell’iniezione parzializzato dovranno somigliare a questi:

nell’iniezione parzializzato dovranno somigliare a questi: Clicchiamo su “Conferma” nel menu “File” (oppure

Clicchiamo su “Conferma” nel menu “File” (oppure premiamo F3). E’ possibile che nel menu “Iniezione” ci siano più voci simili tipo “Iniezione parzializzato”, “Iniezione parzializzato ( Map 1 ) ( boost x Rpm )”, “Iniezione parzializzato ( Map 2 ) ( boost x Rpm )”, ecc… In questi casi dobbiamo modificare “Iniezione parzializzato ( Map 1 ) ( boost x Rpm )” e “Iniezione parzializzato ( Map 2 ) ( boost x Rpm )” nella stessa identica maniera. Entriamo nella prima voce “Iniezione parzializzato ( Map 1 ) ( boost x Rpm )”.

“Iniezione parzializzato ( Map 1 ) ( boost x Rpm )”. - Selezioniamo le celle da

- Selezioniamo le celle da 700 a 4500 RPM e dal 40% al 100% di LOAD.

- Incrementiamo di due punti.

- Selezioniamo le celle da 700 a 4500 RPM e dal 45% al 100% di LOAD.

- Incrementiamo di due punti.

- Selezioniamo le celle da 700 a 4500 RPM e dal 50% al 100% di LOAD.

- Incrementiamo di un punto.

- Selezioniamo le celle da 700 a 4500 RPM e dal 55% al 100% di LOAD.

- Incrementiamo di un punto.

- Selezioniamo le celle da 700 a 4500 RPM e dal 65% al 100% di LOAD.

- Incrementiamo di un punto.

- Selezioniamo le celle da 700 a 4500 RPM e dal 70% al 100% di LOAD.

- Incrementiamo di due punti.

- Selezioniamo le celle da 700 a 4500 RPM e dal 75% al 100% di LOAD.

- Incrementiamo di due punti.

- Selezioniamo le celle da 700 a 4500 RPM e dall’ 80% al 100% di LOAD.

- Incrementiamo di un punto.

- Selezioniamo le celle da 700 a 4500 RPM e dal 85% al 100% di LOAD.

- Incrementiamo di un punto.

- Selezioniamo le celle da 700 a 4500 RPM e dal 90% al 100% di LOAD.

- Incrementiamo di un punto.

- Selezioniamo le celle da 700 a 4500 RPM e dal 95% al 100% di LOAD.

- Incrementiamo di un punto.

- Selezioniamo le celle da 700 a 4500 RPM e dal 100% al 100% di LOAD.

- Incrementiamo di un punto.

- Selezioniamo le celle da 700 a 4500 RPM e dall’ 80% al 100% di LOAD.

- Incrementiamo di due punti.

- Selezioniamo le celle da 700 a 3900 RPM e dal 75% al 100% di LOAD.

- Incrementiamo di un punto.

- Selezioniamo le celle da 700 a 3300 RPM e dal 70% al 100% di LOAD.

- Incrementiamo di un punto.

- Selezioniamo le celle da 700 a 2800 RPM e dal 65% al 100% di LOAD.

- Incrementiamo di un punto.

- Selezioniamo le celle da 700 a 2400 RPM e dal 60% al 100% di LOAD.

- Incrementiamo di un punto.

- Selezioniamo le celle da 700 a 2100 RPM e dal 55% al 100% di LOAD.

- Incrementiamo di un punto.

- Selezioniamo le celle da 700 a 1800 RPM e dal 50% al 100% di LOAD.

- Incrementiamo di due punti.

- Selezioniamo le celle da 700 a 1300 RPM e dal 45% al 100% di LOAD.

- Incrementiamo di due punti.

- Selezioniamo le celle da 700 a 1000 RPM e dal 40% al 100% di LOAD.

- Incrementiamo di due punti.

- Selezioniamo le celle da 700 a 1000 RPM e dal 50% al 100% di LOAD.

- Incrementiamo di due punti.

- Selezioniamo le celle da 700 a 800 RPM e dal 60% al 100% di LOAD.

- Incrementiamo di due punti.

- Selezioniamo le celle da 700 a 1100 RPM e dall’ 80% al 100% di LOAD.

- Incrementiamo di due punti. Gli incrementi dovranno somigliare a questi:

- Incrementiamo di due punti. Gli incrementi dovranno somigliare a questi: Ecm2001 dalla A alla Z

Adesso dobbiamo salvare gli incrementi fatti in un file per poterli poi applicare anche all’altra mappa “Iniezione parzializzato ( Map 2 ) ( boost x Rpm )”. Clicchiamo su “Salva mappa (incrementi)” nel menu “File” e salviamo il file.

(incrementi)” nel menu “File” e salviamo il file. Confermiamo le modifiche premendo F3. Entriamo nella mappa

Confermiamo le modifiche premendo F3. Entriamo nella mappa “Iniezione parzializzato ( Map 2 ) ( boost x Rpm )”. Clicchiamo “Carica mappa” nel menu “File” e selezioniamo il file precedentemente salvato. Se ci appare un avviso clicchiamo su “Si”.

salvato. Se ci appare un avviso clicchiamo su “Si”. Confermiamo nuovamente le modifiche premendo F3 oppure

Confermiamo nuovamente le modifiche premendo F3 oppure tramite “Conferma” nel menu “File”.

.
.

Adesso dobbiamo modificare l’ultima mappa. Clicchiamo su “Limitatore di coppia” nel menu “Iniezione”.

su “Limitatore di coppia” nel menu “Iniezione”. Questa tabella indica il limite massimo di potenza che

Questa tabella indica il limite massimo di potenza che il motore può erogare da 700 a 4500 RPM.

il limite massimo di potenza che il motore può erogare da 700 a 4500 RPM. Ecm2001

Selezioniamo tutte le celle da 800 a 4500 RPM.

Selezioniamo tutte le celle da 800 a 4500 RPM. Ecm2001 dalla A alla Z - v1.0

Incrementiamo i valori di 100 unità circa quindi modifichiamo il valore nel box “Aggiungi 1” da 1 a 100.

modifichiamo il valore nel box “Aggiungi 1” da 1 a 100. Clicchiamo sul bottone “+1”. Selezioniamo
modifichiamo il valore nel box “Aggiungi 1” da 1 a 100. Clicchiamo sul bottone “+1”. Selezioniamo

Clicchiamo sul bottone “+1”.

1” da 1 a 100. Clicchiamo sul bottone “+1”. Selezioniamo le celle da 900 a 4100

Selezioniamo le celle da 900 a 4100 RPM.

Clicchiamo sul bottone “+1”. Selezioniamo le celle da 900 a 4100 RPM. Ecm2001 dalla A alla

Incrementiamo di 50 unità.

Incrementiamo di 50 unità. Selezioniamo le celle da 1000 a 3700 RPM. Incrementiamo di 50 unità.

Selezioniamo le celle da 1000 a 3700 RPM. Incrementiamo di 50 unità. Attiviamo la funzione “Differenze” (tramite il bottone “D”) e la funzione “Incrementi” (tramite il bottone “I”) e controlliamo che gli incrementi siano corretti.

Ecm2001 dalla A alla Z - v1.0 - Pagina 2 0

Confermiamo gli incrementi e torniamo alla finestra principale. Salviamo il nuovo file tramite “Salva EPROM modificata” nel menu “File”.

tramite “Salva EPROM modificata” nel menu “File”. Ci verrà chiesto di allineare i due file, noi

Ci verrà chiesto di allineare i due file, noi risponderemo di no.

Ci verrà chiesto di allineare i due file, noi risponderemo di no. Ecm2001 dalla A alla

Visualizzazione e modifica dei valori tramite il grafico 2D

Capita alcune volte che i driver dell’ecm2001 non permettano di modificare le tabelle. In questi casi per modificare i valori nelle celle possiamo solo aiutarci tramite il grafico 2D. Entriamo in “Pressione turbo” nel menu “Turbo”. Clicchiamo su “Finestra grafica 2D” nel menu “Visualizza”.

su “Finestra grafica 2D” nel menu “Visualizza”. Si aprirà una finestra contenente un grafico 2D

Si aprirà una finestra contenente un grafico 2D rappresentante gli stessi valori nelle celle della tabella.

un grafico 2D rappresentante gli stessi valori nelle celle della tabella. Ecm2001 dalla A alla Z

Modifichiamo la scala verticale di visualizzazione per visualizzare meglio il grafico quindi selezioniamo “4096” dalla lista nel riquadro a destra.

selezioniamo “4096” dalla lista nel riquadro a destra. Modifichiamo la scala orizzontale portando la barra dello

Modifichiamo la scala orizzontale portando la barra dello zoom a ¼ cioè 75x1.

Impostiamo la variazione massima a 100 tramite il box a destra del grafico. Ecm2001 dalla

Impostiamo la variazione massima a 100 tramite il box a destra del grafico.

Impostiamo la variazione massima a 100 tramite il box a destra del grafico. Ecm2001 dalla A

Ora possiamo modificare precisamente il grafico. Clicchiamo con il mouse sopra la prima curva e tracciamo una retta che va da metà curva fino alla fine.

e tracciamo una retta che va da metà curva fino alla fine. Lasciamo il click del

Lasciamo il click del mouse sulla fine della curva.

curva fino alla fine. Lasciamo il click del mouse sulla fine della curva. Ecm2001 dalla A

Possiamo notare in blu il grafico originale e in rosso quello modificato. Eseguiamo la stessa operazione per tutte le 16 curve.

Eseguiamo la stessa operazione per tutte le 16 curve. Diminuendo lo zoom orizzontale possiamo controllare che

Diminuendo lo zoom orizzontale possiamo controllare che gli incrementi siano corretti.

Ecm2001 dalla A alla Z - v1.0 - Pagina 2 7

Clicchiamo su “Conferma” nel menu “File” e confermiamo le modifiche.

nel menu “File” e confermiamo le modifiche. Attiviamo le funzioni “Differenze” e “Incrementi” e

Attiviamo le funzioni “Differenze” e “Incrementi” e controlliamo che le modifiche siano corrette.

e controlliamo che le modifiche siano corrette. Effettuiamo le stesse procedure anche per le altre tabelle.

Effettuiamo le stesse procedure anche per le altre tabelle.

F.A.Q. (Domande Frequenti)

Di quando devo incrementare i valori nelle tabelle?

 

Benzina aspirato

Diesel aspirato

Benzina turbo

Diesel turbo

Iniezione

+25%

+20%

+35%

+30%

Turbo

-

+20%

Limitatore di giri

 

+300 rpm

 

Limitatore di coppia

 

+30%

Anticipo

Da calcolare con appositi strumenti… se non si è esperti non modificarlo

Quali celle devo incrementare nelle tabelle?

 

RPM

LOAD

Da

A

Da

A

Iniezione

700

4500

90

100

1000

4500

0

100

Turbo

700

4500

80

100

1100

4500

40

100

Limitatore di coppia

800

4500

 

-

Anticipo

700

400

0

100

Perché il mio ecm2001 non mi fa salvare il lavoro?

La tua versione di ecm2001 è dimostrativa (Demo).

Posso avere problemi riguardo le protezioni delle centraline (checksum) con ecm2001?

No, se si ha una versione completa di checksums il programma calcola automaticamente il checksum quando salviamo il nostro file.

Perché non riesco a modificare i valori nelle tabelle?

Alcuni driver non permettono la modifica tramite le tabelle ma solamente tramite il grafico 2D.

Posso usare delle percentuali di modifiche diverse da quelle nelle tabelle di esempio?

Si, in alcuni casi queste percentuali possono essere troppo ridotte o troppo elevate. La cosa migliore da fare e iniziare ad incrementare con poche unità fino a raggiungere un compromesso prestazioni/affidabilità ottimo.

Quali modifiche cambiano su un’auto che monta un filtro dell’aria aperto?

Gli incrementi nell’iniezione vengono aumentati nuovamente fino a trovare un compromesso.

Questo manuale verrà aggiornato?

Si, questo manuale verrà aggiornato appena ci saranno novità che verranno pubblicate su:

http://net.supereva.it/ecm2001/

Se non siete riusciti a trovare quello che cercavate in questo manuale contattatemi tramite Messenger su:

modman@hotmail.it