Sei sulla pagina 1di 109

FACULTAD DE CIENCIA Y TECNOLOGA

DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Trabajo Numero 1
Problema numero 12
Problema numero 2
12
Problema numero 3
13
Problema numero 4
14
Problema numero 5
16
Problema numero 6
21
Problema numero 7
22
Problema numero 8
26
Problema numero 9
28
Problema numero 1030
Problema numero 1131
Problema numero 1233
Problema numero 1335
Problema numero 1439
Problema numero 1541
Problema numero 1646
Problema numero 1750
Problema numero 1852
Problema numero 1954
Problema numero 2056
Problema numero 2158
Problema numero 2260

1
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Problema numero 2362


Problema numero 2464
Problema numero 2566
Problema numero 2668
Problema numero 2769
Problema numero 2871
Problema numero 2972
Problema numero 3076
Problema numero 3177
Problema numero 3278
Problema numero 3381
Problema numero 3984
Problema numero 4087
Problema numero 4188
Problema numero 4290
Problema numero 4392
Problema numero 4493
Problema numero 4695
Problema numero 4798
Problema numero 48
100
Problema numero 49
103
Problema numero 50
105

2
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Problema numero 1
Algoritmo dia
Escribir "este programa calcula que dia fue una fecha dada";
Escribir "Digite la fecha del que desea saber que dia fue";
Escribir "Digite el ao";
Repetir
leer a
Si a<1 Entonces
Escribir "el ao que digite debe ser mayor o igual a 1";
Escribir "digite nuevamente el ao"
Fin Si
Hasta Que a>=0;
m1<-a mod 4
m2<-a mod 100
m3<-a mod 400
Si m1=0 Entonces
Si m2=0 Entonces
Si m3=0 Entonces
//"el ao ",a," ES un ao bisiesto"
b<-1
Sino
//"el ao ",a," NO ES un ao bisiesto"
b<-0
Fin Si
Sino

3
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

//"el ao ",a," ES un ao bisiesto"


b<-1
Fin Si
Sino
//"el ao ",a," NO ES un ao bisiesto"
b<-0
Fin Si
cab<-0 //cantidad de aos bisiestos hasta el ao digitado
Para i<-1 Hasta a-1 Con Paso 1 Hacer
m1<-i mod 4
m2<-i mod 100
m3<-i mod 400
Si m1=0 Entonces
Si m2=0 Entonces
Si m3=0 Entonces
//"el ao ",a," ES un ao bisiesto"
cab<-cab+1
Sino
//"el ao ",a," NO ES un ao bisiesto"
cab<-cab+0
Fin Si
Sino
//"el ao ",a," ES un ao bisiesto"
cab<-cab+1
Fin Si
Sino
//"el ao ",a," NO ES un ao bisiesto"
cab<-cab+0

4
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Fin Si
Fin Para
da<-((a-1)*365)+cab //cantidad de dias que han pasado en todos los aos
cursados
Escribir "digite el mes";
Repetir
leer m
Si m<1 o m>12 Entonces
Escribir "el mes debe ser mayor que 0 y debe ser menor que 13"
Escribir "digite nuevamente el mes"
Fin Si
Hasta Que m>0 y m<13
mt<-m-1 //meces transcurridos en su totalidad
Si mt=0 Entonces
dm<-0
Fin Si
Si mt=1 Entonces
dm<-31
Fin Si
Si mt=2 Entonces
dm<-31+28+b
Fin Si
Si mt=3 Entonces
Si b=0 Entonces
dm<-31+28+31+b
Fin Si
Fin Si
Si mt=4 Entonces
dm<-31+28+31+30+b

5
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Fin Si
Si mt=5 Entonces
dm<-31+28+31+30+31+b
Fin Si
Si mt=6 Entonces
dm<-31+28+31+30+31+30+b
Fin Si
Si mt=7 Entonces
dm<-31+28+31+30+31+30+31+b
Fin Si
Si mt=8 Entonces
dm<-31+28+31+30+31+30+31+31+b
Fin Si
Si mt=9 Entonces
dm<-31+28+31+30+31+30+31+31+30+b
Fin Si
Si mt=10 Entonces
dm<-31+28+31+30+31+30+31+31+30+31+b
Fin Si
Si mt=11 Entonces
dm<-31+28+31+30+31+30+31+31+30+31+30+b
Fin Si
Escribir "digite el dia"
leer d
ntd<-da+dm+d //numero total de dias transcurridos
di<-ntd mod 7
Si di=0 Entonces
Escribir "el dia ",d," del mes ",m," del ao ",a;

6
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Escribir "fue un domingo"


Fin Si
Si di=1 Entonces
Escribir "el dia ",d," del mes ",m," del ao ",a;
Escribir "fue un lunes"
Fin Si
Si di=2 Entonces
Escribir "el dia ",d," del mes ",m," del ao ",a;
Escribir "fue un martes"
Fin Si
Si di=3 Entonces
Escribir "el dia ",d," del mes ",m," del ao ",a;
Escribir "fue un miercoles"
Fin Si
Si di=4 Entonces
Escribir "el dia ",d," del mes ",m," del ao ",a;
Escribir "fue un juevez"
Fin Si
Si di=5 Entonces
Escribir "el dia ",d," del mes ",m," del ao ",a;
Escribir "fue un viernes"
Fin Si
Si di=6 Entonces
Escribir "el dia ",d," del mes ",m," del ao ",a;
Escribir "fue un sabado"
Fin Si
FinAlgoritmo

7
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

8
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

9
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

10
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

11
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Problema numero 2
Algoritmo aos_bisiestos
Escribir "este programa dice si un ao es bisiesto o no";
Escribir "digite el ao que desea saber si es bisiesto";
Leer a;
m1<-a mod 4
m2<-a mod 100
m3<-a mod 400
Si m1=0 Entonces
Si m2=0 Entonces
Si m3=0 Entonces
Escribir "el ao ",a," ES un ao bisiesto"
Sino

12
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Escribir "el ao ",a," NO ES un ao bisiesto"


Fin Si
Sino
Escribir "el ao ",a," ES un ao bisiesto"
Fin Si
Sino
Escribir "el ao ",a," NO ES un ao bisiesto"
Fin Si
FinAlgoritmo

Problema numero 3
Algoritmo calculo_de_intereces
Escribir "este programa calcula el valor de un capital que genera intereces";
Escribir "Digite el valor del prestamo";
Leer p;
Escribir "Digite la tasa de interes (porcentaje) que pagara por mes ";
Leer i;
in<-(i/100)

13
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Escribir "Digite el numero de meces que se va a demorar pagando";


leer m;
t<-p*(1+in)^m;
Escribir "el valor total a pagar sera de: ",t;
FinAlgoritmo

Problema numero 4
Algoritmo parqueadero

14
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Escribir "Este programa calcula el valor que se debe pagar en un parqueadero


que cobra 50 pesos por minuto";
Escribir "ingrese la hora de entrada al parqueadero en formato de 24
horas(primero la hora y luego los minutos)"
Leer h1,m1;
Escribir "ingrese la hora de salida del parqueadero en formato de 24
horas(primero la hora y luego los minutos)"
Leer h2,m2;
mt<-(60-m1)+m2;
he<-trunc (mt/60);
min<- mt mod 60
Si h2<h1 Entonces
h2<-h2+24
Fin Si
ht<-h2-h1-1+he
mh<-ht*60
tm<-mh+min
v<-tm*50
Escribir "su tiempo en el parqueadero fue de ",ht," horas y ",min," minutos"
Escribir "el valor a pagar en e parqueadero es de ",v," pesos"

15
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Problema numero 5
Algoritmo areas_de_triangulos
Escribir "este programa calcula el area de de un triangulo segun su tipo"
Escribir " ";
Repetir
Escribir " ";
Escribir " Menu"

16
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Escribir " ";


Escribir "1. Area de un triangulo Escaleno."
Escribir "2. Area de un triangulo Equilatero."
Escribir "3. Area de un triangulo Isosceles."
Escribir "4. Area de un triangulo Rectangulo."
Escribir "5. Area de un triangulo segun las coordenadas de sus vertices"
Escribir " ";
Escribir "Digite el numero del menu que decea usar."
leer z
Si z<1 o z>7 Entonces
Escribir "El numero digitado debe estar entre 1 y 7, que son los
mostrados en el menu."
Fin Si
Hasta Que z>0 y z<8
Segun z Hacer
1:
Escribir "usted eligio la obcion 1"
Escribir "1. Area de un triangulo Escaleno."
Escribir "digite la medida de los 3 lados (consecutivamente)."
leer a,b,c
p<-(a+b+c)/2
x<-raiz(p*(p-a)*(p-b)*(p-c))
Escribir "el area del triangulo es: ",x
2:
Escribir "usted eligio la obcion 2"
Escribir "2. Area de un triangulo Equilatero."
Escribir "digite la medida de un lado."
leer a
p<-(a+a+a)/2

17
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

x<-raiz(p*(p-a)*(p-a)*(p-a))
Escribir "el area del triangulo es: ",x
3:
Escribir "usted eligio la obcion 3"
Escribir "3. Area de un triangulo Isosceles."
Escribir "digite la medida de los 2 lados congruentes y luego a del
ultimo lado"
leer a,b
p<-(a+a+b)/2
x<-raiz(p*(p-a)*(p-a)*(p-b))
Escribir "el area del triangulo es: ",x
4:
Escribir "usted eligio la obcion 4"
Escribir "4. Area de un triangulo Rectangulo."
Escribir "digite la medida de los dos lados que son
perpendiculares"
Leer a,b
x<-(a*b)/2
Escribir "el area del triangulo es: ",x
5:
Escribir "usted eligio la obcion 5"
Escribir "5. Area de un triangulo segun las coordenadas de sus
vertices"
Escribir "digite las coordenas X y Y del primer vertice"
Leer x1, y1
Escribir "digite las coordenas X y Y del segundo vertice"
Leer x2, y2
Escribir "digite las coordenas X y Y del tercer vertice"
Leer x3, y3

18
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

a<-(x1*y2)+(x2*y3)+(x3*y1)
b<-(x1*y3)+(x2*y1)+(x3*y2)
x<-abs((a-b)/2)
Escribir "el area del triangulo es: ",x
Fin Segun

FinAlgoritmo

19
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

20
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Problema numero 6
Algoritmo area_de_cuadrilatero
Escribir "este programa calcula el area de un cuadrilatero dadas las coordenadas
de los vertices"
Escribir "digite las coordenas X y Y del primer vertice"
Leer x1, y1
Escribir "digite las coordenas X y Y del segundo vertice"
Leer x2, y2
Escribir "digite las coordenas X y Y del tercer vertice"
Leer x3, y3
Escribir "digite las coordenas X y Y del tercer vertice"
Leer x4, y4
a<-(x1*y2)+(x2*y3)+(x3*y1)
b<-(x1*y3)+(x2*y1)+(x3*y2)
xt1<-abs((a-b)/2)
p<-(x1*y4)+(x4*y3)+(x3*y1)
q<-(x1*y3)+(x4*y1)+(x3*y4)
xt2<-abs((p-q)/2)
z<-xt1+xt2

21
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Escribir xt1
Escribir xt2
Escribir "el area del cuadrilatero es ",z
FinAlgoritmo

Problema numero 7
Algoritmo poligono_regular
Escribir "este porograma calcula el area de los primeros 10 poligonos regulares"
Repetir

22
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Escribir " ";


Escribir " menu"
Escribir " ";
Escribir " 1. Poligono regular de 3 lados."
Escribir " 2. Poligono regular de 4 lados."
Escribir " 3. Poligono regular de 5 lados."
Escribir " 4. Poligono regular de 6 lados."
Escribir " 5. Poligono regular de 7 lados."
Escribir " 6. Poligono regular de 8 lados."
Escribir " 7. Poligono regular de 9 lados."
Escribir " 8. Poligono regular de 10 lados."
Escribir " ";
Escribir "Digite el numero correspondiente a la opcion del menu que
desea saber"
leer z
si z<1 o z>8 Entonces
Escribir "debe digitar un numero entre 1 y 8 mostrados en el
menu"
Escribir "digite nuevamente la opcion que desea del menu"
FinSi
Hasta Que z>0 y z<9
n<-z+2
Escribir "usted eligio la obcion: ",z,". Poligono regular de ",n," lados."

Escribir "digie la medida de una arista del poligono"


Leer l
n<-z+2
base<-l/2
ang1<-180/n

23
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

ang2<-90
ang3<-180-ang2-ang1
x<-(ang3*pi)/180;
tana<-tan(x)
h<-tana*base
a<-(h*n*l)/2
Escribir "el poligono regular de ",n," lados con logitud de arista de",l
Escribir "tiene un area de: ",a

24
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

25
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Problema numero 8
Algoritmo triangulo
Escribir "este programa dice si apartir de tres medida se puede formar un
triangulo";
Escribir "digite cada uno de las logitudes de los lados"
escribir "digite la longitud del lado 1:";

26
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

leer a;
escribir "digite la longitud del lado 2:";
leer b;
escribir "digite la longitud del lado 3:";
leer c;
d <- a+b;
e <- b+c;
f <- a+c;
si a<=0 o b<=0 o c<=0 entonces
Escribir "no forman un triangulo, la longitud no puede ser 0 o un numero
negativo";
Sino
si e>a y f>b y d>c entonces
Escribir "si forman triangulo";
Sino
escribir "no forman triangulo";
FinSi
FinSi

FinAlgoritmo

27
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Problema numero 9
Algoritmo triangulo_pitagorico
Escribir "este programa dice si un triangulo rectangulo es pitagorico o no"
Escribir "digite los catetos del triangulo rectangulo."
leer a,b
Escribir "digite la hipotenusa del triangulo"
leer c
d <- a+b;
e <- b+c;
f <- a+c;
si a<=0 o b<=0 o c<=0 entonces

28
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Escribir "no forman un triangulo, la longitud no puede ser 0 o un numero


negativo";
Sino
si e>a y f>b y d>c entonces
a1<-a^2
b1<-b^2
c1<-c^2
x<-a1+b1
Si c1=x Entonces
Escribir "el triangulo ES pitagorico"
Sino
Escribir "el triangulo NO ES pitagorico"
Fin Si
Sino
escribir "no forman triangulo";
FinSi
Fin Si
FinAlgoritmo

29
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Problema numero 10
Algoritmo logaritmo
Escribir "este programa calcula el logaritmo de un numero dada la base"
Escribir "digite el la base del logaritmo"
leer x
Escribir "digite el numero"
leer a
z<-ln(a)/ln(x)
Escribir "el logaritmo en base ",x," del numero ",a," es: ",z
FinAlgoritmo

30
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Problema numero 11
Algoritmo funciones_trigonometricas
Escribir "este programa calcula las funciones trigonometricas de un valor";
escribir "digite el valor";
leer z;
x<-(z*pi)/180;
a1<-sen(x);

31
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Escribir "El seno es: ",a1," .";


a2<-cos(x);
Escribir "el coseno es: ",a2," .";
Si a2=0 Entonces
Escribir "la funcion tangente no esta definida para este valor.";
Sino
a3<-tan(x)
Escribir "La tangente es: ",a2," .";
Fin Si
Si a1=0 Entonces
escribir "la funcion cosecantes no esta definida para este valor.";
Sino
a4<-(1/a1);
Escribir "La cosecante es: ",a3," .";
Fin Si
Si a2=0 Entonces
Escribir "la funcion secante no esta definida para este valor.";
Sino
a5<-(1/a2);
Escribir "La secante es: ",a4," .";
Fin Si
Si a3=0 Entonces
escribir "la funcion cotangente no esta definida para este valor.";
Sino
a6<-(1/a3);
Escribir "La cotangente es: ",a3," .";
finsi
FinAlgoritmo

32
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Problema numero 12
Algoritmo finciones_trigonometricas_invereas
Escribir "este programa calcula las funciones trigonometricas inversas";
Escribir "digite el valor";
leer a;
Si a>1 o a<-1 Entonces

33
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Escribir "el arcoseno no esta definido para ",a;


Escribir "el arcocoseno no esta definido para ",a;
Sino
a1<-asen(a);
Escribir "el arcoseno de ",a "es: ",a1;
a2<-acos(a);
Escribir "el arcocoseno de ",a "es: ",a2;
Fin Si
a3<-atan(a);
Escribir "arcotangente de ",a "es: ",a3;
Si a>-1 o a<1 Entonces
Escribir "el arcocosecante no esta definido para ",a;
Sino
a4<-(1/asen(a))
Escribir "el arcosecantes de ",a "es: ",a4;
Fin Si
Si a>-1 o a<1 Entonces
Escribir "el arcosecante no esta definido para ",a;
Sino
a5<-(1/acos(a))
Escribir "el arcosecantes de ",a "es: ",a5;
Fin Si
Si a=0 Entonces
Escribir "la funcion arcocotangente no esta definida para: ",a;
Sino
a6<-(1/atan(a));
Escribir "el arcocotangente de ",a," es: ",a6;
Fin Si

34
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Problema numero 13
Algoritmo salario
Dimension noe[1000],ape[1000],ex[1000],hi[1000],nit[1000],bru[100],
neto[1000],bon[1000],sub[1000],a[1000],ap[1000],sto[1000];
escribir "Este programa calcula el salario neto de varios empleados";
escribir "digite el numero de empleados";

35
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

leer ne;
Para i<-1 Hasta ne Con Paso 1 Hacer
Escribir"ingrese el nombre del empleado",i;
leer noe[i];
escribir"ingrese el apellido del empleado",i;
leer ape[i];
Escribir"ingrese aos de experiencia del empleado",i;
leer ex[i];
escribir"ingrese los numeros de hijos del empleado",i;
leer hi[i];
Escribir"ingrese la identificacion del empleado",i;
leer nit[i];
escribir"ingrese el salario bruto del empleado",i;
leer bru[i];
fin para
Para i<-1 Hasta n Con Paso 1 Hacer
bon[i]<-ex[i]*(2/100)*bru[i];
a[i]<-bru[i]*(8/100);
fin para
minimo<-689540;
Para i<-1 Hasta n Con Paso 1 Hacer
Si bru[i]>4*minimo Entonces
sub[i]<-bru[i]*(5/100)*hi[i];
ap[i]<-bru[i]*(1/100);
Sino
sub[i]<-bru[i]*(7/100)*hi[i];
ap[i]<-ap[i];

36
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Fin Si
Si bru[i]<2*minimo Entonces
sto[i]<-bru[i]*(11/100);

Sino
sto[i]<-sto[i];
Fin Si
Fin Para

Para i<-1 Hasta n Con Paso 1 Hacer


neto[i]<-bru[i]+bon[i]+sub[i]-a[i]-ap[i]+sto[i];
Escribir "el apellido del empleado es ",ape[i];
Escribir "nombre: ",noe[i]," apellido: ",ape[i]," salario neto: ",neto[i],"
bonificacion: ",bon[i]
Fin Para
FinAlgoritmo

37
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

38
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Problema numero 14
Algoritmo raices_de_ecuacion_cuadratica2
Escribir "este programa muestra si las raices de una ecuacion cuadratica son
reales o complejas o iguales a 0";
Escribir "Teniendo en cuenta que una ecuacion cuadratica tiene la forma:
aX^2+bX^+c";
Escribir "digite el valoer de a";
leer a;

39
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Escribir "digite el valoer de b";


leer b;
Escribir "digite el valoer de c";
leer c;
d <- (b^2)-(4*a*c);
Si d<0 Entonces
Escribir "hay dos raices complejas";
Sino
Si d>0 Entonces
Escribir "hay dos raices raices reales";
x1<-((-b)+raiz(d))/2
x2<-((-b)-raiz(d))/2
escribir "estas son: ",x1," y ",x2
Sino
Escribir "hay dos raices iguales"
Fin Si
Fin Si
FinAlgoritmo

40
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Problema numero 15
Algoritmo la_mayor_nota
Escribir "este programa ordena 4 numeros de menor a mayor";
escribir "escriba los 4 numeros";
Dimension a[10]
Para i<-1 Hasta 4 Con Paso 1 Hacer
leer a[i]
Fin Para
Escribir "los numeros ordenados son:"
ma<-a[1]

41
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Para i<-2 Hasta 4 Con Paso 1 Hacer


Si ma<a[i] Entonces
ma<-ma
Sino
ma<-a[i]
Fin Si
Fin Para
Escribir ma
i<-1
Repetir
x<-ma mod a[i]
si x=0 Entonces
a[i]<-a[1]+a[2]+a[3]+a[4]
FinSi
i<-i+1
Hasta Que x=0
mb<-a[1]
Para i<-2 Hasta 4 Con Paso 1 Hacer
Si mb<a[i] Entonces
mb<-mb
Sino
mb<-a[i]
Fin Si
Fin Para
Escribir mb
i<-1
Repetir
x<-mb mod a[i]

42
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

si x=0 Entonces
a[i]<-a[1]+a[2]+a[3]+a[4]
FinSi
i<-i+1
Hasta Que x=0
mc<-a[1]
Para i<-2 Hasta 4 Con Paso 1 Hacer
Si mc<a[i] Entonces
mc<-mc
Sino
mc<-a[i]
Fin Si
Fin Para
Escribir mc
i<-1
Repetir
x<-mc mod a[i]
si x=0 Entonces
a[i]<-a[1]+a[2]+a[3]+a[4]
FinSi
i<-i+1
Hasta Que x=0
md<-a[1]
Para i<-2 Hasta 4 Con Paso 1 Hacer
Si md<a[i] Entonces
md<-md
Sino
md<-a[i]

43
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Fin Si
Fin Para
Escribir md
FinAlgoritmo

44
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

45
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Problema numero 16
Algoritmo area_de_cuadrilateros
Escribir "este programa calcula el area de diferentes cuadrilateros"
Escribir "";
Repetir
Escribir " ";
Escribir " Menu"
Escribir " ";
Escribir "1. Area de un cuadrado."
Escribir "2. Area de un rectangulo."
Escribir "3. Area de un rombo."
Escribir "4. Area de un cometa."

46
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Escribir " ";


Escribir "Digite el numero del menu que decea usar."
leer z
Si z<1 o z>4 Entonces
Escribir "El numero digitado debe estar entre 1 y 7, que son los
mostrados en el menu."
Fin Si
Hasta Que z>0 y z<5
Segun z Hacer
1:
Escribir "eligio hallar el area de un cadrado"
Escribir "digite la longitud de un lado"
Leer a
x<-a*a
Escribir "el area del cuadrado es: ",x
2:
Escribir "eligio hallar el area de un rectangulo"
Escribir "digite la longitud de dos lados adyasentes"
leer a,b
x<-a*b
Escribir "el area del rectangulo es: ",x
3:
Escribir "eligio el area de un rombo"
Escribir "digite la longitud de las diagonales"
Leer a,b
x<-(a*b)/2
Escribir "el areal del rombo es: ",x
4:
Escribir "eligio el area de un cometa"

47
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Escribir "digite la longitud de las diagonales"


Leer a,b
x<-(a*b)/2
Escribir "el area del cometa es: ",x
De Otro Modo:
Escribir "profe cuando no hay tanto tiempo para hacer trabajos,
quedan asi de chambones, perdone"
Fin Segun
FinAlgoritmo

48
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

49
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Problema numero 17
Algoritmo solidos
Escribir "Este programa calcula el volumen de ciertos solidos"
Repetir
Escribir " menu";
Escribir "1. volumen del cubo";
Escribir "2. volumen de la esfera";
escribir "3. volumen del cilindro";
Escribir "4. volumen del cono";
Escribir "5. volumen de paralepipedo";
Leer z;
Segun z Hacer
1:
Escribir "eligio volumen de un cubo";
ESCRIBIR "digite valor de la arista";
LEER a;
x<- a^3;
ESCRIBIR "el volumen del cubo es: ",x;
2:
Escribir "eligio volumen de una esfera";
Escribir "digite la medida del radio";
Leer r;
x<-(4/3)*pi*(r^3);
Escribir "el volumen de la esfera es: ",x;

3:
Escribir "eligio volumen de un cilindro";
Escribir "digite el radio y altura del cilindro";

50
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Leer r,h;
x<-pi*(r^2)*h;
Escribir "el volumen del cilindro es: ", x;
4:
Escribir "eligio volumen de un cono";
Escribir "digite el radio y la altura del cono";
Leer r,h;
x<-pi*(r^3)*h/3;
Escribir "el volumen del cono es: ", x;
5:
Escribir "eligio volumen de un paralelepipedo";
Escribir "digite el valor de las aristas";
Leer a,b,c;
x<-a*b*c;
Escribir "el volumen del paralelepipedo es: ", x;
De Otro Modo:
Escribir "debe digitar un numero que pertenezca al menu,
intente de nuevo";
Fin Segun
Hasta Que z>0 y z<6
FinAlgoritmo

51
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Problema numero 18
Algoritmo poliedro_regular

escribir"este programa calcula el volumen de polidros regulares";


Repetir
escribir" menu";
escribir"1. Volumen de poliedro regular hexaedro";
escribir"2. Volumen de poliedro regular octaedro";
escribir"3. Volumen de poliedro regular tetraedro";
escribir"4. Volumen de poliedro regular dodecaedro";
escribir"5. Volumen de poliedro regular icosaedro";
leer z;
Segun op Hacer
1:
Escribir "eligio el volumen del poliedro regular hexaedro"
Escribir "ingrese el valor de una arisa del poliedro"
leer a;
x<-(a^3)

52
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

escribir"el volumen del poliedro regular hexaedro ",x;


2:
Escribir "eligio el volumen del poliedro regular octaedro"
Escribir "ingrese el valor de una arisa del poliedro"
leer a;
x<-(a^3/3)*raiz(2)
escribir "el volumen del poliedro regular octaedro ",x;
3:
Escribir "eligio el volumen del poliedro regular tetraedro"
Escribir "ingrese el valor de una arisa del poliedro"
leer a;
x<-(a^3/12)*raiz(2)
escribir "el volumen del poliedro regular tetraedro",x;
4:
Escribir "eligio el volumen del poliedro regular
dodecaedro"
Escribir "ingrese el valor de una arisa del poliedro"
leer a;
x<-((15+(7*raiz(5)))/4)*a^3
escribir "el volumen del poliedro regular dodecaedro ",x;
5:
Escribir "eligio el volumen del poliedro regular icosaedro"
Escribir "ingrese el valor de una arisa del poliedro"
leer a;
x<-((5*(3+raiz(5)))/12)*a^3
escribir "el volumen del poliedro regular icosaedro ",x;
De Otro Modo:
escribir "debe elegir una opcion del menu, inente de
nuevo";

53
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Fin Segun
Hasta Que z>0 y z<6
FinAlgoritmo

Problema numero 19
Algoritmo punto_19
dimension a1[100,100];
Escribir "este programa contiene dos obciones en un menu"
Repetir
Escribir " menu";
Escribir "1. solucion a un sistema de dos ecuaciones";
Escribir "2. determinante de una matriz de 3X3";

Leer z;
Segun z Hacer
1:
Escribir "eligio solucion a un sistema de dos ecuaciones";
Escribir "dado un sistema de la este forma";
Escribir "ax+by=c";

54
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Escribir "dx+ey=f";
Escribir "digite a, b, c, d, e, f en ese respectivo orden ";
Leer a,b,c,d,e,f;
w<-(a*e-d*b);
wx<-(c*e-f*b);
wy<-(a*f-c*d);
Si w<>0 Entonces
Escribir "el sistema tiene una solucion unica";
x<-(wx/w);
xy<-(wy/w);
Escribir "x= ",x," ; y= ", xy;
Sino
Si (wx=0 y wy=0) Entonces
Escribir "el sistema tiene infinitas
soluciones";
Sino
Escribir "el sistema no tiene solucion";
Fin Si
Fin Si
2:
Para i<-1 Hasta 3 Con Paso 1 Hacer
Para k<-1 Hasta 3 Con Paso 1 Hacer
Escribir "digite la posicion ",i,",",k;
Leer a1[i,k];
Fin Para
Fin Para
d1<-
(a1[1,1]*a1[2,2]*a1[3,3]+a1[1,2]*a1[2,3]*a1[3,1]+a1[1,3]*a1[2,1]*a1[3,2]);

55
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

d2<-
(a1[3,1]*a1[2,2]*a1[1,3]+a1[3,2]*a1[2,3]*a1[1,1]+a1[3,3]*a1[2,1]*a1[1,2]);
d<-d1-d2;
Escribir "el deteterminante de la matriz es: ",d;
De Otro Modo:
Escribir "debe digitar una obcion del menu, intentelo de
nuevo";
Fin Segun
Hasta Que z=1 o z=2

FinAlgoritmo

Problema numero 20
Algoritmo promedio
Escribir "este programa calcula el promedio de varios numeros"

56
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Escribir "digite la cantidad de numeros"


Repetir
leer n
Si n<1 Entonces
Escribir "el numero digitado debe ser mayor a 0, digite
nuevamente la cantidad de numeros"
FinSi
Hasta Que n>0
Escribir "digite los numeros"
x<-0
Para i<-1 Hasta n Con Paso 1 Hacer
Escribir "numero ",i,": "
leer a
x<-x+a
Fin Para
p<-x/n
Escribir "el promedio es: ",p
FinAlgoritmo

57
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Problema numero 21
Algoritmo primo
Escribir "este programa dice si un numeroe es primo";
Escribir "digite el numero del que quiere saber si es primo";
Leer k;
n<-0;
Para t<-1 Hasta k Con Paso 1 Hacer

58
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

s<-k mod t;
Si s=0 Entonces
n<-n+1;
Fin Si
Fin Para
si n=2 Entonces
Escribir "el numero ",k," es primo"
Sino
Escribir "el numero",k," no es primo"
FinSi

FinAlgoritmo

59
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Problema numero 22
lgoritmo divisores
Escribir "lista de divisores de un numero";
Escribir "digite el numero del que quiere hallar los divisores";
Leer k;
n<-0;
escribir "los divisores de ",k," son";
Para t<-1 Hasta k Con Paso 1 Hacer

60
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

s<-k mod t;
Si s=0 Entonces
Escribir t;
n<-n+1;
Fin Si

Fin Para
escribir "el numero de divisores es: ",n;
FinAlgoritmo

61
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Problema numero 23
Algoritmo primo_menosres
Escribir "este programa da una lissta de primos menor a un numero";
Escribir "digite el numero";
Leer k;
x<-0;
Escribir "numeros primos menores que ",k,":"
Para i<-1 Hasta k-1 Con Paso 1 Hacer

62
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

n<-0;
Para t<-1 Hasta i Con Paso 1 Hacer
s<-i mod t;
Si s=0 Entonces
n<-n+1;
Fin Si
Fin Para
si n=2 Entonces
Escribir i
x<-x+1
FinSi
Fin Para

63
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Problema numero 24
Algoritmo primo
Escribir "este programa muestra n numeros primos";
Escribir "digite cuantos numeros primos quiere ver";
Leer k;
i<-0;
x<-0;
Escribir "lista de los primeros ",k," numeros primos:"

64
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Repetir
i<-i+1
n<-0;
Para t<-1 Hasta i Con Paso 1 Hacer
s<-i mod t;
Si s=0 Entonces
n<-n+1;
Fin Si
Fin Para
si n=2 Entonces
Escribir i
x<-x+1
FinSi
Hasta Que x=k
FinAlgoritmo

65
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Problema numero 25
Algoritmo Fibonaci
Escribir "este programa muestra una lista de terminos de la sucecion fobonaci"
Escribir "digite cuantos terminos de la sucecion desea saber"
leer n
z<-1
x<-0

66
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Para i<-1 Hasta n Con Paso 1 Hacer


t<-z
z<-x
x<-z+t
Escribir "el termino ",i," es ",x
Fin Para
FinAlgoritmo

67
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Problema numero 26
Algoritmo Fibonaci2
Escribir "este programa muestra una lista de terminos de la sucecion fobonaci
menores a un numero"
Escribir "digite el numero"
leer n
z<-1
x<-0
i<-0
Escribir "terminos menores a ",n," de la sucecion:"
Mientras x<n Hacer
t<-z
z<-x
x<-z+t
si x<n Entonces
Escribir ,x
FinSi
Fin Mientras

FinAlgoritmo

68
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Problema numero 27
Algoritmo Fibonaci3
Escribir "genera los terminos de la sucecion fibonaci hasta que la suma de estos
supera un numero"
Escribir "digite el numero"
leer n
z<-1
x<-0

69
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

i<-0
Escribir "terminos menores a ",n," de la sucecion:"
Mientras i<n Hacer
t<-z
z<-x
x<-z+t
Escribir ,x
i<-i+x
Fin Mientras

FinAlgoritmo

70
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Problema numero 28
Algoritmo reduccion_de_angulo
Escribir "este programa reduce la medida de un angulo hasta que sea menor a
360"
Escribir "digite el angulo"
leer a
x<-a mod 360
Escribir "el angulo redcido es: ",x

71
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

FinAlgoritmo

Problema numero 29
Algoritmo promedios
Escribir "este programa calcula diferentes promedios"
Escribir ""
Repetir
Escribir " menu"
Escribir ""
Escribir "1. Promedio artimetico."
Escribir "2. Promedio ponderado."

72
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Escribir "3. Promedio aritmetico."


Escribir "4. Promedio cuadratico."
Escribir ""
Escribir "Digite el numero del menu"
Leer z
Dimension a[1000],po[1000]
Si z<1 o z>4 Entonces
Escribir "el numero digitado debe ser un numero del menu"
Escribir "digite nuevamente el numero del menu"
Fin Si
Segun z Hacer
1:
z<-0
Escribir "usted eligio"
Escribir "1. Promedio artimetico."
Escribir "digite el numero de datos"
leer n
Escribir "digite los datos"
Para i<-1 Hasta n Con Paso 1 Hacer
leer x
z<-x+z
Fin Para
p<-z/n
Escribir "el promedio aritmetico es: ",p
2:
Escribir "usted eligio"
Escribir "2. Promedio ponderado."
Escribir "digite el numero de datos"

73
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

leer n
t<-0
s<-0
Para i<-1 Hasta n Con Paso 1 Hacer
Escribir "digite el dato ",i," luego la ponderacion que este
tiene"
leer a[i]
leer po[i]
s<-po[i]+s
t<-(a[i]*po[i])+t
p<-t/s
Escribir "e promedio ponderado es: ",p
Fin Para
3:
z<-0
Escribir "usted eligio"
Escribir "3. Promedio aritmetico."
Escribir "digite el numero de datos"
leer n
Para i<-1 Hasta n Con Paso 1 Hacer
leer x
z<-(1/x)+z
Fin Para
p<-n/z
Escribir "el promedio aritmetico es: ",p

5:
Escribir "usted eligio"
Escribir "5. Promedio cuadratico."

74
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Escribir "digite el numero de datos"


leer n
Para i<-1 Hasta n Con Paso 1 Hacer
leer a[i]
t<-(a[i]*a[i])+t
Fin Para
p<-raiz(t/n)
Escribir "el promedio cuadratico es: ",p
De Otro Modo:
Escribir "debe elegir una opcion del menu"
Fin Segun
Hasta Que z>0 y z<5
FinAlgoritmo

75
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Problema numero 30
Algoritmo Fibonaci_mientras
Escribir "este programa muestra una lista de terminos de la sucecion fobonaci"
Escribir "digite cuantos terminos de la sucecion desea saber"
leer n
z<-1
x<-0
p<-1
Mientras p<>n Hacer
t<-z
z<-x
x<-z+t
Escribir "el termino ",p," es ",x
p<-p+1
Fin Mientras

FinAlgoritmo

76
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Problema numero 31
Algoritmo Fibonaci_hasta
Escribir "este programa muestra una lista de terminos de la sucecion fobonaci"
Escribir "digite cuantos terminos de la sucecion desea saber"
leer n
z<-1
x<-0
p<-0

77
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Repetir
p<-p+1
t<-z
z<-x
x<-z+t
Escribir "el termino ",p," es ",x
Hasta Que p=n

FinAlgoritmo

78
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Problema numero 32
Algoritmo Fibonaci_para
Escribir "este programa muestra una lista de terminos de la sucecion fobonaci"
Escribir "digite cuantos terminos de la sucecion desea saber"
leer n
z<-1
x<-0
Para i<-1 Hasta n Con Paso 1 Hacer

79
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

t<-z
z<-x
x<-z+t
Escribir "el termino ",i," es ",x
Fin Para
FinAlgoritmo

80
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Problema numero 33
Algoritmo conteo
Escribir "este programa halla algunas tecniacs de conteo";
Escribir " menu"
Escribir "1. Factorial";
Escribir "2. Combinacion";
Escribir "3. Variacion";
Escribir "digite una opcion";
Leer z
Segun z Hacer
1:
Escribir "eligio factorial de un numero"
Escribir "digite el numero";
Leer a;
f<-1;
Para i<-1 Hasta a Con Paso 1 Hacer
f<-f*i;
Fin Para
Escribir "el factorial de ",a," es: ",f;
2:
Escribir "eligio combinatoria"
Escribir "calcula m combinado n";
Escribir "digite m";
leer m;
Escribir "digite n";
leer n;
f<-1;
Para i<-1 Hasta m Con Paso 1 Hacer

81
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

f<-f*i;
Fin Para
f1<-1;
Para i<-1 Hasta n Con Paso 1 Hacer
f1<-f1*i;
Fin Para
f2<-1;
Si m>n Entonces
Para i<-1 Hasta (m-n) Con Paso 1 Hacer
f2<-f2*i;
Fin Para
c<-f/(f1*f2);
Escribir m," combinado ",n," es: ",c;
Sino
Escribir "no se puede calcular esa combinatorio por que m
es menor a n";
Fin Si
3:
Escribir "eligio variaciones"
Escribir "calcula variaciones de m en n"
Escribir "digite m";
leer m;
Escribir "digite n";
leer n;
Si m>n Entonces
f<-1;
Para i<-1 Hasta m Con Paso 1 Hacer
f<-f*i;
Fin Para

82
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

f1<-1;
f2<-1;
Para i<-1 Hasta (m-n) Con Paso 1 Hacer
f2<-f2*i;
Fin Para
v<-f/(f2);
Escribir m," combinado ",n," es: ",v;
Sino
Escribir "no se puede calcular las variaciones, por que m
es menor a n";
Fin Si
De Otro Modo:
Escribir "su opcion no es valida";
Fin Segun
FinAlgoritmo

83
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Problema numero 39
Algoritmo binomio
Escribir "este programa calcula coeficientes";
Escribir "teniendo en cuenta que un binomio de la forma (a+b)^n";
Escribir "digite n"
leer n;
Escribir "Los coeficientes del binomio son: "
Para i<-0 Hasta n Con Paso 1 Hacer
c1<-0;
c2<-0;
c3<-0;
fn<-1;
fk<-1;
fm<-1;
Mientras c1<n Hacer
c1<- c1+1;

84
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

fn<- fn*c1;
Fin Mientras
Mientras c2<i Hacer
c2<- c2+1;
fk<- fk*c2;
Fin Mientras
m <- n-i;
Mientras c3<m Hacer
c3<- c3+1;
fm<- fm*c3;
Fin Mientras
coef<- fn/(fk*fm);
Escribir sinsaltar " ", coef;
Fin Para
Escribir ""
FinAlgoritmo

85
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

86
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Problema numero 40
Algoritmo formula_s
Escribir "este programa genera la formula de una sucecion aritmetica";
Escribir "digite el primer termino";
leer a;
Escribir "digite la razon de la sucesion";
leer r;
Escribir "la formula del termino enesimo de una sucesion es:";
Escribir "Tn= ",a," + ",r,"*(n-1)"

FinAlgoritmo

87
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Problema numero 41
Algoritmo secesiona
Escribir "Este programa genera los n terminos de una sucecion aritmetica";
Escribir "digite el primer termino";
leer a;
Escribir "digite la razon de la sucesion";
leer r;
Escribir "digite la cantiad de terminos que desea conocer";

88
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

leer m;
k<-1;
t<-0;
Mientras m>(k-1) Hacer
t<-a
t<-t+r*(k-1);
Escribir " El termino ",k," es: ",t;
k<-k+1;

Fin Mientras

FinAlgoritmo

89
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Problema numero 42
Algoritmo suma_reciprocos
Escribir "este programa calcula la suma de los reciprocos de numeros naturales
hasta que supera un numero"
Escribir "digite el numero que debe superar la suma de los reciprocos de los
numeros naturales"
leer n
i<-0

90
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

s<-0
Repetir
i<-i+1
s<-(1/i)+s
Hasta Que s>n
Escribir "fue necesario sumar los primeros ",i," reciprocos de los numeros
naturales para superar ",n
FinAlgoritmo

91
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Problema numero 43
Algoritmo cuadrados_reciprocos
Escribir "este programa calcula la suma de los cuadrados de los numeros
reciprocos"
Escribir "digite un numero que esta suma debe superar"
leer n
i<-0
s<-0
Repetir
i<-i+1
s<-(1/(i*i))+s
Hasta Que s>n
Escribir "fue necesario sumar los primeros ",i," reciprocos de los numeros
naturales para superar ",n
FinAlgoritmo

92
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Problema numero 44
Algoritmo raiz_cuadrada
Escribir "este programa calcula la aproximacion a la raiz cuadrada de un numero
segun cierta cantidad de interacciones"
Escribir "escriba el numero que se le sacara la raiz cuadrada"
leer a
t<-1
x<-0
z<-0

93
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Para j<-1 Hasta 30 Con Paso 1 Hacer


Para i<-1 Hasta j Con Paso 1 Hacer
z<-t
t<-x
x<-(a*(1+z))/(a+z)
z<-raiz(a)
e<-z-x
Fin Para
Escribir "interracciones: ",j," raiz aproximada: ",x," margen de error: ",e
Fin Para

FinAlgoritmo

94
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Problema numero 46
Algoritmo vectores
dimension A[1000],B[1000],C[1000];
Escribir "este programa hace operaciones de vectores"
Escribir " menu";
Escribir "1. suma de vectores,";
Escribir "2. producto punto de vectores,";

95
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Escribir "3. producto cruz de vectores,";


Escribir "digite su opcion";
Leer op;
Segun op Hacer
1:
Escribir "digite la dimenin del vector A";
leer n;
Escribir "digite la dimenin del vector B";
leer n1;
Para i<-1 Hasta n Con Paso 1 Hacer
Escribir "digite la componente ",i," del vector A";
leer A[i];
Fin Para
Para i<-1 Hasta n1 Con Paso 1 Hacer
Escribir "digite la componente ",i," del vector B";
leer B[i];
Fin Para
Si n=n1 Entonces
Para i<-1 Hasta n Con Paso 1 Hacer
C[i]<- A[i]+B[i];
Fin Para
Escribir "La suma es:";
Para i<-1 Hasta n Con Paso 1 Hacer
Escribir Sin Saltar " ", C[i];
Fin Para
Escribir " ";
Sino
Escribir "no se pueden sumar";

96
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Fin Si

2:
Escribir "Producto Punto";
Escribir "digite la dimenin del vector A";
leer n;
Escribir "digite la dimenin del vector B";
leer n1;
Para i<-1 Hasta n Con Paso 1 Hacer
Escribir "digite la componente ",i," del vector A";
leer A[i];
Fin Para
Para i<-1 Hasta n1 Con Paso 1 Hacer
Escribir "digite la componente ",i," del vector B";
leer B[i];
Fin Para
Si n=n1 Entonces
x<-0;
Para i<-1 Hasta n Con Paso 1 Hacer
x<- x+A[i]*B[i];
Fin Para
Escribir "el pruducto punto es:";
Escribir x;
Sino
Escribir "no se pueden realizar el producto punto";
Fin Si
3:
Escribir "Producto Cruz";

97
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Escribir "solo se puede realizar para vectores de 3 dimensiones";


Para i<-1 Hasta 3 Con Paso 1 Hacer
Escribir "digite la componente ",i," del vector A";
leer A[i];
Fin Para
Para i<-1 Hasta 3 Con Paso 1 Hacer
Escribir "digite la componente ",i," del vector B";
leer B[i];
Fin Para
C[1]<- (A[2]*B[3]-A[3]*B[2]);
C[2]<- -(A[1]*B[3]-A[3]*B[1]);
C[3]<- (A[1]*B[2]-A[2]*B[1]);
Escribir "el producto cruz es:"
Escribir C[1]," ",C[2]," ",C[3];

De Otro Modo:
Escribir "su opcion no es valida";
Fin Segun
FinAlgoritmo

Problema numero 47
Algoritmo vector_invertido
Dimension v[1000],t[1000]
Escribir "esste programa invierte las componentes de un vector"
Escribir "digite a dimencion del vector"
leer n
Escribir "digite las componentes del vector"
Para i<-1 Hasta n Con Paso 1 Hacer

98
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

leer v[i]
Fin Para
Para i<-0 Hasta n-1 Con Paso 1 Hacer
t[i+1]<-v[n-i]
Fin Para
Escribir "el vector invertido es:"
Para i<-1 Hasta n Con Paso 1 Hacer
Escribir t[i]
Fin Para
FinAlgoritmo

99
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Problema numero 48
Algoritmo suma_de_matrices
Escribir "estre programa suma dos matrices"
Escribir "digite las dimenciones de la primera matriz, primero el numero de filas
y leugo el numero de columnas"
leer m,n
Escribir "digite las dimenciones de la primera matriz, primero el numero de filas
y leugo el numero de columnas"
Leer p,q

100
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Dimension a[1000,1000],b[1000,1000],c[1000,1000]
Si m=p y n=q Entonces
Escribir "la suma de las matrices si es conformable"
escribir "digite los componentes de la primera matriz"
Para i<-1 Hasta m Con Paso 1 Hacer
Para j<-1 Hasta n Con Paso 1 Hacer
Escribir "digite el componente que se ubica en la fila ",i,"
y columna ",j,"."
leer a[i,j]
Fin Para
Fin Para
escribir "digite los componentes de la segunda matriz"
Para i<-1 Hasta p Con Paso 1 Hacer
Para j<-1 Hasta q Con Paso 1 Hacer
Escribir "digite el componente que se ubica en la fila ",i,"
y columna ",j,"."
leer b[i,j]
Fin Para
Fin Para
Para i<-1 Hasta p Con Paso 1 Hacer
Para j<-1 Hasta q Con Paso 1 Hacer
c[i,j]<-a[i,j]+b[i,j]
Fin Para
Fin Para
Escribir "la suma de las dos matrices es:"
Para i<-1 Hasta p Con Paso 1 Hacer
Para j<-1 Hasta q Con Paso 1 Hacer
escribir c[i,j]
Fin Para

101
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Fin Para
Sino
Escribir "la suma de estas matrices no es conformable"
Fin Si

102
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Problema numero 49
Algoritmo transpuesta_de_matriz
Escribir "este progrma hace la transpuesta de una matriz"
Escribir "digite las dimenciones de la matriz (primero numero de filas, segundo
numero de columnas)"
leer n,m
Dimension a[1000,1000],b[1000,1000]
escribir "digite los componentes de la matriz"
Para i<-1 Hasta n Con Paso 1 Hacer

103
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Para j<-1 Hasta m Con Paso 1 Hacer


Escribir "digite el componente que se ubica en la fila ",i," y
columna ",j,"."
leer a[i,j]
Fin Para
fin para
Para i<-1 Hasta m Con Paso 1 Hacer
Para j<-1 Hasta n Con Paso 1 Hacer
b[i,j]<-a[j,i]
Fin Para
fin para
Para i<-1 Hasta m Con Paso 1 Hacer
Para j<-1 Hasta n Con Paso 1 Hacer
Escribir b[i,j]
Fin Para
Fin Para

FinAlgoritmo

104
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Problema numero 50
Algoritmo Multiplicacion_matrices
Dimension a[100,100], b[100,100], c[100,100];
Escribir "Este programa multiplica dos patrices";
Escribir "Digite las dimension de la primera mariz";
Escribir "digite el numero de filas y luego el numero de columnas de la primera
matriz";
leer f1,c1

105
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Escribir "Digite las dimension de la segunda mariz";


Escribir "digite el numero de filas y luego el numero de columnas de la segunda
matriz";
leer f2,c2
Si ca=fb Entonces
Escribir "la multiplicaciond e las matrices es conformable"
Escribir "digite los terminos de la primera matriz"
Para i<-1 Hasta f1 Con Paso 1 Hacer
Para j<-1 Hasta c1 Con Paso 1 Hacer
Escribir "digite el termino de la fila ",i," y columna ",j;
leer a[i,J];
Fin Para
Fin Para
Escribir "digite los terminos dde la segunda matriz"
Para i<-1 Hasta f2 Con Paso 1 Hacer
Para j<-1 Hasta c2 Con Paso 1 Hacer
Escribir "digite el termino de la fila ",i," y columna ",j;
leer b[i,J];
Fin Para
Fin Para
Para i<-1 Hasta f1 Con Paso 1 Hacer
Para j<-1 Hasta c1 Con Paso 1 Hacer
x<-0;
Para k<-1 Hasta f2 Con Paso 1 Hacer
x<-x+a[i,k]*b[k,j];
c[i,j]<-x;
Fin Para
Fin Para
Fin Para

106
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

Para i<-1 Hasta f1 Con Paso 1 Hacer


Para j<-1 Hasta c2 Con Paso 1 Hacer
Escribir sinsaltar " ", c[i,j];
Fin Para
Escribir " ";
Fin Para
Sino
Escribir "no se puede multiplicar las matrices, no son conformables";
Fin Si

FinAlgoritmo

107
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

108
FACULTAD DE CIENCIA Y TECNOLOGA
DEPARTAMENTO DE MATEMTICAS
LICENCIATURA EN MATEMTICAS
ALGORITMOS
SERGIO DANIEL MUOZ GUALDRON
2016240050

109