Sei sulla pagina 1di 4

Esercizi

 Excel  

L'obiettivo  è  riuscire  a  mettere  in  evidenza  alcuni  risultati  di  test  condizionali,  alcuni  dati  
statistici  utilizzando  le  seguenti  funzioni:  

 
SE,  E,  O,  MEDIA.SE,  CONTA.SE,  SOMMA.SE,  MEDIA    

RICORDA  CHE  L'INTERVALLO  VIENE  CARATTERIZZATO  DALL'OPERATORE  (:)    

SE  VOGLIAMO  FARE  RIFERIMENTO  ALL'INTERVALLO  CHE  VA  DA  A1  SINO  A  A10  ,  PER  
ESEMPIO  PER  CALCOLARE  LA  MEDIA    SARA'  SUFFICIENTE  SCRIVERE    

MEDIA(A1:A10)  

Dato  il  seguente  Schema:  

 
 

1)  stampare  positivo  in  corrispondenza  di  quei  pazienti  che  hanno  valore  X  maggiore  di  0,5  

2)  stampare  superato  in  corrispondenza  di  quei  pazienti  che  hanno  valore  X  minore  di  0,7  e  
peso  maggiore  75.  

3)  contare  il  numero  di  pazienti  che  hanno  età  maggiore  dell'età  media  

4)  contare  il  numero  di  pazienti  che  hanno  valore  X  maggiore  di  0,62  ed  età  maggiore  di  47  

5)  calcolare  la  media  del  peso  dei  pazienti  che  hanno  altezza  maggiore  di  1,75;  

6)  calcolare  la  media  del  valore  X  dei  pazienti  che  hanno  peso  minore  di  82  e  altezza  maggiore  
di  1,72.  

7)  calcolare  la  somma  dei  pesi  dei  pazienti  che  hanno  età  maggiore  di  62  

8)  Stampare  positivo  in  corrispondenza  dei  pazienti  che  hanno  peso  maggiore  del  peso  medio  
del  reparto  

 
svolgimento:  

1)Per  stampare  un  valore  legato  ad  una  condizione  si  può  utilizzare  la  funzione  SE.  Se  le  
condizioni  da  rispettare  sono  più  di  una  allora  utilizziamo  gli  operatori  logici  (E,  O)  per  
indicare  la  contemporane  presenza  di  più  di  una  condizione.  

Il  valore  X  è  presente  nella  colonna  D  

Supponendo  di  voler  stampare  i  risultati  nella  colonna  G  

scrivo:  

G3=SE(D3>0,5;"positivo";"negativo")  

Per  estendere  tale  operazione  fino  all'ultimo  paziente  del  reparto  basta  estendere  con  i  
RIFERIMENTI  RELATIVI  (ripassare  dalle  slide)  

Una  volta  scritta  la  formula  nel  compito,  basta  aggiungere,  come  commento  testuale  che  la  
formula  inserita  in  G3  viene  estesa  fino  a  G8  tramite  i  riferimenti  relativi.  

2)  In  questo  quesito  si  richiede  di  stampare  superato  in  corrispondenza  di  quei  pazienti  che  
superano  una  DOPPIA  condizione  (le  due  condizioni  devono  essere  verificate  
contemporaneamente!):  

H3=SE(E(D3<0,7;G3>75);"superato";"non_superato")  

per  verificare  la  condizione  per  gli  altri  pazienti  estendiamo  con  riferimenti  relativi  fino  a  H8  

A  questo  punto  nella  colonna  da  H3  a  H8  avrò  solo  valori  "superato"  oppure  "non_superato"  

3)  Se  vogliamo  calcolare  l'età  media  prima  dobbiamo  estrarre  i  valori  dell'età  di  ogni  singolo  
paziente.  

I3=2015-­‐C3      Questa  funzione  viene  estesa  per  tutta  la  colonna  fino  a  I8,  in  tal  modo  avrò  una  
colonna  con  tutte  le  età  da  I3  a  I8  

Per  calcolare  l'età  media?    

Scelgo  la  cella  J3  per  indicare  l'età  media  dei  pazienti  in  reparto.  

La  funzione  MEDIA  accetta  come  parametro  un  intervallo!  RICORDA  come  si  descrive  un  
intervallo  sul  foglio  elettronico!  
 
 
J3=MEDIA(I3:I8)  

 A  questo  punto  dello  svolgimento  dell'esercizio  avremo,  nella  cella  J3  un  valore  numerico  
riportante  l'età  media    

Se  voglio  contare  il  numero  di  pazienti  che  hanno  età  maggiore  dell'età  media  del  reparto  
devo  utilizzare  la  funzione  CONTA.SE    

K3=CONTA.SE(I3:I8;  ">J3")  

4)Se  dobbiamo  contare  il  numero  di  pazienti  che  rispettino  alcune  condizioni  è  palese  che  
dobbiamo  utilizzare  CONTA.SE.    Il  problema  legato  all'utilizzo  di  CONTA.SE  è  nel  numero  di  
parametri  che  può  accettare.  CONTA.SE(INTERVALLO;"CRITERIO").    

Il  CRITERIO  è  unico,  quindi  possiamo  esprimere  solo  una  condizione!  

Allora  è  necessario  trasformare  le  due  condizioni  in  un'unica  condizione.  Come  facciamo?  

Per  ridurre  le  due  condizioni  richieste  in  una  sola  condizione  utilizziamo  la  funzione  SE  
coadiuvata  dagli  operatori  logici  E,  O.  

L3=SE(E(D3>0,62;I3>47);"OK";"NO_OK")      RIDUZIONE  DOPPIA  CONDIZIONE  AD  UN  


RISULTATO  

Estediamo  fino  a  L8  per  avere  una  colonna  con  valori    "OK"  o  "NO_OK"  

A  questo  punto  possiamo  utilizzare  la  funzione  CONTA.SE  

M3=CONTA.SE(  L3:L8;"OK")  

5)  Per  il  quesito  è  sufficiente  utilizzare  la  funzione  MEDIA.SE  

Tale  funzione  ha  tre  parametri  di  ingresso  -­‐-­‐>  L'intervallo  su  cui  effettuare  il  test,  il  test,  
l'intervallo  su  cui  va  calcolata  la  media  rispetto  al  test  superato.  

N3=MEDIA.SE(F3:F8;">1,75";E3:E8)          

F3:F8  è  l'intervallo  dove  si  effettua  il  test,  il  test  è  ">1,75",  il  secondo  intervallo  E3:E8  
rappresenta  l'intervallo  dove  calcolare  la  media  rispetto  a  quei  pazienti  che  hanno  superato  il  
TEST.  
 6)  Allo  stesso  modo  del  quesito  numero  4,  anche  qui  abbiamo  una  doppia  condizione  da  
sottoporre  alla  funzione  MEDIA.SE.  Tale  funzione  non  può  accettare  il  doppio  criterio,  quindi  
devo  ridurre  la  doppia  condizione  in  un  unico  risultato!  

Uso  la  funzione  SE  con  l'operatore  logico  E  

O3=SE(E(E3<82;F3>1,72);"OK";"NO_OK")  

estendiamo  fino  a  O8  tale  funzione.  Avremo  quindi  una  colonna  con  valori  OK,  NO_OK  

Adesso  possiamo  utilizzare  la  funzione  MEDIA.SE  perchè  la  condizione  da  esprimere  è  solo  
una,  ossia  essere  uguale  al  valore  OK  

P3=MEDIA.SE(O3:O8;"OK";D3:D8)  

7)  Per  tale  quesito  posso  utilizzare  direttamente  la  funzione  SOMMA.SE  

La  sintassi  è  identica  a  MEDIA.SE  

Q3=SOMMA.SE(INTERVALLO;CRITERIO;INTERVALLO_SOMMA)  

L'intervallo  su  cui  effettuare  il  test  è  l'intervallo  delle  età  dei  pazienti  I3:I8  

mentre  l'intervallo  dei  pesi  è  E3:E8  

Q3=SOMMA.SE(I3:I8;  ">62";  E3:E8)  

8)  Una  volta  che  ho  calcolato  in  N3  il  peso  medio  dei  pazienti  ricoverati  nel  reparto,  posso  
utilizzare  la  funzione  SE  con  i  Riferimenti  RELATIVI.  ATTENZIONE  PERO'  !!!    

R3=SE(E3>N3;"positivo";"negativo")        ERRATA!!!  

R3=SE(E3>$N$3;"positivo";"negativo")    CORRETTA!!!  

Con  l'ultima  versione  posso  estendere  la  funzione  fino  a  R8,  altrimenti  avrei  avuto  un  
errore  comportato  dal  fatto  che  il  trascinamento  della  formula  avrebbe  trascinato  
anche  il  riferimento  a  N3  trasformandolo  di  volta  per  volta  in  N4,  N5,  N6  ...  N8  (che  sono  
celle  vuote).  Con  il  $  blocco  la  cella  e  ho  il  RIFERIMENTO  ASSOLUTO.