Sei sulla pagina 1di 104

UNIVERSIDAD NACIONAL DE INGENIERIA

Palacio Real-España

Enrutamiento Dinámico: RIP y OSPF

FACULTAD DE INGENIERIA ELECTRICA Y ELECTRONICA


Ingeniería de Telecomunicaciones

CURSO: PROTOCOLOS DE
COMUNICACIONES
PROTOCOLO DE ENRUTAMIENTO
DINÁMICO: RIP y OSPF
Propiedad intelectual de Daniel Díaz @ 2011

Maracaná
Brasil

Profesor Daniel Díaz Ataucuri


ddiaz@inictel-uni.edu.pe

ddiaz@inictel-uni.edu.pe
Catedrático Titular a Tiempo Parcial FIEE-UNI
Director de Investigación y Desarrollo
Tecnológico del INICTEL-UNI

Lima, Agosto-Diciembre de 2011


INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF

CONTENIDO
INTRODUCCION AL PROTOCOLO RIP

FORMATO DEL PROTOCOLO RIP

CONFIGURACIÓN DE RIPv1/RIPv2
Propiedad intelectual de Daniel Díaz @ 2011

INTRODUCCIÓN AL PROTOCOLO OSPFv2

FORMATO DEL PROTOCOLO OSPFv2

ddiaz@inictel-uni.edu.pe
CONFIGURACIÓN DE OSPFv2

CONFIGURACIÓN RIPv2/OSPFv2
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF

INTRODUCCIÓN
INTRODUCCIÓN AL
AL
PROTOCOLO
PROTOCOLO RIP
RIP
Propiedad intelectual de Daniel Díaz @ 2011

RFC 1058 Routing Information Protocol, Junio 1988


RFC 1723 RIP version 2, Noviembre 1994

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
CLASIFICACIÓN DE LOS PROTOCOLOS
Propiedad intelectual de Daniel Díaz @ 2011

ddiaz@inictel-uni.edu.pe
Información de CCNA-CISCO

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
INTRODUCCION AL PROTOCOLO RIP
RIP presenta dos versiones: RIPv1 y RIPv2
►RIPv1  Es un protocolo de enrutamiento con clase.
►RIPv2  Es un protocolo de enrutamiento sin clase.

RIP utiliza el algoritmo Vector Distancia.


Propiedad intelectual de Daniel Díaz @ 2011

RIP utiliza como métrica el número de saltos.


►Máximo número de saltos en un trayecto (path) es 15.
Mayores a 15 saltos es inalcanzable.

ddiaz@inictel-uni.edu.pe
RIP difunde su tabla de enrutamiento completa a
cada router vecino en intervalos de 30 segundos
► Dirección MAC=FF FF FF FF FF FF

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
RIPv1 – vs – RIPv2
RIPv1 envía sus actualizaciones en broadcast:
255.255.255.255
RIPv2 envía sus actualizaciones en multicast:
224.0.0.9
RIPv2 permite autenticación: texto plano o
Propiedad intelectual de Daniel Díaz @ 2011

cifrado MD5.
RIPv1 y RIPv2 se encapsulan en UDP.

ddiaz@inictel-uni.edu.pe
►En puerto utilizado es el 520.

RIP
RIPesescapaz
capazdedeequilibrar
equilibrarlas
lascargas
cargashasta
hastaen
enseis
seisrutas
rutasde
de
igual
igualcostos,
costos,siendo
siendocuatro
cuatrorutas
rutaslalacantidad
cantidadpor
pordefecto.
defecto.
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
TEMPORIZACION DEL PROTOCOLO RIP
RIP emplea temporizadores para mejorar su
rendimiento.
►Routing-update timer  Inicialmente 30 seg.
Intervalo entre las actualizaciones de tabla de enrutamiento.
►Route-timeout timer  ó Hold down en 180 seg.
Cada entrada tiene un route-timeout asociado.
Propiedad intelectual de Daniel Díaz @ 2011

Cuando expira, la ruta es señalada como inválida y la métrica se


configura con 16; pero no es borrada de la tabla de enrutamiento.
►Route-flush timer  Inicialmente en 240 seg

ddiaz@inictel-uni.edu.pe
Cuando expira el route-timeout, se borrará la entrada de la
tabla de enrutamiento cuando expira el route-flush timer.

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
ACTUALIZACIONES SINCRONIZADAS
Cuando los routers envían actualizaciones al mismo
tiempo, se puede producir colisiones, retardos y
gran consumo de ancho de banda.
►El envío de actualizaciones al mismo tiempo se denomina
sincronización de actualizaciones.
Propiedad intelectual de Daniel Díaz @ 2011

►RIP puede experimentar problemas ya que envía actualizaciones


periódicas.
Cual es la solución.
►Para evitar la sincronización de actualizaciones, se considera una

ddiaz@inictel-uni.edu.pe
variable RIP_JITTER (usado por el IOS de cisco); cuyo valor
fluctúa entre 0% a 15%.
De este modo el intervalo de actualización varía entre 25 a
30 seg. en lugar de los 30 seg.
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF

FORMATO
FORMATO DEL
DEL
PROTOCOLO
PROTOCOLO
Propiedad intelectual de Daniel Díaz @ 2011

RIP
RIP

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
FORMATO DEL PROTOCOLO RIPv1
RIPv1 Comando: Indica si el paquete
0 8 16 31

Comando Versión 00 00
RIP es de requerimiento o
Address Family
00 00
respuesta.
Identifier

Máximo 25 por
►Requerimiento (1) pregunta a un

paquete RIP
Dirección IP

00 00 00 00
router por el envío total o parcial
de su tabla de enrutamiento.
Propiedad intelectual de Daniel Díaz @ 2011

00 00 00 00

Métrica ►Respuesta (2) puede ser una


Address Family 00 00
actualización de enrutamiento
Dirección IP
no solicitada o en respuesta a

ddiaz@inictel-uni.edu.pe
00 00 00 00
un requerimiento.
00 00 00 00 Version: Indica versión del
Métrica
protocolo RIP. Está en 1.
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
FORMATO DEL PROTOCOLO RIPv1
RIPv1 Address Family Identifier
0 8 16 31

Comando Versión 00 00
AFI.
Address Family
►Especifica la familia de dirección
00 00
Identifier usada. RIP está diseñado para

Máximo 25 por
paquete RIP
Dirección IP
llevar información de enrutamiento
00 00 00 00
de varios tipos de protocolos.
Propiedad intelectual de Daniel Díaz @ 2011

00 00 00 00
►AFI está en 2 para IP.
Métrica

Address Family 00 00 Dirección IP: Indica la


Dirección IP dirección IP de entrada.

ddiaz@inictel-uni.edu.pe
00 00 00 00
Métrica: Indica cuantos
00 00 00 00

Métrica
routers atraviesa RIP.
►El valor está entre 1 a 15.
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
FORMATO DEL PROTOCOLO RIPv2
http://www.rfc-editor.org/rfc/pdfrfc/rfc2453.txt.pdf

Comando: Indica si el paquete 0 RIPv2


8 16 31
RIP es de requerimiento o Comando Versión 00 00
respuesta. Address Family
Route Tag
Identifier

Máximo 25 por
paquete RIP
Version: Indica la versión Dirección IP

Máscara de subred
del protocolo RIP.
Propiedad intelectual de Daniel Díaz @ 2011

Salto siguiente

Address Family Identifier Métrica

AFI. Address Family Route Tag

Dirección IP
►Es similar al RIPv1, con una

ddiaz@inictel-uni.edu.pe
excepción Máscara de subred

►Si el AFI de la primera entrada Salto siguiente

está en FFFFh, el resto de las Métrica

entradas contiene información de autenticación.


INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
FORMATO DEL PROTOCOLO RIPv2
http://www.rfc-editor.org/rfc/pdfrfc/rfc2453.txt.pdf

Route tag: Permite distinguir RIPv2


0 8 16 31
entre rutas internas Comando Versión 00 00
(reconocida por RIP) y rutas Address Family
Route Tag
Identifier
externas (por otros Dirección IP

Protocolos EGP). Máscara de subred


Propiedad intelectual de Daniel Díaz @ 2011

Salto siguiente
Dirección IP: Indica el prefijo Métrica

de red de entrada. Address Family Route Tag

Máscara de Subred: Dirección IP

ddiaz@inictel-uni.edu.pe
Máscara de subred
Contiene la máscara de Salto siguiente
subred de entrada. Métrica

Métrica: Cuantos routers atraviesa RIP.


INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
ENCAPSULAMIENTO
0 8 16 31
DEL PROTOCOLO RIPv2
Ver HLEN ToS Longitud Total

Identificador Indicador/Desplazam.
Protocolo
TTL Suma de Chequeo
11H = 17
Dirección IP de Origen
.
Dirección IP de Destino
Puerto de Origen Puerto de Destino
Propiedad intelectual de Daniel Díaz @ 2011

0208H = 520 0208H = 520


Longitud de Mensaje Suma de Chequeo
Dominio de
Comando Versión
enrutamiento
AFI Route Tag

ddiaz@inictel-uni.edu.pe
Dirección IP

Máscara de subred MAC MAC Tipo


Datos
Destino Origen 0800H
Salto siguiente

Métrica
Trama Ethernet

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
ANALISIS DEL PROTOCOLO RIPv1
Lo0:172.16.15.1/16

S0/1
R1 .42
S0/0
.221 20 Lo1:132.2.4.7/16
.3
.3.
4 0 /3
0
Paquetes RIPv1
Propiedad intelectual de Daniel Díaz @ 2011

S0/0 Fa0/0
40.5.5.28/30
10.2.2.220/30 .41 .29
Red
Red
R3
S0/1
.62

/3 0
.4 . 60
S0/1 .4
.222 30

ddiaz@inictel-uni.edu.pe
S0/0
R2 .61

RIP v1

Lo2:172.32.6.7/16

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
ANALISIS DEL PROTOCOLO RIPv1
0 8 16 31

02 01 00 00

Red 172.16.0.0 Métrica 2


Red 132.2.0.0 Métrica 1 Red 30.0.0.0 Métrica 1
Red 10.0.0.0 Métrica 2

00 02 00 00 00 02 00 00 00 02 00 00

0A 00 00 00 1E 00 00 00 AC 10 00 00

00 00 00 00 00 00 00 00 00 00 00 00

00 00 00 00 00 00 00 00 00 00 00 00
Propiedad intelectual de Daniel Díaz @ 2011

00 00 00 02 00 00 00 01 00 00 00 02

00 02 00 00 00 02 00 00 00 02 00 00
Red 20.0.0.0 Métrica 1

Red 172.32.0.0 Métrica 2


14 00 00 00 84 02 00 00 AC 20 00 00

00 00 00 00 00 00 00 00 00 00 00 00

ddiaz@inictel-uni.edu.pe
00 00 00 00 00 00 00 00 00 00 00 00

00 00 00 01 00 00 00 01 00 00 00 02

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
ANALISIS DEL PROTOCOLO RIPv2
Lo4:201.1.1.5/25

S0/0
.70 R5
/ 30 S0/1
Lo3:210.7.1.8/32 68 .6
.6 . 6.
50
Paquetes RIPv2
Fa0/1
Propiedad intelectual de Daniel Díaz @ 2011

40.5.5.28/30 S0/1
.30 70.8.8.4/30
.69
Red
Red R4
S0/0
.205
60
.7.
7 . 20 S0/0
4/ 3 .5
0

ddiaz@inictel-uni.edu.pe
S0/1 R6
.206
RIP v2

Lo5:192.168.1.9/26

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
ANALISIS DEL PROTOCOLO RIPv2
0 8 16 31

02 02 00 00

Red 201.1.1.0 Métrica 2


Red 50.6.6.68 Métrica 1

Red 70.8.8.4 Métrica 2


00 02 00 00 00 02 00 00 00 02 00 00

32 06 06 44 46 08 08 04 C9 01 01 00

FF FF FF FC FF FF FF FC FF FF FF 80

00 00 00 00 00 00 00 00 00 00 00 00
Propiedad intelectual de Daniel Díaz @ 2011

00 00 00 01 00 00 00 02 00 00 00 02

00 02 00 00 00 02 00 00 00 02 00 00
Red 192.168.1.0 Métrica 2
Red 60.7.7.204 Métrica 1

Red 210.7.1.8 Métrica 1


3C 07 07 CC C0 A8 01 00 D8 07 01 08

FF FF FF FC FF FF FF C0 FF FF FF FF

ddiaz@inictel-uni.edu.pe
00 00 00 00 00 00 00 00 00 00 00 00

00 00 00 01 00 00 00 02 00 00 00 01

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF

CONFIGURACIÓN
CONFIGURACIÓN
DE
DE
Propiedad intelectual de Daniel Díaz @ 2011

RIPv1/RIPv2
RIPv1/RIPv2

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
CONFIGURACION BASICA
Configurar RIPv1:
►Activar el protocolo RIPv1:
router rip
►Anunciar redes:
network <dirección de red>
Propiedad intelectual de Daniel Díaz @ 2011

Configurar RIPv2 en R4
►Activar el protocolo RIPv2:
router rip

ddiaz@inictel-uni.edu.pe
►Especificar la versión 2:
version 2
►Anunciar redes:
network <dirección de red>

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
EJEMPLO DE CONFIGURACIÓN RIPv2
200.1.1.64/26

PC2 .66

Fa2/0
Rb Rc .65
Fa1/0 Fa1/1
0 .2 .5 40.1.2.4/30 .6 .10 40
/ 3 Fa .1.
200.1.1.0/26 2.0 Fa1/1 1/0 2 .8/ 200.1.1.128/26
. 1 . Fa .18 3
40 2 /0 0
Ra Fa .9
40
PC1 .1 a1/0 1/1 Re PC3
Propiedad intelectual de Daniel Díaz @ 2011

. 1.
F Fa2/0
.2 .1 .130
Fa2/0 .13 2 .1 .22
40.1 6 /3 .129
0/30
Fa1 /0
/1 .2 .12/3 0 2.2 Fa1
.
Fa

0 .17 40.1
2/1

Fa1
.14 .21
/0 Fa1/1

ddiaz@inictel-uni.edu.pe
Rd .193
Fa2/0

.194 PC4

200.1.1.192/26
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
EJEMPLO DE CONFIGURACIÓN RIPv2
Tablas de enrutamiento inicial:
►Router Ra

Ra#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
Propiedad intelectual de Daniel Díaz @ 2011

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2


E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

ddiaz@inictel-uni.edu.pe
200.1.1.0/26 is subnetted, 1 subnets
C 200.1.1.0 is directly connected, FastEthernet2/0
40.0.0.0/30 is subnetted, 2 subnets
C 40.1.2.12 is directly connected, FastEthernet1/1
C 40.1.2.0 is directly connected, FastEthernet1/0
Ra#
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
EJEMPLO DE CONFIGURACIÓN RIPv2
Tablas de enrutamiento inicial:
►Router Rb

Rb#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
Propiedad intelectual de Daniel Díaz @ 2011

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2


E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

ddiaz@inictel-uni.edu.pe
40.0.0.0/30 is subnetted, 3 subnets
C 40.1.2.0 is directly connected, FastEthernet1/1
C 40.1.2.4 is directly connected, FastEthernet1/0
C 40.1.2.16 is directly connected, FastEthernet2/0
Rb#

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
EJEMPLO DE CONFIGURACIÓN RIPv2
Tablas de enrutamiento inicial:
►Router Rc

Rc#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
Propiedad intelectual de Daniel Díaz @ 2011

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2


E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

ddiaz@inictel-uni.edu.pe
200.1.1.0/26 is subnetted, 1 subnets
C 200.1.1.64 is directly connected, FastEthernet2/0
40.0.0.0/30 is subnetted, 2 subnets
C 40.1.2.8 is directly connected, FastEthernet1/0
C 40.1.2.4 is directly connected, FastEthernet1/1
Rc#
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
EJEMPLO DE CONFIGURACIÓN RIPv2
Tablas de enrutamiento inicial:
►Router Rd

Rd#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
Propiedad intelectual de Daniel Díaz @ 2011

E1 - OSPF external type 1, E2 - OSPF external type 2


i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

ddiaz@inictel-uni.edu.pe
200.1.1.0/26 is subnetted, 1 subnets
C 200.1.1.192 is directly connected, FastEthernet2/0
40.0.0.0/30 is subnetted, 3 subnets
C 40.1.2.12 is directly connected, FastEthernet1/0
C 40.1.2.16 is directly connected, FastEthernet2/1
C 40.1.2.20 is directly connected, FastEthernet1/1
Rd#
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
EJEMPLO DE CONFIGURACIÓN RIPv2
Tablas de enrutamiento inicial:
►Router Re

Re#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
Propiedad intelectual de Daniel Díaz @ 2011

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2


E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

ddiaz@inictel-uni.edu.pe
200.1.1.0/26 is subnetted, 1 subnets
C 200.1.1.128 is directly connected, FastEthernet2/0
40.0.0.0/30 is subnetted, 2 subnets
C 40.1.2.8 is directly connected, FastEthernet1/1
C 40.1.2.20 is directly connected, FastEthernet1/0
Re#
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
EJEMPLO DE CONFIGURACIÓN RIPv2
Configurando RIPv2: Routers Ra y Rb
Ra>
Ra>
Ra>enable
Ra>enable
Ra#configure
Ra#configure terminal
terminal
Enter
Enter configuration
configuration commands,
commands, one
one per
per line.
line. End
End with
with CNTL/Z.
CNTL/Z.
Ra(config)#router
Ra(config)#router rip
rip
Ra(config-router)#version
Ra(config-router)#version 22
Ra(config-router)#network
Ra(config-router)#network 200.1.1.0
200.1.1.0
Ra(config-router)#network 40.0.0.0
Ra(config-router)#network 40.0.0.0
Ra(config-router)#exit
Propiedad intelectual de Daniel Díaz @ 2011

Ra(config-router)#exit
Ra(config)#
Ra(config)#

Rb>
Rb>
Rb>enable
Rb>enable
Rb#configure
Rb#configure terminal
terminal

ddiaz@inictel-uni.edu.pe
Enter
Enter configuration
configuration commands,
commands, one
one per
per line.
line. End
End with
with CNTL/Z.
CNTL/Z.
Rb(config)#router rip
Rb(config)#router rip
Rb(config-router)#version
Rb(config-router)#version 22
Rb(config-router)#network
Rb(config-router)#network 40.0.0.0
40.0.0.0
Rb(config-router)#exit
Rb(config-router)#exit
Rb(config)#
Rb(config)#

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
EJEMPLO DE CONFIGURACIÓN RIPv2
Configurando RIPv2: Routers Rc y Rd
Rc>
Rc>
Rc>enable
Rc>enable
Rc#configure
Rc#configure terminal
terminal
Enter
Enter configuration
configuration commands,
commands, one
one per
per line.
line. End
End with
with CNTL/Z.
CNTL/Z.
Rc(config)#router
Rc(config)#router rip
rip
Rc(config-router)#version
Rc(config-router)#version 22
Rc(config-router)#network
Rc(config-router)#network 200.1.1.0
200.1.1.0
Rc(config-router)#network 40.0.0.0
Rc(config-router)#network 40.0.0.0
Rc(config-router)#exit
Propiedad intelectual de Daniel Díaz @ 2011

Rc(config-router)#exit
Rc(config)#
Rc(config)#

Rd>
Rd>
Rd>enable
Rd>enable
Rd#configure
Rd#configure terminal
terminal

ddiaz@inictel-uni.edu.pe
Enter
Enter configuration
configuration commands,
commands, one
one per
per line.
line. End
End with
with CNTL/Z.
CNTL/Z.
Rd(config)#router rip
Rd(config)#router rip
Rd(config-router)#version
Rd(config-router)#version 22
Rd(config-router)#network
Rd(config-router)#network 200.1.1.0
200.1.1.0
Rd(config-router)#network
Rd(config-router)#network 40.0.0.0
40.0.0.0
Rd(config-router)#exit
Rd(config-router)#exit
Rd(config)#
Rd(config)#

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
EJEMPLO DE CONFIGURACIÓN RIPv2
Configurando RIPv2: Router Re
Re>
Re>
Re>enable
Re>enable
Re#configure
Re#configure terminal
terminal
Enter
Enter configuration
configuration commands,
commands, one
one per
per line.
line. End
End with
with CNTL/Z.
CNTL/Z.
Re(config)#router
Re(config)#router rip
rip
Re(config-router)#version
Re(config-router)#version 22
Re(config-router)#network
Re(config-router)#network 200.1.1.0
200.1.1.0
Re(config-router)#network 40.0.0.0
Re(config-router)#network 40.0.0.0
Re(config-router)#exit
Propiedad intelectual de Daniel Díaz @ 2011

Re(config-router)#exit
Re(config)#
Re(config)#

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
UN DETALLE: “SUMMARY”
Desde Ra como llega a 200.1.1.64/26
Ra#
Ra# show
show ip ip route
route
Codes:
Codes: C - connected, SS -- static,
C - connected, static, RR -- RIP,
RIP, M M -- mobile,
mobile, BB -- BGP
BGP
DD -- EIGRP,
EIGRP, EX EX -- EIGRP
EIGRP external,
external, O O -- OSPF,
OSPF, IA IA-- OSPF
OSPF inter
inter area
area
N1
N1 -- OSPF
OSPF NSSA
NSSAexternal
external typetype 1,
1, N2
N2 -- OSPF
OSPF NSSA
NSSAexternal
external type
type
22
E1
E1 -- OSPF
OSPF external
external type
type 1, 1, E2
E2 -- OSPF
OSPF external
external type
type 22
ii -- IS-IS,
IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2
su - IS-IS summary, L1 - IS-IS level-1, L2 -- IS-IS
IS-IS level-2
level-2
ia
ia -- IS-IS
IS-IS inter
inter area,
area, ** -- candidate
candidate default,
default, UU -- per-user
per-user static
static route
route
oo -- ODR,
ODR, PP -- periodic
periodic downloaded
downloaded staticstatic route
route
Salto siguiente
40.1.2.14
Propiedad intelectual de Daniel Díaz @ 2011

Gateway
Gateway of
of last
last resort
resort isis not
not set
set

200.1.1.0/24
200.1.1.0/24 isis variably
variably subnetted,
subnetted, 22 subnets,
subnets, 22 masks
masks Aquí se ve a las redes
CC 200.1.1.0/26 is directly connected, FastEthernet2/0
200.1.1.0/26 is directly connected, FastEthernet2/0 200.1.1.64, 200.1.1.128
RR 200.1.1.0/24
200.1.1.0/24 [120/1]
[120/1] via
via 40.1.2.14,
40.1.2.14, 00:00:25,
00:00:25, FastEthernet1/1
FastEthernet1/1 y 200.1.1.192 como si
40.0.0.0/30
40.0.0.0/30 isis subnetted,
subnetted, 66 subnets
subnets fuera la red 200.1.1.0
RR 40.1.2.8
40.1.2.8 [120/2]
[120/2] via
via 40.1.2.14,
40.1.2.14, 00:00:25,
00:00:25, FastEthernet1/1
FastEthernet1/1
[120/2]
[120/2] via
via 40.1.2.2,
40.1.2.2, 00:00:11,
00:00:11, FastEthernet1/0
FastEthernet1/0

ddiaz@inictel-uni.edu.pe
CC 40.1.2.12
40.1.2.12 isis directly
directly connected,
connected, FastEthernet1/1
FastEthernet1/1
CC 40.1.2.0 is directly connected, FastEthernet1/0
40.1.2.0 is directly connected, FastEthernet1/0
RR 40.1.2.4
40.1.2.4 [120/1]
[120/1] via
via 40.1.2.2,
40.1.2.2, 00:00:11,
00:00:11, FastEthernet1/0
FastEthernet1/0
RR 40.1.2.16
40.1.2.16 [120/1] via 40.1.2.14, 00:00:25, FastEthernet1/1
[120/1] via 40.1.2.14, 00:00:25, FastEthernet1/1
[120/1]
[120/1] via
via 40.1.2.2,
40.1.2.2, 00:00:11,
00:00:11, FastEthernet1/0
FastEthernet1/0
RR 40.1.2.20
40.1.2.20 [120/1]
[120/1] via
via 40.1.2.14,
40.1.2.14, 00:00:25,
00:00:25, FastEthernet1/1
FastEthernet1/1 Ra#clear ip route *
Ra#
Ra# Borra la tabla de enrutamiento.

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
UN DETALLE: “SUMMARY”
Desde Rd como llega a 200.1.1.0/26
Rd#show
Rd#show ip ip route
route
Codes:
Codes: C - connected, SS -- static,
C - connected, static, RR -- RIP,
RIP, M M -- mobile,
mobile, BB -- BGP
BGP
DD -- EIGRP,
EIGRP, EX EX -- EIGRP
EIGRP external,
external, O O -- OSPF,
OSPF, IA IA-- OSPF
OSPF inter
inter area
area
N1
N1 -- OSPF
OSPF NSSA
NSSAexternal
external typetype 1,
1, N2
N2 -- OSPF
OSPF NSSA
NSSAexternal
external type
type
22
E1
E1 -- OSPF
OSPF external
external type
type 1, 1, E2
E2 -- OSPF
OSPF external
external type
type 22
ii -- IS-IS,
IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2
su - IS-IS summary, L1 - IS-IS level-1, L2 -- IS-IS
IS-IS level-2
level-2
ia
ia -- IS-IS
IS-IS inter
inter area,
area, ** -- candidate
candidate default,
default, UU -- per-user
per-user static
static route
route
oo -- ODR,
ODR, PP -- periodic
periodic downloaded
downloaded staticstatic route
route
Salto siguiente
40.1.2.13
Propiedad intelectual de Daniel Díaz @ 2011

Gateway
Gateway of
of last
last resort
resort isis not
not set
set

200.1.1.0/24
200.1.1.0/24 isis variably
variably subnetted,
subnetted, 22 subnets,
subnets, 22 masks
masks
CC 200.1.1.192/26 is directly connected, FastEthernet2/0
200.1.1.192/26 is directly connected, FastEthernet2/0
RR 200.1.1.0/24 Aquí se ve a las redes
200.1.1.0/24 [120/1]
[120/1] via
via 40.1.2.22,
40.1.2.22, 00:00:05,
00:00:05, FastEthernet1/1
FastEthernet1/1
[120/1] 200.1.1.0, 200.1.1.64, POSIBL
[120/1] viavia 40.1.2.13,
40.1.2.13, 00:00:10,
00:00:10, FastEthernet1/0
FastEthernet1/0
40.0.0.0/30 y 200.1.1.128 como si
40.0.0.0/30 isis subnetted,
subnetted, 66 subnets
subnets E
RR 40.1.2.8 fuera la red 200.1.1.0
40.1.2.8 [120/1]
[120/1] viavia 40.1.2.22,
40.1.2.22, 00:00:05,
00:00:05, FastEthernet1/1
FastEthernet1/1 BUCLE!!

ddiaz@inictel-uni.edu.pe
CC 40.1.2.12 is directly connected, FastEthernet1/0
40.1.2.12 is directly connected, FastEthernet1/0
RR 40.1.2.0
40.1.2.0 [120/1]
[120/1] viavia 40.1.2.18,
40.1.2.18, 00:00:22,
00:00:22, FastEthernet2/1
FastEthernet2/1
[120/1]
[120/1] viavia 40.1.2.13,
40.1.2.13, 00:00:10,
00:00:10, FastEthernet1/0
FastEthernet1/0
RR 40.1.2.4
40.1.2.4 [120/1]
[120/1] viavia 40.1.2.18,
40.1.2.18, 00:00:22,
00:00:22, FastEthernet2/1
FastEthernet2/1
CC 40.1.2.16
40.1.2.16 isis directly
directly connected,
connected, FastEthernet2/1
FastEthernet2/1
CC 40.1.2.20
40.1.2.20 isis directly
directly connected,
connected, FastEthernet1/1
FastEthernet1/1
Rd#
Rd#

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
SOLUCIÓN: DESACTIVAR “SUMMARY”
Ra>enable
Ra#configure terminal
Enter configuration commands, one per line. End with NTL/Z.
Ra(config)#router rip
Ra(config-router)#no auto-summary
Ra(config-router)#exit Rd>enable
Ra(config)# Rd#configure terminal
Enter configuration commands, one per line. End with NTL/Z.
Rd(config)#router rip
Rd(config-router)#no auto-summary
Rb>enable
Rd(config-router)#exit
Rb#configure terminal
Rd(config)#
Enter configuration commands, one per line. End with NTL/Z.
Propiedad intelectual de Daniel Díaz @ 2011

Rb(config)#router rip
Rb(config-router)#no auto-summary
Rb(config-router)#exit Re>enable
Rb(config)# Re#configure terminal
Enter configuration commands, one per line. End with NTL/Z.
Re(config)#router rip
Re(config-router)#no auto-summary
Rc>enable Re(config-router)#exit

ddiaz@inictel-uni.edu.pe
Rc#configure terminal Re(config)#
Enter configuration commands, one per line. End with NTL/Z.
Rc(config)#router rip
Rc(config-router)#no auto-summary
Rc(config-router)#exit
Rc(config)#

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
ANALIZANDO NUEVAMENTE Ra”
Desde Ra como llega a 200.1.1.64/26
Ra#show
Ra#show ip ip route
route
Codes:
Codes: C - connected, SS -- static,
C - connected, static, RR -- RIP,
RIP, MM -- mobile,
mobile, BB -- BGP
BGP
DD -- EIGRP,
EIGRP, EX EX -- EIGRP
EIGRP external,
external, O O -- OSPF,
OSPF, IAIA-- OSPF
OSPF interinter area
area
N1
N1 -- OSPF
OSPF NSSANSSAexternal
external type
type 1, 1, N2
N2 -- OSPF
OSPF NSSA
NSSAexternal
external type
type 22
E1 - OSPF external type 1, E2 - OSPF
E1 - OSPF external type 1, E2 - OSPF external type 2 external type 2
ii -- IS-IS,
IS-IS, susu -- IS-IS
IS-IS summary,
summary, L1 L1 -- IS-IS
IS-IS level-1,
level-1, L2
L2 -- IS-IS
IS-IS level-2
level-2
ia
ia - IS-IS inter area, * - candidate default, U - per-user static route
- IS-IS inter area, * - candidate default, U - per-user static route
oo -- ODR,
ODR, PP -- periodic
periodic downloaded
downloaded staticstatic route
route

Gateway
Gateway of
of last
last resort
resort isis not
not set
set
Propiedad intelectual de Daniel Díaz @ 2011

200.1.1.0/24
200.1.1.0/24 isis variably
variably subnetted,
subnetted, 55 subnets,
subnets, 22 masks
masks Aquí se ve a las redes
RR 200.1.1.192/26
200.1.1.192/26 [120/1]
[120/1] via
via 40.1.2.14,
40.1.2.14, 00:00:00,
00:00:00, FastEthernet1/1
FastEthernet1/1 200.1.1.64, 200.1.1.128
RR 200.1.1.128/26
200.1.1.128/26 [120/2]
[120/2] via
via 40.1.2.14,
40.1.2.14, 00:00:00,
00:00:00, FastEthernet1/1
FastEthernet1/1 y 200.1.1.192 de manera
RR 200.1.1.64/26
200.1.1.64/26 [120/2]
[120/2] via
via 40.1.2.2,
40.1.2.2, 00:00:10,
00:00:10, FastEthernet1/0
FastEthernet1/0 independiente!!!!.
CC 200.1.1.0/26
200.1.1.0/26 isis directly
directly connected,
connected, FastEthernet2/0
FastEthernet2/0
RR 200.1.1.0/24
200.1.1.0/24 [120/2]
[120/2] via
via 40.1.2.14,
40.1.2.14, 00:00:00,
00:00:00, FastEthernet1/1
FastEthernet1/1
40.0.0.0/30
40.0.0.0/30 isis subnetted,
subnetted, 66 subnets
subnets

ddiaz@inictel-uni.edu.pe
RR 40.1.2.8
40.1.2.8 [120/2]
[120/2] via
via 40.1.2.14,
40.1.2.14, 00:00:00,
00:00:00, FastEthernet1/1
FastEthernet1/1
[120/2] via 40.1.2.2, 00:00:10, FastEthernet1/0
[120/2] via 40.1.2.2, 00:00:10, FastEthernet1/0
CC 40.1.2.12
40.1.2.12 isis directly
directly connected,
connected, FastEthernet1/1
FastEthernet1/1
CC 40.1.2.0 is directly connected, FastEthernet1/0
40.1.2.0 is directly connected, FastEthernet1/0
RR 40.1.2.4
40.1.2.4 [120/1]
[120/1] via
via 40.1.2.2,
40.1.2.2, 00:00:10,
00:00:10, FastEthernet1/0
FastEthernet1/0
RR 40.1.2.16
40.1.2.16 [120/1] via 40.1.2.14, 00:00:00, FastEthernet1/1
[120/1] via 40.1.2.14, 00:00:00, FastEthernet1/1
[120/1] via 40.1.2.2, 00:00:10, FastEthernet1/0
[120/1] via 40.1.2.2, 00:00:10, FastEthernet1/0
RR 40.1.2.20
40.1.2.20 [120/1]
[120/1] via
via 40.1.2.14,
40.1.2.14, 00:00:06,
00:00:06, FastEthernet1/1
FastEthernet1/1
Ra#
Ra#
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
ANALIZANDO TABLAS DE ENRUTAMIENTO
Tabla de enrutamiento del Rb:
Rb#
Rb# show
show ip ip route
route
Codes:
Codes: C - connected, SS -- static,
C - connected, static, RR -- RIP,
RIP, MM -- mobile,
mobile, BB -- BGP
BGP
DD -- EIGRP,
EIGRP, EX EX -- EIGRP
EIGRP external,
external, O O -- OSPF,
OSPF, IAIA-- OSPF
OSPF interinter area
area
N1
N1 -- OSPF
OSPF NSSA
NSSAexternal
external type
type 1, 1, N2
N2 -- OSPF
OSPF NSSA
NSSAexternal
external type
type 22
E1 - OSPF external type 1, E2 - OSPF
E1 - OSPF external type 1, E2 - OSPF external type 2external type 2
ii -- IS-IS,
IS-IS, su
su -- IS-IS
IS-IS summary,
summary, L1 L1 -- IS-IS
IS-IS level-1,
level-1, L2
L2 -- IS-IS
IS-IS level-2
level-2
ia
ia - IS-IS inter area, * - candidate default, U - per-user static route
- IS-IS inter area, * - candidate default, U - per-user static route
oo -- ODR,
ODR, PP -- periodic
periodic downloaded
downloaded staticstatic route
route

Gateway
Gateway of
of last
last resort
resort isis not
not set
set
Propiedad intelectual de Daniel Díaz @ 2011

200.1.1.0/26
200.1.1.0/26 isis subnetted,
subnetted, 44 subnets
subnets
RR 200.1.1.192
200.1.1.192 [120/1]
[120/1] via
via 40.1.2.17,
40.1.2.17, 00:00:14,
00:00:14, FastEthernet2/0
FastEthernet2/0 La redes LAN están
RR 200.1.1.128 [120/2] via 40.1.2.17, 00:00:14, FastEthernet2/0
200.1.1.128 [120/2] via 40.1.2.17, 00:00:14, FastEthernet2/0 detalladas.
[120/2]
[120/2] viavia 40.1.2.6,
40.1.2.6, 00:00:10,
00:00:10, FastEthernet1/0
FastEthernet1/0 Se observa el balanceo de
RR 200.1.1.64
200.1.1.64 [120/1]
[120/1] via
via 40.1.2.6,
40.1.2.6, 00:00:10,
00:00:10, FastEthernet1/0
FastEthernet1/0 carga hacia: 200.1.1.128
RR 200.1.1.0 [120/1] via 40.1.2.1, 00:00:12, FastEthernet1/1
200.1.1.0 [120/1] via 40.1.2.1, 00:00:12, FastEthernet1/1
40.0.0.0/30
40.0.0.0/30 isis subnetted,
subnetted, 66 subnets
subnets

ddiaz@inictel-uni.edu.pe
RR 40.1.2.8
40.1.2.8 [120/1] via 40.1.2.6, 00:00:10,
[120/1] via 40.1.2.6, 00:00:10, FastEthernet1/0
FastEthernet1/0
RR 40.1.2.12
40.1.2.12 [120/1] via 40.1.2.17, 00:00:14, FastEthernet2/0
[120/1] via 40.1.2.17, 00:00:14, FastEthernet2/0
[120/1]
[120/1] via via 40.1.2.1,
40.1.2.1, 00:00:12,
00:00:12, FastEthernet1/1
FastEthernet1/1
CC 40.1.2.0
40.1.2.0 isis directly
directly connected,
connected, FastEthernet1/1
FastEthernet1/1
CC 40.1.2.4
40.1.2.4 isis directly
directly connected,
connected, FastEthernet1/0
FastEthernet1/0
CC 40.1.2.16
40.1.2.16 is directly connected, FastEthernet2/0
is directly connected, FastEthernet2/0
RR 40.1.2.20
40.1.2.20 [120/1] via 40.1.2.17, 00:00:17, FastEthernet2/0
[120/1] via 40.1.2.17, 00:00:17, FastEthernet2/0
Rb#
Rb#

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
ANALIZANDO TABLAS DE ENRUTAMIENTO
Tabla de enrutamiento del Rc:
Rc#show
Rc#show ip ip route
route
Codes:
Codes: C - connected, SS -- static,
C - connected, static, RR -- RIP,
RIP, MM -- mobile,
mobile, BB -- BGP
BGP
DD -- EIGRP,
EIGRP, EX EX -- EIGRP
EIGRP external,
external, O O -- OSPF,
OSPF, IAIA-- OSPF
OSPF interinter area
area
N1
N1 -- OSPF
OSPF NSSANSSAexternal
external type
type 1, 1, N2
N2 -- OSPF
OSPF NSSA
NSSAexternal
external type
type 22
E1 - OSPF external type 1, E2 - OSPF
E1 - OSPF external type 1, E2 - OSPF external type 2 external type 2
ii -- IS-IS,
IS-IS, susu -- IS-IS
IS-IS summary,
summary, L1 L1 -- IS-IS
IS-IS level-1,
level-1, L2
L2 -- IS-IS
IS-IS level-2
level-2
ia
ia - IS-IS inter area, * - candidate default, U - per-user static route
- IS-IS inter area, * - candidate default, U - per-user static route
oo -- ODR,
ODR, PP -- periodic
periodic downloaded
downloaded staticstatic route
route

Gateway
Gateway of
of last
last resort
resort isis not
not set
set
Propiedad intelectual de Daniel Díaz @ 2011

200.1.1.0/26
200.1.1.0/26 isis subnetted,
subnetted, 44 subnets
subnets
RR 200.1.1.192
200.1.1.192 [120/2]
[120/2] via
via 40.1.2.9,
40.1.2.9, 00:00:12,
00:00:12, FastEthernet1/0
FastEthernet1/0 La redes LAN están
[120/2] via 40.1.2.5, 00:00:24, FastEthernet1/1
[120/2] via 40.1.2.5, 00:00:24, FastEthernet1/1 detalladas.
RR 200.1.1.128
200.1.1.128 [120/1]
[120/1] via
via 40.1.2.9,
40.1.2.9, 00:00:12,
00:00:12, FastEthernet1/0
FastEthernet1/0 Se observa el balanceo de
CC 200.1.1.64
200.1.1.64 isis directly
directly connected,
connected, FastEthernet2/0
FastEthernet2/0 carga hacia: 200.1.1.192
RR 200.1.1.0
200.1.1.0 [120/2]
[120/2] via
via 40.1.2.5,
40.1.2.5, 00:00:24,
00:00:24, FastEthernet1/1
FastEthernet1/1
40.0.0.0/30
40.0.0.0/30 isis subnetted,
subnetted, 66 subnets
subnets

ddiaz@inictel-uni.edu.pe
CC 40.1.2.8
40.1.2.8 isis directly
directly connected,
connected, FastEthernet1/0
FastEthernet1/0
RR 40.1.2.12
40.1.2.12 [120/2] via 40.1.2.9, 00:00:12, FastEthernet1/0
[120/2] via 40.1.2.9, 00:00:12, FastEthernet1/0
[120/2]
[120/2] viavia 40.1.2.5,
40.1.2.5, 00:00:24,
00:00:24, FastEthernet1/1
FastEthernet1/1
RR 40.1.2.0
40.1.2.0 [120/1]
[120/1] viavia 40.1.2.5,
40.1.2.5, 00:00:24,
00:00:24, FastEthernet1/1
FastEthernet1/1
CC 40.1.2.4
40.1.2.4 isis directly
directly connected,
connected, FastEthernet1/1
FastEthernet1/1
RR 40.1.2.16
40.1.2.16 [120/1]
[120/1] via
via 40.1.2.5,
40.1.2.5, 00:00:24,
00:00:24, FastEthernet1/1
FastEthernet1/1
RR 40.1.2.20 [120/1] via 40.1.2.9, 00:00:13, FastEthernet1/0
40.1.2.20 [120/1] via 40.1.2.9, 00:00:13, FastEthernet1/0
Rc#
Rc#

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
ANALIZANDO TABLAS DE ENRUTAMIENTO
Tabla de enrutamiento del Rd:
Rd#show
Rd#show ip ip route
route
Codes:
Codes: C - connected, SS -- static,
C - connected, static, RR -- RIP,
RIP, MM -- mobile,
mobile, BB -- BGP
BGP
DD -- EIGRP,
EIGRP, EX EX -- EIGRP
EIGRP external,
external, O O -- OSPF,
OSPF, IAIA-- OSPF
OSPF interinter area
area
N1
N1 -- OSPF
OSPF NSSANSSAexternal
external type
type 1, 1, N2
N2 -- OSPF
OSPF NSSA
NSSAexternal
external type
type 22
E1 - OSPF external type 1, E2 - OSPF
E1 - OSPF external type 1, E2 - OSPF external type 2 external type 2
ii -- IS-IS,
IS-IS, susu -- IS-IS
IS-IS summary,
summary, L1 L1 -- IS-IS
IS-IS level-1,
level-1, L2
L2 -- IS-IS
IS-IS level-2
level-2
ia
ia - IS-IS inter area, * - candidate default, U - per-user static route
- IS-IS inter area, * - candidate default, U - per-user static route
oo -- ODR,
ODR, PP -- periodic
periodic downloaded
downloaded staticstatic route
route

Gateway
Gateway of
of last
last resort
resort isis not
not set
set
Propiedad intelectual de Daniel Díaz @ 2011

200.1.1.0/26
200.1.1.0/26 isis subnetted,
subnetted, 44 subnets
subnets
CC 200.1.1.192
200.1.1.192 isis directly
directly connected,
connected, FastEthernet2/0
FastEthernet2/0
RR 200.1.1.128
200.1.1.128 [120/1] via 40.1.2.22, 00:00:00, FastEthernet1/1
[120/1] via 40.1.2.22, 00:00:00, FastEthernet1/1 La redes LAN están
RR 200.1.1.64 [120/2] via 40.1.2.22, 00:00:00, FastEthernet1/1
200.1.1.64 [120/2] via 40.1.2.22, 00:00:00, FastEthernet1/1 detalladas.
[120/2]
[120/2] via
via 40.1.2.18,
40.1.2.18, 00:00:00,
00:00:00, FastEthernet2/1
FastEthernet2/1 Se observa el balanceo de
RR 200.1.1.0
200.1.1.0 [120/1] via 40.1.2.13, 00:00:24, FastEthernet1/0
[120/1] via 40.1.2.13, 00:00:24, FastEthernet1/0 carga hacia: 200.1.1.64
40.0.0.0/30
40.0.0.0/30 isis subnetted,
subnetted, 66 subnets
subnets

ddiaz@inictel-uni.edu.pe
RR 40.1.2.8
40.1.2.8 [120/1]
[120/1] via
via 40.1.2.22,
40.1.2.22, 00:00:00,
00:00:00, FastEthernet1/1
FastEthernet1/1
CC 40.1.2.12 is directly connected, FastEthernet1/0
40.1.2.12 is directly connected, FastEthernet1/0
RR 40.1.2.0
40.1.2.0 [120/1]
[120/1] via
via 40.1.2.18,
40.1.2.18, 00:00:00,
00:00:00, FastEthernet2/1
FastEthernet2/1
[120/1] via 40.1.2.13, 00:00:24, FastEthernet1/0
[120/1] via 40.1.2.13, 00:00:24, FastEthernet1/0
RR 40.1.2.4
40.1.2.4 [120/1]
[120/1] via
via 40.1.2.18,
40.1.2.18, 00:00:00,
00:00:00, FastEthernet2/1
FastEthernet2/1
CC 40.1.2.16 is directly connected, FastEthernet2/1
40.1.2.16 is directly connected, FastEthernet2/1
CC 40.1.2.20
40.1.2.20 isis directly
directly connected,
connected, FastEthernet1/1
FastEthernet1/1
Rd#
Rd#

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
ANALIZANDO TABLAS DE ENRUTAMIENTO
Tabla de enrutamiento del Re:
Re#show
Re#show ip ip route
route
Codes:
Codes: C - connected, SS -- static,
C - connected, static, RR -- RIP,
RIP, MM -- mobile,
mobile, BB -- BGP
BGP
DD -- EIGRP,
EIGRP, EX EX -- EIGRP
EIGRP external,
external, O O -- OSPF,
OSPF, IAIA-- OSPF
OSPF interinter area
area
N1
N1 -- OSPF
OSPF NSSA
NSSAexternal
external type
type 1, 1, N2
N2 -- OSPF
OSPF NSSA
NSSAexternal
external type
type 22
E1 - OSPF external type 1, E2 - OSPF
E1 - OSPF external type 1, E2 - OSPF external type 2external type 2
ii -- IS-IS,
IS-IS, su
su -- IS-IS
IS-IS summary,
summary, L1 L1 -- IS-IS
IS-IS level-1,
level-1, L2
L2 -- IS-IS
IS-IS level-2
level-2
ia
ia - IS-IS inter area, * - candidate default, U - per-user static route
- IS-IS inter area, * - candidate default, U - per-user static route
oo -- ODR,
ODR, PP -- periodic
periodic downloaded
downloaded staticstatic route
route

Gateway
Gateway of
of last
last resort
resort isis not
not set
set
Propiedad intelectual de Daniel Díaz @ 2011

200.1.1.0/26
200.1.1.0/26 isis subnetted,
subnetted, 44 subnets
subnets
RR 200.1.1.192
200.1.1.192 [120/1]
[120/1] via
via 40.1.2.21,
40.1.2.21, 00:00:22,
00:00:22, FastEthernet1/0
FastEthernet1/0
CC 200.1.1.128 is directly connected, FastEthernet2/0
200.1.1.128 is directly connected, FastEthernet2/0 La redes LAN están
RR 200.1.1.64
200.1.1.64 [120/1]
[120/1] via
via 40.1.2.10,
40.1.2.10, 00:00:27,
00:00:27, FastEthernet1/1
FastEthernet1/1 detalladas.
RR 200.1.1.0
200.1.1.0 [120/2]
[120/2] via
via 40.1.2.21,
40.1.2.21, 00:00:22,
00:00:22, FastEthernet1/0
FastEthernet1/0
40.0.0.0/30
40.0.0.0/30 isis subnetted,
subnetted, 66 subnets
subnets
CC 40.1.2.8
40.1.2.8 isis directly
directly connected,
connected, FastEthernet1/1
FastEthernet1/1

ddiaz@inictel-uni.edu.pe
RR 40.1.2.12
40.1.2.12 [120/1] via 40.1.2.21, 00:00:22,
[120/1] via 40.1.2.21, 00:00:22, FastEthernet1/0
FastEthernet1/0
RR 40.1.2.0 [120/2] via 40.1.2.21, 00:00:22, FastEthernet1/0
40.1.2.0 [120/2] via 40.1.2.21, 00:00:22, FastEthernet1/0
[120/2]
[120/2] viavia 40.1.2.10,
40.1.2.10, 00:00:27,
00:00:27, FastEthernet1/1
FastEthernet1/1
RR 40.1.2.4
40.1.2.4 [120/1] via 40.1.2.10, 00:00:27, FastEthernet1/1
[120/1] via 40.1.2.10, 00:00:27, FastEthernet1/1
RR 40.1.2.16
40.1.2.16 [120/1]
[120/1] via
via 40.1.2.21,
40.1.2.21, 00:00:22,
00:00:22, FastEthernet1/0
FastEthernet1/0
CC 40.1.2.20 is directly connected, FastEthernet1/0
40.1.2.20 is directly connected, FastEthernet1/0
Re#
Re#

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
COMANDOS DE ANÁLISIS DE RED CON RIP
show ip protocols
►Muestra el protocolo de
enrutamiento configurado.
Propiedad intelectual de Daniel Díaz @ 2011

►Si es RIP, permite


Auto resumen desactivado
ver la mayoría de

ddiaz@inictel-uni.edu.pe
sus parámetros
(temporizadores,
etc).

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
INTERFAZ PASIVA
Envío
Servidor
Se debe anunciar la red 200.1.1.4/24
actualizaciones?

200.1.1.0 donde está el S0/0


Fa0/0
.1

servidor, para que sea .221 R1


S0/1
.42 20
. 3.
accedido externamente. 3. 4
0/
30 S0/0

22.2.2.220/30
.41

No se debe enviar al servidor R3


Propiedad intelectual de Daniel Díaz @ 2011

S0/1
actualizaciones. Para que?? 4.6
0/ 3
0 .62

S0/0 0.4.
R1(config)# router rip S0/1
.61 3

R1(config-router)# version 2 .222 R2

R1(config-router)# network 200.1.1.0

ddiaz@inictel-uni.edu.pe
R1(config-router)# network 22.2.2.220
R1(config-router)# network 20.3.3.40
R1(config-router)# passive-interface fastethernet 0/0
R1(config-router)# exit
R1#debug ip rip ; permite ver
R1(config)#
actualizaciones según se genere.
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
PROPAGACIÓN DE RUTA POR DEFECTO
200.2.2.0/24 R1 50.5.5.0/30 R2
.9
.2 .1 .1 .2 50.5.8.0/30
PC1 210.10.10.0/24
.10 60.6.6.0/30
.1 .2 .1 .2
.0 /30.13
PC2 .5.12 R5 R6 PC3
5 0
.2 .1 .5 .6
.14
200.2.3.0/24 R3 50.5.5.4/30 R4
Propiedad intelectual de Daniel Díaz @ 2011

R5#show ip route
R4#show
R5#show
R4#show
R3#showip
ip route
ip route
route
ip
R3#show
50.0.0.0/30 is
R2#show
R2#show iproute
R1#show route
subnetted,ip
ip route
route
ip4 route
subnets
50.0.0.0/30
50.0.0.0/30
50.0.0.0/30
50.0.0.0/30 isissubnetted,
isR1#show
subnetted,
subnetted,
is ip
subnetted, 44subnets
4route
subnets
subnets
44subnets
R 50.0.0.0/30
50.5.5.0 [120/1]
50.0.0.0/30
50.0.0.0/30 is
via
50.0.0.0/30 subnetted,
50.5.5.9,
is
is subnetted,
subnetted,
is subnets
00:00:01,
subnetted, FastEthernet0/1
4400:00:22,
subnets
subnets
4 subnets
R 50.5.5.0
R R 50.5.5.0
RR 50.5.5.0
50.5.5.0 [120/2]
[120/1][120/2] via
50.0.0.0/30
[120/3] via 50.5.5.13,
50.5.5.9,
is
viadirectly
via 00:00:01,
subnetted,
50.5.5.13,
50.5.5.6, 4 FastEthernet0/1
FastEthernet0/1
subnets
00:00:22,
00:00:09, FastEthernet0/1
FastEthernet0/1
R 50.5.5.4
C
C 50.5.5.0
[120/1]
C 50.5.5.0
50.5.5.0 [120/3]
via
50.5.5.0 is
is via
50.5.5.14,
directly
is 50.5.5.6,
00:00:24,
connected,
connected,
directly 00:00:09,
connected, FastEthernet0/1
FastEthernet0/0
FastEthernet0/0
FastEthernet0/0
FastEthernet0/1
R CC 50.5.5.4
50.5.5.4
50.5.5.4
CC R50.5.5.4 is
[120/1]
C is directly
via
50.5.5.0
directly
isisdirectly connected,
50.5.5.14,
is directly
connected,
connected, FastEthernet0/0
00:00:24, FastEthernet0/0
connected,
FastEthernet0/0 FastEthernet0/1
FastEthernet0/1
C 50.5.5.8
R 50.5.5.4
is Rdirectly
50.5.5.4
50.5.5.4 directly
connected,
50.5.5.4 [120/2]
[120/2] connected,
[120/3]via
via 50.5.5.10,
via FastEthernet0/1
FastEthernet0/1
50.5.5.10, 00:00:06,
00:00:06,
50.5.5.2, FastEthernet0/1
FastEthernet0/1
00:00:11, FastEthernet0/1
C RR 50.5.5.8
R 50.5.5.8is
50.5.5.8 R
50.5.5.8 [120/1]
directly
[120/1]
[120/2] via
via 50.5.5.13,
connected,
50.5.5.4 [120/3]
50.5.5.13,
via 50.5.5.6, 00:00:22,
FastEthernet0/1
via 50.5.5.2,
00:00:22,
00:00:09,FastEthernet0/1
00:00:11, FastEthernet0/1
FastEthernet0/1
FastEthernet0/1
C R C
50.5.5.12 50.5.5.8
is directly
50.5.5.8 [120/2] via
connected,
is directly 50.5.5.6, 00:00:09,
FastEthernet0/0
connected, FastEthernet0/1
FastEthernet0/1

ddiaz@inictel-uni.edu.pe
C
C CC 50.5.5.12
RR50.5.5.12
50.5.5.12Ris50.5.5.8
R directly
50.5.5.12 50.5.5.8
isisdirectly
50.5.5.8
directly is
[120/1] directly
[120/1]
connected,
connected,
[120/1]
connected,
via connected,
via FastEthernet0/1
50.5.5.2,
FastEthernet0/0
via
50.5.5.6, 50.5.5.2, 00:00:11,
FastEthernet0/100:00:11,
FastEthernet0/1
00:00:09, FastEthernet0/1
FastEthernet0/1
FastEthernet0/1
R
R 50.5.5.12
R 210.10.10.0/24 R [120/1]
50.5.5.12
50.5.5.12 [120/1]
50.5.5.12 via
[120/1]via
60.6.6.2,
[120/1] 50.5.5.6,
via
via
[120/2] 00:00:09,
00:00:08,
50.5.5.10,
50.5.5.10,
via FastEthernet0/1
FastEthernet1/0
00:00:06,
00:00:06,
50.5.5.2, 00:00:11,FastEthernet0/1
FastEthernet0/1
FastEthernet0/1
R RR210.10.10.0/24
210.10.10.0/24
R R [120/1]
210.10.10.0/24
210.10.10.0/24 [120/2]
50.5.5.12
[120/2] viavia
[120/3] via 50.5.5.13,
60.6.6.2,
[120/2]
50.5.5.13,
via 50.5.5.6, 00:00:22,
00:00:08,
via 50.5.5.2,
00:00:22, FastEthernet0/1
FastEthernet1/0
00:00:11,
00:00:09, FastEthernet0/1
FastEthernet0/1
FastEthernet0/1
R R
R210.10.10.0/24
R 200.2.2.0/24 [120/2]
210.10.10.0/24
210.10.10.0/24
R via
210.10.10.0/24 [120/3]
50.5.5.9,
[120/2]
[120/2] via 50.5.5.6,
00:00:01,
via
via
[120/3] 00:00:09,
50.5.5.10,
50.5.5.10,
via FastEthernet0/1
FastEthernet0/1
00:00:06,
00:00:06,
50.5.5.2, FastEthernet0/1
FastEthernet0/1
00:00:11, FastEthernet0/1
R RR200.2.2.0/24
200.2.2.0/24
200.2.2.0/24R
RR 200.2.2.0/24 [120/3]
[120/2][120/3] via
210.10.10.0/24
[120/4] via
via 50.5.5.13,
50.5.5.9,
50.5.5.13,
via 50.5.5.6, 00:00:22,
00:00:01,
[120/3] via FastEthernet0/1
FastEthernet0/1
50.5.5.2,
00:00:22,
00:00:09, 00:00:11,
FastEthernet0/1FastEthernet0/1
FastEthernet0/1
R200.2.2.0/24
R 200.2.3.0/24 [120/2]
200.2.2.0/24
R 200.2.2.0/24
CC[120/2] [120/4]
via
200.2.2.0/24 [120/1]via
50.5.5.14,
[120/1] 50.5.5.6,
00:00:24,
via 50.5.5.1,
via 00:00:24,
50.5.5.1,
isisconnected,
directly 00:00:09, FastEthernet0/1
FastEthernet0/0
00:00:14,
00:00:14,
connected, FastEthernet0/0
FastEthernet0/0
FastEthernet0/0
R RR200.2.3.0/24
200.2.3.0/24
C200.2.3.0/24
200.2.3.0/24 [120/1]isisvia
200.2.2.0/24
[120/1] via
via
directly 50.5.5.5,
50.5.5.14, directly
50.5.5.5, 00:00:17, FastEthernet0/0
FastEthernet0/0
connected,
00:00:17, FastEthernet0/0
FastEthernet0/0
FastEthernet0/0
C
60.0.0.0/30
R200.2.3.0/24
is
R is subnetted,
200.2.3.0/24
200.2.3.0/24 1directly
subnets
[120/3] connected,
via 50.5.5.10,FastEthernet0/0
00:00:06, FastEthernet0/1
RR 60.0.0.0/8
60.0.0.0/30
R60.0.0.0/8 RRsubnetted,
60.0.0.0/8 200.2.3.0/24
[120/1] via
200.2.3.0/24
[120/1]
[120/2] via1[120/3][120/4]
50.5.5.13,
subnets via 00:00:22,
[120/4]
50.5.5.13,
via 50.5.5.6, 50.5.5.10,
via
via 00:00:06,
50.5.5.2,
50.5.5.2,
00:00:22,
00:00:09, FastEthernet0/1
00:00:11,
FastEthernet0/1
00:00:11,
FastEthernet0/1FastEthernet0/1
FastEthernet0/1
FastEthernet0/1
C R R
60.6.6.0
R60.0.0.0/8
is directly
60.0.0.0/8
60.0.0.0/8 [120/2]
connected,
[120/1]
[120/1]via 50.5.5.6,
via
via 00:00:09,
FastEthernet1/0
50.5.5.10,
50.5.5.10, FastEthernet0/1
00:00:06,
00:00:06, FastEthernet0/1
FastEthernet0/1
C R4#60.6.6.0 isRRdirectly60.0.0.0/8
60.0.0.0/8 [120/2]
connected,[120/2] via
via50.5.5.2,
50.5.5.2,00:00:11,
FastEthernet1/0 00:00:11,FastEthernet0/1
FastEthernet0/1
R5# R4#R3#
R3#R2#
R2# R1#
R5# R1#
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
PROPAGACIÓN DE RUTA POR DEFECTO
200.2.2.0/24 R1 50.5.5.0/30 R2
.9
.2 .1 .1 .2 50.5.8.0/30
PC1 210.10.10.0/24
RIP .10 60.6.6.0/30
.1 .2 .1 .2
.0 /30.13
PC2 5 .12 R5 R6 PC3
.2 .1 .5 .6 50.
.14
200.2.3.0/24 R3 50.5.5.4/30 R4
Propiedad intelectual de Daniel Díaz @ 2011

Redes

ddiaz@inictel-uni.edu.pe
anunciadas

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
PROPAGACIÓN DE RUTA POR DEFECTO
default-information originate
►Permite que el router propague la ruta estática por defecto, en las
actualizaciones RIP.
200.2.2.0/24
R1 50.5.5.0/30 R2
.9
.2 .1 .1 .2 50.5.8.0/30 210.10.10.0/24
Propiedad intelectual de Daniel Díaz @ 2011

PC1
.10 60.6.6.0/30
.1 .2 .1 .2
.0/30
12 .13
.5 . R5 R6 PC3
50
.2 .1 .5 .6

ddiaz@inictel-uni.edu.pe
.14
200.2.3.0/24 R3 50.5.5.4/30 R4
PC2
R5#configure terminal
R5(config)#router rip
R5(config-router)#default-information originate
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
PROPAGACIÓN DE RUTA POR DEFECTO
200.2.2.0/24 R1 50.5.5.0/30 R2
.9
.2 .1 .1 .2 50.5.8.0/30
PC1 210.10.10.0/24
.10 60.6.6.0/30
.1 .2 .1 .2
.0 /30.13
PC2 .5.1
2 R5 R6 PC3
.2 .1 .5 .6 50
Desde RI, R2, R3, R4 y R6 se podrá ir a cualquier
.14 red, debido que sus tablas tiene la red 0.0.0.0
200.2.3.0/24 R3 50.5.5.4/30 R4
Propiedad intelectual de Daniel Díaz @ 2011

R2#show
R2#show
R1#showip
iproute
route
R4#showip
R1#show
R4#show iproute
R3#show
R3#show
ipiproute
route route
ip
iproute
route
50.0.0.0/30
50.0.0.0/30 is
is
50.0.0.0/30 subnetted,
subnetted,
50.0.0.0/30is subnetted,
is 44subnets
R6#show
subnets
subnetted,4R6#show ip route
50.0.0.0/30
50.0.0.0/30 is
50.0.0.0/30subnetted,
50.0.0.0/30 is subnetted,
isis 4subnets
44subnets
subnets
subnetted,
subnetted, ip
subnets
44 route
subnets
subnets
CC C50.5.5.0 is directly connected, FastEthernet0/0
C50.5.5.0 R R
is
RR50.5.5.0
50.5.5.0 directly
50.5.5.0
isis
50.5.5.0 directly
50.5.5.0 connected,
[120/2]
directly
[120/2]
50.5.5.0
connected,
via
connected,
[120/3]
[120/3]
FastEthernet0/0
via50.5.5.13,
FastEthernet0/1
50.5.5.13,
via
via
00:00:02,
FastEthernet0/1
50.5.5.6,00:00:02,
50.5.5.6, 00:00:00,FastEthernet0/1
00:00:00,FastEthernet0/1
FastEthernet0/1
FastEthernet0/1
RR R50.5.5.4 [120/2] via 50.5.5.10,R 00:00:05,
50.0.0.0/8 FastEthernet0/1
[120/1] via 60.6.6.1, 00:00:04,
50.5.5.4
C
R C50.5.5.4
C C
[120/2]
50.5.5.4
50.5.5.4
[120/3]
50.5.5.4
[120/3]via
is
50.5.5.4is
50.5.5.4
50.5.5.10,
directly
via 50.5.5.2,
directly
via
is
is R
50.5.5.2,00:00:05,
connected,
00:00:24,
50.0.0.0/8
connected,
directly
directly 00:00:24,
connected, FastEthernet0/1
FastEthernet0/0
FastEthernet0/1
[120/1]
FastEthernet0/0
connected, via 60.6.6.1,
FastEthernet0/1
FastEthernet0/1
FastEthernet0/1 00:00:04,FastEthernet0/1
FastEthernet0/1
CC R50.5.5.8 is directly connected, C FastEthernet0/1
210.10.10.0/24 is directly connected, FastEthernet0/0
R50.5.5.8 R
is
RR50.5.5.8
50.5.5.8 directly
R50.5.5.8
[120/1]
50.5.5.8
[120/1]
50.5.5.8 connected,
[120/1]via
[120/1]
50.5.5.8 via 50.5.5.2,
via FastEthernet0/1
C 50.5.5.13,
50.5.5.2,
via
[120/2]
[120/2]
00:00:24,
50.5.5.13,
via
via
00:00:02,
210.10.10.0/24
00:00:24,
50.5.5.6, FastEthernet0/1
00:00:02,
50.5.5.6,
FastEthernet0/1
is directly
FastEthernet0/1
00:00:00,
00:00:00, connected, FastEthernet0/0
FastEthernet0/1
FastEthernet0/1
FastEthernet0/1
RR R50.5.5.12 [120/1] via 50.5.5.10,
R 00:00:05,
200.2.2.0/24 FastEthernet0/1
[120/3] via 60.6.6.1,
60.6.6.1,00:00:04,
00:00:04,FastEthernet0/1

ddiaz@inictel-uni.edu.pe
R50.5.5.12
CC50.5.5.12
R R
[120/1]
50.5.5.12
50.5.5.12
50.5.5.12[120/2]
[120/2]
50.5.5.12via
50.5.5.12
50.5.5.10,
isisdirectly
via 50.5.5.2,
directly
via 00:00:05,
R connected,
50.5.5.2,
[120/1]
[120/1]
00:00:24,
200.2.2.0/24
connected,
via
via 00:00:24,
50.5.5.6, FastEthernet0/1
FastEthernet0/1
FastEthernet0/1
[120/3]
FastEthernet0/1
50.5.5.6, viaFastEthernet0/1
FastEthernet0/1
00:00:00,
00:00:00, FastEthernet0/1 FastEthernet0/1
RR 210.10.10.0/24 [120/2] via 50.5.5.10,
Rvia 00:00:05,
200.2.3.0/24 FastEthernet0/1
[120/3] via 60.6.6.1, 00:00:04,
R210.10.10.0/24
R 210.10.10.0/24
R210.10.10.0/24
R 210.10.10.0/24 [120/2]
210.10.10.0/24
R R
[120/3]
[120/3]
210.10.10.0/24
210.10.10.0/24
via 50.5.5.10,
[120/2]
via
[120/2] 50.5.5.2,
via
50.5.5.2,
[120/3]
00:00:05,
via50.5.5.13,
R[120/3] 00:00:24,
200.2.3.0/24
50.5.5.13,
via
via 00:00:24,
50.5.5.6,
50.5.5.6,
FastEthernet0/1
00:00:02,
[120/3]FastEthernet0/1
00:00:02,
00:00:00,60.6.6.1,
FastEthernet0/1 00:00:04,FastEthernet0/1
viaFastEthernet0/1
FastEthernet0/1
00:00:00, FastEthernet0/1
FastEthernet0/1 FastEthernet0/1
RR 200.2.2.0/24
C200.2.2.0/24 [120/1]
[120/1] via
via 50.5.5.1,
50.5.5.1, 00:00:04,
60.0.0.0/30
00:00:04, FastEthernet0/0
isissubnetted,
FastEthernet0/0 11subnets
C 200.2.2.0/24
R200.2.2.0/24
R 200.2.2.0/24
200.2.2.0/24
R R
isisdirectly
200.2.2.0/24
200.2.2.0/24
[120/3]
directly
[120/3] connected,
via
via
[120/4]
[120/4]
50.5.5.13,
60.0.0.0/30
connected, FastEthernet0/0
50.5.5.13,
via
via
00:00:02,
subnetted,
FastEthernet0/0
50.5.5.6,
50.5.5.6,00:00:02, FastEthernet0/1
00:00:00, subnets
FastEthernet0/1
00:00:00, FastEthernet0/1
FastEthernet0/1
RR 200.2.3.0/24
R200.2.3.0/24 [120/3]
[120/3] via
via 50.5.5.10,
CC
50.5.5.10, 00:00:05,
60.6.6.0
00:00:05, FastEthernet0/1
is00:00:02,
directly connected,
FastEthernet0/1 FastEthernet0/1
R 200.2.3.0/24
R200.2.3.0/24
R 200.2.3.0/24
200.2.3.0/24
C C
[120/4]
[120/4]
200.2.3.0/24
200.2.3.0/24
[120/1]
via
[120/1]
via
is
is
50.5.5.2,
via 50.5.5.5,
50.5.5.2,
via 00:00:24,
60.6.6.0
50.5.5.5,
directly
directly
00:00:02,
is
00:00:24,
connected,
connected,
FastEthernet0/1
directly FastEthernet0/0
connected,
FastEthernet0/1 FastEthernet0/1
FastEthernet0/0
FastEthernet0/0
FastEthernet0/0
RR 60.0.0.0/8
R60.0.0.0/8 [120/1]
[120/1] via
via 50.5.5.10,R*
50.5.5.10, 00:00:05,
0.0.0.0/0
00:00:05, FastEthernet0/1
[120/1] via
FastEthernet0/160.6.6.1, 00:00:04, FastEthernet0/1
R 60.0.0.0/8
R60.0.0.0/8
R 60.0.0.0/8
R R
[120/2]
60.0.0.0/8 [120/2]
60.0.0.0/8
60.0.0.0/8
[120/1]
via
[120/1]via 50.5.5.2,
via
R* 50.5.5.13,
50.5.5.2,
via
[120/2]
[120/2]
00:00:24,
0.0.0.0/0
50.5.5.13,
via
via
00:00:02,
00:00:24,
50.5.5.6, FastEthernet0/1
[120/1]
00:00:02,
50.5.5.6,
FastEthernet0/1
via 60.6.6.1,
FastEthernet0/1
00:00:00,
00:00:00,FastEthernet0/100:00:04,
FastEthernet0/1
FastEthernet0/1 FastEthernet0/1
R* 0.0.0.0/0
R* R*0.0.0.0/0
R* [120/1]
[120/1]
0.0.0.0/0
0.0.0.0/0
[120/2]via
via 50.5.5.10,
[120/1]via R6#
50.5.5.10,
50.5.5.2,
via 00:00:05,
00:00:05,
50.5.5.13, FastEthernet0/1
FastEthernet0/1
Observar
00:00:24,
00:00:02, queFastEthernet0/1
R5FastEthernet0/1
FastEthernet0/1falta adicionar: no- auto-summary
R* R*
0.0.0.0/0
0.0.0.0/0
R*R* [120/2]
0.0.0.0/0 [120/1]
0.0.0.0/0 via
[120/2] R6#
50.5.5.2,
via
[120/2] 50.5.5.13,
via
via 00:00:24,
50.5.5.6,00:00:02,
50.5.5.6, FastEthernet0/1
00:00:00,
00:00:00,FastEthernet0/1
FastEthernet0/1
R2#
R2#R1# De allí que aparezca en R1, R2, R3 y R4: 60.0.0.0/8
R1#R4#
R4# R3#R3#
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
PROPAGACIÓN DE RUTA POR DEFECTO
200.2.2.0/24 R1 50.5.5.0/30 R2
.9
.2 .1 .1 .2 50.5.8.0/30
PC1 210.10.10.0/24
RIP .10 60.6.6.0/30
.1 .2 .1 .2
.0 /30
PC2 .1 2 .13
5 R5 R6 PC3
50.
.2 .1 .5 .6
.14
200.2.3.0/24 R3 50.5.5.4/30 R4
Propiedad intelectual de Daniel Díaz @ 2011

Ruta por Redes

ddiaz@inictel-uni.edu.pe
defecto anunciadas

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
PROPAGACIÓN DE RUTA POR DEFECTO
200.2.2.0/24 R1 50.5.5.0/30 R2 Habilitado con RIPv2
.9
.2 .1 .1 .2 50.5.8.0/30
PC1 210.10.10.0/24
.10 60.6.6.0/30
.1 .2 .1 .2
.0 /30.13
PC2 . 5.12 R5 R6 PC3
.2 .1 .5 .6 50 .5 Enrutamiento
.14 estático
200.2.3.0/24 R3 50.5.5.4/30 R4 60.6.6.4/30
.6
Propiedad intelectual de Daniel Díaz @ 2011

R7 .1 .2 PC4
220.20.20.0/24
R5#configure terminal
R5(config)#router rip
R7(config)#ip route 0.0.0.0 0.0.0.0 60.6.6.5
R5(config-router)#default-information originate

ddiaz@inictel-uni.edu.pe
►De R1 a R6 tienen la
R5#configure terminal
R5(config)#ip route 220.20.20.0 255.255.255.0 60.6.6.6
ruta por defecto
R5(config)#exit ►“Todos” saben llegar a
R5
►Cuando se llegue a R5, la tabla estática indicará 220.20.20.0
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
REDISTRIBUCIÓN ESTÁTICA
200.2.2.0/24 R1 50.5.5.0/30 R2 Habilitado con RIPv2
.9
.2 .1 .1 .2 50.5.8.0/30
PC1 210.10.10.0/24
.10 60.6.6.0/30
.1 .2 .1 .2
.0 /30.13
PC2 . 5 .12 R5 R6 PC3
.2 .1 .5 .6 50 .5 Enrutamiento
.14 estático
200.2.3.0/24 R3 50.5.5.4/30 R4 60.6.6.4/30
.6
Propiedad intelectual de Daniel Díaz @ 2011

►Verifiquemos que esté PC4 R7 .1 .2

deshabilitado la propagación de No
tien
220.20.20.0/24

ruta por defecto en el router R5. eR


IP
no default-information originate

ddiaz@inictel-uni.edu.pe
►Todos los router tienen: no- auto-summary

Tabla en R7

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
REDISTRIBUCIÓN ESTÁTICA
200.2.2.0/24 R1 50.5.5.0/30 R2 Habilitado con RIPv2
.9
.2 .1 .1 .2 50.5.8.0/30
PC1 210.10.10.0/24
.10 60.6.6.0/30
.1 .2 .1 .2
.0 /30.13
PC2 . 5 .12 R5 R6 PC3
.2 .1 .5 .6 50 .5 Enrutamiento
.14 estático
200.2.3.0/24 R3 50.5.5.4/30 R4 60.6.6.4/30
.6
Propiedad intelectual de Daniel Díaz @ 2011

R7 .1 .2 PC4
220.20.20.0/24
Tabla en R5

ddiaz@inictel-uni.edu.pe
Cómo propagar
220.20.20.0 a la red
usando RIP ?

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
REDISTRIBUCIÓN ESTÁTICA
200.2.2.0/24 R1 50.5.5.0/30 R2 Habilitado con RIPv2
.9
.2 .1 .1 .2 50.5.8.0/30
PC1 210.10.10.0/24
.10 60.6.6.0/30
.1 .2 .1 .2
.0 /30.13
PC2 . 5 .12 R5 R6 PC3
.2 .1 .5 .6 50 .5 Enrutamiento
.14 estático
200.2.3.0/24 R3 50.5.5.4/30 R4 60.6.6.4/30
.6
Propiedad intelectual de Daniel Díaz @ 2011

R7 .1 .2 PC4
220.20.20.0/24

Tabla en R1
No sabe

ddiaz@inictel-uni.edu.pe
como llegar a
220.20.20.0

R5 debe anunciar el link


estático 220.20.20.0

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
REDISTRIBUCIÓN ESTÁTICA
200.2.2.0/24 R1 50.5.5.0/30 R2 Habilitado con RIPv2
.9
.2 .1 .1 .2 50.5.8.0/30
PC1 210.10.10.0/24
.10 60.6.6.0/30
.1 .2 .1 .2
.0 /30.13
PC2 . 5 .12 R5 R6 PC3
.2 .1 .5 .6 50 .5 Enrutamiento
.14 estático
200.2.3.0/24 R3 50.5.5.4/30 R4 60.6.6.4/30
.6
Propiedad intelectual de Daniel Díaz @ 2011

R5(config)#router rip R7 .1 .2 PC4


R5(config-router)#redistribute static 220.20.20.0/24

ddiaz@inictel-uni.edu.pe
Se propaga
el prefijo de red
200.20.20.0

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
REDISTRIBUCIÓN ESTÁTICA

Redistribución
estática
R2 a R1
Propiedad intelectual de Daniel Díaz @ 2011

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
QUE SUCEDE EN LOS ROUTER CISCO?
CISCO implementa RIPv2 soportando:
►Autenticación ►Gestión de clave
►Summarization de rutas ►CIDR
►VLSM
Propiedad intelectual de Daniel Díaz @ 2011

De manera predeterminada, un router que


soporta RIPv2 no recibe paquetes RIPv1

CISCO ofrece comandos para RIPv1 y RIPv2

ddiaz@inictel-uni.edu.pe
►version 1  recibe y envía paquetes RIPv1
►version 2  recibe y envía paquetes RIPv2

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
COMANDOS SEND Y RECEIVE
CISCO ofrece comandos para RIPv1 y RIPv2
►ip rip send version 1  Configura una interfaz para
enviar sólo paquetes RIPv1
►ip rip send version 2  Configura una interfaz para
enviar sólo paquetes RIPv2
►ip rip send version 1 2  Configura una interfaz
Propiedad intelectual de Daniel Díaz @ 2011

para enviar ambos paquetes RIPv1 y RIPv2


►ip rip receive version 1  Configura una interfaz
para recibir sólo paquetes RIPv1

ddiaz@inictel-uni.edu.pe
►ip rip receive version 2  Configura una interfaz
para recibir sólo paquetes RIPv2
►ip rip receive version 1 2 

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
CUENTA A INFINITO R3 detecta que la red
está desconectada, pero
Actualización se demora en envíar
30.3.3.0 salto=3 mensaje a R2.
Actualización Actualización
30.3.3.0 salto=3
salto=1 30.3.3.0 salto=2
20.2.2.0/24 30.3.3.0/24
40.4.4.0/30 40.4.4.4/30
R1 R2 R3
.1 .2 .5 .6
.1 .1
Propiedad intelectual de Daniel Díaz @ 2011

Red Interfaz Salto Red Interfaz Salto Red Interfaz Salto


20.2.2.0 Directo 0 40.4.4.0 Directo 0 30.3.3.0 Directo
40.4.4.5 042
40.1.1.5
40.4.4.0 Directo 0 40.4.4.4 Directo 0 40.4.4.4 Directo 0
40.4.4.4 40.4.4.2 1 20.2.2.0 40.4.4.1 1 40.4.4.0 40.4.4.5 1

ddiaz@inictel-uni.edu.pe
30.3.3.0 40.4.4.2 24 30.3.3.0 40.4.4.6 31 20.2.2.0 40.4.4.5 2

►Valor de métrica iría hasta el infinito.


►Para evitar llegar al infinito, se tiene que definir el valor
máximo de cuenta. Este valor es el 16. CCNA 4.4.1
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
PING EXTENDIDO:
Lo_0 de router R1 a Lo_5 de router R6
Propiedad intelectual de Daniel Díaz @ 2011

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
CONFIGURAR AUTENTICACION EN RIPv2
Propiedad intelectual de Daniel Díaz @ 2011

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
CONFIGURAR AUTENTICACION EN RIPv2
Propiedad intelectual de Daniel Díaz @ 2011

• Como está la tabla de


enrutamiento en R5 ?

• Que pasa si se introduce


key-string inictel

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF

INTRODUCCIÓN
INTRODUCCIÓN AL
AL
PROTOCOLO
PROTOCOLO
Propiedad intelectual de Daniel Díaz @ 2011

OSPFv2
OSPFv2

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
ASPECTO BÁSICO DEL PROTOCOLO OSPF
Definido por la
IETF en la RFC
2328, de Abril-98.
► Se encapsula en IP
con protocolo=59h.
► Se define 05 tipos
Propiedad intelectual de Daniel Díaz @ 2011

de mensajes.
► Lectura obligada.

Características más importante:

ddiaz@inictel-uni.edu.pe
► Velocidad de convergencia. ► Mejor uso del ancho de
► Soporte de VLSM. banda.
► Grandes redes IP: Áreas ► Se define “costos”.
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
CARACTERÍSTICAS DEL PROTOCOLO OSPF
Los routers vecinos deben conocerse entre si.
►Se hace uso del protocolo HELLO. HELLO

►Se envía periódicamente a la Dirección IP 224.0.0.5

dirección multicast IP 224.0.0.5

La clave de OSPF es el intercambio de estados.


Propiedad intelectual de Daniel Díaz @ 2011

Router
El
El estado
estado de
de enlace
enlace eses la
la descripción
descripción Crea una base Llamado también
Base de datos de
de
de una
una interfaz
interfaz yy de
de su
su relación
relación con
con los
los de datos Estado de Enlace
routers
routers vecinos:
vecinos: dirección
dirección IP,IP, máscara
máscara topológicas

ddiaz@inictel-uni.edu.pe
de
de subred,
subred, tipo
tipo de
de red
red conectada,
conectada, etc.
etc.

OSPF origina que cada routers conozca de manera


completa toda la red de su área.
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
REDES DE ÁREA ÚNICA
SISTEMA AUTÓNOMO

AREA 0
Propiedad intelectual de Daniel Díaz @ 2011

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
REDES MULTIAREAS
SISTEMA AUTÓNOMO
Propiedad intelectual de Daniel Díaz @ 2011

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
OBSERVACIONES AL ESTADO DE ENLACE
Los routers con estado de enlace requieren más
memoria y potencia de procesamiento, que un
router con vector-distancia.

Al inicio del proceso se debe inundar la red con


Propiedad intelectual de Daniel Díaz @ 2011

mensaje LSA, puede degradar la red.

Para reducir la base de datos topológica es


necesario dividir la red en áreas.

ddiaz@inictel-uni.edu.pe
► El Área 0 es denominada también Área Backbone y en ella se
conectan las demás áreas.

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF

FORMATO
FORMATO DEL
DEL
PROTOCOLO
PROTOCOLO
Propiedad intelectual de Daniel Díaz @ 2011

OSPFv2
OSPFv2

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
FORMATO DEL PROTOCOLO OSPF
0 8 16 31

El protocolo OSPF está Ver HLEN ToS Longitud Total

Cabecera IPv4
formado por 05 tipos de Identificador Indicador/Desplazam.
Protocolo
paquetes: Se encapsula en IP. TTL
59H = 89
Suma de Chequeo

Dirección IP de Origen
► Tipo 1: Hello
Descubre y mantiene los routers Dirección IP de Destino
Longitud del
vecinos. Versión Tipo
Propiedad intelectual de Daniel Díaz @ 2011

paquete

► Tipo 2: DataBase Description-DBD ID del Router

Describe el contenido de la base de ID del Área

Protocolo OSPF
datos de topología. Suma de Chequeo Tipo de Autenticación
► Tipo 3: Link-State Request-LSR

ddiaz@inictel-uni.edu.pe
Descarga la base de datos (registro). Autenticación

► Tipo 4: Link-State Update-LSU


Actualiza la base de datos (registro). Formato del tipo de
Paquete OSPF
► Tipo 5: Link-State Acknowledgement
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
FORMATO DEL PROTOCOLO OSPF
0 8 16 31

Campo Versión: Ver HLEN ToS Longitud Total

Cabecera IPv4
► Indica la versión del protocolo OSPF, Versión 2.
Identificador Indicador/Desplazam.
Protocolo
Campo Tipo: TTL
59H = 89
Suma de Chequeo

Dirección IP de Origen
► Indica el tipo de mensaje que encapsula OSPF.
Dirección IP de Destino
Campo Longitud del paquete: Versión Tipo
Longitud del
Propiedad intelectual de Daniel Díaz @ 2011

paquete
► Indica longitud del paquete, ID del Router
incluyendo la cabecera OSPF.
ID del Área
Campo ID del Router:
Protocolo OSPF
Suma de Chequeo Tipo de Autenticación
► Indica el ID del router que

ddiaz@inictel-uni.edu.pe
originó en paquete. Autenticación

Campo ID del Área:


Formato del tipo de
► Indica el área a la que pertenece Paquete OSPF
el paquete.
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
FORMATO DEL PROTOCOLO OSPF
0 8 16 31

Campo Suma de Chequeo: Ver HLEN ToS Longitud Total

Cabecera IPv4
► Verifica todo el contenido del paquete OSPF, excluyendo
Identificador el
Indicador/Desplazam.

campo de autenticación. TTL


Protocolo
59H = 89
Suma de Chequeo

Campo Tipo de Autenticación: Dirección IP de Origen

► Indica el esquema de autenticación a usar en Dirección


el paquete.
IP de Destino

Se configura por áreas. Versión Tipo


Longitud del
Propiedad intelectual de Daniel Díaz @ 2011

paquete
La RFC 2328 define dos tipos de ID del Router

autenticación: ID del Área


- 0  Ninguna
Protocolo OSPF
Suma de Chequeo Tipo de Autenticación
- 1  Password de 64 bits, texto.

ddiaz@inictel-uni.edu.pe
- 2  Autenticación MD5. Autenticación

Campo Autenticación:
Formato del tipo de
► Campo de 64 bits, usado para Paquete OSPF
autenticación.
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
FORMATO DEL PROTOCOLO HELLO
(Pag. 193 de la RFC 2328)
0 8 16 31

Longitud del
Paquetes Hello son paquetes
Versión Tipo=1
paquete
OSPF tipo 1.
Protocolo OSPF

ID del Router
► Son enviados periódicamente a
ID del Área
todas las interfaces (incluyendo
Suma de Chequeo Tipo de Autenticación
los enlaces virtuales).
► Establecen y mantienen las
Propiedad intelectual de Daniel Díaz @ 2011

Autenticación

relaciones entre los routers vecinos.


Máscara
Protocolo HELLO

Intervalo de Hello Opción


Prioridad ► Por default, en routers CISCO,
de Router
el paquete Hello se envían cada

ddiaz@inictel-uni.edu.pe
Intervalo de Dead Router

Router Designado (DR)


10 segundos.
► Por default, en routers CISCO,
Router Designado de Reserva (BDR)

si no llega un paquete Hello a un


router en 40 seg. se considera caído este router.
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
FORMATO DEL PROTOCOLO HELLO
(Pag. 193 de la RFC 2328)

Máscara
Campo Máscara.
Protocolo HELLO

Prioridad ► Es la máscara de la red asociada


Intervalo de Hello Opción
de Router
con la interfaz.
Intervalo de Dead Router

Router Designado (DR) Campo Intervalo de Hello.


Router Designado de Reserva (BDR) ► Define la frecuencia en seg. con
que un router envía un paquete Hello.
Propiedad intelectual de Daniel Díaz @ 2011

Campo de Opción:
DN O DC L NP MC E No
usado

ddiaz@inictel-uni.edu.pe
Campo Prioridad de Router:
► Usado para la elección de un router DR o BDR
► Si este campo está en 0, el router nunca será seleccionado como
DR o BDR.
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
FORMATO DEL PROTOCOLO HELLO
(Pag. 193 de la RFC 2328)

Máscara
Campo Intervalo Dead
Protocolo HELLO

Intervalo de Hello Opción


Prioridad
de Router
Router.
Intervalo de Dead Router
► Número en segundos antes de
Router Designado (DR)
declarar caído. Por default es
Router Designado de Reserva (BDR)
cuatro (04) veces del campo de
Intervalo de Hello.
Propiedad intelectual de Daniel Díaz @ 2011

Campo de Router Designado:


► Identifica a un router dentro de un sistema autónomo.
Es la dirección IP más alta de sus interfaces.

ddiaz@inictel-uni.edu.pe
Es utilizado para seleccionar el router DR.
Campo de Router Designado:
► Es utilizado para seleccionar el router BDR.
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
FORMATO DEL PROTOCOLO HELLO
0 8 16 31
IP
4 5 C0 00 4C
Cabecera IPv4

04 D3 00 00 OSPF

Hello
01 59H 00 BD

D0 03 03 01 Versión 2 Máscara 255.255.255.0


E0 00 00 05 Tipo 1 (Hello) Intervalo de Hello 10 seg.
Longitud 2C=44 Prioridad de router 1
02 01 00 2C
Propiedad intelectual de Daniel Díaz @ 2011

ID Router 72.72.72.34Intervalo Dead Router 40 seg.


48 48 48 22 Router DR 208.3.3.1
ID Area 0.0.0.2
00 00 00 02 Suma de Chequeo 892D Router BDR 0.0.0.0
Protocolo OSPF

89 2D 00 00
FF FF FF 00

ddiaz@inictel-uni.edu.pe
Protocolo HELLO
00 00 00 00
00 0A 12 01
00 00 00 00
00 00 00 28

D0 03 03 01

00 00 00 00

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF

CONFIGURACION
CONFIGURACION DE
DE
Propiedad intelectual de Daniel Díaz @ 2011

OSPFv2
OSPFv2

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
ASPECTOS DE CONFIGURACIÓN (1/7)
Configuración OSPF:
Router# configure terminal
Router(config)# router ospf process-ID
Router(config-router)# network dirección_de_red wildcard
area area_ID
Router(config-router)# exit
Propiedad intelectual de Daniel Díaz @ 2011

Router(config)# R1# configure terminal


R1(config)# router ospf 1
R1(config-router)# network 10.2.3.4 0.0.0.3 area 1
40.1.0

40.1

R1(config-router)# network 20.1.71.8 0.0.0.3 area 2


Área 0 R1(config-router)# network 40.1.0.4 0.0.0.3 area 0
.0

ddiaz@inictel-uni.edu.pe
.
.4/30

8/30

R1(config-router)# network 40.1.0.8 0.0.0.3 area 0


R1(config)#
R1
Área 1 Área 2
0 20.
.4 /3 1 .71
2. 3 .8/3
10. 0
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
ASPECTOS DE CONFIGURACIÓN (2/7)
Definición de Identificador de Router (ID-Router):
► Al iniciarse el proceso OSPF en un router, el IOS utiliza
la dirección IP activa local más alta como ID del router.
► Si no existe una interfaz activa, el proceso OSPF no se
iniciará.
► Para asegurar la estabilidad del proceso OSPF, es necesario
Propiedad intelectual de Daniel Díaz @ 2011

que el router tenga una interfaz activa en todo momento.


► La interfaz loopback es importante para este objetivo.
En un router con más de una interfaz loopback,

ddiaz@inictel-uni.edu.pe
la dirección más alta será el ID-Router.
Selección del Router Designado (DR):
► La interfaz con mayor prioridad permitira el router sea DR.
► Ante iguales prioridades se selecciona el de mayor ID-Router.
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
ASPECTOS DE CONFIGURACIÓN (3/7)
Configuración de prioridad en una interfaz:
Router(config)# interface serial 0/0/0
Router(config-if)# ip priority número_de_prioridad

Un valor de prioridad puede variar de 0 a 255.


Propiedad intelectual de Daniel Díaz @ 2011

Valor 0 de prioridad imposibilita al router que


sea elegido DR.
En resumen sobre selección de DR y BDR:

ddiaz@inictel-uni.edu.pe
► Mayor prioridad  Router DR.
► Segundo valor de prioridad  Router BDR.
► Routers con igual prioridad  Será DR el mayor ID-Router
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
ANÁLISIS DE LA RED MULTIAREA

R5
20
AREA 1 .1 .0 /30 .2 .5 .1
Co .1.4/3
AREA 2
.1 6
R3 20 o sto sto
4 .6
0 R6
PCa C PCc
R1 30.3.3
. 0/ 3 0 .1 AREA 0 40.4.4
.0/30 R8
.65 .2 .9 .2 .65
.1

Costo 1
.17

Costo .1
Costo 5
20.1.1.16/30

.22
20.1.1.20/30
20. 1
.9 1
Costo 2
Co .1.8/30
Propiedad intelectual de Daniel Díaz @ 2011

.9 220.2.2.64/26
210.1.1.64/26 sto
30

40.4.4.8/30
Costo 1

Costo 1
.21
30.3.3.8/

0 .10
.18

sto1
Co 4/30 .14 20.1.1.12/30 .13
. 40.
3.3 4
210.1.1.128/26 .10 3 0 . .6 Costo 3 .6 .4.4/30 .10 220.2.2.0/26
Co
R4 R7 sto

ddiaz@inictel-uni.edu.pe
.129 .5 1 .5 .1

PCb R2 R9 PCd

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
CONFIGURACIÓN DE ROUTER CON OSPF
Propiedad intelectual de Daniel Díaz @ 2011

R2>enable
R2#configute terminal
R2(config)#router ospf 1
R2(config-router)#network 30.3.3.4 0.0.0.3 area 1
R2(config-router)#network 30.3.3.8 0.0.0.3 area 1

ddiaz@inictel-uni.edu.pe
R1>enable
R1#configute terminal R2(config-router)#network 210.1.1.128 0.0.0.63 area 1
R1(config)#router ospf 1 R2(config-router)#exit
R1(config-router)#network 30.3.3.0 0.0.0.3 area 1
R1(config-router)#network 30.3.3.8 0.0.0.3 area 1
R1(config-router)#network 210.1.1.64 0.0.0.63 area 1
R1(config-router)#exit
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
CONFIGURACIÓN DE ROUTER CON OSPF
Propiedad intelectual de Daniel Díaz @ 2011

R7>enable
R7#configute terminal
R7(config)#router ospf 1
R7(config-router)#network 20.1.1.8 0.0.0.3 area 0
R7(config-router)#network 20.1.1.12 0.0.0.3 area 0

ddiaz@inictel-uni.edu.pe
R4>enable
R4#configute terminal R7(config-router)#network 20.1.1.20 0.0.0.3 area 0
R4(config)#router ospf 1 R7(config-router)#network 40.4.4.4 0.0.0.3 area 2
R4(config-router)#network 20.1.1.12 0.0.0.3 areaR7(config-router)#exit
0
R4(config-router)#network 20.1.1.16 0.0.0.3 area 0
R4(config-router)#network 30.3.3.4 0.0.0.3 area 1 Los demás router se configuran
R4(config-router)#exit de manera similar.
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
COSTOS OSPF POR DEFAULT

/1
fa2/0 fa1
Propiedad intelectual de Daniel Díaz @ 2011

►Por default, OSPF asigna costo


R1>enable
asociado al ancho de banda: R1#configute terminal
R1(config)#interface fastethernet 2/0

ddiaz@inictel-uni.edu.pe
costo= 108/(Ancho de banda) R1(config-if)#bandwidth 100 000
Expresado en 1000

►Se puede usar el comando bandwidth


para cambiar el denominador de la fórmula
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
CONFIGURACIÓN DE COSTOS OSPF

/1
fa2/0 fa1
Propiedad intelectual de Daniel Díaz @ 2011

R1>enable
R1#configute terminal Los demás router se configuran
R1(config)#interface fastethernet 1/1 de manera similar.
R1(config-if)#ip ospf cost 5
R1(config-router)#exit ►Para observar el costo de una interfaz:

ddiaz@inictel-uni.edu.pe
R1(config)#interface fastethernet 2/0
R1(config-if)#ip ospf cost 1
show ip ospf interface fastethernet 1/1
R1(config-router)#exit

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
COMANDO debug ip ospf events

Se desactiva:
R#no debug ip ospf events
Propiedad intelectual de Daniel Díaz @ 2011

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
ANALISIS DE PATH PCb a PCc
Propiedad intelectual de Daniel Díaz @ 2011

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
ANALISIS DE PATH PCc a PCb
Propiedad intelectual de Daniel Díaz @ 2011

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
TABLA DE ENRUTAMIENTO DE R2

Costo total
Propiedad intelectual de Daniel Díaz @ 2011

► Costo total
desde R2 hasta
la red
220.2.2.64

ddiaz@inictel-uni.edu.pe
es 14.

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
NUEVO ESCENARIO DE ANÁLISIS
Área 1

Lo_0: 131.4.5.33/28 Lo_2: 190.1.7.73/29


Lo_1: 131.4.6.163/27 Lo_3: 190.1.9.130/25
205.2.83.128/25 Lo_1
Fa0/0
Lo_0
10.2.2.36/30 R6
S0/0/0
Lo_3

S0/0/1
Lo_2
Lo_10: 10.41.52.3/24 Lo_13: 204.6.21.36/24
Lo_11: 10.41.68.19/24 Lo_14: 204.9.80.94/24
Lo_12: 51.5.6.6/24
Fa0/0 1Fa0/1
Propiedad intelectual de Daniel Díaz @ 2011

0 0.
Área 0 0 /3 R1 52
.1 Área 3
.6 77
Lo_6 1 77 Lo_4 . 52 Lo_8
5 2. Lo_5 /3
0. 0
Fa0/1 1 Fa0/0
R2 R3
Lo_12 10.52.177.56/30 Lo_13
Lo_10 S0/0/1 S0/0/0
Fa0/0 Fa0/1
R4 10.1 R5

ddiaz@inictel-uni.edu.pe
S0/0/0
. 1.24
/30 Área 2 .1.2
8/ 30
S0/0/1
10 . 1
Lo_7 Lo_9
Fa0/0 Fa0/0
Lo_4: 210.7.2.31/24
Lo_11 Lo_5: 210.8.8.19/24 Lo_14
Lo_6: 55.0.4.3/17
Lo_7: 55.0.190.90//17
Lo_8: 140.1.160.3/21
200.4.5.0/24 Lo_9: 140.1.170.7/21 210.7.9.0/24
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
OBTENCION DE ROUTER-ID
En el router R1
R1#show ip ospf
Routing Process "ospf 1" with ID 210.8.8.19

En el router R2
Propiedad intelectual de Daniel Díaz @ 2011

R2#show ip ospf
Routing Process "ospf 3" with ID 55.0.190.90

ddiaz@inictel-uni.edu.pe
En el router R3
R3#show ip ospf
Routing Process "ospf 3" with ID 140.1.170.7

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
OBTENCION DE ROUTER-ID
En el router R4
R4#show ip ospf
Routing Process "ospf 1" with ID 10.41.68.19

En el router R5
Propiedad intelectual de Daniel Díaz @ 2011

R5#show ip ospf
Routing Process "ospf 3" with ID 204.9.80.94

ddiaz@inictel-uni.edu.pe
En el router R6
R6#show ip ospf
Routing Process "ospf 3" with ID 131.4.6.163

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
USANDO show ip ospf neighbor
En el router R1
R1#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
131.4.6.163 0 FULL/ - 00:00:33 10.2.2.37 Serial0/0/1
55.0.190.90 1 FULL/BDR 00:00:38 10.52.177.62 FastEthernet0/0
140.1.170.7 1 FULL/BDR 00:00:33 10.52.177.53 FastEthernet0/1
R1#
Propiedad intelectual de Daniel Díaz @ 2011

En el router R3
R3#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface

ddiaz@inictel-uni.edu.pe
55.0.190.90 1 FULL/BDR 00:00:39 10.52.177.57 GigabitEthernet0/1
210.8.8.19 1 FULL/DR 00:00:34 10.52.177.54 GigabitEthernet0/0
204.9.80.94 0 FULL/ - 00:00:31 10.1.1.30 Serial0/0/0
R3#
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
ESTABLECIENDO ENLACE VIRTUAL
Área 1

Lo_0: 131.4.5.33/28 Lo_2: 190.1.7.73/29


Lo_1: 131.4.6.163/27 Lo_3: 190.1.9.130/25
205.2.83.128/25 Lo_1
Fa0/0
Lo_0
10.2.2.36/30 R6
S0/0/0
Lo_3

S0/0/1
Lo_2
Lo_10: 10.41.52.3/24 Lo_13: 204.6.21.36/24
Lo_11: 10.41.68.19/24 Lo_14: 204.9.80.94/24
Lo_12: 51.5.6.6/24
Fa0/0 1Fa0/1
Propiedad intelectual de Daniel Díaz @ 2011

0 k 0.
Área 0 /3lin R1 52
Área 3
0
.6 l - .1
77
Lo_6 1 77tuaLo_4 . 52 Lo_8
2. r Lo_5
0.
5 vi /3
0
Fa0/1 1 Fa0/0
R2 R3
Lo_12 10.52.177.56/30 Lo_13
Lo_10 S0/0/1 S0/0/0
R4 Fa0/0 virtual-link Fa0/1
R5
10.1

ddiaz@inictel-uni.edu.pe
S0/0/0
. 1.24
/30 Área 2 .1.2
8/ 30
S0/0/1
10 . 1
Lo_7 Lo_9
Fa0/0 Fa0/0
Lo_4: 210.7.2.31/24
Lo_11 Lo_5: 210.8.8.19/24 Lo_14
Lo_6: 55.0.4.3/17
Lo_7: 55.0.190.90//17
Lo_8: 140.1.160.3/21
200.4.5.0/24 Lo_9: 140.1.170.7/21 210.7.9.0/24
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
OBSERVANDO LA TABLA DE RUTEO EN R5

Observar que un loopback siempre se anuncia


Propiedad intelectual de Daniel Díaz @ 2011

con una máscara 255.255.255.255

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
CONFIGURANDO VIRTUAL-LINK
10
0 .5
Área 0 /3 R1 2. Área 3
. 60 17
Lo_6 1 77 Lo_4
7.
52 Lo_8
5 2. Lo_5 /3
0. 0
Fa0/1 1 Fa0/0
R2 R3
Lo_12 10.52.177.56/30 Lo_13
Lo_10 S0/0/1 S0/0/0
R4 Fa0/0 virtual-link Fa0/1
R5
10.
1.1
S0/0/0
. 1.24
/30 Área 2 .28
/30
S0/0/1
10 . 1
Lo_7 Lo_9
Propiedad intelectual de Daniel Díaz @ 2011

Fa0/0 Fa0/0
Lo_7: 55.0.190.90//17 Lo_9: 140.1.170.7/21
Lo_11 Lo_14

200.4.5.0/24 210.7.9.0/24

ddiaz@inictel-uni.edu.pe
R2>enable R3>enable
R2#configure terminal. R3#configure terminal.
R2(config)#router ospf 2 R3(config)#router ospf 3
R2(config-router)#area 2 virtual-link 140.1.170.7 R3(config-router)#area 2 virtual-link 55.0.190.90
R2(config-router)#exit R3(config-router)#exit
R2(config)# R3(config)#

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
OBSERVANDO LA TABLA DE RUTEO EN R5
Propiedad intelectual de Daniel Díaz @ 2011

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
OBSERVANDO LA TABLA DE RUTEO EN R6
Propiedad intelectual de Daniel Díaz @ 2011

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
CONFIGURANDO VIRTUAL-LINK
Área 1

205.2.83.128/25 Lo_1
Fa0/0
Lo_0
10.2.2.36/30 R6
S0/0/0
Lo_3

S0/0/1
Lo_2

R1>enable
Fa0/0 1Fa0/1 R1#configure terminal
Propiedad intelectual de Daniel Díaz @ 2011

0 0.
Área 0 0 /3 R1 52. R1(config)#router ospf 1
17
.6 k
Lo_6 in
77 lLo_4 7.
R1(config-router)#area
52 Lo_8 2 virtual-link 55.0.190.90
2. l-
1
Lo_5 /3
0. tua
5 0
1
Fa0/1 ir R1(config-router)#exit
Fa0/0
R2 v R1(config)#
Lo_12 10.52.177.56/30
Lo_10 S0/0/1
Fa0/0 Fa0/1
R4

ddiaz@inictel-uni.edu.pe
S0/0/0
. 1.24
/30 Área 2
10 . 1 R2>enable
Lo_7 R2#configure terminal
Fa0/0
Lo_5: 210.8.8.19/24 R2(config)#router ospf 2
Lo_11 R2(config-router)#area 2 virtual-link 210.8.8.19
R2(config-router)#exit
Lo_7: 55.0.190.90//17 R2(config)#
200.4.5.0/24
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
OBSERVANDO LA TABLA DE RUTEO EN R6
Propiedad intelectual de Daniel Díaz @ 2011

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
ANALIZANDO LOS VIRTUAL-LINK
R2#show ip ospf virtual-link
Propiedad intelectual de Daniel Díaz @ 2011

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF

CONFIGURACION
CONFIGURACION DE
DE
Propiedad intelectual de Daniel Díaz @ 2011

RIPv2-OSPF
RIPv2-OSPF

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
ANÁLISIS DE UNA RED OSPF/RIP

R5
20
AREA 1 /30 .2 .5 .1 .
RIPv2 .0
Co 1.4/3 AREA 2
R3 20
.1 .1
s to6 sto 0 R6 RIPv2
PCa 0 .1 Co 4 .6 PCc
R1 30.3.3
.0/3
AREA 0 40.4.4
.0 / 3 0 R8
.65 .2 .9 .2 .65
.1

Costo 1
.17

osto 5 Costo .1
20.1.1.16/30

.22
20.1.1.20/30
C 20 . 1
.9 1 .1
Costo 2
Propiedad intelectual de Daniel Díaz @ 2011

Co .8/3 .9 220.2.2.64/26
210.1.1.64/26 sto 0
0

40.4.4.8/30
Costo 1

Costo 1
3

.21
0
30.3.3.8/

1 .10
sto
.18

Co
.14 .13
.4 / 30 20.1.1.12/30 40 .
3.3 Costo 3 4 .4
210.1.1.128/26 .10 30 . .6 .6
Co
.4/3 .10
0
220.2.2.0/26
R4 R7 sto

ddiaz@inictel-uni.edu.pe
.129 .5 1 .5 .1

PCb R9 PCd
R2

RIPv2 RIPv2
Revisión de redistribución RIP y OSPF en: OSPFv2
http://docwiki.cisco.com/wiki/Internetwork_Design_Guide_--_RIP_and_OSPF_Redistribution#RIP_and_OSPF_Redistribution
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
ANÁLISIS DE UNA RED OSPF/RIP
router
routerospf
ospf11 router
routerrip rip
redistribute
redistributerip
ripsubnets
subnets version
version22
network
network30.3.3.0
30.3.3.00.0.0.3
0.0.0.3area
area redistribute
redistribute R5ospf
ospf11match
matchinternal
internalexternal
external11
11 external
external22
network
network30.3.3.8
30.3.3.80.0.0.3
0.0.0.3area
area network
network0 .2 210.1.1.64
210.1.1.64
AREA 1 / 3 .5 20.1.
11
RIPv2 no0
1. auto-summary Co 1.4/3 AREA 2
R3 0 .1. notoauto-summary
6 s to 0 R6 RIPv2
2
C os 4 .6
PCa R1 .0/3 0 .1 40.4.4 R8 PCc
.65 30.3.3
.2 .9 AREA 0 .2
.0 / 3 0
.65
.1

Costo 1
.17

osto 5 Costo .1
20.1.1.16/30

.22
20.1.1.20/30
C 20 . 1
.9 1 .1
Costo 2
Propiedad intelectual de Daniel Díaz @ 2011

Co .8/3 .9 220.2.2.64/26
210.1.1.64/26 sto 0
0

40.4.4.8/30
Costo 1

Costo 1
3

.21
0
30.3.3.8/

1 .10
sto
.18

Co
.14 .13
.4 / 30 20.1.1.12/30 40 .
3.3 Costo 3 4 .4
210.1.1.128/26 .10 30 . .6 .6
Co
.4/3 .10
0
220.2.2.0/26
R4 R7 sto

ddiaz@inictel-uni.edu.pe
.129 .5 1 .5 .1

PCbospf router R9 PCd


router
router ospf11 R2 routerrip
rip
redistribute
redistributerip
ripsubnets
subnets version
version22
network
network30.3.3.4
RIPv2 30.3.3.40.0.0.3
0.0.0.3area
area redistribute
redistributeospf
ospf11match
matchinternal
internalexternal
external11 RIPv2
11 external 2
OSPFv2
external
network
2
network 30.3.3.8 0.0.0.3 area
network 30.3.3.8 0.0.0.3 area network210.1.1.128
210.1.1.128
11 no
INSTITUTO NACIONAL DE INVESTIGACION
auto-summary
noY auto-summary
CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
ANÁLISIS DE UNA RED OSPF/RIP
172.16. 0.0/16

RIPv2 .0.2 BW 100Mbps


.0.1
Ra
.198 .201
S1 S0

10
OSPFv2 AREA 0
/30

.0 .
Propiedad intelectual de Daniel Díaz @ 2011

37
.19

.2 0
37

0/3
.0.

BW 1544kbps

0
10

S0 .197 S1
.202
S1

ddiaz@inictel-uni.edu.pe
S0
.206
router .65 10.0.37.204/30 .205 .129
routerospf
ospf11 router
routerrip
rip BW 100Mbps
BW 100Mbps
redistribute
redistributerip
ripsubnets
subnets version
version22
network .66 0.0.0.3 area
network10.0.37.196
10.0.37.196 0.0.0.3 redistribute
redistributeospf
ospf11match
.130 external11external
matchinternal
internalexternal
RIPv2
00
area
22 RIPv2 external

network 10.0.37.200
10.0.37.200 0.0.0.3
network200.37.42.0/24 0.0.0.3 area network
network172.16.0.0
area 172.16.0.0200.37.51.0/24
00 INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION
no auto-summary
no auto-summary
DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
TABLA DE ENRUTAMIENTO
Propiedad intelectual de Daniel Díaz @ 2011

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
PROPUESTAS DE TEMAS DE EXPOSICION
Network Simulator
The Network Simulator, ns-2 NS by Example
http://www.isi.edu/nsnam/ns/tutorial/ http://nile.wpi.edu/NS/

OPNET IT GURU
http://www.opnet.com/university_program/itguru_academic_edition/
Propiedad intelectual de Daniel Díaz @ 2011

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
BIBLIOGRAFIA
RFC 2453 RIP version 2
Noviembre de 1998.
http://www.ietf.org/rfc/rfc1058.txt
Routing Information Protocol, Autor CISCO
http://www.cisco.com/univercd/cc/td/doc/cisintwk/ito_doc/rip.pdf
Propiedad intelectual de Daniel Díaz @ 2011

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF
BIBLIOGRAFIA
RFC 1058 Routing Information Protocol
Junio de 1988.
http://www.ietf.org/rfc/rfc1058.txt

RFC 1723 RIP version 2, Noviembre de 1994


http://www.ietf.org/rfc/rfc1723.txt
Propiedad intelectual de Daniel Díaz @ 2011

RFC 2082 MD5 Authentication


http://www.ietf.org/rfc/rfc2082.txt

Routing Information Protocol, Autor CISCO

ddiaz@inictel-uni.edu.pe
http://www.cisco.com/univercd/cc/td/doc/cisintwk/ito_doc/rip.pdf

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


UNIVERSIDAD NACIONAL DE INGENIERIA
Enrutamiento Dinámico: RIP y OSPF

MUCHAS
MUCHAS GRACIAS
GRACIAS
Propiedad intelectual de Daniel Díaz @ 2011

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI