Sei sulla pagina 1di 25

SERVICIO NAT

REDES Y COMUNICACIONES II
UCV SISTEMAS
ING. LUIS MOTTA C.

© 2003 Cisco Systems, Inc. All rights reserved.


NAT

Session Number
Presentation_ID © 2003 Cisco Systems, Inc. All rights reserved. 2
Repaso
• NAT permite a direcciones privadas ser traducidas
en públicas, direcciones enrutables.
• Esto conserva las direcciones IP registradas de
organizaciones y le permite al paquete ser
transportado sobre redes públicas externas, tales
como Internet.
• Una variación de NAT, llamada Port Address
Translation (PAT), permite muchas direcciones
privadas internas ser traducidas a una o más
direcciones públicas externas.

© 2003 Cisco Systems, Inc. All rights reserved.


Direccionamiento Privado

• Network Address
Translation conserva
direcciones IP contando
con el espacio de Internal Address CIDR
direcciones IP privadas RFC 1918
Range Prefix
reutilizables
especificado en el RFC Class A 10.0.0.0 10.255.255.255 10.0.0.0/8

1918. Class B 172.16.0.0 172.31.255.255 172.16.0.0/12

• Las organizaciones son Class C 192.168.0.0 192.168.255.255


192.168.0.0/1
6
libres de usar estas
direcciones IP privadas
dentro de sus redes Estas direcciones son para uso privado
e interno de la red solamente y no
internas.
pueden ser enrutadas a internet.

© 2003 Cisco Systems, Inc. All rights reserved.


NAT

Un dispositivo con NAT-activado típicamente opera


en la frontera de una red cerrada.
Los dispositivos dentro de la red interna tienen
direccionamiento IP privado que deberá ser
traducido a público, a direcciones ruteables.

© 2003 Cisco Systems, Inc. All rights reserved.


Beneficios de NAT
• Elimina la re-asignación para cada host de una
nueva dirección IP cuando se cambia a un nuevo
ISP. Los hosts conservan la dirección IP privada.
• Elimina la necesidad de re-direccionar todos los
hosts que requieren acceso externo, ahorrando
tiempo y dinero.
• Conserva direcciones a través de aplicaciones de
multiplexaje nivel-puerto (port-level)
• Protege la seguridad de la red.

© 2003 Cisco Systems, Inc. All rights reserved.


Conceptos de Network Address Translation

NAT
• NAT es el proceso de
cambiar una dirección por E0 S1
otra en el encabezado del 10.1.1.1 165.193.3.1
paquete de IP.
• El host de inside en la IP
10.1.1.11 puede aparecer SA SA
como IP 165.193.1.35 a la 10.1.1.11 165.193.1.35

red externa.
• El router de NAT traduce Internet

de inside (E0) a outside


(S1). Inside Host
10.1.1.11
SA= Source Address
© 2003 Cisco Systems, Inc. All rights reserved.
Tabla de NAT

•La tabla de NAT registra las asociaciones de inside


a outside.

© 2003 Cisco Systems, Inc. All rights reserved.


Inside & Outside

Local & Global

Session Number
Presentation_ID © 2003 Cisco Systems, Inc. All rights reserved. 9
Direcciones Inside & Outside

NAT
• Dirección de Inside e0 e1
10.1.1.1 165.193.3.1
- La dirección IP de un
host ubicado en la red
Inside
interna
address
Podría ser una dirección
privada no enrutable.

Destination
Local Host
Host
10.0.0.11
165.193.3.2

© 2003 Cisco Systems, Inc. All rights reserved.


DIrecciones Inside & Outside

NAT

• Dirección de Outside e0 e1
10.1.1.1 165.193.3.1
- Dirección IP de un host
ubicado en la red externa
Outside
Podría ser una dirección
address
públicamente enrutable

Destination
Local Host
Host
10.0.0.11
165.193.3.2

© 2003 Cisco Systems, Inc. All rights reserved.


NAT Dinámico

Session Number
Presentation_ID © 2003 Cisco Systems, Inc. All rights reserved. 12
NAT Dinámico

• NAT puede ser dinámico o estático.


• NAT Dinámico traduce direcciones inside usando un
conjunto (pool) de direcciones globales.
• Cada dirección inside local es dinámicamente
asignada a una dirección inside global de un
conjunto (pool) de direcciones definido
administrativamente.
• NAT Dinámico habilita los hosts en una red privada
para acceder a internet traduciendo las direcciones
privadas en direcciones públicas.

© 2003 Cisco Systems, Inc. All rights reserved.


Configure NAT Dinámico

1. Defina un conjunto de direcciones globales para ser asignadas


como se necesite.
router(config)# ip nat pool pool-name start-ip
end-ip netmask netmask
1. Defina una lista de acceso estándar para identificar cuáles hosts
serán traducidos.
router(config)# access-list number permit network mask
2. Establezca traducción de origen dinámica, identificando la lista de
acceso definida en el paso previo.
router(config)# ip nat inside source list access-list-
num pool pool-name
3. Identifique interfaces como inside u outside con respecto a NAT.
router(config-if)# ip nat {inside|outside}

© 2003 Cisco Systems, Inc. All rights reserved.


Ejemplo de Configuración de NAT Dinámico

© 2003 Cisco Systems, Inc. All rights reserved.


NAT Estático

Session Number
Presentation_ID © 2003 Cisco Systems, Inc. All rights reserved. 16
NAT Estático

• Permite a los dispositivos


con una dirección privada ser
vistos en una red pública.
• Las traducciones estáticas
son ingresadas directamente
en la configuración y están
siempre en la tabla de
traducciones.
SA SA
• Típicamente usado para 10.1.1.11 192.168.1.35
servidores de web.

Internet

Inside Host
10.1.1.11

© 2003 Cisco Systems, Inc. All rights reserved.


Configure NAT Estático

1. Establezca traducción estática entre direcciones de


inside y outside.
router(config)# ip nat inside source static local-ip
global-ip

2. Identifique interfaces como inside u outside con


respecto a NAT.
router(config-if)# ip nat {inside|outside}

© 2003 Cisco Systems, Inc. All rights reserved.


Configurando NAT Estático

e0 s0

SA SA
10.1.1.11 192.168.1.35

Internet

Inside Host
10.1.1.11
router(config)# ip nat inside source static 10.1.1.11 192.168.1.35
router(config)#interface e0
rotuer(config-if)#ip nat inside
router(config)#interface s0
rotuer(config-if)#ip nat outside
© 2003 Cisco Systems, Inc. All rights reserved.
Port Address Translation

PAT es el proceso de asociar dinámicamente múltiples


direcciones inside a una o más direcciones globalmente
enrutables.
Utiliza números de puerto para diferenciar entre los hosts
de inside.
Algunas veces llamado overloading

Session Number
Presentation_ID © 2003 Cisco Systems, Inc. All rights reserved. 20
Características de PAT

PAT usa números de puerto origen únicos en la dirección IP


inside global para distinguir entre traducciones.
El router PAT mantiene la cuenta de las diferentes
conversaciones asociando números de puerto TCP y UDP en la
tabla de NAT.
© 2003 Cisco Systems, Inc. All rights reserved.
Configurando PAT (Overloading NAT)
• Configure un pool de NAT. (U overload una
interface.)
• Genere una lista de acceso para determinar cuál
dirección deberá ser traducida.
• Asigne esta lista de acceso al pool de NAT y
configúrelo para overload.
• Asigne inside y outside a las interfaces.

© 2003 Cisco Systems, Inc. All rights reserved.


Overloading NAT

1. Configure el pool de NAT


Rango de direcciones:
ip nat pool bigpool 192.168.1.33 192.168.1.57 netmask
255.255.255.224
Dirección simple:
ip nat pool smallpool 192.168.1.33 192.168.1.33 netmask
255.255.255.224
2. Crea una lista de acceso estándar para identificar cuál dirección
deberá ser traducida
access-list 24 permit 10.0.0.0 0.255.255.255
3. Asigne esta lista de acceso para el pool de NAT y configúrelo para
overload
ip nat inside source list 24 pool bigpool overload
4. Asigne inside y outside a las interfaces
router(config-if)# ip nat {inside|outside}

© 2003 Cisco Systems, Inc. All rights reserved.


Configurando PAT

Interface is
used in place
of a NAT pool.

© 2003 Cisco Systems, Inc. All rights reserved.


Resumen

• Direcciones privadas son para uso interno, privado


y no pueden ser enrutadas por un router a Internet
público.
• NAT altera el encabezado de IP de un paquete así
que la dirección destino, la dirección origen, o
ambas direcciones son reemplazadas con diferentes
direcciones.
• PAT usa números de puerto origen únicos en la
dirección IP inside global para distinguir entre
traducciones.
• Las traducciones de NAT pueden ocurrir dinámica o
estáticamente y pueden ser utilizadas para una
variedad de situaciones.

© 2003 Cisco Systems, Inc. All rights reserved.