Sei sulla pagina 1di 21

SELECCIN

Tengo un buen trabajo ?????

No Si
SELECCIN

si < condicin > entonces


< bloque instrucciones 1>
sino
< bloque instrucciones 2>
fin_si
SELECCIN

Pseudo cdigo Diagrama de Flujo

si x > 0 entonces SI NO
y=0 x>0
sino y=0 y =1
y=1
fin_si
EJEMPLO

Hallar el cuadrado o la suma de


un nmero previamente ledo,
segn la condicin
EJEMPLO
a, b: entero
leer (a) Memoria
si a >0
entonces
a b
b = a+a
sino XXX8080
40 XXX
b = a*a
fin_si
escribir (b)
EJEMPLO
a, b: entero
Memoria
leer (a)
si a >0
entonces a b
b = a+a 100
-10
XXX 100
XXX
sino
b = a*a
fin_si
escribir (b)
EJEMPLO

Dados tres nmeros


enteros, calcular el mximo
a, b, c : entero
EJEMPLO (a)
mayor: entero
leer (a)
leer (b) Memoria
leer (c)
si a>=b
a>=b & & a>=c
a>=centonces
entonces
mayor = :=aa a b c
sino XXX
5 XXX
2XXX
10
si b>=a
b>=a & & b>=c
b>=centonces
entonces maximo 10
mayor = :=bb
sino mayor
mayor = :=cc XXX
10
fin_si
fin_si
escribir (maximo)
escribir (mayor)
a, b, c : entero EJEMPLO (b)
mayor: entero
leer (a)
leer (b)
leer (c) Memoria
a>=b &&a>=c
si a>=b a>=centonces
entonces
mayor = a
sino a b c
b>=a &&b>=c
si b>=a b>=centonces
entonces XXX
2 XXX
9 XXX
4
mayor = b maximo 9
sino mayor
mayor = c
fin_si XXX
9
fin_si
escribir (maximo)
escribir (mayor)
SELECCIN MLTIPLE
seleccionar <opcion> hacer
caso <constante 1>:
<bloque_intrucciones 1>
.
.
.
caso <constante n>:
<bloque_intrucciones n>
otrocaso:
<bloque_intrucciones>
fin_seleccionar
EJEMPLO

Seleccin de una transaccin


en un cajero automtico
EJEMPLO (a)
opcion: entero
leer (opcion)
seleccionar opcion de opcion
caso1: escribir (Consignacin)
Cambio4 de Clave
XXX
caso2: escribir (Retiro)
caso3: escribir (Pago de Servicios)
caso4: escribir (Cambio de Clave)
caso5: escribir (Terminar)
otrocaso: escribir (Terminar)
fin_seleccionar
EJEMPLO (b)

opcion: entero
leer (opcion)
seleccionar opcion de opcion
caso1: escribir (Consignacin) Salir
caso2: escribir (Retiro) XXX
5
caso3: escribir (Pago de Servicios)
caso4: escribir (Cambio de Clave)
caso5: escribir (Salir)
otrocaso: escribir(Salir)
fin_seleccionar
CODIFICACIN DE ALGORITMOS EN C++

SEUDOCODIGO C++
Def. Variables x : tipo tipo x;
Def. Constante PI = 3.1415926 PI = 3.1415926
Asignacin = =
Oper. Aritmticos
Suma + +
Resta - -
Multiplicacin * *
Divisin / /
Mdulo mod %
CODIFICACIN DE ALGORITMOS EN C++

Lectura leer (a) cin >>a;


Impresin escribir(a) cout << a;
Cambio de lnea cambio_linea \n
Cad. Caracteres cadena "cadena"
Seleccin si (condicin) if (condicin)
entonces {
bloque_instrucciones1 bloque_instru
sino cciones1;
bloque_instrucciones2 }
fin_si else
{
bloque_instru
cciones2 ;
}