Sei sulla pagina 1di 15

OmniAuto.it - FORUM [Powered by Invision Power Board] http://www.omniauto.it/forum/index.php?act=Print&client=print...

Versione Stampabile della Discussione


Clicca qui per visualizzare questa discussione nel suo formato originale

OmniAuto.it - FORUM _ tuning _ INTERFACCIA RS 232 ECU GAS

Inviato da: ALFONE Jun 10 2005, 05:02 PM

Sono riuscito a scovare qua' e la' su alcuni siti queste interfacce rs232 che permetterebbero di
collegare le nostre ecu con un computer

Sono delle comunissime rs232 i circuiti sono leggermente diversi ma dovrebbero funzionare alla
stessa maniera.

Non li ho ancora realizzati x che' non ho il software.

Comunque se possono essere utili a qualcuno .....

DECLINO OGNI RESPONSABILITA' X EVENTUALI DANNI ALLE CENTRALINE E/O COMPUTER

Immagini allegate

1 di 15 02/05/2006 10.54
OmniAuto.it - FORUM [Powered by Invision Power Board] http://www.omniauto.it/forum/index.php?act=Print&client=print...

2 di 15 02/05/2006 10.54
OmniAuto.it - FORUM [Powered by Invision Power Board] http://www.omniauto.it/forum/index.php?act=Print&client=print...

Inviato da: ALFONE Jun 10 2005, 05:03 PM

Ecco l' altro circuito....

Immagini allegate

Inviato da: carlobs Jun 10 2005, 05:11 PM

Ottimo lavoro, purtroppo per me non c'è il collegamento per lo Zavoli, altrimenti lo facevo...
trovando un pò di tempo libero.

Ciao

Inviato da: mystr Jun 11 2005, 11:32 AM

QUOTE (carlobs @ Jun 10 2005, 06:11 PM)


Ottimo lavoro, purtroppo per me non c'è il collegamento per lo Zavoli, altrimenti lo facevo...
trovando un pò di tempo libero.

Ciao

Mah sul sito della zavoli ho scaricato il loro software (si puo'! ) e mi pare anch'esso della

3 di 15 02/05/2006 10.54
OmniAuto.it - FORUM [Powered by Invision Power Board] http://www.omniauto.it/forum/index.php?act=Print&client=print...

grande famiglia AEB. questo lo renderebbe (forse) completamente compatibile con una
interfaccia aeb, come quella per l'omegas, per esempio. Solo bisogna vedere qual'e' il
connettore usato per la centralina.

Comunque, per quanto riguarda il mio omegas, dopo estenuanti ricerche guardando non senza
contorsioni acrobartiche il connettore femmina della centralina che da me e' vicino al pedale
dell'acceleratore......

......ho scoperto di cosa si tratta!

Ebbene era......

Un banalissimissimo connettore SUPERSEAL MASCHIO A 4 POLI, ex AMP ora prodotto dalla


TYCO. Roba da 2 o 3 euro da qualsiasi autoricambi.

Comuque per il landi mi orienterei sul secondo schema, ho visto lo scatolotto dell'interfaccia
landi una volta e non era cosi' smilzo come il primo schema, ed inoltre non aveva i connettori
DB9 gia' saldati sul circuito come quello, ma uscivano fili.

ciao, allego foto del mio connettore superseal femmina

Immagini allegate

4 di 15 02/05/2006 10.54
OmniAuto.it - FORUM [Powered by Invision Power Board] http://www.omniauto.it/forum/index.php?act=Print&client=print...

Inviato da: ALFONE Jun 11 2005, 10:51 PM

HO trovato il software universale...


e' qui... e costa anche poco

5 di 15 02/05/2006 10.54
OmniAuto.it - FORUM [Powered by Invision Power Board] http://www.omniauto.it/forum/index.php?act=Print&client=print...

http://mujobchod.atlas.cz/shop/item.aspx?id_shop=541&id_language=19&ts=33rh589&id_item=46&id_cat=8

circa 10€ possibile?

Inviato da: mystr Jun 11 2005, 11:24 PM

QUOTE (ALFONE @ Jun 11 2005, 11:51 PM)


HO trovato il software universale...
e' qui... e costa anche poco

http://mujobchod.atlas.cz/shop/item.aspx?id_shop=541&id_language=19&ts=33rh589&id_item=46&id_cat=8

circa 10€ possibile?

Ma dove li scovi alfone?

ciao

Inviato da: Punto Gpl Jun 12 2005, 02:41 PM

Azz..... universale.. siamo sicuri?

Inviato da: mystr Jun 12 2005, 06:44 PM

QUOTE (Punto Gpl @ Jun 12 2005, 03:41 PM)


Azz..... universale.. siamo sicuri?

Di universale non esiste niente, tranne un'interfaccia molto rozza, forse.

Che poi l'aeb faccia il software per una diecina di impianti secondo te vuol dire che sono
intecambiabi?

Aspetta e spera...

magari e' vero!

Inviato da: Punto Gpl Jun 12 2005, 07:04 PM

Figurati che ho provato il software per il Leonardo... che penso sia il piu' simile al mio... e mi dice
che la centralina e' diversa.

Inviato da: carlobs Jun 13 2005, 08:48 AM

QUOTE (mystr @ Jun 11 2005, 12:32 PM)


QUOTE (carlobs @ Jun 10 2005, 06:11 PM)

6 di 15 02/05/2006 10.54
OmniAuto.it - FORUM [Powered by Invision Power Board] http://www.omniauto.it/forum/index.php?act=Print&client=print...

Ottimo lavoro, purtroppo per me non c'è il collegamento per lo Zavoli, altrimenti lo
facevo... trovando un pò di tempo libero.

Ciao

Mah sul sito della zavoli ho scaricato il loro software (si puo'! ) e mi pare anch'esso
della grande famiglia AEB. questo lo renderebbe (forse) completamente compatibile con
una interfaccia aeb, come quella per l'omegas, per esempio. Solo bisogna vedere qual'e'
il connettore usato per la centralina.

Comunque, per quanto riguarda il mio omegas, dopo estenuanti ricerche guardando non
senza contorsioni acrobartiche il connettore femmina della centralina che da me e' vicino
al pedale dell'acceleratore......

......ho scoperto di cosa si tratta!

Ebbene era......

Un banalissimissimo connettore SUPERSEAL MASCHIO A 4 POLI, ex AMP ora prodotto


dalla TYCO. Roba da 2 o 3 euro da qualsiasi autoricambi.

Comuque per il landi mi orienterei sul secondo schema, ho visto lo scatolotto


dell'interfaccia landi una volta e non era cosi' smilzo come il primo schema, ed inoltre
non aveva i connettori DB9 gia' saldati sul circuito come quello, ma uscivano fili.

ciao, allego foto del mio connettore superseal femmina

sicuramente l'interfaccia va bene, il problema è che anche se vedo che connettore ho su, la
disposizione dei cavi potrebbe essere semplicemente diversa, e senza conoscerla non si può
fare.... senza correre rischi.

Inviato da: ALFONE Jun 13 2005, 01:41 PM

I fili sono sempre 4 +12V - e tx rx

Con un tester si individua il + 12V e la massa


Gli altri 2 non sono critici, al limite la centralina non comunica col pc, basta invertirli!!

Inviato da: carlobs Jun 13 2005, 04:21 PM

QUOTE (ALFONE @ Jun 13 2005, 02:41 PM)


I fili sono sempre 4 +12V - e tx rx

Con un tester si individua il + 12V e la massa


Gli altri 2 non sono critici, al limite la centralina non comunica col pc, basta invertirli!!

Ci avevo già pensato......bisogna vedere che tipo di configurazione a riposo avrebbero i due
canali.... se sono forzati a livello logico 0 avrei tre identificazioni di massa utilizzando un tester,
semai dovrei controllare la resistenza verso una massa vera (carrozzaria) a macchina spenta e
sperare che questi due diano resistenza maggiore rispetto al cavo di GND.

7 di 15 02/05/2006 10.54
OmniAuto.it - FORUM [Powered by Invision Power Board] http://www.omniauto.it/forum/index.php?act=Print&client=print...

Inviato da: carlobs Jun 16 2005, 04:17 PM

Sono stato dal mio impiantista per il primo controllo dello Zavoli e ho guardato il cavo di
collegamento, riporta in sequenza da sx a dx quattro cavetti di colore Verde, Marrone, Rosso e
bianco, guardandolo dall'alto con il gancetto del connettore verso l'alto.

La forma è quella del primo tipo nello schema, cioè "Leonardo" (Rosso scambiato col marrone e blu
che diventa bianco).

Potrebbe tornar utile.

Ciao

Inviato da: fraant Jul 5 2005, 07:13 PM

se vi interessa ho il software originale landi lsi, e anche io sto cercando di farmi il cavo.

Intanto la cosa principale da definire e' se tale programma alla fine gira solo su win 98/me e non
su xp, io lo ho visto girare solo su 9x.

io lo ho montato sulla mia omega 2.5 v6, la calibrazione va quasi bene, ma da 600 giri a 1400 giri
a volte ho delle mancanze di gas che dovrei colmare con delle extrainiettate.

cerchiamo di fare sto cavo

grazie atutti FRAANT

Inviato da: ALFONE Jul 5 2005, 07:40 PM

QUOTE (fraant @ Jul 5 2005, 08:13 PM)


se vi interessa ho il software originale landi lsi, e anche io sto cercando di farmi il cavo.

Intanto la cosa principale da definire e' se tale programma alla fine gira solo su win 98/me e
non su xp, io lo ho visto girare solo su 9x.

io lo ho montato sulla mia omega 2.5 v6, la calibrazione va quasi bene, ma da 600 giri a 1400
giri a volte ho delle mancanze di gas che dovrei colmare con delle extrainiettate.

cerchiamo di fare sto cavo

grazie atutti FRAANT

ma che tu sappia il software landi LSI vah bene anche per il landi omegas??

Inviato da: fraant Jul 5 2005, 07:42 PM

si, dovrebbe cambiare solo la chiave hardware per la configurazione avanzata.

Inviato da: fraant Jul 6 2005, 07:06 PM

ho avuto la conferma ufficiale, il software e' il medesimo, se ti interessa io ho quello lsi versione
2.20, e mi arrivera' la settimana prossima l'interfaccia originale per la connessione con la
centralina, che dovrebbe essere quella col max 232, comunque l'ho acquistata a 39 euro gia' bella
e fatta.

8 di 15 02/05/2006 10.54
OmniAuto.it - FORUM [Powered by Invision Power Board] http://www.omniauto.it/forum/index.php?act=Print&client=print...

Oltre al software ho le configurazioni di base di maggio 2005 consigliate dalla landi per iniettori
med e matrix nelle versioni 3,4,5,6,8 cilindri

scrivimi in pvt e dimmi che soft hai grazie

Inviato da: mystr Jul 6 2005, 09:29 PM

QUOTE (fraant @ Jul 6 2005, 08:06 PM)


ho avuto la conferma ufficiale, il software e' il medesimo, se ti interessa io ho quello lsi versione
2.20, e mi arrivera' la settimana prossima l'interfaccia originale per la connessione con la
centralina, che dovrebbe essere quella col max 232, comunque l'ho acquistata a 39 euro gia'
bella e fatta.

Oltre al software ho le configurazioni di base di maggio 2005 consigliate dalla landi per iniettori
med e matrix nelle versioni 3,4,5,6,8 cilindri

scrivimi in pvt e dimmi che soft hai grazie

da chi hai avuto la conferma ufficiale che il lsi va anche sull'omegas?

ciao.

Inviato da: fraant Jul 6 2005, 09:31 PM

il fornitore dell'adattatore in germania, se vuoi in pvt ti giro l'email che mi ha mandato fammi
sapere
ciao fraant

Inviato da: suso Jul 9 2005, 07:11 PM

Di solito cio che gira su win 9x gira anche su xp a patto di lanciare il programma facendo capire al
sistema operativo di emulare l'ambiente win 9x , dos o win2000.
Non ho installato sul pc di casa winxp (ho il 2000) ma per far girare un vecchio programma devi
creare un collegamento all' eseguibile del programma stesso poi selezionare tale collegamento col
tasto destro e cliccare proprieta'.
Ti apparira' una schermata uguale a quella dell' immagine che allego (la schermata sara pero' in
italiano) dalla quale potrai selezionare il sistema da emulare.
Ritengo comunque difficile che i programmi succitati non funzionino sotto winxp.
Sono programmi recenti ( 2-3 anni al massimo) e non capisco per quale oscuro motivo dovrebbero
essere stati sviluppati a 16bit invece che a 32 (che sono pienamente compatibili sia con win 9x che
con xp)

L'emulazione che ho descritto prima emula l'ambiente in termini di dll di sistema ecc. non fa girare
un programma a 16bit su win xp

Immagini allegate

9 di 15 02/05/2006 10.54
OmniAuto.it - FORUM [Powered by Invision Power Board] http://www.omniauto.it/forum/index.php?act=Print&client=print...

Inviato da: cicciomio Aug 1 2005, 10:35 AM

Ragazzi, scusate...
Qualcuno qui sa dirmi nella centralina BRC Sequent l'interfaccia come va collegata
visto che al connettore della suddetta centralina nello spinotto esistono solo 3 cavi:
Rosso
Nero
Bianco
Rimango in attesa di un V.s. cosiglio per poter risolvere il problemuccio.
Grazie in anticipo.

Inviato da: carlobs Aug 2 2005, 10:43 AM

QUOTE(cicciomio @ Aug 1 2005, 11:35 AM)

Ragazzi, scusate...
Qualcuno qui sa dirmi nella centralina BRC Sequent l'interfaccia come va collegata
visto che al connettore della suddetta centralina nello spinotto esistono solo 3 cavi:
Rosso
Nero
Bianco
Rimango in attesa di un V.s. cosiglio per poter risolvere il problemuccio.
Grazie in anticipo.

Ciao,
veramente rimango sorpreso di quello che dici... solo tre cavi mi sembra molto strano, anche perchè
di solito l'interfaccia PC viene alimentata dalla centralina gas quindi servono sia i +12v sia la massa.
Purtroppo non ho mai visto un BRC e non so dirti.... Per il software, se hai quello della centralina BRC
già dovrebbe darti info sulla sonda lambda... purtroppo non ho mai visto nemmeno questo.

10 di 15 02/05/2006 10.54
OmniAuto.it - FORUM [Powered by Invision Power Board] http://www.omniauto.it/forum/index.php?act=Print&client=print...

Ciao

Inviato da: cicciomio Aug 2 2005, 11:07 AM

ciao, carlo...
Ebbene si ! sono rimasto anch'io sopreso alla vista, tanto che, avendo una certa preparazione in
materia, e non sprovveduto.
Qui mi sono fermato, vorrei che qualcuno mi facesse un po di chiarezza in merito,
anche se ho notato che qui in pochi hanno il sequent, probabilmente perchè il piu ostico da
rovistare...
Comunque non mi do per vinto, devo riuscire a meterci mano, anche perchè vorrei settare la
centralina a pennello.
Ti ringrazio, se conoscessi qualche istrione in merito è gradita la possibilita di conversazione.
ciao

Ciao,
veramente rimango sorpreso di quello che dici... solo tre cavi mi sembra molto strano, anche
perchè di solito l'interfaccia PC viene alimentata dalla centralina gas quindi servono sia i +12v sia
la massa.
Purtroppo non ho mai visto un BRC e non so dirti.... Per il software, se hai quello della centralina
BRC già dovrebbe darti info sulla sonda lambda... purtroppo non ho mai visto nemmeno questo.
Ciao

[/quote]

Inviato da: fraant Sep 9 2005, 11:40 AM

[quote=cicciomio,Aug 2 2005, 12:07 PM]


ciao, carlo...
Ebbene si ! sono rimasto anch'io sopreso alla vista, tanto che, avendo una certa preparazione in
materia, e non sprovveduto.
Qui mi sono fermato, vorrei che qualcuno mi facesse un po di chiarezza in merito,
anche se ho notato che qui in pochi hanno il sequent, probabilmente perchè il piu ostico da
rovistare...
Comunque non mi do per vinto, devo riuscire a meterci mano, anche perchè vorrei settare la
centralina a pennello.
Ti ringrazio, se conoscessi qualche istrione in merito è gradita la possibilita di conversazione.
ciao

Ciao,
veramente rimango sorpreso di quello che dici... solo tre cavi mi sembra molto strano, anche
perchè di solito l'interfaccia PC viene alimentata dalla centralina gas quindi servono sia i +12v sia
la massa.
Purtroppo non ho mai visto un BRC e non so dirti.... Per il software, se hai quello della centralina
BRC già dovrebbe darti info sulla sonda lambda... purtroppo non ho mai visto nemmeno questo.
Ciao

[/quote]

[/quote]

Il software gira anche su win 2000 e XP testato e funzionante.

Inviato da: ALFONE Oct 18 2005, 12:51 PM

11 di 15 02/05/2006 10.54
OmniAuto.it - FORUM [Powered by Invision Power Board] http://www.omniauto.it/forum/index.php?act=Print&client=print...

Informo tutti che si tratta di una generica rs232 infatti io ho usato un cavo dati x
cellulare siemens s55

Funziona benissimo !!

Per gli amanti della usb esiste anche la possibilita' di usare un cavo usb.
Praticamete si prende un cavo dati x cellulare ... si stacca il connettore del cellulare e si collega il
connettore per la centralina gpl.

Ovviamente bisogna rispettare rx tx gnd e + 5V

Saluti.

Inviato da: lynx_deb Oct 18 2005, 12:57 PM

tale aggeggio è compatibile con l'ECU di un ROMANO RIS?


vedendo il connettore sono 4 poli.. e potrei anche avere il programma dal mio installatore

grazie per le info

Inviato da: ALFONE Oct 18 2005, 01:48 PM

[quote name='lynx_deb' date='Oct 18 2005, 01:57 PM' post='75754']


tale aggeggio è compatibile con l'ECU di un ROMANO RIS?
vedendo il connettore sono 4 poli.. e potrei anche avere il programma dal mio installatore

grazie per le info


[/quote]

certo che e' compatibile

Inviato da: lynx_deb Oct 18 2005, 02:11 PM

[quote name='ALFONE' date='Oct 18 2005, 02:48 PM' post='75771']


[quote name='lynx_deb' date='Oct 18 2005, 01:57 PM' post='75754']
tale aggeggio è compatibile con l'ECU di un ROMANO RIS?
vedendo il connettore sono 4 poli.. e potrei anche avere il programma dal mio installatore

grazie per le info


[/quote]

certo che e' compatibile

[/quote]

sicuro sicuro?
non è che poi pijo e fotto la centralina GPL?

thx

Inviato da: ALFONE Nov 23 2005, 10:39 AM

[quote name='ALFONE' date='Jun 10 2005, 06:03 PM' post='51289']


Ecco l' altro circuito....
[/quote]

rimetto in evidenza questo post viste le continue richieste.............

12 di 15 02/05/2006 10.54
OmniAuto.it - FORUM [Powered by Invision Power Board] http://www.omniauto.it/forum/index.php?act=Print&client=print...

Inviato da: Gig81 Nov 23 2005, 10:42 AM

Grazie...

Inviato da: lynx_deb Nov 23 2005, 01:58 PM

ok, io ho usato il primo schema e funziona..


per chi vuole programmarsi la sua centralina ROMANO, deve invertire TX ed RX nel connettore
altrimeni non funziona!

ciao

Inviato da: Gig81 Nov 23 2005, 02:28 PM

Io ho appena messo un LandiRenzo Omegas sulla mia Alfa147.


Ho già comprato tutti i componenti per il secondo schema,
appena faccio qualche test posto i risultati.
C'è qualche accorgimento particolare nel montaggio?
Che software usate? Quelli su emule?

Inviato da: Gig81 Nov 24 2005, 12:55 PM

Ma il software riconosce in automatico la porta COM a cui è collegata l'interfaccia o è necessario


qualche settaggio?

Inviato da: lynx_deb Nov 24 2005, 01:01 PM

riconosce in automatico

Inviato da: Bravo Wolf Feb 3 2006, 11:15 PM

Ragazzi ma qualcuno ha provato a costruirsi uno dei due schemi?


L'avete collegato? FUNZIONA?? Non c'è il rischio di danneggiare la centralina??

Inviato da: mystr Feb 4 2006, 12:21 AM

(Bravo Wolf @ Feb 3 2006, 11:15 PM)

Ragazzi ma qualcuno ha provato a costruirsi uno dei due schemi?


L'avete collegato? FUNZIONA?? Non c'è il rischio di danneggiare la centralina??

La centralina esplode, specie con la generic rs232 interface, non e' la trascrizione dell'interfaccia
originale, ripeto, non e'....

E' lo schema di un tostapane.

Inviato da: zxr400 Feb 7 2006, 02:51 PM

ciao a tutti, visti i miei continui problemi con miscela troppo magra e quindi la continua accensione
della spia controllo avari amotore sto pensando di seguiri le vostre sagge orme e farmi le
modifiche da solo.
ho pero 2 domande....
1- dove posso trovare il software per un impianto zavoli, dal sito non riesco a scaricarlo mi da

13 di 15 02/05/2006 10.54
OmniAuto.it - FORUM [Powered by Invision Power Board] http://www.omniauto.it/forum/index.php?act=Print&client=print...

sempre un errore quando cerci di registrarmi

2- come faccio a spegnere la spia dal cruscotto .......

grazie mille

Ciao Stefano

Inviato da: zxr400 Feb 7 2006, 03:47 PM

se non riesco dal sito della zavoli cosa devo cercare su emule ?

grazie

Inviato da: Joe Bar Feb 7 2006, 04:12 PM

messaggio privato per te

Inviato da: zxr400 Feb 12 2006, 07:58 PM

sabato ho guardato il cavo dell installatore mentre mi rimappava la centralina....


avveva 5 fili............
e aveva anche una scatola attacata prima del connettore ......
cos è quella scatola io pensavo di collegarmi direttamente con una seriale........
avete informazioni su come ci si collega ad un impianto zavoli ?

Inviato da: velox Mar 20 2006, 05:17 PM

---

Inviato da: ZEUS79 Apr 25 2006, 02:20 PM

(ALFONE @ Oct 18 2005, 01:51 PM)

Informo tutti che si tratta di una generica rs232 infatti io ho usato un cavo dati x cellulare
siemens s55

Funziona benissimo !!

Per gli amanti della usb esiste anche la possibilita' di usare un cavo usb.
Praticamete si prende un cavo dati x cellulare ... si stacca il connettore del cellulare e si collega il
connettore per la centralina gpl.

Ovviamente bisogna rispettare rx tx gnd e + 5V

Saluti.

Ma dici sul serio? Io mi ero costruito da solo il cavetto per il mio siemens M55...chissà dove ho messo
lo schema che ho seguito per costruirlo...meglio che gli dia una okkiata prima...

14 di 15 02/05/2006 10.54
OmniAuto.it - FORUM [Powered by Invision Power Board] http://www.omniauto.it/forum/index.php?act=Print&client=print...

Powered by Invision Power Board (http://www.invisionboard.com)


© Invision Power Services (http://www.invisionpower.com)

15 di 15 02/05/2006 10.54