Sei sulla pagina 1di 8

INFORMATICA

Corso di Laurea in SCIENZE INFERMIERISTICHE

Ing. R. Ceccarelli
Ing. A. Ammendolia

EXCEL: La Funzione CERCA.VERT

23/01/2020
Descrizione della FUNZIONE CERCA.VERT – 1 -
Cosa fa la funzione CERCA.VERT? CERCA.VERT cerca un valore1 nella prima colonna dell’intervallo
specificato di celle, e restituisce il valore2 di un’altra colonna della stessa riga dove è stato trovato il
valore1. La stringa “VERT” di CERCA.VERT sta per “verticale”. E’ utilizzata per differenziare CERCA.VERT
dalla funzione CERCA.ORIZZ che cerca un valore nella riga superiore di una matrice.
La sintassi della funzione CERCA.VERT è la seguente:
=CERCA.VERT(valore; matrice_tabella; indice; [intervallo])
Come potete vedere, la funzione CERCA.VERT di Microsoft Excel ha 4 parametri, o argomenti. I primi tre
parametri sono obbligatori, l’ultimo è facoltativo.
1. valore – il valore da cercare. Questo può essere un valore (numero, data o testo), o un riferimento di
cella(riferimento a una cella contenente un valore di ricerca), o il valore restituito da qualche altra
funzione di Excel. Ad esempio, la formula =CERCA.VERT(40; A2:B11; 2) cercherà il valore “40” .

2. matrice_tabella – due o più colonne di dati. La funzione CERCA.VERT cerca sempre il valore di ricerca
nella prima colonna di matrice_tabella. La vostra matrice_tabella può contenere valori diversi, come
testo, date, numeri o valori logici. Quindi, la nostra formula =CERCA.VERT(40; A2:B11; 2) cercherà “40”
nelle celle da A2 a A11 perché A è la prima colonna della matrice_tabella A2:B11.

3. indice – il numero di colonna in matrice_tabella da cui il valore nella riga corrispondente deve essere
restituito. La colonna più a sinistra della specificata matrice_tabella ha indice 1, la seconda colonna ha
indice 2, la terza colonna 3 e così via. La formula =CERCA.VERT(40; A2:B11; 2) cerca “40” nelle celle da
A2 a A11 e restituisce il valore corrispondente della colonna B (perché B è la seconda colonna della
specificata matrice_tabella A2:B11).

4. intervallo – specifica se siete alla ricerca di una corrispondenza esatta (FALSO) o di una corrispondenza
approssimativa (VERO o omesso). Questo ultimo parametro è opzionale ma molto importante.

Bozza per la discussione 2


Descrizione della FUNZIONE CERCA.VERT – 2 -

la formula =CERCA.VERT(40; A2:B11; 2), inserita nella cella D3,


restituisce il valore «Elefante».

Come fare CERCA.VERT da un altro foglio di lavoro


Nella pratica, le formule CERCA.VERT sono raramente utilizzate per trovare dati nello stesso foglio di lavoro. Il più
delle volte dovrete cercare e recuperare dati da un foglio diverso.
Per fare un CERCA.VERT da un foglio di Excel diverso, è necessario immettere il nome del foglio di lavoro e un
punto esclamativo nell’argomento matrice_tabella prima dell’intervallo di celle, ad esempio, =CERCA.VERT(40;
Foglio2!A2:B11; 2). La formula indica che l’intervallo di ricerca A2: B11 si trova in Foglio2.
Naturalmente, non è necessario digitare il nome del foglio manualmente. Basta iniziare a digitare la formula e,
quando si arriva all’argomento matrice_tabella, passare al foglio di lavoro di ricerca e selezionare l’intervallo
utilizzando il mouse.

E’ una buona idea utilizzare sempre i riferimenti di cella assoluti (con $) nell’argomento matrice_tabella delle
formule CERCA.VERT. In questo modo, l’intervallo di ricerca rimane costante quando si copia la formula in altre
celle. Bozza per la discussione 3
Come utilizzare intervalli denominati o celle di una tabella nelle formule
CERCA.VERT
Se pensate di utilizzare lo stesso intervallo di ricerca in diverse formule CERCA.VERT, è possibile creare un
intervallo denominato e digitare il suo nome direttamente nella formula anziché l’intervallo di ricerca
(argomento matrice_tabella)
Per creare un intervallo denominato, è sufficiente selezionare le celle e digitare un nome nella “Casella
del nome”, a sinistra della barra della formula. Nel caso in esame: «Prodotti».

Prodotti E ora potrete scrivere la seguente formula CERCA.VERT per ottenere


il prezzo di Prodotto 1:
=CERCA.VERT("Prodotto 1";Prodotti;2)

Se avete convertito un intervallo di celle in una tabella vera e


propria di Excel (scheda INSERISCI > Tabella), selezionando
l’intervallo di ricerca utilizzando il mouse, Microsoft Excel aggiungerà
automaticamente alla formula i nomi delle colonne (o il nome della
tabella nel caso in cui abbiate selezionato l’intera tabella):

Bozza per la discussione 4


Utilizzare caratteri jolly nelle formule CERCA.VERT
Così come in molte altre formule, è possibile utilizzare i seguenti caratteri jolly nella funzione
CERCA.VERT di Excel:

 Punto interrogativo (?) – Sostituisce qualunque carattere (singolo);


 Asterisco (*) – Sostituisce qualunque sequenza di caratteri.

Utilizzare i caratteri jolly nelle formule CERCA.VERT può rivelarsi davvero utile in molti casi:
 Se non ricordate il testo esatto che state cercando
 Se si vuole trovare una parola che è solo una parte del contenuto della cella. Siate consapevoli del
fatto che la funzione CERCA.VERT cerca l’intero contenuto della cella, come se aveste selezionato
l’opzione “Confronta intero contenuto della cella” nella finestra standard “trova e sostituisci” di Excel
 Quando una colonna di ricerca contenga degli spazi aggiuntivi in testa, in mezzo o in coda al testo che
cerchiamo.

Ecco alcuni altri esempi di formule CERCA.VERT con caratteri jolly:


=CERCA.VERT(“*rio”;$A$2:$C$25;1;FALSO) – per trovare un nome che termina in “rio”
=CERCA.VERT(“co*de”;$A$2:$C$25;1;FALSO) – per trovare un nome che inizia con “co” e finisce con “de”
=CERCA.VERT(“???????????”;$A$2:$C$25;1;FALSO) – trovare un nome lungo 11 caratteri

N.B. Perché una formula CERCA.VERT con caratteri jolly funzioni correttamente, è sempre necessario
aggiungere FALSO come ultimo parametro. Se l’intervallo di ricerca contiene più di una voce che
soddisfa i criteri jolly, verrà restituito il primo valore trovato.

Bozza per la discussione 5


Usare le formule CERCA.VERT con corrispondenza esatta o approssimativa -1-
Vediamo cosa significa in realtà “corrispondenza esatta” o “corrispondenza approssimativa”
per Microsoft Excel .
 Se intervallo è impostato su FALSO, la formula cercherà una corrispondenza esatta, vale a dire il
valore di ricerca esattamente come lo avete inserito nel primo parametro (valore). Se nella prima
colonna di matrice_tabella ci sono due o più valori che corrispondono al valore di ricerca, viene
restituito il primo valore trovato. Se non viene trovata nessuna corrispondenza esatta, viene
restituito un errore #N/D
 Se intervallo è impostato su VERO o omesso, la formula cerca una corrispondenza approssimativa.
Più precisamente, la formula CERCA.VERT cercherà prima una corrispondenza esatta e, se non viene
trovata una corrispondenza esatta, restituirà una corrispondenza approssimativa. Una
corrispondenza approssimativa è il valore più grande inferiore al parametro “valore”.

N.B. Se immettete VERO o omettete l’argomento intervallo, i valori della prima colonna dell’intervallo
di ricerca devono essere ordinati in ordine crescente, cioè dal più piccolo al più grande. Altrimenti, la
funzione CERCA.VERT di Excel non potrà trovare il valore corretto.

La funzione CERCA.VERT con corrispondenza


esatta restituisce il 1° valore trovato che
corrisponde al valore di ricerca. Vedere
esempio a fianco:

Bozza per la discussione 6


Usare le formule CERCA.VERT con corrispondenza esatta o approssimativa -2-
Quando si utilizzano formule CERCA.VERT con corrispondenza approssimativa, cioè con “intervallo”
impostato su VERO o omesso, la prima cosa che dovete fare è ordinare la prima colonna del vostro
intervallo di ricerca in ordine crescente.
Questo è molto importante perché la formula CERCA.VERT troverà il valore immediatamente più grande
del valore di ricerca specificato e quindi interromperà la ricerca restituendo il valore precedente in
elenco. Se si trascura di ordinare correttamente i dati, si finirà per avere risultati strani o un errore di
#N/D.

Come vedete, la prima formula, che ricerca il valore “48” come nell’esempio fatto per la corrispondenza
esatta, questa volta restituisce “Orso Grizzly” piuttosto che “Cervo”: questo perché Excel trova il valore
immediatamente superiore al valore di ricerca (57) e restituisce il valore che lo precede in elenco.

La seconda formula, che ricerca il valore “100”, restituisce invece “Struzzo” la cui velocità è 69 km/h,
mentre abbiamo anche “Ghepardo” che corre 101 km/h, e 101 è molto più vicino a 100 che 69, non è
vero? Allora, perché? Perché la funzione CERCA.VERT con corrispondenza approssimativa restituisce il
valore più grande immediatamente inferiore al valore di ricerca.
Bozza per la discussione 7
La funzione CERCA.VERT

Grazie per l’attenzione

Bozza per la discussione 8

Potrebbero piacerti anche