Sei sulla pagina 1di 4

Configuration and Verification Examples

This example shows how to configure the Gigabit Ethernet port 5/8 as an 802.1Q trunk. This example
assumes that the neighbor port is configured to support 802.1Q trunking:

Router# configure terminal


Router(config)# interface gigabitethernet 5/8
Router(config-if)# shutdown
Router(config-if)# switchport
Router(config-if)# switchport mode dynamic desirable
Router(config-if)# no shutdown
Router(config-if)# end
Router# exit

Router# show running-config interface gigabitethernet 5/8


Router# show interfaces gigabitethernet 5/8 switchport
Router# show interfaces gigabitethernet 5/8 trunk

Configuring a LAN Interface as a Layer 2 Access Port

This example shows how to configure the Gigabit Ethernet port 5/6 as an access port in VLAN 200:

Router# configure terminal


Router(config)# interface gigabitethernet 5/6
Router(config-if)# shutdown
Router(config-if)# switchport
Router(config-if)# switchport mode access
Router(config-if)# switchport access vlan 200
Router(config-if)# no shutdown
Router(config-if)# end
Router# exit

Configuring the 802.1Q Native VLAN


Router(config-if)# switchport trunk native vlan vlan_ID
Configuring the List of VLANs Allowed on a Trunk
Router(config-if)# switchport trunk allowed
vlan [ add | except | none | remove ] vlan [, vlan [, vlan [,...]]

Configuring a LAN Port for Layer 2 Switching

Router(config)# interface type slot/port


Router(config-if)# shutdown
Router(config-if)# switchport
Router(config-if)# no shutdown
Router(config-if)# end
This example shows how to enable STP on VLAN 200:
Router# configure terminal
Router(config)# spanning-tree vlan 200
Router(config)# end
Router#

Router# show spanning-tree vlan 200

This example shows how to configure the switch as the root bridge for VLAN 10, with a network
diameter of 4:

Router# configure terminal


Router(config)# spanning-tree vlan 10 root primary diameter 4
Router(config)# end
Router#

Router# configure terminal


Router(config)# spanning-tree vlan 10 root secondary diameter 4
Router(config)# end
Router#

Configuring STP Port Priority


This example shows how to configure the STP port priority of Gigabit Ethernet port 1/4:

Router# configure terminal


Router(config)# interface gigabitethernet 1/4
Router(config-if)# spanning-tree port-priority 160
Router(config-if)# end
Router#

Router# show spanning-tree interface gigabitethernet 1/4

This example shows how to configure the VLAN port priority of Gigabit Ethernet port 1/4:

Router# configure terminal


Router(config)# interface gigabitethernet 1/4
Router(config-if)# spanning-tree vlan 200 port-priority 64
Router(config-if)# end
Router#

Router# show spanning-tree interface gigabitethernet 1/4

You also can display spanning tree information for VLAN 200 using the following command:
Router# show spanning-tree vlan 200 interface gigabitethernet 1/4

Configuring the Bridge Priority of a VLAN

This example shows how to configure the bridge priority of VLAN 200 to 33792 when the extended
system ID is disabled:

Router# configure terminal


Router(config)# spanning-tree vlan 200 priority 32768
Router(config)# end
Router#

Router# show spanning-tree vlan 200 bridge

How to Form a Catalyst 3850 Data-Stack and Power-Stack

On the show switch output verify that the current state of all switches is READY.

Switch#show switch

On the show switch stack-ports verify that all the ports are shown as OK, that is an indication that
the stack-wise cables are working properly:

Switch#show switch stack-ports

After the switch has come up, collect the following :

* show switch

* show switch stack-ports

* sh version

Assigning a Stack Member Number

Switch# switch 3 renumber 4


Switch# reload slot 4

Setting the Stack Member Priority Value

Switch enable
Switch# switch 3 priority 2
Switch# show switch
Switch# copy running-config startup-config

Provisioning a New Member for a Switch Stack


Switch# show switch
Switch# configure terminal
Switch(config)# switch 3 provision WS-xxxx
Switch(config)# end
Switch# copy running-config startup-config

Removing Provisioned Switch Information

Switch# configure terminal


Switch(config)# no switch 3 provision
Switch(config)# end
Switch# copy running-config startup-config

Accessing the Diagnostic Console of a Stack Member


This optional task is available only from the active switch.
Switch# session switch 2
Switch(diag)> exit

Temporarily Disabling a Stack Port


Switch# switch 2 stack port 1 disable
Switch# switch 2 stack port 1 enable
Switch# show switch stack-ports summary
Switch# show running-config | include switch 2
Switch(config)# switch 2 provision switch_PID

Potrebbero piacerti anche