Sei sulla pagina 1di 2

Configurazione base

Router>enable Accede alla modalità privilegiata


Router#conf term Accede alla configurazione globale
SW1(config)#hostname R1 Assegna al router un nome host
R1(config)#line con 0 Configura accesso via console
R1(config-line)#password cisco Assegna una password per l’accesso via console
R1(config-line)#login Obbliga ad inserire credenziali di accesso
R1(config-line)#line vty 0 15 Configura accesso remoto
R1(config-line)#password cisco Assegna una password per l’accesso remoto
R1(config-line)#login Obbliga ad inserire credenziali di accesso
R1(config-line)#exit Termina configurazione
R1(config)#enable secret class Assegna password criptata per il passaggio alla modalità privilegiata
R1(config)#interface fa0/0 Accede alla configurazione dell’interfaccia FastEthernet 0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0 Assegna all’interfaccia indirizzo e maschera di sottorete
R1(config-if)# description Router Office LAN Assegna un identificativo all’interfaccia
R1(config-if)#no shutdown Attiva l’interfaccia
R1(config-if)#exit Termina la configurazione dell’interfaccia

Rotta statica e Default route:


R1(config)#ip route 192.168.1.0 255.255.255.0 192.168.1.2 Fai uscire attraverso l’interfaccia con indirizzo
192.168.1.2 tutti i pacchetti destinati alla rete
192.168.1.0 – 255.255.255.0
R1(config)#ip route 0.0.0.0 0.0.0.0 s0 Qualunque pacchetto che “non sai come gestire”, fallo
uscire sulla seriale s0
RIP
R1(config)#router rip Attiva il protocollo rip
R1(config-router)#network 192.168.1.0 Gestisci col suddetto protocollo l’interfaccia connessa alla rete 192.168.1.0
R1(config-router)#network 192.168.2.0 Gestisci col suddetto protocollo l’interfaccia connessa alla rete 192.168.2.0
Di default (impostazione predefinita) “riassume” alla network maggiore e non supporta il VSLM

http://www.areanetworking.it/appunti-ccna-640-802.html

riepilogando, lo schema degli indirizzi IP appena ricavato, può essere rappresentato nella forma descritta nella tabella 5.11.
Tabella 5.11: Schema degli indirizzi IP
Spazio di indirizzamento iniziale: 10.0.0.0/8
10.1.0.0/16
10.1.1.0/24 Subnet 1 Milano
10.1.2.0/24 Subnet 2 Milano
10.1.3.0/24 Subnet 3 Milano

10.2.0.0/16
10.2.1.0/24 Subnet 1 Roma
10.2.2.0/24 Subnet 2 Roma
10.2.3.0/24 Subnet 3 Roma

10.3.0.0/16
10.3.1.0/24 Subnet 1 Cagliari
10.3.2.0/24 Subnet 2 Cagliari
10.3.3.0/24 Subnet 3 Cagliari

10.4.0.0/16
10.4.1.0/24 Subnet 1 Palermo
10.4.2.0/24 Subnet 2 Palermo
10.4.3.0/24 Subnet 3 Palermo

Subnetting e protocolli di routing


In questa sezione viene trattato l’aspetto matematico del subnetting e non vengono presi in conto, volutamente, considerazioni legate al tipo di protocolli di routing
daselezionare. A tale proposito, come si vedrà nella sezione dedicata ai protocolli di routing, è necessario valutare attentamente quale protocollo implementare sui
rou-ter in caso di subnetting soprattutto di tipo VLSM/CIDR, laddove la subnet mask è per definizione variabile e quindi il protocollo di routing deve interpretare i
singoli indirizzi estrapolandoli dalla classe di appartenenza standard (A, B, C). Infatti, se così non fosse,un protocollo di routing in un contesto di subnetting in
classe A come quello dell’esempio precedente, valuterebbe tutte gli indirizzi del tipo 10.x.y.0 come appartenenti alla stessa network di classe A 10.0.0.0/8.I
protocolli di rounting che “ragionano” in questo modo vengono definiti di tipoClassFull (per esempio: RIPv1).Viceversa, i protocolli che applicano sempre e
comunque la subnet mask al fine di stabilire la subnet di appartenenza di un indirizzo IP vengono definiti di tipoClassLess.Alcuni esempi di protocolli di questo
tipo sono:RIPv2 e OSPF.In tal caso si dice anche che essi applicano dei meccanismi di “summarization”al fine di sintetiz-zare l’identificazione di gruppi di host in
base alla subnet mask specificata.Per con-tro, i protocolli di tipo ClassFull applicano dei criteri di “auto-summarization” ba-sandosi esclusivamente sulla
valutazione della classe standard di appartenenza del-l’indirizzo IP.
Internet Protocol version 4 (IPv4)