Sei sulla pagina 1di 33

ABOUT

This project all about building a network


topology using networking devices as well
as end devices and configuring using IP
addresses and any routing protocol.

MAHABALE ABHISHEK CHANDRAKANT


AIM
Implementing 5 routers, 5
COMPUTER switches, 20 PC’s Topology
using IPv4 and RIP
NETWORKS Protocol.

Brings World Closer In Your Pocket


MAHATMA EDUCATION SOCIETY’’S

PILLAI’S COLLEGE OF ARTS, COMMERECE


& SCIENCE
(AUTONOMOUS INSTITUTION AFFILATED TO THE UNIVERSITY OF MUMBAI)

DR K.M. VASUDEVAN PILLAI CAMPUS, SECTOR 16, NEW PANVEL 410206.

(NAAC ACCREDITED ‘A’ GRADE)

CERTIFICATE

THIS IS TO CERTIFY THAT MS/MR MAHABALE ABHISHEK CHANDRAKANT

ROLL NO         6334     , DIV    B     , CLASS     SYBSCIT                    HAS WORKED AND


DULY COMPLETED HER/HIS PROJECT WORK FOR THE BACHELOR IN SCIENCE

(INFORMATION TECHNOLOGY) UNDER THE FACULTY OF SCIENCE IN THE


SUBJECT ’OF

   COMPUTER NETWORKING               AND PROJECT ENTITLED

Implementing 5 routers, 5 switches, 20 PC’s Topology using IPv4 and RIP

Protocol

I FURTHER CERTIFY THAT THE ENTIRE WORK HAS BEEN DONE BY THE LEARNER

AND SUCCESSFULLY COMPLETED HIS PROJECT WORK FOR SEMESTER-III YEAR

2020-2021.

ASST. PROF. DHANYA


VINISH

1|Page
Index

Sr. No. Name Page No.

1. Topology Diagram 3

2. Router Configuration 4-13

3. End Devices Configuration 14-23

3. Command Prompt Output using Ping 24

Command

4. Interfaces and IP Information Table 25

5. Project Description & Overview 26-32

2|Page
Topology of computer network project:

3|Page
Router Configuration

 Router 0 Configuration:
1. Router interfaces configuration:
Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int fa0/0
Router(config-if)#ip add 195.5.1.1 255.255.255.0
Router(config-if)#no shut
Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0,
changed state to up
exit
Router(config)#int se2/0
Router(config-if)#ip add 196.5.2.2 255.255.255.0
Router(config-if)#no shut
%LINK-5-CHANGED: Interface Serial2/0, changed state to down
Router(config-if)#int se3/0
Router(config-if)#ip add 196.5.6.2 255.255.255.0
Router(config-if)#no shut
%LINK-5-CHANGED: Interface Serial3/0, changed state to down
Router(config-if)#exit

2. Router RIP configuration in router:

4|Page
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router rip
Router(config-router)#network 195.5.1.0
Router(config-router)#network 196.5.2.0
Router(config-router)#network 196.5.6.0
Router(config-router)#exit
Router(config)#^Z
Router#
%SYS-5-CONFIG_I: Configured from console by console
wr
Building configuration...
[OK]
Router#

5|Page
 Router 1 Configuration:
1. Router interfaces configuration:
Router>EN
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int fa0/0
Router(config-if)#ip add 195.5.2.1 255.255.255.0
Router(config-if)#no shut
Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0,
changed state to up
exit
Router(config)#int se3/0
Router(config-if)#ip add 196.5.3.0 255.255.255.0
Router(config-if)#no shut
%LINK-5-CHANGED: Interface Serial3/0, changed state to down
Router(config-if)#exit
Router(config)#int se2/0
Router(config-if)#ip add 196.5.2.1 255.255.255.0
Router(config-if)#no shut
Router(config-if)#
%LINK-5-CHANGED: Interface Serial2/0, changed state to up
Exit

6|Page
2. Router RIP configuration in router:
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router rip
Router(config-router)#network 195.5.2.0
Router(config-router)#network 196.5.2.0
Router(config-router)#network 196.5.3.0
Router(config-router)#exit
Router(config)#^Z
Router#
%SYS-5-CONFIG_I: Configured from console by console
wr
Building configuration...
[OK]

7|Page
 Router 2 Configuration:
1. Router interfaces configuration:
Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int fa0/0
Router(config-if)#ip add 195.5.3.1 255.255.255.0
Router(config-if)#no shut
Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0,
changed state to up
exit
Router(config)#int se3/0
Router(config-if)#ip add 196.5.3.2 255.255.255.0
Router(config-if)#no shut
Router(config-if)#
%LINK-5-CHANGED: Interface Serial3/0, changed state to up
exit
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/0, changed
state to up
Router(config)#int se2/0
Router(config-if)#ip add 196.5.4.1 255.255.255.0
Router(config-if)#no shut
%LINK-5-CHANGED: Interface Serial2/0, changed state to down
Router(config-if)#exit

8|Page
2. Router RIP configuration in router:
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router rip
Router(config-router)#network 195.5.3.0
Router(config-router)#network 196.5.3.2
Router(config-router)#network 196.5.4.0
Router(config-router)#exit
Router(config)#^Z
Router#
%SYS-5-CONFIG_I: Configured from console by console
wr
Building configuration...
[OK]
Router#

9|Page
 Router 3 configuration:
1. Router interfaces configuration:
Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int fa0/0
Router(config-if)#ip add 195.5.4.1 255.255.255.0
Router(config-if)#no shut
Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0,
changed state to up
exit
Router(config)#int se2/0
Router(config-if)#ip add 196.5.4.2 255.255.255.0
Router(config-if)#no shut
Router(config-if)#
%LINK-5-CHANGED: Interface Serial2/0, changed state to up
exit
Router(config)#int se3/0
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed
state to up
Router(config-if)#ip add 196.5.5.1 255.255.255.0
Router(config-if)#no shut
%LINK-5-CHANGED: Interface Serial3/0, changed state to down
Router(config-if)#exit
Router(config)#^Z
Router#
10 | P a g e
%SYS-5-CONFIG_I: Configured from console by console

2. Router RIP configuration in router:


Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router rip
Router(config-router)#network 195.5.4.0
Router(config-router)#network 196.5.4.0
Router(config-router)#network 196.5.5.0
Router(config-router)#exit
Router(config)#^Z
Router#
%SYS-5-CONFIG_I: Configured from console by console
wr
Building configuration...
[OK]
Router#

11 | P a g e
 Router 4 configuration:
1. Router interfaces configuration:
Router>EN
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int fa0/0
Router(config-if)#ip add 195.5.5.1 255.255.255.0
Router(config-if)#no shut
Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0,
changed state to up
exit
Router(config)#int se3/0
Router(config-if)#ip add 196.5.5.2 255.255.255.0
Router(config-if)#no shut
Router(config-if)#
%LINK-5-CHANGED: Interface Serial3/0, changed state to up
exit
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/0, changed
state to up
Router(config)#int se2/0
Router(config-if)#ip add 196.5.6.1 255.255.255.0
Router(config-if)#no shut
Router(config-if)#
%LINK-5-CHANGED: Interface Serial2/0, changed state to up
Exit

12 | P a g e
2. Router RIP configuration in router:
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router rip
Router(config-router)#network 195.5.5.0
Router(config-router)#network 196.5.5.0
Router(config-router)#network 196.5.6.0
Router(config-router)#exit
Router(config)#^Z
Router#
%SYS-5-CONFIG_I: Configured from console by console
wr
Building configuration...
[OK]
Router#

13 | P a g e
End devices configuration

1. End devices in network 195.5.1.0 :

A. Pc0 :

B. Pc1:

14 | P a g e
C. Pc2:

D. Pc3:

15 | P a g e
2. End devices in network 195.5.2.0:

A. Pc4:

B. Pc5:

16 | P a g e
C. Pc6:

D. Pc7:

17 | P a g e
3. End devices in network 192.168.3.0:

A. Pc8:

B. Pc9:

18 | P a g e
C. Pc10:

D. Pc11:

4. End devices in network 195.5.4.0:

19 | P a g e
A. Pc12:

B. Pc13:

C. Pc14:
20 | P a g e
D. Pc15:

5. End devices in network 195.5.5.0:

21 | P a g e
A. Pc16:

B. Pc17:

22 | P a g e
C. Pc18:

D. Pc19:

23 | P a g e
Command prompt Ping command output

 Ping command: Ping is a computer network administration software


utility used to test the reachability of a host.

1. Ping 1:

24 | P a g e
Interfaces and IP Information Table

Sr No Interface Router IP address Subnet Mask

1. Fa0/0 Router 0 195.5.1.0 255.255.255.0

2. Se2/0 Router 0 196.5.2.2 255.255.255.0

3. Se3/0 Router 0 196.5.6.2 255.255.255.0

4. Fa0/0 Router 1 195.5.2.1 255.255.255.0

5. Se3/0 Router 1 196.5.3.1 255.255.255.0

6. Se2/0 Router 1 196.5.2.1 255.255.255.0

7. Fa0/0 Router 2 195.5.3.1 255.255.255.0

8. Se3/0 Router 2 196.5.3.2 255.255.255.0

9. Se2/0 Router 2 196.5.4.1 255.255.255.0

10. Fa0/0 Router 3 195.5.4.1 255.255.255.0

11. Se2/0 Router 3 196.5.4.2 255.255.255.0

12. Se3/0 Router 3 196.5.5.1 255.255.255.0

13. Fa0/0 Router 4 195.5.5.1 255.255.255.0

14. Se3/0 Router 4 196.5.5.2 255.255.255.0

15. Se2/0 Router 4 195.5.6.1 255.255.255.0

25 | P a g e
Project Description

 Aim: Implementing 5 routers, 5 switches, 20 PC’s Topology using IPv4,


RIP
 Prerequisites:
1. Basic knowledge of IPv4 addressing, topology and routing protocols.
2. Basic knowledge of how cisco packet tracer works

 What is the use of Packet Tracer: Cisco Packet Tracer version 7.2 which
is powerful network simulation tool built by cisco to give user a real life
scenario how computer networks actually works in real time.

 Networking devices used in this project:


1. What is a Switch and why we are using switches : A switch is a
networking device in a computer network that connects multiple devices
together and multiple cables are plugged into switch to enable
communication between different networking devices.
Use :- Each networked device connected to a switch can be identified using
a MAC address, allowing the switch to regulate the flow of traffic.

2. What is the key advantage of using switches ?


Switches reduce the workload on individual computers. Switches increase
network performance. Networks that include switches experience fewer
frame collisions because switches create collision domains for each
connection (a process called micro segmentation)

26 | P a g e
 What are routers ?
Routers: A router is networking device that is designed to receive,
analyze and move incoming packets to another networks. Router
maintains routing table which includes source address and destination
address of packets to be send or receive.

 What is the difference between Router and Switch:

Sr. no. Routers Switches


1. Connects various networks Connects various devices through
simultaneously. cables simultaneously.
2. Routers work on network layer. Switches work on data link layer.
3. Routers used by different Switch is only used in Lan.
network types like LAN,WAN
etc.
4. Data is sent in the form of Data is sent in the form of frames in
packets in router switches.

 What are the different types cables that are used in routing ?
1. Copper straight-through: Copper straight-through is a type of twisted pair
cable that is used in local area networks to connect computer to hub such as
router.
2. Copper cross-over: Copper cross-over cable is a type of Ethernet cable used
to connect computing devices together directly.
3. Serial DCE: Serial cables are used to transfer information between two
devices using serial communication protocol.

 Define IP Address ?

27 | P a g e
IPv4: It stands for Internet Protocol Version 4 which is fourth version of
Internet Protocol and it is most widely used core protocol standard based
internetworking methods in internet and packet switched networks.

 What is Network Subnet ?


Subnet: A subnet or subnetwork is a logical subdivision of an IP network
and it helps to keep network organized and functional.

 Can IP address be assigned to layer 2? :

We cannot assign IP address to data link layer as it uses physical addressing and
data is present in the form of frames. IP address used by network layer and data
is in the form of packets for transmission of data.

 What are the different class and ranges of IP addresses ?


Classful IP addressing:

Sr. Class IP Default No of No of Hosts


no. Range subnet mask Networks
1. 0 to 127 255.0.0.0 2^7 = 128 2^24 = 16777216
2. 128 to 191 255.255.0.0 2^14 = 16384 2^16 = 65536
3. 192 to 223 255.255.255.0 2^21=2097152 2^8 = 256
4. 224 to 239 Reserved for multicasting
5. 240 to 255 Reserved for research and development

 What is Private IP and Public IP ?


Private IP address and public IP address:

28 | P a g e
a. Private IP address: Private ip addresses area those which area been used
only in local area network and cannot transfer network traffic on that
networks.
b. Public IP address: Public IP address are those addresses which are used
outside local area network i.e. Internet and those addresses are used to
access internet.

 What is the difference between Static and Dynamic IP Addresses ?


Static IP address vs Dynamic IP address:

Sr. no. Dynamic IP Static IP


1. Dynamic IP addresses are Static IP addresses are need to be
assigned to system assigned to system manually.
dynamically in random
manner.
2. It is easier to assign dynamic It is difficult to assign manually to
IP addresses to system. number of systems.
3. It provides less security to It provides high security to systems.
systems.

 What is Routing ?

Routing is the process of selecting path across one or more networks for
transmission data. There are mostly two types of routing methods used i.e. static
routing and dynamic routing.

I. Static routing: In static routing user or administrator sets the routing


path statically and which is need to be updated manually.

29 | P a g e
II. Dynamic routing: In dynamic routing , routes are updated automatically
in dynamic manner.

 What is Routing ?
Routing is the process of selecting a path for traffic in a network or
between or across multiple networks. Broadly, routing is performed in
many types of networks, including circuit-switched networks, such as the
public switched telephone network, and computer networks, such as the
Internet.

 What do you understand by ‘Protocol’ in Networking ?


A network protocol is an established set of rules that determine how data
is transmitted between different devices in the same network. Essentially,
it allows connected devices to communicate with each other, regardless
of any differences in their internal processes, structure or design.

 In your Project which Protocol you have used RIP or OSPF ?


I have used RIP.

 What is RIP ? Describe it.


RIP: It stands for Routing Information Protocol which dynamic routing
protocol which uses hop count as routing metric to find best path between
source and destination network. It is distance routing vector protocol.

 What is OSPF ? Describe it.

30 | P a g e
OSPF : Open Shortest Path First is a routing protocol for Internet
Protocol networks. It uses a link state routing algorithm and falls into the
group of interior gateway protocols, operating within a single
autonomous system.

 What is Ping used for ?


Ping is a computer network administration software utility used to test
the reachability of a host on an Internet Protocol (IP) network.

Project Overview
31 | P a g e
1. Here in this project we have designed a topology for 5 Router, 5 Switches,
20 PC’s using different networking devices which includes Routers,
Switches, Connecting cables such as copper-straight through, serial DCE
and copper-cross over etc.
2. We are connecting 4 pc through 1 switch and then switch is connected to
router in each network.
3. Then we are connecting each router network with each other through serial
DCE cable.
4. Here switch act as gateway to network we created. Data that is transferred
will use that default router to move data between networks.

Project done by : 6334 SYIT ( B )

32 | P a g e

Potrebbero piacerti anche