Sei sulla pagina 1di 7

UNIVERSIDAD NACIONAL ABIERTA Y A DISTANCIA UNAD 1

ECBTI- INGENIERIA ELECTRONICA


PROGRAMACIÓN

PROGRAMACIÓN

ESTUDIANTES:

MIGUEL ANGEL RODRIGUEZ

CÓD:

ALEJANDRO MARIÑO

CÓD: 1016035870

ROBINSON QUINTERO C

CÓD: 80157633

TUTOR:

LUIS FERNANDO ARIAS RAMIREZ

UNIVERSIDAD NACIONAL ABIERTA Y A DISTANCIA UNAD


UNIVERSIDAD NACIONAL ABIERTA Y A DISTANCIA UNAD 2
ECBTI- INGENIERIA ELECTRONICA
PROGRAMACIÓN

INTRODUCCIÓN:

El presente trabajo hace referencia al curso

PROGRAMACIÓN destinado para la actividad llamada Proyecto Final con énfasis en Producción

Intelectual. Aplicando los conocimientos y competencias previamente adquiridos durante el curso,

nos indica brindar una solución en código C++ a un determinado problema.

Se presentan los diagramas de flujo y el código fuente para así

realizar un programa codificado en lenguaje C++ aplicando los temas y conocimientos como por

ejemplo: funciones, menú de opciones, estructuras, entre otros.

Además se incluyen Diagramas de Flujo en el software PSeInt y un

código base el cual se utiliza para desarrollar el programa en código C++.


UNIVERSIDAD NACIONAL ABIERTA Y A DISTANCIA UNAD 3
ECBTI- INGENIERIA ELECTRONICA
PROGRAMACIÓN

Actividad en grupo: el grupo debe analizar el siguiente escenario:

El señor Pipe Peláez tiene un granero en la plaza de las

Nieves, distribuye Arroz, Frijol, Garbanzo, Arveja, Cebada y Maíz, a razón de $2500.oo libra. Si

un cliente compra más de 25 libras le descuenta el 5% y si compra más de 35 le descuenta el 10%.

Este señor quiere contratar a Elías, Álvaro y Rosa como vendedores a los cuales les da el 2% de

comisión sobre las ventas.

Se encuentra preocupado porque no sabe cómo controlar los

movimientos que realiza en su granero y en algunas ocasiones le ha pagado más dinero del que se

debe a sus empleados. El cree que sus problemas se acaban, con el desarrollo de un programa en

C++
UNIVERSIDAD NACIONAL ABIERTA Y A DISTANCIA UNAD 4
ECBTI- INGENIERIA ELECTRONICA
PROGRAMACIÓN

Identificación del problema:

Control erróneo de movimientos tanto en productos como financieros.

Objetivo General:

Desarrollar un programa en lenguaje C++ dando solución a las incógnitas planteadas, como lo son

los descuentos y las comisiones

Objetivos Específicos:

 Brindar una efectiva solución al Sr Felipe Peláez para su total tranquilidad.

 Utilizar los temas adquiridos en el presente curso.

 Obtener diferentes soluciones para entre todos dar la mejor respuesta.


UNIVERSIDAD NACIONAL ABIERTA Y A DISTANCIA UNAD 5
ECBTI- INGENIERIA ELECTRONICA
PROGRAMACIÓN

Diagrama de Flujo en PSeInt “Primera parte”:

Diagrama de Flujo en PSeInt “Finalizado”:


UNIVERSIDAD NACIONAL ABIERTA Y A DISTANCIA UNAD 6
ECBTI- INGENIERIA ELECTRONICA
PROGRAMACIÓN

Código en PSeInt:

Algoritmo proyecto_final
Repetir
Escribir "Seleccione una de las siguientes opciones: "
Escribir "1: Calcular el valor de las ventas."
Escribir "2: Valor de la comisión al empleado."
Escribir "3: Salir."
Leer Op
Segun Op Hacer
1:
Escribir 'Introduzca cantidad de libras compradas.'
Leer x
Si x<24 O x=24 Entonces
Escribir 'El precio total es: $',x*2500
Sino
Si x=25 O x<35 Entonces
z <- (x*2500)
a <- (z*0.05)
Escribir 'El precio con descuento incluido es de: $',z-a
Sino
Si x=35 O x>35 Entonces
b <- (x*2500)
d <- (b*0.10)
Escribir 'El precio con descuento incluido es de: $',b-d
FinSi
FinSi
FinSi
2:
Escribir "Ingrese el valor total de las ventas de c/u de los empleados."
Leer k
Escribir "Valor total por comisión es: $" k*0.02

3:
Escribir "Gracias, vuelva pronto."

De Otro Modo:
Escribir "Opción NO VÁLIDA."
FinSegun
Escribir 'Pulse cualquier tecla para continuar.'
Leer p
Borrar Pantalla
Hasta Que Op=3
FinAlgoritmo
UNIVERSIDAD NACIONAL ABIERTA Y A DISTANCIA UNAD 7
ECBTI- INGENIERIA ELECTRONICA
PROGRAMACIÓN

Primera parte código fuente C++ en programa ZinjaI

#include <stdio.h>
#include <stdlib.h>
int main(int argc, char *argv[])
{
printf ("Seleccione una de las siguientes opciones: ");
printf(" ");
int Opcion,x,u,s;

do {
printf("\n1.- Calcular el valor de las ventas.");
printf("\n2.- Valor de la comision al empleado.");
printf("\n3.- Salir");
printf("\n ");
printf("\nOpción...: ");
scanf(" %d",&Opcion);
switch(Opcion) {
case 1:
printf ("Introduzca cantidad de libras compradas: ");
scanf(" %d",&x);
printf("El precio total es: $");
break;
case 2:
printf("Ingrese el valor total de las ventas de c/u de los empleados:
");
scanf(" %e",&u);
s=u*0.02;
printf("Valor total por comisión es: ",s);
break;
case 3:
printf("Gracias, vuelva pronto.");
break; }
} while(Opcion!=3);
return 0;
}