Sei sulla pagina 1di 10

UAB – UNIVERSIDADE ABERTA DO BRASIL

IFMT – INSTITUTO FEDERAL DE MATO GROSSO


PÓS-GRADUAÇÃO LATU SENSU EM REDES E COMPUTAÇÃO DISTRIBUÍDA

REDES DE COMPUTADORES
ATIVIDADE 04 - LABORÁRIOS DE CENÁRIOS DE ROTEAMENTOS NO GNS3

CUIABÁ – MT
2019
UAB – UNIVERSIDADE ABERTA DO BRASIL
IFMT – INSTITUTO FEDERAL DE MATO GROSSO
PÓS-GRADUAÇÃO LATU SENSU EM REDES E COMPUTAÇÃO DISTRIBUÍDA

REDES DE COMPUTADORES
ATIVIDADE 04 - LABORÁRIOS DE CENÁRIOS DE ROTEAMENTOS NO GNS3

Curso: Pós-Graduação Latu Senso em Redes e C.


Distribuída.
Disciplina: Redes de Computadores
Docente: Guilherme Almeida
Discentes: Alan P. Heleno,
Felipe Fonteles Belo,
Hugo Leonardo Santos de Almeida
Jackson Duarte Vilela
Leonardo Do Espírito Santo Da Silva

CUIABÁ – MT
2019
RESUMO

Este trabalho tem o propósito de apresentar 9 laboratórios implementados no software


emulador de redes GNS3, onde aplicamos configurações de rede em roteadores
Cisco. Cada cenário possui sua particularidade e também encontramos coisas em
comum, como por exemplo, a configuração de interfaces de rede e alguns protocolos
de roteamento. Veremos sobre Rotas flutuantes, Restrição de banda policing e
shaping, Roteamento avançado utilizando o protocolo de roteamento OSPF,
Autenticação IPSec do OSPF v3 no roteamento IPv6, Protocolo PIM-DM no
roteamento multicast, VPN site-to-site em redes IPv4, VPN site-to-site em redes IPv6,
VPN dinâmica multiponto (DMVPN) e Roteamento externo via BGP.

Palavras-Chave: Redes de computadores, roteamento, protocolos, cenários,


configurações, GNS3.
SUMÁRIO

Laboratório 19 – Rotas Flutuantes no Ambiente Corporativo ............................................. 5


Laboratório 21 – Restrição de Banda Policing x Shaping .................................................... 6
Laboratório 22 – Roteamento Avançado Utilizando OSPF ................................................. 6
Laboratório 23 – Autenticação IPSec do OSPFv3 no roteamento IPv6 ............................ 7
Laboratório 24 – Protocolo PIM-DM no Roteamento Multicast ........................................... 9
Laboratório 27 – VPN Site-to-Site em Redes IPv4 ............................................................... 9
Laboratório 28 – VPN Site-to-Site em Redes IPv6 ............................................................... 9
Laboratório 29 – VPN Dinâmica Multiponto (DMVPN) ....................................................... 10
Laboratório 30 – Roteamento Externo Via BGP.................................................................. 10
Referência Bibliográfica........................................................................................................... 10
Laboratório 19 – Rotas Flutuantes no Ambiente Corporativo

O objetivo desse laboratório é apresentar uma solução de failover de link para a


seguinte situação. O roteador recebe fisicamente dois links, um MPLS e outro LAN-2-
LAN(L2L), as configurações padrões criariam duas rotas default com custos diferentes
observando a ativa da interface, alternando entre elas quando a atividade de uma das
portas for interrompida.

Exemplo:
Core(config)# ip route 0.0.0.0 0.0.0.0 f1/0 1
Core(config)# ip route 0.0.0.0 0.0.0.0 f2/0 2

Essa solução não é a mais recomendada porque nem sempre a falha de navegação
está associada à falha no status da interface (camada 2), mas principalmente à falta
de fornecimento de link (camada 3).

Abaixo imagem da solução em funcionamento após a conclusão do laboratório, saindo


pela FastEthernet1/0 como principal e alternando para a 2/0 na falha de link do MPLS.
Laboratório 21 – Restrição de Banda Policing x Shaping

Este laboratório trata do assunto de controle de banda usando as técnicas de Policing


e Shaping. Ambas as estratégias tem o objetivo de restringir o tráfego para um
determinado destino ou origem. A principal diferença entre elas é o tratamento do
tráfego excedente, enquanto a Policing DESCARTA o tráfego que ultrapassou o limite
configurado, a Shaping o coloca em uma FILA. Esta estratégia é mais elegante para o
tratamento do tráfego excedente, porém exige mais recurso do roteador pois a fila é
criada localmente em memória.

Abaixo a configuração necessária para limitar o tráfego do ip 192.168.0.109 à apenas


128 Kbps usando Shaping:

1. R1(config)# ip access-list extended Host-Chupim


2. R1(config-ext-nacl)# permit ip any host 192.168.0.109
3. R1(config-ext-nacl)# permit ip host 192.168.0.109 any
4. R1(config-ext-nacl)# exit
5. R1(config)# class-map match-all Chupim
6. R1(config-cmap)# match access-group name Host-Chupim
7. R1(config-cmap)# exit
8. R1(config)# policy-map QoS
9. R1(config-pmap)# class Chupim
10. R1(config-pmap)# shape average 128000
11. R1(config-pmap-c-police)# end
12. R1# conf t
13. R1(config)# int f0/0
14. R1(config-if)# servisse-policy output QoS

Obs. Para aplicar por Policing basta trocar a linha 10 por: police rate 128000 bps.

Laboratório 22 – Roteamento Avançado Utilizando OSPF

O cenário apresentado neste laboratório permite ao estudante configurar o roteamento


dinâmico utilizando os recursos avançados contidos no OSPF.

Os principais recursos utilizados são a sumarização manual e áreas stub, resultando


numa configuração de uma área não-backbone a propagar apenas uma única rota-
padrão referente a um prefixo sumarizado.
As interfaces físicas estão configuradas, já havendo comunicação entre ambos.
Adiante, o primeiro passo é a de configurar as duas interfaces seriais de R1-Backbone
na área 0, pois este roteador representará o backbone desta estrutura lógica
hierárquica.
Os roteadores de borda R2-ABR e R3-ABR também são configurados para fazer parte
da área 0, porque todas as áreas devem estar conectadas à área principal.

A camada de segurança se dará através da adoção de um mecanismo de


autenticação permitindo um roteador se tornar vizinho de outro apenas se conhecerem
a senha ou chave de segurança.
No R2=ABR as redes 192.168.88.0/24 e 192.168.89.0/24 serão sumarizados,
propagadas por R4 por meio de um prefixo único, encaminhado para o R1-Backbone,
se fazendo necessário, pois somente este prefixo será propagado para as demais
áreas.

Os roteadores R4 e R5, área 16 e 34 respectivamente, serão o stub, ou seja, só


receberá uma única rota externa padrão, a 0.0.0.0?0 de seus vizinhos, diminuindo o
tamanho das tabelas de roteamento em grandes infraestruturas. Requisitos traçados
utilizam-se então os recursos do OSPF.

Abaixo, os comandos utilizados para configuração do laboratório:

Laboratório 23 – Autenticação IPSec do OSPFv3 no roteamento IPv6

Este laboratório tem a finalidade de ensinar ao estudante como configurar a solução


de segurança IPSec para prover autenticação entre roteadores executando OSPFv3.

O cenário é composto de apenas dois roteadores que estabelecerão adjacência OSPF


na área 0 – Backbone.
Este lab. também é responsável por ensinar que o fato do IPv6 possuir segurança
nativa quer dizer que agora a solução de segurança IPSec faz parte da suíte de
protocolos da arquitetura TCP/IPv6, então nativamente ela deve ter suporte ao IPSec,
sendo uma solução de segurança embutida em dispositivos que suportam IPv6,
diferente do que ocorre com dispositivos IPv4 em que o profissional de redes tem que
estar atento se existe suporte ao IPSec.

No IPv6, os métodos de autenticação que eram utilizados na v4 para viabilizar a


vizinhança segura entre roteadores mudou, já que agora devemos utilizar o IPSec.

A configuração deste lab. se faz após os 2 passos adiante:

1) Autenticação de Vizinhança no OSPFv2 (IPv4)

R1(config)# router ospf 110


R1(config-router)# router-id 1.1.1.1
R1(config-router)# network 192.168.100.0 0.0.0.255 area 0
R1(config-router)# exit
R1(config)# int s0/0
R1(config-if)# ip ospf authentication message-digest
R1(config-if)# ip ospf authentication-key SENHA

R2(config)# router ospf 110


R2(config-router)# router-id 2.2.2.2
R2(config-router)# network 192.168.100.0 0.0.0.255 area 0
R2(config-router)# exit
R2(config)# int s0/0
R2(config-if)# ip ospf authentication message-digest
R2(config-if)# ip ospf authentication-key SENHA

2) Autenticação de Vizinhança no OSPFv3 (IPv6)

R1(config)# ipv6 router ospf 160


R1(config-router)# router-id 1.1.1.1
R1(config-router)# exit
R1(config)# int s0/1
R1(config-if)# ipv6 enable
R1(config-if)# ipv6 ospf 160 area 0
R1(config-if)# ipv6 ospf authentication ipsec spi 500 md5
1234560ABCD...EF

R2(config)# ipv6 router ospf 160


R2(config-router)# router-id 2.2.2.2
R2(config-router)# exit
R2(config)# int s0/1
R2(config-if)# ipv6 enable
R2(config-if)# ipv6 ospf 160 area 0
R2(config-if)# ipv6 ospf authentication ipsec spi 500 md5 1234560ABCD...EF
A última linha informa que a autenticação será realizada via IPSec (AH) usando uma
chave que deve conter 32 dígitos hexadecimais, podendo optar também por fazer a
autenticação (header AH) com criptografia (header ESP) através do comando "ipv6
ospf encryption”

Laboratório 24 – Protocolo PIM-DM no Roteamento Multicast

Neste Laboratório é demonstrado os conceitos e configurações do protocolo PIM-DM


de roteamento multicast nos roteadores cisco, o qual é bastante útil em ambientes que
possuem várias sub-redes por onde um conteúdo do tipo multicast tem de trafegar, é
primeiramente mostrado o conceito, logo após, é configurado a fonte do trafego
multicast, que seria um servidor que irá gerar o fluxo multicast para um determinado
grupo, e neste grupo terá um host cliente. Foi utilizado o sla monitor, para medir o
desempenho da rede, Em seguida foi configurado 3 roteadores com o protocolo pim-
dm o protocolo de roteamento multicast. A análise do roteamento ocorreu checando
todos os roteadores com comando show ip route, no qual mostrou a entrada
192.168.1.1 indicado pelo trafego multicast do servidor e destino 226.1.1.1 no roteador
1, no R2 e 3, não foi encaminhado trafego, pois, o protocolo pim-dm impede a
ocorrência de loop na rede, o mesmo só aceita rotas multicast no qual o endereço do
próximo salto seja o mais próximo da origem, baseado na topologia do cenário.

Laboratório 27 – VPN Site-to-Site em Redes IPv4

O Laboratório 27, mostra basicamente a configuração para funcionar uma VPN site-to-
site entre empresas em estados distintos, no caso SP e RJ, utilizando a internet
publica como rede de transito, após demonstrado a topologia, é configurado o ip no
roteador de são Paulo e no roteador do rio de janeiro, depois é setado o tipo de chave
(aes 128) no modo gre ipsec mode transport vpn, em seguida é realizado a troca de
chaves, inserido os respectivos ips de SP no roteador do RJ, e do RJ no Roteador de
são paulo, a partir disso o túnel será estabelecido para que haja comunicação ponto a
ponto entre os roteadores, e por último é configurado rotas nos mesmos, rota estática
manualmente, para viabilizar a comunicação.

Laboratório 28 – VPN Site-to-Site em Redes IPv6

Fizemos a configuração de dois roteadores de túnel VPN IPV6, com endereçamento


colocado pelo autor do livro e nomeando suas interfaces se tratando de conexão de
ponto a ponto, além disso, também estamos fazendo uso de endereços privados
unique locais (ULA) porque se trata de um link privativo entre as unidades e que existe
“camuflado” por trás dos links com a Internet pública. Foi configurado também
criptografias nas VPN para uma conexão segura entre os roteadores com políticas de
segurança do IPSec. E por final nos ensina comandos que podemos verificar as rotas,
interfaces, e a criptografias criadas nos roteadores.
Laboratório 29 – VPN Dinâmica Multiponto (DMVPN)

Neste cenário temos 3 equipamentos a ser configurados. Mostra a tecnologia hub-and-


spoke a ser configurada, onde centraliza a conexão somente em uma unidade, para
menor complexidade de comunicação entre os nós.

Configuramos nos 3 nós a Tecnologia DMVPN (Dynamic Multpoint VPN) que prove
uma solução escalável para configuração de tuneis dinâmicos em ambientes que
possuem diversos nós (filiais), tendo vantagem dessa solução é que ela é simples de
configurar como a topologia hub-and-spoke, e tem o desempenho otimizado da
topologia full-mesh, uma outra topologia apresentada no pdf.

Na configuração foi necessário criar VPNs apenas entre filiais e a Matriz (nos
extremos com o no central). Quando há comunicação entre duas filiais essa solução
estabelece dinamicamente uma VPN temporária para que trafego entre as unidades
não tenha que passar pelo ponto central mantendo a regra dos 80/20, 80% da
conexão ocorre entre matriz e filial e 20% entre filiais.

Laboratório 30 – Roteamento Externo Via BGP

Utilizamos o protocolo BPG, para o roteamento externo, entre sistemas autônomos,


para uso nos roteadores da internet. O BGP utiliza um algoritmo de roteamento
dinâmico tipo vetor-caminho. No laboratório configuramos um roteador para
estabelecer uma vizinhança entre a empresa e seus outros provedores de internet, no
caso dois provedores. Em que ISP1 possui dois links e o ISP2 possui um link, a
configuração foi feita de que maneira quando haver uma queda de um link haja
disponibilidade de outro link. Na configuração foi feita a publicação de IP bloco público
e configurações de interfaces de rede do roteador.

Referência Bibliográfica

BRITO, Samuel; Laboratórios de Tecnologias Cisco em Infraestrutura de Redes; 2ª


Edição; Editora Novatec; 2014.