Sei sulla pagina 1di 56

Integração de Redes de Dados e Voz

Caracteristicas de Voz e Dados Comuns

O tráfego de voz é extremamente rigoroso quanto ás exigências de qualidade


de serviço.
O tráfego de voz normalmente gera um fluxo contínuo e suave e tem um
impacto mínimo a outros fluxos que possam estar a competir a mesma largura
de banda.
Apesar dos pacotes de voz serem normalmente pequenos (entre 60 a 120
bytes), estes não toleram atrasos nem quebras, cujo resultado pode ser
considerado inaceitável para a qualidade requerida de voz.
Uma vez que não são toleradas atrasos nem perdas, o suporte ao tráfego de
voz é feito pelo protocolo UDP; a capacidade de retransmissão inerente ao
TCP, não fará sentido no contexto do tráfego de voz.
Em regra, para a garantia da qualidade de voz, os níveis de atraso não devem
ser superior a 150 ms e os níveis de perda de pacotes, não devem ser
superiores a 1%.
Caracteristicas de Voz e Dados Comuns

Uma chamada de voz requer, em


termos de garantia e prioridade
de largura de banda, de 17 a 106
kbps, mais 150 bps de overhead,
por cada chamada, para efeitos
de controlo.
A largura de banda total
necessária para o tráfego de voz,
resulta da multiplicação do
número máximo estimado de
chamadas, medidas pelo seu de
banda de pico.
Caracteristicas de Voz e Dados Comuns

As exigências de QoS, para o tráfego de dados varia considerávelmente.


Duas aplicações ( por exemplo, uma aplicação de gestão de RH e outra de
gestão de ATM ), terão exigências diferentes de largura de banda. Ainda que
se tratem de versões diferentes da mesma aplicação, podem ter
caracteristicas diferentes de tráfego na rede. O tráfego de dados pode-se
apresentar, ora constante, ora com descontinuidades em forma de rajadas;
esta tendencia não afectará a qualidade da transmissão. Em geral, o tráfego
de dados tolera atrasos e ás vezes, níveis acentuados de perdas.

Por tolerar atrasos e perdas, o suporte ao tráfego de dados é normalmente


atribuido ao TCP, dada a sua capacidade de retransmissão
Etapas Operacionais para estabelecimento
de uma chamada

As chamadas por VOIP


normalmente competem sobre
a mesma largura de banda, se
o tráfego de dados e o de voz
estiverem sob a mesma VLAN.
Um processo de competição
retira a possibilidade de
partilha.

Para evitar-se este problema,


normalmente a voz é dedicada
a uma VLAN independente.
Uma vez separados os
tráfegos, já é possível a
aplicação eficaz do QoS,
visando a priorização da voz.
Etapas Operacionais para estabelecimento
de uma chamada

Um aspecto a ter em conta na


configuração de uma rede de voz
integrada, é o aprovisionamento
da largura de banda.

Deve-se calcular a largura de


banda mínima para o suporte de
todas as aplicações da rede,
incluindo voz, vídeo, etc.

O valor calculado deve estar a


75% da largura disponível.
Etapas Operacionais para estabelecimento
de uma chamada

Uma chamada de voz sobre IP,


consiste de dois tipos de tráfego:
O tráfego portador de voz
O tráfego de sinalização

O tráfego de voz, é suportado pelo


Protocolo de Transporte em Tempo
Real (RTP) e é aquele que
transporta a voz própriamente dita.

O tráfego de sinalização utiliza


protocolos como o H.323, que
serve para setup da chamada.
Formato do pacote de voz

Um pacote de voz é composta por:


Carga de voz (payload)
Cabeçalho RTP (Real-Time Transport Protocol)
Cabeçalho UDP
Cabeçalho IP
Encapsulamento da camada de ligação de dados

O cabeçalho RTP é de 12 bytes e o encapsulamento da camada 2 depende


da rede em uso.
São empregues Coder-Decoders, para converter a voz no formato digital, de
acordo com as normas habituais para sistemas TDM, as normas G.711 e
G.729 (esta última com capacidade de compressão abaixo dos 8 kbps), entre
vários standards da industria.
QoS (Qualidade de Serviço)

Quase todas as redes, independentemente da sua dimensão, podem tirar vantagens do


uso da QoS, para optimizarem sua eficiência. A QoS utiliza recursos e funcionalidades
que vão de encontro ás exigências das aplicações de rede que são sensíveis ás perdas,
ao atraso, ou ainda ás variações de atraso (jitter). A QoS atribui preferências ao uso da
largura de banda disponível aos fluxos de dados oriundos de aplicações críticas.

A implementação da QoS, oferece os seguintes benefícios:

Prioridade de acesso aos recursos.


Uma eficiente gestão dos recursos de rede.
Serviços personalizados.
Suporte a um ambiente de coexistência de aplicações críticas.
QoS e Tráfego de Voz na Estrutura de Campus

Independentemente da capacidade
individual dos equipamentos na rede ou da
velocidade dos links, existem factores
como:

A disparidade da capacidade
nos links interligados
O modelo Vários-para-Um e a
Agregação

Que podem causar congestionamentos e


atrasos (latencia)
Se os mecanismos de gestão de
congestionamento não tiverem sido postos
em acção, muitos pacotes poderão ser
descartados, o que por via da grande
quantidade de retransmissões daí
decorrentes, onera gravemente a carga da
rede.
A QoS utiliza o mecanismo de marcação
ou rotulagem de tráfego, de acordo com
a qual será feita a sua classificação para
fins de priorização de tráfego.

A classificação do tráfego é feita aos


vários níveis do modelo OSI. Uma vez
classificado, o tráfego recebe uma
marca ou valor de QoS.
O tráfego IP, pode ser classificado de acordo com as
condições impostas por uma ACL ou ainda de acordo
com os seguintes critérios:

Parâmetros da Camada 2:
Endereços físicos, MPLS,
Bit de Controlo da perda de prioridade
na célula ATM,
Bit DE (elegível para descarte) do
quadro Frame Relay, Interface entrada.

Parâmetros da Camada 3
Campo Cabeçalho IP Precedência
Código de Diferenciação de Serviço (DSCP)
Grupo QoS, Endereço IP, Interface entrada.

Parâmetros da Camada 4:
Número de Portas TCP e UDP
Interfaces de entrada.

Parâmetros da Camada 7:
Assinaturas nas aplicações e
Interfaces de entrada
A classificação QoS da camada de ligação de dados,
avalia a informação do cabeçalho Ethernet ou do
cabeçalho IEEE 802.1q, tal como o endereço MAC de
destino ou a VLAN ID, mais concretamente, a
marcação QoS ocorre ao nível do campo Priority, do
cabeçalho 802.1q.
Note-se que o cabeçalho normal Ethernet não possui
o campo acima, pelo que a QoS só deverá ocorrer
após encapsulamento 802.1q.
O campo Priority é de 3 bits e é igualmente conhecido
como

802.1p User Priority ou


Class of Service (CoS) Value

O valor da prioridade varia de 0 á 7, sendo os valores


inferiores correspondentes ás aplicações tolerantes a
atrasos (tráfego TCP, por exemplo) e os valores
superiores a aplicações sensíveis a perdas, etc,
conforme o quadro ao lado.
Como resultado da marcação de nível 2,
deverão ter lugar as seguintes operações
de QoS:

Armazenamento Temporário
em Filas de Entrada (Input
Queue Scheduling)

Inspecção ou Policiamento

Armazenamento Temporário
em Filas de Saida (Output
Queue Scheduling)
A Classificação de nível 3, examina alguns
valores do cabeçalho, como

Endereço IP de destino ou
Protocolo.

A marcação de QoS tem lugar no campo


Tipo de Serviço (ToS) e cujos primeiros 3 bit
define-se a Precedência, em conformidade
aos bits CoS (Priority) do cabeçalho da
camada 2.

O campo ToS serve também para a


marcação DSCP (Código de Serviços
Diferenciados). A DSCP permite a
priorização salto-a-salto, sendo que os
pacotes são processados em cada
equipamento ou interface, durante seu ciclo
de vida.
Como o DSCP utiliza o campo ToS?

Os primeiros 3 bits são definidos de


acordo com os correspondentes bits CoS e
Precedencia, identificando a Classe de
Serviço (CoS) na categoria DSCP, atribuida
a um pacote.
Os três bits seguintes definem a
Precedencia DSCP para a eliminação,
(Drop Precedence), sendo que os pacotes
com maior precedencia são os primeiros
candidatos a serem descartados em caso de
congestionamento ou sobrelotação dos
dispositivos e filas.
É evidente que o tráfego de voz deve ser
marcado com a precedencia menor, no
sentido de se minimizar o efeito de perdas.
Os dois últimos bits são utilizados para o
controlo de fluxo.
Configuração Básica VOIP
O esquema representa a topologia comum de uma
ligação Switch-Telefone-PC

Configuração Básica:

1. Associar uma porta para voz, a respectiva


VLAN

switchport voice vlan vlan-id

2. Configurar a relação de confiança e as opções


de CoS

mls qos cos


mls qos trust device cisco-phone
mls qos extend trust
switchport priority extend cos cos-value

3. Verificar configurações

show interface interface switchport


show mls qos interface interface
Configuração Básica VOIP Exemplo de Configuração
Auto configuração QoS É possível estabelecer-se a confiança QoS de forma
automática o que pode melhorar o desempenho do
sistema.

Estabelece a relação de confiança na porta


dispositivo, face ao tráfego ido do equipamento
de voz (telefone IP)

auto qos voip trust

Automaticamente detecta a presença do


telefone IP, por intermédio do controlo CDP

auto qos voip cisco-phone

Verifica a configuração

show auto qos interface


Necessidade da Redundancia no Modelo Hierárquico
de Rede.

A arquitectura de rede a luz do modelo acima, deve garantir os


níveis de redundancia necessários para um funcionamento ininterrupto
dos fluxos de dados entre os níveis de acesso e de distribuição de uma
rede de local.
Default Gateway
Quando os dispositivos utilizam o default
gateway, normalmente não existe uma
forma explícita de configurar um segundo
parametro para saída padrão, ainda que
para o efeito exista uma rota alternativa.

Na figura ao lado, após a falha do Router


A, a rede convergirá no sentido de
adoptar o Router B, para encaminhar os
dados antes geridos pelo ora falhado
router A.
Porém, a grande maioria das estações,
servidores, impressoras, etc, não
possuem a capacidade de reflectir esta
alteração, pois não podem ler a
informação de encaminhamento
dinámico.
Default Gateway, por Proxy ARP
Os equipamentos de encaminhamento
podem accionar o mecanismo Proxy ARP,
a partir do qual as estações conseguem
obter a informação sobre a presença de
um novo Default Gateway.

Todas as solicitações de resolução cujo o


endereço não faz parte do segmento
local, são aceites pelo Router B, na
qualidade de Proxy ARP.

Eventualmente, as tabelas ARPs locais


ás estações, podem invalidar as entradas
para o servidor (por caducidade), o que
interromperá o tráfego, pelo menos,
durante o tempo necessário para a
mudança para um outro proxy, caso
exista.
Redundancia de Equipamentos A redundancia de equipamentos (Routers)
permite fazer de um agrupamento de
routers, um Router Virtual, acessível ás
estações da rede, como se de apenas um
equipamento de saída se tratasse. Esta
configuração permite manter um nível
permanente de redundancia á saida do
tráfego da rede.

Um ou mais equipamentos vão partilhar o


par de parametros (Endereço IP e
Endereço MAC), actuando em conjunto
como apenas um Router Virtual.

Quando uma estação solicita a resolução


para um endereço fora da gama local, a
resposta será o endereço do Router Virtual
físicamente representado pelo Router
Activo ou o Router Standby, que fazem
parte do conjunto de redundancia.
Redundancia de Equipamentos Dois ou mais Routers, utilizam um
protocolo que determinará qual dos
Routers físicos será responsável para o
processamento dos quadros enviados ao
Endereço MAC ou IP do Router Virtual.

Para as estações da rede é completamente


transparente a informação sobre o actual
Router que fisicamente encaminha dos
dados, pelo que, qualquer mudança que
possa ocorrer não afectará o fluxo normal
dos dados á saida da rede local.
Hop Standby Router Protocol (HSRP)
O HSRP define um grupo de equipamentos em
Standbay, em que cada um assume uma
determinada tarefa no grupo, para efeitos de
redundancia na saida do tráfego da rede local.
Compõem o HSRP, os seguintes elementos:

Router Activo
Router Standby
Router Virtual
Outros Routers

O Router Activo é o actual router que processa a


informação devida ao Router Virtual enquanto
que o Standby é o Router de backup em caso de
falha do primeiro.
Ambos trocam periodicamente mensagens Hello,
para o endereço multicast 224.0.0.2, porta UDP
1985.
Hop Standby Router Protocol (HSRP)
Neste exemplo,o Router A assume-se
como Router Activo, processando todo o
tráfego endereçado ao MAC
0000.0c07.acXX,

onde XX é o identificador do Grupo HSRP,


neste caso,
0000.0c07.ac01, o grupo HSRP é 1.

A informação sobre o endereçamento do


Router Virtual é mantido na tabela ARP de
cada um dos membros do grupo.
Hop Standby Router Protocol (HSRP)
A figura ao lado, mostra a saida do
comando
show ip arp,
num dos routers do grupo.

Os restantes routers, para além do


activo e do standby, monitoram as
mensagens Hello, a si enviadas, para
se certificarem da presença daqueles,
no grupo de que são membros.

Tanto o router activo como o standby,


anunciam nas mensagens Hello, a
função que estes desempenham no
grupo HSRP e o estado em que se
encontram.
Hop Standby Router Protocol (HSRP) Se o router activo falhar, os outros routers
deixam de monitorar as mensagens a partir
deste e então o standby assume-se no novo
papel de activo.

Se ambos, o activo e o standby falharem,


então os demais irão disputar a liderança .
Existirá sempre uma prioridade atribuida aos
equipamentos.

Existem dois temporizadores que controlam o


processo de sucessão:
O tempo de actualização Hello
(3 segundos).

O tempo de retenção (hold time): é o tempo


que vai desde a recepção da última
mensagem Hello e o momento em que se
presume que o router terá falhado,
normalmente igual a 10 segundos.
Hop Standby Router Protocol (HSRP) Um router, enquanto membro de um grupo
HSRP, pode estar num dos seguintes
estados operacionais:

Inicial
Aprendizagem
Escuta
Conversação
Standby e
Active

O ciclo de vida de um router começa no


estado em a interface é activada para
pertencer ao grupo HSRP.
O estado seguinte permite que o router
aprenda a configuração do Router Virtual e
em seguida entra na fase de monitoramento.
Se já existir um router activo e um standby, o
que se encontrar no estado de escuta lá irá
permanecer, até que eventualmente ocorra
uma alteração.
Hop Standby Router Protocol (HSRP)

O estado de Conversação (Speak)

Se após certo periodo de tempo o router não


acusar a recepção de alguma mensagem
Hello, então este entrará numa fase em que
disputará directamente a eleição do novo
router activo, stanby ou ambos.

É nesta fase em que os routers observam-se


mútuamente, através das respectivas
mensagens hello.

Esta também é a única etapa, em que routers


que não são, nem activos nem standby,
experimentam as mensagens hello, na
condição de possíveis candidatos á eleição
para o estado activo ou standby.
Hop Standby Router Protocol (HSRP)

No estado activo, o router encaminha


todo o tráfego enviado ao endereço
físico virtual do grupo e responde ás
solicitações de resolução de endereços
(ARP reply), dirigidas ao endereço IP
do router virtual.

Enquanto isto, o router no estado


activo, continua a gerar e enviar
mensagens hello, que são monitoradas
pelos restantes membros do grupo.

A figura mostra o resultado de uma


mensagem enviada por um router
activo, com prioridade igual a 200.
Hop Standby Router Protocol (HSRP)
Configuração de um grupo Standby

A configuração do grupo HSRP deve


seleccionar uma interface e atribuir o
endereço IP do Router Virtual:

standby group-number ip ip-address

Para verifcar a configuração:

show running-config
show standby interface group brief
Hop Standby Router Protocol (HSRP)
Configuração de um grupo Standby

A configuração do grupo HSRP deve


seleccionar uma interface e atribuir o
endereço IP do Router Virtual:

standby group-number ip ip-address

Para verifcar a configuração:

show running-config
show standby interface group brief
Hop Standby Router Protocol (HSRP)
Com o HSRP activo, as estações
terminais não devem descobrir os
endereços MAC reais dos membros do
grupo standby.

Por isso, devem estar desabilitados


todos os protocolos de descoberta que
se reportem ao anuncio do endereço
real do router, como é o caso do
redireccionamento ICMP.

Com a presença do HSRP na interface,


o ICMP redirect, fica automaticamente
desabilitado, para garantir o
pressuposto acima.
Hop Standby Router Protocol (HSRP)

Uma vez configurada a redundancia em


uma interface, pode-se utilizar o seguinte
comando, para verificar o seu estado:

show standby [interface [group]] [active


| init | listen | standby] [brief]

show standby Vlan11 11 Veja o exemplo ao lado, que reflecte a


Vlan11 - Group 11 saida parcial do comando acima.
Local state is Active, priority 110
Hellotime 3 holdtime 10
Next hello sent in 00:00:02.944 O endereço MAC, do router virtual é um
Hot standby IP address is 172.16.11.115 configured endereço bem conhecido, (reservado)
Active router is local que atende á operação do HSRP
Standby router is 172.16.11.114 expires in 00:00:08
Standby virtual mac address is 0000.0c07.ac01
Hop Standby Router Protocol (HSRP)

Optimização das Operações HSRP A redundancia HSRP, em rede local pode


ser melhorada se o administrador de rede
poder avaliar a influência exercida pela
alteração do valor de alguns parâmetros,
como,

a prioridade
o ajustamento dos temporizadores
a reactivação do equipamento activo
rastreamento de interfaces
Hop Standby Router Protocol (HSRP)

Optimização das Operações HSRP Temporizadores

As mensagens do tipo Hello, são transmitidas


periodicamente, pelos routers activo e standby
ou por todos os routers do grupo, em fase de
eleição.
As mensagens transportam o valor da
prioridade e os valores dos relógios hello e
retenção (hold).
Como já foi mencionado, o relógio hello, conta
o tempo que medeia o envio dos anuncios,
enquanto que o relógio de retenção conta o
tempo em que o anuncio actual ainda é válido.
Os seus valores por defeito, são 3 e 10
segundos, respectivamente. Isto também
significa que em caso de falha, a recuperação
por redundancia levará quanto muito, 10
segundos, para que as estações se reportem
ao novo default gateway.
Hop Standby Router Protocol (HSRP)
Temporizadores
Optimização das Operações HSRP
O tempo ora indicado para a recuperação a
falhas, pode se tornar demasiado excessivo,
para o suporte adequado á algumas
aplicações, daí a necessidade da optmização
dos timers.

standby group-number
timers [msec] hellotime oldtime

Quando se fizer a alteração dos intervalos,


estes devem ser iguais em todos os
equipamentos do grupo.

Exemplo
standby 1 timers msec 200 msec 750

Aqui, os períodos de hello e retenção passam


a ordem de milisegundos, o que aumenta o
tráfego de controlo HSRP.
Hop Standby Router Protocol (HSRP)

Optimização das Operações HSRP


Em determinadas ocasiões, o estado de uma
interface, pode directamente afectar na decisão
de que router pode ser elevado para assumir-
se como activo. Isto é particularmente útil,
quando os routers pertencentes ao grupo têm
caminhos diferentes para acesso aos recursos
da Rede de Campus.

Repare na figura, que os routers A e B, todos


estão localizados num edifício e possuem links
Gigabits (G1) para o outro edifício. O router A,
por possuir maior prioridade, é o que
actualmente encaminha o tráfego, ou seja, é o
router activo do grupo standby, digamos, 1; e
naturalmente, o router B é o standby, deste
mesmo grupo.
Deste modo, ambos os routers, estarão a
executar a troca de mensagens hello, através
das respectivas interfaces, E0.
Hop Standby Router Protocol (HSRP)

Optimização das Operações HSRP


Vamos agora supor, que o link entre o router
activo e o outro edifício, se torne inactivo.
Na ausência do HSRP, o router A, ao acusar a
falha do link, accionaria o processo ICMP de
redirecionamento para o router B, passando
através deste a ser feito o tráfego do link
falhado. Mas com a presença do HSRP, o
redirecionamento ICMP fica desabilitado, quer
ao nível do router activo, como no virtual.

Apesar da sua parcial inoperatividade, devida a


falha da interface G1, o router A, através da
interface E0, continuará a trocar mensagens
hello, ao router B, reportando o facto de que
ainda é o router activo; porém, os pacotes
enviados ao router virtual não poderão ser
encaminhados ao edifífio sede.
Hop Standby Router Protocol (HSRP)

Optimização das Operações HSRP


No cenário que temos vindo a analisar, é
possível que algum protocolo de
encaminhamento esteja presente e activo na
rede, que ao dectetar a falha, do link Router A,
Edificio Sede, actualiza as tabelas de routing
nos dois routers e por via disto, o tráfego
enviado para ser encaminhado por A , será
reencaminhado a B, através da interface E0,
para daí seguir por meio da interface G1, que
se encontra activa.

Mas a solução que se pretende dar passa pelo


uso do mecanismo de monitoramento de
interface (interface tracking), segundo o qual,
ser possível ajustar automáticamente a
prioridade do router standby do grupo, de
acordo com a sua disponibilidade.
Hop Standby Router Protocol (HSRP)

Optimização das Operações HSRP


Se a interface a ser monitorada se tornar
inactiva, prioridade do router que a detém
baixa.

Quando devidamente configurado, o recurso


de rastreamento HSRP garante que um
roteador com uma interface chave indisponível,
abandona o papel de router activo do grupo.

No exemplo, a interface E0 de Router A,


rastreia a outra interface, G1. Quando a ligação
a partir de G1 falhar, o router automaticamente
decrementa a prioridade da interface E0
(lembremo-nos que é a partir desta que se
desenrola o protocolo HSRP, com Router B) e
interrompe o envio de mensagens hello.
Decorrido o período hold time, o router B
(standby) assumirá o papel de activo.
Hop Standby Router Protocol (HSRP)

Optimização das Operações HSRP


Exemplo de configuração do rastreamento de
interfaces.

Seja a VLAN 1 e o grupo standby1, no router


activo:

interface vlan 10
standby 1 track gigaethernet 0/7 50

Quando a interface monitorada entrar fora de


serviço, o HSRP decrementará a prioridade e
interromperá o envio de hellos, forçando o
standby a entrar em acção ...
Hop Standby Router Protocol (HSRP)

Optimização das Operações HSRP Reactivação após recuperação da falha

A possibilidade do router A retomar sua função


após recuperação do link a partir de G1 é
ditada pela presença do mecanismo preempt,
no grupo HSRP.
Ora, uma vez habilitado tal mecanismo, na
condição de ter havido o rastreamento de
interface, que colocou provisóriamente, o
router B, activo, o router A, retomaria sua
anterior prioridade e passaria novamente a
Router activo do grupo.

Este mecanismo é fundamentalmente útil para


a manutenção, que obriga, por exemplo, a uma
acção de reboot ao equipamento.
Quando se programa o tempo mínimo
necessário para a reactivação, este deve ser,
pelo menos, 50% do tempo estimado para o
reboot.
Hop Standby Router Protocol (HSRP)

Optimização das Operações HSRP


No exemplo abaixo, se o tempo de
reinicialização for de 120 segundos, o prempt
deve ser configurado como segue:

standby 1 preempt
standby 1 preempt delay minimum 180
Hop Standby Router Protocol (HSRP)

Optimização por vários grupos


A existencia de mais de um grupo, numa mesma
subrede, permite uma melhor utilização dos
equipamentos em termos de balanceamento de
carga; Assim um mesmo router pode assumir-se
como activo num grupo enquanto
simultaneamente é standby noutro grupo.

Podem existir a até 255 grupos standby, mas


este número deve estar limitado ao número de
equipamentos existentes na rede
Hop Standby Router Protocol (HSRP)

Optimização por vários grupos


Exemplo de configuração

Router A

interface Vlan10
ip address 172.16.10.32 255.255.255.0
no ip redirects
standby 1 priority 150
standby 1 ip 172.16.10.110
standby 2 priority 50
standby 2 ip 172.16.10.120

Router B

interface Vlan10
ip address 172.16.10.33 255.255.255.0
no ip redirects
standby 1 priority 50
standby 1 ip 172.16.10.110
standby 2 priority 150
standby 2 ip 172.16.10.120
Virtual Router Redundance Protocol (VRRP)

Tal como em HSRP, o VRRP consiste num


grupo de routers que formam um único
router virtual. Entre os routers existe um
que recebe e processa todas as
solicitações dirigidas ao endereço IP do
router virtual, até aqui é tudo igual, entre o
HSRP e o VRRP.

O VRRP, trata de master, o router activo e


aceita um ou mais routers backup (o que
no HSRP é standby e só pode existir um).
Virtual Router Redundance Protocol (VRRP)

Vejamos as principais diferenças entre o


HSRP e o VRRP:

1. O VRRP é uma norma IEEE (RFC


2338), para redundancia entre routers; o
HSRP é propriietário da Cisco.
2. O router activo é conhecido como
master virtual router
3. O master virtual router deve ter o
mesmo endereço IP que o router virtual
que representa o grupo.
4. Vários routers podem responder á
função do router backup.
5. O VRRP, é suportado em todas as
variantes ethernet, MPLS, VPN e VLANs.
Virtual Router Redundance Protocol (VRRP)

Na figura, os routers A, B e C, são membros


do grupo de redundancia VRRP.

O endereço IP do router virtual (10.0.0.1) é o


mesmo que o da interface LAN do router A,
tornando-o master virtual router. Assim os
reatantes routers assumem-se como
backups.

Em caso de falha do master, o backup com


maior prioridade ascende aquela função;
Uma vez recuperado o master falhado
reassume as funções.
Virtual Router Redundance Protocol (VRRP)

No exemplo ao lado, existem dois grupos


VRRP, numa mesma subrede, para que seja
optmizado o processo de redundancia,
reforçada com o balanceamento de carga
entre os dois routers (SW3).

O grupo 1, tem o endereço virtual equivalente


ao do router A, tornando-o master e ao
mesmo tempo, colocando o router B como
backup.
O inverso acontece quanto ao grupo 2, cujo o
endereço virtual é o do router B (10.0.0.2).
A prioridade assinalada ao master é sempre
de 255 e a do(s) backup(s) varia de 1 á 254,
sendo o default igual a 100.
O valor da prioridade 0, indica que o master
deixa de participar no processo VRRP.
Virtual Router Redundance Protocol (VRRP)

Contrariamente ao HSRP, no VRRP, apenas


o master participa do processo de envio de
mensagens de status, aqui claramente
conhecidas como anuncios (advertisements)
em vez de hellos. Estes anuncios são
difundidos pelo multicast 224.0.0.18, porta
112, a cada 1 segundo.

Quando o master se torna indisponível, o


processo dinamico de alternancia, utiliza 3
temporizadores:

Anuncio: ( 1 segundo )
Retenção: ( 3 vezes anuncio + alternancia)
Alternância: ( 256 prioridade ) / 256 ms
Virtual Router Redundance Protocol (VRRP)

O tempo de retenção (master down interval)


é o periodo findo o qual, o backup presume o
estado de indisponibilidade do master

O tempo de alternância (skew time), é o


tempo de garantia á ascensão para master
do router backup de maior prioridade.

Para que a transição para o novo master se


faça mais rápida, sempre que se tratar de
uma operação de shutdown avisada, o então
master, emite um advertisement de
prioridade zero, o que colocará o backup
candidato á master, num estado de transição
directa ( que não precisa aguardar o
accionamento dos timers)
Virtual Router Redundance Protocol (VRRP)

Exemplo de Configuração VRRP

SwitchA(config)#interface vlan10
SwitchA(config-if)#ip address 10.1.10.5
255.255.255.0

SwitchA(config-if)# vrrp 10 ip 10.1.10.1


SwitchA(config-if)# vrrp 10 priority 150
SwitchA(config-if)# vrrp 10 timer advertise 4

SwitchB(config)#interface vlan10
SwitchB(config-if)#ip address 10.1.10.6
255.255.255.0

SwitchB(config-if)# vrrp 10 ip 10.1.10.1


SwitchB(config-if)# vrrp 10 priority 100
SwitchB(config-if)# vrrp 10 timer advertise 4
Virtual Router Redundance Protocol (VRRP)

A instrução

interface vlan X
vrrp group-number ip virtual-gateway-addr

permite colocar a interface como membro do


grupo group-number, cujo endereço IP virtual é
virtual-gateway-addr.

Já a instrução

vrrp group-number priority prority-value,

permite definir a prioridade de um router.

vrrp group-number timers advertise


timers-value,

é utilizado pelo master para estabelecer aos


demais o intervalo entre anuncios.
This document was created with Win2PDF available at http://www.daneprairie.com.
The unregistered version of Win2PDF is for evaluation or non-commercial use only.