Sei sulla pagina 1di 36

1. INTRODUCTION

1.1 Background

Mavorion system is the startup company that has been handling software development and handling a major areas of IT sector. In addition to managing networks for the cli- ents, they also manage the system related task and activities. This project report fo- cuses on the Client-Server system management and configuration for the specific cli- ent. The client’s network management system was already managed by Mavorion sys- tem and on part of one major contract, new client-server management task was also offered to the company, the job which lies within the perimeter of the network man- agement contract.

The client-server system management and configuration here focuses on basically configuring the client and server system and monitoring the activities. The process was initiated as the interne joined the company and was involved in the research, analysis part and implementation part as well in coordination with senior officer and interne’s supervisor. The client for which the task was done relates to health sector and the overall process was done in order to implement the lab-management app for the same.

Client/server is a program relationship in which one program (the client) requests a service or resource from another program, the server (Rouse, n.d). An effective client- server management overall includes managing all hardware and software device in that system and also includes the process of upgrading/downgrading according to the need of the organization. Mostly, the type of activities are foreseen by the senior per- son in the organization, as these type of activities needs upper level authority.

Client-server management and configuration are not only delicate task but also im- portant one because the consequences of these task certainly causes the big impact. A lot of application are hosted on server, which maybe vital. For e.g., the system loss in case of delicate places like health sector, bank sector can not only hamper business but also the livelihood of the people. So these types of activities needs not only great planning but also in depth research, analysis on how to overcome the cost and opti- mize the work flow.

1

1.2 Organizational Overview

1.2.1 Introduction

Mavorion system is a startup company that identifies as a mixture of the IT related expertise. The area of IT expertise which currently they are serving are software de-

velopment and various networking and system activities.

Mavorion system offers flexible and optimizable solution in case of software devel- opment. Being inside valley, the service is not limited to valley but outside the valley and tend to provide all Nepal Service.

In other scenario they help client in service deployment, infrastructure management, system integration and system management (Mavorion System, n.d). They analyze the needs of the customer and as per the user requirement, provide the optimal solution to the user. The team consist of well-known personalities in the field of networking and hence they have been able to manage the large corporate networks while improving accessibility and reliability.

1.2.2 Markets and Customers.

The company has been starting to grow its service areas and its customer are mostly health sector. From managing the client network system to deploying services for them, Mavorion system has worked also in educational sector. But mostly, the client up to which interne was there saw the number of health related institutes such as hos- pitals, lab was higher than other field.

1.2.3 Client Introduction

In this project, Interne has done the specific client side work regarding the contract between the Mavorion System and the Client. The Client here refers to the National Health Public Laboratory (NPHL). The network and system management has been started not only after this project but even before this time frame. NPHL is located at Teku, Kathmandu, Nepal.

2

1.2.4

Products and Service.

Mavorion system handles the most area of the IT expertise any company would need. The products they have built are Online Library management System for Chitwan Medical College, Lab management System for National Public Health Laboratory, Teku, Kathmandu. In addition to these products, the customer that they are providing services are Civil Hospital, Baneshwor, Kathmandu, Star Hospital Sanepa, National Public health service Teku and Nepal Telecommunication Authority (NTA).

1.2.5 Organizational Hierarchy

Organizational structure consists of the activities such as task allocation, coordination

and its environment. A structure depends entirely on the organization’s objectives and the strategy chosen to achieve them and supervision, which are directed towards the achievement of organizational aims. In case of Mavorion Systems the structure of the organization is more like a boundary-less organization. The members in this company believe more into eliminating vertical and horizontal boundaries and break down ex- ternal barriers between the company and its customers and suppliers. Mavorion Systems was established when three experienced and specialized people together came up with idea to run their own business. Since the existence of organiza- tion have not been so long, the hierarchy of the management didn’t appear clear. Also at the time interne joined the company one of the major associate had left the compa- ny. But interne believes each partner is liable to their specialized department and eve- ry work here is done by the agreement of all the partners. Everyone is working for same project in a parallel manner in order to complete a task.

1.2.6 Internship duration

The interne worked at Mavorion System, Handigaun Marg, Dumbarahi. From August

1 st to November 3 rd 2017.

Table 1.1: Internship Duration Details

Organization:

Mavorion Systems

Address

Handigaun Marga, Dhumabarahi, Kathmandu

Mentor’s name

Mr. Kshitiz Bohara

3

Mentor Position

Senior Network officer

Total Duration

3

months (1st august to 3rd November)

Office Hours :

8

hours (9:30 -5:30)

Office Days:

6 days (Sun-Fri)

1.3 Problem Statement

Client-server system configuration and management needs to be done before imple- menting any type of service. In this specific scenario, the configuration meant config- uring server and clients and making test on them such that needed functionalities were working properly which was assigned to the networking team including the interne. The task needed to be done in order to implement the new type of service in the NPHL or the client which itself is the reputable health organization in the country.

Existing condition in the NPHL can be overviewed as one old server with old soft- ware implemented at that the site for complete Lab Operation. However, this led to the some major problems. Since the Lab System itself had non responsiveness server and client system, the emergence of the additional server and new client were real- ized. Also Mavorion System was developing the new Lab Management System, the old server and client wouldn’t be able to handle the new type of system.

Another major area to where the old system would fail is Machine Integration. Old application and its peripherals were unable to handle the machine related activities. Even machine can be dealt as a client, but the level of operation would see it as differ- ent because the automation process in the lab would need additional configuration. Also the software that was to be deployed in the client was related to health sector, it was crucial the server shouldn’t create any problem during the operating hour.

1.4 Objectives

The main objectives of this project is:

To provide an elegant solution to the upper level on system managing and configuration.

4

To learn networking and its real world scenario and applications.

To develop an ethical and professional work manner in an organization.

To work under resources provided by organization.

1.5 Responsibilities Assigned

In order to meet the target for the goal, it was necessary to learn about different plat- form for server configuration. Besides learning various platform, interne had to learn extra things such as configuration of RJ 45 jacks, virtual box testing. These type of activities were not only required to achieve the goal but also to enhance the self- confidence of the interne in upcoming activities.

Besides studying fundamental parts it was necessary to learn security challenges and ways to make solution out of it. However, this type of activity was maintained by up- per level management but interne was told to make analysis and carry out the study which could be applied whenever needed if it was within work condition as assigned by the administration. Apart from these, regular interaction with supervisor and con- stant communication and coordination with mentor and senior level person helped the interne to widen up the existing knowledge and ideas.

1.6 Motivation

1.6.1 Motivation for choosing Networking and System An NMS is a system designed for monitoring, maintaining, and optimizing a network. It includes both hardware and software, but most often an NMS refers to the software used to manage a network (Christensson, 2017). Networking and System management has been so crucial part in now a days that it has become an inevitable part of human life. With the rapid pace in development of the internet, the business have moved from a computer to cloud without even knowing where it is. As along the internet it- self is revolutionary, various new technology and tools in field of networking and sys- tem have emerged.

5

1.6.2 Motivation for choosing Mavorion System Mavorion system even though is a startup company, it has been great on its perfor- mance. The CEO of Company, Mr. Indiver Badal is a very reputable personalities and well known in the field of Networking in context of Nepal. Beside this fact, the com- pany provides an innovative network and system solution. The company has proved its service worthy by expanding its service not around to valley but outside to valley and both private and governmental organization has been the customer for the service and products Mavorion System has offered.

1.7 Report Organization

The report is separated into different chapters. The first section would overall intro- duce about the organization and the project. The second section describes about the overall literature review and identification on existing system and the third section would see the overall client-server analysis. The fourth section would describe about the necessary network design only for new client and fifth section would see the actu- al Implementation and Testing part with necessary hardware and software used. The sixth section finally describes about the result analysis and the type of lesson learnt during this internship period.

6

2. Literature Review

2.1 Cisco Enterprise Network Architecture

The Cisco Enterprise Architecture is a modular approach to network design. To ac- commodate the need for modularity in network design, Cisco developed the Cisco Enterprise Architecture model. This model provides all the benefits of the hierarchical network design on the campus infrastructure, and facilitates the design of larger, more scalable networks.

The Cisco Enterprise Architecture model separates the enterprise network into func- tional areas that are referred to as modules. The modularity that is built in to the archi- tecture allows flexibility in network design and facilitates implementation and trou- bleshooting (Cisco Press, 2014).

implementation and trou- bleshooting (Cisco Press, 2014). Figure 2.1 Cisco Enterprise Architecture Model 2.2 NCIA

Figure 2.1 Cisco Enterprise Architecture Model

2.2 NCIA Client-Server Model

The process describes native client interface architecture (NCIA) support for Systems Network Architecture (SNA) devices. NCIA server and the NCIA client/server model extends the scalability of NCIA I, the earlier NCIA implementation, by minimizing the number of central-site remote source-route bridging (RSRB) or data-link switch-

7

ing plus (DLSw+) peer connections required to support a large number of NCIA cli- ents (Cisco IOS 15.0SY, 2014)

required to support a large number of NCIA cli- ents (Cisco IOS 15.0SY, 2014) Figure 2.2

Figure 2.2 NCIA Client-Server Model

8

3. System Analysis

3.1 Requirement Analysis

Before suggesting the new server requirement and client requirement, it was neces- sary to study the existing one. Existing server was running at with just only 4 GB RAM and a lot of people accessing at same time, in the time the data gets increased tends to slow down the server. So, the interne and his team would collect and suggest requirement to upper level management and discuss with the client. However it should be noted that the decision was always made between the upper level and client.

Client/Server Requirements 3.1.1 Functional requirements Functional requirement of the server and client must be able to define the functional activities they can do. There are some requirements that server and client must be able to consider while configuration of client server.

1. Server Operating Status

Server at NPHL is 24*7*365 days is online. Besides hosting the dolphin app, the server also hosts the mechanism to check the report online as well. Patient who regis- ter themselves and perform test can view the results directly without to having come at the lab again. At office hour (8-4), the server has to be involved in both parts i.e. hosting dolphin app as well as online report checking mechanism.

2. Server Capacity

Server machine has capacity of 4GB RAM and 2TB hard disk. The peak hour to oper- ate the client machine/devices is 8-12 which remains up to 4 PM. So, during this time period, lot of request needs to be handled from a lot of client devices. Hence, the ca-

pacity of server must be in perfect condition to handle request and send response.

3. Client Status

The client Status here means the devices or machines used in lab either operating in their self or by humans. Generally the devices are operational in lab hour. In other time, these devices are powered off and no such activities are recorded

9

Access Server Completely Install new software Troubleshoot Server (Re- mote/Physical Manage Network
Access Server Completely
Install new software
Troubleshoot Server (Re-
mote/Physical
Manage Network

Admin

Figure 3.1: Functional Requirement for Admin

3.1.2 Nonfunctional requirement

Nonfunctional requirement of the client-server visualizes the process of understanding

how the client-server are working. They can give the overall non-technical infor-

mation for our system.

a.Performance

The peak hour during which the system would have maximum operational status is 8-

4 among which 8-12 is very crucial. During these time period, the server and client

performance shouldn’t be degraded or slowed for even minimal amount of time.

b. Reliability

Client and Server Devices reliability can be measured in terms of operation and the

type of activities done. Server should be reliable when handling client response. An

updated system on both client and server guarantees the highest chance of reliability,

10

c. Responsiveness Client and Server devices and system should be as fast as possible both on handling the data from other sector. A minimal server that fails in responsiveness of the opera- tion can’t be further believed to other operation. Alongside the server and client, the sector for which the process needs to be implemented is health sector, so it vital that overall system performance shouldn’t fail to minimum human expectation.

3.2 Feasibility Study

The selection among different alternatives available in case of client server would lead to implementation. The proposed system first requires a system study procedure for feasibility analysis. This feasibility study helps to determine whether the system will sufficiently feasible enough to meet the objectives or not. It also helps to identify that the system will be capable of performing efficiently in long process or not.

3.2.1 Technical Feasibility

Client server configuration should be in up to date in nature, In case of server configu-

ration, network team would always monitor and troubleshoot if any issue arises but client system weren’t found all up-to-date. But since the application that the server was hosting was limited to IP restriction, the outdated client system wouldn’t bring any big issue. However, it was recommended for any upgrade whenever possible.

3.2.2 Operational Feasibility

Operational feasibility ensures our configuration on client-server would work when- ever needed. Since server are booted 24x7x365, their availability should be 99.9% and client availability in terms of the need. This also ensures, that different people are having simultaneous access and the server can handle large number of request.

3.2.3 Economic Feasibility

Cost management and Economic feasibility terms were considered in terms of electric power consumptions and server operation cost. Since the client-server management is done for a vital health sector relating to government sector, the estimated cost and ex- penditures factors were out of study area for interne.

11

4. System Design

4.1 Client-Server Architecture

Client Server Architecture is a distributed system architecture where the workload of client server are separated. Clients are those who request for the services or resources and Server means the resource provider (Technosoft, 2014). Server handles client re- quest and serves as per the need.

4.1.1 Client Server Module Following topics are the main existing client server architecture types. Basically the popular existing architecture are 2 tier and 3 tier although this tier can be used in n tier depending upon the business requirement.

3 tier architecture A three-tier architecture is a client-server architecture in which the functional process logic, data access, computer data storage and user interface are developed and main- tained as independent modules on separate platforms (What is Three-Tier Architec- ture n.d).

The three tiers in the architecture are I. Presentation layer The presentation layer is the one which the end user see. They interact with applica- tion server and operate accordingly. In case of NPHL, the Presentation Layer would be the Dolphin App seen by the employee who are currently working there under dif- ferent department and section.

II. Application layer Application Layer is the layer which the actual application is hosted. They interact with both the presentation layer and the data layer for at least in architecture like 3 tier or above. In case of NPHL, the application layer mainly saw the hosting of Dolphin App which would replace the current old lab management system.

12

III. Data layer. Data layer is the layer where both database and database server gets stored. In case of complex app or system, where data pattern are large, it would be easier to store and develop a different place for data storage. In case of NPHL, the data layer was sepa- rately defined in order to make accessibility to other app or software launched by NPHL for example, Online Report Checking System.

to other app or software launched by NPHL for example, Online Report Checking System. Figure 4.1

Figure 4.1 3 tier architecture

13

4.2 Existing Client-Server System

Existing Overview of the current system is shown as below in co-ordination with the ISP and the server system.

below in co-ordination with the ISP and the server system. Figure 4.2: Existing Server System Similarly,

Figure 4.2: Existing Server System

Similarly, overview of the network system for the new building is shown below. The major distribution was operated via switch connected to main router and in relation was distributed to major department as follow.

14

Figure 4.3: Overview of Network in New Building NPHL Again similarly, overview of the network

Figure 4.3: Overview of Network in New Building NPHL

Again similarly, overview of the network system for the old building is shown below. The major distribution was operated via switch connected to new building switch be- cause of the main router placed in the new building and in relation was distributed to major department as follow.

and in relation was distributed to major department as follow. Figure4.4: Overview of Network in Old

Figure4.4: Overview of Network in Old Building NPHL

15

4.3

ISP and Primary/Secondary connection

NPHL has been connected to one single ISP: Worldlink communication Pvt. Ltd and serving as both primary and secondary connection. It was entire up to client policy however the point of connection from where those connection are different. One is from Tripureshwor and another is from Kalimati. Primary and secondary connection are useful to prevent from failover and to balance load. When the first experiences an outage, the second ISP is there to take over every- thing until the primary ISP can get up and running again. This saves you from the lost productivity, but wastes some of the potential of having a second ISP which you can take advantage of in the next mode. Using load-balancing allows you to balance usage on which connection is best at that point in time based off of multiple variables (that’s where it gets complicated

4.4 Firewall: IP Restriction

IP restriction has been made to NPHL as the outside client cannot connect to the app. So, the server utilities and other functionalities can’t be accessed by the outsiders. For the current case and upcoming case, the server and other functionalities would be ac- cessible from NPHL and Mavorion office only.

16

5. Implementation and Testing

5.1 Device and Software Implementation

Router

Routers are small electronic devices that join multiple computer networks together via either wired or wireless connections (Mitchel, 2017). In this scenario, the main router was configured as follows.

version 15.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname NPHL-router

!

boot-start-marker

boot-end-marker

!

!

logging buffered 51200 warnings

enable secret 5 $1$k/AY$9QzxS36EdQhhILWAGIagG/

!

aaa new-model

!

!

!

!

!

17

!

!

aaa session-id common

!

!

!

!

!

!

ip dhcp excluded-address 192.168.0.1 192.168.0.21

ip dhcp excluded-address 192.168.10.1 192.168.10.100

!

ip dhcp pool LAN1

network 192.168.0.0 255.255.255.0

default-router 192.168.0.1

dns-server 9.9.9.9 202.79.43.4 103.75.148.17

!

ip dhcp pool LAN2

network 192.168.10.0 255.255.255.0

default-router 192.168.10.1

dns-server 9.9.9.9 202.79.43.4 103.75.148.17

!

!

!

cts logging verbose

18

!

crypto pki trustpoint TP-self-signed-3768761517

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-3768761517

revocation-check none

rsakeypair TP-self-signed-3768761517

!

!

username NPHL secret 5 $1$2jMM$O2zesl./E8yUD9Ac2UnLI/

!

!

!

interface GigabitEthernet0/1

description WorldLink Internet

ip address 124.41.240.188 255.255.255.0

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

!

interface GigabitEthernet0/2

description LAN1

ip address 192.168.0.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

19

!

!

interface GigabitEthernet0/3

description LAN2

ip address 192.168.10.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

!

ip nat inside source route-map nat-wlink interface GigabitEthernet0/1 overload

ip route 0.0.0.0 0.0.0.0 124.41.240.1 25

!

!

ip access-list standard SSH_Permit

permit 192.168.0.0 0.0.255.255

!

!

ip access-list standard lan-subnets

permit 192.168.0.0 0.0.255.255

!

!

!

route-map nat-wlink permit 10

match ip address lan-subnets

match interface GigabitEthernet0/1

!

20

control-plane

!

!

!

line con 0

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

access-class SSH_Permit in

login authentication local

transport preferred ssh

transport input ssh

!

scheduler allocate 20000 1000

!

end

21

Software and their Usage

Oracle VM Virtual Box VirtualBox is a free and open-source hypervisor from Oracle Corporation. VirtualBox can be installed in number of host operating systems like Linux, Windows, OS X, etc. Before actually implementing the server configuration, the system with the initial re- quirement was tested on the virtualbox and service configuration and testing were done to make sure that the configuration operation would go smoothly.

Cacti Cacti is "a complete network graphing solution." That means that Cacti polls your de- vices, gathers the data, then provides graphs based on what you configured (Davis, 2008). In this scenario, Cacti was used to monitor and error reporting mechanism in order to ease and troubleshoot the problem case scenario.

Icingaweb2

Icingaweb2 is a flexible and powerful open-source monitoring system used to monitor the load and uptime of a cluster of web workers, free disk space on a storage device, memory consumption on a caching service, and so on (Boucheron, 2017). Icingaweb2 was actually used to monitor and overview the data transmission and loss rate and an- alyse the severity of the problem.

5.2 Client-Server Implementation

5.2.1 Server Implementation The machine which the server would be configured is DELL XPS Series which packed 8GB RAM and 2 TB Hard Disk. First of all the server machine would be connected to the Network via switch. It was connected to the VLAN 1 network pre- configured for the server purpose. Ubuntu 16.04.3 LTS server edition was installed and configured in the server because Ubuntu is very popular distribution based on Debian Architecture. 67% use Unix in website and app server while 14.4% use Ub- untu as websites and app server (Usage statistics and market share of Ubuntu for web- sites, 2018).

22

Step 1: Burn the image in the USB Drive First the Ubuntu server image was burned to the USB drive in the existing machine of the interne. Usually it took approx. 6 minutes.

Step 2: General Procedure for Ubuntu The server had existing OS. So, the reboot sequence was followed by the USB drive booting to the language>Ubuntu welcome screen. Then language and country selec- tion process would be followed by keyboard layout section which is although not nec- essary because if any problem would appear, then someone in Network Team from office could SSH into the server without having physical presence in the server.

Step 3: Network Configuration IPv6 Network configuration would be auto attempted by the installation method.

Step4: Account and Time Zone Setup Account setup would see the username and password and fix the timezone for the cur- rent system which could be useless as user may setup even after full installation as well. However the interne team were pre directed on setting up the correct variables for the system.

23

Figure 5.1 Account setup for Server Step 5: HDD setup During the application launch instance,

Figure 5.1 Account setup for Server

Step 5: HDD setup During the application launch instance, there were no other app in order to be de- ployed or any remaining pending work lead to configure the HDD to one instance for that moment.

Step6: Software Installation The process was almost fast and it included some more task such as apt installation. After that it also gave chance to install some more software such as DNS server, LAMP Server, OpenSSH Server. However, it was important to note that, the version difference could lead conflict in app deployment and operation in production sever. Because, the development team was still testing in the few bugs and version update was going in continue process, the installation team left software installation part but configure OpenSSH server. After that few more installation such as GRUB installa- tion was done and the process was complete.

24

Figure 5.2: Software Installation in Server 5.2.2 Client Implementation The team wouldn’t see any new

Figure 5.2: Software Installation in Server

5.2.2 Client Implementation The team wouldn’t see any new client configuration in NPHL because the old client devices were already in working condition for old server but for new device setup, the network team alongside development team would setup the required software and hardware requirements would be suggested by network team. Client Implementation would normally see the following process.

Existing Connection and Device Condition For client working side, the devices were checked to initial network connection status. Since, the most of the devices were working in the previous condition and due to the no any new device setup, the overall network and device condition were found to be perfect for new client server system and app deployment.

App Deployment Process The web app deployment for laboratory system‘s client was to be very subtle and ac- curate one. Since the app were only used during office hour from 8-4 relating to all financial to lab activities sector, the app had to be very accurate during operational

25

period. For this purpose, the app were configured to every client browser and tested manually to make sure the app are working fine.

5.3 Service Implementation

5.3.1 Server IP Configuration

Server machine is configured to VLAN 1. The static IP was designated to 192.168.0.252. VLAN 1 was already used for other purpose including networks. VLAN 10 was used for AP. So, task was to assign a static IP. For this, the following

procedure were done:

# vi /etc/network/interfaces/

And then write the following lines

auto eth0 iface eth0 inet static address 192.168.0.252 netmask 255.255.255.0 broadcast 192.168.0.255 gateway 192.168.0.1

And save the file. Then the networking services had to be restarted with

# service networking restart

5.3.2 SSH Implementation

Since, the SSH was already installed during server installation time, it was necessary to configure the port of SSH. By default the port 22 serves up for SSH operation, however, it is not so good to leave the port unconfigured. So, the team configured it to other port address by

# vi /etc/ssh/sshd_config

Change the port line to 22 to 1337

26

And save the file. Now its time to return to restart ssh service # service ssh restart

5.4 Monitoring

Monitoring is one of the major task when it comes to the server. For this project and other major project monitoring task, access on Cacti and Icingaweb2 were provided. The limited access even meant a huge opportunity to walk through server perfor- mance. Also, monitoring provides us hint of some kind of attack going if happening.

5.4.1 Monitoring Dolphin Server using Cacti The following diagram shows the performance status for the client NPHL in the Cacti. Cacti provides the graphical form of the server status and notifies about the perfor- mance. This comes very handy when one need to general overview of the client per- formance.

when one need to general overview of the client per- formance. Figure 5.3 Monitoring Client in

Figure 5.3 Monitoring Client in the graph form in Cacti

27

Figure 5.4 Monitoring the client via general Overview in Cacti 5.4.2 Monitoring Dolphin Server using

Figure 5.4 Monitoring the client via general Overview in Cacti

5.4.2 Monitoring Dolphin Server using Icingaweb2 The following diagram shows the performance status in the Icingaweb2. Icingaweb2 shows the client status via the detailed data. It can even show the loss percentage and loss output. For the device and client addition, upper level access was required.

For the device and client addition, upper level access was required. Figure 5.5 Monitoring Client status

Figure 5.5 Monitoring Client status via IcingaWeb2

28

5.5

Troubleshooting the issues

5.5.1 Network Issue

The minor network issue were fixed by the internal team of NPHL, however at one time, the major issue was faced in the system. The network team was contacted by NPHL IT department for the problem case. After overall investigation of the system manually by the network team which included interne as well, the Worldlink office was immediately contacted to upon which they responded problem with their services because of Fiber Breakage due to ongoing construction work at Nearby Places in Teku. The scenario was resolved in 1.5 hours. Fortunately, the problem appeared in the morning to which the ongoing operation remain unaffected and the day-to-day op- eration was continued.

5.5.2 System Issue

System issue were jointly handled with the developmental team as the application was

deployed under the joint cooperation of both team. The major upgrade on the system was the reason which was identified by the network team and reported to the upper level department and the developmental team. The issue was resolved within 10 minutes and the system operated normally.

5.6 Testing

5.6.1 Server Test

Ping test A ping test is a method of checking if the computer is connected to a network. It also determines the latency or delay between two computers (Peeva, 2018).

29

Figure 5.6: Ping test on Server Test Case for Ping Test Table 5.1: Test Case

Figure 5.6: Ping test on Server

Test Case for Ping Test Table 5.1: Test Case for Ping Test

S.N

Test Scenario

Expected Result

Pass/Fail

Remarks

TC_PT_01

Ping from Outside the Net- work

Unable to Ping

Passed

 

TC_PT_02

Ping from the Wireless De- vice

Unable to Ping

Passed

 

TC_PT_03

Ping from Wired Device on Same VLAN

Ping succeed

Passed

 

TC_PT_04

Ping from Mavorion Office

Ping Succeed

Passed

 

SSH Test After the successful network connection test, now the time is for SSH test. One can use PuTTY or other SSH client for windows machine whereas, in linux, it would be by default in most desktop based edition. SSH test was done using one of the team’s laptop connected in same network with following command. $ cdrrazan/ ssh root@192.168.0.252

30

Test Case for SSH access

Table 5.2: Test Case for SSH access

S.N

Input Case

Result

Pass/Fail

Remarks

TC_SSH_01

SSH outside the net- work with username and password

Undefined

Pass

 

Network

TC_SSH_02

SSH from inside the network

Failed Access

Pass

No

username

or password

TC_SSH_03

SSH from Mavorion office with correct username and pass- word

Access

suc-

Pass

 

cessful

TC_SSH_04

SSH from client site

Failed Access

Pass

Either

username

or

password

was

unknown.

5.6.2 Client Testing On the client testing side, the client devices were mainly tested to the existing net- work connection and the app working condition. The existing network devices and condition were working in perfect state and app accessibility were checked to be in working condition.

Test Case for Client Testing

Table 5.3: Test Case for Client Testing

S.N

Input Case

Result

Pass/Fail

Remarks

TC_CT_01

App access with username and pass- word

Access

success-

Passed

Username

and

ful

password

re-

quired

TC_CT_02

App access with in- valid username and invalid password

Access

unsuc-

Passed

Invalid creden-

cessful

tials

 

31

TC_CT_03

App

access

with

Access unsuc- cessful due to no internet

Passed

correct username and password

TC_CT_04

App access

with

Access

unsuc-

Passed

username or pass-

cessful

due

to

word only.

 

partial

infor-

 

mation.

 

32

6. Result Analysis

6.1 Result

Once the server installation process was completed, it was important to inform the server machine status to the Current Head of the IT department in NPHL. The team informed system status, operating system, currently installed services and status on working module of different software and services. Back in the office, the team would submit a formal report on ways of configuring the system, and tests done on the system. Also, the system would have to be added to the Cacti and Icingaweb2 Dashboard and reported to the upper level management. The other important task of the network team was also help to the employee in the client site about the configuration of the services that would be required as the new web app was launched which would be side by side cooperation with development team.

6.2 Conclusion

During the time of the internship, the interne learnt from absolute basic, because it is crucial that the professional and the educational background seem to be complete dif- ferent. But during all these time, the learning environment was extremely helpful. Frequent communication with senior officer and supervisor would help me progress in this scenario. This 3 month not only taught me the professional environment but also the way of dealing with client, dealing with senior person, and ways of reporting them. It was also a great opportunity to get an industrial exposure at an organization like Mavorion System and to work with great personalities. This internship has en- hanced the skill and enthusiasm of this interne to be known to the business environ- ments and to learn from different aspects of working mechanisms of the organization. Working as an intern provided this interne extra knowledge and experience regarding the, networking and also experience on how to make a better relationship with the in- sider and with the outsider.

6.3 Lesson Learnt

Working at Mavorion Systems is one of the great experiences of this interne, which will be very helpful in the future life. Despite learning the various aspects of network- ing and system, this internship provided this interne with the following aspects:

33

Developing the interpersonal, managerial and entrepreneurial skills that are crucial in every professionals and employees career development.

The importance of time and punctuality.

Learnt communication skill and to make good public relation with the customers.

Moreover the best part of the intern was to learn and gain the valuable knowledge regarding the technical aspects of the Value Added Service.

Learnt to socialize and maintain good relationship with peers.

6.4 Recommendation to Internship Program

Internship program is very beneficial to the students as it tries to cover the gap be- tween the educational and professional world. So, the maximum utilization of intern- ship program should be done by everyone who are involved in this course however there are certain limitation. The current internship program is 3month long which wasn’t long enough to know the entire organizational culture and norms and the activ- ities done in the organization. So, the beneficial part would be only realized if the in- tern period could get extended.

34

7. References

Rouse, M. (n.d). What is client/server (client/server model, client/server architec- ture)? Retrieved Feb 26, 2018, from http://searchnetworking.techtarget.com/definition/client-server

Mavorion Systems (n.d). Retrieved Feb 26, 2018, from http://mavorion.com/page/about

Christensson, P. (2017, April 6). NMS Definition. Retrieved Feb 27, 2018, from https://techterms.com

Cisco Press (2017, May 9). Cisco Networking Academy Connecting Networks Com- panion Guide: Hierarchical Network Design. Retrieved Feb 28, 2018, from

http://www.ciscopress.com/articles/article.asp?p=2202410&seqNum=6

Cisco IOS 15.0SY (2014, Feb 12). Configuring NCIA Client/Server. Retrieved Feb 27, 2018, from

https://www.cisco.com/c/en/us/td/docs/ios/bridging/configuration/guide/15_0sy/br_15

_0sy_book/br_ncia_client_svr.html

Technosoft, M. (2017, Mar 4). Client Server Architecture | Types Of Client Server Architecture | MSA Technosoft. Retrieved Feb 26, 2018, from https://msatechnosoft.in/blog/tech-blogs/types-of-client-server-architecture/

What is Three-Tier Architecture (n.d) Retrieved Feb 27, 2018, from

https://www.techopedia.com/definition/24649/three-tier-architecture

N-Tier Architecture - System Concepts & Tips (n.d). Retrieved Feb 27, 2018, from

https://www.guru99.com/n-tier-architecture-system-concepts-tips.html

Mitchel, B. (2017, Nov 13). What Is a Router for Computer Networks? Retrieved Feb 28, 2018, from https://www.lifewire.com/how-routers-work-816456

35

Davis, D. (2008, Jan). Open source network monitoring: Monitor your routers with Cacti Retrieved Feb 28, 2018, from http://searchnetworking.techtarget.com/tip/Open- source-network-monitoring-Monitor-your-routers-with-Cacti

Boucheron, B. (2017, May 5). How To Install Icinga and Icinga Web on Ubuntu 16.04 Retrieved Feb 27, 2018, from

https://www.digitalocean.com/community/tutorials/how-to-install-icinga-and-icinga-

web-on-ubuntu-16-04

Usage statistics and market share of Ubuntu for websites (2018, Mar 9) Retrieved Feb 28, 2018, from https://w3techs.com/technologies/details/os-ubuntu/all/all

Peeva, B.(2018, Apr 18) Ping Test explained by websitepluse. Retrieved Feb 27, 2018, from https://www.websitepulse.com/blog/what-is-ping-test

36