Sei sulla pagina 1di 6

Estructuras condicionales y repetitivas.

Alexis Rosales Borquez.

INTRODUCCIÓN A LA PROGRAMACIÓN

Instituto IACC
Desarrollo

a) Se tienen como entradas tres números (a, b y c). Determine cuál es el mayor de los
tres.

Algoritmo numero_mayor
definir Num1,Num2,Num3,resultado como Entero;
Num1<-0;
Num2<-0;
Num3<-0;
resultado<-0;
Escribir 'Ingrese Primer Numero';
leer Num1;
Escribir 'Ingrese Segundo Numero';
leer Num2;
Escribir 'Ingrese Tercer Numero';
leer Num3;

Si Num1>Num2 Entonces
resultado <- Num1;
SiNo
resultado <- Num2;
FinSi

Si resultado>Num3 Entonces
Escribir "El número mayor ingresado es:";
Escribir resultado;
SiNo
Escribir "El número mayor ingresado es:";
Escribir Num3;
FinSi
FinAlgoritmo
b) Realizar un algoritmo que permita leer como entrada 20 números naturales e indique
cuántos son: pares, impares, positivos y negativos.

algoritmo Numeros_pos_neg_pares_impares
definir contador como entero;
definir par como entero;
definir impar como entero;
definir positivo como entero;
definir negativo Como entero;
definir numero como entero;
par <-0;
impar<-0;
positivo<-0;
negativo<-0;
para contador <- 1 hasta 6 hacer
escribir "Digite un numero:";
leer numero;
si numero mod 2 = 0 Entonces
par <- par + 1;
SiNo
impar <- impar + 1;
FinSi
si numero > 0 Entonces
positivo <- positivo + 1;
SiNo
negativo <- negativo + 1;
FinSi
FinPara
Escribir 'Total de numeros pares:',par;
Escribir 'Total de numeros Impares:',impar;
Escribir 'Total de numeros Positivos:',positivo;
Escribir 'Total de numeros Negativos:',negativo;
FinAlgoritmo
c) Realizar un algoritmo que permita calcular la edad de una persona conociendo su
fecha de nacimiento. El cálculo se debe realizar la cantidad de veces que lo desee el
usuario.

algoritmo Determina_edad

//definicion de variables

definir anno_actual como entero;

definir anno_nacimiento como entero;

definir edad como entero;

definir respuesta como caracter;

Repetir

Escribir ‘Ingrese Año Actual';

leer anno_actual;

Escribir 'Ingrese su año de Nacimiento';

leer anno_nacimiento;

edad <- (anno_actual - anno_nacimiento);

Escribir' Su edad actual es de: ’, edad,'años';

escribir' desea seguir calculando edades S/N o s/n';

leer respuesta;

Hasta Que respuesta='N'o respuesta='n';

escribir' fin de cálculo edad';

Fin Algoritmo
d) A una reunión asistieron personas de diferentes edades y géneros. Construir un
algoritmo que, dadas las edades y los géneros (M/F) de las personas, calcule:

Algoritmo Reunión
definir edad como entero;
definir genero como caracter;
definir cantidad_personas como entero;
definir cantidad_hombres como entero;
definir cantidad_mujeres como entero;
definir acumula_edad_hombres como entero;
definir acumula_edad_mujeres como entero;
definir promedio_edad_hombres como real;
definir promedio_edad_mujeres como real;
cantidad_personas<-0;
cantidad_hombres<-0;
cantidad_mujeres<-0;
acumula_edad_hombres<-0;
acumula_edad_mujeres<-0;
promedio_edad_hombres<-0;
promedio_edad_mujeres<-0;
Escribir'Ingrese Edad o Cero (0) para finalizar programa';
leer edad;
Mientras (edad <>0) Hacer
Si (edad<18) Entonces
Escribir'Eres menor edad,<NO PUEDES ENTRAR>';
Escribir'Ingrese Edad o Cero(0) para finalizar programa';
leer edad;
SiNo
Escribir'Ingrese su Genero M(masculino)O F(femenino)';
leer genero;
Si (genero='M') Entonces
cantidad_hombres=cantidad_hombres+1;
acumula_edad_hombres=acumula_edad_hombres+edad;
SiNo
si (genero='F') Entonces
cantidad_mujeres=cantidad_mujeres+1;
acumula_edad_mujeres=acumula_edad_mujeres+edad;
Fin Si
FinSi
Finsi
cantidad_personas=cantidad_personas+1;
Escribir'Ingrese Edad o Cero(0) para finalizar programa';
leer edad;
FinMientras
Escribir'Estadisticas';
Escribir' Total de personas que asistieron a la Reunion:' ,cantidad_personas;
Escribir' Total de Hombres que asistieron a la Reunion:' ,cantidad_hombres;
Escribir' Total de Mujeres que asistieron a la Reunion:' ,cantidad_mujeres;
promedio_edad_hombres=acumula_edad_hombres/cantidad_hombres;
Escribir' Promedio de edad de los Hombres:' ,promedio_edad_hombres;
promedio_edad_mujeres=acumula_edad_mujeres/cantidad_mujeres;
Escribir' Promedio de edad de las Mujeres:' ,promedio_ edad_mujeres;
FinAlgoritmo