Sei sulla pagina 1di 39

UNIVERSIDAD NACIONAL MAYOR DE SAN MARCOS

(Universidad del Perú, DECANA DE AMERICA)


FACULTAD DE INGIENERIA ELECTRONICA Y ELETRICA
E.A.P DE TELECOMUNICACIONES

Laboratorio N° 3
Configuración de Router

Curso: Laboratorio de Sistemas de Telecomunicaciones I

Estudiantes:

Chafloque Mejia Joseph Daniel 11190182


Arteaga Manrique Walter André 11190220

Ciclo: 2014-I

Profesora: Ing. Rossina Gonzales

Junio del 2014


LABORATORIO DE SISTEMAS DE TELECOMUNICACIONES I
Configuración de Router

I. OBJETIVOS:

1. Usar el Software Cisco Packet Tracer o GNS 3 para configurar un router Cisco.
2. Conocer los modos de acceso basicos y almacenamiento de configuracion de un router.
3. Emplear protocolos de enrutamiento estático y dinámico en redes WAN.

II. HERRAMIENTAS:

1. Cisco Packet Tracer v.5.4.4.0019 oGNS3 v. 0.8.4.

III. PROCEDIMIENTO
INFORMACION BASICA SOBRE ROUTERS

El router es un computador que selecciona las mejores rutas y maneja la conmutación de


paquetes en dos redes diferentes. Los componentes de la configuración interna de un router
son los siguientes:

 RAM/DRAM: Almacena tablas de enrutamiento, caché ARP, caché de conmutación


rápida, búfering de paquetes (RAM compartida) y colas de espera de paquetes. La RAM
también proporciona memoria temporal y/o de ejecución para el archivo de
configuración del router, mientras el router se enciende. El contenido de la RAM se
pierde cuando se apaga o se reinicia el router.
 NVRAM: RAM no volátil. Almacena el archivo de configuración de inicio/copia de
respaldo del archivo de configuración de un router. El contenido no se elimina cuando
se apaga o se reinicia el router.
 Flash: ROM borrable y reprogramable. Contiene la imagen y micro código del sistema
operativo. Permite actualizar el software sin eliminar y reemplazar chips en el
procesador. El contenido se conserva cuando se apaga o reinicia el router. Se pueden
almacenar múltiples versiones del software IOS en la memoria flash.
 ROM: Contiene diagnosticos de encendido, un programa bootstrap y software del
sistema operativo. Las actualizaciones de software en ROM requieren el reemplazo de
chips enchufables en el CPU.
 Interfaz: Conexión de red a través de la cual los paquetes entran y salen de un router.
Puede estar en un motherboard o en un módulo de interfaz separado.

FUNCIÓN DE LOS ROUTERS

Debido a que los routers son los dispositivos de backbone (columna vertebral) de las redes
internas extensas y de internet, operan en la Capa 3 de modelos OSI, tomando decisiones
basadas en direcciones de red (en internet, utilizando el Protocolo Internet IP). Las dos funciones
principales de los routers son la selección de mejores rutas para los paquetes de datos entrantes,

1
FIEE UNMSM
y la conmutación de paquetes a la interfaz de salida correspondiente. Los routers hacen esto
creando tablas de enrutamiento e intercambiando la información de red de estas tablas con
otros routers.

Se pueden configurar las tablas de enrutamiento, pero por lo general se mantienen de forma
dinámica mediante un protocolo de enrutamiento que intercambia información de topología
(ruta) de red con otros routers.

LISTA DE COMANDOS

Cuando se escribe un signo de interrogación (?) en el indicador del modo usuario o el modo
privilegiado aparece una práctica lista de comandos de uso común. La pantalla muestra 22 líneas
por vez. De modo que a veces aparece el indicador - - More - - en la parte inferior de la pantalla.
Esto indica que hay multiples pantallas disponibles como resultado. Siempre que aparece un
indicador - - More - - se puede ver la siguiente pantalla disponible presionando la barra
espaciadora.

MODOS DE OPERACION DEL ROUTER

MODO USUARIO

Si se visualiza el prompt: >, el router se encuentra en el MODO USUARIO en este modo solo está
permitido el monitoreo de ciertos parámetros y la ejecución de algunos comandos del router:

Router > (prompt de MODO USUARIO y nombre de router configuración de fábrica)

2
FIEE UNMSM
MODO PRIVILEGIADO O SUPERVISOR

Este modo permite realizar lo siguiente:

 Interface (interfaz)
 Subinterface (subinterfaz)
 Líne (línea)
 Router
 Router map (mapa de router)
 Otros modos de configuración

Si ejecuta el comando exit, en uno de los modos de configuración específicos, esto lo hará volver
al modo de configuración global. Si presiona Control - >, sale por completo del modo de
configuración y el router vuelve al modo EXEC privilegiado.

MODO DE CONFIGURACIÓN GLOBAL

Implementa poderoso comandos de una línea que ejecutan tareas simples de configuración.
Para entrar al modo de configuración global ejecute el sgte. Comando:

Router# config terminal

Router(config)#

CONFIGURACIÓN DE PARÁMETROS GLOBALES

Para esto se deberá ejecutar los siguientes comandos:

NOMBRE DEL ROUTER: Este nombre de host será parte de los indicadores de Cisco IOS para
todos los modos de configuración. En la configuración inicial, el nombre po defecto del router
es Router.

Router(config)#Hostname < Nombre del router >

PASSWORD PARA ACCESO A MODO PRIVILEGIADO: Restringe el acceso al modo EXEC


privilegiado.

Router(config)#enable password < password >

Si se desea tener mayor seguridad en el acceso al modo privilegiado, se puede configurar un


password secreto el cual es encriptado de la siguiente manera:

Router(config)#enable secret < password >

Luego al verificar la configuración obtendrá algo parecido:

Enable secret 5 $1$lh93$dl.POLd7Jikwn7ZUHRLzO1

PASSWORD DE TERMINAL DE CONSOLA: Establece una contraseña en la terminal de consola

Router(config)# line console 0

3
FIEE UNMSM
Router(config-line)# login

Router(config-line)#password < password >

PASSWORD PARA ACCESO DE TERMINAL VIRTUAL: Establece protección mediante contraseña


en las sesiones Telnet entrantes

Router(config)# line vty 0.4

Router(config-line)# login

Router(config-line)# password < password >

VISUALIZACION DEL ARCHIVO DE CONFIGURACIÓN

Ingrese al modo privilegiado y digite el siguiente comando

Router # show running-config

Según el router se visualizará las interfaces físicas visualiza (nomenclatura) y la configuración


actual del router

GUARDAR ARCHIVO DE CONFIGURACIÓN

Digite el siguiente comando en modo privilegiado

Router # copy running-config startup-config

COMANDOS DE EXAMEN DE LOS ESTADOS DEL ROUTER

Estos comandos lo ayudan a obtener información importante que es necesaria para monitorear
y diagnosticar las fallas de las operaciones del router. Lo más comunes son:

 Show versión: Muestra la configuración del hardware del sistema, la versión del
software, los nombres y orígenes de los archivos de configuración y la imagen del
arranque.
 Show protocols: Muestra los protocolos configurados. Muestra el estado de todos los
protocolos configurados de Capa 3.
 Show flash: Muestra información acerca del dispositivo de memoria Flash.
 Show running-config: (write term en la version 10.3 o anterior de Cisco IOS): Muestra el
archive de configuración activo.
 Show startup-config: (show cofig en la version 10.3 o anterior de Cisco IOS): Muestra la
copia de respaldo del archive de configuración.
 Show interfaces: Muestra estadísticas para todas las interfaces configuradas en el
router.

COMANDOS DE CONFIGURACIÓN DE INTERFAZ

Modifican la operación de un puerto Ethernet, Token Ring o serial

Router(config)# interface < Tipo de puerto > ó < Tipo Ring o serial.

4
FIEE UNMSM
Router(config)# interface < Tipo de puerto > ó < Tipo de slot/puerto >

En los routers siempre es necesario determinar el número de Slots que tiene el router y la
posición de los puertos LAN o WAN que tien dentro del Slot, la nomenclatura para una interface
es la siguiente SLOT/PUERTO ejemplo:

Interface serial 0/1  indica puerto WAN o interface WAN 1 del slot 0

Interface Ethernet 0/0  indica puerto LAN o interface LAN o del slot 0

El siguiente comando asigna una dirección lógica a la interfaz

Router(config-if)# ip address < Dirección IP > <Máscara>

Como todas las interfaces de router se inician automáticamente en el modo


administrativamente desactivado, este comando le sirve para activar la interfaz:
Router(config-if)# no shutdown

En los enlaces seriales, uno de los lados (el DCE) debe suminstrar una señal de temporización; el
otro lado es un DTE. Por defecto, los routers Cisco son dispositivos DTE, pero en algunos casos
se pueden utilizar como dispositivos DCE. Se utiliza una interfaz para suministrar temporización
y debe especificar una velocidad mediante el comando clock rate.

Router(config)# interface serial 0

Router(config-if)# clock rate < Velocidad en bits >

El commando ip host crea una entrada estática que relaciona el nombre de host con la dirección
del mismo en el archivo de configuración del router.

Router(config)# ip host < Nombre > < Dirección IP >

CONFIGURACIÓN DE PROTOCOLOS DE ENRUTAMIENTO

Los routers aprenden las rutas hacia los destinos de tres formas diferentes:

 Rutas estáticas: definidas manualmente por el administrador del sistema como el


siguiente salto hacia un destino; útil para la seguridad y la reducción del tráfico.
El comando ip route configura una ruta estática.

Router(config)# ip route < Dirección de red destino > <Máscara> <Dirección IP del salto
siguiente> <Distancia Administrativa>

La distancia administrativa es una calificación para determinar la confiabilidad de una


fuente de información de enrutamiento, expresada por un valor numérico de 0 a 255.
Cuanto mayor sea el número, menor será la calificación de confiabilidad.
Los valores de distancia administrativa introducidos manualmente para las rutas
estáticas son generalmente números bajos (1 es el valor por defecto).

5
FIEE UNMSM
 Rutas por defecto: definidas manualmente por el administrador del sistema como la
ruta a tomar cuando no exista ninguna ruta conocida para llegar al destino. Se define
con el siguiente comando:
Router(config)# ip route 0.0.0.0 0.0.0.0 < Dirección IP del salto siguiente>

 Enrutamiento dinámico: el router averigua las rutas para llegar al destino a través de
actualizaciones periódicas enviadas por otros routers.
En la capa internet del conjunto de protocolos TCP/IP un router puede utilizar un
protocolo de enrutamiento IP para realizar el enrutamiento a través de la
implementación de un algoritmo de enrutamiento específico. A continuación, algunos
ejemplos de protocolos de enrutamiento IP:

 RIP: un protocolo de enrutamiento vector-distancia


 IGRP: protocolo de enrutamiento vector-distancia de Cisco
 OSPF: un protocolo de enrutamiento estado-enlace
 EIGRP: un protocolo de enrutamiento híbrido balanceado

Para el protocolo de enrutamiento dinámico se define con el siguiente comando:


Router(config)# router < Protocolo de enrutamiento >
Router(config-router)#network < Dirección de la Red directamente conectada >

PRUEBAS BÁSICAS DE NETWORKING

Los problemas más comunes que se producen en las redes IP son causados por errores en el
esquema de direccionamiento. Es importante verificar la configuración de direcciones antes de
continuar con los siguientes pasos de configuración. Los comandos para realizar estas pruebas
son:

 telnet: verificar el software de la capa de aplicación entre las estaciones origen y


destino. Es el mecanismo de verificación más completo disponible.
 Ping: Utiliza el protocolo ICMP para verificar la conexión de hardware y la dirección
lógica en la capa de internet. Es un mecanismo de verificación sumamente básico. Se
soporta en los modos EXEC usuario y privilegiado.
 Trace: utiliza valores TTL para generar mensajes desde cada router que se utiliza a lo
largo de la ruta. Es sumamente poderoso en cuanto a su capacidad para ubicar fallas en
la ruta desde el origen hasta el destino.

Se utiliza comando show ip route para determinar si una entrada de tabla de enrutamiento
existe para la red objetivo.

IV. PROCEDIMIENTO

1. Con los software de simulación Cisco Packet Tracer o GNS 3, desarrole la topología de la
Fig 1, en la que se sumulará la interconexión de redes corporativas empleado solo
enrutamiento estático.

6
FIEE UNMSM
2. Arrastre con el mouse los dispositivos de red que va a necesitar para su simulación,
según la Fig.1.
3. Para conectar los dispositivos haga click derecho a uno de ellos, en la pantalla aparecerá
un zoom de los puertos disponibles; elija el puerto a conectar haciendo click sobre él,
repita lo mismo para el otro dispositivo.

4. Utilizando los comandos en modo de configuración global antes explicados configure los
routers asignándoles:

a. Nombre de host (según la Fig. 1)


b. Password de consola cisco
c. Password de Modo Privilegiado class
d. Password de Terminal Virtual lab
e. Direcciones IP para cada interface
f. Terminales DCE con c|ock rate igual a 64000 bps
g. Rutas estáticas
h. Rutas por defecto

5. Asignar a los Host:

a. Dirección IP
b. Puerta de enlace o Gateway

6. Verifique e interprete la configuración de cada router, con el comando sh run.


7. Verifique e interprete las tablas de enrutamiento con el comando sh ip route.
8. Verifique la conectividad con el comando ping desde:

7
FIEE UNMSM
a. Host 1 – Host 3
b. Host 1 – Host 5
c. Host 1 – Host 7
d. Host 2 – Host 4
e. Host 2 – Host 6
f. Host 2 – Host 7
g. Host 3 – Host 5
h. Host 3 – Host 7
i. Acceso a internet de todos los hosts.

9. Verifique la ruta que siguen los datos con el comando trace o tracert:

a. R1 – R4
b. R3 – R4
c. Host 2 – R4
d. Host 4 – R4

10. Compruebe la configuración cie un router remoto con el comando telnet desde la
consola de:

a. R1 — R2
b. R2 — R3
c. R3 — R4

11. Desarrolle la siguiente topología en la cual se presenta la conexión de redes LAN con el
proveedor de internet. Utilice enrutamiento dinámico y estático, según la Fig. 2
12. Utilizando los comandos en modo de configuración global entes explicados configure
los routers asignándoles:

i. Nombre de host (según ia Fig. 2)


j. Password de consoia cisco
k. Password de Modo Privilegiado class
l. Password de Terminal Virtual! lab
m. Direcciones IP para cada interface
n. Terminales DCE con clock rate igual a 64000 bps
o. Rutas estáticas
p. Rutas por defecto
q. Enrutamiento Dinámico RIP

13. Asignar a los Host:

a. Dirección IP
b. Puerta de enlace o Gateway

8
FIEE UNMSM
14. Verifique e interprete la configuración de cada router, con el comando sh run.
15. Verifique e interprete las tablas de enrutamiento con el comando s hip route.
16. Verifique la conectividad con el comando ping desde:
a. Host 1 — Host 2
b. Host 1 — Host 3
c. Host 2 — Host 3
d. Host 2 — R2
e. Host 3 — R1
f. Host 3 — R3

17. Verifique la ruta que siguen los daños con el comando trace:

a. R5 — R6
b. R2 — R5
c. R1 — F36

18. Compruebe la configuración de un router remoto con el comando telnet desde la


consola de:
a. R1 — R5
b. R2 — R6
c. R3 — R4

9
FIEE UNMSM
V. INFORME FINAL

1. Describa las características técnicas de los routers y switches Cisco más


populares.

Existen muchas clases de routers y switches Cisco que son populares:

Entre ellos tenemos a:

10
FIEE UNMSM
2. ¿Para qué sirve la ruta estática?
Las rutas estáticas se definen administrativamente y establecen rutas específicas que han
de seguir los paquetes para pasar de un puerto de origen hasta un puerto de destino. Se
establece un control preciso del enrutamiento según los parámetros del administrador.

11
FIEE UNMSM
Las rutas estáticas por default especifican un gateway (puerta de enlace) de último recurso,
a la que el router debe enviar un paquete destinado a una red que no aparece en su tabla de
enrutamiento, es decir que desconoce.

Por eso se configura para conseguir conectividad con un enlace de datos que no esté
directamente conectado al router. Para conectividad de extremo a extremo, es necesario
configurar la ruta en ambas direcciones. Las rutas estáticas permiten la construcción manual de
la tabla de enrutamiento.

3. ¿Para qué es necesario el enrutamiento dinámico?


Para compartir información de forma dinámica entre los routers, actualizando las tablas de
enrutamiento de forma auntomática cuando cambia la topología y sobre todo determina cuál
es la mejor ruta a un destino.

Su objetivo es descubrir redes remotas manteniendo la información de enrutamiento


actualizada. Selecciona la mejor ruta a las redes de destino y brinda la funcionalidad necesaria
para encontrar una nueva mejor ruta si la actual deja de estar disponible.

4. Desarrolle los protocolos de enrutamiento dinámico RIP, OSPF y IGRP.


A. Rourter Information Protocol (RIP)

RIP es un protocolo importante por ser uno de los primeros en implementarse y servir
de base para la evolución de los protocolos de enrutamiento dinámico. Entre sus
características básicas habría que destacar las siguientes:

• Es un protocolo de enrutamiento vector distancia.


• Utiliza el conteo de saltos como su única métrica o coste para la selección de rutas.
• Las rutas publicadas con conteo de saltos mayores que 15 son inalcanzables.
• Se transmiten mensajes cada 30 segundos.
• Sus mensajes se encapsulan en un segmento UDP con direcciones de puerto 520
tanto en origen como en destino.
• Tiene asignada una distancia administrativa de 120.

En su primera versión (RIPv1) es un protocolo con clase, es decir, considera las


direcciones de red como pertenecientes a una de las clases definidas por el estándar (clases
A, B y C), por lo que no admite VLSM (máscaras de subred de longitud variable) ni la
notación CIDR para estas (enrutamiento entre dominios sin clases). La versión mejorada de
este protocolo (RIPv2) admite tanto VLSM y CIDR, por lo que ya no se asocia cada dirección
de red con la máscara de la clase a la que pertenece.

Por defecto, cuando se activa RIPv2, realiza el resumen automático de rutas


(autosummary), lo que implique que en el caso de subredes fronterizas que pertenezcan a
una misma clase, el router propaga la ruta como si se tratase de una red con clase. Esto
puede generar problemas cuando se utilizan subredes contiguas en un mismo dominio de
red pero no adyacentes o fronterizas (conectadas a un mismo router).

La compatibilidad entre versiones se garantiza porque RIPv2 utiliza campos del mensaje
RIP no utilizados en su versión precedente.

12
FIEE UNMSM
Figura 1: Formato de los mensajes RIP de ambas versiones

El proceso de activación y configuración de RIP requiere los siguientes pasos en cada router:

1. Activación del proceso


2. Selección, en su caso, de la versión 2
3. Desactivación, en su caso, del resumen automático de rutas
4. Designación de las interfaces por las que no se enviarán actualizaciones del
protocolo
5. Enumeración de las redes conectadas que formarán parte en el proceso de
enrutamiento

El coste o métrica que se asigna a una ruta en RIP es un valor entero igual al número de
saltos o routers que forman parte de esa ruta.

B. Open Shortest Path First (OSPF)

OSPF es un protocolo de enrutamiento sin clase y de estado del enlace, cuya versión
actual para IPv4 es la OSPFv2 descrita en la RFC 2328. Entre sus características básicas
habría que destacar las siguientes:

• Sus mensajes se encapsulan en un paquete IP con indicador de protocolo 89.


• La dirección de destino se establece para una de dos direcciones multicast: 224.0.0.5
ó 224.0.0.6. Si el paquete OSPF se encapsula en una trama de Ethernet, la dirección
MAC de destino es también una dirección multicast: 0100-5E-00-00-05 o 01-00-5E-
00-00-06.
• Tiene asignada una distancia administrativa de 110

Existen cinco tipos de paquetes OSPF:

13
FIEE UNMSM
• Paquete Hello. Se utiliza para mantener activa la conexión OSPF con otros routers
adyacentes
• Paquete DBD (DataBase Description). Contiene información de la base de datos
del router que lo emite acerca del estado de los enlaces locales a este.
• Paquete LSR (Link-State Request). Es una solicitud de información sobre cualquier
entrada de la base de datos de estado del enlace.
• Paquete LSU (Link-State Update). Es una respuesta a las peticiones LSR y contiene
diferentes tipos de notificaciones sobre el estado del enlace, LSA (Link-State
Advertisement).
• Paquete LSAck (Link-State acknowledgment). Es un acuse de recibo de un paquete
LSU.

Figura 2: Formato del mensaje OSPF

Cad router OSPF mantiene una base de datos de link-state que contiene las LSA
recibidas por parte de todos los demás routers. Una vez que un router recibió todas las LSA
y creó su base de datos de link-state local, OSPF utiliza el algoritmo SPF (primero el camino
más corto, Shortest Path First) de Dijkstra para crear un árbol SPF. El árbol SPF luego se
utiliza para completar la tabla de enrutamiento IP con las mejores rutas para cada red. Esto
implica que cada router mantiene un árbol propio y que no tiene porqué ser similar al de
los routers del mismo dominio de enrutamiento.

El proceso de activación y configuración de OSPF requiere los siguientes pasos en cada router:

1. Activación del proceso asignándole un identificador propio que sólo tiene


significado local al router
2. Enumeración de las redes conectadas que formarán parte en el proceso de
enrutamiento, indicando para cada una de ellas
a. La dirección de red

14
FIEE UNMSM
b. La máscara, en formato complementado a las máscaras de subred
c. Un identificador de área OSPD. Número entero que coincidirá en todos
los routers del área de enrutamiento que compartan información sobre
el estado de los enlaces

En OSPF cada router tiene que tener una identificación propia e inequívoca que coincide, en el
caso de los routers de Cisco, con el siguiente orden de precedencia:

1. La dirección IP configurada expresamente con tal fin (comando routerid).


2. Si no se configura expresamente, la dirección IP más alta de cualquier de sus
interfaces de loopbak (son interfaces software activadas en cada router con el
propósito de simular otras redes no existentes físicamente).
3. Si no se ha configurado ninguna interfaz de loopbak, la dirección IP más alta
de cualquiera de sus interfaces físicas activas.

El coste OSPF de una ruta es un valor entero que se obtiene sumando los costes
individuales de cada uno de los enlaces que forman parte de la ruta. El coste individual de
un enlace en los routers de Cisco tiene un valor de referencia de 108 por defecto.

Figura 3: Valores del costo de los distintos tipos de enlace en los routers Cisco

C. Open Shortest Path First (OSPF)

El Interior Gateway Routing Protocol (IGRP) es un protocolo patentado desarrollado por


Cisco. Las características principales de diseño del IGRP son las siguientes:

Se considera el ancho de banda, el retardo, la carga y la confiabilidad para crear una métrica
compuesta. Por defecto, se envía un broadcast de las actualizaciones de enrutamiento cada 90
segundos. El IGRP es el antecesor de EIGRP y actualmente se considera obsoleto.

IGRP es un protocolo de métrica vector-distancia, perteneciente a Cisco, utilizado para el


intercambio de información entre routers. Lo que se encarga de hacer es buscar la mejor vía de
envío mediante el algoritmo de métrica vector-distancia.

IGRP utiliza los siguientes parámetros:

 Retraso de Envío: Representa el retraso medio en la red en unidades de 10


microsegundos.

15
FIEE UNMSM
 Ancho de Banda (BandWidth – Bw): Representa la velocidad del enlace, dentro del
rango de los 12000 Mbps y 10 Gbps. En realidad el valor usado es la inversa del ancho
de banda multiplicado por 107.

 Fiabilidad: va de 0 a 255, donde 255 es 100% confiable.

 Distancia administrativa (Load): toma valores de 0 a 255, para un enlace en particular,


en este caso el valor máximo (255) es el peor de los casos.

 La fórmula usada para calcular el parámetro de métrica es:

(K1*Ancho de Banda) + (K2*Ancho de Banda)/(256-Distancia) + (K3*Retraso)*(K5/(Fiabilidad +


K4)).

Las principales características de IGRP:

 Envía actualizaciones de enrutamiento periódicas (cada 90 segundos).


 Difunde la tabla de enrutamiento completa periódicamente.
 Utiliza la distancia como parte de su métrica (en este caso, un compuesto de ancho de
banda y retardos).
 IGRP utiliza el algoritmo Vector-Distancia Bellman-Ford para determinar la mejor ruta
hacia un destino particular.

Otras características de IGRP son:

 Soporta Sólo enrutamiento IP.


 Las rutas IGRP tiene una distancia administrativa de 100.
 IGRP, por defecto, admite un máximo de 100 saltos. Este valor puede ser ajustado a un
máximo de 255 saltos.
 Utiliza el ancho de banda y retardos de la línea, de forma predeterminada, para calcular
su distancia métrica. La confiabilidad, la carga de la red y MTU son atributos opcionales
que pueden ser utilizados para calcular la métrica de distancia. IGRP requiere la inclusión
de un Sistema Autónomo (AS) en su configuración. Sólo los routers que estén en el
mismo AS enviarán actualizaciones entre sí.

16
FIEE UNMSM
5. Desarrolle los resultados de cada punto de experiencia.
ENRUTAMIENTO ESTATICO

a. Para este paso se desarrolló la siguiente estructura de la figura siguiente, se realizó


con el software Cisco Packet Tracer 6.0.1.

Fig 1

b. Cada Router se configuro asignándole los siguientes valores, tomando como


ejemplo el Router 1:
i. Nombre del host, en este caso R1:

Router>enable
Router#config terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# Hostname R1

ii. Password de la consola “cisco”:

R1(config)#line console 0
R1(config-line)#login
% Login disabled on line 0, until 'password' is set
R1(config-line)#password cisco
R1(config-line)#exit

iii. Password en Modo Privilegiado “class”:

17
FIEE UNMSM
R1(config)# enable password class
R1(config)#line vty 0 4
R1(config-line)#login
% Login disabled on line 132, until 'password' is set
% Login disabled on line 133, until 'password' is set
% Login disabled on line 134, until 'password' is set
% Login disabled on line 135, until 'password' is set
% Login disabled on line 136, until 'password' is set
R1(config-line)#password lab
R1(config-line)#exit

Estas configuraciones serán para todos los router, a excepción del nombre del host, las
direcciones IP para cada puerto serán según la imagen:

Fig. 2

Para conectar Router con Router se usan sus puertos Serial disponibles, y para conectar
los Router con los host se usaran sus puertos Fasethernet.

Tomando como ejemplo el Router 1, y viendo la imagen Fig.2, configuraremos sus Router de la
siguiente manera. Primero lo haremos con su puerto serial, el cual en este caso es el Serial2/0:

R1(config)#interface Serial2/0
R1(config-if)#clock rate 64000

18
FIEE UNMSM
R1(config-if)#ip address 172.16.1.2 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#

Los FastEheternet se configuraron de la siguiente manera:

R1(config)#interface FastEthernet0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown

R1(config)#interface FastEthernet1/0
R1(config-if)#ip address 192.168.2.1 255.255.255.0
R1(config-if)#no shutdown

De la misma manera se realizara la configuración de los otros Router.

Para la configuración de lo host se realizó de la siguiente manera, se tomara como


ejemplo el host 1:

Hacer click sobre el host a configurar, en este caso al host 1, ir a “Desktop” y luego a “Ip
configuration” y poner los respectivos valores:

19
FIEE UNMSM
Se repetido los pasos para el resto de los host, con su respectiva IP y Gateway como indica la
Fig.2.

CONFIGURACION DE LAS RUTAS ESTATICAS

Para esto nos guiaremos de la Fig.3:

Fig.3

20
FIEE UNMSM
Para eso vamos a tomar como ejemplo el Router R1 con el Router R2 para el retorno.

a. Entrar a configuración de R2, comando config terminal, de una vez ejecutado el


comando deben tener en su pantalla de configuración lo siguiente Router(config)# si no
es así presionen Ctrl.+C y recién digiten el comando.

b. Asignar la ruta de la red con la que se va a comunicar y por qué Router va a pasar, en
este caso desde el Router R1 necesito que mi red 192.168.2.0/24 y 192.168.1.0/25 se
comunique con la red 200.10.80.0/24, esto lo puedo hacer agregando el siguiente
comando:

· ip route 200.10.80.0 255.255.255.0 172.16.1.2

c. Hasta ahí puedo enviar pero no puedo recibir una respuesta, para eso necesito
configurar el R2, de igual manera entramos a la configuración con el comando conf t e
indicamos la ruta:

· ip route 192.168.2.0 255.255.255.0 172.16.1.1


· ip route 192.168.1.0 255.255.255.0 172.16.1.1

Vamos a realizar la configuración de una ruta en la cual para enviar una mensaje del Host 1 a
Host 5 tenga que seguir la siguiente ruta R1 – R2 – R3 y de retorno R3 – R2 - R1.

a. En R1 agregamos la ruta:

· ip route 199.6.13.0 255.255.255.0 172.16.1.2

b. En R2:

· ip route 199.6.13.0 255.255.255.0 172.16.2.1

c. Ahora para el retorno agregamos en R3 lo siguiente:

· ip route 192.168.1.0 255.255.255.0 172.16.2.2

d. En R2 se tiene que agregar lo siguiente, pero ya no es necesario ya que en el paso


anterior ya se agregó (R1 con R2), se pondrá por tema didáctico:

· ip route 192.168.1.0 255.255.255.0 172.16.1.1

De la misma forma realizar la configuración de las rutas estáticas en los demás Router. Las cuales
son las siguientes:

Configuración de Rutas

R1 a R2

 ip route 10.0.1.0 255.255.255.0 172.16.1.2


 ip route 199.6.13.0 255.255.255.0 172.16.1.2
 ip route 200.10.80.0 255.255.255.0 172.16.1.2
 ip route 172.16.2.0 255.255.255.252 172.16.1.2

21
FIEE UNMSM
R3 a R2

 ip route 192.168.1.0 255.255.255.0 172.16.2.2


 ip route 192.168.2.0 255.255.255.0 172.16.2.2
 ip route 200.10.80.0 255.255.255.0 172.16.2.2
 ip route 10.0.1.0 255.255.255.0 172.16.2.2
 ip route 172.16.1.0 255.255.255.252 172.16.2.2

R2 a R1

 ip route 192.168.1.0 255.255.255.0 172.16.1.1


 ip route 192.168.2.0 255.255.255.0 172.16.1.1

R2 a R3

 ip route 199.6.13.0 255.255.255.0 172.16.2.1

R2 a R4

 ip route 10.0.1.0 255.255.255.0 200.10.80.2

R4 a R2

 ip route 192.168.1.0 255.255.255.0 200.10.80.1


 ip route 192.168.2.0 255.255.255.0 200.10.80.1
 ip route 199.6.13.0 255.255.255.0 200.10.80.1
 ip route 172.16.1.0 255.255.255.252 200.10.80.1
 ip route 172.16.2.0 255.255.255.252 200.10.80.1

6. Se verifico la configuración de cada Router con el comando sh run, dándonos lo


siguiente:

R1 R2
R1#sh run R2#sh run
Building configuration... Building configuration...

Current configuration : 887 bytes Current configuration : 936 bytes


version 12.2 version 12.2
no service timestamps log datetime msec no service timestamps log datetime msec
no service timestamps debug datetime msec no service timestamps debug datetime msec
no service password-encryption no service password-encryption
hostname R1 hostname R2
enable password class enable password class

R3 R4
R3#sh run R4#sh run
Building configuration... Building configuration...

Current configuration : 903 bytes Current configuration : 858 bytes


version 12.2 version 12.2

22
FIEE UNMSM
no service timestamps log datetime msec no service timestamps log datetime msec
no service timestamps debug datetime msec no service timestamps debug datetime msec
no service password-encryption no service password-encryption
hostname R3 hostname R4
enable password class enable password class

Básicamente nos muestra la configuración de los Router, como por ejemplo su hostname y el
password que pusimos.

7. Se verifico las tablas de enrutamiento de cada Router con el comando sh ip route,


dándonos lo siguiente:

R1 R2
Gateway of last resort is not set Gateway of last resort is not set

10.0.0.0/24 is subnetted, 1 subnets 10.0.0.0/24 is subnetted, 1 subnets


S 10.0.1.0 [1/0] via 172.16.1.2 S 10.0.1.0 [1/0] via 200.10.80.2
172.16.0.0/30 is subnetted, 1 subnets 172.16.0.0/30 is subnetted, 2 subnets
C 172.16.1.0 is directly connected, Serial2/0 C 172.16.1.0 is directly connected, Serial2/0
C 192.168.1.0/24 is directly connected, FastEthernet0/0 C 172.16.2.0 is directly connected, Serial3/0
C 192.168.2.0/24 is directly connected, FastEthernet1/0 S 192.168.1.0/24 [1/0] via 172.16.1.1
S 199.6.13.0/24 [1/0] via 172.16.1.2 S 192.168.2.0/24 [1/0] via 172.16.1.1
S 200.10.80.0/24 [1/0] via 172.16.1.2 S 199.6.13.0/24 [1/0] via 172.16.2.1
C 200.10.80.0/24 is directly connected, FastEthernet0/0
R3 R4
Gateway of last resort is not set Gateway of last resort is not set

10.0.0.0/24 is subnetted, 1 subnets 10.0.0.0/24 is subnetted, 1 subnets


S 10.0.1.0 [1/0] via 172.16.2.2 C 10.0.1.0 is directly connected, FastEthernet1/0
172.16.0.0/30 is subnetted, 1 subnets S 192.168.1.0/24 [1/0] via 200.10.80.1
C 172.16.2.0 is directly connected, Serial2/0 S 192.168.2.0/24 [1/0] via 200.10.80.1
S 192.168.1.0/24 [1/0] via 172.16.2.2 S 199.6.13.0/24 [1/0] via 200.10.80.1
S 192.168.2.0/24 [1/0] via 172.16.2.2 C 200.10.80.0/24 is directly connected, FastEthernet0/0
C 199.6.13.0/24 is directly connected, FastEthernet0/0
S 200.10.80.0/24 [1/0] via 172.16.2.2

Las tablas de enrutamiento nos confirman lo que hemos realizado en la configuración


del enrutamiento estático, porque nos muestra las direcciones por las cuales tiene que pasar
para llegar a las otras redes y viene dado por la letra “S”.

8. Se comprobó la conectividad haciendo “ping” desde:

a. Host 1 – Host 3

23
FIEE UNMSM
b. Host 1 – Host 5

c. Host 1 – Host 7

d. Host 2 – Host 4

24
FIEE UNMSM
e. Host 2 – Host 6

f. Host 2 – Host 7

g. Host 3 – Host 5

h. Host 3 – Host 7

25
FIEE UNMSM
i. Host INTERNET – Host 7 / Host 1 / Host 6

9. Se verifico la ruta que siguen los datos con el comando trace o tracert:

a. R1 – R4

b. R3 – R4

26
FIEE UNMSM
c. Host 2 – R4

d. Host 4 – R4

10. Se comprobó la configuración de los Router con el comando telnet desde. Recordar
que la contraseña de todos los Reuters es “lab”:

a. R1 – R2

b. R2 – R3

c. R3 – R4

27
FIEE UNMSM
ENRUTAMIENTO DINAMICO RIP

a. Para este paso se desarrolló la siguiente estructura de la figura siguiente, se realizó


con el software Cisco Packet Tracer 6.0.1.

Fig 4

b. Cada Router se configuro asignándole los siguientes valores, tomando como


ejemplo el Router 1:
i. Nombre del host, en este caso R1:

Router>enable
Router#config terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# Hostname R1

ii. Password de la consola “cisco”:

R1(config)#line console 0
R1(config-line)#login
% Login disabled on line 0, until 'password' is set

28
FIEE UNMSM
R1(config-line)#password cisco
R1(config-line)#exit

iii. Password en Modo Privilegiado “class”:

R1(config)# enable password class


R1(config)#line vty 0 4
R1(config-line)#login
% Login disabled on line 132, until 'password' is set
% Login disabled on line 133, until 'password' is set
% Login disabled on line 134, until 'password' is set
% Login disabled on line 135, until 'password' is set
% Login disabled on line 136, until 'password' is set
R1(config-line)#password lab
R1(config-line)#exit

Estas configuraciones serán para todos los router, a excepción del nombre del host. Las
direcciones IP para cada puerto serán según la imagen:

Fig. 5

Para conectar Router con Router se usan sus puertos Serial disponibles, y para conectar
los Router con los host se usaran sus puertos Fasethernet.

Tomando como ejemplo el Router 5, y viendo la imagen Fig.5, configuraremos sus Router de la
siguiente manera. Primero lo haremos con su puerto serial, el cual en este caso es el Serial2/0:

R5(config)#interface Serial2/0
R5(config-if)#clock rate 64000
R5(config-if)#ip address 10.0.2.2 255.255.255.252

29
FIEE UNMSM
R5(config-if)#no shutdown
R5(config-if)#

Los FastEheternet se configuraron de la siguiente manera:

R5(config)#interface FastEthernet0/0
R5(config-if)#ip address 10.0.4.1 255.255.255.0
R5(config-if)#no shutdown

De la misma manera se realizara la configuración de los otros Router.

Para la configuración de lo host se realizó de la siguiente manera, se tomara como


ejemplo el host 1:

Hacer click sobre el host a configurar, en este caso al host 1, ir a “Desktop” y luego a “Ip
configuration” y poner los respectivos valores:

30
FIEE UNMSM
Se repetido los pasos para el resto de los host, con su respectiva IP y Gateway como indica la
Fig.5.

CONFIGURACION DE LAS RUTAS DINAMICAS

Para la configuración de las rutas dinámicas del Router nos guiaremos de la Fig.6:

Fig.6

Para eso vamos a tomar como ejemplo el Router R1.

a. Acceder a la programación del Router en modo consola (CLI). El sistema mostrará


el prompt con el nombre del equipo:
R1>

b. Entrar en el modo de ejecución de usuario privilegiado


R1> enable
R1#

c. Entrar en el modo de configuración global


R1# configure terminal
R1(config)#

d. Activar el protocolo de enrutamiento RIP en su versión 2 (RIPv2):


R1(config)> router rip
R1(config-router)# version 2
R1(config-router)#

e. Señalar las redes que conectan al Router con sus vecinos para que sean destino de
sus broadcast de publicación de la tabla de enrutamiento, en otras palabras las
redes conectadas al Router.
R1(config-router)# network 192.168.1.0

31
FIEE UNMSM
R1(config-router)# network 172.16.2.0

Siguiendo los mismos pasos para los demás Router tendremos el siguiente enrutamiento
dinámico.

Configuración de Rutas Dinámicas

R2

 network 192.168.1.0
 network 172.16.1.0

R3
 network 172.16.1.0
 network 172.16.2.0
 network 10.0.1.0

Los routers R4, R5 y R6 tendrán una configuracion RIP y estática:

El router R5 tendrá la siguiente configuración:

R5(config)> ip route 0.0.0.0 0.0.0.0 10.0.2.1

El router R6 tendrá la siguiente configuración:

R6(config)> ip route 0.0.0.0 0.0.0.0 10.0.3.1

Esta dirección (0.0.0.0 0.0.0.0) se ingresa como ruta estática y sirve para que el router envíe
cualquier cosa por la interfaz, es un ruta por defecto. Se usa para salir a internet mayormente.

El router R4 tendrá la siguiente configuración:

R4(config)> ip route 10.0.5.0 255.255.255.0 10.0.3.2


R4(config)> ip route 10.0.4.0 255.255.255.0 10.0.2.2
R4(config)> router rip
R4(config-router)# default-information originate
R4(config-router)# network 10.0.1.0

Como se ve se está usando tanto rutas estáticas como dinámicas, por tanto usamos el
comando “dafault-information originate”, este comando nos sirve para que el router con salida
a internet o con la ruta 0.0.0.0/0 la pueda compartir con todos los routers que están
configurados con el mismo protocolo.

14. Se verifico la configuración de cada Router con el comando sh run, dándonos lo


siguiente:

R1 R2
R1#sh run R2#sh run
Building configuration... Building configuration...

Current configuration : 791 bytes Current configuration : 773 bytes

32
FIEE UNMSM
version 12.2 version 12.2
no service timestamps log datetime msec no service timestamps log datetime msec
no service timestamps debug datetime msec no service timestamps debug datetime msec
no service password-encryption no service password-encryption
hostname R1 hostname R2
enable password class enable password class
R3 R4
R3#sh run R4#sh run
Building configuration... Building configuration...

Current configuration : 815 bytes Current configuration : 773 bytes


version 12.2 version 12.2
no service timestamps log datetime msec no service timestamps log datetime msec
no service timestamps debug datetime msec no service timestamps debug datetime msec
no service password-encryption no service password-encryption
hostname R3 hostname R4
enable password class enable password class
R5 R6
R5#sh run R6#sh run
Building configuration... Building configuration...

Current configuration : 761 bytes Current configuration : 743 bytes


version 12.2 version 12.2
no service timestamps log datetime msec no service timestamps log datetime msec
no service timestamps debug datetime msec no service timestamps debug datetime msec
no service password-encryption no service password-encryption
hostname R5 hostname R6
enable password class enable password class

Básicamente nos muestra la configuración de los Router, como por ejemplo su hostname y el
password que pusimos.

15. Se verifico las tablas de enrutamiento de cada Router con el comando sh ip route,
dándonos lo siguiente:

R1 R2
Gateway of last resort is 172.16.2.2 to network 0.0.0.0 Gateway of last resort is 172.16.1.2 to network 0.0.0.0

R 10.0.0.0/8 [120/1] via 172.16.2.2, 00:00:17, Serial2/0 R 10.0.0.0/8 [120/1] via 172.16.1.2, 00:00:21, Serial3/0
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks 172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
R 172.16.0.0/16 [120/1] via 192.168.1.2, 00:00:16, R 172.16.0.0/16 [120/1] via 192.168.1.1, 00:00:04, Serial2/0
Serial3/0 C 172.16.1.0/30 is directly connected, Serial3/0
R 172.16.1.0/30 [120/1] via 172.16.2.2, 00:00:17, R 172.16.2.0/30 [120/1] via 172.16.1.2, 00:00:21, Serial3/0
Serial2/0 192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C 172.16.2.0/30 is directly connected, Serial2/0 R 192.168.1.0/24 is possibly down, routing via 172.16.1.2,
192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks Serial3/0
R 192.168.1.0/24 is possibly down, routing via C 192.168.1.0/30 is directly connected, Serial2/0
192.168.1.2, Serial3/0 R* 0.0.0.0/0 [120/2] via 172.16.1.2, 00:00:21, Serial3/0
C 192.168.1.0/30 is directly connected, Serial3/0
R* 0.0.0.0/0 [120/2] via 172.16.2.2, 00:00:17, Serial2/0
R3 R4

33
FIEE UNMSM
Gateway of last resort is 10.0.1.2 to network 0.0.0.0 Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks 10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C 10.0.1.0/24 is directly connected, FastEthernet0/0
C 10.0.1.0/24 is directly connected, FastEthernet0/0
R 10.0.2.0/30 [120/1] via 10.0.1.2, 00:00:21, FastEthernet0/0
C 10.0.2.0/30 is directly connected, Serial2/0
R 10.0.3.0/30 [120/1] via 10.0.1.2, 00:00:21, FastEthernet0/0
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks C 10.0.3.0/30 is directly connected, Serial3/0
R 172.16.0.0/16 [120/2] via 172.16.2.1, 00:00:24, Serial2/0 S 10.0.4.0/24 [1/0] via 10.0.2.2
C 172.16.1.0/30 is directly connected, Serial3/0 S 10.0.5.0/24 [1/0] via 10.0.3.2
C 172.16.2.0/30 is directly connected, Serial2/0 R 172.16.0.0/16 [120/1] via 10.0.1.1, 00:00:10,
R 192.168.1.0/24 is possibly down, routing via 172.16.1.1, FastEthernet0/0
Serial3/0 R 192.168.1.0/24 is possibly down, routing via 10.0.1.1,
R* 0.0.0.0/0 [120/1] via 10.0.1.2, 00:00:21, FastEthernet0/0 FastEthernet0/0
R5 R6
Gateway of last resort is 10.0.2.1 to network 0.0.0.0 Gateway of last resort is 10.0.3.1 to network 0.0.0.0

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks 10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.0.2.0/30 is directly connected, Serial2/0 C 10.0.3.0/30 is directly connected, Serial2/0
C 10.0.4.0/24 is directly connected, FastEthernet0/0 C 10.0.5.0/24 is directly connected, FastEthernet0/0
S* 0.0.0.0/0 [1/0] via 10.0.2.1 S* 0.0.0.0/0 [1/0] via 10.0.3.1

Las tablas de enrutamiento nos confirman lo que hemos realizado en la configuración


del enrutamiento dinámico, porque nos muestra las direcciones por las cuales tiene que pasar
para llegar a las otras redes y viene dado por la letra “R”, y nos dice que ruta siguió para llegar a
las otras redes. Aparte las rutas estáticas que configuramos en R4,R5 y R6, así como la ruta
0.0.0.0 por defecto que pusimos anteriormente.

16. Se comprobó la conectividad haciendo “ping” desde:

a. Host 1 – Host 2

b. Host 1 – Host 3

34
FIEE UNMSM
c. Host 2 – Host 3

d. Host 2 – R2

e. Host 3 – R1

f. Host 3 – R3

35
FIEE UNMSM
17. Se verifico la ruta que siguen los datos con el comando trace o tracert:

a. R5 – R6

b. R2 – R5

c. R1 – R6

18. Se comprobó la configuración de los Router con el comando telnet desde, recordando
que el password es “lab”:

a. R1 – R5

b. R2 – R6

36
FIEE UNMSM
c. R3 – R4

CONCLUSIONES

DEL RUTEO ESTÁTICO SE PUEDE CONCLUIR LO SIGUIENTE :

El ruteo estático es la forma más sencilla y que menos conocimientos exige para
configurar las tablas de ruteo en un dispositivo. Es un método manual que requiere que el
administrador indique explícitamente en cada equipo las redes que puede alcanzar y por qué
camino hacerlo.

La ventaja de este método, además de la simpleza para configurarlo, es que no supone


ninguna sobrecarga adicional sobre los routers y los enlaces en una red. Sin embargo, las
desventajas principales son determinantes en muchos casos para no escoger este método.

Por un lado, configurar rutas estáticas en una red de más de unos pocos routers puede
volverse un trabajo muy engorroso para el administrador, además de aumentar la probabilidad
de cometer un error, en cuyo caso puede llegar a ser bastante dificultoso encontrar dicho error.
Pero además, existe un problema aún más importante: la redundancia (el uso de un Router de
respaldo por si falla el Router principal). Cuando se utiliza ruteo estático en una red con
redundancia y hay un fallo en un enlace el administrador debe modificar las rutas
manualmente, lo cual implica un tiempo de respuesta ante una falla mucho mayor que si se
utiliza un método automático.

DEL RUTEO DINÁMICO SE PUEDE CONCLUIR LO SIGUIENTE :

En contraposición con el método estático, el ruteo dinámico utiliza diferentes protocolos


cuyo fin es el de intercambiar rutas entre dispositivos intermedios con el objetivo de tener una
red totalmente accesible. En este caso, los routers envían y reciben información de
enrutamiento que utilizan para armar sus tablas de ruteo.

El ruteo dinámico tiene varias ventajas que lo convierten en el preferido en la mayoría


de los casos: configurar el ruteo en una red mediana a grande implica mucho menos trabajo
para el administrador, a la vez que permite que la red completa se ponga en funcionamiento en
un tiempo mucho menor; es capaz también de adaptarse a los problemas, ya que puede detectar
la falla de un enlace principal y utilizar entonces un enlace alternativo para alcanzar el destino
(si lo hubiera).

Las desventajas son que, al intercambiar información entre los dispositivos y requerir
que cada router procese dicha información se utiliza tanto ancho de banda de los enlaces como
tiempo de procesamiento en los equipos, lo cual en algunas circunstancias puede convertirse en

37
FIEE UNMSM
un problema. Adicionalmente, dependiendo del protocolo que se utilice, el enrutamiento
dinámico requiere un mayor conocimiento por parte del administrador, tanto para configurarlo
de forma correcta como para solucionar problemas.

BIBLOGRAFIA

[1] http://es.kioskea.net/contents/internet-2096316497
[2] http://cert.inteco.es/extfrontinteco/img/File/intecocert/EstudiosInformes/cert_inf_se
guridad_analisis_trafico_wireshark.pdf
[3] http://support.microsoft.com/kb/164015/es
[4] http://www.slideshare.net/DougCesp/caracteristicas-tecnicas-11281014

38
FIEE UNMSM