Sei sulla pagina 1di 7

EIGRP

router eigrp 1

redistribute static metric 100 10 255 1 1500

passive-interface Loopback0

network 2.2.2.0 0.0.0.255

network 192.168.12.0

network 192.168.24.0

metric weights 0 1 0 1 1 0

distribute-list 10 out eigrp 1

distribute-list prefix pref-lyptus out FastEthernet3/0

distribute-list prefix pref-walnut out FastEthernet1/0

neighbor 192.168.13.1 Serial0/0

eigrp stub connected summary

no auto-summary

variance 2

key chain GNS3VAULT

key 1

key-string WOOD

interface FastEthernet0/0

ip address 192.168.24.4 255.255.255.0

ip authentication mode eigrp 1 md5

ip authentication key-chain eigrp 1 GNS3VAULT

duplex auto

speed auto

interface FastEthernet3/0

ip address 192.168.54.4 255.255.255.0

ip summary-address eigrp 1 0.0.0.0 248.0.0.0 51

duplex auto

speed auto

!
ip prefix-list pref-lyptus seq 10 deny 192.168.54.0/24 ge 25

ip prefix-list pref-lyptus seq 20 permit 0.0.0.0/0

ip prefix-list pref-walnut seq 10 deny 192.168.54.0/24 ge 25

ip prefix-list pref-walnut seq 20 permit 0.0.0.0/0

access-list 10 deny 5.5.5.0 0.0.0.255

access-list 10 permit any

interface Serial0/0

ip address 192.168.33.6 255.255.255.0

encapsulation frame-relay

no ip split-horizon eigrp 1

serial restart-delay 0

frame-relay map ip 192.168.33.3 603 broadcast

frame-relay map ip 192.168.33.7 603 broadcast

no frame-relay inverse-arp

bandwidth 1001

ip bandwidth-percent eigrp 1 25

delay 1

OSPF

#sh ip ospf neighbor

#sh ip ospf interface serial 0

#debug ip ospf adj

#ip ospf priority (1 is default if set to 0 then route will not participate in election)

#router-id

OSPF virtual link – use the RID of remote router.

R4(config)#router ospf 1

R4(config-router)#area 34 virtual-link 3.3.3.3

R3(config)#router ospf 1

R3(config-router)#area 34 virtual-link 4.4.4.4

#sh ip eigrp 100 interfaces detail s1/3 (to see the hello and hold timer value)

#timers active-time 1 (1 minutes)


(config)#logging buffer debug

(config)#logging buffer 100000

debug eigrp packet query reply

summary-metric 0.0.0.0/0 distance 30

R1(config)#router eigrp INE

R1(config-router)#address-family ipv4 unicast autonomous-system 100

R1(config-router-af)#af-interface loopback 5

R1(config-router-af-interface)#shut

R1(config-router-af-interface)#exit-af-interface

R1(config-router-af)#af-interface s1/3

R1(config-router-af-interface)#summary-address 0.0.0.0/0

R1(config-router-af)#exit-address-family

R1(config)#access-list 1 deny 111.111.111.32 0.0.0.15

R1(config)#access-list 1 permit any

R1(config-router-af)#topology base

R1(config-router-af-topology)#distribute-list 1 out

R1(config-router-af)#network 1.2.1.0 0.0.0.255

R1(config-router-af)#network 1.4.1.0 0.0.0.255

Ospf Network type

--------------------------

NBMA

#config t

#int e0/0

#encapsulation frame-relay

#frame-relay map 1.1.1.1 101

#ip ospf network non-broadcast

#router ospf 1

#neighbor 2.2.2.2 area 0

(note: neighbor need to define manually)

But we can trick this as mentioned below

#int e0/0

#encapsulation frame-relay

#frame-relay map 1.1.1.1 101 broadcast


#ip ospf network broadcast

(Note: now we do not need to define neighbor manually)

Point to poing like T1 line (HDLC and PPP)

---------------------------------------------------------

#int s0/0

#encapsulation frame-relay

#int s0/0.1 point-to-point

#frame-relay map 1.1.1.1 101 broadcast

#ip ospf network point-to-point

The default ospf network type for point to multipoint it NBMA. However OSPF support an additional

Network type called point-to-multipoint on which we do not discover neighbor manually.

#int s0/0

#encapsulation frame-relay

#int s0/0.1 multipoint

#frame-relay map ip 1.1.1.1 101 broadcast

#ip ospf network point-to-multipoint

(Note: neighbor will discover automatically)

If add non-broadcast then we need to discover neighbor manually

#int e0/0

#encapsulation frame-relay

#int e0/0.1 multipoint

#frame-relay map ip 1.1.1.1 101

#ip ospf network point-to-multipoint non-broadcast

#router ospf 1

#neighbor 10.1.1.1

Cost changing of ospf

------------------------------------

#int s0/0

#bandwidth 64

#int s0/0

#ip ospf cost 20


#router ospf 1

#ip ospf auto-cost reference-bandwidth 100

Authentication

#router ospf 1

#network 1.1.1.0 0.0.0.255 area 1

#area 1 authentication

#int e0/0

#ip ospf authentication

#ip ospf authentication-key cisco123

#router ospf1

#network 1.1.1.0 0.0.0.255 area 1

#area 1 authentication message-digest

#int e0/0

#ip ospf authentication message-digest-key 10 md5 cisco123

Virtual Link

(Router B ABR)

#router ospf 1

#router-id 2.2.2.2

#area 1 virtual-link 3.3.3.3

(Router C ABR)

#router ospf 1

#router-id 3.3.3.3

#area 1 virtual-link 2.2.2.2

Always remember: the area specified in the virtual-link command is the

transit area. Additionally, the transit area cannot be a stub area

As stated earlier, if authentication is enabled for Area 0, the same

authentication must be configured on Virtual Links, as they are “extensions”

of Area 0:

RouterB(config)# router ospf 1

RouterB(config-router)# area 1 virtual-link 3.3.3.3 message-digest-key 1 md5 MYKEY

RouterC(config)# router ospf 1

RouterC(config-router)# area 1 virtual-link 2.2.2.2 message-digest-key 1 md5 MYKEY


Summarization

#router ospf 1

#network 10.1.0.0 0.0.7.255 area 1

#area 1 range 10.1.0.0 255.255.248.0

External ospf summarization

External Summarization is configured on ASBRs, and will only

summarize external routes learned by route redistribution. Configuration on

Router B would be as follows:

RouterB(config)# router ospf 1

RouterB(config-router)# summary-address 15.0.0.0 255.252.0.0

Summarization can be used to filter certain routes (true route filtering is

covered in a separate guide). To force OSPF to advertise the 15.0.0.0 and

15.1.0.0 networks as a summarized route, but not advertise the 15.2.0.0 and

15.3.0.0 prefixes:

RouterB(config)# router ospf 1

RouterB(config-router)# summary-address 15.0.0.0 255.254.0.0

RouterB(config-router)# summary-address 15.2.0.0 255.255.0.0 not-advertise

RouterB(config-router)# summary-address 15.3.0.0 255.255.0.0 not-advertise

Areas

Configuration of stub areas is relatively simple:

Router(config)# router ospf 1

Router(config-router)# network 10.1.0.0 0.0.7.255 area 1

Router(config-router)# area 1 stub

The area 1 stub command must be configured on all routers in the Stub area.

No ASBRs are allowed in a Stub area.

Configuration of totally stubby areas is relatively simple:

Router(config)# router ospf 1

Router(config-router)# network 10.1.0.0 0.0.7.255 area 1

Router(config-router)# area 1 stub no-summary

The area 1 stub no-summary command is configured only on the ABR of

the Totally Stubby area; other routers within the area are configured with the

area 1 stub command. No ASBRs are allowed in a Totally Stubby area.

Potrebbero piacerti anche