Sei sulla pagina 1di 12

Per scrivere una formula in Excel, bisogna sempre cominciare con un = davanti (es.

A2*B3 non fa niente,


per ottenere il prodotto dei valori nelle due celle si scrive: =A2*B3

=SOMMA(A1; B3; … C9) = somma i valori contenuti nelle singole celle specificate, separate da punto e
virgola ;

=SOMMA(A2:A10) = somma i valori di tutte le celle contenute nell’intervallo (indicato dai due punti : , come
in Matlab)

Non esiste una funzione SOTTRAZIONE. Si effettua una somma, ma i sottraendi vanno posti negativi (così la
somma algebrica diventa a tutti gli effetti una sottrazione)

5*2 = moltiplica i due numeri. Il simbolo del prodotto è l’asterisco * , esattamente come in Matlab

Per moltiplicare una colonna di numeri (es. la colonna A) per un numero costante, es contenuto nella cella
B2, si va su una colonna libera (es. la C) e sulla prima cella si digita A1 * $B$ 2. Il simbolo del dollaro tiene
fissa la cella B2. Poi trascinando giù i valori delle celle nella colonna A scorrono, mentre il moltiplicatore B2
resta fisso. Il simbolo del $ dà il cosiddetto “riferimento assoluto” a quella cella.

=PRODOTTO(A2; B10) moltiplica i valori all’interno delle singole celle specificate, separate da punto e
virgola ;

=PRODOTTO(A2:A10) moltiplica fra loro i valori di tutte le celle nell’intervallo indicato dai due punti :

=PRODOTTO(A2:A10 ; C4) moltiplica fra loro tutti i valori nell’intervallo, e a sua volta il risultato viene
moltiplicato per il valore contenuto nella cella C4

N.B = se ho ben capito, se Excel è in inglese, al posto del punto e virgola ; si usa la virgola , per separare dei
valori singoli all’interno di una formula

Non esiste una funzione DIVISIONE. Si usa la /. Anche in questo caso va sempre messo un = all’inizio della
riga, altrimenti la / viene automaticamente interpretata da Excel come separatore di una data.

=QUOZIENTE(A1; C5) smentendo quanto appena detto, questa operazione effettua la “divisione intera”, il
che vuol dire che dà il quoziente, ma non il resto. Quindi in effetti non è una vera e propria divisione. Dà la
parte intera del risultato della divisione. Es. QUOZIENTE(5;2) dà come risultato 2. Se la divisione considerata
non ha resto, siamo fortunati e il quoziente corrisponde al quoto, e quindi al risultato esatto della divisione.
Dà risultati anche negativi.

Se Excel è in italiano, i numeri decimali si mettono con la virgola. Se è in inglese, si mettono col punto.

La funzione SE equivale all’IF di Matlab.


Esempio: =SE(C2="Sì" ; 1 ; 2)
La dicitura qui sopra significa: Se il contenuto della cella C2 è la stringa “Sì” (quindi se la condizione è vera)
restituisci come risultato 1. Altrimenti, se la condizione è falsa, restituisci come risultato 2. La presenza
della condizione di ELSE è opzionale. Nel caso la condizione di ELSE non sia presente, e la condizione dell’if
non sia soddisfatta, Excel restituisce automaticamente il risultato FALSO. Il risultato appare ovviamente
nella cella all’interno della quale viene scritta la formula SE.
Le condizioni vengono separata da punto&virgola (credo solo in italiano, e da virgole in inglese).
È possibile annidare varie condizioni SE, ed anche eseguire calcoli al loro interno.

- Procedure utili per la condizione SE:

=SE(E7="Sì";F5*0,0825;0)
In questo esempio la formula nella cella F7 dice SE(E7 = "Sì", allora moltiplica
l'importo totale nella cella F5 * 8,25%, altrimenti non sono dovute imposte quindi
restituisci 0)

Nell'ultimo esempio nella formula vengono immessi direttamente sia "Sì" che
l'aliquota dell'imposta (0,0825). In generale, non è consigliabile immettere costanti
letterali, ossia valori che potrebbero dover cambiare nel corso del tempo,
direttamente nelle formule, perché possono essere difficili da trovare e cambiare
nel futuro. È preferibile invece inserire le costanti in celle specifiche, dove è
possibile trovarle e cambiarle facilmente (es se la costante è nella cella A2, anziché scrivere il valore
della costante, scrivo solo A2, così se devo cambiare il valore della costante, lo cambio solo nella
cella A2, e mi si modifica tutto di conseguenza). In questo caso la formula è accettabile
perché c'è una sola funzione SE ed è improbabile che l'aliquota dell'imposta cambi.
E anche se dovesse cambiare, sarà facile modificarla nella formula.

- Alcuni possibili operatori matematici utilizzabili (anche all’interno della funzione SE):

VAL.VUOTO(D2) verifica che la cella D2 sia vuota


=SE(VAL.VUOTO(D2) ; … ; …) usata all’interno di una condizione SE
Un risultato analogo si ottiene anche con le virgolette: =SE(D2=””; … ; …)

=SE(D3="";"";Formula())
SE(D3 non è niente, allora non restituire niente, altrimenti calcola la formula all’interno di D3).
- ESEMPIO DI FUNZIONI SE ANNIDATE:

Mentre una funzione SE semplice restituisce solo due risultati (Vero o Falso), quelle
annidate possono generare da 3 a 64 risultati.
=SE(D2=1;"SÌ";SE(D2=2;"No";"Forse"))
Nella figura precedente la formula nella cella E2 dice: SE(D2 è uguale a 1, allora
restituisci "Sì", altrimenti SE(D2 è uguale a 2, allora restituisci "No", altrimenti
restituisci "Forse")). Notare che alla fine della formula sono presenti due parentesi di
chiusura. Queste sono necessarie per completare entrambe le funzioni SE e se si
prova a immettere la formula senza entrambe le parentesi di chiusura, Excel tenterà
di correggerla automaticamente.

!!!Attenzione:
Anche se Excel consente di annidare fino a 64 funzioni SE diverse, non è
consigliabile adottare questo approccio. Perché?
La creazione di più istruzioni SE valide richiede molta attenzione ed è necessario
verificare che la logica possa essere calcolata correttamente attraverso ogni
condizione fino alla fine. Se le istruzioni SE vengono annidate in modo
completamente corretto, la formula potrebbe funzionare il 75% delle volte, ma
restituire risultati imprevisti nel restante 25%. Purtroppo, le probabilità di capire il
problema in quel 25% di occorrenze sono scarse.
Più istruzioni SE possono diventare molto difficili da gestire, soprattutto se in
seguito si deve provare a capire cosa si stava cercando di ottenere o, peggio
ancora, qual era l'obiettivo di qualcun altro.
Più istruzioni SE richiedono più parentesi di apertura e di chiusura, che possono
essere difficili da gestire a seconda della complessità della formula.

- Problemi comuni:

0 (zero) in una cella  Non è stato specificato un argomento per se_vero o se_falso. Per
restituire il valore corretto, aggiungere del testo ai due argomenti
o aggiungere VERO o FALSO all'argomento.

#NOME? in una cella  Questo errore indica in genere che la formula non è stata digitata
correttamente.

La funzione SE accetta anche i comandi logici di > o <.


=CONTASE(…) conta le celle che soddisfano determinati criteri.

=CONTA.SE(A2:A5;"mele") Conta il numero di celle contenenti "mele" nell'intervallo compreso


tra A2 e A5. Il risultato è 2.

=CONTA.SE(A2:A5;A4) Conta il numero di celle contenenti "pesche" (il valore in A4)


nell'intervallo compreso tra A2 e A5. Il risultato è 1.

=CONTA.SE(A2:A5;A2)+CONTA.SE(A2:A5;A3) Conta il numero di celle contenenti "mele" (il valore in A2) e


"arance" (il valore in A3) nell'intervallo compreso tra A2 e A5.
Il risultato è 3. Questa formula usa CONTA.SE due volte
per specificare più criteri, uno per ogni espressione.
Si può anche usare la funzione CONTA.PIÙ.SE.

=CONTA.SE(B2:B5;">55") Conta il numero di celle contenenti un valore maggiore di 55


nell'intervallo compreso tra B2 e B5. Il risultato è 2.

=CONTA.SE(B2:B5;"<>"&B4) Conta il numero di celle contenenti un valore diverso da 75


nell'intervallo compreso tra B2 e B5. La e commerciale (&) unisce
l'operatore di confronto "non uguale a" (<>) e il valore in B4
per leggere =CONTA.SE(B2:B5; "<>75"). Il risultato è 3.

=CONTA.SE(B2:B5;">=32")- Conta il numero di celle contenenti un valore maggiore (>)


CONTA.SE(B2:B5;">85") o uguale (=) a 32 e minore (<) o uguale (=) a 85 nell'intervallo
compreso tra B2 e B5. Il risultato è 3.

=CONTA.SE(A2:A5; "*") Conta il numero di celle contenenti testo nell'intervallo compreso


tra A2 e A5. L'asterisco (*) viene usato come carattere jolly
corrispondente a un carattere qualsiasi. Il risultato è 4.

=CONTA.SE(A2:A5; "?????le") Conta il numero di celle che hanno esattamente 7 caratteri e


terminano con le lettere "le" nell'intervallo compreso tra A2 e
A5. Il punto interrogativo (?) viene usato come carattere jolly
corrispondente a un singolo carattere. Il risultato è 2.

=SOMMA.SE(intervallo; condizione);
Esempio: =SOMMA.SE(B2:B25;">5") somma i valori (compresi nell’intervallo/colonna B2:B25)
che siano maggiori di 5. Restituisce come risultato questa somma.

In realtà la sintassi completa di SOMMA.SE è la seguente:

SOMMA.SE(intervallo; criteri; [int_somma])


Gli argomenti della sintassi della funzione SOMMA.SE sono i seguenti:
 intervallo Obbligatorio. Intervallo di celle da valutare in base ai criteri. Le celle di ogni intervallo
devono contenere numeri oppure nomi, matrici o riferimenti che includono numeri. Le celle vuote
e i valori di testo verranno ignorati. L'intervallo selezionato può contenere date nel formato
standard di Excel (vedere gli esempi di seguito).
 criteri Obbligatorio. Criteri in forma di numero, espressione, riferimento di cella, testo o funzione
che definisce le celle che verranno sommate. Ad esempio, è possibile esprimere i criteri come 32,
">32", B5, "32", "mele" oppure OGGI().
Importante: Qualsiasi criterio di testo o di altro tipo comprendente simboli logici o matematici
deve essere racchiuso tra virgolette doppie ("). Se il criterio è numerico, le virgolette doppie non
saranno necessarie.
 int_somma Facoltativo. Celle effettivamente da sommare, se si vogliono sommare celle diverse da
quelle specificate nell'argomento intervallo. Se l'argomento int_somma è omesso, verranno
sommate le celle specificate nell'argomento intervallo, ovvero le stesse celle a cui vengono
applicati i criteri.
 Nell'argomento criteri è possibile usare i caratteri jolly, ovvero il punto interrogativo (?) e
l'asterisco (*). Usare il punto interrogativo e l'asterisco per indicare rispettivamente un carattere
singolo e una sequenza di caratteri qualsiasi. Se si desidera trovare un punto interrogativo o un
asterisco, digitare una tilde (~) prima del carattere.
Osservazioni
 La funzione SOMMA.SE restituirà risultati non corretti se usata per la corrispondenza con stringhe
contenenti più di 255 caratteri o con la stringa #VALORE!.
 L'argomento int_somma non deve necessariamente avere le stesse dimensioni e forma
dell'argomento intervallo. Le celle effettivamente da sommare vengono determinate usando la
cella superiore sinistra dell'argomento int_somma come cella iniziale e includendo le celle che
corrispondono all'argomento intervallo in termini di dimensioni e forma.

Se si vuole, è possibile applicare i criteri a un intervallo e sommare i valori corrispondenti in un altro


intervallo. Ad esempio, la formula =SOMMA.SE(B2:B5; "Luca"; C2:C5) sommerà solo i valori dell'intervallo
C2:C5 per cui il contenuto delle celle corrispondenti nell'intervallo B2:B5 è uguale a "Luca".

= SOMMA.PIÙ.SE è una funzione che somma tutti i suoi argomenti che soddisfano più criteri. Ad esempio,
è possibile usare SOMMA.PIÙ.SE per sommare il numero dei rivenditori nel paese che (1) hanno lo stesso
codice postale e (2) i cui profitti superano un importo specifico.

SOMMA.PIÙ.SE(int_somma; intervallo_criteri1; criteri1; [intervallo_criteri2; criteri2]; ...)

int_somma (obbligatorio) = Intervallo di celle da sommare.

intervallo_criteri1 (obbligatorio) = Intervallo testato tramite criteri1.

intervallo_criteri1 e criteri1 impostano una coppia di ricerca in base alla quale eseguire la ricerca di criteri
specifici in un intervallo. Una volta trovati gli elementi nell'intervallo, vengono sommati i valori
corrispondenti in int_somma.

criteri1 (obbligatorio) = Criteri che definiscono quali celle in intervallo_criteri1 verranno sommate. Ad
esempio, i criteri possono essere immessi come 32, ">32", B4, "mele" o "32".
intervallo_criteri2; criteri2; ... (facoltativo)

Intervalli aggiuntivi e criteri associati. È possibile immettere fino a 127 coppie di intervalli/criteri.

=SOMMA.PIÙ.SE(A2:A9;B2:B9;"=A*";C2:C9;"Luca")

=SOMMA.PIÙ.SE(A2:A9;B2:B9;"<>Banane";C2:C9;"Luca")

=CERCA.VERT è una funzione di ricerca e riferimento, che serve per trovare elementi in una tabella o in un
intervallo per riga, ad esempio per cercare il prezzo di un pezzo di ricambio di un'auto in base al numero di
articolo.

Nella sua forma più semplice, la sintassi della funzione CERCA.VERT è la seguente:

=CERCA.VERT(valore da cercare; intervallo in cui cercare il valore; numero di colonna nell'intervallo che
contiene il valore restituito; Corrispondenza esatta o Corrispondenza approssimativa, indicata come
0/FALSO o 1/VERO).

Per creare la sintassi di CERCA.VERT sono necessari quattro tipi di informazioni:

1. Il valore da cercare, detto anche valore di ricerca.

2. L'intervallo che contiene il valore di ricerca. Tenere presente che il valore di ricerca deve trovarsi
sempre nella prima colonna dell'intervallo affinché CERCA.VERT funzioni correttamente. Ad
esempio, se il valore di ricerca è nella cella C2, l'intervallo deve iniziare con C.

3. Il numero di colonna nell'intervallo che contiene il valore restituito. Ad esempio, se si specifica B2:
D11 come intervallo, occorre considerare B come la prima colonna, C come la seconda e così via.

4. Se si vuole, si può specificare VERO se si vuole ottenere una corrispondenza approssimativa o


FALSO se si vuole ottenere una corrispondenza esatta del valore restituito. Se non si specifica nulla,
il valore predefinito sarà sempre VERO o una corrispondenza approssimativa.

Ora disporre tutte queste informazioni nel modo seguente:

=CERCA.VERT(valore di ricerca; intervallo che contiene il valore di ricerca; numero di colonna nell'intervallo
che contiene il valore restituito; (facoltativo) VERO per una corrispondenza approssimativa o FALSO per una
corrispondenza esatta).

=CONTA.VALORI(A1:A6) conta il numero di celle presenti nell’intervallo indicato

=MIN(B1:B7) trova il valore minimo nell’intervallo indicato

=MAX(B1:B7) trova il valore massimo nell’intervallo indicato


=E La funzione E è una funziona logica, utilizzata per determinate se tutte le condizioni in un test sono
vere.

=E(A2>1;A2<100) Visualizza VERO se A2 è maggiore di 1 E minore di 100, altrimenti visualizza


FALSO.
=SE(E(A2<A3; A2<100); A2; "Il valore non è Visualizza il valore nella cella A2 se è minore di A3 E minore di 100, altrimenti
compreso nell'intervallo.") visualizza il messaggio "Il valore non è compreso nell'intervallo".
=SE(E(A3>1;A3<100); A3; "Il valore non è Visualizza il valore nella cella A3 se è maggiore di 1 E minore di 100, altrimenti
compreso nell'intervallo") viene visualizzato un messaggio. È possibile sostituire qualsiasi messaggio a
scelta.

=O funzione usata per verificare se tutte le condizioni in un test danno come risultato VERO.

=O(A2>1,A2<100) Visualizza VERO se A2 è maggiore di 1 O minore di 100, altrimenti visualizza


FALSO.

=SE(O(A2>1,A2<100), A3, "Il valore non è Visualizza il valore nella cella A3 se è maggiore di 1 O minore di 100, altrimenti
compreso nell'intervallo") visualizza il messaggio "Il valore non è compreso nell'intervallo".

=SE(O(A2<0,A2>50),A2, "Il valore non è Visualizza il valore nella cella A2 se è minore di 0 O maggiore di 50, altrimenti
compreso nell'intervallo") viene visualizzato un messaggio.

= NON funzione usata per verificare che un determinato valore non coincida con un altro.

=NON(A2>100) A2 NON è maggiore di 100

=SE(E(NON(A2>1);NON(A2<100));A2;"Il valore non 50 è maggiore di 1 (VERO) E 50 è minore di 100 (VERO), quindi la


è compreso nell'intervallo") funzione NON inverte entrambi gli argomenti in FALSO. E richiede che
entrambi gli argomenti abbiano il valore VERO, quindi restituisce il
risultato se è FALSO.

=SE(O(NON(A3<0);NON(A3>50));A3;"Il valore non 100 non è minore di 0 (FALSO) e 100 è maggiore di 50 (VERO), quindi la
è compreso nell'intervallo") funzione NON inverte gli argomenti in VERO/FALSO. O richiede che un
solo argomento abbia il valore VERO, quindi restituisce il risultato se è
VERO.
Ecco alcuni esempi di come strutturare le funzioni E, O e NON singolarmente. Quando si combina ognuna di
esse con un'istruzione SE, la struttura è la seguente:

 E – =SE(E(Una condizione è vera; Un'altra condizione è vera); Valore se Vero; Valore se Falso)

 O – =SE(O(Una condizione è vera; Un'altra condizione è vera); Valore se Vero; Valore se Falso)

 NON – =SE(NON(Una condizione è vera); Valore se Vero; Valore se Falso)

=SE(E(A2>0;B2<100);VERO; FALSO) SE A2 (25) è maggiore di 0 E B2 (75) è minore di 100, restituisci VERO,


altrimenti FALSO. In questo caso entrambe le condizioni sono vere, quindi
viene restituito VERO.

=SE(E(A3="Rosso";B3="Verde");VERO;FALSO) SE A3 ("Blu") è uguale a "Rosso" E B3 ("Verde") è uguale a "Verde" restituisci


VERO, altrimenti FALSO. In questo caso è vera solo la prima condizione, quindi
viene restituito FALSO.

=SE(O(A4>0;B4<50);VERO; FALSO) SE A4 (25) è maggiore di 0 O B4 (75) è minore di 50, restituisci VERO,


altrimenti FALSO. In questo caso è vera solo la prima condizione, ma poiché
per O è sufficiente che un solo argomento sia vero la formula restituisce
VERO.

=SE(O(A5="Rosso";B5="Verde"); SE A5 ("Blu") è uguale a "Rosso" O B5 ("Verde") è uguale a "Verde" restituisci


VERO;FALSO) VERO, altrimenti FALSO. In questo caso il secondo argomento è vero, quindi la
formula restituisce VERO.

=SE(NON(A6>50);VERO;FALSO) SE A6 (25) NON è maggiore di 50 restituisci VERO, altrimenti FALSO. In questo


caso 25 non è maggiore di 50, quindi la formula restituisce VERO.

=SE(NON(A7="Rosso");VERO;FALSO) SE A7 ("Blu") NON è uguale a "Rosso" restituisci VERO, altrimenti FALSO.

Si noti che in tutti gli esempi ogni condizione è seguita da una parentesi chiusa. Gli argomenti Vero/Falso
rimanenti fanno quindi parte dell'istruzione SE esterna. È anche possibile sostituire i valori VERO/FALSO con
valori di testo o numerici da restituire negli esempi.

Ecco alcuni esempi di utilizzo delle funzioni E, O e NON per valutare date.

=SE(A2>B2;VERO;FALSO) SE A2 è maggiore di B2 restituisci VERO, altrimenti FALSO. In questo caso 12/03/14 è


maggiore di 01/01/14, quindi la formula restituisce VERO.

=SE(E(A3>B2;A3<C2);VERO;FALSO) SE A3 è maggiore di B2 E A3 è maggiore di C2 restituisci VERO, altrimenti FALSO. In


questo caso entrambi gli argomenti sono veri, quindi la formula restituisce VERO.

=SE(O(A4>B2;A4<B2+60);VERO;FALSO) SE A4 è maggiore di B2 O A4 è minore di B2 + 60 restituisci VERO, altrimenti FALSO.


In questo caso il primo argomento è vero, ma il secondo è falso. Poiché per O è
sufficiente che solo uno degli argomenti sia vero, la formula restituisce VERO. Per
vedere come Excel valuta la formula si può usare la procedura guidata Valuta
formula nella scheda Formula.
=SE(NON(A5>B2);VERO;FALSO) SE A5 NON è maggiore di B2 restituisci VERO, altrimenti FALSO. In questo caso A5 è
maggiore di B2, quindi la formula restituisce FALSO.

SINISTRA restituisce il primo carattere o i primi caratteri di una stringa di testo in base al numero di
caratteri specificato.

SINISTRAB restituisce il primo carattere o i primi caratteri di una stringa di testo in base al numero di byte
specificato.

SINISTRA(testo; [num_caratt])

SINISTRAB(testo; [num_byte])

Gli argomenti della sintassi delle funzioni SINISTRA e SINISTRAB sono i seguenti:

 Testo Obbligatorio. Stringa di testo che contiene i caratteri che si desidera estrarre.

 Num_caratt Facoltativo. Specifica il numero di caratteri che la funzione SINISTRA deve estrarre.

 Num_caratt deve essere maggiore o uguale a zero.

 Se num_caratt è maggiore della lunghezza del testo, SINISTRA restituisce tutto il testo.

 Se num_caratt è omesso, verrà considerato uguale a 1.

 Num_byte Facoltativo. Specifica il numero di caratteri che SINISTRAB deve estrarre in base ai
byte.

DESTRA(testo; [num_caratt])

DESTRA.B(testo; [num_byte])

Questa formula non fa altro che unire due stringhe in una. Quindi se per esempio la prima stringa è “Ciao, “,
e la seconda è “che fai?”, la stringa risultante sarà “Ciao, che fai?”.

La formula generale è:

=CONCATENA(stringa1; stringa2)
=MAIUSC.INIZ(C4)

E’ la corrispondente della funzione PROPER dell’Excel in versione inglese. La formula in questione opera sui
testi e converte la prima lettera di ogni parola di una frase in maiuscolo e tutte le altre in minuscolo. La
funzione riceverà in ingresso l’indirizzo di una cella o una stringa.

Se invece vogliamo trasformare tutto il testo in maiuscolo usiamo la formula MAIUSC. Questa viene usata
con le stesse modalità della formula MAIUSC.INIZ, ma il risultato sarà diverso.

Quindi ad esempio, il testo “sto imparando excel”, con MAIUSC verrà trasformato in “STO IMPARANDO
EXCEL”.

Molti di voi avranno sentito parlare dei numeri random, cioè dei numeri casuali ottenuti da una funzione.
Nello specifico la funzione CASUALE, restituisce un valore casuale che va da 0 a 1, quindi qualsiasi valore
che va da 0 a 1.

Dove utilizzare questa funzione? Supponiamo che dobbiamo riempire una tabella vuota per fare dei test e
questa tabella è costituita da migliaia di celle. In quel caso, ci potrebbe essere utile riempirla con dei valori
a caso che possiamo ottenere tramite la formula CASUALE, con opportuni accorgimenti. Infatti se ci serve
un valore che va da 0 a 10, basta che selezioniamo una cella e scriviamo nella barra della formula la
seguente formula:

=CASUALE()*10

Ma cosa accade di preciso? La funzione CASUALE() ci restituirà un valore che va da 0 a 1 (Es.: 0,23455309),
successivamente questo valore sarà moltiplicato per 10, quindi avremo come risultato 2,3455309. Quindi i
risultati restituiti andranno da 0 a 10. Se invece vogliamo valori che vadano da 0 a 100 basterà scrivere:

=CASUALE()*100

La funzione CASUALE.TRA, invece, è configurata in modo da ottenere un numero casuale compreso tra due
numeri, ad esempio:

• un numero compreso tra 0 e 20;

• un numero compreso tra -10 a +10, con range che partono dai numeri negativi e arrivano a numeri
positivi;
• un numero compreso tra -34 a 0, quindi quasi completamente negativi;

Se non capite il concetto di numero casuale è consigliabile fare riferimento prima alla funzione di sopra
quindi leggersi il precedente paragrafo.

Vediamo un esempio della funzione:

=CASUALE.TRA(-100; 78)

Questa restituisce un valore a caso che va da -100 a +78.

La formula generica di CASUALE.TRA è

CASUALE.TRA(minimo; massimo)

dove minimo e massimo sono gli estremi dell’intervallo da dove prendere i numeri, quindi si otterrà un
numero che va da “minimo” a “massimo”.

=ARROTONDA(num, num_cifre)

Dove num è il valore che si vuole arrotondare e num_cifre è il numero di cifre decimali scelte per
l’arrotondamendo.

La funzione ARROTONDA prenderà il valore di una cella (o un numero) e lo trasformerà in intero. Quindi se,
per esempio, nella cella A1 abbiamo il valore 3,490504 , applicando la formula arrotonda, avremo:

=ARROTONDA(A1, 0)

Supponiamo che con la funzione CASUALE precedente vogliamo produrre dei valori che sono degli interi,
es.: 0, 1, 2, 3, …

In quel caso andremo ad utilizzare la funzione ARROTONDA sui valori decimali prodotti. Quindi per
produrre dei numeri casuali interi la formula sarà:

=ARROTONDA(CASUALE()*100;0)

Per evitare rotture di scatole, può risultare conveniente convertire le celle contenenti formule, nei loro
risultati. Lo si fa copiando la cella e, fra le opzioni di Incolla, scegliere “valori”. Lo si reincolla sulla stessa
cella e il gioco è fatto.