Sei sulla pagina 1di 3

interface S0/0/0

clock rate 64000 = This command applies only to DCE interfaces (1200 x2)

no ip domain-lookup

router ospf 1
R1(config-router)# network 192.168.1.0 0.0.0.255 area 0
R1(config-router)# network 10.1.1.0 0.0.0.3 area 0

R1(config)# router ospf 1


R1(config-router)# passive-interface g0/1 solo a dispositivos finales

no shutdown

show ip ospf neighbor

show ip route

R1(config)# line console 0


R1(config-line)# password ciscocon
R1(config-line)# exec-timeout 5 0
R1(config-line)# login
R1(config-line)# logging synchronous

R1(config)# line aux 0


R1(config-line)# password ciscoauxpass
R1(config-line)# exec-timeout 5 0
R1(config-line)# login

R1(config)# line vty 0 4


R1(config-line)# password ciscovtypass
R1(config-line)# exec-timeout 5 0
R1(config-line)# transport input telnet
R1(config-line)# login

service password-encryption

R1(config)# banner motd $Unauthorized access strictly prohibited!$


R1(config)# exit

R1(config)# username user01 algorithm-type ? md5 scrypt sha256

R1(config)# username user01 algorithm-type scrypt secret user01pass

R1(config)# line console 0


R1(config-line)# login local
R1(config-line)# end
R1# exit

R1(config)# line vty 0 4


R1(config-line)# login local

R1(config)# line aux 0


R1(config-line)# login local

R1# conf t
R1(config)# ip domain-name ccnasecurity.com
R1(config)# username admin privilege 15 algorithm-type scrypt secret
cisco12345
R1(config)# line vty 0 4
R1(config-line)# privilege level 15
R1(config-line)# login local
R1(config-line)# transport input ssh
R1(config-line)# exit

crypto key zeroize rsa


crypto key generate rsa general-keys modulus 1024 512 a 1024

R1(config)# ip ssh version 2

R1(config)# ip ssh time-out 90


R1(config)# ip ssh authentication-retries 2

R1# copy running-config startup-config

AAA
R1(config)# aaa new-model (Enable AAA on the router)

R1(config)# aaa authentication login default local

R1(config)# aaa authorization exec default local

R1(config)# ip scp server enable (Enable SCP server on R1.)

R3# copy scp: flash:


Address or name of remote host []? 10.1.1.1
Source username [R3]? admin
Source filename []? R1-Config
Destination filename [R1-Config]? [Enter]
Password: cisco12345

NTP server

Configure routers to update hardware clock.


ntp update-calendar
do show clock

Configure routers to timestamp log messages.


service timestamps log datetime msec

ntp server 192.168.1.5


do show ntp status

Configure the routers to identify the remote host (Syslog Server) that will
receive logging messages.
logging host 192.168.1.6

telenet a SSH
Configure a domain name.
ip domain-name ccnasecurity.com

Configure users for login from the SSH client on R3.


username SSHadmin privilege 15 secret ciscosshpa55

Configure the incoming VTY lines on R3.


line vty 0 4
login local
transport input ssh

Erase existing key pairs on R3.


crypto key zeroize rsa
Step 5. Generate the RSA encryption key pair for R3.
crypto key generate rsa
1024

Configure SSH timeouts and authentication parameters.


ip ssh time-out 90
ip ssh authentication-retries 2
ip ssh version 2
do show ip ssh

Potrebbero piacerti anche