Sei sulla pagina 1di 9

PASO 1 CONFIGURACION DE DIRECCIONAMIENTO.

LAN 1-CENTRAL 172.16.1.1/24


2-LOCAL 172.16.2.1/24
3-R2 172.16.3.1/24
4-SUC1 172.16.4.1/24
FRAME-RELAY CENTRAL 10.1.1.1/24
LOCAL 10.1.1.2/24
R1 10.1.1.3/24
OSPF 20.2.2.1/30
R1
20.2.2.10/30
20.2.2.2/30
R2
20.2.2.5/30
20.2.2.6/30
R3
20.2.2.9/30
INTERNET R3 200.1.1.1/30
200.1.1.2/30
INTERNET
200.3.3.2/30
SUC 200.3.3.1/30
TUNEL IPSEC 30.3.3.0/30

--switch lan CENTRAL--

interface range f0/0 , f0/1 , f0/2 , f0/3 , f0/4


switchport mode access
switchport access vlan 1
interface range f0/5 , f0/6 , f0/7 , f0/8 , f0/9
switchport mode access
switchport access vlan 1
interface range f0/10 , f0/11 , f0/12 , f0/13
switchport mode access
switchport access vlan 1
interface range f0/14 , f0/15
switchport mode access
switchport access vlan 1
exit
do wr

FRAME RELAY

--router frame relay--


frame-relay switching
interface s0/0
no ip addres
no shutdown
encapsulation frame-relay
clock rate 64000
frame-relay intf-type dce
ip ospf network broadcast
frame-relay route 101 interface serial0/2 201
frame-relay route 102 interface serial0/1 302
interface s0/1
no ip addres
no shutdown
encapsulation frame-relay
clock rate 64000
frame-relay intf-type dce
ip ospf network broadcast
frame-relay route 301 interface serial0/2 202
frame-relay route 302 interface serial0/0 102
interface s0/2
no ip addres
no shutdown
encapsulation frame-relay
clock rate 64000
frame-relay intf-type dce
ip ospf network broadcast
frame-relay route 201 interface serial0/0 101
frame-relay route 202 interface serial0/1 301
do wr

--R1--
interface serial0/1
encapsulation frame-relay
frame-relay lmi-type cisco
ip ospf network broadcast
ip add 10.1.1.1 255.255.255.0
no shutdown
exit
do wr

--R4--
interface serial0/3
encapsulation frame-relay
frame-relay lmi-type cisco
ip ospf network broadcast
ip add 10.1.1.2 255.255.255.0
no shutdown
exit
do wr

--R3--
interface serial0/2
encapsulation frame-relay
frame-relay lmi-type cisco
ip ospf network broadcast
ip add 10.1.1.3 255.255.255.0
no shutdown
exit
do wr

LINEAS DEDICADAS CON OSPF


HDLC

--R3--
username R6 password ciscoclass
username R5 password ciscoclass
interface s0/1
encapsulation ppp
ppp authentication chap
ip add 20.2.2.1 255.255.255.252
no shutdown
interface s0/3
encapsulation ppp
ppp authentication pap
ppp pap sent-username R3 password ciscoclass
ip add 20.2.2.10 255.255.255.252
no shutdown
exit
router ospf 1
router-id 1.1.1.1
network 10.1.1.0 0.0.0.255 area 0
network 20.2.2.0 0.0.0.3 area 0
network 20.2.2.8 0.0.0.3 area 0
default-information originate
exit
do wr

--R6--
username R3 password ciscoclass
interface f0/1
ip add 172.16.3.1 255.255.255.0
no shutdown
interface s0/3
encapsulation ppp
ppp authentication pap
ppp pap sent-username R6 password ciscoclass
ip add 20.2.2.9 255.255.255.252
no shutdown
interface s0/2
encapsulation hdlc
ip add 20.2.2.6 255.255.255.252
no shutdown
exit
router ospf 1
router-id 6.6.6.6
passive-interface FastEthernet0/1
network 172.16.3.0 0.0.0.255 area 0
network 20.2.2.8 0.0.0.3 area 0
network 20.2.2.4 0.0.0.3 area 0
default-information originate
exit
do wr

--R5--
username R5 password ciscoclass
username R3 password ciscoclass
interface s0/3
ip add 200.1.1.1 255.255.255.252
no shutdown
interface s0/1
encapsulation ppp
ppp authentication chap
ip add 20.2.2.2 255.255.255.252
no shutdown
interface s0/2
encapsulation hdlc
ip add 20.2.2.5 255.255.255.252
no shutdown
exit
router ospf 1
router-id 5.5.5.5
network 20.2.2.0 0.0.0.3 area 0
network 30.3.3.0 0.0.0.3 area 0
network 20.2.2.4 0.0.0.3 area 0
default-information originate
exit
do wr
VPN + IPSEC

--R5--
ip route 0.0.0.0 0.0.0.0 s0/3
interface tunnel0
ip add 30.3.3.1 255.255.255.252
tunnel source s0/3
tunnel destination 200.3.3.1
exit
crypto isakmp policy 10
encr aes 256
authentication pre-share
group 2
crypto isakmp key cisco address 200.3.3.1
crypto ipsec transform-set VPNSET esp-aes esp-sha-hmac
crypto ipsec profile VPNSET
set transform-set VPNSET
crypto map VPNMAP 10 ipsec-isakmp
set peer 200.3.3.1
set transform-set VPNSET
match address 101
interface Tunnel0
tunnel mode ipsec ipv4
tunnel protection ipsec profile VPNSET
exit
interface Serial0/3
crypto map VPNMAP
exit
access-list 101 permit ip 172.16.1.0 0.0.0.255 172.16.4.0
0.0.0.255
access-list 101 permit ip 172.16.2.0 0.0.0.255 172.16.4.0
0.0.0.255
access-list 101 permit ip 172.16.3.0 0.0.0.255 172.16.4.0
0.0.0.255
do wr

--R8--
ip route 0.0.0.0 0.0.0.0 s0/2
interface s0/2
ip add 200.3.3.1 255.255.255.252
no shutdown
interface f0/0
ip add 172.16.4.1 255.255.255.0
no shutdown
interface tunnel0
ip add 30.3.3.2 255.255.255.252
tunnel source s0/2
tunnel destination 200.1.1.1
exit
router ospf 1
network 30.3.3.0 0.0.0.3 area 0
network 172.16.4.0 0.0.0.255 area 0
default-information originate
passive-interface FastEthernet0/0
exit
crypto isakmp policy 10
encr aes 256
authentication pre-share
group 2
crypto isakmp key cisco address 200.1.1.1
crypto ipsec transform-set VPNSET esp-aes esp-sha-hmac
crypto ipsec profile VPNSET
set transform-set VPNSET
crypto map VPNMAP 10 ipsec-isakmp
set peer 200.1.1.1
set transform-set VPNSET
match address 101
interface Tunnel0
tunnel mode ipsec ipv4
tunnel protection ipsec profile VPNSET
exit
interface Serial0/2
crypto map VPNMAP
exit
access-list 101 permit ip 172.16.4.0 0.0.0.255 172.16.1.0
0.0.0.255
access-list 101 permit ip 172.16.4.0 0.0.0.255 172.16.2.0
0.0.0.255
access-list 101 permit ip 172.16.4.0 0.0.0.255 172.16.3.0
0.0.0.255
do wr

--INTERNET--
interface s0/3
ip add 200.1.1.2 255.255.255.252
no shutdown
interface f0/1
ip add 200.2.2.1 255.255.255.252
no shutdown
interface s0/2
ip add 200.3.3.2 255.255.255.252
no shutdown
exit
do wr

DHCP LOCAL

ip dhcp excluded-address 172.16.2.1 172.16.2.10


ip dhcp excluded-address 172.16.2.65 172.16.2.80
ip dhcp excluded-address 172.16.2.129 172.16.2.149
ip dhcp pool VLAN10
network 172.16.2.0 255.255.255.192
default-router 172.16.2.1
exit
ip dhcp pool VLAN20
network 172.16.2.64 255.255.255.192
default-router 172.16.2.65
exit
ip dhcp pool VLAN30
network 172.16.2.128 255.255.255.192
default-router 172.16.2.129
exit
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 172.16.2.1 255.255.255.192
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 172.16.2.65 255.255.255.192
interface FastEthernet0/0.30
encapsulation dot1Q 30
ip address 172.16.2.129 255.255.255.192
interface FastEthernet0/0
no ip add
no shutdown
exit
router ospf 1
network 172.16.2.0 0.0.0.63 area 0
network 172.16.2.64 0.0.0.63 area 0
network 172.16.2.128 0.0.0.63 area 0
network 10.1.1.0 0.0.0.255 area 0
default-information originate
exit
do wr

CENTRAL OSPF
router ospf 1
network 172.16.1.0 0.0.0.255 area 0
network 10.1.1.0 0.0.0.255 area 0
default-information originate
exit
do wr

PVST
R11
interface f0/0
switchport mode trunk
switchport trunk native vlan 1
exit
interface range f0/1 , f0/2
switchport mode access
channel-group 1 mode on
no shutdown
interface range f0/3 , f0/4
switchport mode access
channel-group 2 mode on
no shutdown
exit
interface Port-channel1
switchport mode trunk
switchport trunk native vlan 1
exit
interface Port-channel2
switchport mode trunk
switchport trunk native vlan 1
exit
do wr

R12
interface range f0/1 , f0/2
switchport mode access
channel-group 1 mode on
no shutdown
interface range f0/5 , f0/6
switchport mode access
channel-group 3 mode on
no shutdown
exit
interface Port-channel1
switchport mode trunk
switchport trunk native vlan 1
exit
interface Port-channel3
switchport mode trunk
switchport trunk native vlan 1
exit
interface f0/10
switchport mode access
switchport access vlan 10
exit
do wr

R13
interface range f0/3 , f0/4
switchport mode access
channel-group 2 mode on
no shutdown
interface range f0/5 , f0/6
switchport mode access
channel-group 3 mode on
no shutdown
exit
interface Port-channel2
switchport mode trunk
switchport trunk native vlan 1
exit
interface Port-channel3
switchport mode trunk
switchport trunk native vlan 1
exit
interface f0/10
switchport mode access
switchport access vlan 20
exit
do wr

IPV6
LAN1
ipv6 unicast-routing
interface fastEthernet 0/0
ipv6 enable
ipv6 address 2001:db8:acad:a::1/64
ipv6 address fe80::1 link-local
exit
do wr

LAN2
ipv6 unicast-routing
interface fastEthernet 0/0.10
ipv6 enable
ipv6 address 2001:db8:cafe:1::1/64
ipv6 address fe80::2 link-local
exit
interface fastEthernet 0/0.20
ipv6 enable
ipv6 address 2001:db8:cafe:2::1/64
ipv6 address fe80::2 link-local
exit
interface fastEthernet 0/0.30
ipv6 enable
ipv6 address 2001:db8:cafe:3::1/64
ipv6 address fe80::2 link-local
exit
do wr

LAN4
ipv6 unicast-routing
interface fastEthernet 0/0
ipv6 enable
ipv6 address 2001:db8:acad:c::1/64
ipv6 address fe80::3 link-local
exit
do wr

final lan 4
R11
interface f0/0
switchport mode access
switchport access vlan 1
exit
interface range f0/1 , f0/2
switchport mode access
channel-group 1 mode on
no shutdown
interface range f0/3 , f0/4
switchport mode access
channel-group 2 mode on
no shutdown
exit
interface Port-channel1
switchport mode access
switchport access vlan 1
exit
interface Port-channel2
switchport mode trunk
switchport access vlan 1
exit
do wr

R12
interface range f0/1 , f0/2
switchport mode access
channel-group 1 mode on
no shutdown
interface range f0/5 , f0/6
switchport mode access
channel-group 3 mode on
no shutdown
exit
interface Port-channel1
switchport mode access
switchport access vlan 1
exit
interface Port-channel3
switchport mode access
switchport access vlan 1
exit
interface f0/10
switchport mode access
switchport access vlan 1
exit
do wr
R13
interface range f0/3 , f0/4
switchport mode access
channel-group 2 mode on
no shutdown
interface range f0/5 , f0/6
switchport mode access
channel-group 3 mode on
no shutdown
exit
interface Port-channel2
switchport mode access
switchport access vlan 1
exit
interface Port-channel3
switchport mode access
switchport access vlan 1
exit
interface f0/10
switchport mode access
switchport access vlan 1
exit
do wr

Potrebbero piacerti anche