Sei sulla pagina 1di 6

TIA ESTRUCTURAS DE DECISIÓN

Tutor(a)
Digite acá el nombre

Laura Cuartas Ríos

20/05/2018
Medellin
Orientaciones:

Este archivo es una plantilla en la que usted deberá desarrollar lo siguiente para el
problema suministrado:

● Etapa de Análisis: debe indicar claramente los datos de entrada, datos de salida
y el proceso describiendo los subalgoritmos que usará.

● Algoritmo principal y subalgoritmos (aplique procedimientos y funciones)

● Prueba de escritorio: Deberá grabar un video donde se vean claramente al


algoritmo y subalgoritmos y la tabla de variables. Tenga en cuenta: escriba con un
color distinto las variables locales de los subalgoritmos en la tabla de variables.
Muestre muy bien lo que va ocurriendo instrucción por instrucción.
Asigne el siguiente nombre al video: <Prueba Estructura de Decisión>. Luego
súbalo a su unidad de Google Drive. Al archivo deberá crearle el enlace para
compartirlo, tal como se le enseñó previamente en las orientaciones de la página 7
de la AEAE 2, unidad 1. Deberá tener en cuenta este enlace para incluirlo en la
etapa 4) Prueba de Escritorio de esta plantilla.
Problema

1) Problema: En I.U.Pascual Bravo, para realizar el pago de la matrícula, se tiene


en cuenta la cantidad de créditos de una materia y si ésta es teórica, práctica o
teórico-práctica.

El valor del crédito varía de acuerdo a esto:


Si la asignatura es teórica, el valor del crédito es de $300.000
Si la asignatura es práctica, el valor del crédito es de $750.000
Si la asignatura es teórico-práctica, el valor del crédito es de $1’100.000

Independiente de los créditos hay un pago base, que no es igual para todos los
estudiantes. Si el alumno es de estrato 1, 2 o 3 el pago base es de $ 450.000 y si es
de estrato 4, 5 o 6 el pago base es de $ 900.000

Aparte de lo anterior, si el estudiante tiene un promedio del semestre anterior, entre


4.7 y 5.0, tiene una beca del 50% y si tiene promedio entre 4.3 y 4.6, su beca es del
30%. DESCUBRA LA INCONSISTENCIA QUE HAY EN ESTE PUNTO.

Asumiendo que el estudiante matricula una sola materia, calcule el pago de su


matrícula de acuerdo a estos requerimientos.

2) Análisis:

Se desea saber cuál será el valor a pagar por matrícula una asignatura sabiendo cuánto
cuesta cada credito dependiendo del tipo de materia que sea
(teórica,práctica,ambas),además de los parámetros ya mencionados en el enunciado

Datos de Entrada

Cantidad de creditos,estrato,promedio anterior,tipo de asignatura

Proceso
Condiciones para los valores dados
3) Realización del Algoritmo:

// Desarrollado por Laura Cuartas Rios


// Desarrollo del Software Pascual Bravo

SubProceso subtotal <- pagoMatricula(cant,asig,est,prom)


//defino las variables locales para las operaciones
Definir costCredito,subtotal Como Entero;
Definir mostrardesc Como Real;
costCredito<-0;
subtotal<-0;
mostrardesc<-0;
Si (asig ="teorica" o asig = "teorica" o asig = "teorica" o asig = "teorica") Entonces
costCredito<-cant*300000;
SiNo
Si (asig ="Practica" o asig = "Practica" o asig = "Practica" o asig = "Practica")
Entonces
costCredito<-cant*750000;
SiNo
costCredito<-cant*1100000;
Fin Si
Fin Si
Si (est >=1 Y est <=3) Entonces
subtotal<-450000 + costCredito;
SiNo
Si (est >=4 Y est<=6) Entonces
subtotal<-900000 + costCredito;
Fin Si
Fin Si
Si (prom>=4.3 & prom <=4.6)Entonces
//Mostrara cuanto seria el valor a pagar en caso de no tener beca.
Escribir "El valor de la matricula sin la beca es: $",subtotal;
mostrardesc<-(subtotal * 0.3);
subtotal<-subtotal-mostrardesc;
Escribir "Obtuvo una beca equivalente al 30%: $",mostrardesc;
SiNo
Si (prom>=4.7 & prom<=5.0) Entonces
Escribir "El valor de la matricula sin la beca es: $",subtotal;
mostrardesc<-(subtotal*0.5);
subtotal<-subtotal-mostrardesc;
Escribir "Obtuvo una beca equivalente al 50%: $",mostrardesc;
SiNo
Escribir "Mejora tus resultados y obtendras becas por 30% y 50%";
subtotal<-subtotal;
Fin Si
Fin Si

Escribir "El valor de la matricula es: $",subtotal;

FinSubProceso

Proceso Matricula_de_pago
//Variables a utilizar en el proceso
Definir cantCredito,estrato Como Entero;
Definir promanterior,result Como Real;
Definir asignatura Como Caracter;

//Inicializamos variables
cantCredito<-0;
estrato<-0;
result<-0; // VARIABLE QUE CONTENDRA EL RESULTADO SIN DESCUENTO DE
LA MATRICULA
promanterior <- 0;
asignatura <- "";

//PROCESO PARA DESARROLLAR EL PAGO DE LA MATRICULA

Escribir "¿Cual es la cantidad de creditos de la materia?: ";


Leer cantCredito;
Escribir "¿Que tipo de asignatura es?: (teorica, practica o ambas)";
Leer asignatura;
Escribir "¿Cual es su estrato social?: ";
Leer estrato;
Escribir "¿Cual fue su promedio del semestre anterior?: ";
Leer promanterior;

//metodo para saber el valor final a pagar


result<-pagoMatricula(cantCredito,asignatura,estrato,promanterior);

FinProceso

4) Prueba de escritorio:
Copie y pegue acá el enlace o URL del video que usted grabó de la prueba de
escritorio para el primer problema, que subió a su unidad en Google Drive y que
Compartió según las indicaciones.
Cantidad Credito Tipo de asignatura Estracto Promedio anterior Resultado
0 vacio 0 0 0
4 vacio 0 0 0
4 ambas 0 0 0
4 ambas 5 0 0
4 ambas 5 4.4 0
Llamado a la funcion pagoMatricula
Realiza las operaciones de acuerdo a las condiciones dadas y lo retorna a Result
Mostrara en pantalla el resultado hallado en la variable Subtotal 5.300.000
Mostrara en pantalla el resultado hallado en la variable mostrarDesc 1.590.000
la variable Subtotal modificara su valor al nuevo con el descuento 3.710.000