Sei sulla pagina 1di 6

-------------- R1 --------------

enable
conf t
no ip domain-lookup
line con 0
logging synchronous
exec-timeout 0 0
exit
hostname R1

interface s0/0/0
ip address 192.168.9.1 255.255.255.252
ipv6 address 2001:db8:acad:90::1/64
ipv6 address fe80::1 link-local
bandwidth 128
clock rate 64000
no shut
exit

interface g0/0
ip address 192.168.110.1 255.255.255.0
ipv6 address 2001:db8:acad:110::1/64
no shutdown
exit

ipv6 unicast-routing

key chain r1-chain


key 1
key-string secret-1
exit
exit

router eigrp ExamH3


address-family ipv4 unicast autonomous-system 101
eigrp router-id 1.1.1.1
network 192.168.110.0 0.0.0.255
network 192.168.9.0 0.0.0.3
af-interface s0/0/0
authentication key-chain r1-chain
authentication mode hmac-sha-256 secret-1
exit
topology base
no auto-summary
exit
af-interface g0/0
passive-interface
exit
exit

address-family ipv6 unicast autonomous-system 101


eigrp router-id 1.1.1.1
af-interface g0/0
passive-interface
exit
af-interface s0/0/0
authentication key-chain r1-chain
authentication mode hmac-sha-256 secret-1
exit
exit
exit

-------------- R2 --------------
enable
conf t
no ip domain-lookup
line con 0
logging synchronous
exec-timeout 0 0
exit
hostname R2

interface s0/0/0
ip address 192.168.9.2 255.255.255.252
ipv6 address 2001:db8:acad:90::2/64
ipv6 address fe80::2 link-local
bandwidth 128
no shutdown
exit

interface s0/0/1
ip address 192.168.9.5 255.255.255.252
ipv6 address 2001:db8:acad:91::1/64
ipv6 address fe80::2 link-local
bandwidth 128
clock rate 64000
no shutdown
exit

interface g0/0
ip address 192.168.2.1 255.255.255.0
ipv6 address 2001:db8:acad:b::1/64
no shutdown
exit

ipv6 unicast-routing

router ospfv3 1
address-family ipv4 unicast
redistribute eigrp 101 metric 100 metric-type 1
router-id 2.2.2.2
area 1 stub no-summary
exit-address-family
address-family ipv6 unicast
redistribute eigrp 101 metric 100 metric-type 1 include-connected
router-id 2.2.2.2
area 1 stub no-summary
exit
exit

interface g0/0
ospf 1 ipv4 area 1
ospf 1 ipv6 area 1
exit

interface s0/0/1
ospf 1 ipv4 area 0
ospf 1 ipv6 area 0
exit

access-list 1 deny 192.168.3.0 0.0.0.255


access-list 1 permit any

key chain r2-chain


key 1
key-string secret-1
exit
exit

router eigrp ExamH3


address-family ipv4 unicast autonomous-system 101
eigrp router-id 2.2.2.2
network 192.168.9.0 0.0.0.3
af-interface s0/0/0
authentication key-chain r2-chain
authentication mode hmac-sha-256 secret-1
exit
topology base
distribute-list 1 out
no auto-summary
redistribute ospfv3 1 metric 1500 100 255 1 1500
exit
address-family ipv6 unicast autonomous-system 101
eigrp router-id 2.2.2.2
af-interface s0/0/0
authentication key-chain r2-chain
authentication mode hmac-sha-256 secret-1
exit
af-interface s0/0/1
shutdown
exit
af-interface g0/0
shutdown
exit
topology base
redistribute ospf 1 metric 1500 100 255 1 1500 include-connected
exit
exit
exit

-------------- R3 --------------
enable
conf t
no ip domain-lookup
line con 0
logging synchronous
exec-timeout 0 0
exit
hostname R3

interface s0/0/1
ip address 192.168.9.6 255.255.255.252
ipv6 address 2001:db8:acad:91::2/64
ipv6 address fe80::3 link-local
bandwidth 128
no shutdown
exit

interface g0/0
ip address 192.168.3.1 255.255.255.0
ipv6 address 2001:db8:acad:c::1/64
no shutdown
exit

ipv6 unicast-routing

interface s0/1/1
ip address 172.16.1.2 255.255.255.252
ipv6 address 2001:db8:feed:1::2/64
ipv6 address fe80::3 link-local
bandwidth 128
clock rate 64000
no shutdown
exit

interface s0/1/0
ip address 172.16.2.2 255.255.255.252
ipv6 address 2001:db8:feed:2::2/64
ipv6 address fe80::3 link-local
bandwidth 128
clock rate 64000
no shutdown
exit

router ospfv3 1
address-family ipv4 unicast
router-id 3.3.3.3
default-information originate always
exit-address-family
address-family ipv6 unicast
router-id 3.3.3.3
default-information originate always
exit-address-family

interface g0/0
ospf 1 ipv4 area 0
ospf 1 ipv6 area 0
exit

interface s0/0/1
ospf 1 ipv4 area 0
ospf 1 ipv6 area 0
exit

router bgp 65101


bgp router-id 3.3.3.3
neighbor 172.16.2.1 remote-as 65401
neighbor 172.16.1.1 remote-as 65401
neighbor 172.16.1.1 weight 200
neighbor 172.16.2.1 weight 100
neighbor 2001:DB8:FEED:1::1 remote-as 65401
neighbor 2001:DB8:FEED:2::1 remote-as 65401
address-family ipv4 unicast
neighbor 172.16.2.1 activate
neighbor 172.16.1.1 activate
network 192.168.3.0 mask 255.255.255.0
exit
address-family ipv6 unicast
neighbor 2001:DB8:FEED:1::1 activate
neighbor 2001:DB8:FEED:2::1 activate
neighbor 2001:DB8:FEED:1::1 weight 200
neighbor 2001:DB8:FEED:2::1 weight 100
neighbor 172.16.2.1 activate
neighbor 172.16.1.1 activate
network 2001:db8:acad:C::/64
exit
exit

-------------- R4 --------------
enable
conf t
no ip domain-lookup
line con 0
logging synchronous
exec-timeout 0 0
exit
hostname R4

interface s0/0/1
ip address 172.16.1.1 255.255.255.252
ipv6 address 2001:db8:feed:1::1/64
ipv6 address fe80::4 link-local
bandwidth 128
no shutdown
exit

interface s0/0/0
ip address 172.16.2.1 255.255.255.252
ipv6 address 2001:db8:feed:2::1/64
ipv6 address fe80::4 link-local
bandwidth 128
no shutdown
exit

interface g0/0
ip address 172.16.4.1 255.255.255.0
ipv6 address 2001:db8:cafe:4::1/64
no shut
exit

ipv6 unicast-routing

router bgp 65401


bgp router-id 4.4.4.4
neighbor 172.16.2.2 remote-as 65101
neighbor 172.16.1.2 remote-as 65101
neighbor 172.16.1.2 weight 200
neighbor 172.16.2.2 weight 100
neighbor 2001:DB8:FEED:1::2 remote-as 65101
neighbor 2001:DB8:FEED:2::2 remote-as 65101
address-family ipv4 unicast
neighbor 172.16.2.2 activate
neighbor 172.16.1.2 activate
network 172.16.4.0 mask 255.255.255.0
exit
address-family ipv6 unicast
neighbor 2001:DB8:FEED:1::2 activate
neighbor 2001:DB8:FEED:2::2 activate
neighbor 2001:DB8:FEED:1::2 weight 200
neighbor 2001:DB8:FEED:2::2 weight 100
neighbor 172.16.2.2 activate
neighbor 172.16.1.2 activate
network 2001:db8:cafe:4::/64
exit
exit

Potrebbero piacerti anche