Sei sulla pagina 1di 2

Terzaghi.

it - Excel e VBA 11/1/09 2:18 PM

La funzione CERCA.VERT (in inglese VLOOKUP)

La funzione CERCA.VERT è molto utile per incrociare tra di loro piccoli database. Se si hanno database con
qualche migliaio di linee da incrociare non usate CERCA.VERT potreste impiegarci molto tempo o forse non
riuscirci proprio!

Tale funzione è però un poco ostica. Prima di tutto, se il database su cui si ricerca non è ordinato in senso
alfabetico crescente la funzione, se non impostata correttamente può dare dei risultati errati. E' quindi
Genera XLS da praticamente sempre necessario inserire il flag che indica la necessità di ricercare la corripondenza esatta.
AS/400 Per farla breve, la tipica sintassi da utilizzare è:
Trasforma
automaticamente =CERCA.VERT(E13; A2:B100;2;FALSO)
i tuoi report
iSeries in CSV, =VLOOKUP(E13; A2:B100;2;FALSE)
XLS, DB2
www.spoolmaster.it
dove:

Exxon Mobil - E3 indica cosa cercare


DTE 10 Excel
Scopri la Nuova - A2:B100 indica dove cercare
Generazione di -2 indica quale colonna del range A2:B100 considerare (qui la colonna B)
Oli Mobil dalle - FALSO indica che è necessario ricercare la corrispondenza esatta tra ciò che è contenuto in E3 e
Maggiori ciò che si trova nella prima colonna del range A2:B100.
Prestazioni! (NOTA: FALSO può essere sostituito con 0)
www.Mobilindustrial.com

Il problema nasce subito quando si cerca di elaborare poi i risultati del CERCA.VERT.
Treccani
Trevolumi Se infatti la ricerca è infruttuosa il nostro CERCA.VERT restituisce, invece che un numero o il dato corretto,
Chiedi maggiori un bellissimo #N/D (in ingelse #N/A). Si tratta di un messaggio di errore di Excel. In sostanza ci comunica
informazioni che la ricerca è stata senza risultato. Il punto è che è ora impossibile applicare formule che coinvolgono la
ricevi in regalo cella che contiene il nostro #N/A. Infatti questo bellissimo messaggio di errore si propaga sulle altre celle:
Treccani Memory
USB!
www.3volumi.it

To use this Web page interactively, you must have Microsoft® Internet Explorer 4.01 or later and the Microsoft Office Web Components. See the
Gestione Microsoft Office Web site for more information.
Entrate e Uscite
Software (Nel caso in cui non sia visibile un file Excel vedere questo esempio)
Tesoreria
Banche e Cassa La soluzione più banale è quella di cancellare la formula quando essa dà errore. Questo comporta però che il
Scadenze modello Excel realizzato dipende nelle sue formule da come sono fatti i dati (qui la presenza della formula
Incassi della cella dipende dalla presenza o no della variabile ricercata nei dati). Questo approccio è dannosissimo e
Pagamenti Fido fonte di errori. E' meglio modificare la formula in questo modo:
SBF
=SE(VAL.NON.DISP(CERCA.VERT(E3;A2:B100;2;FALSO));0;CERCA.VERT(E3;A2:B100;2;F
ALSO))

=IF(ISNA(VLOOKUP(E3;A2:B100;2;FALSE));0;VLOOKUP(E3;A2:B100;2;FALSE))

To use this Web page interactively, you must have Microsoft® Internet Explorer 4.01 or later and the Microsoft Office Web Components. See the
Microsoft Office Web site for more information.

(Nel caso in cui non sia visibile un file Excel vedere questo esempio)

Per verificare la formula corretta e vederla "in funzione" su un file excel, scaricate il file qui.

Questa formula, per prima cosa verifica se il CERCA.VERT genera l'errore, in questo caso, invece di scrivere
nella cella il fastidioso #N/A scrive 0 (o qualsiasi altra cosa volete fargli scrivere!), altrimenti restituisce il
valore corretto del CERCA.VERT.

Questa soluzione permette:

http://www.terzaghi.it/excel/index.htm Page 1 of 2
Terzaghi.it - Excel e VBA 11/1/09 2:18 PM

1. di evitare di riempire il foglio di lavoro con fastidiosi messaggi di errore di Excel,


2. di svincolare il complesso delle formule che costituiscono il modello Excel dalla contingenza dei dati
3. di consentire una forte riduzione del tempo necessario per la manutenzione del modello stesso ogni
volta che vengono aggiornati i dati
4. di ridurre la probabilità di errore

Treccani Trevolumi Gestione Entrate e Uscite Excel Plus Ultrasuoni


Chiedi maggiori informazioni ricevi Software Tesoreria Banche e Strumento per Cellulite, Acne
in regalo Treccani Memory USB! Cassa Scadenze Incassi Pagamenti Rughe Prezzi da ingrosso:
www.3volumi.it Fido SBF €10,00/mese!
mkt.it www.shooop.it

Iscriviti alla newsletter!

Ti verrà spedita una mail soltanto per informarti di nuovi Formato


contributi alla sezione Excel del sito www.terzaghi.it. iscriviti cancellati

Privacy: Le tue informazioni personali non verranno


distribuite a nessuno e non ne verrà fatto alcun uso
commerciale o non attinente alla semplice informativa delle
pagine web indicate. Verrà trattato in forma anonima al solo
scopo di conteggio delle persone interessate al servizio.
L'interessato può esercitare i diritti previsti dall'art. 13 della
legge 675/96. Dopo la cancellazione un indirizzo non è più
recuperabile.

Mi appoggio a un servizio gratuito di gestione delle


Newsletter: www.domeus.it

Commenti a questa pagina: Inviate una mail

http://www.terzaghi.it/excel/index.htm Page 2 of 2