Sei sulla pagina 1di 9

Teste 5

Roteadores utilizando OSPF em diferentes áreas

Descrição do testeTeste 5 Roteadores utilizando OSPF em diferentes áreas Arquitetura utilizada na rede Configuração dos equipamentos

Arquitetura utilizada na redeutilizando OSPF em diferentes áreas Descrição do teste Configuração dos equipamentos Conclusões Descrição do

Configuração dos equipamentosáreas Descrição do teste Arquitetura utilizada na rede Conclusões Descrição do teste Como já foi dito

Conclusõesutilizada na rede Configuração dos equipamentos Descrição do teste Como já foi dito na descrição do

Descrição do testena rede Configuração dos equipamentos Conclusões Como já foi dito na descrição do teste do OSPF,

Como já foi dito na descrição do teste do OSPF, a existência de múltiplas áreas se deve a necessidade de colocarmos limites na troca de informações entre os roteadores, isto é, controlar o flooding na rede.

Um roteador que tem todas as suas interfaces numa mesma área é chamado de Internal Router (IR), Um roteador que tem suas interfaces em múltiplas áreas é chamado de Area Border Router (ABR), e tem o dever de repassar toda a informação de tabela das outras áreas.

Normalmente, toda informação é concentrada no backbone, também chamado de área 0 e daí repassada para outras áreas, que têm que ser fisicamente conectadas a ele. Podemos então perceber que os roteadores pertencentes à esta área são ABR.

No nosso caso, os ABR são os roteadores cisco1 e cisco2. E tanto o cisco 4000 quanto o cisco3 são do tipo

IR.

. E tanto o cisco 4000 quanto o cisco3 são do tipo IR. Arquitetura utilizada na

Arquitetura utilizada na rede. E tanto o cisco 4000 quanto o cisco3 são do tipo IR. Configuração dos equipamentos

o cisco3 são do tipo IR. Arquitetura utilizada na rede Configuração dos equipamentos Comandos para os

Configuração de uma interface serial:

<4000>#

<4000>#conf t Enter configuration commands, one per line. End with CNTL/Z. <4000>(config)#int s1 <4000>(config-if)#ip address 192.80.209.14 255.255.255.0 <4000>(config-if)#clock rate 800000

<4000>(config-if)#

Configuração de uma interface ethernet:

<4000>#

<4000>#conf t Enter configuration commands, one per line. End with CNTL/Z. <4000>(config)#int e0 <4000>(config-if)#ip address 192.80.100.1 255.255.255.0

<4000>(config-if)#

Configuração de uma interface loopback:

<4000>#conf t Enter configuration commands, one per line. End with CNTL/Z. <4000>(config)#int lo0 <4000>(config-if)#ip address 200.20.6.1 255.255.255.0

<4000>(config-if)#

Habilitação do protocolo OSPF:

<4000>#conf t Enter configuration commands, one per line. End with CNTL/Z. <4000>(config)#router ospf 1

<4000>(config-router)#

Anúncio das redes pelo OSPF:

cisco1#

cisco1#conf t Enter configuration commands, one per line. End with CNTL/Z. cisco1(config)#router ospf 1 cisco1(config-router)#network 192.80.209.13 0.0.0.255 area1 cisco1(config-router)#network 200.156.10.1 0.0.0.255 area 1 cisco1(config-router)#network 200.20.94.81 0.0.0.255 area 0

cisco1(config-router)#

cisco2#

cisco2#conf t Enter configuration commands, one per line. End with CNTL/Z. cisco2(config)#router ospf 1 cisco2(config-router)#network 200.20.94.1 0.0.0.255 area 0 cisco2(config-router)#network 200.20.3.1 0.0.0.255 area 2 cisco2(config-router)#network 200.20.4.1 0.0.0.255 area 2

cisco2(config-router)#

cisco3#

cisco3#conf t Enter configuration commands, one per line. End with CNTL/Z. cisco3(config)#router ospf 1 cisco3(config-router)#network 200.20.4.2 0.0.0.255 area 2 cisco3(config-router)#network 139.82.10.1 0.0.0.255 area 2

cisco3(config-router)#

cisco3#

<4000>#conf t Enter configuration commands, one per line. End with CNTL/Z. <4000>(config)#router ospf 1 <4000>(config-router)#network 192.80.209.14 0.0.0.255 area 1

<4000>(config-router)#network 192.80.100.1 0.0.0.255 area 1 <4000>(config-router)#network 200.20.6.1 0.0.0.255 area 1

<4000>(config-router)#

Salvando as configurações:

<4000>#

<4000>#copy running-config startup-config Building configuration [OK]

<4000>#

Obs: para o cisco3 usar o comando 'write'

cisco3#

cisco3#write

#####[OK]

cisco3#

SHOW RUNNING -CONFIG

Este comando é utilizado para verificar a configuração do roteador. Observar se a interface está UP/DOWN, quais os IPs de cada interface e que redes são anunciadas por OSPF com suas respectivas áreas.

Resultados 4000

<4000>#

<4000>#show running-config Building configuration

Current configuration:

!

version 11.3

service timestamps debug uptime service timestamps log uptime no service password-encryption

!

hostname <4000>

!

!

!

!

!

interface Loopback0 ip address 200.20.6.1 255.255.255.0

!

interface Ethernet0 ip address 192.80.100.1 255.255.255.0

!

interface Ethernet1

no ip address shutdown

!

interface Serial0 no ip address no ip mroute-cache shutdown no fair-queue

!

interface Serial1 ip address 192.80.209.14 255.255.255.0 clockrate 800000

!

interface Serial2 ip address 192.80.150.1 255.255.255.0 shutdown clockrate 800000

!

interface Serial3

no ip address shutdown

!

router ospf 1 network 192.80.100.0 0.0.0.255 area 1 network 192.80.209.0 0.0.0.255 area 1 network 200.20.6.0 0.0.0.255 area 1

!

ip classless

!

!

!

line con 0 line aux 0 line vty 0 4 login

!

end

<4000>#

Resultados cisco1

cisco1#

cisco1#show running-config Building configuration

Current configuration:

!

version 11.2

service timestamps debug uptime service timestamps log uptime service password-encryption no service udp-small-servers no service tcp-small-servers

!

hostname cisco1

!

enable password 7 06100E324F41

!

ip subnet-zero

no ip source-route no ip domain-lookup

!

interface Loopback0 ip address 200.156.10.1 255.255.255.0

!

interface Ethernet0 ip address 200.20.94.81 255.255.255.0

!

interface Serial0 ip address 192.80.209.13 255.255.255.0

!

interface Serial1

no ip address shutdown

!

router ospf 1 network 192.80.209.0 0.0.0.255 area 1 network 200.156.10.0 0.0.0.255 area 1 network 200.20.94.0 0.0.0.255 area 0

!

ip classless

!

!

line con 0 exec-timeout 0 0 password 7 060C0E2F494208 login line aux 0 line vty 0 4 password 7 000E120801570A login

!

end

cisco1#

Resultados cisco2

cisco2#

cisco2#show running-config Building configuration

Current configuration:

!

version 11.2 service password-encryption

no service udp-small-servers no service tcp-small-servers

!

hostname cisco2

!

enable secret 5 $1$jibr$cTHEQancHt3LUqhsNxGXG0

!

no ip domain-lookup

!

interface Loopback0 ip address 200.20.3.1 255.255.255.0

!

interface Ethernet0 ip address 200.20.94.1 255.255.255.0 no ip directed-broadcast

!

interface Serial0 ip address 192.80.209.125 255.255.255.252 no ip directed-broadcast ip ospf network point-to-multipoint shutdown clockrate 800000

!

interface Serial1 ip address 200.20.4.1 255.255.255.0 no ip directed-broadcast

!

router ospf 1 network 200.20.3.0 0.0.0.255 area 2 network 200.20.4.0 0.0.0.255 area 2 network 200.20.94.0 0.0.0.255 area 0

!

ip classless

!

!

line con 0 password 7 0501070124404F line aux 0 password 7 0501070124404F line vty 0 1 password 7 0501070124404F login line vty 2 password 7 082B4D400C1504 login line vty 3 4 password 7 044904131B245E login

!

end

cisco2#

Resultados cisco3

cisco3#

cisco3#show configuration

Using 444 out of 32762 bytes

!

version 10.2 ! hostname cisco3 ! ! ! interface Loopback0 ip address 139.82.10.1 255.255.255.0 !

version

10.2

!

hostname cisco3

!

!

!

interface Loopback0

ip address 139.82.10.1 255.255.255.0

!

interface Ethernet0 ip address 192.80.100.1 255.255.255.0

shutdown

!

interface Serial0

ip address 200.20.5.1 255.255.255.0

shutdown

!

interface Serial1 ip address 200.20.4.2 255.255.255.0 clockrate 800000

!

router ospf 1

network

200.20.4.0 0.0.0.255 area 2

network

139.82.10.0 0.0.0.255 area 2

!

!

line

con 0

line

aux 0

line

vty 0 4

login

!

end

cisco3#

0 line vty 0 4 login ! end cisco3# Conclusões Neste ítem serão mostrados dois comandos

Conclusões

Neste ítem serão mostrados dois comandos que são fundamentais para que possamos tirar nossas conclusões. São eles: show ip route e traceroute.

O primeiro nos mostra por qual interface e por qual protocolo o roteador aprende as outras redes, já o segundo nos mostra os roteadores percorridos até o endereço de destino.

4000

<4000>#

<4000>#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i

- IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

U

- per-user static route, o - ODR

Gateway of last resort is 192.80.209.13 to network 0.0.0.0

C

192.80.209.0/24 is directly connected, Serial1

O

IA 200.20.4.0/24 [110/138] via 192.80.209.13, 00:02:25, Serial1

C

200.20.6.0/24 is directly connected, Loopback0 139.82.0.0/32 is subnetted, 1 subnets

O

IA

139.82.10.1 [110/138] via 192.80.209.13, 00:02:25, Serial1 200.20.3.0/32 is subnetted, 1 subnets

O

IA

200.20.3.1 [110/75] via 192.80.209.13, 00:02:25, Serial1

C

192.80.100.0/24 is directly connected, Ethernet0 200.156.10.0/32 is subnetted, 1 subnets

O

200.156.10.1 [110/65] via 192.80.209.13, 00:02:25, Serial1

O

IA 200.20.94.0/24 [110/74] via 192.80.209.13, 00:02:25, Serial1

Verificamos que o roteador 4000 aprende as outras redes por OSPF através da interface Serial1, via 192.80.209.13 (interface Serial0 do cisco1).

É importante notar que as redes que possuem ao lado IA: 200.20.4.0 , 139.82.10.1 ,

200.20.3.1 e 200.20.94.0 fazem parte de áreas diferentes, por isso o nome de inter-área.

<4000>#

<4000>#traceroute 139.82.10.1

Type escape sequence to abort.

Tracing the route to 139.82.10.1

1 192.80.209.13 4 msec 0 msec 0 msec

2 200.20.94.1 8 msec 4 msec 4 msec

3 200.20.4.2 8 msec 4 msec *

<4000>#

Com o comando traceroute, confirmamos o caminho que o pacote percorre até a interface 139.82.10.1 (Loopback0 do cisco3).

cisco1

cisco1#

cisco1#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i

- IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

U

- per-user static route, o - ODR

Gateway of last resort is not set

C

192.80.209.0/24 is directly connected, Serial0

C

200.156.10.0/24 is directly connected, Loopback0

C

200.20.94.0/24 is directly connected, Ethernet0

O

IA 200.20.4.0/24 [110/74] via 200.20.94.1, 00:00:36, Ethernet0 139.82.0.0/32 is subnetted, 1 subnets

O IA

139.82.10.1 [110/74] via 200.20.94.1, 00:00:36, Ethernet0 200.20.6.0/32 is subnetted, 1 subnets

O 200.20.6.1 [110/65] via 192.80.209.14, 00:00:36, Serial0 200.20.3.0/32 is subnetted, 1 subnets

O IA

200.20.3.1 [110/11] via 200.20.94.1, 00:00:36, Ethernet0

O 192.80.100.0/24 [110/74] via 192.80.209.14, 00:00:36, Serial0

Verificamos que o roteador cisco1 aprende as outras redes por OSPF através de suas interfaces Serial0, via 192.80.209.14 (Serial1 4000) e Ethernet0 via 200.20.94.1 (Ethernet0 cisco2).

É importante notar que as redes que possuem ao lado IA: 200.20.4.0 , 139.82.10.1 , 200.20.3.1

fazem parte de áreas diferentes, por isso o nome de inter-área.

cisco1#

cisco1#traceroute 139.82.10.1

Type escape sequence to abort.

Tracing the route to 139.82.10.1

1 200.20.94.1 4 msec 4 msec 4 msec

2 200.20.4.2 8 msec *

4 msec

cisco1#traceroute 192.80.100.5

Type escape sequence to abort.

Tracing the route to 192.80.100.5

1 192.80.209.14 0 msec 4 msec 4 msec

2 192.80.100.5 4 msec 4 msec 4 msec

cisco1#

Com o comando traceroute confirmamos o caminho que o pacote percorre

até a 139.82.10.1 (Loopback0 do cisco3) e até o PC 192.80.100.5.

cisco2

cisco2#

cisco2#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i

- IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

U

- per-user static route, o - ODR

Gateway of last resort is not set

O IA 192.80.209.0/24 [110/74] via 200.20.94.81, 00:00:03, Ethernet0 200.156.10.0/32 is subnetted, 1 subnets

O IA

200.156.10.1 [110/11] via 200.20.94.81, 00:00:03, Ethernet0

C

200.20.94.0/24 is directly connected, Ethernet0

C

200.20.4.0/24 is directly connected, Serial1 139.82.0.0/32 is subnetted, 1 subnets

O

139.82.10.1 [110/64] via 200.20.4.2, 00:00:03, Serial1 200.20.6.0/32 is subnetted, 1 subnets

O IA

200.20.6.1 [110/75] via 200.20.94.81, 00:00:03, Ethernet0

C

200.20.3.0/24 is directly connected, Loopback0

O

IA 192.80.100.0/24 [110/84] via 200.20.94.81, 00:00:03, Ethernet0

Verificamos que o roteador cisco2 aprende as outras redes por OSPF através de suas interfaces Serial1, via 200.20.4.2 (Serial1 cisco3) e Ethernet0 via 200.20.94.81 (Ethernet0 cisco1).

É importante notar que as redes que possuem ao lado IA: 192.80.209 , 200.156.10.1 , 200.20.6.1 e 192.80.100.0 fazem parte de áreas diferentes, por isso o nome de inter-área.

cisco2#

cisco2#traceroute 192.80.100.5

Type escape sequence to abort.

Tracing the route to 192.80.100.5

1 200.20.94.81 4 msec 4 msec 4 msec

2 192.80.209.14 4 msec 4 msec 4 msec

3 192.80.100.5 4 msec 4 msec 8 msec

cisco2#

cisco2#traceroute 139.82.10.1

Type escape sequence to abort.

Tracing the route to 139.82.10.1

1 200.20.4.2 4 msec *

cisco2#

4 msec

Com o comando traceroute confirmamos o caminho que o pacote percorre até a 139.82.10.19 (Loopback0 do cisco3) e até o PC 192.80.100.5.

cisco3

cisco3#

cisco3#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

Gateway of last resort is not set

O

IA 192.80.209.0 [110/1636] via 200.20.4.1, 00:09:38, Serial1 200.156.10.0 is subnetted (mask is 255.255.255.255), 1 subnets

O

IA

200.156.10.1 [110/1573] via 200.20.4.1, 00:09:38, Serial1

O

IA 200.20.94.0 [110/1572] via 200.20.4.1, 16:21:34, Serial1

C

200.20.4.0

is directly connected, Serial1

139.82.0.0

is subnetted (mask is 255.255.255.0), 1 subnets

C

139.82.10.0 is directly connected, Loopback0

200.20.6.0 is subnetted (mask is 255.255.255.255), 1 subnets

O IA

200.20.6.1 [110/1637] via 200.20.4.1, 00:09:39, Serial1

200.20.3.0 is subnetted (mask is 255.255.255.255), 1 subnets

O

200.20.3.1 [110/1563] via 200.20.4.1, 16:21:34, Serial1

O

IA 192.80.100.0 [110/1646] via 200.20.4.1, 00:09:39, Serial1

Verificamos que o roteador cisco3 aprende as outras redes por OSPF através da interface Serial1, via 200.20.4.1 (interface Serial1 do cisco2).

É importante notar que as redes que possuem ao lado IA: 192.80.209.0 , 200.56.10.1 ,

200.20.4.0 , 200.20.6.1 , 192.80.100.0

por isso o nome de inter-área.

fazem parte de áreas diferentes,

cisco3#

cisco3#trace ip 192.80.100.5

Type escape sequence to abort.

Tracing the route to 192.80.100.5

1 200.20.4.1 4 msec 4 msec 4 msec

2 200.20.94.81 4 msec 4 msec 4 msec

3 192.80.209.14 8 msec 4 msec 4 msec

4 192.80.100.5 8 msec 8 msec 4 msec

cisco3#

Com o comando traceroute confirmamos o caminho que o pacote percorre até o PC 192.80.100.5.

msec 4 msec cisco3# Com o comando traceroute confirmamos o caminho que o pacote percorre até
msec 4 msec cisco3# Com o comando traceroute confirmamos o caminho que o pacote percorre até