Sei sulla pagina 1di 20

DCNI-2

Lab 6: Quality of Service


Activity Objective
In this activity, you will become familiar with configuring QoS parameters within Cisco NX-
OS. After completing this activity, you will be able to meet these objectives:
n Configure type qos and type queueing class maps
n Configure type qos and type queueing policy maps
n Configure type qos and type queueing service policies
n View and validate the QoS configurations

Required Resources
These are the resources and equipment required to complete this activity:
n Two Cisco Nexus 7010 chassis with dual supervisor modules
n Dual power supplies, dual system fans, dual fabric fans, and three fabric modules per
chassis
n One 48-port 1 Gigabit Ethernet I/O module per chassis
n One 32-port 10 Gigabit Ethernet I/O module per chassis with SFP+ SR optical transceivers
installed
n Cisco NX-OS LAN Enterprise License
n Cisco NX-OS LAN Advanced Services License
Commands
The table lists the commands that are used in this activity.

Command

bandwidth
Checkpoint
class class-default
class-map type qos
class type qos
class type queuing
match cos
match dscp
match packet length
match protocol
police
policy-map type qos
queue-limit
random-detect
service-policy type qos
service-policy type queuing
set
show class-map name
show class-map type qos
show policy-map type qos
show policy-map type queuing
show table-map DSCP-SET
table-map

2 Implementing Cisco Data Center Networking Infrastructure 2 (DCNI-2) v3.0 2009 Cisco Systems, Inc.
To have a painless experience and avoid unnecessary support
requests, it is important to go through the entire Lab Access session
before starting the lab!!!

Lab Access

Identify Your Pod Number: Pod number can be found on the left upper corner **** NX-OS-X ,
where X is your pod number. Make a note of your pod number on a paper.

Note: In this doc, the interfaces referred in most of the output shown in these steps refer to Pod1.

Once your pod number is identified, go to Table 1 POD Information and Access Account and
make a note of the credentials and interfaces assigned to your pod on a paper.
Table 1 POD Information and Access Account
POD Devices Login/Password Assigned Interfaces mgmt0 IP
POD 1
N7K11 admin/pod1nxos 1/1-5, 2/1-8 10.2.8.17
N7K12 admin/pod1nxos 1/1-5, 2/1-8 10.2.8.18
CAT 6K n/a 6/1-2
Nexus 5K admin/1234qwe 10.10.8.15
MDS 9124 admin/1234qwe
VSphere Client cisco/12345qwe localhost
POD 2
N7K11 admin/pod2nxos 1/13-17, 2/9-16 10.2.8.27
N7K12 admin/pod2nxos 1/13-17, 2/9-16 10.2.8.28
CAT 6K n/a 6/1-2
Nexus 5K admin/1234qwe 10.10.8.25
MDS 9124 admin/1234qwe
VSphere Client cisco/12345qwe localhost
POD 3
N7K11 admin/pod3nxos 1/25-29, 2/17-24 10.2.8.37
N7K12 admin/pod3nxos 1/25-29, 2/17-24 10.2.8.38
CAT 6K n/a 6/1-2
Nexus 5K admin/1234qwe 10.10.8.35
MDS 9124 admin/1234qwe
VSphere Client cisco/12345qwe localhost

Dont try to ping these IP addresses from your desktop, they are private addresses.

2009 Cisco Systems, Inc. Lab Guide 3


Task 1: Configure Type QoS Class Maps
In this task you will configure QoS class maps.

Note The lab topology includes two Cisco Nexus 7010 platforms. Each Nexus 7010 switch is
shared between the pods and has multiple virtual device contexts (VDCs). You will manage
the VDC assigned to your pod.

Activity Procedure
Step 1 Connect to your N7K11-podX VDC (where X is your pod number) using the
provided access information (username admin with password pod1nxos, pod2nxos,
or pod3nxos, depending on your pod).

Note In this exercise you do not have to configure the second N7K switch in your pod. All tasks
can be configured and verified on a single switch.

Step 2 Configure a type qos class map named DSCP-CLUB.

Note Class map names are case sensitive.

N7K11-pod1(config)# class-map ?
WORD Class-map name (Max Size 40)
match-all Logical-AND all match statements under this classmap
match-any Logical-OR all match statements under this classmap
type Specify the type of this class-map

N7K11-pod1(config)# class-map type qos ?


WORD Class-map name (Max Size 40)
match-all Logical-AND all match statements under this classmap
match-any Logical-OR all match statements under this classmap

N7K11-pod1(config)# class-map type qos m


match-all match-any

N7K11-pod1(config)# class-map type qos match-any ?


WORD Class-map name (Max Size 40)

N7K11-pod1(config)# class-map type qos match-any DSCP-CLUB


N7K11-pod1(config-cmap-qos)# show class-map ?
*** No matching command found in current mode, matching in (exec) mode ***
<CR>
> Redirect it to a file
>> Redirect it to a file in append mode
WORD Class map name (Max Size 40)
conform-color-in Conform color map in input direction
conform-color-out Conform color map in output direction
exceed-color-in Exceed color map in input direction
exceed-color-out Exceed color map in output direction
type Type of the class-map
| Pipe command output to filter
N7K11-pod1(config-cmap-qos)# show class-map DSCP-CLUB

Type qos class-maps


====================
class-map type qos match-any DSCP-CLUB

Step 3 Assign match criteria for DSCP classes AF11, AF12, and AF43.
N7K11-pod1(config-cmap-qos)# match ?
access-group Access group

4 Implementing Cisco Data Center Networking Infrastructure 2 (DCNI-2) v3.0 2009 Cisco Systems, Inc.
class-map Class map
cos IEEE 802.1Q class of service
discard-class Discard class
dscp DSCP in IP(v4) and IPv6 packets
ip IP
not Negate this match result
packet Packet
precedence Precedence in IP(v4) and IPv6 packets
protocol Protocol
qos-group Qos-group

N7K11-pod1(config-cmap-qos)# match dscp ?


<0-63> List of DSCP values
af11 AF11 dscp (001010)
af12 AF12 dscp (001100)
af13 AF13 dscp (001110)
af21 AF21 dscp (010010)
af22 AF22 dscp (010100)
af23 AF23 dscp (010110)
af31 AF31 dscp (011010)
af32 AF32 dscp (011100)
af33 AF33 dscp (011110)
af41 AF41 dscp (100010)
af42 AF42 dscp (100100)
af43 AF43 dscp (100110)
cs1 CS1(precedence 1) dscp (001000)
cs2 CS2(precedence 2) dscp (010000)
cs3 CS3(precedence 3) dscp (011000)
cs4 CS4(precedence 4) dscp (100000)
cs5 CS5(precedence 5) dscp (101000)
cs6 CS6(precedence 6) dscp (110000)
cs7 CS7(precedence 7) dscp (111000)
default Default dscp (000000)
ef EF dscp (101110)

N7K11-pod1(config-cmap-qos)# match dscp af11


N7K11-pod1(config-cmap-qos)# match dscp af12
N7K11-pod1(config-cmap-qos)# match dscp af43
N7K11-pod1(config-cmap-qos)# exit

Step 4 Validate the type qos class-map DSCP-CLUB.


N7K11-pod1(config)# show class-map DSCP-CLUB

Type qos class-maps


====================

class-map type qos match-any DSCP-CLUB


match dscp 10,12,38

1. Why does the match statement in the show class-map DSCP-CLUB show the dscp
classes 10, 12, and 38?

Step 5 Configure a type qos class map named COS-CODES.


N7K11-pod1(config)# class-map type qos match-any COS-CODES
Step 6 Assign the match criteria for 8021.Q Class of Service codes 3, 5, 6, and 7.
N7K11-pod1(config-cmap-qos)# match cos ?
<0-7> List of class-of-service values
N7K11-pod1(config-cmap-qos)# match cos 3,5-7
N7K11-pod1(config-cmap-qos)# exit

Step 7 Verify the class map named COS-CODES.

2009 Cisco Systems, Inc. Lab Guide 5


N7K11-pod1(config)# show class-map COS-CODES

Type qos class-maps


====================

class-map type qos match-any COS-CODES


match cos 3,5-7

Step 8 Create a type qos class map named PACKET-SIZE.


N7K11-pod1(config)# class-map type qos match-any PACKET-SIZE
N7K11-pod1(config-cmap-qos)# match ?
access-group Access group
class-map Class map
cos IEEE 802.1Q class of service
discard-class Discard class
dscp DSCP in IP(v4) and IPv6 packets
ip IP
not Negate this match result
packet Packet
precedence Precedence in IP(v4) and IPv6 packets
protocol Protocol
qos-group Qos-group
N7K11-pod1(config-cmap-qos)# match packet ?
length Length of IP datagram
N7K11-pod1(config-cmap-qos)# match packet length 1500

Step 9 View the class map named PACKET-SIZE.


N7K11-pod1(config)# show class-map PACKET-SIZE

Type qos class-maps


====================

class-map type qos match-any PACKET-SIZE


match packet length 1500

Step 10 Configure a type qos class map named L2PROTOCOL.


N7K11-pod1(config)# class-map type qos L2PROTOCOL
Step 11 Set the match criteria for ARP and Cisco Discovery Protocol.
N7K11-pod1(config-cmap-qos)# match protocol arp
N7K11-pod1(config-cmap-qos)# match protocol cdp
N7K11-pod1(config-cmap-qos)# exit

Step 12 View the class map named L2PROTOCOL.


N7K11-pod1(config)# show class-map L2PROTOCOL

Type qos class-maps


====================

class-map type qos match-all L2PROTOCOL


match protocol arp
match protocol cdp

N7K11-pod1(config)# show class-map type qos

Type qos class-maps


====================

class-map type qos match-any COS-CODES


match cos 3,5-7

class-map type qos match-any DSCP-CLUB

6 Implementing Cisco Data Center Networking Infrastructure 2 (DCNI-2) v3.0 2009 Cisco Systems, Inc.
match dscp 10,12,38

class-map type qos match-all L2PROTOCOL


match protocol arp
match protocol cdp

class-map type qos match-any PACKET-SIZE


match packet length 1500

class-map type qos conform-color-in


Description: Conform color map in input direction

class-map type qos conform-color-out


Description: Conform color map in output direction

class-map type qos exceed-color-in


Description: Exceed color map in input direction

class-map type qos exceed-color-out


Description: exceed color map in output direction

2. Do you see the class maps that were created during this task?
________________________

3. Why are there additional type qos class maps displayed for this show command?

Task 2: Configure Type QoS Policy Maps


Activity Procedure
In this task you will configure the policies that will be assigned to the type qos class-maps
created in Task 1.
Complete these steps:
Step 1 Create a table map named dscp-set. This map will be used to define a type qos
policy for the class map named DCSP-CLUB.
N7K11-pod1(config)# table-map DSCP-SET
N7K11-pod1(config-tmap)# ?
default Map default values
description Table-Map description
end Go to exec mode
exit Exit from command interpreter
from Map values from this
no Negate a command or set its defaults
pop Pop mode from stack or restore from name
push Push current mode to stack or save it under name
where Shows the cli context you are in

N7K11-pod1(config-tmap)# default 11
N7K11-pod1(config-tmap)# from 10 to 18
N7K11-pod1(config-tmap)# from 12 to 20
N7K11-pod1(config-tmap)# from 38 to 26
N7K11-pod1(config-tmap)# exit

Step 2 View the table and validate its parameters.


N7K11-pod1(config)# show table-map DSCP-SET

Table-map DSCP-SET
default 11
from 10 to 18
from 12 to 20

2009 Cisco Systems, Inc. Lab Guide 7


from 38 to 26

Step 3 Create a type qos policy named DSCP-MUTATE.


N7K11-pod1(config)# policy-map type qos DSCP-MUTATE

Step 4 Assure that the policy includes all packets.


N7K11-pod1(config-pmap-qos)# class class-default
N7K11-pod1(config-pmap-c-qos)# class-map type qos DCSP-CLUB
N7K11-pod1(config-cmap-qos)# exit

Step 5 Specify the actions associated with the policy map DSCP-MUTATE.
N7K11-pod1(config)# policy-map type qos DSCP-MUTATE
N7K11-pod1(config-pmap-qos)# class class-default
N7K11-pod1(config-pmap-c-qos)# set dscp dscp table DSCP-SET

Step 6 View the type qos policy map named DSCP-MUTATE.


N7K11-pod1(config-pmap-c-qos)# show policy-map DSCP-MUTATE

Type qos policy-maps


====================

policy-map type qos DSCP-MUTATE


class class-default
set dscp dscp table DSCP-SET

Step 7 Create a policy for the class map named COS-CODES.


N7K11-pod1(config)# policy-map type qos COS-LIMIT
Step 8 Associate the policy with the class map named COS-CODES.
N7K11-pod1(config-pmap-qos)# class type qos COS-CODES
Step 9 Set the bandwidth to not exceed 40 percent of the interface speed.
N7K11-pod1(config-pmap-c-qos)# police percent 40
Step 10 View the policy map named COS-CODES.
N7K11-pod1(config-pmap-c-qos)# show policy-map COS-LIMIT

Type qos policy-maps


====================

policy-map type qos COS-LIMIT


class cos-codes
police cir percent 40 bc 200 ms conform transmit violate drop

4. What type of policer has been created by this policy?

Step 11 Create a type qos policy map named PACKET-RATE.


N7K11-pod1(config)# policy-map type qos PACKET-RATE

Step 12 Associate the policy with the class map named PACKET-SIZE.
N7K11-pod1(config-pmap-qos)# class type qos PACKET-SIZE

Step 13 Set the IP Precedence to routine (precedence value 0).


N7K11-pod1(config-pmap-c-qos)# set precedence routine

Step 14 View the policy map named PACKET-RATE.

8 Implementing Cisco Data Center Networking Infrastructure 2 (DCNI-2) v3.0 2009 Cisco Systems, Inc.
N7K11-pod1(config-pmap-c-qos)# show policy-map PACKET-RATE

Type qos policy-maps


====================

policy-map type qos PACKET-RATE


class PACKET-SIZE
set prec routine

Step 15 Create a type qos policy map named L2-COS.


N7K11-pod1(config)# policy-map type qos L2-COS

Step 16 Associate the policy map with the class map named L2PROTOCOL.
N7K11-pod1(config-pmap-qos)# class type qos L2PROTOCOL
Step 17 For packets that match ARP and Cisco Discovery Protocol, set the 802.1Q Class of
Service to 4.
N7K11-pod1(config-pmap-c-qos)# set cos 4
N7K11-pod1(config-pmap-c-qos)# show policy-map L2-COS

Type qos policy-maps


====================

policy-map type qos L2-COS


class L2PROTOCOL
set cos 4

Step 18 View the type qos policy maps created in Task 2.


N7K11-pod1(config-pmap-c-qos)# show policy-map type qos

Type qos policy-maps


====================

policy-map type qos L2-COS


class L2PROTOCOL
set cos 4
policy-map type qos COS-LIMIT
class COS-CODES
police cir percent 40 bc 200 ms conform transmit violate drop
policy-map type qos DSCP-MUTATE
class class-default
set dscp dscp table DSCP-SET
policy-map type qos PACKET-RATE
class PACKET-SIZE
set prec routine

Task 3: Configure Type QoS Service Policies


Activity Procedure
During this exercise, you will configure type QoS service policies.
Step 1 Assign the service policy named DSCP-MUTATE to your port channel interface in
the outbound direction.
N7K11-pod1(config)# interface port-channel 1
N7K11-pod1(config-if)# service-policy output DSCP-MUTATE
Step 2 View the service policies associated with the port channel interface in the egress
direction.
N7K11-pod1(config-if)# show policy-map interface port-channel 1 output

2009 Cisco Systems, Inc. Lab Guide 9


Global statistics status : enabled

port-channel1

Service-policy (qos) output: DSCP-MUTATE


policy statistics status: enabled

Class-map (qos): class-default (match-any)


0 packets
set dscp dscp table DSCP-SET

Service-policy (queuing) output: default-out-policy


policy statistics status: enabled

Class-map (queuing): out-pq1 (match-any)


priority level 1
queue-limit percent 16
queue dropped pkts : 0

Class-map (queuing): out-q2 (match-any)


queue-limit percent 1
queue dropped pkts : 0

Class-map (queuing): out-q3 (match-any)


queue-limit percent 1
queue dropped pkts : 0

Class-map (queuing): out-q-default (match-any)


queue-limit percent 82
bandwidth remaining percent 25
queue dropped pkts : 0

Step 3 Assign a service policy to the first 1 Gigabit Ethernet interface within your VDC
pod in the ingress direction for the policy map named COS-LIMIT.
N7K11-pod1(config)# interface ethernet 1/1
N7K11-pod1(config-if)# service-policy input COS-LIMIT

Step 4 View the service policies associated with this interface in the ingress direction.
N7K11-pod1(config-if)# show policy-map interface ethernet 1/1 input

Global statistics status : enabled

Ethernet1/1

Service-policy (qos) input: COS-LIMIT


policy statistics status: enabled

Class-map (qos): COS-CODES (match-any)


0 packets
Match: cos 3,5-7
0 packets
police cir percent 40 bc 200 ms
conformed 0 bytes, 0 bps action: transmit
violated 0 bytes, 0 bps action: drop

Service-policy (queuing) input: default-in-policy


policy statistics status: enabled

Class-map (queuing): in-q1 (match-any)


queue-limit percent 50
bandwidth percent 80
queue dropped pkts : 0

Class-map (queuing): in-q-default (match-any)


queue-limit percent 50

10 Implementing Cisco Data Center Networking Infrastructure 2 (DCNI-2) v3.0 2009 Cisco Systems, Inc.
bandwidth percent 20
queue dropped pkts : 0

Step 5 Assign a service policy to the second 1 Gigabit Ethernet interface in the egress
direction within your VDC pod using the policy map named packet-rate.
N7K11-pod1(config)# interface ethernet 1/2
N7K11-pod1(config-if)# service-policy output PACKET-RATE
Step 6 View the service policy associated with this interface in the egress direction.
N7K11-pod1(config-if)# show policy-map interface ethernet 1/2 output

Global statistics status : enabled

Ethernet1/2

Service-policy (qos) output: PACKET-RATE


policy statistics status: enabled

Class-map (qos): PACKET-SIZE (match-any)


0 packets
Match: packet length 1500
0 packets
set prec routine

Service-policy (queuing) output: default-out-policy


policy statistics status: enabled

Class-map (queuing): out-pq1 (match-any)


priority level 1
queue-limit percent 16
queue dropped pkts : 0

Class-map (queuing): out-q2 (match-any)


queue-limit percent 1
queue dropped pkts : 0

Class-map (queuing): out-q3 (match-any)


queue-limit percent 1
queue dropped pkts : 0

Class-map (queuing): out-q-default (match-any)


queue-limit percent 82
bandwidth remaining percent 25
queue dropped pkts : 0

Step 7 Assign a service policy to the port channel interface in the egress direction.
N7K11-pod1(config)# interface port-channel 1
N7K11-pod1(config-if)# service-policy output L2-COS
Step 8 View the service policy.
N7K11-pod1(config-if)# show policy-map interface port-channel 1 output

Global statistics status : enabled

port-channel1

Service-policy (qos) output: L2-COS


policy statistics status: enabled

Class-map (qos): L2PROTOCOL (match-all)


0 packets
Match: protocol arp
Match: protocol cdp
set cos 4

2009 Cisco Systems, Inc. Lab Guide 11


Service-policy (queuing) output: default-out-policy
policy statistics status: enabled

Class-map (queuing): out-pq1 (match-any)


priority level 1
queue-limit percent 16
queue dropped pkts : 0

Class-map (queuing): out-q2 (match-any)


queue-limit percent 1
queue dropped pkts : 0

Class-map (queuing): out-q3 (match-any)


queue-limit percent 1
queue dropped pkts : 0

Class-map (queuing): out-q-default (match-any)


queue-limit percent 82
bandwidth remaining percent 25
queue dropped pkts : 0

5. What happened to the service policy named dscp-mutate created and assigned to the port
channel interface in the egress direction in Step 1?

Task 4: Configure Type Queueing Policy Maps


Activity Procedure
In this task you will configure type queueing class maps.
Step 1 From within your VDC pod, create a class-map type queuing named myqueue.
N7K11-pod1(config)# class-map type queuing myqueue
^
% String is invalid, 'type' is not an allowed string at '^' marker.
N7K11-pod1(config)# class-map type ?
qos Qos class

6. Is there an option to create a class-map type queuing?


______________________________

7. If not, why not?


____________________________________________________________

Step 2 Type queuing maps have a different configuration methodology than type QoS
maps. Create a type queuing policy map named SHAPE_MY_QUEUE.
N7K11-pod1(config)# policy-map type queuing ?
WORD Policy-map name (alphanumeric) (Max Size 40)
match-first Take the action for the first class that matches
N7K11-pod1(config)# policy-map type queuing SHAPE_MY_QUEUE

Step 3 Now assign a class-map type queuing to the policy map named
SHAPE_MY_QUEUE.
N7K11-pod1(config-pmap-que)# class type queuing ?
1p3q4t-out-pq1 Egress priority queue of 1p3q4t type
1p3q4t-out-q-default Egress default queue of 1p3q4t type
1p3q4t-out-q2 Egress queue 2 of 1p3q4t type
1p3q4t-out-q3 Egress queue 3 of 1p3q4t type
1p7q4t-out-pq1 Egress priority queue of 1p7q4t type
1p7q4t-out-q-default Egress default queue of 1p7q4t type
1p7q4t-out-q2 Egress queue 2 of 1p7q4t type
1p7q4t-out-q3 Egress queue 3 of 1p7q4t type

12 Implementing Cisco Data Center Networking Infrastructure 2 (DCNI-2) v3.0 2009 Cisco Systems, Inc.
1p7q4t-out-q4 Egress queue 4 of 1p7q4t type
1p7q4t-out-q5 Egress queue 5 of 1p7q4t type
1p7q4t-out-q6 Egress queue 6 of 1p7q4t type
1p7q4t-out-q7 Egress queue 7 of 1p7q4t type
2q4t-in-q-default Ingress default queue of 2q4t type
2q4t-in-q1 Ingress queue 1 of 2q4t type
8q2t-in-q-default Ingress default queue of 8q2t type
8q2t-in-q1 Ingress queue 1 of 8q2t type
8q2t-in-q2 Ingress queue 2 of 8q2t type
8q2t-in-q3 Ingress queue 3 of 8q2t type
8q2t-in-q4 Ingress queue 4 of 8q2t type
8q2t-in-q5 Ingress queue 5 of 8q2t type
8q2t-in-q6 Ingress queue 6 of 8q2t type
8q2t-in-q7 Ingress queue 7 of 8q2t type

Step 4 Select the egress queue type 1p3q4t-out-pq1.


N7K11-pod1(config-pmap-que)# class type queuing 1p3q4t-out-pq1

Step 5 Set a tail drop threshold for packets with a class of service (CoS) of 4 to a maximum
size of 1 MB.
N7K11-pod1(config-pmap-c-que)# queue-limit ?
<1-83886080> Queue size in packets/bytes/kbytes/mbytes/ms/us
cos IEEE 802.1Q class of service
percent Specify queue size in Percentage
N7K11-pod1(config-pmap-c-que)# queue-limit cos 4 ?
<1-83886080> Queue size in packets/bytes/kbytes/mbytes/ms/us
percent Specify queue size in Percentage
N7K11-pod1(config-pmap-c-que)# queue-limit cos 4 1 mbytes

Step 6 View the policy map named SHAPE_MY_QUEUE.


N7K11-pod1(config-pmap-c-que)# show policy-map type queuing SHAPE_MY_QUEUE

Type queuing policy-maps


========================

policy-map type queuing SHAPE_MY_QUEUE


class type queuing 1p3q4t-out-pq1
queue-limit cos 4 1 mbytes

Step 7 Create a policy map named WRED-SET.


N7K11-pod1(config)# policy-map type queuing WRED-SET

Step 8 Select the egress queue type 8q-2t-in-q-default.


N7K11-pod1(config-pmap-que)# class type queuing 8q2t-in-q-default

Step 9 Set the aggregate WRED thresholds for nonconfigured classes of traffic to a
minimum of 10 percent and a maximum of 20 percent of the queue size.
N7K11-pod1(config-pmap-c-que)# random-detect ?
cos Parameters for each cos value
cos-based Configure WRED parameters for cos-based mode
N7K11-pod1(config-pmap-c-que)# random-detect cos-based ?
<CR>
aggregate Configure WRED parameters to same value for all
sub-classes
N7K11-pod1(config-pmap-c-que)# random-detect cos-based aggregate ?
<1-52428800> Minimum threshold value
minimum-threshold Specify minimum threshold for WRED
percent Specify thresholds in percent
N7K11-pod1(config-pmap-c-que)# random-detect cos-based aggregate percent ?
N7K11-pod1(config-pmap-c-que)# random-detect cos-based aggregate percent 10 ?
<1-52428800> Maximum threshold value

2009 Cisco Systems, Inc. Lab Guide 13


maximum-threshold Specify maximum threshold for WRED
percent Specify thresholds in percent
N7K11-pod1(config-pmap-c-que)# random-detect cos-based aggregate percent 10
percent 20

Step 10 View the policy map type queuing named WRED-SET.


N7K11-pod1(config-pmap-c-que)# show policy-map type queuing WRED-SET

Type queuing policy-maps


========================

policy-map type queuing WRED-SET


class type queuing 8q2t-in-q-default
random-detect cos-based aggregate minimum-threshold percent 10
maximum-threshold percent 20

Step 11 Create a policy map type queuing named MY-RATE.


N7K11-pod1(config)# policy-map type queuing MY-RATE

Step 12 Assign the type queuing class map.


N7K11-pod1(config-pmap-que)# class type queuing 1p3q4t-out-pq1

Step 13 Set the priority queue.


N7K11-pod1(config-pmap-c-que)# priority
N7K11-pod1(config-pmap-c-que)# exit

Step 14 Assign remaining bandwidth to a nondefault queue.


N7K11-pod1(config-pmap-que)# class type queuing 1p3q4t-out-q2
N7K11-pod1(config-pmap-c-que)# bandwidth ?
<1-10000000000> Value in bps/kbps/mbps/gbps
percent Percentage of available bandwidth
remaining % of remaining bandwidth
N7K11-pod1(config-pmap-c-que)# bandwidth remaining percent 25
N7K11-pod1(config-pmap-c-que)# exit

Step 15 Assign 40 percent of the remaining bandwidth to the third queue and 25 percent of
the remaining bandwidth to the default queue.
N7K11-pod1(config-pmap-que)# class type queuing 1p3q4t-out-q3
N7K11-pod1(config-pmap-c-que)# bandwidth remaining percent 40
N7K11-pod1(config-pmap-c-que)# exit
N7K11-pod1(config-pmap-que)# class type queuing 1p3q4t-out-q-default
N7K11-pod1(config-pmap-c-que)# bandwidth remaining percent 25
N7K11-pod1(config-pmap-c-que)# exit

Step 16 View the type queuing policy map named MY-RATE


N7K11-pod1(config-pmap-que)# show policy-map type queuing MY-RATE

Type queuing policy-maps


========================

policy-map type queuing MY-RATE


class type queuing 1p3q4t-out-pq1
priority level 1
class type queuing 1p3q4t-out-q2
bandwidth remaining percent 25
class type queuing 1p3q4t-out-q3
bandwidth remaining percent 40
class type queuing 1p3q4t-out-q-default
bandwidth remaining percent 25

14 Implementing Cisco Data Center Networking Infrastructure 2 (DCNI-2) v3.0 2009 Cisco Systems, Inc.
Task 5: Configure Type Queueing Service Policies
Activity Procedure
In this task you will configure type queueing service policies.
Step 1 Assign a type queuing service policy named SHAPE_MY_QUEUE and assign it to
the first 1 Gigabit Ethernet interface.
N7K11-pod1(config)# interface ethernet 1/1
N7K11-pod1(config-if)# service-policy type queuing output SHAPE_MY_QUEUE

Step 2 View the type queuing service policy named SHAPE_MY_QUEUE.


N7K11-pod1(config-if)# show policy-map type queuing SHAPE_MY_QUEUE

Type queuing policy-maps


========================
policy-map type queuing SHAPE_MY_QUEUE
class type queuing 1p3q4t-out-pq1
queue-limit cos 4 1 mbytes
Step 3 View the type queuing service policy named WRED-SET.
N7K11-pod1(config-if)# show policy-map type queuing WRED-SET

Type queuing policy-maps


========================

policy-map type queuing WRED-SET


class type queuing 8q2t-in-q-default
random-detect cos-based aggregate minimum-threshold percent 10 maximum-
thr
eshold percent 20

Step 4 Assign a type queuing service policy named MY-RATE and assign it to the second 1
Gigabit Ethernet interface.
N7K11-pod1(config-if)# interface ethernet 1/2
N7K11-pod1(config-if)# service-policy type queuing output MY-RATE
ERROR: Module 1 returned status "All queues configured, but percentage is
less than 100. If all queues are used, percentage should be 100 percent."

Step 5 Modify the default queue to receive 35 percent of the remaining bandwidth and
repeat Step 5.
8. Is this operation successful?
__________________________________________________

Step 6 View the type queuing service policy named MY-RATE.


N7K11-pod1(config-if)# show policy-map type queuing MY-RATE

Type queuing policy-maps


========================

policy-map type queuing MY-RATE


class type queuing 1p3q4t-out-pq1
priority level 1
class type queuing 1p3q4t-out-q2
bandwidth remaining percent 25
class type queuing 1p3q4t-out-q3
bandwidth remaining percent 40
class type queuing 1p3q4t-out-q-default
bandwidth remaining percent 35

2009 Cisco Systems, Inc. Lab Guide 15


Step 7 Create a checkpoint named QOS-CONFIG.

16 Implementing Cisco Data Center Networking Infrastructure 2 (DCNI-2) v3.0 2009 Cisco Systems, Inc.
Answer Key
The correct answers and expected solutions for the activities that are described in this guide
appear here.

Lab 6 Answer Key: Quality of Service


Upon completing this lab exercise, your configuration should look similar to the following:

Task 1: Configure Type QoS Class Maps


1. The match statement shows the DSCP decimal equivalent for the classes af11, af12, and
af43.

2. Yes

3. The additional class maps are standard default class maps used for policing of traffic.

Task 2: Configure Type QoS Policy Maps


4. A 1-rate, 2-color policer

Task 3: Configure Type QoS Service Policies


version 5.0(3)
feature ssh
feature ospf
feature lacp

username admin password 5 $1$LVQxygTs$YR.oO8KhXrNMIb9Vt51YH0 role vdc-admin


ip domain-lookup
ip host N7K11-pod1 10.2.8.17
switchname pod1
logging event link-status default
class-map type qos match-any COS-CODES
match cos 3,5-7
class-map type qos match-any DSCP-CLUB
match dscp 10,12,38
class-map type qos match-all L2PROTOCOL
match protocol arp
match protocol cdp
class-map type qos match-any PACKET-SIZE
match packet length 1500
table-map DSCP-SET
default 11
from 10 to 18
from 12 to 20
from 38 to 26
policy-map type qos L2-COS
class L2PROTOCOL
set cos 4
policy-map type qos COS-LIMIT
class COS-CODES
police cir percent 40 bc 200 ms conform transmit violate drop
policy-map type qos DSCP-POLICY
class class-default
policy-map type qos DSCP-MUTATE
class DSCP-CLUB
class class-default
set dscp dscp table DSCP-SET
policy-map type qos PACKET-RATE
class PACKET-SIZE
set precedence 0
snmp-server user admin vdc-admin auth md5 0xffc46dea7a4eb4c1d792c71bc5549043
pri
v 0xffc46dea7a4eb4c1d792c71bc5549043 localizedkey

2009 Cisco Systems, Inc. Lab Guide 17


vrf context management
ip route 0.0.0.0/0 10.2.8.1
vrf context INTERSWITCH
vlan 1

interface port-channel1
service-policy type qos output L2-COS
vrf member INTERSWITCH
ip address 10.11.3.1/24
ip ospf message-digest-key 1 md5 3 3607ff6124fab2a3
ip ospf dead-interval 20
ip ospf hello-interval 5
ip router ospf 1 area 0.0.0.0

interface Ethernet1/1
service-policy type qos input COS-LIMIT
no shutdown

interface Ethernet1/2
service-policy type qos output PACKET-RATE
no shutdown

interface Ethernet1/3

interface Ethernet1/4

interface Ethernet1/5

interface Ethernet2/1
channel-group 1 mode active
no shutdown

interface Ethernet2/2
switchport
no shutdown

interface Ethernet2/3
channel-group 1 mode active
no shutdown

interface Ethernet2/4

interface Ethernet2/5

interface Ethernet2/6

interface Ethernet2/7

interface Ethernet2/8

interface mgmt0
ip address 10.2.8.17/24

interface loopback0
ip address 10.10.10.10/32
router ospf 1
router-id 10.10.10.10
area 0.0.0.0 authentication message-digest
log-adjacency-changes
auto-cost reference-bandwidth 40
5. Only one type qos service policy can be applied per interface in either direction. This action
eliminated the service policy dscp-mutate created in Step 1.

Task 4: Configure Type Queueing Policy Maps


6. No, not within your VDC. No results are shown.

18 Implementing Cisco Data Center Networking Infrastructure 2 (DCNI-2) v3.0 2009 Cisco Systems, Inc.
7. To modify type queuing class maps you must be within the default VDC configuration
context.

Task 5: Configure Type Queueing Service Policies


version 5.0(3)
feature ssh
feature lacp

username admin password 5 $1$tPIpx/5m$k3zcbQEzAT3LmLUjKBOSm1 role vdc-admin


ip domain-lookup
ip host N7K11-pod1 10.2.8.17
switchname pod1
logging event link-status default
class-map type qos match-all class
policy-map type queuing MY-RATE
class type queuing 1p3q4t-out-pq1
priority level 1
class type queuing 1p3q4t-out-q2
bandwidth remaining percent 25
class type queuing 1p3q4t-out-q3
bandwidth remaining percent 40
class type queuing 1p3q4t-out-q-default
bandwidth remaining percent 35
policy-map type queuing WRED-SET
class type queuing 8q2t-in-q-default
random-detect cos-based aggregate minimum-threshold percent 10 maximum-
threshold percent 20
policy-map type queuing SHAPE_MY_QUEUE
class type queuing 1p3q4t-out-pq1
queue-limit cos 4 1 mbytes
snmp-server user admin vdc-admin auth md5 0xa5fc30c26ff1fbe89ed7e2b2cfff0bb2
priv 0xa5fc30c26ff1fbe89ed7e2b2cfff0bb2 localizedkey

vrf context management


ip route 0.0.0.0/0 10.2.8.1
vlan 1

interface port-channel1

interface Ethernet1/1
service-policy type queuing output SHAPE_MY_QUEUE

interface Ethernet1/2
service-policy type queuing output MY-RATE

interface Ethernet1/3

interface Ethernet1/4

interface Ethernet1/5

interface Ethernet2/1
channel-group 1 mode active

interface Ethernet2/2

interface Ethernet2/3
channel-group 1 mode active

interface Ethernet2/4

interface Ethernet2/5

interface Ethernet2/6

interface Ethernet2/7

2009 Cisco Systems, Inc. Lab Guide 19


interface Ethernet2/8

interface mgmt0
ip address 10.2.8.17/24
8. Yes

20 Implementing Cisco Data Center Networking Infrastructure 2 (DCNI-2) v3.0 2009 Cisco Systems, Inc.

Potrebbero piacerti anche