Sei sulla pagina 1di 26

ADAMSON UNIVERSITY

COLLEGE OF ENGINEERING
ELECTRONICS ENGINEERING DEPARTMENT

DATA COMMUNICATIONS
First Semester S.Y 2016-2017

EXPERIMENT NO: 3

DYNAMIC ROUTING

REMARKS:

ZURITA, CHRISTIAN ANDREW T.

______________________

_____________

DOP: August 5, 2016


DOS: August 12, 2016

ENGR. JOAN DEL ESPIRITU-STA ANA

GRADE:

Instructor

EXPERIMENT 3: DYNAMIC ROUTING


I.

Introduction
Theory
Dynamic routing is a networking technique that provides optimal data routing. Unlike static
routing, dynamic routing enables routers to select paths according to real-time logical network
layout changes. In dynamic routing, the routing protocol operating on the router is responsible for
the creation, maintenance and updating of the dynamic routing table. In static routing, all these jobs
are
manually
done
by
the
system
administrator.
Dynamic routing uses multiple algorithms and protocols. The most popular are Routing Information
Protocol (RIP) and Open Shortest Path First (OSPF).

Dynamic routing protocols work well in any type of network consisting of several routers. They are
scalable and automatically determine better routes if there is a change in the topology. Although there is
more to the configuration of dynamic routing protocols, they are simpler to configure in a large network.
There are disadvantages to dynamic routing. Dynamic routing requires knowledge of additional
commands. It is also less secure than static routing because the interfaces identified by the routing
protocol send routing updates out. Routes taken may differ between packets. The routing algorithm uses
additional CPU, RAM, and link bandwidth.
ADVANTAGES/DISADVANTAGES
Advantages

Disadvantages

Suitable in all topologies where


multiple routers are required.

Can be more complex to initially implement.

Generally independent of the


network size.

Less secure due to the broadcast and multicast routing updates. Additional configuration
settings such as passive interfaces and routing protocol authentication are required to
increase security.

Automatically adapts topology to Route depends on the current topology.


reroute traffic if possible.

Requires additional resources such as CPU, memory, and link bandwidth.

Advantages

II.

Disadvantages

Activity
A. Topology Diagram

Figure 1. The given network for Dynamic Routing

B. Screenshots

Figure 2. Successful sent messages from one LAN to another LAN

Figure 3. LAN A: 90 (PC 0) IP Configuration

Figure 4. LAN B: 100 (PC 1) IP Configuration

Figure 5. LAN C: 16 (PC 2) IP Configuration

Figure 6. LAN D: 30 (PC 3) IP Configuration

Figure 7. LAN E: 200 (PC 4) IP Configuration

Figure 8. LAN F: 40 (PC 5) IP Configuration

C. Codes

For Router 0 (RA)

Figure 9. Router A IP configuration

--- System Configuration Dialog ---

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#host RA
RA(config)#int fa0/0
RA(config-if)#ip add
RA(config-if)#ip address 192.168.1.3 255.255.255.128
RA(config-if)#no shutdown

RA(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

RA(config-if)#exit
RA(config)#int fa0/1
RA(config-if)#ip add
RA(config-if)#ip address 192.168.1.131 255.255.255.128
RA(config-if)#no shut

RA(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up


exit
RA(config)#int s0/0/0
RA(config-if)#ip add
RA(config-if)#ip address 192.168.2.162 255.255.255.252
RA(config-if)#clock rate 64000
RA(config-if)#no shut
RA(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down


RA(config-if)#
RA(config-if)#

RA(config-if)#
RA(config-if)#exit
RA(config)#
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

RA con0 is now available

Press RETURN to get started.

RA>en
RA#conf t
Enter configuration commands, one per line. End with CNTL/Z.
RA(config)#exit
RA#
%SYS-5-CONFIG_I: Configured from console by console

RA#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR


P - periodic downloaded static route

Gateway of last resort is not set

192.168.1.0/25 is subnetted, 2 subnets


C 192.168.1.0 is directly connected, FastEthernet0/0
C 192.168.1.128 is directly connected, FastEthernet0/1
192.168.2.0/30 is subnetted, 1 subnets
C 192.168.2.160 is directly connected, Serial0/0/0
RA#conf t
Enter configuration commands, one per line. End with CNTL/Z.
RA(config)#router rip
RA(config-router)#network 192.168.1.0
RA(config-router)#network 192.168.1.128
RA(config-router)#network 192.168.2.160
RA(config-router)#no auto-summary
RA(config-router)#version 2
RA(config-router)#

RA con0 is now available


Press RETURN to get started.

For Router 1 (RB)

Figure 10. Router B IP configuration


--- System Configuration Dialog ---

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#host RB
RB(config)#int fa0/0
RB(config-if)#ip add
RB(config-if)#ip address 192.168.0.3 255.255.255.0
RB(config-if)#no shut

RB(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

RB(config-if)#exit
RB(config)#int s0/0/1
RB(config-if)#ip add
RB(config-if)#ip address 192.168.2.166 255.255.255.252
RB(config-if)#clock rate 64000
RB(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/0/1, changed state to down


RB(config-if)#
RB(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up

RB con0 is now available

Press RETURN to get started.


RB>en
RB#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is not set

C 192.168.0.0/24 is directly connected, FastEthernet0/0


192.168.2.0/30 is subnetted, 1 subnets
C 192.168.2.164 is directly connected, Serial0/0/1
RB#conf t
Enter configuration commands, one per line. End with CNTL/Z.
RB(config)#router rip
RB(config-router)#network 192.168.0.0
RB(config-router)#network 192.168.2.0
RB(config-router)#no auto-summary
RB(config-router)#version 2
RB(config-router)#

RB con0 is now available

Press RETURN to get started.

For Router 2 (RC)

Figure 11. Router C IP configuration

--- System Configuration Dialog ---

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#host RC
RC(config)#int fa0/0
RC(config-if)#ip add
RC(config-if)#ip address 192.168.2.131 255.255.255.224
RC(config-if)#no shut

RC(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

RC(config-if)#exit
RC(config)#int fa0/1
RC(config-if)#ip add
RC(config-if)#ip address 192.168.2.99 255.255.255.224

RC(config-if)#no shut

RC(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

RC(config-if)#exit
RC(config)#int s0/1/0
RC(config-if)#ip add
RC(config-if)#ip address 192.168.2.170 255.255.255.252
RC(config-if)#clock rate 64000
RC(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/1/0, changed state to down


RC(config-if)#
RC(config-if)#exit
RC(config)#
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0, changed state to up

RC con0 is now available

Press RETURN to get started.

RC>en
RC#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

192.168.2.0/24 is variably subnetted, 3 subnets, 2 masks


C 192.168.2.96/27 is directly connected, FastEthernet0/1
C 192.168.2.128/27 is directly connected, FastEthernet0/0
C 192.168.2.168/30 is directly connected, Serial0/1/0
RC#conf t
Enter configuration commands, one per line. End with CNTL/Z.
RC(config)#router rip
RC(config-router)#network 192.168.2.96
RC(config-router)#network 192.168.2.128
RC(config-router)#network 192.168.2.168
RC(config-router)#no auto-summary
RC(config-router)#version 2
RC(config-router)#

RC con0 is now available

Press RETURN to get started.

For Router 3 (RD)

Figure 12. Router D IP configuration

--- System Configuration Dialog ---

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int fa0/0

Router(config-if)#ip add
Router(config-if)#ip address 192.168.2.3 255.255.255.192
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#int fa0/1
Router(config-if)#ip add
Router(config-if)#ip address 192.168.2.67 255.255.255.224
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

Router(config-if)#exit
Router(config)#int s0/1/1
Router(config-if)#ip add
Router(config-if)#ip address 192.168.2.174 255.255.255.252

Router(config-if)#clock rate 64000


Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/1/1, changed state to down


Router(config-if)#
Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/1/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/1, changed state to up

Router con0 is now available

Press RETURN to get started.

Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#host RD
RD(config)#router rip
RD(config-router)#exit
RD(config)#exit
RD#
%SYS-5-CONFIG_I: Configured from console by console
show

% Incomplete command.
RD#
RD#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

192.168.2.0/24 is variably subnetted, 3 subnets, 3 masks


C 192.168.2.0/26 is directly connected, FastEthernet0/0
C 192.168.2.64/27 is directly connected, FastEthernet0/1
C 192.168.2.172/30 is directly connected, Serial0/1/1
RD#conf t
Enter configuration commands, one per line. End with CNTL/Z.
RD(config)#router rip
RD(config-router)#network 192.168.2.0
RD(config-router)#network 192.168.2.64
RD(config-router)#network 192.168.2.172
RD(config-router)#no auto-summary

RD(config-router)#version 2
RD(config-router)#

RD con0 is now available

Press RETURN to get started.

For Router 4 (RE)

Figure 13. Router E IP configuration

--- System Configuration Dialog ---

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#host RE
RE(config)#int s0/0/0
RE(config-if)#ip add

RE(config-if)#ip address 192.168.2.161 255.255.255.252


RE(config-if)#no shut

RE(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

RE(config-if)#exit
RE(config)#int s0/0/1
RE(config-if)#ip add
RE(config-if)#ip address 192.1
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state
% Incomplete command.
RE(config-if)#exit
RE(config)#int s0/0/1
RE(config-if)#ip add
RE(config-if)#ip address 192.168.2.165 255.255.255.252
RE(config-if)#exit
RE(config)#int s0/1/0
RE(config-if)#ip add
RE(config-if)#ip address 192.168.2.169 255.255.255.252
RE(config-if)#no shut

RE(config-if)#
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to up

RE(config-if)#
RE(config-if)#exit
RE(config)#
RE(config)#int s0/0/1
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0, changed state to up
^
% Invalid input detected at '^' marker.
RE(config)#
RE(config)#int s0/0/1
RE(config-if)#ip add
RE(config-if)#ip address 192.168.2.165 255.255.255.252
RE(config-if)#no shut

RE(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/1, changed state to up

RE(config-if)#
RE(config-if)#
RE(config-if)#
RE(config-if)#
RE(config-if)#exit
RE(config)#
RE(config)#int s0/1/1

RE(config-if)#ip add
RE(config-if)#ip address 192.168.
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up
^
% Invalid input detected at '^' marker.
RE(config-if)#int s0/1/1
RE(config-if)#ip add
RE(config-if)#ip address 192.168.2.173 255.255.255.252
RE(config-if)#no shut

RE(config-if)#
%LINK-5-CHANGED: Interface Serial0/1/1, changed state to up

RE(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/1, changed state to up

RE con0 is now available

Press RETURN to get started.

RE>en
RE#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2


E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

192.168.2.0/30 is subnetted, 4 subnets


C 192.168.2.160 is directly connected, Serial0/0/0
C 192.168.2.164 is directly connected, Serial0/0/1
C 192.168.2.168 is directly connected, Serial0/1/0
C 192.168.2.172 is directly connected, Serial0/1/1
RE#conf t
Enter configuration commands, one per line. End with CNTL/Z.
RE(config)#router rip
RE(config-router)#network 192.168.2.160
RE(config-router)#network 192.168.2.164
RE(config-router)#network 192.168.2.168
RE(config-router)#network 192.168.2.172
RE(config-router)#no auto-summary
RE(config-router)#version 2
RE(config-router)#
RE con0 is now available

Press RETURN to get started.

D. Tables
Device
RA
RB
RC
RD

RE

Terminal
LAN A: 100
LAN B: 64
LAN C: 200
LAN D: 16
LAN E: 20
LAN F: 50
LAN G: 30

E. Conclusion
-

Interface
fa0/0
fa0/1
s0/0/0
fa0/0
s0/0/1
fa0/0
fa0/1
s0/1/0
fa0/0
fa0/1
s0/1/1
s0/0/0
s0/0/1
s0/1/0
s0/1/1
IP Address
192.168.1.1
192.168.1.129
192.168.0.1
192.168.2.129
192.168.2.97
192.168.2.1
192.168.2.65

IP Address
192.168.1.3
192.168.1.131
192.168.2.162
192.168.2.131
192.168.2.99
192.168.2.170
192.168.2.3
192.168.2.67
192.168.2.174
192.168.2.161
192.168.2.165
192.168.2.169
192.168.2.173

SNM
/25
/25
/30
/24
/30
/27
/27
/30
/26
/27
/30
/30
/30
/30
/30

SNM
/25
/25
/24
/27
/27
/26
/27

Default Gateway
192.168.1.3
192.168.1.131
192.168.0.3
192.168.2.131
192.168.2.99
192.168.2.3
192.168.2.67

192.168.0.3
192.168.2.166

Potrebbero piacerti anche