Sei sulla pagina 1di 10

LISTA DE COMANDOS PARA CONFIGURACIN

Switch>
Switch#
Switch(config)#
Switch>enable
Switch#configure terminal
Switch> ping IP-address
Switch> traceroute IP-address
Switch#clock set 19:06:00 25 june 2014
Switch# show history
Switch#show running-config
Switch#show startup-config
Switch# show interfaces
Switch# show interfaces fastethernet 0/1
Switch#show version
Switch#show bootvar
Switch#show ip ssh
Switch#show ip interface brief
Switch# show ip interface vlan1
S1# show mac address-table
Switch#dir flash
S1# show interface vlan 99
Switch(config)#interface vlan 99
Switch(config-if)#ip address 192.168.10.11 255.255.255.0
Switch(config-if)#no shutdown
S1(config-line)# logging synchronous
Switch(config)#hostname S1

Switch(config-if)#ip default-gateway ip_de_router


Switch#copy running-config startup-config
S1(config)# service password-encryption
S1(config)# enable secret class

S1(config)# no ip domain-lookup
S1# clear mac address-table dynamic
S1(config)# banner motd # xyz #
Establecer la direccin IP de la SVI del switch para permitir la administracin remota del switc
S1# configure terminal

S1(config)# vlan 99
S1(config-vlan)# exit
S1(config)# interface vlan99
S1(config-if)# ip address 192.168.1.2 255.255.255.0
S1(config-if)# no shutdown
S1(config-if)# exit
Asigne todos los puertos de usuario a VLAN 99
S1(config)# interface range f0/1 24,g0/1 - 2
S1(config-if-range)# switchport access vlan 99
S1(config-if-range)# exit
restringir el acceso del puerto de consola
S1(config)# line con 0
S1(config-line)# password cisco
S1(config-line)# login
S1(config-line)# logging synchronous
S1(config-line)# exit
Configura las lneas de terminal virtual (vty) para que el switch permita el acceso por Telnet
S1(config)# line vty 0 15
S1(config-line)# password cisco
S1(config-line)# login
Para crear una VLAN con la id_de_vlan 99 y asociarla a una interfaz.
S1(config)# vlan id_de_vlan
S1(config-vlan)# name nombre_de_vlan
S1(config-vlan)# exit
S1(config)# interface interface_id

S1(config-if)# switchport access vlan id_de_vlan


S1(config)# mac address-table static 0050.56BE.6C89 vlan 99 interface
fastethernet 0/6
S1# erase startup-config
S1# reload
Switch# delete vlan.dat
S1(config)# no ip http server

configurar duplex y velocidad de puerto.


S1# configure terminal
S1(config)# interface fastethernet 0/1
S1(config-if)#duplex full
S1(config-if)#speed 100
S1(config-if)#end
S1#coppy running-config startup-config

Configurar AUTO-MDIX(caracterstica automtica de conexin cruzada de interfaz dependiente del me


S1# configure terminal
S1(config)# interface fastethernet 0/1
S1(config-if)#duplex auto
S1(config-if)#speed auto
S1(config-if)#mdix auto
S1(config-if)#end
S1#coppy running-config startup-config
Comandos para configural SSH para la administracin remota.
S1#configure terminal
S1(config)#ip domain-name cisco.com
S1(config)# crypto key generate rsa modulus 1024
S1(config)#username nombre-de-usuario secret contrasea
S1(config)# username admin privilege 15 secret sshadmin

S1(config)# ip ssh time-out 75


S1(config)# ip ssh authentication-retries 2

S1(config)# line vty 0 15


S1(config-line)#transport input ssh
S1(config-line)# login local
S1(config-line)# exit

S1(config)#ip ssh version 2


S1(config)# exit

S1#show vlan brief

S1(config)#interface fastethernet 0/1


S1(config-if)# no switchport access vlan nmero
configura la deteccin de DHCP en un switch
S1(config)#ip dhcp snooping
S1(config)#ip dhcp snooping vlan nmero
S1(config)#interface fastethernet 0/1
S1(config-if)#ip dhcp snooping trust
S1(config)#interface range fastethernet 0/1-24
S1(config-if-range)#ip dhcp snooping limit rate velocidad

S1(config)#interface fastethernet 0/1


S1(config-if)#switchport port-security mac-address direccin-mac

S1(config)#interface fastethernet 0/1


S1(config-if)#switchport port-security mac-address sticky direccinmac
S1(config)#interface fastethernet 0/1
S1(config-if)#switchport port-security violation {protect | restrict |
shutdown}
CONFIGURAR LA SEGURIDAD DE LOS PUERTOS DINMICOS
S1(config)#interface fastethernet 0/18
S1(config-if)#swithport mode access
S1(config-if)#swithport mode security
S1(config-if)#swithport mode security maximum 50
S1(config-if)#switchport port-security mac-address sticky

S1#show port-security interface fastethernet 0/18


CONFIGURACION DE NPT
R1(config)#ntp server direccin-IP
R1(config)#ntp master [capa]
R1#show ntp associations
ELIMINACION DE UNA VLAN
S1#conf t
S1#(config)#no vlan nmero
S1#(config)#end
S1#delete flash:vlan.dat

S1#show vlan summary


S1#show interfaces vlan id-vlan
S1#show vlan name monbre_de_vlan
CONFIGURACION DE ENLACES TRONCALES
S1#conf t
S1#(config)#interface fastethernet 0/1
S1#(config-if)#switchport mode trunk
S1#(config-if)#switchport trunk native vlan 99
S1#(config-if)#switchport trunk allowed Vlan 10,20
S1#(config-if)#end
S1#(config-if)#no switchport trunk allowed Vlan 10,20

S1(config-if)# switchport nonegotiate

S PARA CONFIGURACIN
modo usuario
modo privilegiado/se aplican comandos show
modo de configuracin global
acceder del modo usuario al modo priviegiado
acceder al modo de configuracin global
hacer ping en CLI
muetra los saltos que da el paquete en la red
configurar la hora y fecha en el equipo
muestra el historial de comandos introducidos
muestra la configuracin act. corriendo en el equipo
muestra el archivo de inicio delo ios
muestra la informacion de todas las interfacesa del equipo
muestra la informacion de una interface especfica
muestra informacin sobre la version del ios cargada actualmente
muestra la configuracin actual del archivo de arranque del IOS
Para mostrar los datos de la versin y de configuracin de SSH
determinar el estado de las interfaces virtuales y fsicas
Examine las caractersticas de la SVI para VLAN 1.
Muestre las direcciones MAC
proporciona acceso a los archivos almacenados en la memoria flash
Verifica la configuracin de la VLAN de administracin

ingresar al modo de configuracin de interfaz.


Para configurar la direccin IP
Habilita la interfaz
evita que los mensajes de consola interrumpan los comandos
cambiar el nombre del dispositivo

configurar
el
gateway
predeterminado
del
predeterminado es la direccin IP de router

switch

El

realiza copia de seguridad de configuracin.


Configurar la encriptacin de contraseas.
Asigna contrasea secreta para el acceso al modo EXEC privilegiado

Evite las bsquedas de DNS no deseadas


Para eliminar las direcciones MAC existentes
Configure un mensaje MOTD
h para permitir la administracin remota del switch.

ertos de usuario a VLAN 99


modifica RANGO de puertos

so del puerto de consola

Evita que los mensajes de consola interrumpan los comandos.

y) para que el switch permita el acceso por Telnet

e_vlan 99 y asociarla a una interfaz.

gateway

Configure una direccin MAC esttica


eliminar la configuracin de inicio de la NVRAM.
eliminar configuracin antigua de la memoria
eliminar archivo vlan.dat en la memoria flash
Deshabilite el servicio HTTP
y velocidad de puerto.

de conexin cruzada de interfaz dependiente del medio)

SH para la administracin remota.


Configurar el dominio IP
Genere una clave criptogrfica RSA con un mdulo de 1024 bits

mtodo de autenticacin local cree un user y un password


privilege 15: acceso de nivel de administrador
configuracin de tiempo de espera para SSH
intentos de autenticacin permite SSH?
Configurar las lneas vty
Habilite el protocolo SSH en las lneas vty
para requerir la autenticacin local de las conexiones SSH

Habilita la versin 2 de SSH


muestra el rango de vlan's

cambiar la pertenencia de un puerto de switch de la VLAN (nnero), por


interface

in de DHCP en un switch
Habilite la deteccin de DHCP
Habilite la deteccin de DHCP para VLAN especficas
Defina los puertos como confiables en el nivel de la interfaz
Limite la velocidad que un atacante puede enviar solicitudes DHCP
falsas dentro de un rango de direcciones
Direcciones MAC seguras estticas son direcciones MAC que se configuran
manualmente en un puerto
habilitar el aprendizaje por persistencia. El aprendizaje por
persistencia se habilita en una interfaz
Para cambiar el modo de violacin en un puerto de switch

AD DE LOS PUERTOS DINMICOS


Especifica la interface que se debe conf la seguridad

establece la interfaz en modo de acceso


establece la seguridad de puerto en la interfaz
establece la cant. Max. De direcciones seguras en puerto

habilita el aprendizaje por persistencia

Verificar los parmetros de seguridad de puerto


RACION DE NPT
Permitir que un servidor horario NTP sincronice el reloj del software
Para configurar un dispositivo con un reloj maestro NTP con el que los
peers se puedan sincronizar

mostrar el estado de las asociaciones NTP


ION DE UNA VLAN
Eliminar una vlan
Eliminar el archivo vlan.dat completo

muestra el conteo de todas las VLAN configuradas


muestra detalles de la vlan

DE ENLACES TRONCALES
ingreso al modo de conf. De interfaz
hace que sea un elace troncal
se especifica una vlan nativa para troncales 810.1Q
especificar la lista de VLAN que se permiten en el enlace troncal
enlace troncal vuelve a configurarce en un estado predeterminado

Desactivar la negociacin entre los puertos.