Sei sulla pagina 1di 57

Previsione della domanda

Previsione della domanda 1

1

1. Introduzione … pag. 3

1.1 Alcune problematiche … pag. 12

Indice

2. I modelli di previsione … pag. 14

2.1 Analisi delle serie storiche … pag. 19

2.1.1 Media mobile semplice … pag. 20

2.1.2 Media mobile ponderata … pag. 22

2.1.3 Smorzamento esponenziale … pag. 23

3. Errori di previsione … pag. 26

4. Cenni sull’analisi di regressione lineare … pag. 30

5. Scomposizione di una serie storica … pag. 34

5.1 Effetti di trend (il modello di Holt) … pag. 35

5.2 Effetti di trend e di stagionalità (il modello di Winter)pag.37

6. Studio del caso Tahoe Salt … pag. 43

7. Previsione mediante simulazione … pag. 51

2

8. Modello collaborativo di pianificazione, previsione,reintegro

1. Introduzione Finanza e controllo di gestione

Produzione

1. Introduzione Finanza e controllo di gestione Produzione Commerciale M a r k e t i

Commerciale

Marketing

Previsione

3

Nel mondo della produzione industriale molto rari sono i casi di aziende che hanno l’intero orizzonte del Piano di produzione basato sulle commesse acquisite dei clienti. I prodotti di consumo (cibi, elettrodomestici, parti di ricambio, farmaci…) sono esempi di prodotti con prevalenti previsioni di vendite.

Molte aziende forniscono una scadente assistenza alle vendite e allo stesso tempo hanno elevate giacenze in magazzino proprio a causa dell’incapacità di realizzare delle previsioni.

Quattro caratteristiche fondamentali delle previsioni:

1) Le previsioni sono sempre sbagliate. Tuttavia sono tutto quello che abbiamo a disposizione e rappresentano pur sempre una base da cui partire.

2) Le previsioni dovrebbero essere espresse da almeno due numeri. Se le previsioni sono sempre sbagliate il problema è allora: quanto sono sbagliate? Spesso l’errore di previsione è più prevedibile della previsione stessa

3) Le previsioni sono più precise per famiglie. Ciò suggerisce che i programmi principali di produzione dovrebbero essere costruiti, ove possibile, per famiglie di prodotti, ritardando il più possibile la conversione negli articoli specifici del prodotto.

4) Le previsioni sono tanto più sbagliate quanto più sono a lungo termine. Questo spinge a dichiarare guerra ai lead time e ai tempi di risposta, sia di produzione che di approvvigionamento.

Di fronte a ordini che si discostano dalle previsioni ci si può comportare in tre modi diversi:

1) modificare il più rapidamente possibile il MPS per fare fronte all’urgenza: ciò comporta costi maggiori, scontento dei fornitori, elevate giacenze e clima da “spegnimento di incendio” in fabbrica.

2) non modificare il piano e offrire al cliente le consegne programmate sulla base delle previsioni: gli inconvenienti sono scontento dei clienti, mancate vendite, elevate giacenze di prodotti finiti.

3) aggiungere dei margini di variabilità selettivi sulle voci specifiche di un prodotto finito e previsti dallo stesso MPS (over-planning), in modo da consentire che le vendite effettive siano diverse da quelle pianificate, senza grossi turbamenti ai programmi di produzione e di approvvigionamento

Over-planning significa aumentare la quantità da produrre nel MPS. Questi aumenti di quantità, esplosi attraverso la distinta di base, incrementano la domanda di scorte e la capacità necessaria

Ordinariamente le distinte di base non permettono previsioni sulle singole voci ed è pertanto necessario una ri-definizione delle stesse introducendo la distinta di pianificazione (planning bill o super bill).

Consideriamo un prodotto caratterizzato da tre feature; alla prima corrispondono due opzioni alla seconda quattro ed alla terza tre. L’uso delle super bill semplifica le definizione di MPS perché programmare il numero di opzioni risulta più semplice che programmare le possibili combinazioni.

veicolo Uno di 2 trasmissioni Uno di 4 interni Uno di 3 motori
veicolo
Uno di 2
trasmissioni
Uno di 4
interni
Uno di 3
motori

- Numero di modelli possibili = 2·4·3 = 24 - Numero di moduli prodotti = 2+4+3 = 9

Nelle super bill si riportano le percentuali di clienti che scelgono ciascuna opzione; ad esempio, per quanto riguarda la caratteristica 1 l’opzione A costituisce mediamente il 60% degli ordini e l’opzione B il 40%. Le parti comuni hanno ovviamente percentuale d’uso del 100%. Fluttuazioni nel mix di ordini sono coperte dalla scorta di sicurezza SS.

10

Super bill parti comuni % uso = 1,0 SS = 0 Opzione 1A Opzione 2A
Super bill
parti comuni
% uso = 1,0
SS = 0
Opzione 1A
Opzione 2A
Opzione 3A
%
uso = 0,6
SS = 100
%
uso = 0,1
SS = 100
%
uso = 0,5
SS = 200
Opzione 1B
Opzione 2B
Opzione 3B
%
uso = 0,4
SS = 150
%
uso = 0,4
SS = 300
%
uso = 0,4
SS = 100
Opzione 2C
Opzione 3C
%
uso = 0,2
SS = 400
%
uso = 0,1
SS = 250
Opzione 2D
%
uso = 0,3
SS = 50

Se la previsione di vendita del prodotto generico è 1000 unità, l’MPS, che in ambiente assemble to order è dato a livello di moduli da assemblare, prevederà un fabbisogno lordo di 600 moduli corrispondenti all’opzione 1A, di 400 corrispondenti all’opzione 1B e così via.

1.1 Alcune problematiche

1.1 Alcune problematiche 12 Diversificazione ritardata : tenere gli articoli in stato di basso costo

12

Diversificazione ritardata: tenere gli articoli in stato di basso costo

13
13

2.

2. 14

14

Principali modelli di previsione

1.

Qualitativa

2.

Analisi delle serie storiche

3.

Causale

4.

Modelli di simulazione

1- Qualitativa

BOTTOM UP

RICERCA DI

MERCATO

PANEL CONSENSUS

ANALOGIA STORICA

METODO DELPHI

Soggettiva, discrezionale, basata su stime ed opinioni

Elabora la previsione inserendo input provenienti dal fondo della gerarchia distributiva, concernenti l´oggetto della previsione. Una previsione delle vendite complessive, per esempio, puó scaturire dalla combinazione di input da ogni venditore, il soggetto piú vicino al cliente finale.

Procede alla raccolta die dati mediante diversi sistemi (indagini, interviste ecc.) per testare ipotesi di mercato. Tipicamente applicata al prodotto, per prevedere le vendite nel lungo periodo e le vendite dei nuovi prodotti.

Riunioni allargate, con libera circolazione di idee. L´idea é che tali discussioni di gruppo generano previsioni migliori delle elaborazioni del singolo. I partecipanti possono essere dirigenti, venditori o clienti.

Pone in relazione la voce oggetto di previsione con articoli simili. Utile a pianificare nuovi prodotti quando sia possibile derivare una previsione dai dati storici di un prodotto analogo.

Gruppi di esperti rispondono ad un questionario. Un moderatore elabora i risultati e formula un nuovo questionario, poi sottoposto al gruppo. Pertanto, ricevendo nuove informazioni, il gruppo

fruisce di un processo di apprendimento e non risente di influenze dovute a pressioni di gruppo o

a soggetti in posizione dominante.

15

2- Analisi delle serie storiche

Basata sul concetto che la successione degli eventi nel tempo possa essere usata per prevedere il futuro

MEDIA MOBILE SEMPLICE

Si

calcola la media aritmetica di una serie di valori puntuali di un periodo di tempo.

Ciascuno di essi, quindi, ha uguale peso.

MEDIA MOBILE PONDERATA

A

determinati valori possono essere attribuiti pesi superiori rispetto agli altri, secondo

valori suggeriti dall´esperienza.

SMORZAMENTO

I valori recenti vengono ponderati secondo pesi esponenziali decrescenti, proporzionalmente all´invecchiamento dei dati.

ESPONENZIALE

ANALISI DI REGRESSIONE

Traccia una linea retta tra i dati passati, generalmente correlando il valore dei dati al tempo. La tecnica piú comune per definire la retta è quella dei minimi quadrati.

PROCEDURA BOX- JENKINS

Correla ai dati una classe di modelli statistici e adegua il modello alla serie temporale utilizzando le distribuzioni di Bayes.

SERIE TEMPORALE DI SHISKIN

Ideata da Julius Shiskin del Census Bureau. Metodo efficace per scomporre una serie temporale in elementi stagionali, di trend e irregolari.

PROIEZIONI DI TREND

Adegua una linea di tendenza ai valori e la proietta nel futuro.

3- Casuale

Cerca di comprendere il sistema di relazioni casuali che circonda la voce oggetto di previsione. Le vendite, ad esempio, possono essere influenzate da pubblicitá, qualitá e concorrenti.

ANALISI DI REGRESSIONE

Simile al metodo dei minimi quadrati, ma puó contenere variabili multiple. Fondata sull´idea che la previsione è causata dal verificarsi di altri eventi.

MODELLI

Tentano di descrivere alcuni settori dell´economia attraverso una serie di equazioni interdipendenti.

ECONOMETRICI

MODELLI DI INPUT/OUTPUT

Indicano le probabili future variazioni di vendita entro un settore industriale, legate a variazioni nei modelli d´acquisto in un altro settore.

4- Modelli di Simulazione

Modelli dinamici, normalmente originati al computer, che consentono al pianificatore di fare delle ipotesi sulle variabili interne e sull´ambiente esterno al modello. A seconda delle variabili nel modello, il pianificatore puó porsi delle domande come „Che cosa accadrebbe alla mia previsione se il prezzo aumentasse del 10%?“, „Che impatto avrebbe sulla mia previsione una lieve flessione dell´economia nazionale?“

Componenti della domanda

trend sistematiche cicliche oscillatorie componenti stagionali casuali
trend
sistematiche
cicliche
oscillatorie
componenti
stagionali
casuali
Livello medio
Livello
medio

19

Va inoltre tenuta in considerazione la componente autocorrelazione

Trend più comuni

Trend più comuni 20

2.1 Analisi delle serie storiche

METODO DI PREVISIONE

Quantitá di dati storici

Andamento dei dati

Orizzonte di

Tempo di

Competenza

previsione

preparazione

richiesta al

   

personale

Smorzamento

Da 5 a 10 osservazioni per assegnare il peso

I dati dovrebbero essere stazionari

Breve

Breve

Minima

esponenziale

semplice

   

Smorzamento

Da 10 a 15 osservazioni per assegnare entrambi i pesi

Presenza di trend, assenza di stagionalitá

Da breve a medio

Breve

Sufficiente

esponenziale di

Holt

   

Smorzamento

Almeno 4 o 5 osservazioni per stagione

Presenza di trend e stagionalitá

Da breve a medio

Breve

Discreta

esponenziale di

Winter

   

Modelli di regressione con trend

Da 10 a 20; per la stagionalitá almeno 5 per stagione

Presenza di trend e stagionalitá

Da breve a medio

Breve

Discreta

Modelli di regressione casuale

10

osservazioni per le

Andamenti complessi gestibili

Breve medio o lungo

Tempo di elaborazione lungo, tempo di implementazione breve

Buona

variabili indipendenti

Box-Jenkins

50

o piu´osservazioni

Il set di dati deve essere stazionario o deve esser convertito in stazionario

Breve medio o lungo

Lungo

Elevata

2.1.1 Media mobile semplice

F

t

=

A

t

1

A

+ +

t

2

+

A

t

n

n

F t = previsione per il periodo entrante

n = numero di periodi su cui si calcola la media

A t-n = domanda effettiva n periodi indietro nel tempo

* Più lungo è il periodo della media mobile e più gli elementi casuali vengono livellati

media mobile e più gli elementi casuali vengono livellati * Se i dati presentano un trend

* Se i dati presentano un trend un periodo di media più corto consentirà una maggiore aderenza al trend

23
23

23

2.1.2 Media mobile ponderata

F

t

=

w A

1

t

1

+

w A

2

t

2

+ +

w A

n

t

n

n

= numero di periodo su cui si calcola la media

w n = peso da attribuire al periodo t-n

calcola la media w n = peso da attribuire al periodo t-n n ∑ i =

n

i = 1

w

i

= 1

Mese 1

Mese 2

Mese 3

Mese 4

100

90

105

95

Dando maggior peso ai dati più recenti:

w 1 = 0.4, w 2 = 0.3, w 3 = 0.2, w 4 = 0.1 F 5 = 0.4x95+0.3x105+0.2x90+0.1x100 = 97.5

2.1.3 Smorzamento esponenziale

Utile nei casi in cui i dati più recenti sono più significativi dei dati più lontani nel tempo

F t

=

F

t

1

+

(

α A

t

1

F

t

1

)

Si richiedono solo 3 dati F t-1 A t-1 e α = coefficiente di reazione desiderato

F

t

= αA F t t − F t
= αA
F t
t
F
t

1

+

(1

α F

)

t

1

=

αA

t 1

+

(1

F t ααA ) [ t − 2
F t
ααA
)
[
t
2

1

+

+

=

(1

αA

t

2

+ (1

α F

)

t 2

]

=α

[

A

t

1

(1

+ −α

) A

t

2

(1

+ −α

)

=α

t

k

= 1

(1

α

2

)

A

t

k 1

k − 1

(1

+ + −α

k

(1

+ −α

t

)

) F

k

1

3

A

t

0

)

α F

t

A

t

k

2

]

(1

+ −α

α k (1 + − α t ) ) F k − 1 − 3 A

25

t

) F

0

26

La previsione della domanda in periodi successivi al primo

Si considera A(t + τ) uguale ad F(t), con τ = 1, 2, … ampiezza dell’orizzonte di previsione

periodo

quantità

 

1 975

 

2 1025

 

3 895

 

4 1055

 

5 925

 

6 985

 

7 775

 

8 805

 

9 880

10 870

 

11 915

 

12 855

 

con n = 2 e τ = 3 F 13 = (855 + 915)/2 = 885 = F 14 = F 15

Al tempo 13 se A 13 = 890

F 14 = (890 + 855)/2 = 872.5 = F 15 = F 16

* L’orizzonte temporale di previsione è di tipo

mobile (rolling horizon)

3. Errori di previsione

Domanda osservata (O) = Componente Sistematica (S) + Componente Casuale (R)

Componente sistematica:

1)

Level = domanda destagionalizzata

2)

Trend = tasso di crescita o di perdita della domanda nel periodo

3)

successivo Stagionalità = fluttuazioni stagionali della domanda

Componente casuale: parte della previsione che non è compresa nella componente sistematica. Un’impresa non può prevedere la componente casuale.

Un’impresa non può prevedere la componente casuale. 1) Errore casuale : errori non spiegabili con il

1)

Errore casuale: errori non spiegabili con il modello previsionale impiegato

2)

Errore sistematico: dovuto ad utilizzo di relazioni improprie tra le variabili, uso sbagliato di trend, errato posizionamento della domanda stagionale, esistenza di tendenze pluriennali non rilevate. Può essere rilevato utilizzando i tracking signal.

Misurazione dell’errore

Errore di previsione nel periodo t =

MSE (Mean Squared Error) =

1

n

E

t

n

t = 1

(

= A F

t

t

A F

t

t

)

2

* In pratica si può considerare che la componente casuale abbia

una distribuzione normale con valor medio pari a 0 e varianza pai a MSE

MAD (Mean Absolute Deviation) =

1

n

t = 1

A F

t

t

n

Ipotizzando al solito che la componente casuale sia distribuita secondo una curva normale, allora :

Deviazione standard σ = MADπ/2 1.25 MAD

MAPE (Mean Absolute Percentage Error) =

1

n

E

t

t

n

t = 1

A

100

Per valutare se le previsioni consecutivamente stanno sovra o sotto stimando la domanda effettive si valuta il BIAS:

BIAS

=

n

t

= 1

E

t

O ancora meglio il Tracking Signal (TS):

TS

=

BIAS

t

t MAD

t

BIAS BIAS BIAS
BIAS
BIAS
BIAS

In linea generale se il TS ad ogni periodo è fuori dal range ± 6, questo è un segnale che il nostro modello di previsione tendenzialmente sottostima (TS > 6) o sovrastima (TS < -6) la

31

domanda sarà necessario utilizzare dei modelli che tengano in considerazione i trend.

4. Cenni sull’analisi di regressione lineare

Retta che interpola una serie di dati (retta dei minimi quadrati):

Y = a + bX

Y

= variabile dipendente

X

= variabile indipendente (tempo)

∑ ∑ ∑ ∑

y

i

x

2

i

x

i

(

)

x

i

y

i

Intercetta sull’asse Y a

=

x

2

i

∑ ∑

(

)

2

n

x

i

n

(

x

i

y

i

)

x

i

y

i

 

n

 

2

(

 

)

2

x

i

x

i

Pendenza della retta

b =

* Usata nei modelli di previsione attraverso serie temporali e mediante relazioni casuali

Si conoscono i dati della produzione di frumento (in milioni di quintali) negli anni dal 1996 al 2004

Anni

xi

yi

xi^2

xi yi

1996

0

85,65

0

0

1997

1

91,8

1

91,8

1998

2

94,6

4

189,2

1999

3

88,55

9

265,65

2000

4

86,4

16

345,6

2001

5

98,2

25

491

2002

6

90,5

36

543

2003

7

99,35

49

695,45

2004

8

90,7

64

725,6

 

36

825,75

204

3347,3

n = 9

x i = 36

(

x i )

2

= 36

2

= 1296

825.75 204

 

9 204

1296

36 3347.3 =

a =

88.798

b =

9 3347.3

36 825.75 =

1296

9 204

0.738

110

100

90

80

70

60

50

y = 0,7383x + 88,797 R 2 = 0,1756 0 2 4 6 810
y = 0,7383x + 88,797
R 2 = 0,1756
0
2
4
6
810

Per l’anno 2005 si può prevedere una produzione di frumento di:

0.7383·9 + 88.798 = 95.44

Si

parla di correlazione tra X ed Y quando si vuole misurare il grado

di

intensità della relazione lineare che intercorre tra i due fenomeni

Coefficiente di correlazione

tra i due fenomeni Coefficiente di correlazione → r = r = ∑ ∑∑ xy −

r =

r =

∑ ∑∑

xy

x

n

y

[ 2 2 ][ 2 2 ] n ∑ x − ( ∑ x) n
[
2
2
][
2
2
]
n
x
(
x)
n
y
(
y)
9 3347.3 ⋅ (9 204 − 1296)(9 75948.8 36 ⋅ 825.75 ⋅ − ⋅ −
9 3347.3
(9 204
1296)(9 75948.8
36 ⋅ 825.75
681863)

r

2 = 0.1756

= 0.419

y) 9 3347.3 ⋅ (9 204 − 1296)(9 75948.8 36 ⋅ 825.75 ⋅ − ⋅ −
y) 9 3347.3 ⋅ (9 204 − 1296)(9 75948.8 36 ⋅ 825.75 ⋅ − ⋅ −

34

Anni

xi

yi

xi^2

yi^2

xi yi

yi lin

(yi-yi lin)^2

yi pol

(yi-yi pol)^2

yi esp

(yi-yi esp)^2

1996

0

85,65

0

7335,9

0

88,80

9,9

87,7

4,2

88,7

9,6

1997

1

91,8

1

8427,2

91,8

89,54

5,1

89,3

6,4

89,5

5,5

1998

2

94,6

4

8949,2

189,2

90,27

18,7

90,6

16,1

90,2

19,6

1999

3

88,55

9

7841,1

265,65

91,01

6,1

91,7

9,7

90,9

5,5

2000

4

86,4

16

7465,0

345,6

91,75

28,6

92,5

37,5

91,6

27,4

2001

5

98,2

25

9643,2

491

92,49

32,6

93,1

25,5

92,4

34,0

2002

6

90,5

36

8190,3

543

93,23

7,4

93,5

9,2

93,1

6,8

2003

7

99,35

49

9870,4

695,45

93,97

29,0

93,7

32,0

93,9

30,2

2004

8

90,7

64

8226,5

725,6

94,70

16,0

93,6

8,5

94,6

15,3

36

825,75

204

75948,8

3347,3

153,5

149,3

153,8

2 ∑ ( y − y ) i i σ = dev stand dev stand
2
(
y
y
)
i
i
σ
=
dev stand
dev stand
dev stand
n
4,13006368
4,07338785
4,134133674
105
100
95
105
90
y = 0,7383x + 88,797
100
85
R 2 = 0,1756
95
80
105
0
2
90
100
y = -0,1166x 2 + 1,6708x + 87,709
85
95
R 2 = 0,1981
80
90
0
2
4
6
810
y
= 88,746e 0,008x
85
R 2 = 0,177
35
80
0
2
4
6
810

5. Scomposizione di una serie storica

L’obbiettivo di qualsiasi modello di previsione è quello di prevedere la componente sistematica della domanda. Le situazioni più diffuse sono:

Moltiplicativa: componente sistematica = level x trend x stagionalità Additiva: componente sistematica = level + trend + stagionalità Mixed: componente sistematica = (level + trend) x stagionalità

sistematica = level + trend + stagionalità Mixed : componente sistematica = ( level + trend)

5.1 Effetti di trend (il modello di Holt)

componente sistematica = level + trend

FIT

t

=

F

t

1

+

T

t

1

F

t

(

= FIT +α A FIT

t

t

t

)

T

t

= T +

t

1

δ

(

F FIT

t

t

)

FIT t = previsione con trend al periodo t T t = trend smorzato esponenzialmente δ = costante di smorzamento del trend (così come α anche δ ha un valore compreso tra 0 ed 1

Nei periodi successivi al primo si assume:

FIT t+n = F t-1 + (n+1) T t-1

37

Si assuma di avere inizialmente F t-2 = 100 ed ipotizziamo T t-2 = 10. Si assume inoltre α = 0.2 e δ = 0.3. Supponendo che la domanda reale al tempo t-1 è stata di 115 e non di 100, si vuole calcolare la previsione per il periodo t. FIT t-1 = F t-1 +T t-1 = 100 + 10 = 110; con A t-1 = 115 F t-1 = FIT t-1 + α (A t-1 – FIT t-1 ) = 110 + 0.2(115 – 110) = 111 T t-1 = T t-2 + δ (F t-1 – FIT t-1 ) = 10 + 0.3(111 – 110) = 10.3 FIT t = F t-1 + T t-1 = 111 + 10.3 = 121.3 FIT t+3 = F t-1 + (n+1) T t-1 = 111 + 4 · 10.3 = 152.2 Se la domanda reale al periodo t si rivelasse pari a 120 la previsione per il periodo t+1 sarebbe:

F t = 121.3 + 0.2(120 - 121.3) = 121.04 T t = 10.3 + 0.3(121.04 – 121.3) = 10.22 FIT t+1 = 121.04 + 10.22 = 131.26

38

5.2 Effetti di trend e di stagionalità (il modello di Winter)

componente sistematica = (level + trend) x stagionalità

Passi del processo di scomposizione di una serie storica:

1) Scomporre la serie temporale nei suoi componenti

• Individuare i componenti di stagionalità

• Destagionalizzare la domanda

• Individuare i componenti di level e di trend

2) Prevedere i valori futuri di ogni componente

• Proiettare il componente di trend nel futuro

• Moltiplicare il componente (level + trend) per il componente stagionale

Domanda di sale alla Tahoe Salt

anno

trimestre

periodo t

domanda A(t)

2000

2

1

8000

2000

3

2

13000

2000

4

3

23000

2001

1

4

34000

2001

2

5

10000

2001

3

6

18000

2001

4

7

23000

2002

1

8

38000

2002

2

9

12000

2002

3

10

13000

2002

4

11

32000

2003

1

12

41000

45000 40000 35000 30000 25000 20000 15000 10000 5000 0 1 2 3 4 5
45000
40000
35000
30000
25000
20000
15000
10000
5000
0
1
2
3
4
5
6
7
8
9
10
11
12

Periodicità = numero di periodi dopo i quali il ciclo stagionale si ripete per il caso in esame la periodicità (p) è uguale a 4

Domanda destagionalizzata:

A =

t

i

t +

p / 2

A /

i

=−

t

p

/ 2

p per p dispari

A

t

=

A

t

(

p

/ 2)

+ A

t

+

(

p

/2)

t

−+

1

(

p

+

/ 2)

2

A

i

i

=+−

t

1

(

p

/ 2)

p

/ 2

per p pari

40

Nel caso Tahoe 4 ⎤ A = ⎡ A A + + ∑ 2 A
Nel caso Tahoe
4
A
=
⎡ A
A
+ + ∑ 2 A
/ 8
= 19750
3
5
1
i
i= 2
AB
C
1
periodo t
domanda A(t) domanda destagionalizzata
2
1
8000
3
2
13000
=(B2+B6+2*SOMMA(B3:B5))/8
4
3
23000
19750
5
4
34000
20625
6
5
10000
21250
7
6
18000
21750
8
7
23000
22500
9
8
38000
22125
10
9
12000
22625
11
10
13000
24125
12
11
32000
domanda
45000
13
12
41000
domanda
40000
destagionalizzata
35000
30000
25000
20000
15000
10000
5000
0
41
1
2
3
4
5
6
7
8
9
10
11
12

Una volta determinati i dati della domanda destagionalizzata si assume che sussista una relazione lineare tra i dati destagionalizzati ed il tempo:

A F

t =

0

+

T

t

F 0 = level, o domanda destagionalizzata al tempo 0 T = trend, tasso di crescita della domanda destagionalizzata

Nel caso Tahoe impostando una regressione lineare dei dati destagionalizzati si ha: domanda 29000 domanda
Nel caso Tahoe impostando una regressione lineare dei dati
destagionalizzati si ha:
domanda
29000
domanda
A
= 18439 + 524
t
destagionalizzata
27000
t
y = 523,81x + 18439
25000
23000
21000
19000
17000
15000
42
1
2
3
4
5
6
7
8
9
10
11
12
A t Fattore di stagionalità: S = t =18439+524*A2 A t AB C D 1
A
t
Fattore di stagionalità:
S
=
t
=18439+524*A2
A
t
AB
C
D
1
periodo t
domanda A(t) domanda destagionalizzata
fattore di stagionalità
2
1
8000
18963
0,42
=B2/C2
3
2
13000
19487
0,67
4
3
23000
20011
1,15
5
4
34000
20535
1,66
6
5
10000
21059
0,47
7
6
18000
21583
0,83
8
7
23000
22107
1,04
9
8
38000
22631
1,68
10
9
12000
23155
0,52
11
10
13000
23679
0,55
12
11
32000
24203
1,32
13
12
41000
24727
1,66

Se si hanno a disposizione r cicli stagionali il fattore di stagionalità può essere calcolato

come la media sui r cicli:

r

1

j

= 0

S

S

i

/

=

r

jp

+

i

Nel caso Tahoe con p = 4 e r = 3

S

S

1

2

=

=

(

S

1

+ S

5

+ S

9

) / 3

=

(0.42

+

0.47

+

0.52) / 3

=

0.47

(

S

2

+ S

6

+ S

10

) / 3

=

(0.67

+

0.83

+

0.55) / 3

=

0.68

S 3 =1.17, S 4 =1.67

43

La previsione è data da

FIT

t

+

1

F

t

+

1

=

=

α

(

(

F

t

A

t

+

1

+

/

T

t

)

S

t

+

1

S

)

t

+

+

1

(1

+

α

)(

F T

t

t

T

t

S

t

+

1

=δ

+ + 1

p

=

(F

t

+

1

(

γ A

t

F )

t

+

1

/

F

t

+ −δ

(1

)T

t

+

1

)

+

(1

)

γ S

t +

1

)

FIT t+1 = previsione con level, trend e stagionalità al periodo t+1 T t = trend smorzato esponenzialmente S = fattore di stagionalità γ = costante di smorzamento del fattore di stagionalità (così come α e δ anche γ ha un valore compreso tra 0 ed 1

Si ha inoltre:

FIT = ( F + lT ) S t + l t t t +
FIT
= (
F
+
lT
)
S
t
+
l
t
t
t
+
l

6. Studio del caso Tahoe Salt

6. Studio del caso Tahoe Salt 45
6. Studio del caso Tahoe Salt 45

Media mobile semplice con n = 4

=SOMMA($E$6:E6)/H6

=MEDIA($I$6:I6) =SOMMA($F$6:F6)/(A6-4) =SOMMA.Q($E$6:E6)/(A6-4) =D6-B6 =ASS(E6) =100*(F6/B6) D E F G HI forecast
=MEDIA($I$6:I6)
=SOMMA($F$6:F6)/(A6-4)
=SOMMA.Q($E$6:E6)/(A6-4)
=D6-B6
=ASS(E6)
=100*(F6/B6)
D
E
F G
HI
forecast FIT
error E
errore assoluto
MSE
MAD
%error
MAPE

19500

20000

21250

21250

22250

22750

21500

23750

9500

2000

-1750

-16750

10250

9750

-10500

-17250

9500

2000

1750

16750

10250

9750

10500

17250

90250000

47125000

32437500

94468750

96587500

96333333,33

98321428,57

123226562,5

9500

5750

4416,667

7500

8050

8333,333

8642,857

9718,75

95

11,11111

7,608696

44,07895

85,41667

75

32,8125

42,07317

95,0

53,1

37,9

39,4

48,6

53,0

50,1

49,1

=MEDIA(B2:B5) A B 1 periodo t domanda A 2 1 8000 3 2 13000 4
=MEDIA(B2:B5)
A B
1
periodo t
domanda A
2
1
8000
3
2
13000
4
3
23000

5

6

7

8

9

10

11

12

13

4 34000

5 10000

6 18000

7 23000

8 38000

9 12000

10 13000

11 32000

12 41000

=C5 C level F 19500
=C5
C
level F
19500

20000

21250

21250

22250

22750

21500

23750

24500

JK

TS

1,0

2,0

2,2

-0,9

0,4

1,6

0,3

-1,5

46

FIT 13 = FIT 14 = FIT 15 = FIT 16 = F 12 = 24500

Poiché MAD = 9719 la deviazione standard dell’errore di previsione è pari a 1.25 x 9719 = 12148 (valore abbastanza elevato in relazione alla previsione) TS rimane nel range ± 6 la previsione con n = 4 non produce significativi valori di BIAS

alla previsione) TS rimane nel range ± 6 → la previsione con n = 4 non

47

Smorzamento esponenziale

F

0

=

1

12

12

A

i

i= 1

= 22083

con α = 0.1

1

2

3

4

5

6

7

8

9

10

11

12

13

14

=0,1*B3+(1-0,1)*C2 =C2 =D3-B3 AB C D t A F FIT 0 22083 1 8000 20675
=0,1*B3+(1-0,1)*C2
=C2
=D3-B3
AB
C
D
t
A
F
FIT
0
22083
1
8000
20675
22083

2 13000

3 23000

4 34000

5 10000

6 18000

7 23000

38000

8

9

10 13000

11 32000

12 41000

12000

19907

20217

21595

20435

20192

20473

22225

21203

20383

21544

23490

20675

19907

20217

21595

20435

20192

20473

22225

21203

20383

21544

=SOMMA($E$3:E3)/H3

=MEDIA($I$3:I3) =SOMMA($F$3:F3)/A3 =100*(F3/B3) H I J MAD %error MAPE
=MEDIA($I$3:I3)
=SOMMA($F$3:F3)/A3
=100*(F3/B3)
H I
J
MAD
%error
MAPE

198330889

128615955

88932378

114195454

118244501

99525590

86434191

114030916

112978425

108409252

110823399

133131785

14083

10879

8283

9658

10046

8777

7925

9125

9247

9143

9368

10208

176

59

13

41

116

14

12

46

85

63

36

47

176

118

83

72

81

70

62

60

62

63

60

59

=SOMMA.Q($E$3:E3)/A3 =ASS(E3) E F G error E errore ass MSE
=SOMMA.Q($E$3:E3)/A3
=ASS(E3)
E
F
G
error E
errore ass
MSE

14083

7675

-3093

-13783

11595

2435

-2808

-17527

10225

8203

-11617

-19456

14083

7675

3093

13783

11595

2435

2808

17527

10225

8203

11617

19456

K

TS

1,0

2,0

2,3

0,5

1,6

2,2

2,0

-0,2

1,0

1,9

0,6

-1,4

FIT 13 = FIT 14 = FIT 15 = FIT 16 = F 12 = 23490

Il modello di Holt con α = 0.1 e δ = 0.2

periodo t

domanda A

1

8000

2

13000

3

23000

4

34000

5

10000

6

18000

7

23000

8

38000

9

12000

10

13000

11

32000

12

41000

45000 40000 35000 30000 25000 20000 y = 1549x + 12015 15000 10000 5000 0
45000
40000
35000
30000
25000
20000
y = 1549x + 12015
15000
10000
5000
0
1
2
3
4
5
6
7
8
9
10
11
12
20000 y = 1549x + 12015 15000 10000 5000 0 1 2 3 4 5 6

F 0 = 12015, T 0 = 1549

49

=SOMMA($G$3:G3)/I3

=MEDIA($J$3:J3) =0,2*(C3-C2)+(1-0,2)*D2 =SOMMA($F$3:F3)/A3 =C2+D2 =SOMMA.Q($F$3:F3)/A3 =100*(G3/B3) =E3-B3 =ASS(F3)
=MEDIA($J$3:J3)
=0,2*(C3-C2)+(1-0,2)*D2
=SOMMA($F$3:F3)/A3
=C2+D2
=SOMMA.Q($F$3:F3)/A3
=100*(G3/B3)
=E3-B3
=ASS(F3)
AB
C
D
E
F
G
H
I
J
K
t
A
F
T
FIT
error E
errore ass
MSE
MAD
%error
MAPE
0
12015
1549

13008

14301

16439

19594

20322

21570

23123

8 26018

1

2 13000

3 23000

4 34000

5 10000

6 18000

7 23000

8000

1438

1409

1555

1875

1645

1566

1563

1830

1513

1217

1307

1541

13564

14445

15710

17993

21469

21967

23137

24686

27847

27775

27515

29270

5564

1445

-7290

-16007

11469

3967

137

-13314

15847

14775

-4485

-11730

5564

1445

7290

16007

11469

3967

137

13314

15847

14775

4485

11730

30958096

16523523

28732318

85603146

94788701

81613705

69957267

83369836

102010079

113639348

105137395

107841864

5564

3505

4767

7577

8355

7624

6554

7399

8338

8981

8573

8836

70

11

32

47

115

22

1

35

132

114

14

29

70

40

37

40

55

49

42

41

52

58

54

52

=0,1*B3+(1-0,1)*(C2+D2)

1

2

3

4

5

6

7

8

9

10 38000

11 12000

12 10 13000

13 11 32000

14 12 41000

9 26262

26298

27963

30443

L

TS

1,0

2,0

-0,1

-2,1

-0,6

-0,1

-0,1

-1,9

0,2

1,8

1,4

0,0

FIT 13 = F 12 + T 12 = 30443+1541 = 31984; FIT 14 = F 12 + 2T 12 = 33525; FIT 15 = F 12 + 3T 12 = 35066; FIT 16 = F 12 + 4T 12 = 36607

MAD = 8836 → σ = 1.25 x 8836 = 11045 TS rimane tra ± 6 con α = 0.1 e δ = 0.2 non si produce significativi valori di BIAS

50

Il modello di Winter

Il modello di Winter con α = 0.05, δ = 0.1 e γ = 0.1 F

con α = 0.05, δ = 0.1 e γ = 0.1 F 0 = 18439, T 0 = 524, S 1 = 0.47, S 2 = 0.68, S 3 = 1.17, S 4 = 1.67

=0,05*(B3/E3)+(1-0,05)*(C2+D2)

=SOMMA($G$3:G3)/J3

=0,1*(C3-C2)+(1-0,1)*D2 =MEDIA($K$3:K3) =0,1*(B3/C3)+(1-0,1)*E3 =SOMMA($H$3:H3)/A3 =(C2+D2)*E3 =SOMMA.Q($G$3:G3)/A3
=0,1*(C3-C2)+(1-0,1)*D2
=MEDIA($K$3:K3)
=0,1*(B3/C3)+(1-0,1)*E3
=SOMMA($H$3:H3)/A3
=(C2+D2)*E3
=SOMMA.Q($G$3:G3)/A3
=100*(H3/B3)
=F3-B3
=ASS(G3)
AB
C
D
E
F
G
H
I
J
K
L
1 A
t
F
T
S
FIT
error E
errore ass
MSE
MAD
%error
MAPE
2 0
18439
524
3
1
8000
18866
514
0,47
8913
913
913
832857
913
11
11,41
4
2 13000
19367
513
0,68
13179
179
179
432367
546
1
6,39
5
3 23000
19869
512
1,17
23260
260
260
310720
450
1
4,64
6
4 34000
20380
512
1,67
34036
36
36
233364
347
0
3,50
7 5
10000
20921
515
0,47
9723
-277
277
202036
333
3
3,36

8

6

18000

21689

540

0,68

14558

-3442

3442

2143255

851

19

9

7

23000

22102

527

1,17

25981

2981

2981

3106508

1155

13

10

8 38000

22636

528

1,67

37787

-213

213

2723856

1037

1

11

9 12000

23291

541

0,47

10810

-1190

1190

2578653

1054

10

12

10 13000

23577

515

0,69

16544

3544

3544

3576894

1303

27

13

11 32000

24271

533

1,16

27849

-4151

4151

4818258

1562

13

14

12 41000

24791

532

1,67

41442

442

442

4432987

1469

1

15

13

0,47

16

14

0,68

17

15

1,17

5,98

6,98

6,18

6,59

8,66

9,05

8,39

51

M

TS

1,00

2,00

3,00

4,00

3,34

-2,74

0,56

0,42