Sei sulla pagina 1di 21

EIGRP Troubleshooting Sim

Question
The topology below is running EIGRP. You are required to troubleshoot and resolve the EIGRP issues
between the various routers. Use the appropriate show commands to troubleshoot the issues.

Instead of posting the output of show run commands we post here the commands entered on each
router to reduce some useless lines. Also you can try solving questions by yourself before reading the
answers.

R1:
int lo0
ip address 10.1.1.1
255.255.255.255
int e0/0
ip address 192.168.16.1
255.255.255.0
int s1/1
ip address 192.168.13.1
255.255.255.0
bandwidth 1000
int s1/3
ip address 192.168.12.1
255.255.255.0
!
router eigrp 1
network 192.168.12.0
network 192.168.13.0
network 192.168.16.0

R2:
int lo0
ip address 10.2.2.2
255.255.255.255
int e0/0
ip address 192.168.123.2
255.255.255.0
int s2/1
ip address 192.168.12.2
255.255.255.0
!
router eigrp 1
network 10.2.2.2 0.0.0.0
network 192.168.12.0
network 192.168.123.0

R3:
int lo0
ip address 10.3.3.3
255.255.255.255
int e0/0
ip address 192.168.123.3
255.255.255.0
int s2/1
ip address 192.168.13.3
255.255.255.0
!
router eigrp 1
network 10.3.3.3 0.0.0.0
network 192.168.13.0
network 192.168.123.0

R4:
int lo0
ip address 10.4.4.4
255.255.255.255
int lo1
ip address 10.4.4.5
255.255.255.255
int lo2
ip address 10.4.4.6
255.255.255.255
int e0/0
ip address 192.168.123.4
255.255.255.0
!
router eigrp 2

R5:
int lo0
ip address 10.5.5.5
255.255.255.255
int lo1
ip address 10.5.5.55
255.255.255.255
int e0/0
ip address 192.168.123.5
255.255.255.0
!
router eigrp 1
network 10.5.5.5 0.0.0.0
network 10.5.5.55 0.0.0.0

R6:
int lo0
ip address 10.6.6.6
255.255.255.255
int e0/0
ip address 192.168.16.6
255.255.255.0
!
router eigrp 1
network 10.6.6.6 0.0.0.0

network 10.4.4.4 0.0.0.0


network 10.4.4.5 0.0.0.0
network 10.4.4.6 0.0.0.0
network 192.168.123.0

network 10.10.10.0 0.0.0.255


network 192.168.123.0

Question 1
The loopback interfaces on R4 with the IP addresses of 10.4.4.4/32, 10.4.4.5/32 and 10.4.4.6/32 are not
appearing in the routing table of R5. Why are the interfaces missing?
A. The interfaces are shutdown, so they are not being advertised.
B. R4 has been incorrectly configured to be in another AS, so it does not peer with R5.
C. Automatic summarization is enabled, so only the 10.0.0.0 network is displayed.
D. The loopback addresses havent been advertised, and the network command is missing on R4.

Answer: B
Explanation
On R4 we see EIGRP is configured with AS 2 (router eigrp 2) while other routers are using AS 1 (router
eigrp 1). Therefore R4 cannot see other routers and vice versa.

Question 2
Which path does traffic take from R1 to R5?
A. The traffic goes through R2.
B. The traffic goes through R3.
C. The traffic is equally load-balanced over R2 and R3.
D. The traffic is unequally load-balanced over R2 and R3.

Answer: A

Question 3
Router R6 does not form an EIGRP neighbor relationship correctly with router R1. What is the cause for this
misconfiguration?
A. The K values mismatch. B. The AS does not match. C. The network command is missing. D. The passiveinterface command is enabled.

Answer: C
Explanation
For this question we have to check the routing table of R1 to find out the answer. Use the show ip route
command on R1 we will get something like this:

There are three interfaces on R5 which are Loopback0: 10.5.5.5 ; Loopback1: 10.5.5.55; Ethernet0/0:
192.168.123.5 and all of them are advertised via 192.168.12.2 so we can conclude traffic from R1 to R5
goes through R2 (192.168.12.2 is the IP address of S2/1 interface of R2).
Note: Maybe there is another version of this question in the exam in which the answer should be The
traffic is equally load-balanced over R2 and R3. Therefore please check the show ip route output
carefully to see if there are more than one route to the destination.

Question 4
Study the following output taken on R1:
R1#ping 10.5.5.55 source 10.1.1.1 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to
10.5.5.55, timeout is 2 seconds: Packet sent with a source address of 10.1.1.1 . . . . . Success rate is 0 percent
(0/5)
Why are the pings failing?
A. The network statement is missing on R5.
B. The loopback interface is shut down on R5.
C. The network statement is missing on R1.
D. The IP address that is configured on the Lo1 interface on R5 is incorrect.

Answer: C

Explanation
R1 does not advertise its loopback 0 (10.1.1.1) to EIGRP therefore a ping to destination 10.5.5.55 (R5)
from 10.1.1.1 will not be successful because R5 does not know how to reply to R1.

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

OSPF Neighbor Sim


Question
The topology below is running OSPF. You are required to troubleshoot and resolve the OSPF issues
between the various routers. Use the appropriate show commands to troubleshoot the issues.

Instead of posting the output of show run commands we post here the commands entered on each
router to reduce some useless lines. Also you can try solving questions by yourself before reading the
answers.

R1
interface Loopback0
description ***Loopback***
ip address 192.168.1.1
255.255.255.255
ip ospf 1 area 0
!
interface Ethernet0/0
description **Connected to
R1-LAN**
ip address 10.10.110.1
255.255.255.0
ip ospf 1 area 0
!
interface Ethernet0/1
description **Connected to
L2SW**
ip address 10.10.230.1
255.255.255.0
ip ospf hello-interval 25
ip ospf 1 area 0
!
router ospf 1
log-adjacency-changes

R2
!
interface Loopback0
description **Loopback**
ip address 192.168.2.2
255.255.255.255
ip ospf 2 area 0
!
interface Ethernet0/0
description **Connected to
R2-LAN**
ip address 10.10.120.1
255.255.255.0
ip ospf 2 area 0
!
interface Ethernet0/1
description **Connected to
L2SW**
ip address 10.10.230.2
255.255.255.0
ip ospf 2 area 0
!
router ospf 2
log-adjacency-changes

R3
username R6 password
CISCO36
!
interface Loopback0
description **Loopback**
ip address 192.168.3.3
255.255.255.255
ip ospf 3 area 0
!
interface Ethernet0/0
description **Connected to
L2SW**
ip address 10.10.230.3
255.255.255.0
ip ospf 3 area 0
!
interface Serial1/0
description **Connected to
R4-Branch1 office**
ip address 10.10.240.1
255.255.255.252
encapsulation ppp
ip ospf 3 area 0

!
interface Serial1/1
description **Connected to
R5-Branch2 office**
ip address 10.10.240.5
255.255.255.252
encapsulation ppp
ip ospf hello-interval 50
ip ospf 3 area 0
!
interface Serial1/2
description **Connected to
R6-Branch3 office**
ip address 10.10.240.9
255.255.255.252
encapsulation ppp
ip ospf 3 area 0
ppp authentication chap
!
router ospf 3
router-id 192.168.3.3
!
R4
!
interface Loopback0
description **Loopback**
ip address 192.168.4.4
255.255.255.255
ip ospf 4 area 2
!
interface Ethernet0/0
ip address 172.16.113.1
255.255.255.0
ip ospf 4 area 2
!
interface Serial1/0
description **Connected to
R3-Main Branch office**
ip address 10.10.240.2
255.255.255.252
encapsulation ppp
ip ospf 4 area 2
!
router ospf 4
log-adjacency-changes

R5
!
interface Loopback0
description **Loopback**
ip address 192.168.5.5
255.255.255.255
ip ospf 5 area 0
!
interface Ethernet0/0
ip address 172.16.114.1
255.255.255.0
ip ospf 5 area 0
!
interface Serial1/0
description **Connected to
R3-Main Branch office**
ip address 10.10.240.6
255.255.255.252
encapsulation ppp
ip ospf 5 area 0
!
router ospf 5
log-adjacency-changes

R6
username R3 password
CISCO36
!
interface Loopback0
description **Loopback**
ip address 192.168.6.6
255.255.255.255
ip ospf 6 area 0
!
interface Ethernet0/0
ip address 172.16.115.1
255.255.255.0
ip ospf 6 area 0
!
interface Serial1/0
description **Connected to
R3-Main Branch office**
ip address 10.10.240.10
255.255.255.252
encapsulation ppp
ip ospf 6 area 0
ppp authentication chap
!
router ospf 6
router-id 192.168.3.3
!

Note: Packet Tracer does not support enabling OSPF under interface mode (ip ospf 3 area 0). We dont
know why such a popular command is not supported so we cant make a pkt file for this lab.

Question 1
An OSPF neighbor adjacency is not formed between R3 in the main office and R4 in the Branch1 office.
What is causing the problem?
A. There is an area ID mismatch.
B. There is a Layer 2 issue; an encapsulation mismatch on serial links.
C. There is an OSPF hello and dead interval mismatch.
D. The R3 router ID is configured on R4.

Answer: A
Explanation
We learned it is a OSPF problem so we should check the interfaces between them first. On both R3 and R4
use show running-config command to check their S1/0 interfaces

R3#show running-config
<<output omitted>>
!
interface Serial1/0
description **Connected to R4-Branch1 office**
ip address 10.10.240.1 255.255.255.252
encapsulation ppp
ip ospf 3 area 0
!
<<output omitted>>
R4#show running-config
<<output omitted>>
!
interface Serial1/0
description **Connected to R3-Main Branch office**
ip address 10.10.240.2 255.255.255.252
encapsulation ppp
ip ospf 4 area 2
!
<<output omitted>>
In the output above we see their Area IDs are mismatched; interface S1/0 of R3 is in area 0 (R3: ip ospf
3 area 0) while interface s1/0 of R4 is in area 2 (R4: ip ospf 4 area 2).

Question 2
An OSPF neighbor adjacency is not formed between R3 in the main office and R5 in the Branch2 office.
What is causing the problem?
A. There is an area ID mismatch.
B. There is a PPP authentication issue; a password mismatch.
C. There is an OSPF hello and dead interval mismatch.
D. There is a missing network command in the OSPF process on R5.

Answer: C

Explanation
Continue checking their connected interfaces with the show running-config command:

R3#show running-config
<<output omitted>>
!
interface Serial1/1
description **Connected to R5-Branch2 office**
ip address 10.10.240.5 255.255.255.252
encapsulation ppp
ip ospf hello-interval 50
ip ospf 3 area 0
!
<<output omitted>>
R5#show running-config
<<output omitted>>
!
interface Serial1/0
description **Connected to R3-Main Branch office**
ip address 10.10.240.6 255.255.255.252
encapsulation ppp
ip ospf 5 area 0
!
<<output omitted>>
The only difference we can see here is the line ip ospf hello-interval 50 on R3. This command sets the
number of seconds R3 waits before sending the next hello packet out this interface. In this case after
configuring this command, R3 will send hello packets to R5 every 50 seconds. But the default value of
hello-interval is 10 seconds and R5 is using it. Therefore we can think of a hello interval mismatch problem
here. You can verify with the show ip ospf interface <interface> command on each router.

R3#sh ip ospf int s1/1


Serial1/1 is up, line protocol is up
Internet Address 10.10.240.5/30, Area 0
Process ID 3, Router ID 192.168.3.3, Network Type POINT_TO_POINT, Cost: 64
Enabled by interface config, including secondary ip addresses
Transmit Delay is 1 sec, State POINT_TO_POINT,
Timer intervals configured, Hello 50, Dead 200, Wait 200, Retransmit 5
oob-resync timeout 200
Hello due in 00:00:28
Supports Link-local Signaling (LLS)
Index 2/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 0
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 0, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)
R5#sh ip ospf int s1/0
Serial1/0 is up, line protocol is up
Internet Address 10.10.240.6/30, Area 0
Process ID 5, Router ID 10.10.240.6, Network Type POINT_TO_POINT, Cost: 64
Enabled by interface config, including secondary ip addresses
Transmit Delay is 1 sec, State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:04

Supports Link-local Signaling (LLS)


Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 0
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 0, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)
So we can see both hello and dead interval are mismatched because the dead interval always four times
the value of hello interval, unless you manually configure the dead interval (with the ip ospf deadinterval <seconds> command).

Question 3
R1 does not form an OSPF neighbor adjacency with R2. Which option would fix the issue?
A. R1 ethernet0/1 is shutdown. Configure no shutdown command.
B. R1 ethernet0/1 configured with a non-default OSPF hello interval of 25; configure no ip ospf hellointerval 25
C. R2 ethernet0/1 and R3 ethernet0/0 are configured with a non-default OSPF hello interval of 25;
configure no ip ospf hello-interval 25
D. Enable OSPF for R1 ethernet0/1; configure ip ospf 1 area 0 command under ethernet0/1

Answer: B

Explanation
Continue checking their connected interfaces with the show running-config command:

R1#show running-config
<<output omitted>>
!
interface Ethernet0/1
description **Connected to L2SW**
ip address 10.10.230.1 255.255.255.0
ip ospf hello-interval 25
ip ospf 1 area 0
!
<<output omitted>>
R2#show running-config
<<output omitted>>
!
interface Ethernet0/1
description **Connected to L2SW**
ip address 10.10.230.2 255.255.255.0
ip ospf 2 area 0
!
<<output omitted>>
We see the hello interval on R1 is not the same as R2 (and you can verify with the show ip ospf interface
<interface> command) -> There is a hello and dead interval mismatch problem. We should configure no
ip ospf hello-interval 25 on R1.

Note: Maybe there are some versions of this question in the exam. For example there are some reports
saying that Ethernet0/1 on R1 is shutdown (and this is the correct choice in the exam). So please be
careful checking the config on the routers before choosing the correct answers.

Question 4
An OSPF neighbor adjacency is not formed between R3 in the main office and R6 in the Branch3 office.
What is causing the problem?
A. There is an area ID mismatch. B. There is a PPP authentication issue; the username is not configured
on R3 and R6. C. There is an OSPF hello and dead interval mismatch. D. The R3 router ID is configured on
R6.
Answer: D

Explanation

R3#show running-config
<<output omitted>>
username R6 password CISCO36
!
interface Serial1/2
description **Connected to R6-Branch3 office**
ip address 10.10.240.9 255.255.255.252
encapsulation ppp
ip ospf 3 area 0
ppp authentication chap
!
<<output omitted>>
!
router ospf 3
router-id 192.168.3.3
!
<<output omitted>>
R6#show running-config
<<output omitted>>
username R3 password CISCO36
!
interface Serial1/0
description **Connected to R3-Main Branch office**
ip address 10.10.240.10 255.255.255.252
encapsulation ppp
ip ospf 6 area 0
ppp authentication chap
!
<<output omitted>>
!
router ospf 6
router-id 192.168.3.3
!
<<output omitted>>
We are not sure about the configuration of ppp authentication in this case. Some reports said that only
one router has the ppp authentication chap command but it is just a trick and is not the problem here.
The real problem here is R6 uses the same router-id of R3 (192.168.3.3) so OSPF neighborship cannot be
established. In real life, such configuration error will be shown in the command line interface (CLI). So
please check carefully for this question.

CCNA Access List Sim


Question
An administrator is trying to ping and telnet from Switch to Router with the results shown
below:
Switch>
Switch> ping 10.4.4.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.4.4.3,timeout is 2 seconds:
.U.U.U
Success rate is 0 percent (0/5)
Switch> Switch> telnet 10.4.4.3
Trying 10.4.4.3
% Destination unreachable; gateway or host down
Switch>
Click the console connected to Router and issue the appropriate commands to answer the questions.

Explanation
Note: If you are not sure about Access-list, please read my Access-list tutorial. You can also download this
sim to practice (open with Packet Tracer)
here:http://www.9tut.com/download/9tut.com_CCNA_Access_List_Sim.pkt
For this question we only need to use the show running-config command to answer all the questions
below
Router>enable
Router#show running-config

Question 1
How can we fix the problem but only allow ping to work while disabling telnet?
A Correctly assign an IP address to interface fa0/1
B Change the ip access-group command on fa0/0 from in to out
C Remove access-group 106 in from interface fa0/0 and add access-group 115 in.
D Remove access-group 102 out from interface s0/0/0 and add access-group 114 in
E Remove access-group 106 in from interface fa0/0 and add access-group 104 in

Answer: E
Explanation
Lets have a look at the access list 104:

The question does not ask about ftp traffic so we dont care about the two first lines. The 3rd line denies
all telnet traffic and the 4th line allows icmp traffic to be sent (ping). Remember that the access list 104 is
applied on the inbound direction so the 5th line access-list 104 deny icmp any any echo-reply will not
affect our icmp traffic because the echo-reply message will be sent over the outbound direction.

Question 2
What will happen after issuing the command ip access-group 114 in to the fa0/0 interface?
A Attempts to telnet to the router would fail
B All traffic from the 10.4.4.0 network would be allow to go through
C TCP and UDP traffic are not allowed to pass
D Routing protocol updates for the 10.4.4.0 network would not be accepted from the fa0/0 interface

Answer: B
Explanation
From the output of access-list 114: access-list 114 permit ip 10.4.4.0 0.0.0.255 any we can easily
understand that this access list allows all traffic (ip) from 10.4.4.0/24 network

Question 3
What will happen after issuing the command access-group 115 in on the s0/0/1 interface?
A Hosts cannot connect to Router through s0/0/1
B Telnet and ping would work but routing updates would fail.
C FTP, FTP-DATA, echo, and HTTP traffic would work but telnet would fail
D Only traffic from the 10.4.4.0 network would pass through the interface

Answer: A

Explanation
First lets see what was configured on interface S0/0/1:

Recall that each interface only accepts one access-list, so when using the command ip access-group 115 in on the
s0/0/1 interface it will overwrite the initial access-list 102. Therefore any telnet connection will be accepted (so we can
eliminate answer C).
B is not correct because if telnet and ping can work then routing updates can, too.
D is not correct because access-list 115 does not mention about 10.4.4.0 network. So the most reasonable answer is A.
But here raise a question
The wildcard mask of access-list 115, which is 255.255.255.0, means that only host with ip addresses in the form of
x.x.x.0 will be accepted. But we all know that x.x.x.0 is likely to be a network address so the answer A: no host could
connect to Router through s0/0/1 seems right
But what will happen if we dont use a subnet mask of 255.255.255.0? For example we can use an ip address of
10.45.45.0 255.255.0.0, such a host with that ip address exists and we can connect to the router through that host. Now
answer A seems incorrect!

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

CCNA Access List Sim 2


Question
Security is being added to the Corp1 router. The user on host C should be able to use a web
browser to access financial information from the Finance Web Server. No other hosts from the
LAN nor the Core should be able to use a web browser to access this server. Since there are
multiple resources for the corporation at this location including other resources on the Finance
Web Server, all other traffic should be allowed.
The task is to create and apply a numbered access-list with no more than three statements that
will allow ONLY host C web access to the Finance Web Server. No other hosts will have web
access to the Finance Web Server. All other traffic is permitted.
Access to the router CLI can be gained by clicking on the appropriate host.
All passwords have been temporarily set to cisco .
The Core connection uses an IP address of 198.18.196.65
The computers in the Hosts LAN have been assigned addresses of 192.168.33.1
192.168.33.254
Host A 192.168.33.1
Host B 192.168.33.2
Host C 192.168.33.3
Host D 192.168.33.4
The servers in the Server LAN have been assigned addresses of 172.22.242.17 172.22.242.30
The Finance Web Server is assigned an IP address of 172.22.242.23.
The Public Web Server is assigned an IP address of 172.22.242.17

Answer
Corp1>enable (you may enter cisco as it passwords here)
We should create an access-list and apply it to the interface which is connected to the Server LAN because
it can filter out traffic from both Sw-2 and Core networks. The Server LAN network has been assigned
addresses of 172.22.242.17 172.22.242.30 so we can guess the interface connected to them has an IP
address of 172.22.242.30 (.30 is the number shown in the figure). Use the show running-config
command to check which interface has the IP address of 172.22.242.30.
Corp1#show running-config

We learn that interface FastEthernet0/1 is the interface connected to Server LAN network. It is the
interface we will apply our access-list (for outbound direction).
Corp1#configure terminal
Our access-list needs to allow host C 192.168.33.3 to the Finance Web Server 172.22.242.23 via web
(port 80)
Corp1(config)#access-list 100 permit tcp host 192.168.33.3 host 172.22.242.23 eq 80
Deny other hosts access to the Finance Web Server via web

Corp1(config)#access-list 100 deny tcp any host 172.22.242.23 eq 80


All other traffic is permitted
Corp1(config)#access-list 100 permit ip any any
Apply this access-list to Fa0/1 interface (outbound direction)
Corp1(config)#interface fa0/1
Corp1(config-if)#ip access-group 100 out
Notice: We have to apply the access-list to Fa0/1 interface (not Fa0/0 interface) so that the access-list can
filter traffic coming from both the LAN and the Core networks. If we apply access list to the inbound
interface we can only filter traffic from the LAN network.
In the exam, just click on host C to open its web browser. In the address box
type http://172.22.242.23 to check if you are allowed to access Finance Web Server or not. If your
configuration is correct then you can access it.
Click on other hosts (A, B and D) and check to make sure you cant access Finance Web Server from these
hosts.
Finally, save the configuration
Corp1(config-if)#end
Corp1#copy running-config startup-config
(This configuration only prevents hosts from accessing Finance Web Server via web but if this server
supports other traffic like FTP, SMTP then other hosts can access it, too.)
Notice: You might be asked to allow other host (A, B or D) to access the Finance Web Server so please
read the requirement carefully.
Some modifications:
Modification 1:

permit host B from accessing finance server

access-list 100 permit ip host 192.168.33.2 host


172.22.242.23

deny host B from accessing other servers (not


the whole network)

access-list 100 deny ip host 192.168.33.2


172.22.242.16 0.0.0.15

permit everything else

access-list 100 permit ip any any

Modification 2:

Only allow Host C to to access the financial


server

access-list 100 permit ip host 192.168.33.3


host 172.22.242.23

Not allow anyone else in any way communicate


with the financial server

access-list 100 deny ip any host


172.22.242.23

Allow all other traffic

access-list 100 permit ip any any

Modification 3:

Host C should be able to use a web


browser(HTTP)to access the Finance
Web Server

access-list 100 permit tcp host 192.168.33.3 host


172.22.242.23 eq 80

Other types of access from host C to


the Finance Web Server should be
blocked
All access from hosts in the Core or

access-list 100 deny ip any host 172.22.242.23


(because the requirement says we can not use more

local LAN to the Finance Web Server


should be blocked

than 3 statements so we have to use any here for


the hosts in the Core and hosts in local LAN)

All hosts in the Core and local LAN


should be able to access the Public Web
Server *

access-list 100 permit ip any host


(If the question asks this, surely it has to give you the
IP of Public Web Server) but in the exam you should
use access-list 100 permit ip any any

Modification 4:

Host C should be able to use a web


browser to access the financial web
server

access-list 100 permit tcp host 192.168.33.3 host


172.22.242.23 eq 80

Other types of access from host C to


the finance web server should be
blocked

access-list 100 deny ip host 192.168.33.3 host


172.22.242.23

All hosts in the core and on the local


LAN should be able to access the
Public web server *

access-list 100 permit ip any host


(The IP of Public Web Server will surely be given in this
question) but in the exam you should use access-list
100 permit ip any any

* There are some reports about the command of All hosts in the core and on the local LAN should be able
to access the Public web server saying that the correct command should be access-list 100 permit ip any
any, not access-list 100 permit ip any host (IP of Public Web Server). Although I believe the second
command is better but maybe you should use the first command access-list 100 permit ip any any
instead as some reports said they got 100% when using this command (even if the question gives you the
IP address of Public Web Server). It is a bug in this sim.
(Note: Dont forget to apply this access list to the suitable interface or you will lose points
interface fa0/1
ip access-group 100 out
And in the exam, they may slightly change the requirements, for example host A, host B instead of host
C so make sure you read the requirement carefully and use the access-list correctly)
I created this sim in Packet Tracer v5.2.1 so you can practice with it. You will need new version of Packet
Tracer to open it (v5.1+).

Download this sim here


Notice: After typing the commands above, if you make a ping from other hosts (PC0, PC1, PC3) then
PC4 (Finance Web Server) can still reply because we just filter HTTP traffic, not ICMP traffic. To generate
HTTP traffic, select Web Browser in the Desktop tab of these PCs. When a web browser opens, type the
IP address of Finance Web Server and you can see how traffic flows in Simulation Mode.

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

CCNA EIGRP Lab


Question
Your company has just added R3 router to the existing network. But currently no routing updates are
being exchanged between R3 and the network. All other connectivity, including Internet access are
working properly.
The task is to identify the fault(s) and correct the router configuration to provide full connectivity between
the routers.
All passwords on all routers are set to cisco.
IP addresses are listed in the chart below.

R1
Fa0/0: 192.168.77.33
S1/0: 198.0.18.6
S0/1: 192.168.60.25
S0/0: 192.168.36.13

R2
Fa0/0: 192.168.60.97
Fa0/1: 192.168.60.113
S0/0: 192.168.36.14

R3
Fa0/0: 192.168.77.34
Fa0/1: 192.168.60.65
Fa1/0: 192.168.60.81

R4
Fa0/0: 192.168.60.129
Fa0/1: 192.168.60.145
S0/1: 192.168.60.26

Answer and explanation


(Note: If you are not sure how EIGRP works, please read my EIGRP tutorial: http://www.9tut.com/eigrprouting-protocol-tutorial. Note: You can download this sim to practice
here: http://www.9tut.com/download/9tut.com_CCNA_EIGRP_sim_question.zip)
We should check the configuration of the new added router first because it does not function properly
while others work well. From the command line interface of R3 router, enter the show runningconfig command

From the output above, we know that this router was wrongly configured with an autonomous number
(AS) of 22. When the AS numbers among routers are mismatched, no adjacency is formed.

(You should check the AS numbers on other routers for sure)


To solve this problem, we simply re-configure router R3 with the following commands:
R3>enable (you have to enter Secret@9tut as its password here)
R3#configure terminal
R3(config)#no router eigrp 22
R3(config)#router eigrp 212
R3(config-router)#network 192.168.60.0
R3(config-router)#network 192.168.77.0
R3(config-router)#no auto-summary
R3(config-router)#end
R3#copy running-config startup-config
Check R1 router with the show running-config command:

Notice that it is missing a definition to the network R3. Therefore we have to add it so that it can recognize
R3 router
R1>enable (you have to enter cisco as its password here)
R1#configure terminal
R1(config)#router eigrp 212
R1(config-router)#network 192.168.77.0
R1(config-router)#end
R1#copy running-config startup-config
Now the whole network will work well. You should check again with ping command from router R3 to
other routers!
Modifications:
Maybe in this EIGRP Sim you will see the passive-interface command somewhere in R1 configuration.
If the link between R1 to R2; or R1 to R3; or R1 to R4) routers has the passive interface then we have to
remove it with the no passive-interface command because it prevents EIGRP update from being sent
on that interface. But if the passive interface is applied to the link between R1 and ISP router like
this:
R1:
!
router eigrp 212
passive-interface s1/0
!

then we just leave it. Dont use the no passive-interface s1/0 on R1 because the link between R1 &
ISP doesnt need EIGRP to run on it. A static route from R1 to ISP & ip default-network command in R1
are correct so that all the routers (R1, R2, R3, R4) can access the Internet.
(Note: The ip default-network command in R1 will advertise the static route of R1 (to go to the Internet)
to other routers (R2,R3,R4) so that they can access the Internet too). In the exam you will see these lines
in R1 configuration:
!
ip default-network 198.0.18.0
ip route 0.0.0.0 0.0.0.0 198.0.18.5
!
If you want to learn more about ip default-network command please
read:http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080094374.shtml
I read recent comments and realized that you will see the passive-interface in the link between R1 &
ISP router so just leave it.
Note: Also some readers confuse about if we should use the wildcard masks on the network statements
under EIGRP process or not. For example should we use:
router eigrp 212
network 192.168.77.0 0.0.0.3
The answer is: we can use wildcard masks or not, it does not matter. Not having a wildcard mask does not
make the routes conflicting. The network command in EIGRP (and OSPF, RIP) does not means
advertise this network but means If I has interface(s) belongs to this network please turn on EIGRP on
that interface. Therefore when you dont use wildcard mask EIGRP will turn on EIGRP on all interfaces that
belongs to the network you specify in the network command.
You should only use wildcard mask on EIGRP if you have 2 or more interfaces that belong to the same
major networks but you dont want to run EIGRP on all of them. For example if your router has 2
interfaces whose IP addresses are 192.168.30.1/28 and 192.168.30.17/28 but you only want to run EIGRP
on the first interface, you can type network 192.168.30.0 0.0.0.15 under EIGRP process.

Potrebbero piacerti anche