Sei sulla pagina 1di 4

CCNP ROUTE Skills Based Assessment Notes

At my Cisco academy, you are allowed to bring notes/commands to the exam.

These notes ensured I got a 100/100 in the SBA for CCNP ROUTE v6.

TCL Script Example

Router# tclsh

! Start the TCL shell

foreach var {

! Begin the foreach loop

X.X.X.X

! Array element

Y.Y.Y.Y

Z.Z.Z.Z

} {

ping $var }

! action against $var

Setting up an interface

interface <int> when initialized

description

ip address <ip> <subnet mask> including the subnet mask

clock rate <clock>

bandwidth <bw> comp utation

no shutdown

ipv6 address <ipv6>

ivp6 rip <NAME> enable

tunnel source <int>

tunnel destination <ip>

tunnel mode ipv6ip

! Loopbacks will automatically go up

! Optional description for the interface

! The address of the interface,

! Clock rate in Kb/s

! EIGRP needs bandwidth to do

! Open the interface

! Set an IPV6 address

! Enable RIPv1 via IPV6

! The tunnel source interface

! The tunnel destination IP

! Allow IPV6 through the Tunnel

Routing

Gateway of Last Resort

ip route 0.0.0.0 0.0.0.0 <int>

! The the quad zero exit interface

Floating Static Routes

ip route <network> <subnet> <destination ip>

ip route <network> <subnet> <destination ip> <priority>

Create BGP Autonomous System (AS)

router bgp <AS>

no synchronization

neigbor <ip> remote- as <AS>

neigbor <ip> route- map <route- map> in

no auto- summary

network <summary>

ip route <network> <subnet> null0

! Initialize the BGP AS

! Only announce if local convergence

! Declare neighbor

! Set route- maps for neighbor

! Disable summarization

! Announce a network

! Add the nullroute

clear ip bgp doesn't update)

route- map <routemap> <permit|deny> <no>

! Refresh BGP (Use this if something

set local - preference <no>

Create EIGRP Autonomous System (AS)

router eigrp <AS>

network <network> [wildcard] broadcast

p assive - interface default EIGRP routing updates

neighbor <DEST- IP> <INT> manually setup neigbor

! Initialize the EIGRP AS

! Add the networks to be

! Set all interfaces to suppress ALL

! If passive interface is set,

no passive- interface <int> interface

no auto- summary

! Re- enable the routing updates on this

! Disable summarization

interface <int>

! Enter the interface to set Hello

interval

ip hello- interval eigrp <AS> <sec> each end

key chain <KEYCHAIN> config mode

! Hello interval, must be the same in

! MD5 on EIGRP

! Create a new keychain in

key 1

! First key

key- string <KEY>

! Keystring

interface <int>

ip authentication mode eigrp <AS> md5

ip authentication key- chain eigrp <AS> <KEYCHAIN>

! Setup MD5 for link

Create OSPF

interface <interface>

ip ospf network point- to- point

router ospf <AS>

router- id <id> creating networks)

! Select the interface for Point to Point

! Setup OSPF point- to- point

! Initialize the OSPF AS

! Set the Router- ID (Do this before

area <no> range <start- ip> <end - ip>

network <network> [wildcard] area <no> broadcast

! Optionally setup the Area

! Add the networks to

passive - interface default

no passive- interface <int>

redistribute <routing protocol> <no> subnets metric <no>

distr ibute- list <acl> <direction>

default - information originate always

interface <int>

ip ospf network broadcast interface.

! Set OSPF to broadcast on the

ip ospf priority <priority>

! Set priority (force DR)

ip ospf network point- to- point broadcast correct mask

access- list <no> <deny|permit> <network wildcard|any> ! Remember to Deny, then Permit

router ospf <AS>

! Loopbacks must be point - to- point to

area <no> stub

! STUB, on ABR

area <no> nssa

! NSSA, on ABR

area <no> stub no - summary

area <no> nssa no - summary

router ospf <AS> otherwise create virtual link

area <AS> virtual - link <dest ip> X) - also opposite direction

IPv6 Routing

ipv6 unicast - routing

ipv6 router rip <process>

interface <int>

ipv6 rip <process> enable

! Totally STUB, on ABR

! Totally NSSA, on ABR

! All areas must connect to Backbone,

! Transit area (between 0 and

! Initialize routing for IPv6

! Initialize RIP for the process

! Select interface

! Enable process on interface