Sei sulla pagina 1di 51

RESUMEN DE COMANDOS

STO. 1 FRANCO (BTA-VII/22)


Versin 1.0
CCNA-2
Configuracin de Contraseas de Consola
Router>
Router#
Router(config)#
Router(config-line)#
Router(config-line)#
Router(config-line)#
Router#
enable
Configure terminal
Line console 0
login
Password cisco
exec-timeout 30 30
Router(config-line)# exit
Configuracin de Contraseas de VTY
Router>
Router#
Router(config)#
Router(config-line)#
Router(config-line)#
Router(config-line)#
Router#
enable
Configure terminal
Line vty 0 4
login
Password cisco
exit
Router(config-line)# exec-timeout 30 30
Configuracin de Contraseas de AUX
Router>
Router#
Router(config)#
Router(config-line)#
Router(config-line)#
Router(config-line)#
Router#
enable
Configure terminal
Line aux 0
login
Password cisco
exit
Router(config-line)# exec-timeout 30 30
Configuracin de Contraseas Enable
Router>
Router#
Router(config)#
Router(config)#
Router#
enable
Configure terminal
Enable secret CISCO
exit
Router(config)# exec-timeout 30 30
Encriptar Contraseas
Router>
Router#
Router(config)#
Router(config)#
Router#
enable
Configure terminal
service password-encryption
exit
Recuperar Contraseas (1)
Router>
Router# show version
Rommon>confreg 0x2142
0x2102= Carga startup-config
0x2142= Obvia statup-config
Observar el nmero de registro: 0x2102 0x2142
enable
Reiniciar el router (OFF)
Durante el proceso de arranque, pulsar Ctrl + Pause
Rommon>reset

--- System Configuration Dialog ---

Continue with configuration dialog? [yes/no]: n
Recuperar Contraseas (2)
Router>
Router# configure terminal
Router# copy startup-config running-config
Router(config)#enable secret franco
enable
Poner nuestra contrasea
Router# configure terminal
Router# copy running-config starup-config
Router(config)#config-register 0x2102
Router(config)#exit
Cambiar nombre al Router
Router>
Router#
Router(config)#
R-13(config)#
R-13#
enable
Configure terminal
Hostname R-13
exit
Comando Show
Router> Router#
show version:Informacin sobre:
-Versin y ubicacin de IOS CISCO
-Programa bootstrap de ROM.
-Modelo de CPU e interfaces
-Cantidad de RAM, NVRAM y Flash
-Registro de configuracin (hexadec. Para recuperar
contraseas.

show clock:Muestra la hora y la fecha del router.
show hosts:Muestra una lista de los nombres de los host y las
direcciones.
show history:Muestra un resumen de los comandos introducidos
en el router.
Comando Show
Router> Router#
show startup-config:Muestra el archivo de configuracin de
inicio, almacenado en la NVRAM. Informa del tamao del
archivo, versin de boopstrap, estado de los interfaces,
consola y VTY (telnet) y sus contraseas.
show running-config:Muestra la configuracin actual en
ejecucin almacenada en la RAM. Informa del tamao del
archivo, versin de boopstrap, estado de los interfaces,
consola y VTY (telnet) y sus contraseas.
Comando Show
Router> Router#
show interface:Muestra estado y describe uno a uno los
interfaces detalladamente.
show interface fastEthernet 0/0:Muestra estado y describe
slo ese interfaz. Nivel Fsico 1 y 2.
show ip interface:Resumen detallado de todos los interfaces,
con IP, estado (up/down)y puerto.
show interface serial 0/0/0:Muestra estado y describe slo
ese interfaz. Nivel Fsico 1 y 2.
show controllers serial 0/0/0:Informacin adicional de ese
interfaz (DCE,DTE,reloj,).
show ip interface brief:Resumen simplificado de los
interfaces, con IP, estado (up/down)y puerto.
Comando Show
Router> Router#
show ip route:Informacin de las redes conectadas al router.
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 3 subnets, 3 masks
C 10.40.246.96/29 is directly connected, FastEthernet0/0
C 10.40.247.24/30 is directly connected, Serial0/0/1
C 10.40.247.26/32 is directly connected, Serial0/0/1
Comando Show
Router> Router#
show ip protocols:Informacin sobre los protocolos utilizados
en cada red.
show cdp neighbors details:Descubre los dispositivos CISCO
ms detalladamente.
show cdp neighbors:Descubre los dispositivos CISCO.
(config)#no cdp run:Desactiva CDP globalmente.
(config-if)#no cdp enable:Desactiva CDP de ese interfaz.
Comando Show
Router> Router#
show ip ospf neighbor:Informacin de los vecinos que
tenemos utilizando el protocolo OSPF.(State:FULL/DOWN)
show ip eigrp neighbor:Informacin de los vecinos que
tenemos utilizando el protocolo EIGRP.
show ip eigrp topology:Informacin de la topologia de la red
(Sucesor y Sucesores Factibles).
show ip eigrp topology all-links:Informa de todas las rutas
posibles hacia una red, incluidos los Sucesores, Sucesores
Factibles,etc...
Salvar Configuracin
Router>
Router#
Building Configuration ...
enable
copy running-config startup-config
[ok]
Router#
Borrar Configuracin
Router>
Router#
Erasing the nvram filesystem will remove all configuration
files! Continue? [confirm]
enable
erase startup-config
[OK]
Erase of nvram: complete
Router#reload
Proceed with reload? [confirm]
.
.
.
--- System Configuration Dialog ---
Would you like to enter the initial configuration dialog?
[yes/no]:
Debug: Control de operaciones en
tiempo real
Router#debug ip routing
IP routing debugging is on
Router#un debug ip routing
IP routing debugging is off
Router#undebug all
All possible debugging has been turned off
Router#debug ip rip
RIP protocol debugging is on
Router#debug eigrp fsm (Mquina de Estado Finito)
EIGRP FSM Events/Actions debugging is on
Comandos Variados
Router(config-line)#Logging synchronous: Impide que aparezcan
mensajes (informes de estado) mientras se est escribiendo.
Router(config)#no ip domain-lookup:Cancela la busqueda de un
DNS. Evita que se bloquee el equipo al introducir un comando
errneo.
do : Introduciendolo antes de un comando que correspondera
escribirlo en un sub-men diferente, lo ejecuta sin tener que
salir del men en que nos encontramos.
Ej: router(config)# do show version
Configuracin de Interfaces FastEthernet
Direccionamiento IP
Router>
Router#
Router(config)#
Router(config-if)#
Router(config-if)#
Router(config-if)#
Router(config)#
enable
Configure terminal
interface fastethernet 0/0
ip address 192.168.0.1 255.255.255.0
no shutdown
exit
Configuracin de Interfaces FastEthernet
VLAN - Direccionamiento IP
Router>
Router#
Router(config)#
Router(config-if)#
Router(config-if)#
Router(config-if)#
Router(config)#
enable
Configure terminal
interface fastethernet 0/0.2
ip address 10.40.2.1 255.255.255.248
Encapsulation dot1Q
exit
Protocolo de encapsulacin de VLANs
Sub-interfaz
Configuracin de Interfaces FastEthernet
Descripcin
Router>
Router#
Router(config)#
Router(config-if)#
enable
Configure terminal
interface fastethernet 0/0
Description PC-14
Router(config-if)#exit
Router(config)#
Configuracin de Interfaces FastEthernet
Velocidad
Router>
Router#
Router(config)#
Router(config-if)#
auto
10
100
enable
Configure terminal
interface fastethernet 0/0
Speed ?
Force 10 Mbps operation
Force 100 Mbps operation
Enable AUTO speed configuration
Router(config-if)# Speed 100
Router(config-if)#exit
Router(config)#
Configuracin de Interfaces FastEthernet
Duplex/Half-Duplex
Router>
Router#
Router(config)#
Router(config-if)#
auto
full
half
enable
Configure terminal
interface fastethernet 0/0
duplex ?
Enable AUTO duplex configuration
Force full duplex operation
Force half-duplex operation
Router(config-if)# duplex full
Router(config-if)#exit
Router(config)#
Configuracin de Interfaces
Direccionamiento (Loopback)
Router>
Router#
Router(config-if)#
enable
Configure terminal
ip address 10.40.248.13 255.255.255.255
exit Router(config)#
Router(config)# Interface loopback 0
Configuracin de Interfaces Seriales DCE
Direccionamiento
Router>
Router#
Router(config)#
Router(config-if)#
Router(config-if)#
Router(config-if)#
Router(config-if)#
enable
Configure terminal
interface serial 0/0
ip address 192.168.0.1 255.255.255.0
clockrate 56000
no shutdown
exit
Router(config)#
Configuracin de Interfaces Seriales DTE
Direccionamiento
Router>
Router#
Router(config)#
Router(config-if)#
Router(config-if)#
Router(config-if)#
enable
Configure terminal
interface serial 0/0
ip address 192.168.0.1 255.255.255.0
no shutdown
exit
Router(config)#
Configuracin de Interfaces Seriales
Enrutamiento
Router>
Router#
Router(config)#
enable
Configure terminal
Ip route 10.40.246.104 255.255.255.248
10.40.247.26
exit Router(config)#
Red Destino Mscara Destino
Interfaz Serial Router Destino
Configuracin de Interfaces Seriales
Enrutamiento (2)
Router>
Router#
Router(config)#
enable
Configure terminal
Ip route 10.40.246.104 255.255.255.248 s0/0/0
exit Router(config)#
Red Destino Mscara Destino
Interfaz Serial Router Local
Configuracin de Interfaces Seriales
Enrutamiento (Ruta por defecto)
Router>
Router#
Router(config)#
enable
Configure terminal
Ip route 0.0.0.0 0.0.0.0 s0/0/0
exit Router(config)#
Ruta quad-zero
Interfaz Serial Router Local
Configuracin de Interfaces Seriales
Enrutamiento (Ruta de Resumen)
Router>
Router#
Router(config)#
enable
Configure terminal
Ip route 172.16.0.0 255.255.252.0 s0/0/0
exit Router(config)#
Ruta Sumarizada Interfaz Serial Router Local
Varias direcciones por un mismo interfaz se pueden resumir en una sola
direccin de Red.

172.16.1.0 10101100.00010000.00000001.00000000
172.16.2.0 10101100.00010000.00000010.00000000
172.16.3.0 10101100.00010000.00000011.00000000

172.16.0.0 10101100.00010000.00000000.00000000
255.255.252.0 11111111.11111111.11111100.00000000
22
Configuracin de Interfaces Serial
Encapsulacin
Router>
Router#
Router(config)#
Router(config-if)#
enable
Configure terminal
interface serial 0/0/0
encapsulation ?
Router(config-if)#hdlc
Router(config-if)#exit
Router(config)#
frame-relay Frame Relay networks
hdlc Serial HDLC synchronous
lapb LAPB (X.25 Level 2)
ppp Point-to-Point protocol
smds Switched Megabit Data Service (SMDS)
x25 X.25
Configuracin de Interfaces (FastEthernet y Serial)
Bucle (Local)
Router>
Router#
Router(config)#
Router(config-if)#
enable
Configure terminal
interface serial 0/0/0
loopback
Router(config-if)#exit
Router(config)#
Si se hace un show interface serial 0/0/0, aparecer:
Serial 0/0/0: up Protocol :down (looped).
DCD:up DRS:up DTR:up RTS:up CTS:up

Para quitarlo se introduce: no loopback
Configuracin de Protocolos de Enrutamiento
RIP
Router>
Router#
Router(config)#
Router(config-router)#
Router(config-router)#
Router(config-router)#
enable
Configure terminal
Router rip
network 192.168.0.0
network 80.0.0.0
exit
Router(config)#
Redes conectadas en los
interfaces (sin mscara)
Configuracin de Protocolos de Enrutamiento
RIPv2
Router>
Router#
Router(config)#
Router(config-router)#
Router(config-router)#
Router(config-router)#
enable
Configure terminal
Router rip
network 192.168.0.1
network 80.0.0.1
exit
Router(config)#
Dir. IP de los Interfaces de las
Redes conectadas(sin mscara)
Router(config-router)#version 2
Router(config-router)# no auto-summary
En RIPv2 est habilitado por
defecto
Router>
Router#
Router(config)#
enable
Configure terminal
Ip route 0.0.0.0 0.0.0.0 s0/1/0
Para comunicarlo al resto de la Red
Router(config)#exit
Ruta quad-zero
Interfaz Serial Router Local
Configuracin de Protocolos de Enrutamiento
RIP (Ruta por Defecto)
Router(config)# router rip
Router(config-router)#Default-information originate
Router(config-router)#exit
Configuracin de Protocolos de Enrutamiento
(Interface Pasivo)
Router>
Router#
Router(config)#
Router(config-router)#
Router(config-router)#
enable
Configure terminal
Router rip
Passive-interface fastethernet 0/0
exit
Router(config)#
Detiene las actualizaciones
RIP por este interfaz.
Definir el protocolo
Configuracin de Protocolos de Enrutamiento
IGRP
Router>
Router#
Router(config)#
Router(config-router)#
Router(config-router)#
Router(config-router)#
enable
Configure terminal
Router igrp 110
network 192.168.0.0
network 80.0.0.0
exit
Router(config)#
Redes conectadas en los
interfaces (sin mscara)
NMERO DE PROCESO: nico para
cada Red
Configuracin de Protocolos de Enrutamiento
EIGRP
Router>
Router#
Router(config)#
Router(config-router)# no auto-summary
Router(config-router)#
Router(config-router)#
enable
Configure terminal
Router eigrp 10
network 10.40.2.0 0.0.0.255
network 10.40.3.0 0.0.0.7
exit
Router(config)#
Redes conectadas en los interfaces
NMERO DE PROCESO: nico para
cada Red (de 1 a 65535)
Wildcard
(Mscara al revs)
255.255.255.0
255.255.255.248
Router(config-router)#
Configuracin de Interfaces
Direccionamiento (Nulo)
Router>
Router#
Router(config)#route eigrp 1
enable
Configure terminal
ip route 192.168.10.0 255.255.255.0 null0
Router(config)#exit
Router(config)#
Router(config-route)#redistribute static
Router(config-route)#exit
Definir el protocolo
Router>
Router#
Router(config)#
enable
Configure terminal
Ip route 0.0.0.0 0.0.0.0 s0/1/0
Para comunicarlo al resto de
la Red
Router(config)#exit
Ruta quad-zero
Interfaz Serial Router Local
Configuracin de Protocolos de Enrutamiento
EIGRP (Ruta por Defecto)
Router(config)# router eigrp 1
Router(config-router)#redistribute static
Router(config-router)#exit
Configuracin de Protocolos de Enrutamiento
EIGRP (Ruta Sumarizada Manual)
Router>
Router#
Router(config)#
Router(config-if)#ip summary-address eigrp 192.168.0.0
255.255.252.0
enable
Configure terminal
Interface serial 0/1/0
Router(config)# exit
Router(config-if)# exit
Configuracin de Protocolos de Enrutamiento
EIGRP (Ancho de Banda/BW)
Router>
Router#
Router(config)#
Router(config-if)# bandwidth 64
enable
Configure terminal
Interface serial 0/1/0
Router(config)# exit
En Kbps
Router(config-if)# exit
Router(config-if)# ip bandwidth-percent eigrp 1 50
% de utilizacin BW
(50% por defecto)
Configuracin de Protocolos de Enrutamiento
EIGRP (Intervalo y Tiempo de Espera HELLO)
Router>
Router#
Router(config)#
Router(config-if)# ip hello-interval eigrp 1 60
enable
Configure terminal
Interface serial 0/1/0
Router(config)# exit
Router(config-if)# exit
Router(config-if)# ip hold-time eigrp 1 180
En segundos
(de 1 a 65535)
En segundos
(de 1 a 65535)
Configuracin de Protocolos de Enrutamiento
OSPF
Router>
Router#
Router(config)#
Router(config-router)#
Router(config-router)#
Router(config-router)#
enable
Configure terminal
Router ospf 1000
network 10.40.2.0 0.0.0.255 Area 0
network 10.40.3.0 0.0.0.7 Area 0
exit
Router(config)#
Redes conectadas en los interfaces
Wildcard
(Mscara al revs)
255.255.255.0
255.255.255.248
Backbone= Area 0
NMERO DE PROCESO: nico para
cada Red (de 1 a 65535)
Configuracin de Protocolos de Enrutamiento
OSPF (Router ID) a partir de IOS 12.0(T)
Router>
Router#
Router(config)#
Router(config-router)#
Router(config-router)#
enable
Configure terminal
Router ospf 1000
Router id 10.40.2.1
end
Router# reload
IMPORTANTE
Direccin IP dl router
seleccionado
Router# copy running-config statup-config
Configuracin de Protocolos de Enrutamiento
OSPF (Prioridad de Interfaz)
Router>
Router#
Router(config)#
Router(config-if)# ip ospf priority 10
enable
Configure terminal
Interface fastethernet 0/0
Router(config)# exit
(De 0 a 255)
Router(config-if)# exit
Router(config-if)# shutdown
Reiniciar el interfaz
Router(config-if)# no shutdown
Router>
Router#
Router(config)#
enable
Configure terminal
Ip route 0.0.0.0 0.0.0.0 loopback 1
Para comunicarlo al resto de la Red
Router(config)#exit
Ruta quad-zero
Interfaz Serial Router Local
Configuracin de Protocolos de Enrutamiento
OSPF (Ruta por Defecto)
Router(config)# router ospf 1000
Router(config-router)#Default-information originate
Router(config-router)#exit
Configuracin de Protocolos de Enrutamiento
OSPF (Ancho de Banda/BW)
Router>
Router#
Router(config)#
A) Router(config-if)# bandwidth 64
enable
Configure terminal
Interface serial 0/1/0
Router(config)# exit
En Kbps
Router(config-if)# exit
B) Router(config-if)# ip ospf cost 1562
Resultado de 10
8
/64000 bps)
Se puede utilizar cualquiera de los dos comandos
Configuracin de Protocolos de Enrutamiento
OSPF (Ancho de Banda de Referencia)
Router>
Router#
Router(config)#
Router(config-if)# router ospf 1000
enable
Configure terminal
Interface serial 0/1/0
Router(config)# exit
N de Proceso
Router(config-if)# exit
Router(config-if)# auto-cost reference-bandwidth 10000
Valor Predeterminado = 100
(de 1 a 4294967)
Configuracin de Protocolos de Enrutamiento
OSPF (Modificacin de Intervalos)
Router>
Router#
Router(config)#
Router(config-if)# ip ospf hello-interval 5
enable
Configure terminal
Interface serial 0/1/0
Router(config)# exit
En segundos
Router(config-if)# exit
Router(config-if)# ip ospf dead-interval 20