Sei sulla pagina 1di 79

Nombre: Diogenes Jean Carlos

Apellido: Polanco Martinez


Matricula: 2008-0488
Ejercicios cap 7
1. Leer un nmero entero y determinar si es un nmero terminado en 4.
Programa Determinar_si_es_4
Var
Entero : num
Inicio
Escriba Introduzca un numero
Lea num
Si num=4
Escriba Numero introducido es igual a 4
Sino
Escriba Numero introducido es diferente a 4
Fin
2. Leer un nmero entero y determinar si tiene 3 dgitos.
Programa Determinar_3dig
Var
Entero: num
Inicio
Escriba Introduzca un numero
Lea num
Si num<0
num =num*(-1)
Si num>99 y num<1000
Escriba numero es de tres digitos
Sino
Escriba El numero no es de tres digitos
Fin
3. Leer un nmero entero y determinar si es negativo.
Programa Determ_negativo
Var
Entero : num.
Inicio
Escriba introduzca un numero
Lea num
Si num<0
Escriba Numero es negativo
Sino
Escriba Numero NO es negativo
Fin
4. Leer un nmero entero de dos dgitos y determinar a cunto es igual la suma de sus
dgitos.
Programa Suma_digitos
Var:
Entero: num
Entero: resultado
Entero: valorDigito
Inicio
Escriba Introduzca un numero de dos digitos
Lea num
Si num<0
Escriba Por favor introducir numero positivo
Sino
Si num>99
Escriba Por favor introducir un numero de dos dgitos
Sino
ValorDigito=num-{[(n/10)]*10}
Resultado=resultado+ValorDigito
Valor Digito=num/10
Resultado= valorDigito + resultado
Escriba La suma de los dgitos del numero+ num+es igual a+ resultado
Fin
5. Leer un nmero entero de dos dgitos y determinar si ambos dgitos son pares.
Programa Digitos_pares
Var
Entero: num, dig1, dig2
Inicio
Escriba Introduzca un numero entero
Lea num
Si num>0 y num<100
dig1=num/10
dig2=num-{[(num/10)]*10}
Si dig1==dig/2*2 y dig2==dig2/2*2
Escriba Ambos digitos del numero+num+son pares
Sino
Escriba Ambos digitos NO son pares
Fin_Si
Sino Escriba El numero que usted introdujo no es valido
Fin _ si
Fin
6. Leer un nmero entero de dos dgitos menor que 20 y determinar si es primo.
Programa Numero_es_Primo
Var
Entero: num
Inicio
Escriba Por favor introduzca un numero entero menor que veinte
Lea num
Si num<0
Num=num*(-1)
Fin si
Si num>9 y num<21
Si num==11 o num==13 o num=17 o num==19
Escriba El numero+num+ES PRIMO
Sino
Escriba El numero +num+NO es primo
Fin _ si
Sino
Escriba Numero no valido: introducir numero de dos digitos
Fin _ si
Fin
7. Leer un nmero entero de dos dgitos y determinar si es primo y adems si es negati
vo.
Programa numero_primo_negativo
Var
Entero: num
Inicio
Escriba Por favor, introduzca el numero que desea evaluar
Lea num
Si num=0
Escriba El numero escrito es invalido: escriba un numero de dos digitos
Sino
Si num<0
Si num<(-99) y num>(-9)
Escriba El numero escrito es invalido: escriba un numero de dos digitos
Sino
Escriba El numero es negativo
Fin_si
Fin_Si
Si num>0
Si num >99 y num<9
Escriba El numero escrito es invalido: escriba un numero de dos dgitos
Sino
Escriba el numero escrito es positivo
Fin si
Si num<0
Num=num*(-1)
Fin si
Si num==11 o num==13 o num==17 o num==19
Escriba Numero ES PRIMO
Sino
Escriba Numero No es Primo
Fin
8. Leer un nmero entero de dos dgitos y determinar si sus dos dgitos son primos.
Programa digitos_Primos
Var
Entero: num, dig1, dig2
Inicio
EscribaEscriba un numero de dos digitos
Si num<0
num=num*(-1)
Fin_si
Si num<10 o num>99
Escriba El numero escrito es invalido: Por favor introduzca un numero de dos digi
tos
Sino
dig1=num/10
dig2=num-{[(num/10)]*10}
Si dig1== 11 o dig1==13 o dig1==17 o dig1==19
Si dig2== 11 o dig2==13 o dig2==17 o dig2==19
Escriba Ambos dgitos son nmeros Primos
Sino
Escriba Ambos dgitos NO son nmeros Primos
Fin_si
Sino
Escriba Ambos dgitos NO son nmeros Primos
Fin_Si
Fin
9.
Leer un nmero entero de dos dgitos y determinar si un dgito es mltiplo del otro.
Programa Determinar _ mltiplo
Var
Entero: num, dig1,dig2
Inicio
Escriba Escriba un numero de dos dgitos
Lea num
Si num==0
Escriba numero escrito es cero: numero invalido
Sino
Si num<0
num= num*(-1)
Fin_Si
Si num>9 y num<100
dig1=num/10
dig2=num-{[(num/10)]*10}
Si RESTO de dig1/dig2==0
Si RESTO de dig2/dig1==0
Escriba Un digito es mltiplo del otro
Sino
Escriba ningn digito es mltiplo del otro
Sino
Escriba ningn digito es mltiplo del otro
Fin_Si
Sino
Escriba numero invalido: Escriba numero de dos dgitos
Fin_Si
Fin_Si
Fin
10. Leer un nmero entero de dos dgitos y determinar si los dos dgitos son iguales.
Programa dgitos _ iguales
Var
Entero: num, dig1, dig2
Inicio
Escriba Escriba un numero de dos dgitos
Lea num
Si num==0
Escriba Numero invalido.
Sino
Si num<0
Num=num*(-1)
Si num>9 y num<100
dig1=num/10
dig2=num-{[(num/10)]*10}
Si dig1=dig2
Escriba Ambos dgitos son iguales
Sino
Escriba Ambos digitos NO son iguales
Fin_si
Fin_si
Fin_Si
Fin_Si
Fin
11. Leer dos nmeros enteros y determinar cul es el mayor.
Programa numero _ mayor
Var
Entero: num1, num2
Inicio
Escriba Escriba dos nmeros enteros
Lea num1
Lea num 2
Si num1==0 o num2==0
Escriba Numero invalido.
Sino
Si num1>num2
Escriba num1+Es mayor que +num2
Si num2>num1
Escriba num2+es mayor que+num1
Sino
Escriba Nmeros son iguales favor Escriba dos nmeros diferentes
Fin_Si
Fin
12. Leer dos nmeros enteros de dos dgitos y determinar si tienen dgitos comunes.
Programa comparar_digitos_comunes
Var
Entero:Num1, num2, dig1a, dig1b, dig2a, dig2b
Inicio
Escriba Escriba dos nmeros enteros
Lea num1
Lea num2
Si num1==0 o num2==0
Escriba Numero invalido.
Sino
Si num1<0
num1=num1*(-1)
Si num2<0
Num2=num2*(-1)
dig1a= num1/10
dig1b=num1-{[(num1/10)]*10}
dig2a= num2/10
dig2b=num2-{[(num2/10)]*10}
Si dig1a==dig2a o dig1a== dig2b o dig1b== dig2a o dig1b== dig2b
Escriba Si, los numeros tienen digitos comunes
Sino
Escriba Los nmeros no tienen dgitos en comn
Fin_Si
Fin
13. Leer dos nmeros enteros de dos dgitos y determinar si la suma de los dos nmeros
origina un nmero par.
Programa suma_es_par
Var
Entero: num1, num2, suma
Inicio
Escriba Escriba dos nmeros enteros
Lea num1
Lea num 2
Si num1==0 o num2==0
Escriba Numero invalido.
Si num1<0
num1=num1*(-1)
Si num2<0
Num2=num2*(-1)
Suma=num1+num2
Si suma/2*2==suma
Escriba La suma de ambos nmeros origina un numero par
Sino
Escriba La suma de ambos numeros No origina un numero par
Fin si
Fin
14. Leer dos nmeros enteros de dos dgitos y determinar a cunto es igual la suma de
todos los dgitos.
Programa Suma_digitos_dosNum
Var
Entero:Num1, num2, dig1a, dig1b, dig2a, dig2b, sumaTOTAL
Inicio
Escriba Escriba dos nmeros enteros
Lea num1
Lea num2
Si num1==0 o num2==0
Escriba Numero invalido.
Sino
Si num1>9 y num1<100
Si num2>9 y num2<100
Si num1<0
num1=num1*(-1)
Si num2<0
Num2=num2*(-1)
dig1a= num1/10
dig1b=num1-{(num1/10)*10}
dig2a= num2/10
dig2b=num2-{[(num2/10)]*10}
sumaTOTAL= dig1a+dig1b+dig2a+dig2b
Escriba La suma de todos los digitos de los dos numeros es igual a+sumaTOTAL
Sino Escriba numero no valido
Fin_Si
Sino Escriba numero no valido
Fin
15. Leer un nmero entero de tres dgitos y determinar a cunto es igual la suma de su
s dgitos.
Programa Suma_tres digitos
Var
Entero: num, dig1a, dig1, dig2, dig3, sumaTOTAL
Inicio
Escriba Escriba nmero entero de tres digitos
Lea num
Si num==0
Escriba Numero invalido.
Si num<0
num1=num1*(-1)
Si num>99 y num<1000
dig3=num/100
dig2= num1-(dig3*100)/10
dig1=num1-{(num/10)*10}
sumaTOTAL= dig1+dig1+dig3
Escriba La suma de todos los dgitos del numero escrito es igual a+sumaTOTAL
Sino
Numero no valido: Favor Escriba un numero de tres dgitos
Fin_Si
Fin
16. Leer un nmero entero de tres dgitos y determinar si al menos dos de sus tres dg
itos son iguales.
Programa Digito_igual_tres
Var
Entero: num, dig1, dig2, dig3
Inicio
Escriba Escriba nmero entero de tres digitos
Lea num
Si num==0
Escriba Numero invalido.
Si num<0
num1=num1*(-1)
Si num>99 y num<1000
dig3=num/100
dig2= num1-(dig3*100) /10
dig1=num1-{(num/10)*10}
Si dig1==dig2 o dig1==dig3 o Dig2==dig3
Escriba Al menos dos de los tres dgitos del numero escrito son iguales
Sino
Escriba El numero no tiene dgitos repetidos
Fin_si
Fin
17. Leer un nmero entero de tres dgitos y determinar en qu posicin est el mayor dgito.
Programa Digito_igual_tres
Var
Entero: num, dig1a, dig1, dig2, dig3
Inicio
Escriba Escriba nmero entero de tres dgitos
Lea num
Si num==0
Escriba Numero invalido.
Si num<0
num1=num1*(-1)
Si num>99 y num<1000
dig3=num/100
dig2= num1-(dig3*100) /10
dig1=num1-{(num/10)*10}
Si dig1>dig2 y dig1>dig3
Escriba El digito mayor se encuentra en la primera posicin desde la izquierda
Fin_Si
Si dig2>dig1 y dig2>dig3
Escriba El digito mayor se encuentra en la segunda posicin desde la izquierda
Fin_Si
Si dig3>dig1 y dig3>dig2
Escriba El digito mayor se encuentra en la tercera posicin desde la izquierda
Fin_Si
Sino
Escriba El numero introducido no es valido. Favor escriba un numero de tres cifra
s
Fin _si
Fin
18. Leer un nmero entero de tres dgitos y determinar si algn dgito es mltiplo de los
otros.
Programa Digitos_multiplos_trescifras
Var
Entero: num, dig1, dig2, dig3
Inicio
Escriba Escriba nmero entero de tres dgitos
Lea num
Si num==0
Escriba Numero invalido.
Si num<0
num1=num1*(-1)
Si num>99 y num<1000
dig3=num/100
dig2= num1-(dig3*100) /10
dig1=num1-{(num/10)*10}
Si dig1/dig2*dig2=dig1 O dig1/dig3*dig3=dig1
O dig2/dig1*dig1=dig2 O dig2/dig3*dig3=dig2
O dig3/dig1*dig1=dig3 O dig3/dig2*dig2=dig3
Escriba S: alguno de los dgitos es mltiplo de otro
Sino
Escriba Ninguno de los dgitos es mltiplo de otro
Fin_Si
Sino
Escriba El numero introducido no es valido. Favor escriba un numero de tres cifra
s
Fin _si
Fin
19. Leer tres nmeros enteros y determinar cul es el mayor. Usar solamente dos vari
ables.
Programa Determinar_numero_mayor
Var
Entero: numRecibido, numAlmacenado
Inicio
Escriba Escriba nmero entero
Leer numRecibido
numAlmacenado=numRecibido
Escriba Escriba otro nmero entero
Leer numRecibido
Si numRecibido>numAlmacenado
numAlmacenado=numRecibido
Fin si
Escriba Escriba otro nmero entero
Leer numRecibido
Si numRecibido>numAlmacenado
numAlmacenado=numRecibido
Fin si
Escriba El mayor de los tres nmeros introducidos es+numAlmacenado
Fin
20. Leer tres nmeros enteros y mostrarlos ascendentemente.
Programa mostrar_ascendentemente
Var
Entero: num1, num2, num 3, Primero, Segundo, Tercero
Inicio
Escriba Favor de introducir 3 numeros enteros
Lea num1
Lea num2
Lea num 3
Si num1>num2 o num1>num3
Si num1>num2 y num1>num3
Primero=num1
Sino
Segundo=num1
Sino
Tercero=num1
Fin_si
Si num2>num1 o num2>num3
Si num2>num1 y num2>num3
Primero=num2
Sino
Segundo=num2
Sino
Tercero=num2
Fin_si
Si num3>num2 o num3>num1
Si num3>num2 y num3>num1
Primero=num3
Sino
Segundo=num3
Sino
Tercero=num3
Fin_si
Escriba los nmeros ordenados ascendentemente son +Tercero+ Segundo+ Primero
Fin
21. Leer tres nmeros enteros de dos dgitos cada uno y determinar en cul de ellos se
encuentra el mayor dgito.
Programa MayorDigito_deTresNumeros
Var
Entero:
num1, num2, num3,
dig1a, dig1b,dig2a, dig2b, dig3a, dig3b,
mayor1, mayor2, mayor3,
mayorDigito
Inicio
Escriba Favor de introducir 3 numeros enteros de dos digitos
Lea num1
Lea num2
Lea num 3
Si num1==0 O num2==0 O num2==0
Escriba Uno o ms de los nmeros es invalido. Favor de introducir 3 nmeros enteros de
dos dgitos.
Fin_Si
Si num1<0
num1=num1*(-1)
Fin_si
Si num2<0
Num2=num2*(-1)
Fin_s
Si num3<0
Num3=num3*(-1)
Fin_si
Si num1>9 y num1<100 y num2>9 y num2<100 y num3>9 y num3<100
dig1a=num1/10
dig1b=num1-{(num1/10)*10}
dig2a=num2/10
dig2b=num2-{(num2/10)*10}
dig3a=num3/10
dig3b=num3-{(num3/10)*10}
Si dig1a>dig1b
Mayor1=dig1a
Sino
Mayor1=dig1b
Fin si
Si dig2a>dig2b
Mayor2=dig2a
Sino
Mayor2=dig2b
Fin si
Si dig3a>dig3b
Mayor3=dig3a
Sino
Mayor3=dig3b
Fin si
Si mayor1>mayor2 y mayor1>mayor3
Escriba El digito mayor pertenece al Primero de los numeros
Fin_Si
Si mayor2>mayor1 y mayor2>mayor3
Escriba El digito mayor pertenece al Segundo de los nmeros
Fin_Si
Si mayor3>mayor1 y mayor3>mayor1
Escriba El digito mayor pertenece al Tercero de los nmeros
Fin_Si
Sino
Escriba Existen dos dgitos mayores que son iguales
Fin_Si
Sino
Escriba numero digitado no es de tres cifras,. Digite numero valido
Fin_Si
Fin
22. Leer un nmero entero de tres dgitos y determinar si el primer dgito es igual al
ltimo.
Programa Dgitos _ iguales
Var
Entero: num, firstDig, lastDig
Inicio
Escriba Introduzca un numero entero de tres dgitos
Lea num
Si num<0
num=num*(-1)
Si num>99 y num<1000
firstDig=num/100
lastDig=num-[(num/10)*10]
Si firstDig==lastDig
Escriba Primer y ultimo digito son iguales
Sino
Escriba Primer y ultimo digito no son iguales
Fin_Si
Fin
23. Leer un nmero entero de tres dgitos y determinar cuntos dgitos primos tiene.
Programa determina_digitos_primos
Var
Entero: num, dig1, dig2, dig3, digsPrimos
Inicio
Escriba Introduzca un numero entero de tres digitos"
Lea num
Si num<0
num=num*(-1)
Si num>99 y num<1000
dig1=num/100
dig2= num1-(dig1*100) /10
dig3=num- [(num/10)*10]
Si dig1==1 O dig1==3 O dig1==5 O dig1==7 O dig1==9
digsPrimos=1
Si dig2==1 O dig2==3 O dig2==5 O dig2==7 O dig2==9
digsPrimos= digsPrimos+1
Si dig3==1 O dig3==3 O dig3==5 O dig3==7 O dig3==9
digsPrimos= digsPrimos+1
Escriba El numero tiene+digsPrimos+digitos primos
Sino
Escriba Numero no valido :Escriba numero de tres cifras
Fin_Si
Fin
24. Leer un nmero entero de tres dgitos y determinar cuntos dgitos pares tiene.
Programa determina_digitos_pares
Var
Entero: num, dig1, dig2, dig3, digsPares
Inicio
Escriba Introduzca un numero entero de tres digitos"
Lea num
Si num<0
num=num*(-1)
Si num>99 y num<1000
dig1=num/100
dig2= num-(dig3*100) /10
dig3=num- [(num/10)*10]
Si dig1/2*2=dig1
digsPares=digsPares+1
Si dig2/2*2=dig2
digsPares=digsPares+1
Si dig3/2*2=dig3
digsPares=digsPares+1
Escriba El numero evaluado tiene+numPares+numeros pares
Sino
Escriba Numero no valido: Escriba numero de tres cifras
Fin_Si
Fin
25. Leer un nmero entero de tres dgitos y determinar si alguno de sus dgitos es igu
al a la suma de los otros dos.
Programa determina_digito_sumadedos
Var
Entero: num, dig1, dig2, dig3
Inicio
Escriba Introduzca un numero entero de tres digitos"
Lea num
Si num<0
num=num*(-1)
Si num>99 y num<1000
dig1=num/100
dig2= num-(dig1*100) /10
dig3=num-[(num/10)*10]
Si dig1+dig2==dig3 O dig2+dig3==dig1 O dig1+dig3==dig2
Escriba Uno de los dgitos es igual a la suma de los otros dos
Sino
Escriba Ninguno de los dgitos es igual a la suma de los otros dos
Fin_Si
Sino
Escriba Numero no valido: Escriba numero de tres cifras
Fin_Si
Fin
26. Leer un nmero entero de cuatro dgitos y determinar a cuanto es igual la suma d
e sus dgitos.
Programa Suma_cuatro digitos
Var
Entero: num, dig1a, dig1, dig2, dig3,dig4, sumaTOTAL
Inicio
Escriba Escriba nmero entero de cuatro digitos
Lea num
Si num==0
Escriba Numero invalido.
Si num<0
num1=num1*(-1)
Si num>999 y num<10000
dig4=num/1000
dig3= num-(dig4*1000) /100
dig2= num-(dig3*100) /10
dig1=num-{(num/10)*10}
sumaTOTAL= dig1+dig1+dig3+dig4
Escriba La suma de todos los dgitos del numero escrito es igual a+sumaTOTAL
Sino
Numero no valido: Favor Escriba un numero de tres dgitos
Fin_Si
Fin
27. Leer un nmero entero de cuatro dgitos y determinar cuntos dgitos pares tiene.
Programa determina_digitos_pares
Var
Entero: num, dig1, dig2, dig3, dig 4, digsPares
Inicio
Escriba Introduzca un numero entero de cuatro digitos"
Lea num
Si num<0
num=num*(-1)
Si num>999 y num<10000
dig1=num/1000
dig2= num-(dig3*1000) /100
dig3= num-(dig3*100) /10
dig4=num- [(num/10)*10]
Si dig1/2*2=dig1
digsPares=digsPares+1
Si dig2/2*2=dig2
digsPares=digsPares+1
Si dig3/2*2=dig3
digsPares=digsPares+1
Si dig4/2*2=dig4
digsPares=digsPares+1
Escriba El numero evaluado tiene+numPares+numerosPares
Sino
Escriba Numero no valido: Escriba numero de tres cifras
Fin_Si
Fin
28. Leer un nmero entero menor que 50 y positivo y determinar si es un nmero primo
.
Programa determina_si_Primo
Var
Entero: num,
Inicio
Escriba Introduzca un numero entero de cuatro dgitos"
Lea num
Si num<0
num=num*(-1)
Fin_Si
Si num<50
Si num==2 O num==3 O num==5 O num== 7 O num==11 O num==13 O num==17 O num==19 O
num==23 O num==29 O num==31 num==37 O num==41 O num==43 O num==47
Escriba ES PRIMO
Sino
Escriba NO ES PRIMO
Fin_si
Fin _Si
Fin _ si
29. Leer un nmero entero de cinco dgitos y determinar si es un nmero capico. Ej. 156
51,
59895.
Programa Capicuo
Var
Entero: num, dig1, dig2, dig3, dig4, dig5
Inicio
Escriba Introduzca un numero entero de cinco digitos"
Lea num
Si num<0
num =num*(-1)
Fin Si
Si num>9999 y num<100000
Dig5=num/10000
Dig4=num-(dig5*10000)/1000
Dig3= num-(dig4*1000) /100
Dig2= num-(dig3*100) /10
Dig1=num- [(num/10)*10]
Si dig5==dig1 y Dig4==dig2
Escriba El numero es capico
Sino
Escriba El numero no es capico
Fin_Si
Sino
Escriba numero invalido: Introduzca un numero entero de cinco digitos"
Fin_Si
31. Leer un nmero entero y determina si es igual a 10.
Programa igual_diez
Var
Entero: num
Inicio
Escriba Introduzca un numero entero "
Lea num
Si num==10
Escriba numero es igual a diez
Sino
Escriba numero es distinto a diez
Fin_si
Fin
32. Leer un nmero entero y determinar si es mltiplo de 7.
Programa multiplo_siete
Var
Entero: num
Inicio
Escriba Introduzca un numero entero "
Lea num
Si num/7*7=num
Escriba numero es multiplo de siete
Sino
Escriba numero no es multiplo de siete
Fin_si
Fin
33. Leer un nmero entero y determinar si termina en 7.
Programa termina_enSiete
Var
Entero: num, lastDig
Inicio
Escriba Introduzca un numero entero "
Lea num
lastDig= num-[(num/10)*10]
Si lastDig==7
Escriba numero Termina en 7
Sino
Escriba numero NO termina en 7
Fin_si
Fin
34. Leer un nmero entero menor que mil y determinar cuntos dgitos tiene.
Programa Contar_digitos
Var
Enteros: num, numDigitos
Inicio
Escriba Introduzca un numero entero "
Lea num
Si num<0
Num=num*(-1)
Fin_si
Si num>0 y num<1000
Si num/10=0
numDigitos= 1
sino
Si num/100=0
numDigitos= 2
sino
numDigitos=3
Fin_si
Fin_Si
Escriba el numero de digitos es+numDigitos
Sino
Escriba Numero invalido. Introduzca un numero de tres dgitos valido
Fin si
Fin
35. Leer un nmero entero de dos dgitos, guardar cada dgito en una variable diferent
e y luego mostrarlas en pantalla.
Programa Separar_digitos
Var
Entero: num, dig1, dig2
Inicio
Escriba Escriba un nmero entero
Lea num1
Si num==0
Escriba numero escrito es cero, Favor introducir numero valido
Sino
Si num<0
Num=num*(-1)
Fin_Si
Si num>0 y num<100
Dig1= num/10
Dig2=num- [(num/10)*10]
Escriba El primer digito es+dig1
Escriba El Segundo digito es+dig2
Sino
Escriba numero invalido. Escriba un numero de dos dgitos
Fin Si
Fin
36. Leer un nmero entero de 4 dgitos y determinar si tiene ms dgitos pares o impares
.
Programa pares_o_impares
Var
Entero: num, dig1, dig2, dig3, dig4, digsPares, digsImpares
Inicio
Escriba Porfavor escriba un numero entero de cuatro dgitos para evaluarlo
Lea num
Si num==0
Escriba El cero no es un numero valido
Sino
Si num<0
num=num*(-1)
Fin si
Si num>999 y num<10000
Dig4=num/1000
Dig3=num/100
Dig2=num/10
Dig1=num- [(num/10)*10]
Si dig4/2*2==dig4
digsPares=digsPares+1
Sino
disgsImpares=digsImpares+1
Si dig3/2*2==dig3
digsPares=digsPares+1
Sino
disgsImpares=digsImpares+1
Si dig2/2*2==dig2
digsPares=digsPares+1
Sino
disgsImpares=digsImpares+1
Si dig1/2*2==dig1
digsPares=digsPares+1
Sino
disgsImpares=digsImpares+1
Si digsPares>digsImpares
Escriba el numero tiene ms numero pares que impares
Si digsPares<digsImpares
Escriba el numero tiene ms dgitos pares que impares
Si digsPares==digsImpares
Escriba El numero tiene tantos numeros pares como impares
Fin Si
Fin
37. Leer dos nmeros enteros y determinar cul es mltiplo de cul.
Programa cualEsMultiplo
Var
Entero
num1, num2,
Inicio
Escriba Escriba dos numeros enteros
Lea num1
Lea num2
Si num1/num2*num2 =num1
Escriba Primer numero es mltiplo del segundo
Si num2/num1*num1 =num2
Escriba Segundo numero es mltiplo del primero
Sino
Escriba Ninguno de los nmeros es mltiplo el uno del otro
Fin
38. Leer tres nmeros enteros y determinar si el ltimo dgito de los tres nmeros es ig
ual.
Programa lastDigs_iguales
Var
Enteros: num1, num2, num3, lastDig1, lastDig2, lastDig3
Inicio
Escriba Introduzca los tres nmeros enteros a evaluar
Lea num1
Si num1<0
Num1=num1*(-1)
Fin si
Lea num2
Si num2<0
num2=num2*(-1)
Fin si
Lea num3
Si num3<0
num3=num3*(-1)
Fin si
lastDig1=num1-[(num1/10)*10]
lastDig2=num2-[(num2/10)*10]
lastDig3=num3- [(num3/10)*10]
Si lastDig1==lastdig2 y lastDig2==lastDigi3 y lastDig1==lastDig3
Escriba Los ltimos dgitos de los nmeros son iguales
Sino
Escriba Los ltimos dgitos de los nmeros son diferentes
Fin
39. Leer tres nmeros enteros y determina si el penltimo dgito de los tres nmeros es
igual.
Programa PenDigs_iguales
Var
Entero: num1, num2, num3, penDig1, penDig2, penDig3
Inicio
Escriba Introduzca los tres nmeros enteros a evaluar
Lea num1
Lea num2
Lea num3
penDig1= (num1/10)- [(num1/10)/10*10]
penDig2 =(num2/10)- [(num2/10)/10*10]
penDig3=(num3/10)- [(num3/10)/10*10]
Si penDig1==penDig2 y penDig2==penDig3
Escriba Los Penultimos digitos de los numeros son iguales
Sino
Escriba Los penltimos dgitos de los nmeros son diferentes
Fin
40. Leer dos nmeros enteros y si la diferencia entre los dos es menor o igual a 1
0 entonces
mostrar en pantalla todos los enteros comprendidos entre el menor y el mayor de
los nmeros ledos.
Programa Desplegar_numsEntreDiferencia
Var
Enteros: num1, num2,numeroMayor, numeroMenor, diferencia,contador
Inicio
Escriba Por favor introduzca dos numeros enteros
Lea num1
Lea num2
Si num1>num2
numeroMayor=num1
numeroMenor=num2
Si num2>num1
numeroMayor=num2
numeroMenor=num1
diferencia=numeroMayor-NumeroMenor
Si diferencia<=10
Escriba numMenor
Contador=numMenor+1
Si contador ==numeroMayor
Escriba numeroMayor
Sino
Escriba contador
Contador=contador+1
Si contador ==numeroMayor
Escriba numeroMayor
Sino
Escriba Contador
Contador=contador+1
Si contador ==numeroMayor
Escriba numeroMayor
Sino
Escriba Contador
Contador=contador+1
Si contador ==numeroMayor
Escriba numeroMayor
Sino
Escriba Contador
Contador=contador+1
Si contador ==numeroMayor
Escriba numeroMayor
Sino
Escriba Contador
Contador=contador+1
Si contador ==numeroMayor
Escriba numeroMayor
Sino
Escriba Contador
Contador=contador+1
Si contador ==numeroMayor
Escriba numeroMayor
Sino
Escriba Contador
Contador=contador+1
Si contador ==numeroMayor
Escriba numeroMayor
Sino
Escriba Contador
Contador=contador+1
Si contador ==numeroMayor
Escriba numeroMayor
Sino
Escriba Contador
Contador=contador+1
Fin_Si
Fin_Si
Fin_Si
Fin_Si
Fin_Si
Fin_Si
Fin_Si
Fin_Si
Fin_Si
Fin_Si
Sino
Escriba La diferencia entre los dos numeros sobrepasa al numero diez
Fin_Si
Fin
41. Leer dos nmeros enteros y determinar si la diferencia entre los dos es un nmer
o primo.
Programa diferencia_prima
Var
Entero:Num1, num2,
Natural:diferencia
Inicio
Escriba escriba dos nmeros enteros
Lea num1
Lea num2
Si num1==0 o num2==0
Escriba error al leer nmeros. Por favor introduzca nmeros validos
Sino
diferencia=num1-num2
Si diferencia<0
diferencia=diferencia*(-1) //Usamosel teorema de Fermat para nums. Primos
Si RESTO de (2diferencia-2)/diferencia==0
Escriba La diferencia de los numeros evaluados da un numero Primo
Sino
Escriba La diferencia de los nmeros evaluados NO da un numero primo
Fin_si
Fin si
Fin
42. Leer dos nmeros enteros y determinar si la diferencia entre los dos es un nmer
o par.
Programa diferencia_es_Par
Var
Entero:
Num1, num2, diferencia
Inicio
Escriba Escriba dos nmeros enteros
Lea num1
Lea num 2
Diferencia=num1-num2
Si diferencia/2*2==diferencia
Escriba La diferencia de los nmeros evaluados es un numero Par
Sino
Escriba La diferencia entre los nmeros evaluados es un numero Impar
Fin_Si
Fin
43. Leer dos nmeros enteros y determinar si la diferencia entre los dos es un nmer
o divisor exacto de alguno de los dos nmeros.
Programa diferencia_divisor_exacto
Var
Entero: num1, num2, diferencia
Inicio
Escriba Escriba dos nmeros enteros
Lea num1
Lea num2
Si num1>num2
diferencia=num1-num2
Si num2>num1
diferencia=num2-num1
Si RESTO de num1/diferencia==0 O RESTO de num2/diferencia==0
Escriba Diferencia entre ambos nmeros es divisor de uno de los nmeros
Sino
Escriba Diferencia entre ambos numeros NO es divisor de ninguno de los numeros
Fin_Si
Fin
44. Leer un nmero entero de 4 dgitos y determinar si el primer dgito es mltiplo de a
lguno de los otros dgitos.
Programa FirstDig_multiplo_otro
Var
Entero: num, dig1, dig2, dig3, dig4
Inicio
Escriba Favor introduzca un numero entero de cuatro digitos
Lea num
Si num<0
Num=num*(-1)
Si num>999 y num<10000
dig4=num/1000
dig3=num/100
dig2=num/10
dig1=num- [(num/10)*10]
Si dig1/dig4*dig4==dig1
Escriba el Primer digito es mltiplo del cuatro digito.
Sino
Si dig1/dig3*dig3==dig1
Escriba el Primer digito es mltiplo del tercer digito.
Sino
Si dig1/dig2*dig2==dig1
Escriba el Primer digito es mltiplo del Segundo digito.
Sino
Escriba El primer digito no es mltiplo de ninguno de los otros digitos
Fin_Si
Fin_Si
Sino
Escriba numero invalido. Escriba un numero de 4 cifras
Fin_Si
Fin
45. Leer un nmero entero de 2 dgitos y si es par mostrar en pantalla la suma de su
s dgitos, si es primo y menor que 10 ERROR EN ESTE MANDATO:NO HAY NUMEROS DE DOS
DIGITOS MENORES QUE DIEZ mostrar en pantalla su ltimo dgito y si es mltiplo de 5 y
menor que 30 mostrar en pantalla el primer dgito.
Programa numero_dos_digitos
Var:
Entero
Num1, dig1, dig2, sumaDigs
Programa
Escriba Porfavor escriba un numero entero de cuatro dgitos para evaluarlo
Lea num
Si num==0
Escriba El cero no es un numero valido
Sino
Si num<0
num=num*(-1)
Fin si
Si num>9 y num<100
Dig2=num/10
Dig1=num- [(num/10)*10]
Si num/2*2==num
Escriba Numero es Par
Si num==11 O num==13 O O num==17 O num==19
Escriba El ultimo digito del numero es+dig1
Si num/5*5==num y num<30
Escriba El primer digito del numero es+dig2
Fin
46. Leer un nmero entero de 2 dgitos y si terminar en 1 mostrar en pantalla su pri
mer dgito, si termina en 2 mostrar en pantalla la suma de sus dgitos y si termina
en 3 mostrar en pantalla el producto de sus dos dgitos.
Progrma numero_dosDigs_segundo
Var
Num, dig1, dig2, sumaDigs, prioductoDigs
Inicio
Escriba Porfavor escriba un numero entero de cuatro dgitos para evaluarlo
Lea num
Si num==0
Escriba El cero no es un numero valido
Sino
Si num<0
num=num*(-1)
Fin si
Si num>9 y num<100
dig2=num/10
dig1=num- [(num/10)*10]
sumaDigs=dig1+dig2
productoDigs=dig1*dig2
Si dig1==1
Escriba El Primer digito desde la izquierda del numero es +dig1
Si dig1==2
Escriba La suma de los digitos del numero essumaDigs
Si dig1==3
Escriba El producto de los digitos del numero esproductoDigs
Sino
Escriba numero Invalido. Escriba un numero de dos dgitos
Fin_si
Fin
47. Leer dos nmeros enteros y si la diferencia entre los dos nmeros es par mostrar
en pantalla la suma de los dgitos de los nmeros, si dicha diferencia es un nmero p
rimo menor que 10 entonces mostrar en pantalla el producto de los dos nmeros y si
la diferencia entre ellos terminar en 4 mostrar en pantalla todos los dgitos por
separado.
Programa dos_nums_enteros
Var
Num1, num2, diferencia
48. Leer un nmero entero y si es menor que 100 determinar si es primo.
Programa es_primo
Var:
Entero:Num
Programa
Escriba Por favor introduzca un numero entero para evaluarlo
Lea num
Si num<100
Si (2num-2)/num*num==(2num-2)
Escriba El numero evaluado es primo
Sino
Escriba El numero evaluado no es primo
Fin_Si
Sino
Escriba El numero evaluado no es menor que Cien
Fin_si
Fin
49. Leer un nmero entero y si es mltiplo de 4 determinar si su ltimo dgito es primo.
Programa es_multiplo_cuatro
Var
Entero:
Num, dig1, dig2
Inicio
Escriba Por favor, escriba el numero entero que desea Evaluar
Lea num
Si num==0
Escriba Numero escrito es igual a cero, por favor escriba otro numero valido
Sino
Si num<0
Num=num*(-1)
Fin_si
dig2=num/10
dig1=num- [(num/10)*10]
Si num/4*4==num
Si 2dig1-2/dig1*dig1=2dig1-2
Escriba El ultimo digito de este numero es primo
Sino
Escriba el ultimo digito de este numero no es primo
Fin Si
Sino
Escriba este numero no es mltiplo de cuatro
Fin Si
Fin si
Fin
50. Leer un nmero entero y si es mltiplo de 4 mostrar en pantalla su mitad, si es
mltiplo de 5 mostrar en pantalla su cuadrado y si es mltiplo e 6 mostrar en pantal
la su primer dgito. Asumir que el nmero no es mayor que 100.
Programa multiplo_cuatroCicoOSeis
Var
Entero: num1, mitad, cuadrado, dig1
Inicio
Escriba Por favor, escriba el numero entero que desea Evaluar
Lea num
Si num==0
Escriba Numero escrito es igual a cero, por favor escriba otro numero valido
Sino
Mitad =num/2
Cuadrado= num*num
dig1=num/10
Si num/4*4==num
Escriba Este numero es mltiplo de cuatro y su mitad es+mitad
Si num/5*5==num
Escriba Este numero es mltiplo de cinco y su cuadrado es+cuadrado
Si num/6*6==num
Escriba Este numero es mltiplo de seis y su primer digito es+dig1
Fin _ si
FIN
Ejercicios Cap 8
Leer un nmero entero y mostrar todos los enteros comprendidos entre 1 y el nmero l
edo.
Programa leer_yDesplegar_hasta
Variables
Enteros: num, aux
Inicio
Escriba Digite un numero entero
Lea num
Para aux=1 hasta num (paso 1)
Escriba aux
Fin_Para
2. Leer un nmero entero y mostrar todos los pares comprendidos entre 1 y el nmero
ledo.
Programa mostrar_impares
Variables
Entero: num, aux
Inicio
Escriba digite un numero
Lea num
aux =1
Haga
Escriba aux
aux = aux+2
Hasta aux>=num
Fin_Haga_hasta
Fin
3. Leer un nmero entero y mostrar todos los divisores exactos del nmero comprendid
os entre 1 y el nmero ledo.
Programa mostrar_divisor
Variable
Entero: num, divisor
Inicio
Escriba digite un numero
Lea num
Si num<0
num = num*(-1)
divisor=1
haga
Si num/divisor*divisor=num
Escriba divisor
Fin_si
divisor=divisor+1
hasta
divisor=num
Fin_haga_hasta
Fin
4. Leer dos nmeros y mostrar todos los enteros comprendidos entre ellos.
Programa leer_mostrar_dos
Variables
Enteros: num1,num2, aux
Inicio
Escriba Digite un numero entero
Lea num1
Si num1
Escriba Digite otro numero entero
Lea num2
Si num1>num2
aux=num2
Escriba Los nmeros comprendidos entre las dos cifras evaluadas son:
Haga
Escriba aux
aux=aux+1
Hasta
aux==num1
Fin_haga_hasta
Fin_Si
Si num2>num1
aux=num1
Escriba Los nmeros comprendidos entre las dos cifras evaluadas son:
Haga
Escriba aux
aux=aux+1
Hasta
aux==num2
Fin_haga_hasta
Fin_Si
Fin
5. Leer dos nmeros y mostrar todos los nmeros terminados en 4 comprendidos entre e
llos.
Programa desplegar_siTermina_en_cuatro
Variables
Enteros: num1,num2,lastDig, numeroIntermedio
Inicio
Escriba digite dos numeros enteros
Lea num1
Lea num2
Si num1>num2
numeroIntermedio=num2
mientras numeroIntermedio<=num1
Si numeroIntermedio -{ (numeroIntermedio /10) *10}=4
Escriba numeroIntermedio
Fin_Si
numeroIntermedio=numeroIntermedio+1
Fin_mientras
Fin_Si
6. Leer un nmero entero de tres dgitos y mostrar todos los enteros comprendidos en
tre 1 y cada uno de los dgitos.
Progrma uno_a_digito
Variables
Enteros: num, dig, probador, aux
Programa
Escriba Digite un numero entero de tres dgitos
Lea num
probador=num
Si probador<=0
pobador=probador*(-1)
Si probador>999 o probador<100
Escriba Numero Invalido, digitar un numero de tres cifras
Sino
Si num<0
dig= num +{ (num /10) *10} aux=1
mientras aux>=dig
Escriba Los numeros comprendidos entre el uno y el primer digito son+aux
aux=aux-1
Fin_Mientras
dig =num+(dig*100/10)
aux=1
mientras aux>=dig
Escriba Los numeros comprendidos entre el uno y el Segundo digito son+aux
aux=aux-1
Fin_Mientras
dig =num/100
aux=1
mientras aux>=dig
Escriba Los nmeros comprendidos entre el uno y el Tercer digito son+aux
aux=aux-1
Fin_Mientras
Si num>0
dig= num -{ (num /10) *10} aux=1
mientras aux<=dig
Escriba Los numeros comprendidos entre el uno y el primer digito son+aux
aux=aux+1
Fin_Mientras
dig = num-(dig*100/10)
aux=1
mientras aux<=dig
Escriba Los nmeros comprendidos entre el uno y el Segundo digito son+aux
aux=aux+1
Fin_Mientras
dig =num/100
aux=1
mientras aux<=dig
Escriba Los nmeros comprendidos entre el uno y el Tercer digito son+aux
aux=aux+1
Fin_Mientras
Fin Si
Fin
7. Mostrar en pantalla todos los enteros comprendidos entre 1 y 100.
Programa uno_cien
Variables
Entero: num, aux
Inicio
Para aux=1 hasta 100 pasa1
Escriba numero+aux
Fin_para
Fin
8. Mostrar en pantalla todos los pares comprendidos entre 20 y 200.
Programa pares_hastaDoscientos
Variables
Enteros: num, aux
Inicio
Para aux=2 hasta 200 (pasa 2)
Escriba aux
Fin_Para
Fin
9. Mostrar en pantalla todos los nmeros terminados en 6 comprendidos entre 25 y 2
05.
Programa Terminados en seis
Variables
Entero: num, lastDig
Inicio
Para num=25 hasta 205 (pasa1)
lastDig=num-(num/10*10)
Si lastDig==6
Escriba num
Fin_si
Fin_Para
Fin
10. Leer un nmero entero y determinar a cunto es igual la suma de todos los entero
s
comprendidos entre 1 y el nmero ledo.
Programa suma_hasta_num
Var
Entero: num, suma, proxNum
Inicio
Escriba Digite un numero entero
Lea num
Si num<0
Haga
suma=suma+proxNum
proxNum=proxNum-1
Hasta
proxNum=num
Fin_haga_hasta
Escriba La suma de todos los digitos comprendidos entre el uno y el numero introd
ucido es+suma
Fin_Si
Si num>0
Haga
suma=suma+proxNum
proxNum=proxNum+1
Hasta
proxNum=num
Fin_haga_hasta
Escriba La suma de todos los dgitos comprendidos entre el uno y el numero introduc
ido es+suma
Fin_si
Si num==0
Escriba La suma de todos los dgitos comprendidos entre el uno y el numero introduc
ido es 1
Fin_Si
Fin
11. Leer un nmero entero de dos dgitos y mostrar en pantalla todos los enteros com
prendidos
entre un dgito y otro.
Programa enteros_entre_dosDigitos
Variables
Enteros: num1, dig1, dig2, aux
Inicio
Escriba Digite un numero entero de dos cifras
Lea num
Si num<0
Num=num*(-1)
Si num<10 o num>99
Escriba El numero digitado no es de dos cifras. Numero invalido
Sino
dig1=num-(num/10*10)
dig2=num/10
Si dig2<dig1
aux=dig2
Mientras aux<=dig1
Escriba aux
aux=aux+1
Fin_Mientras
Fin_si
Si dig1<dig2
aux=dig1
Mientras aux<=dig2
Escriba aux
aux=aux+1
Fin_Mientras
Fin_si
Fin_si
Fin
12. Leer un nmero entero de 3 dgitos y determinar si tiene el dgito 1.
Programa tiene_uno
Variables
Entero: num, dig
Inicio
Escriba digite un numero de tres digitos
Lea num
Si num<0
Num=num*(-1)
Si num>100 o num<10
Escriba numero digitado no es de tres cifras. Numero invalido
Sino
dig=num/100
Si dig==1
Escriba el numero si tiene el digito 1
Sino
dig={num-(dig*100)}/10
Si dig==1
Escriba el numero si tiene el digito 1
Sino
dig=num-(num/10*10)
Si dig==1
Escriba el numero si tiene el digito 1
Sino
Escriba EL NUMERO NO TIENE EL DIGITO 1
Fin_si
Fin_Si
Fin_Si
Fin_Si
Fin
13. Leer un entero y mostrar todos los mltiplos de 5 comprendidos entre 1 y el nme
ro ledo.
Programa multiplos_cinco
Variables
Enteros: num, aux
Inicio
Escriba Digite un numero entero
Lea num
Si num<0
Num=num*(-1)
Fin_Si
Si num==0
Escriba numero digitado es cero. Numero Invalido
sino
aux=1
Mientras aux<=num
Si aux/5*5==aux
Escriba aux
Fin_si
aux=aux+1
Fin_Mientras
Fin
14. Mostrar en pantalla los primeros 20 mltiplos de 3.
Programa multiplos_tres
Variables:
Entero: aux, counter
Inicio
Aux=1
Haga
Si aux/3*3=aux
Escriba aux
Counter=counter+1
Fin_Si
aux=aux+1
Hasta counter==20
Fin_haga_hasta
Fin
15. Escriba en pantalla el resultado de sumar los primeros 20 mltiplos de 3.
Programa suma_multiplos_tres
Variables:
Entero: aux, counter, suma
Inicio
Aux=1
suma=0
Haga
Si aux/3*3=aux
suma=suma+aux
counter=counter+1
Fin_Si
aux=aux+1
Hasta counter==20
Fin_haga_hasta
Escriba La suma de los primeros 20 mltiplos de tres es+suma
Fin
16. Mostrar en pantalla el promedio entero de los n primeros mltiplos de 3 para u
n nmero n
ledo.
Programa promedio_multiplos_tres
Variables
Enteros: num, suma, promedio, aux
Inicio
Escriba Digite un numero entero
Lea num
Si num>0
Num=num*(-1)
Fin_Si
Si num==0
Escriba numero digitado es cero. Numero Invalido
Fin_Si
aux=1
suma=0
Haga
Si aux/3*3=aux
counter=counter+1
suma=suma+aux
Fin_Si
aux=aux+1
Hasta counter==num
Fin_haga_hasta
promedio = suma/num
Escriba El promedio de los+num+primeros mltiplos de tres es+promedio
Fin
17. Promediar los x primeros mltiplos de 2 y determinar si ese promedio es mayor
que los y
primeros mltiplos de 5 para valores de x y y ledos.
Programa promedios_dos_cinco
Variables
Enteros: x, y, promedio, control, aux
Inicio
Escriba Digite el numero de primeros multiplos de dos que quiere promediar
Lea x
Si x<=0
Escriba El numero digitado es invalido
Escriba Digite el numero de primeros multiplos de cinco con los que quiere compar
ar el promedio
Lea y
Si y<=0
Escriba El numero digitado es invalido
Sino
Haga
Si aux/2*2==aux
contador=contador+1
promedio=aux+promedio
Fin_Si
aux=aux+1
Hasta contador==x
Fin_haga_hasta
promedio=promedio/x
aux=0
contador=0
Haga
auxiliar+1
Si aux/5*5==aux
contador=contador+1
Si aux>promedio
Escriba Promedio de primeros x mltiplos de dos es MENOR que alguno de los +y+
primeros mltiplos de 5
control=2
Fin _Si
Hasta contador==y o control==2
Fin_haga_hasta
Si control><2
Escriba Promedio de primeros x mltiplos de dos es MAYOR que uno de los +y+
primeros mltiplos de 5
Fin_Si
Fin
18. Leer dos nmeros entero y mostrar todos los mltiplos de 5 comprendidos entre el
menor y el
mayor.
Programa multiplo_cinco
Variables
Enteros= num1, num2, aux
Inicio
Escriba Digite un numero entero
Lea num1
Si num1<0
Num1=num1*(-1)
Fin_Si
Escriba Digite otro numero entero
Lea num2
Si num2<0
Num2=num2*(-1)
Fin_Si
Si num1==num2
Escriba Ambos nmeros son iguales, no se puede realizar la operacin
Sino
Si num1>num2
Aux=num2
Mientras aux<=num1
Si aux/5*5=aux
Escriba aux
Fin_Si
Aux=aux+1
Fin_si
Si num2>num1
Aux=num1
Mientras aux<=num2
Si aux/5*5=aux
Escriba aux
Fin_Si
Aux=aux+1
Fin_si
Fin_Si
Fin
19. Leer un nmero entero y determinar si es primo.
Programa es_primo
Var
Entero: num, aux, control
Inicio
Escriba digite un numero entero
Lea num
Si num<0
Num=num*(-1)
Fin_Si
aux=2
Haga
Si num/aux*aux=num
Escriba El numero digitado NO es primo
control=5
Fin_Si
aux= aux+1
Hasta aux==num o control==5
Fin_Haga_hasta
Si control><5
Escriba El numero digitado es primo
Fin_Si
Fin
20. Leer un nmero entero y determinar cuntos dgitos tiene.
Programa cuenta_digitos
Variables:
Entero: num, digitos
Inicio
Escriba Digite un numero entero
Lea num
Si num<0
num=num*(-1)
Fin_Si
Si num==0
Escriba El numero digitado es cero. Digite un numero valido
Sino
digitos=0
haga
num/10
digitos=digitos+1
hasta
num=0
Fin_Haga_hasta
Escriba El numero de digitos del numero digitado es+digitos
Fin_Si
Fin
21. Leer un nmero entero y determinar a cunto es igual al suma de sus dgitos.
Programa suma_digitos
Variables
Entero:
Num, digito, suma
Inicio
Escriba Digite un numero entero
Lea num
Si num==0
Escriba El numero digitado es cero, Por favor digite un numero valido
Si num<0
Num=num*(-1)
Fin_Si
digito= num-(num/10*10)
suma = digito
haga
num=(num-dig)/10
digito= num-(num/10*10)
suma=suma+digito
hasta num=<0
Fin_haga_hasta
Escriba la suma de los digitos del numero digitado es igual a+suma
Fin_Si
22. Leer un nmero entero y determinar cuntas veces tiene el dgito 1.
Programa cuantos_uno
Variables
Entero
Num, contador, divisor digito
Inicio
Escriba Digite el numero entero que quiere evaluar
Lea num
Si num==0
Escriba El numero digitado es cero, Por favor digite un numero valido
Si num<0
Num=num*(-1)
Fin_Si
Digito= num-(num/10*10)
Contador=0
Mientras num>0
Si digito==1
Contador=contador+1
Fin_Si
num=(num-dig)/10
digito= num-(num/10*10)
Fin_Si
23. Leer un nmero entero y determinar si la suma de sus dgitos es tambin un nmero pr
imo.
Programa suma_digitos
Variables
Entero:
Num, digito, suma, aux, control
Inicio
Escriba Digite un numero entero
Lea num
Si num==0
Escriba El numero digitado es cero, Por favor digite un numero valido
Si num<0
Num=num*(-1)
Fin_Si
digito= num-(num/10*10)
suma = digito
haga
num=(num-dig)/10
digito= num-(num/10*10)
suma=suma+digito
hasta num=<0
Fin_haga_hasta
aux=2
control=0
Mientras aux<suma o control><7
Si suma/aux*aux=suma
Escriba La suma de los dgitos
del numero no es primo
control=7
sino
aux=aux+1
Fin_Si
Fin_mientras
Si control><
Escriba La suma de los digitos del numero ES PRIMO
Fin_Si
Fin
24. Leer un nmero entero y determinar a cunto es igual al suma de sus dgitos pares.
Programa suma_digitos pares
Variables
Entero: num, digito, suma
Inicio
Escriba digite el numero entero que desee evaluar
Lea num
Si num<0
num=num*(-1)
Fin_Si
haga
Digito=num-(num/10*10)
Si digito/2*2==digito
suma=suma+digito
Fin_si
Num=num-digito/10
Hasta num<=0
Fin_haga_hasta
Escriba la suma de los digitos pares del numero evaluado es+suma
Fin
25. Leer un nmero entero y determinar a cunto es igual el promedio entero de sus dg
itos.
Programa promedio-digitos
Variables
Num, digito, suma, numDigitos, promedio
Inicio
Escriba Digite un numero entero
Lea num
Si num<0
num=num*(-1)
Fin_Si
Si num==0
Escriba numero digitado es cero. Digite un numero valido
Sino
Haga
digito=num-(num/10*10
suma=suma+digito
numDigitos=numDigitos+1
num=(num-dig)/10
Hasta
num<=0
Fin_haga_hasta
promedio =suma/numDigitos
Escriba el promedio entre los dgitos de el numero evaluado es+promedio
Fin_si
Fin
26. Leer un nmero entero y determinar cul es el mayor de sus dgitos.
Programa mayor_digito
Variables
Entero: num, digito, mayor
Inicio
Escriba Digite un numero entero
Lea num
Si num<0
num=num*(-1)
Fin_Si
Si num==0
Escriba numero digitado es cero. Digite un numero valido
Sino
digito=num-(num/10*10)
mayor=digito
Mientras num>0
Si digito>mayor
mayor=digit
Fin Si
num=num-digito/10 digito=num-(num/10*10)
Fin_Mientras
Escriba El digito de mayor valor de los digitos del numero es +mayor
Fin
27. Leer 2 nmeros enteros y determinar cul de los dos tiene mayor cantidad de dgito
s.
Programa mas_digitos
Variables: num1, num2,digitos, numDigitos1, numDigitos2
Inicio
Escriba Digite un numero entero
Lea num1
Si num<0
Num1=num1*(-1)
Fin_Si
Si num1==0
Escriba numero digitado es cero. Digite un numero valido
Escriba Digite Otro numero entero
Lea num2
Si num2<0
Num2=num2*(-1)
Fin_Si
Si num2==0
Escriba numero digitado es cero. Digite un numero valido
digitos =1
Mientras num1>0
digitos=digito+1
Num/10
Fin_Mientras
numDigitos1=digitos
digitos=0
Mientras num1>0
Digito=digito+1
Num/10
Fin_Mientras
numDigitos2=digitos
Si numDigitos1>numDigitos2
Escriba El numero de dgitos del primer numero digitado es mayor que el numero de dg
itos del segundo
Si numDigitos2>numDigitos1
Escriba El numero de dgitos del segundo numero digitado es mayor que el numero de
dgitos del primero
Si numDigitos2==numDigitos1
Escriba El numero de dgitos del primer numero digitado es igual que el numero de dg
itos del segundo
Fin
28. Leer 2 nmeros enteros y determinar cual de los dos tiene mayor cantidad de dgi
tos primos.
Programa mas_digitos_primos
Variables
Enteros: num1, num2, primos1, primos2, digito, aux
Inicio
Escriba Digite un numero entero
Lea num1
Si num<0
Num1=num1*(-1)
Fin_Si Si num1==0
Escriba numero digitado es cero. Digite un numero valido
Escriba Digite Otro numero entero
Lea num2
Si num2<0
Num2=num2*(-1)
Fin_Si
Si num2==0
Escriba numero digitado es cero. Digite un numero valido
Haga
digito =num1-(num1/10*10)
aux=2
control=0
mientras aux<digito y control><5 Si digito/aux*aux=digito
control=5
Fin_Si
aux=aux+1
Fin_mientras
Si control><5 primos1=primos1+1
num1 =num1-digito/10
Hasta
num1=<0
Fin_haga_hasta
Haga
digito =num2-(num2/10*10)
aux=2
control=0
mientras aux<digito y control><5 Si digito/aux*aux=digito
control=5
Fin_Si
aux=aux+1
Fin_mientras
Si control><5 primos2=primos2+1 num2 =num2-digito/10
num2=<0
Fin_haga_hasta
Si primos1>primos2
Escriba El primer numero es el que tiene mayor cantidad de digitos primos
Si primos2>primos1
Escriba El segundo numero es el que tiene mayor cantidad de digitos primos
Fin
29. Leer un nmero entero y determinar a cunto es igual el primero de sus dgitos.
Programa primer digito
Variables
Entero: num, digito, aux
Programa
Escriba Digite un numero entero
Lea num
Si num<0
num=num*(-1)
Fin_Si
Si num==0
Escriba numero digitado es cero. Digite un numero valido
Fin_Si
Haga
digito=num- (num/10*10)
num=num-digito/10
Hasta num<=0
Fin_Haga_hasta
Escriba El primero de los dgitos de este numero es+digito
Fin
30. Leer un nmero entero y mostrar todos sus componentes numricos o sea aquellos p
ara
quienes el sea un mltiplo.
Programa multiplos
Variables
Numero, multiplo, auxiliar
Inicio
Escriba Digite un numero entero
Lea num
Si num<0
num=num*(-1)
Fin_Si
Si num==0
Escriba numero digitado es cero. Digite un numero valido
Fin_Si
Haga
Si num/aux*aux=num
Escriba aux
Fin_Si
aux=aux+1
Hasta
aux=num
Fin_haga_hasta
Fin
31. Leer nmeros hasta que digiten 0 y determinar a cunto es igual el promedio de l
os nmeros
terminados en 5.
Programa promedio-cincos
Variables
Enteros: num, digito, suma, promedio, contador
Inicio
Escriba Digite un numero entero
Lea num
Si num<0
num=num*(-1)
Fin_Si
Mientras num><0
digito= num-(num/10*10)
Si digito==5
Suma=suma+num
contador=contador+1
Fin Si
Escriba digite un numero entero
Lea num
Fin_Mientras
promedio =suma/contador
Escriba El promedio de los numeros terminados en cinco que se digitaron es +promed
io
Fin
32. Leer nmeros hasta que digiten 0 y determinar a cuanto es igual el promedio en
tero de los
nmero primos ledos.
Programa promedio_Primos
Variables
Enteros: num, digito, suma, promedio, contador, control
Inicio
Haga
Escriba Digite un numero entero
Lea num
Si num<0
num=num*(-1)
Fin_Si
aux=2
Mientras aux<num y control><5
Si num/aux*aux=num
control=5
Fin Si
aux =aux+1
Fin mientras
Si control><5
Suma=suma+num
contador=contador+1
Fin Si
Hasta
promedio =suma/contador
Escriba El promedio de los nmeros terminados en cinco que se digitaron es +promedio
Fin
33. Si 32768 es el tope superior para los nmeros entero cortos, determinar cul es
el nmero
primo mas cercano por debajo de l.
Programa primo_antes_numero
Variables
Enteros: num, aux, control, primo
Inicio
Para num=3 hasta 32768 (pasa 1)
aux=2
control =0
Mientras aux<num y control==0
Si num/aux*aux=num
control =5
Fin_Si
aux=aux+1
Fin_Mientras
Si control=0
primo=num
Fin Si
Fin_Para
Escriba El numero primo mas cercano a 32768 es+primo
Fin
34. Generar los nmeros del 1 al 10 utilizando un ciclo que vaya de 10 a 1.
Programa contando_inversa
Variables
Entero: aux, aux2
Inicio
Para aux=10 hasta 1 (Resta 1)
Para aux2=1 hasta 10 (pasa 1)
Escriba aux-aux2
Fin_para
Fin
35. Leer dos nmeros enteros y determinar a cunto es igual el producto mutuo del pr
imer dgito
de cada uno.
Programa primer digito
Variables
Entero: num1,num2, digito1, digito2, producto
Inicio
Escriba Digite un numero entero
Lea num1
Si num1<0
Num1=num1*(-1)
Fin_Si
Si num1==0
Escriba numero digitado es cero. Digite un numero valido
Fin_Si
Escriba Digite otro numero entero
Lea num2
Si num2<0
Num2=num2*(-1)
Fin_Si
Si num2==0
Escriba numero digitado es cero. Digite un numero valido
Fin_Si
Haga
digito1=num1- (num1/10*10)
num1=num1-digito1/10
Hasta
num1<=0
Fin_Haga_hasta
Haga
digito2=num2- (num2/10*10)
num2=num2-digito2/10
Hasta
num2<=0
Fin_Haga_hasta
Producto=digito1*digito2
Escriba El producto de los dos primeros digitos es +producto
Fin
36. Mostrar en pantalla la tabla de multiplicar del nmero 5.
Programa tabla_cinco
Variables
Entero: multiplicando, producto
Inicio
Para multiplicando=0 hasta 10
producto=5*multiplicando
Escriba 5x+multiplicando+=+producto
Fin
37. Generar todas las tablas de multiplicar del 1 al 10.
Programas tablas_hasta_diez
Variables:
Entero: multiplicando, multiplicador, producto
Inicio
Para multiplicando=1 hasta 10 (pasa1)
Para multiplicador=1 hasta 10 (pasa1)
Producto=multiplicando*multiplicador
Escriba multiplicando+x+multiplicador+=+producto
Fin_Para
Fin_Para
Fin
38. Leer un nmero entero y mostrar en pantalla su tabla de multiplicar.
Programa tabla
Variables
Entero: num, multiplicador, producto
Inicio
Escriba Digite un numero entero
Lea num
Si num<0
num=num*(-1)
Fin_Si
Si num==0
Escriba numero digitado es cero. Digite un numero valido
Fin_Si
Para multiplicador=1 hasta 10 (pasa1)
Producto=num*multiplicador
Escriba num+x+multiplicador+=+producto
Fin_Para
Fin
39. Se define la serie de Fibonacci como la serie que comienza con los dgitos 1 y
0 y va sumando
progresivamente los dos ltimos elementos de la serie, as:
0 1 1 2 3 5 8 13 21 34.......
Utilizando el concepto de ciclo generar la serie de Fibonacci hasta llegar o sob
repasas el nmero
10000.
Programa generador_fibonacci
Variables
Entero: num1, num2, digito
Inicio
Num1=0
Num2=1
Escriba num1
Escriba num2
Haga
Digito=num1+num2
Escriba digito
Num1=num2
Num2=digito
Hasta
digito>=10000
Fin_haga_hasta
Fin
40. Leer un nmero de dos dgitos y determinar si pertenece a la serie de Fibonacci.
Programa es_fibonacci
Variables
Entero:, cifra, num1, num2, digito
Inicio
Escriba Digite un numero entero
Lea cifra
Si cifra<0
cifra=cifra*(-1)
Si cifra>99 O cifra<10
Escriba Cifra invalida. Digite una cifra de dos dgitos
Num1=0
Num2=1
Haga
Digito=num1+num2
Num1=num2
Num2=digito
Si digito==cifra
Escriba Digito Pertenece a la serie Fibonnacci
Fin_si
Hasta
digito>=100 o digito==cifra
Fin_haga_hasta
Si digito><cifra
Escriba numero no pertenece a la serie Fibonnacci
Fin_Si
Fin
41. Determinar a cunto es igual la suma de los elementos de la serie de Fibonacci
entre 0 y 100.
Programa suma_fibonacci
Variables
Entero: num1, num2, digito, suma
Inicio
Num1=0
Num2=1
Haga
Suma=suma+digito2
Digito=num1+num2
Num1=num2
Num2=digito
Hasta
digito>=100
Fin_haga_hasta
Escriba La suma de los elementos de la serie Fibonnaci entre cero y diez es+suma
Fin
42. Determinar a cunto es igual el promedio entero de los elementos de la serie d
e Fibonacci
entre 0 y 1000.
Programa promedio_fibonacci
Variables
Entero: num1, num2, digito, suma, contador, promedio
Inicio
num1=0
num2=1
contador=2
Haga
Suma=suma+digito2
Digito=num1+num2
Num1=num2
Num2=digito
Contador=contador+1
Hasta
digito>=1000
Fin_haga_hasta
Promedio=suma/contador
Escriba El promedio entero de los elementos de la serie de Fibonacci entre 0 y 10
00 es+promedio
Fin
43. Determinar cuntos elementos de la serie de Fibonacci se encuentran entre 1000
y 2000.
Programa elementos_fibonacci
Variables
Entero: num1, num2, digito, contador
Inicio
num1=0
num2=1
Haga
Digito=num1+num2
Num1=num2
Num2=digito
Si dig>=1000 y dig<=2000
Contador=contador+1
Fin_Si
Hasta
digito>=2000
Fin_haga_hasta
Escriba El numero de elementos de la serie Fibonnacci entre 1000 y 2000 es+contado
r
Fin
44. Leer un nmero y calcularle su factorial.
Programa factorial
Variables
Entero: num, factorial, aux
Inicio
Escriba Digite un numero entero
Lea num
Si num<0
num=num*(-1)
Fin_Si
Si num==0
Escriba numero digitado es cero. Digite un numero valido
Fin_Si
Aux=num
Mientras aux>0
Factorial=factorial+aux
Aux-1
Fin_mientras
Escriba El factorial de numero digitado es +factorial
Fin
45. Leer un nmero y calcularle el factorial a todos los enteros comprendidos entr
e 1 y el nmero
ledo.
Programa factoriales
Variables
Entero: num, factorial, aux
Inicio
Escriba Digite un numero entero
Lea num
Si num<0
num=num*(-1)
Fin_Si
Si num==0
Escriba numero digitado es cero. Digite un numero valido
Fin_Si
Haga
Aux=num
factorial=0
Mientras aux>0
Factorial=factorial+aux
Aux-1
Fin_mientras
Escriba El factorial de numero+num+es+factorial
Num=num-1
Hasta
Num==0
Fin Haga_hasta
Fin
46. Leer un nmero entero y calcular el promedio entero de los factoriales de los
enteros
comprendidos entre 1 y el nmero ledo.
Programa factoriales
Variables
Entero: num, factorial, aux, suma,contador, promedio
Inicio
Escriba Digite un numero entero
Lea num
Si num<0
num=num*(-1)
Fin_Si
Si num==0
Escriba numero digitado es cero. Digite un numero valido
Fin_Si
Haga
Aux=num
factorial=0
Mientras aux>0
Factorial=factorial+aux
Aux-1
Fin_mientras
Suma=suma+factorial
Contador=contador+1
Num=num-1
Hasta
Num==0
Fin Haga_hasta
Promedio=suma/contador
Escriba el el promedio entero de los factoriales de los enteros comprendidos entr
e 1 y el nmero ledo es+promedio
Fin
47. Leer un nmero entero y calcular a cunto es igual la sumatoria de todos los fac
toriales de los
nmeros comprendidos entre 1 y el nmero ledo.
Programa suma_factoriales
Variables
Entero: num, factorial, aux, suma
Inicio
Escriba Digite un numero entero
Lea num
Si num<0
num=num*(-1)
Fin_Si
Si num==0
Escriba numero digitado es cero. Digite un numero valido
Fin_Si
Haga
Aux=num
factorial=0
Mientras aux>0
Factorial=factorial+aux
Aux-1
Fin_mientras
Suma=suma+factorial
Num=num-1
Hasta
Num==0
Fin Haga_hasta
Escriba la sumatoria de todos los factoriales de los nmeros comprendidos entre 1 y
el nmero ledo es+suma
Fin
Ejercicios Cap. 9
Algunas posibles soluciones a estos enunciados las puede encontrar en el Libro A
lgoritmos del
mismo autor.
1. Leer 10 enteros, almacenarlos en un vector y determinar en qu posicin del vecto
r est el
mayor nmero ledo.
Programa mayor_de_vector
Variables:
Enteros:
vector(10),ndice, mayor, posicion
Inicio
Escriba Digite 10 numeros enteros
Para indice=1 hasta 10 (pasa 1)
Lea Vector(indice)
Fin Para
mayor=0
posicion=0
Para indice=1 hasta 10 (pasa 1)
Si vector(indice)>mayor
mayor= vector(indice)
posicion=indice
Fin Si
Fin_Para
Escriba El numero ms alto de los digitados es+mayor+y se encuentra en la posicion+pos
icion
Fin
2. Leer 10 enteros, almacenarlos en un vector y determinar en qu posicin del vecto
r est el
mayor nmero par ledo.
Programa mayor_par
Variables
Enteros: vector(10), posicion, num_mayor, indice
Inicio
Escriba Digite un numero entero
Para indice=1 hasta 10 (pasa1)
Lea vector(indice)
Fin_para
num_mayor=0
posicion=0
Para ndice=1 hasta 10 (pasa1)
Si vector(indice)/2*2=vector(indice)
Si vector(indice)>num_mayor
Num_mayor=vector(indice)
Posicion=ndice
Fin_Si
Fin_Si
Fin_Para
Escriba El mayor numero par leido se encuentra en la posicion+posicion
Fin
3. Leer 10 enteros, almacenarlos en un vector y determinar en qu posicin del vecto
r est el
mayor nmero primo ledo.
Programa mayor_primo
Variables
Enteros: vector(10), posicion, num_mayor, indice
Inicio
Escriba Digite un numero entero
Para indice=1 hasta 10 (pasa1)
Lea vector(indice)
Fin_para
num_mayor=0 //Aplicamos el teorema de Fermat que declara que
posicion=0 // Si p es primo y a es algn nmero entero,
//entonces ap - a es divisible por p
Si {2^vector(indice)-2}/vector(indice)*vector(indice)= vector(indice)
Si vector(indice)>num_mayor
Posicion=indice
Num_mayor=vector(indice)
Fin_Si
Fin_Si
Fin_Para
Escriba El mayor numero primo ledo se encuentra en la posicion+posicion
Fin
4. Cargar un vector de 10 posiciones con los 10 primeros elementos de la serie d
e Fibonacci y
mostrarlo en pantalla.
Programa vector_fibonnacci
Variables: vector(10), indice
Inicio.
Vector(1)=0
Vector(2)=1
Para indice=3 hasta 10 (pasa1)
Vector(indice)=vector(indice-1)+vector(indice-2)
Fin_Para
Para indice=1 hasta 10 (pasa1)
Escriba Vector(indice)
Fin_para
Fin
5. Almacenar en un vector de 10 posiciones los 10 nmeros primos comprendidos entr
e 100 y
300. Luego mostrarlos en pantalla.
Programa 10 numsPrimos
Variables: vector(10), indice, aux
Inicio
indice=1
Mientras indice<10
Para num=100 hasta 300 (pasa1) //se deposita sucesivamente un numero para eval
uar
switch=3 //se resetea variable es o no primo a es primo
aux=2 //se chequea si el numero evaluado es divisible por
mientras aux<num y switch=3 //alguno de sus enteros menores,. Si es as, se p
ara la
Si num/aux*aux = num //la revisin y se altera una variable para que numero
switch=5 //no sea depositado en el vector
Fin_Si
aux=aux+1
Fin mientras
Si switch=3
Vector(indice)=num //si el numero no fue divisible por ningunos otros
Indice=indice+1 //se deposita en el vector
Fin_si
Fin_Mientras
Para indice=1 hasta 10 (pasa1)
Escriba Vector(indice)
Fin_Para
Fin
6. Leer dos nmeros enteros y almacenar en un vector los 10 primeros nmeros primos
comprendidos entre el menor y el mayor. Luego mostrarlos en pantalla.
Programa primos_entre_dos numeros
Variables:num1, num2, vector(10), indice, aux
Inicio
Escriba Digite 1 nmero entero
Lea num1
Escriba Digite otro nmero entero
Lea aux
Si num1>aux
Num2=aux
Si num1<aux
num2=num1
num1=aux
Fin_si
indice=1
Mientras indice<10
Para num1 hasta num2 (pasa1) //se deposita sucesivamente un numero para eval
uar
switch=3 //se resetea variable es o no primo a es primo
aux=2 //se chequea si el numero evaluado es divisible por
mientras aux<num y switch=3 //alguno de sus enteros menores,. Si es asi, se
para la
Si num/aux*aux = num //la revision y se altera una variable para que numero
switch=5 //no sea depositado en el vector
Fin_Si
aux=aux+1
Fin mientras
Si switch=3
Vector(indice)=num //si el numero no fue divisible por ningunos otros
Indice=indice+1 //se deposita en el vector
Fin_si
Fin_Mientras
Para indice=1 hasta 10 (pasa1)
Escriba Vector(indice)
Fin_Para
Fin
7. Leer 10 nmeros enteros, almacenarlos en un vector y determinar en qu posiciones
se
Encuentra el nmero mayor.
Programa dondeEstaMayor
Variables:
Entero: vector(10),V_posciones(10), ndice, indiceB
Inicio
Para indice=1 hasta 10
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
num_mayor=0
Para indice=1 hasta 10
Si vector(indice)>num_mayor
num_mayor=vector(indice)
Fin_para
Indice2=1
Para indice=1 hasta 10
Si vector(indice)==num_mayor
V_posicion(indice2)=indice
IndiceB=indiceB+1
Fin_Para
Escriba el numero mayor es+num_mayor y se encuentra en las posiciones:
Para indice=1 hasta 10
Escriba V_posicion(indice)
Fin_Para
Fin
8. Leer 10 nmeros enteros, almacenarlos en un vector y determinar en qu posiciones
se
encuentran los nmeros terminados en 4.
Programa terminados _ en_4
Variables:
Enteros: vector(10),dig,indice
Inicio
Para indice=1 hasta 10
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
Inicio
Para indice=1 hasta 10
dig=Vector(indice)-{vector(indice)/10*10}
Si dig==4
Escriba Un numero terminado en 4 es el+vector(indice)+y se encuentra en la posicio
n+indice
Fin_si
Fin_para
Fin_Para
9. Leer 10 nmeros enteros, almacenarlos en un vector y determinar cuntas veces est
repetido
el mayor.
Programa cuantas_veces_mayor
Variables:
Entero: vector(10), indice, mayor, contador
Inicio
Inicio
Para indice=1 hasta 10
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
mayor=0
contador=0
Inicio
Para indice=1 hasta 10
Si vector(indice)>mayor
mayor=vector(indice)
Fin_si
Fin_Para
Para indice=1 hasta 10
Si vector(indice)==mayor
Contador=contador+1
Fin_si
Fin_Para
Escriba el numero mayor es+mayor+y se repite+contador+veces
Fin
10. Leer 10 nmeros enteros, almacenarlos en un vector y determinar en qu posicione
s se
encuentran los nmeros con mas de 3 dgitos.
Programa tres_digitos
Variables:
Entero: vector(10), indice
Inicio
Para indice=1 hasta 10
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
Para indice=1 hasta 10
Si {vector(indice)/10}/10>0
Escriba en la posicion numero+indice+se encuentra un numero con mas de tres digitos
Fin_Si
Fin_Para
Fin
11. Leer 10 nmeros enteros, almacenarlos en un vector y determinar cuntos nmeros ti
enen, de
los almacenados all, tienen menos de 3 dgitos.
Programa menos_tres_digitos
Variables:
Entero:vector(10), indice, contador
Inicio
Para indice=1 hasta 10
Escriba Digite numero entero
Lea vector(indice)
Fin_Para+
contador=0
Para indice=1 hasta 10
Si {vector(indice)/10}/10=<0
contador=contador+1
Fin_Si
Fin_Para
Escriba La cantidad de nmeros con menos de tres dgitos en el vector es +contador
Fin
12. Leer 10 nmeros enteros, almacenarlos en un vector y determinar a cunto es igua
l el
promedio entero de los datos del vector.
Programa promedio
Variables:
Entero: vector (10), ndice, suma, promedio
Inicio
Para indice=1 hasta 10
Escriba Digite numero entero
Lea vector(indice)
Fin_Para+
suma=0
Para indice=1 hasta 10
Suma=suma+vector(indice)
Fin_Para
Promedio=suma/10
Escriba El promedio de los enteros almacenados es+promedio
Fin
13. Leer 10 nmeros enteros, almacenarlos en un vector y determinar si el promedio
entero de
estos datos est almacenado en el vector.
Programa promedio_en_vector
Variables:
Entero :vector (10), ndice, suma, promedio, switch
Inicio
Para indice=1 hasta 10
Escriba Digite numero entero
Lea vector(indice)
Fin_Para+
suma=0
Switch=22
Para indice=1 hasta 10
Suma=suma+vector(indice)
Fin_Para
Promedio=suma/10
Para indice=1 hasta 10
Si promedio==vector(indice)
Switch=5
Fin_si
Fin_Para
Si switch=5
Escriba El promedio de los datos almacenados en el vector es uno de los nmeros del
vector
Sino
Escriba El promedio de los datos almacenados en el vector NO es uno de los nmeros
del vector
Fin_Si
Fin
14. Leer 10 nmeros enteros, almacenarlos en un vector y determinar cuntas veces se
repite el
promedio entero de los datos dentro del vector.
Programa cuantos_promedios
Variables:
Entero: vector (10), ndice, suma, promedio, contador
Inicio
Para indice=1 hasta 10
Escriba Digite numero entero
Lea vector(indice)
Fin_Para+
suma=0
Contador=0
Para indice=1 hasta 10
Suma=suma+vector(indice)
Fin_Para
Promedio=suma/10
Para indice=1 hasta 10
Si promedio==vector(indice)
Contador=contador+1
Fin_si
Fin_Para
Escriba El promedio de los se repite+contador+numero de veces en el vector
Fin
15. Leer 10 nmeros enteros, almacenarlos en un vector y determinar cuntos datos al
macenados
son mltiplos de 3.
Programa cuantos_multiplos_tres
Variables:
Entero:vector (10), ndice,
Inicio
Para indice=1 hasta 10
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
contador=0
Para indice=1 hasta 10
Si vector(indice)/3*3=vector(indice)
Contador=contador+1
Fin_Para
Escriba El En este vector hay almacenados+contador+multiplos de tres
Fin
16. Leer 10 nmeros enteros, almacenarlos en un vector y determinar cules son los d
atos
almacenados mltiplos de 3.
Programa multiplos_tres
Variables:
Entero: vector (10), ndice,
Inicio
Para indice=1 hasta 10
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
Para indice=1 hasta 10
Si vector(indice)/3*3=vector(indice)
Escriba El dato almacenado en la poscion+indice+es+vector(indice)y es multiplo de tre
s
Fin_Si
Fin_Para
Fin
17. Leer 10 nmeros enteros, almacenarlos en un vector y determinar cuntos nmeros ne
gativos
hay.
Programa cuantos_nega
Variables:
Entero: vector (10), ndice,
Inicio
Para indice=1 hasta 10
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
contador=0
Para indice=1 hasta 10
Si vector(indice)<0
Contador=contador+1
Fin_Para
Escriba El En este vector hay almacenados+contador+nmeros negativos
Fin
18. Leer 10 nmeros enteros, almacenarlos en un vector y determinar en qu posicione
s estn los
nmeros positivos.
Programa donde_positivos
Variables:
Entero: vector (10), ndice,
Inicio
Para indice=1 hasta 10
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
Para indice=1 hasta 10
Si vector(indice)>0
Escriba El dato almacenado en la poscion+indice+es+vector(indice)y es positivo
Fin_Si
Fin_Para
Fin
19. Leer 10 nmeros enteros, almacenarlos en un vector y determinar cul es el nmero
menor.
Programa menor_almacenado
Variables:
Entero:vector (10), ndice,menor
Inicio
Para indice=1 hasta 10
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
menor=0
Para indice=1 hasta 10
Si vector(indice)<menor
menor=vector(indice)
Fin_Si
Fin_Para
Escriba En este vector, el menor numero almacenado es+menor
Fin
20. Leer 10 nmeros enteros, almacenarlos en un vector y determinar en qu posicin es
t el
menor nmero primo.
Programa menor_primo
Variables:
Entero: vector (10), ndice, menor, switch, aux, posicion, num
Inicio
Para indice=1 hasta 10
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
Menor=0
Para indice=1 hasta 10 (pasa1)
vector(indice)=num
switch=3 aux=2
mientras aux<num y switch=3
Si num/aux*aux = num
switch=5
Fin_Si
aux=aux+1
Fin mientras
Si switch=3
Si num<menor
menor= num
posicion=indice
Fin_si
Fin_Para
Escriba El menor numero primo almacenado en el vector es+menor+y se encuentra en la
posicion+posicion
Fin
21. Leer 10 nmeros enteros, almacenarlos en un vector y determinar en qu posicin es
t el
nmero cuya suma de dgitos sea la mayor.
Programa sumaDigs_mayor
Variables:
Entero: vector (10), ndice, menor, digito, suma, sumaMayor
Inicio
Para indice=1 hasta 10
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
Suma=0
Digito=0
sumaMayor=0
Para ndice=1 hasta 10 (pasa1)
num=vector(ndice)
Haga
digito= num-(num/10*10)
suma=suma+digito
num=(num-dig)/10
Hasta num=<0
Fin_haga_hasta
Si suma>sumaMayor
sumaMayor=suma
Posicion=ndice
Fin_Si
Fin_Para
Escriba La mayor de las sumas de los digitos de los enteros almacenados es la del
digito+vector(posicion)+el cual esta en la posicion+posicion
Fin
22. Leer 10 nmeros enteros, almacenarlos en un vector y determinar cules son los nm
eros
mltiplos de 5 y en qu posiciones estn.
Programa multiplos_cinco
Variables:
Entero: vector (10), ndice,
Inicio
Para indice=1 hasta 10
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
Para indice=1 hasta 10
Si vector(indice)/5*5=vector(indice)
Escriba El dato almacenado en la poscion+indice+es+vector(indice)y es multiplo de Cin
co
Fin_Si
Fin_Para
Fin
23. Leer 10 nmeros enteros, almacenarlos en un vector y determinar si existe al m
enos un
nmero repetido.
Programa repetidos
Variables:
Entero: vector (10), ndice,
Inicio
Para indice=1 hasta 10 (pasa 1)
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
Para indice=1 hasta 10 pasa
Si vector(indice)==vector(indice+1)
Escriba existe al menos un numero repetido
Fin_Si
Fin_para
Fin
24. Leer 10 nmeros enteros, almacenarlos en un vector y determinar en qu posicin es
t el
nmero con mas dgitos.
Programa cual_tiene_mas_digitos
Variables:
Entero: vector(10), ndice, num, digitos, masDigitos, posicion
Inicio
Para indice=1 hasta 10 (pasa 1)
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
Para indice=1 hasta 10 pasa
num= vector(indice)
digitos=0
haga
num/10
digitos=digitos+1
hasta
num=0
Fin_Haga_hasta
Si digitos>masDigitos
masDigitos=digitos
posicion=indice
Fin_Si
Fin_para
Escriba El entero con ms digitos almacenado es+vector(posicion)+El cual se encuentra
en la posicion+posicion+
Y tiene+masDigitos+digitos
Fin
25. Leer 10 nmeros enteros, almacenarlos en un vector y determinar cuntos de los nm
eros
ledos son nmeros primos terminados en 3.
Programa primos_terminados_tres
Variables:
Entero:vector(10), contador
Inicio
Inicio
Para indice=1 hasta 10 (pasa 1)
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
contador=0
Para indice=1 hasta 10 pasa
Si {2^[vector(indice)]-2}/vector(indice)*vector(indice)==vector(indice)
Si vector(indice)-{vector(indice)/10*10}==3
contador=contador+1
Fin_Si
Fin_Para
Escriba En este vector existen+contador+numeros primos terminados en tres
Fin
26. Leer 10 nmeros enteros, almacenarlos en un vector y calcularle el factorial a
cada uno de los
nmeros ledos almacenndolos en otro vector.
Programa factorial_enteros
Variables:
Enteros:vector(10), Vfactorial(10), indice, num, aux, factorial
Inicio:
Para indice=1 hasta 10 (pasa 1)
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
Para indice=1 hasta 10 (pasa 1)
num=vector(indice)
Aux=num
Mientras aux>0
factorial=factorial*aux
Aux-1
Fin_mientras
Vfactorial(indice)=factorial
Fin_Para
Escriba Los factoriales de los numeros digitados son
Para indice=1 hasta 10 (pasa 1)
Escriba Vfactorial(indice)
Fin_Para
Fin
27. Leer 10 nmeros enteros, almacenarlos en un vector y determinar a cunto es igua
l el
promedio entero de los factoriales de cada uno de los nmeros ledos.
Programa promedio _ factoriales
Variables:
Enteros: vector(10), num, aux, factorial, suma, promedio, dgitos, ndice
Inicio:
Para indice=1 hasta 10 (pasa 1)
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
Para indice=1 hasta 10 (pasa 1) //este proceso se repetira para todos los eleme
ntos del vector
digitos=0
num=vector(indice)
Aux=num //Se calcula factorial
Mientras aux>0
factorial=factorial*aux
Aux-1
Fin_mientras
haga
num/10
digitos=digitos+1 //Se calculan numero de digitos
hasta
num=0
Fin_Haga_hasta
Promedio=factorial/digitos //se calcula promedio y se imprime respuesta pa
ra el elemento
Escriba: El promedio del factorial del elemento+vector(indice)+, en la posicion+indi
ce+es+promedio
Fin_Para
Fin
28. Leer 10 nmeros enteros, almacenarlos en un vector y mostrar en pantalla todos
los enteros
comprendidos entre 1 y cada uno de los nmeros almacenados en el vector.
Programa de_uno
Variables:
vector(10), aux,
Inicio:
Para indice=1 hasta 10 (pasa 1)
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
Para indice=1 hasta 10 (pasa 1)
Escribe Para el numero+vector(indice)+almacenado la en posicion+indice+:
Para aux=1 hasta vector(indice) (paso 1)
Escriba aux
Fin_Para
Fin_Para
Fin
29. Leer 10 nmeros enteros, almacenarlos en un vector y mostrar en pantalla todos
los enteros
Comprendidos entre 1 y cada uno de los dgitos de cada uno de los nmeros almacenado
s en
el vector.
Programa de_uno_digitos
Variables:
vector(10), aux, digito.
Inicio:
Para indice=1 hasta 10 (pasa 1)
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
Para indice=1 hasta 10 (pasa 1) //Se escoge uno de los elementos del vector resp
ectivamente
num=vector(indice) //se almacena el valor en una variable auxiliar que pue
de ser degradada
Haga
digito= num-(num/10*10) //se saca ultimo digito
Escriba para el digito+digito+del numero+vector(indice)+en la posicion+indice+los numer
os son:
Para aux=1 hasta digito (paso 1) //Se sacan los numeros del 1 al digito
y se imprimen
Escriba aux
Fin_Para
num=(num-dig)/10 //Se extrae este ultimo digito al numero
hasta
num<=0 //hasta que no queden mas dgitos
Fin_haga_hasta
Fin_Para
Fin
30. Leer 10 nmeros enteros, almacenarlos en un vector. Luego leer un entero y det
erminar si este
ltimo entero se encuentra entre los 10 valores almacenados en el vector.
Programa pertenece_a_vector
Variables:
Entero: vector(10), num, switch
Inicio:
Para indice=1 hasta 10 (pasa 1)
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
switch=0
Escriba digite otro numero entero
Lea num
Para indice=1 hasta 10 (pasa 1)
Si num==vector(indice)
switch=5
Fin_Si
Fin_Para
Si switch==0
Escriba El numero digitado no se encuntra en el vector
Si switch==5
Escriba El numero almacenado se encuentra entre los valores del vector
Fin_si
Fin
31. Leer 10 nmeros enteros, almacenarlos en un vector. Luego leer un entero y det
erminar
Cuantos divisores exactos tiene este ltimo nmero entre los valores almacenados en
el vector.
Programa divisores
Variables:
Entero: vector(10), num, contador
Inicio:
Para indice=1 hasta 10 (pasa 1)
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
Escriba digite otro numero entero
Lea num
Para indice=1 hasta 10 (pasa 1)
Si num/vector(ndice)*vector(ndice)==num
contador=contador+1
Fin_si
Fin_Para
Escriba Este numero tiene+contador+divisores exactos en este vector
Fin
32. Leer 10 nmeros enteros, almacenarlos en un vector. Luego leer un entero y det
erminar
cuntos nmeros de los almacenados en el vector terminan en el mismo dgito que el ltim
o
valor ledo.
Programa ultimo_digito_igual
Variables
Entero: vector(10), digito, ultimoDigito, contador
Inicio:
Para indice=1 hasta 10 (pasa 1)
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
Escriba digite otro numero entero
Lea num
ultimoDigito=num-(num/10*10)
Para indice=1 hasta 10 (pasa 1)
digito=vector(indice)-{(vector(indice)/10)*10}
Si digito==ultimoDigito
contador==contador+1
Fin_si
Fin_Para
Escriba El numero de elementos que terminan en el mismo digito que el numero escr
ito es+contador
Fin
33. Leer 10 nmeros enteros, almacenarlos en un vector y determinar a cunto es igua
l la suma de
los dgitos pares de cada uno de los nmeros ledos.
Programa suma_digitos_pares
Variables:
vector(10), aux, digito.
Inicio:
Para indice=1 hasta 10 (pasa 1)
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
Para indice=1 hasta 10 (pasa 1) //Se escoge uno de los elementos del vector resp
ectivamente
num=vector(indice) //se almacena el valor en una variable auxiliar que pue
de ser degradada
Haga
digito= num-(num/10*10) //se saca ultimo digito
Si digito/2*2=digito
suma=suma+digito
Fin_Si
num=(num-dig)/10 //Se extrae este ultimo digito al numero
hasta
num<=0 //hasta que no queden mas dgitos
Fin_haga_hasta
Escriba La suma de los dgitos pares del numero+vector(ndice)+en la posicion+ndice+es i
al a +suma
Fin_Para
Fin
34. Leer 10 nmeros enteros, almacenarlos en un vector y determinar cuntas veces en
el vector
se encuentra el dgito 2. No se olvide que el dgito 2 puede estar varias veces en u
n mismo
nmero.
Programa cuantas_veces_dos
Variables:
Enteros: vector(10), contador
Inicio:
Para indice=1 hasta 10 (pasa 1)
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
Para indice=1 hasta 10 (pasa 1)
num=vector(indice)
Haga
digito= num-(num/10*10) Si digito==2
contador=contador+1
Fin_Si
num=(num-dig)/10
hasta
num<=0 Fin_haga_hasta
Fin_Para
Escriba El numero de digitos dos entre los elementos de este vector es +contador
Fin
35. Leer 10 nmeros enteros, almacenarlos en un vector y determinar si el promedio
entero de
dichos nmeros es un nmero primo.
Programa promedio_es_primo
Variables:
Enteros: vector(10), suma, promedio, switch, indice
Inicio:
Para indice=1 hasta 10 (pasa 1)
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
Para indice=1 hasta 10 (pasa 1)
suma= suma+vector(indice)
Fin_para
promedio=suma/10
indice=2
switch=5
mientras indice<promedio y switch=5
Si promedio/indice*indice=promedio
Switch=3
Fin_si
Indice =indice+1
Fin_Mientras
Si Switch=5
Escriba El promedio entero de estos nmeros es un numero primo
Sino
Escriba El promedio entero de estos nmeros NO es un numero primo
Fin_Si
Fin
36. Leer 10 nmeros enteros, almacenarlos en un vector y determinar cuntos dgitos pr
imos hay
en los nmeros ledos
Programa cuantos_primos
Variables:
Enteros: vector(10), contador, num, digito, aux, control,
Inicio:
Para indice=1 hasta 10 (pasa 1)
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
Para indice=1 hasta 10 (pasa 1) //Se escoge uno de los nmeros del vector
num=vector(indice) //se asigna valor a una variable para poder degradarla
Haga
digito= num-(num/10*10) //se saca ultimo digito
aux=2 //se resetea variable auxiliar
control=1 //se resetea control
Haga
Si digito/aux*aux=digito //se revisa si el numero es divisible entre algn
otro control=5 //que no sea el uno o si mismo
Fin_Si //Si otro divisor es encontrado, se activa Switch
aux= aux+1
Hasta
aux==num o control==5
Fin_Haga_hasta
Si control==1 //si el numero resulto ser primo, se suma uno a contador
contador=contador+1
Fin_Si
num=(num-dig)/10 //Se quita el digito evaluado de num para extraer el prx
imo
Hasta
Num=<0
Fin_haga_hasta
Fin_Para
Escriba El numero de digitos priomos entre los elementos de este vector es +conta
dor
Fin
.
37. Leer 10 nmeros enteros, almacenarlos en un vector y determinar a cuntos es igu
al el
cuadrado de cada uno de los nmeros ledos.
Programa cuadrados
Variables
Entero: vector(10),indice, cuadrado
Inicio
Para indice=1 hasta 10 (pasa 1)
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
Para indice=1 hasta 10 (pasa 1)
cuadrado= vector(indice)*vector(indice)
Escriba El cuadrado del numero en la posicion+indice+del vector, es+cuadrado
Fin_para
Fin
38. Leer 10 nmeros enteros, almacenarlos en un vector y determinar si la semisuma
entre el valor
mayor y el valor menor es un nmero primo.
Programa semisuma_prima
Variables
Entero: vector(10),semisuma, valorMayor, valorMenor
Inicio
Para indice=1 hasta 10 (pasa 1)
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
valorMayor=0
valorMenor=0
Para indice=1 hasta 10 (pasa 1)
Si vector(indice)>valorMayor
ValorMayor=vector(indice)
Si vector(indice)<valorMenor
valorMenor=vector(indice)
Fin_Si
Fin_para
Semisuma=valorMayor+valorMenor/2
aux=2
switch=7
Mientras aux<semisuma
Si semisuma/aux*aux=semisuma
switch=5
Fin_Si
aux+1
Fin_mientras
Si switch==7
Escriba la semisuma del valor mayor y el menor almacenaos es un numero primo
Sino
Escriba la semisuma del valor mayor y el menor almacenaos NO es un numero primo
Fin_Si
Fin
39. Leer 10 nmeros enteros, almacenarlos en un vector y determinar si la semisuma
entre el valor
mayor y el valor menor es un nmero par.
Programa semisuma_par
Variables
Entero: vector(10),semisuma, cuadrado , valorMayor, valorMenor
Inicio
Para indice=1 hasta 10 (pasa 1)
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
valorMayor=0
valorMenor=0
Para indice=1 hasta 10 (pasa 1)
Si vector(indice)>valorMayor
ValorMayor=vector(indice)
Si vector(indice)<valorMenor
valorMenor=vector(indice)
Fin_Si
Fin_para
Semisuma=valorMayor+valorMenor/2
Si semisuma/2*2==semisuma
Escriba la semisuma del valor mayor y el menor almacenaos es un numero par
Sino
Escriba la semisuma del valor mayor y el menor almacenaos NO es un numero par
Fin_Si
Fin
40. Leer 10 nmeros enteros, almacenarlos en un vector y determinar cuntos nmeros de
los
almacenados en dicho vector terminan en 15.
Programa terminan_quince
Variables
Entero: vector(10),indice, contador
Inicio
Para indice=1 hasta 10 (pasa 1)
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
contador=0
Para indice=1 hasta 10 (pasa 1)
Si vector(indice)-15/10*10=vector(indice)-15
contador=contador+1
Fin_Si
Fin_Para
Escriba El numero de elementos terminados en 15 en este vector es+contador
Fin
41. Leer 10 nmeros enteros, almacenarlos en un vector y determinar cuntos nmeros de
los
almacenados en dicho vector comienzan con 3.
Programa comienzan_tres
Variables:
Enteros:Vector(10), indice, digito, num, contador
Inicio
Para indice=1 hasta 10 (pasa 1)
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
digito=0
Para indice=1 hasta 10 (pasa 1)
Num= vector (ndice)
Haga
Digito=num-(num/10*10)
Num=num-digito/10
Hasta
Num<=0
Fin_haga_hasta
Si digito==3
Contador=contador+1
Fin_Si
Fin_para
Escriba El numero de elementos cuyo primer digito es tres en este vector es+contad
or
Fin
42. Leer 10 nmeros enteros, almacenarlos en un vector y determinar cuntos nmeros co
n
cantidad par de dgitos pares hay almacenados en dicho vector.
Progrma cantidad_par_pares
Variables
Entero: vector(10), indice, pares, digito, conParDePares
Inicio
Para indice=1 hasta 10 (pasa 1)
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
digito=0
conParDePares=0
Para indice=1 hasta 10 (pasa 1) // escojo uno de los elementos del vector
Num= vector (ndice) //asigno su valor a una variable para poder extraerle d
igitos
pares=0
Haga
digito=num-(num/10*10) //saco ultimo digito
Si digito/2*2=digito //Verifico si es par
pares=pares+1 //si es as se acumula (al cambiar de elemento
//se reinicia esta variable)
Num=num-digito/10 //quito este ultimo digito evaluado del valor
Hasta
Num<=0 //si todava quedan dgitos, saco ultimo digito y evalo
Fin_haga_hasta
Si pares/2*2=pares //tras contar cantidad digitos pares, veo si esta es pa
r
conParDePares=conParDePares+1 //si es asi sumo uno a contador
Fin_si
Fin_Si
Fin_para
Escriba la cantidad de elementos con cantidad par de dgitos pares en este vector e
s=conParDePares
Fin
43. Leer 10 nmeros enteros, almacenarlos en un vector y determinar en qu posicione
s se
encuentra el nmero con mayor cantidad de dgitos primos.
Programa donde_con_mas_primos
Variables:
Enteros:Vector(10), indice, digito, num, primos, masPrimos, posicin, aux
Inicio
Para indice=1 hasta 10 (pasa 1)
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
Para indice=1 hasta 10 (pasa 1) // Escojo un valor del vector
Num= vector (ndice) //deposito su valor en variable para extraer sus digito
s
Haga
Digito=num-(num/10*10) //calculo ultimo digito
Aux=2 //reinicio variable auxiliar
esPrimo=3 //variable que indica que no se ha encontrado divisor
Mientras aux<digito y esPrimo=3
Si digito/aux*aux=digito //Veo si el digito es divisible por alguno otro
numero que uno y si m.
esPrimo=7 //Se trastorna variable para indicar que no es primo si se encu
entra // divisor
Fin_Si
aux=aux+1
Fin_mientras
Si esPrimo=3 //Si variable indica que numero es primo
Primos=primos+1 //Se suma un uno a la cantidad de digitos primos contabilizada
Fin_Si
Num=num-digito/10 //quito este digito del numero
Hasta num=<0 //si quedan mas dgitos se vuelve a repetir ciclo
Fin_haga_hasta
Si primos>masPrimos //Si en este numero se ha hallado la mayor cantidad de
primos
masPrimos= primos //se almacena cual fue esta cantidad para futura compar
acin
posicin=indice //y se almacena posicin del elemento a quien pertenece
Fin_Si
Fin_para
Escriba El numero con mayor cantidad de digitos primos es el+vector(posicin) y se
encuentra en las posiciones
Para indice=1 hasta 10
Si vector(indice)=vector(posicin)
Escriba ndice
Fin_Si
Fin_para
Fin
44. Leer 10 nmeros enteros, almacenarlos en un vector y determinar cuntos de los nm
eros
almacenados en dicho vector pertenecen a los 100 primeros elementos de la serie
de
Fibonacci.
Programa cuantos_fibonacci
Variables:
Enteros:Vector(10), indice, num1, num2, aux, contador
Inicio
Para indice=1 hasta 10 (pasa 1)
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
Para indice=1 hasta 10 (pasa 1) //Sacamos un elemento del vector
Num1=0 //inicializamos la serie con sus dos primeros valores
Num2=1
Para aux=1 hasta 98 (pasa1) //se compara el elemento de vector con los prim
eros 100 Fibonn. Si vector(indice)== num2
Escriba El elemento en la posicin+indice+pertenece a la serie Fibonnaci
contador=contador+1
Fin_Si
Num2=num1+num2 //se calcula prximo elemento de la serie Fib.para repetir compar
acion
Fin_Para
Escriba el numero de elementos en el vector que pertenecen a la serie Fibonacci e
s+contador
Fin
45. Leer 10 nmeros enteros, almacenarlos en un vector y determinar cuntos nmeros de
los
almacenados en dicho vector comienzan por 34.
Programa comienzan_treintaycuatro
Variables:
Enteros:Vector(10), indice, digito, num, contador
Inicio
Para indice=1 hasta 10 (pasa 1)
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
digito=0
Para indice=1 hasta 10 (pasa 1)
num= vector (ndice)
mientras num>=34
num=num/10
Fin_mientras
Si num==34
contador=contador+1
Fin_Si
Fin_Para
Escriba La cantidad de elementos que comienzan por 34 en este vector es +contador
Fin
46. Leer 10 nmeros enteros, almacenarlos en un vector y determinar cuntos nmeros de
los
almacenados en dicho vector son primos y comienzan por 5.
Programa primo_comienza_cinco
Variables:
Enteros:vector(10), indice, digito, num, contador, aux, esPrimo
Inicio
Para indice=1 hasta 10 (pasa 1)
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
digito=0
Para indice=1 hasta 10 (pasa 1)
num= vector (ndice)
Aux=2
esPrimo=3
Mientras aux<num y esPrimo=3
Si num/aux*aux=num
esPrimo=7
Fin_Si
aux=aux+1
Fin_mientras
Si esPrimo=3
Haga
num=num/10
hasta
num<=5
Fin_Haga_hasta
Si num==5
contador=contador+1
Fin_Si
Fin_Para
Escriba La cantidad de elementos Primos que comienzan por 34 en este vector es +co
ntador
Fin
47. Leer 10 nmeros enteros, almacenarlos en un vector y determinar en qu posicione
s se
encuentran los nmeros mltiplos de 10. No utilizar el nmero 10 en ninguna operacin.
Programa multiplos de diez
Variables
Enteros: vector(10), i, lastDig, num
Inicio
Para i=1 hasta 10 (pasa 1)
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
Para i=1 hasta 10 (pasa 1)
num=vector(i) // se deposita el valor del elemento en una variable para no daa
r el contenido
Si num<0
num= num*(-1)
Si num>9
lastDig=(num*100)-{(num*100)/1000*1000}
Si lastDig==0
Escriba En la posicion+i+Se encuentra el elemento+vector(i)+El cual es multiplo de 10
Fin_Si
Fin_Si
Fin_Para
Fin
48. Leer 10 nmeros enteros, almacenarlos en un vector y determinar en qu posicin se
encuentra el nmero primo con mayor cantidad de dgitos pares.
Programa mayor_Primo
Variables
Enteros:
Variables:
Enteros:vector(10), indice, digito, num, contador, aux, esPrimo, masPares, primo
ConMasPares
Inicio
Para indice=1 hasta 10 (pasa 1)
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
digito=0
masPares=0
primoConMasPares =0
Para indice=1 hasta 10 (pasa 1)
num= vector (ndice)
aux=2
esPrimo=3
Mientras aux<num y esPrimo=3 //confirmamos si el numero es primo
Si num/aux*aux=num
esPrimo=7
Fin_Si
aux=aux+1
Fin_mientras
Si esPrimo=3
Mientras num>0
dig=num-(num/10*10)
Si dig/2*2=dig
contador=contador*1
Fin_Si
Num=(num-dig)/10
Fin_mientras
Si contador>masPares
masPares=contador
primoConMasPares=indice
Fin_Si
Fin_Para
Escriba El numero primo con ms dgitos pares se encuentra en la posicin+primoConMasPa
res+y es el numero+vector(primoConMasPares)
Fin
49. Leer 10 nmeros enteros, almacenarlos en un vector y determinar cuntos nmeros te
rminar
en dgito primo.
Programa terminan_primo
Variables
Entero: vector(10), digito, esPrimo, i,aux, contador
Inicio
Para in=1 hasta 10 (pasa 1)
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
Para i=1 hasta 10 (pasa 1)
digito=vector(i)-{(vector(i)/10)*10}
aux=2
esPrimo=3
mientras aux<digito y esPrimo=3
Si digito/aux*aux=digito
esPrimo=7
Fin_si
Aux=aux+1
Fin_Mientras
Si esPrimo==3
contador=contador+1
Fin_si
Fin_Para
Escriba El numero de elementos cuyo ultimo digito es primo en este vector es+conta
dor
Fin
50. Leer 10 nmeros enteros, almacenarlos en un vector y determinar cuntos nmeros de
los
almacenados en dicho vector comienzan en dgito primo.
Programa comienzan_primo
Variables
Enteros: vector(10), num, digito, aux, i, esPrimo,
Para in=1 hasta 10 (pasa 1)
Escriba Digite numero entero
Lea vector(indice)
Fin_Para
Para in=1 hasta 10 (pasa 1)
Num=vector(i)
Mientras num>=0
Digito=num-(num/10*10)
Num=(num-digito)/10
Fin_mientras
Aux=2
esPrimo=3
Mientras aux<digito
Si digito/aux*aux=digito
esPrimo=7
Fin_Si
Aux=aux+1
Fin_Mientras
Si esPrimo=3
contador=contador+1
Fin_Si
Fin_Para
Escriba El numero de elementos cuyos primeros dgitos son primos del vector son +con
tador