Sei sulla pagina 1di 5

Cisco Router/Switch configuration Template

BASIC ROUTER/SWITCH CONFIGURATION TEMPLATE


===================================
1) General configuration with banner and hotname (copy and paste the from enable till the end
of %)
enable
configure terminal
hostname nameOfTheRouter
banner motd %
########################################
# This a password protect area! #
# Unauthorized access is not allowed #
########################################
%
2) Password protection and password encryption (copy and paste the from enable till the last
line)
enable secret password1
line console 0
password password2
login
line vty 0 4
password password3
login
service password-encryption


ROUTER INTERFACE CONFIGURATION
==============================

On the global configuration mode, copy and paste the following lines (repeat it for each
interface), make sure to replace ip address A.B.C.D and subnet mask a.b.c.d with proper ipv4
address

interface fa0/0
description {type up to 240 characters describing the interface (i.e connection from where to
where)}
ip address A.B.C.D a.b.c.d
no shutdown


ROUTER RIPv2 CONFIGURATION
==========================

on the global configuration mode, copy and paste the following commands. Make sure your
replace A.B.X.0 and A.B.Y.0 with appropriate nework address. Also, repeat the network
statement for all the connected networks on the router.


router rip
version 2
network A.B.X.0
network A.B.Y.0
exit


ROUTER's SUB-INTERFACE CONFIGURATION
====================================

On the global configuration mode, copy and paste the following lines (repeat it for each
interface), make sure to replace vlan-ID, ip address A.B.C.D and subnetmask a.b.c.d with proper
ipv4 address


int fa0/1.vlan-ID
description type up to 240 characters describing the sub-interface (i.e connection from where
to where)
encapsulation dot1q vlan-ID
ip address A.B.C.D a.b.c.d
int fa0/1
no shutdown
exit

VLAN CONFIGURATION TEMPLATE
=====================

On the global configuration mode, copy and paste the following lines (repeat it for each
interface), make sure to replace the interface you want to be added to the respective VLANs.
Also replace {vlan name} with the name for vlan

vlan 10
name {vlan name}
vlan 20
name {vlan name}
vlan 30
name {vlan name}
vlan 40
name {vlan name}
exit
int fa0/2
switchport mode access
switchport access vlan 10
int fa0/3
switchport mode access
switchport access vlan 10
int fa0/4
switchport mode access
switchport access vlan 20
int fa0/5
switchport mode access
switchport access vlan 30
int fa0/6
switchport mode access
switchport access vlan 40
int fa0/1
switchport mode trunk
exit
exit
copy run start

Potrebbero piacerti anche