Sei sulla pagina 1di 48

Network Routing and Fundamentals Case Study 2

NETWORK ROUTING AND FUNDAMENTALS


CASE STUDY 2

1
Network Routing and Fundamentals Case Study 2

CONTENTS

1. Overview and Objectives

1.1 Introduction Page 3

1.2 Requirements Page 3

1.3 Technical Solution Page 4

2. Technical Solution Page 4

2.1 Existing Topology Page 4

2.2 Internet Protocol & Router Configuration Page 5

2.2.1 Addressing Space Page 5

2.2.2 Addressing Space Configuration Page 5

2.2.3 Packet Tracer Software Page 6

2.2.4 TFTP Requirements Page 6


2.3 Routing Protocol Solution Page 7

3. Summary Page 8

4. Abbreviations Page 9

5. References Page 10

6. Appendices Page 11

6.1 Appendix 1 – IP Range Page 11

6.2 Appendix 2 – Network Configuration Tables Page 13

6.3 Appendix 3 – New Network Topology Page 14

6.4 Appendix 4 – Host Names and Passwords Page 15

6.5 Appendix 5a - Show CDP Neighbors Page 16

6.6 Appendix 5b - Show IP Route Page 17

2
Network Routing and Fundamentals Case Study 2

6.7 Appendix 5c - Show IP Protocol Page 20

6.8 Appendix 5d - Show IP Interface Page 23

6.9 Appendix 5e - Show Version Page 33

6.9.1 Appendix 5f - Show Hosts Page 36

6.9.2 Appendix 5g - Show Startup-config Page 39

1.0 OVERVIEW AND OBJECTIVES

1.1 Introduction

A unit has several people responsible for maintaining various sections of the
internetwork infrastructure. Many technicians have done an excellent job with the
small portion for which they are responsible.

One of the other network associates who was responsible for a larger portion of the
infrastructure was suddenly posted. This left redesign and implementation on this
portion of the internetwork unfinished. A technician is given the task to complete the
design and implementation of the unfinished network.

The few documents that existed were poorly written. So during the weekend the
technician reconstructs the diagram from an existing diagram that was found. It
represents the new internetwork design. It shows the planned routers, hubs
/switches, circuits, and the servers/ workstation at each site. The server at the center
site is a file server accessed only by workstations on this internetwork. The
workstation at the center site is used to manage all routers on the internetwork.

After returning to work Monday morning, the technician presents the new diagram,
shown at Figure 1 to their network infrastructure team leader that assigned the
project. After discussion, it is determined that the new documentation must be
developed for the project.

3
Network Routing and Fundamentals Case Study 2

1.2 Requirements
1.2.1 This Project has the following requirements:

• Set up the physical layout of the network using the provided diagram
and accompanying narrative.

• Correctly configure the routers with a basic router configuration.

• Set up a TFTP server on one of the workstations.

• Troubleshoot and test all connectivity.

• Provide detailed documentation that is logically organised to make


troubleshooting easier.

2.0 TECHNICAL SOLUTION

2.1 Existing Topology

2.1.1 The original network topology diagram has been provided and is
shown at Figure 1 below. The topology has been checked and is correct, so
this to form the basis of the new network design.

4
Network Routing and Fundamentals Case Study 2

3 4 5 6

Center

Eva
Boaz

Server

Figure 1 – Original Network Topology

2.1.2 The information gleaned from Figure 1 shows that there are five distinct
networks within the topology. There are three Local Area Networks (LANs)
and two smaller networks which provide serial link connectivity between the
LANs. The following information will provide will be used throughout this
document and will be used for the network design process.

Provided Network Address: 172.17.0.0/16


Required Number of Subnets: 5
Routing Protocol: Open Shortest Path First (OSPF)

5
Network Routing and Fundamentals Case Study 2

2.2 Internet Protocol Range & Router Configuration

2.2.1 As stated in paragraph 2.1.2, the provided network address for this
project is 172.17.0.0/16. This address space will provide 65534 Internet
Protocol (IP) addresses which far exceeds the requirements for this network.
Using Variable Length Subnet Masking (VLSM), it is recommended that the
address space be reduced and is that it is sub-netted as shown in Tables 1
through to 5 at Appendix 1, page 11 and as summarised here:

Boaz LAN Subnet.............172.17.0.0/24


Center LAN Subnet..........172.17.1.0/24
Eva LAN Subnet ..............172.17.2.0/24
Center - Eva Subnet.........172.17.3.0/30
Center - Boaz Subnet.......172.17.3.4/30

2.2.2 It is proposed that the serial link subnets will become /30 networks
providing 2 usable host addresses; each serial link requires only 2 host
addresses, one for each end. The three LANs will become /24 networks,
allowing a maximum of 254 host’s each. This will allow for significant future
expansion to each of the LAN networks and the distinct subnets will enable
ease of configuration. To provide a logical addressing scheme which is
common across the subnets, each LAN will use the first usable address for
the router Fast Ethernet interface and the second address is used for the
Switch VLAN. The remaining addresses are used by the workstations and
server, starting with the last usable address and working backwards.

Configuration tables for each network can be found at Appendix 2, Page 13.

2.2.3 The network design has been constructed and tested in the Cisco
propriety simulation software called Packet Tracer. A network topology
printout from Packet Tracer can be found at Appendix 3, page 14, and Show
commands for each router can be found at Appendix 5a – g on pages 16 –
39.

6
Network Routing and Fundamentals Case Study 2

2.2.3 To enable ease of configuration and to assist technicians when


fault finding, each router has been given a unique hostname and for security
passwords have been set up. When trying to access the router a prompt will
ask the user to enter a password which will allow him access to User Exec
Mode, a mode which will allow him to monitor things only. A second
password is then required to enter Privileged Exec Mode, a mode which
allows the user to gain detailed information. Here the user can also access
the Configure Terminal Mode, where router configuration changes can be
made. The passwords and hostnames used for this network, and used within
the Packet Tracer software, are listed at Appendix 4, page 15. Once the
network is constructed, the passwords shown here should be changed and
should be kept in a secure location.

2.2.4 One of the requirements of the project is to set up a Trivial File


Transfer Protocol (TFTP) server on one of the workstations. After some
investigation and research it has been discovered that to do this proprietary
software needs to be installed on the workstation. As there is a server
already within the network, it is recommended that this become the TFTP
server, and the TFTP function within the server has been enabled in the
Packet Tracer simulation software.

2.3 Routing Protocol

2.3.1 The routing protocol recommended for this project is Open Shortest
Path First (OSPF). OSPF is a ‘Link-state protocol that was developed as a
replacement for the distance vector routing protocol Routing Information
Protocol (RIP)’ Graziani and Johnson (2008: 500). Link-state protocols do not
exchange routes and metrics, they exchange only the state of the links they

7
Network Routing and Fundamentals Case Study 2

know about, and the cost associated with those links. This saves
considerably on bandwidth.

The other protocols considered are Enhanced Interior Gateway Routing


Protocol (EIGRP) and RIP. Although very easy to configure, RIP has been
discounted as the routing protocol because of drawbacks such as it can only
be used in networks that have fewer than 15 hops, it converges slowly on
larger networks, it is prone to routing loops and routing updates can require
significant bandwidth because the entire routing table is sent. TechRepublic
(2004)

EIGRP was also considered but is not recommended as it is a Cisco


proprietary protocol. The major drawback with EIGRP is that it is specifically
designed for Cisco routers. ‘EIGRP is an enhancement of Cisco Interior
Gateway Routing Protocol (IGRP) and will only operate on Cisco routers’
Graziani and Johnson (2008: 392). Therefore EIGRP would require that only
Cisco equipment be used in any future expansion of the network unless a new
routing protocol was introduced throughout the network at the same time.

There are disadvantages to using link state protocols, such as OSPF. They
are resource intensive and require more processor capacity and memory.
‘For very large internetworks, the database of link state advertisements and
the calculation of routing table entries can be memory and processor
intensive.’ . www.microsoft.com (2010). The size of the current network
topology is not considered intensive for the routers to handle.

OSPF has been recommended because this protocol is an open source


routing protocol and is used commonly on most routers from most
manufacturers. It has fast convergence, it minimizes bandwidth consumed by
routing information, using low bandwidth wisely, and it can take link bandwidth
into account.

3.0 SUMMARY

8
Network Routing and Fundamentals Case Study 2

3.1 Summary

3.1.1 The solution provided covers all the requirements requested by the
project. The proposed network is based on the existing topology diagram and
the solution will be easily managed and can be scaled for future growth. The
network addressing scheme has been derived from sub-netting the allocated
address space into manageable subnets with logical allocation of IP
addresses whilst leaving significant room for future expansion.
The two main routing protocols considered were EIGRP and OSPF. Although
OSPF is slightly more complex to configure and understand than EIGRP, it is
the recommended protocol due to EIGRP being Cisco proprietary.

4.0 ABBREVIATIONS

4.1 Abbreviations

Abbreviations used throughout this report are listed below:

EIGRP Enhanced Interior Gateway Routing Protocol


IGRP Interior Gateway Routing Protocol
IP Internet Protocol

9
Network Routing and Fundamentals Case Study 2

LAN Local Area Network


NIC Network Interface Card
OSPF Open Shortest Path First
RIP Routing Information Protocol
TFTP Trivial File Transfer Protocol
VLAN Virtual Local Area Network
VLSM Variable Length Subnet Masking

References

Graziani and Johnson (2008). Routing Protocols and Concepts. 2nd ed. USA: Cisco
Press. 392.

Graziani and Johnson (2008). Routing Protocols and Concepts. 2nd ed. USA: Cisco
Press. 500.

10
Network Routing and Fundamentals Case Study 2

Microsoft Technet. (2010). Link State Based Routing Protocols. Available:


http://technet.microsoft.com/en-us/library/cc940461.aspx. Last accessed 23 May
2010.

Tech Republic. (2004). Quick Reference Cisco Internetworking. Available:


articles.techrepublic.com.com/i/tr/one_offs/t063_preview.pdf . Last accessed 23 May
2010.

Appendix 1
Internet Protocol Range
Table 1 – Center Subnet

Subnet 1 - Center Subnet


Network Address 172.17.1.0

1st Usable Address 172.17.1.1

11
Network Routing and Fundamentals Case Study 2

Last Usable Address 172.17.1.254

Broadcast address 172.17.1.255

Subnet Mask 255.255.255.0

Table 2 – Boaz Subnet

Subnet 2 - Boaz Subnet


Network Address 172.17.0.0

1st Usable Address 172.17.0.1

Last Usable Address 172.17.0.254

Broadcast address 172.17.0.255

Subnet Mask 255.255.255.0

Table 3 – Eva Subnet

Subnet 3 - Eva Subnet


Network Address 172.17.2.0

1st Usable Address 172.17.2.1

Last Usable Address 172.17.2.254

Broadcast address 172.17.2.255

Subnet Mask 255.255.255.0

Table 4 – Eva to Center Link Subnet

Subnet 4 - Eva to Center Link Subnet


Network Address 172.17.3.0

1st Usable Address 172.17.3.1

Last Usable Address 172.17.3.2

Broadcast address 172.17.3.4

Subnet Mask 255.255.255.252

12
Network Routing and Fundamentals Case Study 2

Table 5 – Boaz to Center Link Subnet

Subnet 5 - Boaz to Center Link Subnet


Network Address 172.17.3.4

1st Usable Address 172.17.3.5

Last Usable Address 172.17.3.6

Broadcast address 172.17.3.7

Subnet Mask 255.255.255.252

Appendix 2
Network Configuration Tables
Center Configuration

Interface IP Address Subnet Mask Default Gateway

Center Router 172.17.3.5 255.255.255.252 N/A


Se 3/0 DCE
Center Router 172.17.3.1 255.255.255.252 N/A
Se 2/0 DCE
Center Router 172.17.1.1 255.255.255.0 N/A

13
Network Routing and Fundamentals Case Study 2

FA 0/0
Center Switch 172.17.1.2 255.255.255.0 172.17.1.1
VLAN 1
Server 172.17.1.253 255.255.255.0 172.17.1.1

PC 2 NIC 172.17.1.254 255.255.255.0 172.17.1.1

Boaz Configuration

Interface IP Address Subnet Mask Default Gateway

Boaz Router 172.17.3.6 255.255.255.25 N/A


S 3/0 2
Boaz Router 172.17.0.1 255.255.255.0 N/A
FA 0/0
Boaz Switch 172.17.0.2 255.255.255.0 172.17.0.1
VLAN 1
PC 3 NIC 172.17.0.253 255.255.255.0 172.17.0.1

PC 4 NIC 172.17.0.254 255.255.255.0 172.17.0.1

Eva Configuration

Interface IP Address Subnet Mask Default Gateway


Eva Router 172.17.3.2 255.255.255.25 N/A
S 2/0 2
Eva Router 172.17.2.1 255.255.255.0 N/A
FA 0/0
Eva Switch 172.17.2.2 255.255.255.0 172.17.0.1
VLAN 1
PC 5 NIC 172.17.2.254 255.255.255.0 172.17.0.1

PC 6 NIC 172.17.2.253 255.255.255.0 172.17.0.1


Appendix 3
New Network Topology

14
Network Routing and Fundamentals Case Study 2

Appendix 4
Host Names and Passwords

Hostnames

15
Network Routing and Fundamentals Case Study 2

Equipment Hostname
Boaz Router Boaz

Center Router Center

Eva Router Eva

Boaz Switch Boaz-Switch

Center Switch Center-Switch

Eva Switch Eva-Switch

Server Server

PC 2 PC2

PC 3 PC3

PC 4 PC4

PC 5 PC5

PC 6 PC6

Passwords

Type Password

Console class

VTY 0 – 4 class

Secret cisco

Appendix 5a
Center Show CDP Neighbors
Center#sh cdp neigh

16
Network Routing and Fundamentals Case Study 2

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge


S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone
Device ID Local Intrfce Holdtme Capability Platform Port ID
Center-Switch
Fas 0/0 124 S 2950 Fas 0/1
Boaz Ser 3/0 131 R PT1000 Ser 3/0
Eva Ser 2/0 133 R PT1000 Ser 2/0
Center#

Boaz Show CDP Neighbors


Boaz#sh cdp neigh
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone
Device ID Local Intrfce Holdtme Capability Platform Port ID
oaz-Switch Fas 0/0 134 S 2950 Fas 0/1
Center Ser 3/0 134 R PT1000 Ser 3/0
Boaz#

Eva Show CDP Neighbors


Eva#sh cdp neigh
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone
Device ID Local Intrfce Holdtme Capability Platform Port ID
Eva-Switch Fas 0/0 134 S 2950 Fas 0/1
Center Ser 2/0 134 R PT1000 Ser 2/0
Eva#

Appendix 5b

Center Show IP Route


Center#sh ip route

17
Network Routing and Fundamentals Case Study 2

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP


D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
172.17.0.0/16 is variably subnetted, 5 subnets, 2 masks
O 172.17.0.0/24 [110/782] via 172.17.3.6, 00:02:07, Serial3/0
C 172.17.1.0/24 is directly connected, FastEthernet0/0
O 172.17.2.0/24 [110/782] via 172.17.3.2, 00:02:07, Serial2/0
C 172.17.3.0/30 is directly connected, Serial2/0
C 172.17.3.4/30 is directly connected, Serial3/0
Center#

Boaz Show IP Route


Boaz#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

18
Network Routing and Fundamentals Case Study 2

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area


N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
172.17.0.0/16 is variably subnetted, 5 subnets, 2 masks
C 172.17.0.0/24 is directly connected, FastEthernet0/0
O 172.17.1.0/24 [110/782] via 172.17.3.5, 00:08:06, Serial3/0
O 172.17.2.0/24 [110/1563] via 172.17.3.5, 00:08:06, Serial3/0
O 172.17.3.0/30 [110/1562] via 172.17.3.5, 00:08:06, Serial3/0
C 172.17.3.4/30 is directly connected, Serial3/0
Boaz#

Eva Show IP Route


Eva#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

19
Network Routing and Fundamentals Case Study 2

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area


N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
172.17.0.0/16 is variably subnetted, 5 subnets, 2 masks
O 172.17.0.0/24 [110/1563] via 172.17.3.1, 00:14:03, Serial2/0
O 172.17.1.0/24 [110/782] via 172.17.3.1, 00:14:03, Serial2/0
C 172.17.2.0/24 is directly connected, FastEthernet0/0
C 172.17.3.0/30 is directly connected, Serial2/0
O 172.17.3.4/30 [110/1562] via 172.17.3.1, 00:14:03, Serial2/0
Eva#

Appendix 5c

Center Show IP Protocol


Center#sh ip protocol

20
Network Routing and Fundamentals Case Study 2

Routing Protocol is "ospf 1"


Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 172.17.3.5
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Maximum path: 4
Routing for Networks:
172.17.1.0 0.0.0.255 area 0
172.17.3.0 0.0.0.3 area 0
172.17.3.4 0.0.0.3 area 0
Passive Interface(s):
FastEthernet0/0
Routing Information Sources:
Gateway Distance Last Update
172.17.3.2 110 00:02:45
172.17.3.6 110 00:02:45
Distance: (default is 110)
Center#

Boaz Show IP Protocol


Boaz#sh ip protocol
Routing Protocol is "ospf 1"

21
Network Routing and Fundamentals Case Study 2

Outgoing update filter list for all interfaces is not set


Incoming update filter list for all interfaces is not set
Router ID 172.17.3.6
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Maximum path: 4
Routing for Networks:
172.17.3.4 0.0.0.3 area 0
172.17.0.0 0.0.0.255 area 0
Passive Interface(s):
FastEthernet0/0
Routing Information Sources:
Gateway Distance Last Update
172.17.3.5 110 00:08:55
Distance: (default is 110)

Boaz#

Eva IP Protocol
Eva#sh ip protocol
Routing Protocol is "ospf 1"

22
Network Routing and Fundamentals Case Study 2

Outgoing update filter list for all interfaces is not set


Incoming update filter list for all interfaces is not set
Router ID 172.17.3.2
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Maximum path: 4
Routing for Networks:
172.17.2.0 0.0.0.255 area 0
172.17.0.0 0.0.3.255 area 0
Passive Interface(s):
FastEthernet0/0
Routing Information Sources:
Gateway Distance Last Update
172.17.3.1 110 00:14:40
Distance: (default is 110)

Eva#

Appendix5d

Center Show IP Interface


Center#sh ip int

23
Network Routing and Fundamentals Case Study 2

FastEthernet0/0 is up, line protocol is up (connected)


Internet address is 172.17.1.1/24
Broadcast address is 255.255.255.255
Address determined by setup command
MTU is 1500
Helper address is not set
Directed broadcast forwarding is disabled
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Security level is default
Split horizon is enabled
ICMP redirects are always sent
ICMP unreachables are always sent
ICMP mask replies are never sent
IP fast switching is disabled
IP fast switching on the same interface is disabled
IP Flow switching is disabled
IP Fast switching turbo vector
IP multicast fast switching is disabled
IP multicast distributed fast switching is disabled
Router Discovery is disabled
IP output packet accounting is disabled
IP access violation accounting is disabled
TCP/IP header compression is disabled
RTP/IP header compression is disabled
Probe proxy name replies are disabled
Policy routing is disabled
Network address translation is disabled

24
Network Routing and Fundamentals Case Study 2

WCCP Redirect outbound is disabled


WCCP Redirect exclude is disabled
BGP Policy Mapping is disabled
FastEthernet1/0 is administratively down, line protocol is down (disabled)
Internet protocol processing disabled
Serial2/0 is up, line protocol is up (connected)
Internet address is 172.17.3.1/30
Broadcast address is 255.255.255.255
Address determined by setup command
MTU is 1500
Helper address is not set
Directed broadcast forwarding is disabled
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Security level is default
Split horizon is enabled
ICMP redirects are always sent
ICMP unreachables are always sent
ICMP mask replies are never sent
IP fast switching is disabled
IP fast switching on the same interface is disabled
IP Flow switching is disabled
IP Fast switching turbo vector
IP multicast fast switching is disabled
IP multicast distributed fast switching is disabled
Router Discovery is disabled
IP output packet accounting is disabled
IP access violation accounting is disabled

25
Network Routing and Fundamentals Case Study 2

TCP/IP header compression is disabled


RTP/IP header compression is disabled
Probe proxy name replies are disabled
Policy routing is disabled
Network address translation is disabled
WCCP Redirect outbound is disabled
WCCP Redirect exclude is disabled
BGP Policy Mapping is disabled
Serial3/0 is up, line protocol is up (connected)
Internet address is 172.17.3.5/30
Broadcast address is 255.255.255.255
Address determined by setup command
MTU is 1500
Helper address is not set
Directed broadcast forwarding is disabled
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Security level is default
Split horizon is enabled
ICMP redirects are always sent
ICMP unreachables are always sent
ICMP mask replies are never sent
IP fast switching is disabled
IP fast switching on the same interface is disabled
IP Flow switching is disabled
IP Fast switching turbo vector
IP multicast fast switching is disabled
IP multicast distributed fast switching is disabled

26
Network Routing and Fundamentals Case Study 2

Router Discovery is disabled


IP output packet accounting is disabled
IP access violation accounting is disabled
TCP/IP header compression is disabled
RTP/IP header compression is disabled
Probe proxy name replies are disabled
Policy routing is disabled
Network address translation is disabled
WCCP Redirect outbound is disabled
WCCP Redirect exclude is disabled
BGP Policy Mapping is disabled
FastEthernet4/0 is administratively down, line protocol is down (disabled)
Internet protocol processing disabled
FastEthernet5/0 is administratively down, line protocol is down (disabled)
Internet protocol processing disabled
Center#

Boaz Show IP Interface


Boaz#sh ip interface
FastEthernet0/0 is up, line protocol is up (connected)

27
Network Routing and Fundamentals Case Study 2

Internet address is 172.17.0.1/24


Broadcast address is 255.255.255.255
Address determined by setup command
MTU is 1500
Helper address is not set
Directed broadcast forwarding is disabled
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Security level is default
Split horizon is enabled
ICMP redirects are always sent
ICMP unreachables are always sent
ICMP mask replies are never sent
IP fast switching is disabled
IP fast switching on the same interface is disabled
IP Flow switching is disabled
IP Fast switching turbo vector
IP multicast fast switching is disabled
IP multicast distributed fast switching is disabled
Router Discovery is disabled
IP output packet accounting is disabled
IP access violation accounting is disabled
TCP/IP header compression is disabled
RTP/IP header compression is disabled
Probe proxy name replies are disabled
Policy routing is disabled
Network address translation is disabled
WCCP Redirect outbound is disabled

28
Network Routing and Fundamentals Case Study 2

WCCP Redirect exclude is disabled


BGP Policy Mapping is disabled
FastEthernet1/0 is administratively down, line protocol is down (disabled)
Internet protocol processing disabled
Serial2/0 is administratively down, line protocol is down (disabled)
Internet protocol processing disabled
Serial3/0 is up, line protocol is up (connected)
Internet address is 172.17.3.6/30
Broadcast address is 255.255.255.255
Address determined by setup command
MTU is 1500
Helper address is not set
Directed broadcast forwarding is disabled
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Security level is default
Split horizon is enabled
ICMP redirects are always sent
ICMP unreachables are always sent
ICMP mask replies are never sent
IP fast switching is disabled
IP fast switching on the same interface is disabled
IP Flow switching is disabled
IP Fast switching turbo vector
IP multicast fast switching is disabled
IP multicast distributed fast switching is disabled
Router Discovery is disabled
IP output packet accounting is disabled

29
Network Routing and Fundamentals Case Study 2

IP access violation accounting is disabled


TCP/IP header compression is disabled
RTP/IP header compression is disabled
Probe proxy name replies are disabled
Policy routing is disabled
Network address translation is disabled
WCCP Redirect outbound is disabled
WCCP Redirect exclude is disabled
BGP Policy Mapping is disabled
FastEthernet4/0 is administratively down, line protocol is down (disabled)
Internet protocol processing disabled
FastEthernet5/0 is administratively down, line protocol is down (disabled)
Internet protocol processing disabled
Boaz#

Eva Show IP Interface


Eva#sh ip interface
FastEthernet0/0 is up, line protocol is up (connected)

30
Network Routing and Fundamentals Case Study 2

Internet address is 172.17.2.1/24


Broadcast address is 255.255.255.255
Address determined by setup command
MTU is 1500
Helper address is not set
Directed broadcast forwarding is disabled
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Security level is default
Split horizon is enabled
ICMP redirects are always sent
ICMP unreachables are always sent
ICMP mask replies are never sent
IP fast switching is disabled
IP fast switching on the same interface is disabled
IP Flow switching is disabled
IP Fast switching turbo vector
IP multicast fast switching is disabled
IP multicast distributed fast switching is disabled
Router Discovery is disabled
IP output packet accounting is disabled
IP access violation accounting is disabled
TCP/IP header compression is disabled
RTP/IP header compression is disabled
Probe proxy name replies are disabled
Policy routing is disabled
Network address translation is disabled
WCCP Redirect outbound is disabled

31
Network Routing and Fundamentals Case Study 2

WCCP Redirect exclude is disabled


BGP Policy Mapping is disabled
FastEthernet1/0 is administratively down, line protocol is down (disabled)
Internet protocol processing disabled
Serial2/0 is up, line protocol is up (connected)
Internet address is 172.17.3.2/30
Broadcast address is 255.255.255.255
Address determined by setup command
MTU is 1500
Helper address is not set
Directed broadcast forwarding is disabled
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Security level is default
Split horizon is enabled
ICMP redirects are always sent
ICMP unreachables are always sent
ICMP mask replies are never sent
IP fast switching is disabled
IP fast switching on the same interface is disabled
IP Flow switching is disabled
IP Fast switching turbo vector
IP multicast fast switching is disabled
IP multicast distributed fast switching is disabled
Router Discovery is disabled
IP output packet accounting is disabled
IP access violation accounting is disabled
TCP/IP header compression is disabled

32
Network Routing and Fundamentals Case Study 2

RTP/IP header compression is disabled


Probe proxy name replies are disabled
Policy routing is disabled
Network address translation is disabled
WCCP Redirect outbound is disabled
WCCP Redirect exclude is disabled
BGP Policy Mapping is disabled
Serial3/0 is administratively down, line protocol is down (disabled)
Internet protocol processing disabled
FastEthernet4/0 is administratively down, line protocol is down (disabled)
Internet protocol processing disabled
FastEthernet5/0 is administratively down, line protocol is down (disabled)
Internet protocol processing disabled
Eva#

Appendix5e

Center Show Version


Center#sh version
Cisco Internetwork Operating System Software

33
Network Routing and Fundamentals Case Study 2

IOS (tm) PT1000 Software (PT1000-I-M), Version 12.2(28), RELEASE SOFTWARE


(fc5)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2005 by cisco Systems, Inc.
Compiled Wed 27-Apr-04 19:01 by miwang
Image text-base: 0x8000808C, data-base: 0x80A1FECC
ROM: System Bootstrap, Version 12.1(3r)T2, RELEASE SOFTWARE (fc1)
Copyright (c) 2000 by cisco Systems, Inc.
ROM: PT1000 Software (PT1000-I-M), Version 12.2(28), RELEASE SOFTWARE
(fc5)
System returned to ROM by reload
System image file is "flash:pt1000-i-mz.122-28.bin"

PT 1001 (PTSC2005) processor (revision 0x200) with 60416K/5120K bytes of


memory
Processor board ID PT0123 (0123)
PT2005 processor: part number 0, mask 01
Bridging software.
X.25 software, Version 3.0.0.
4 FastEthernet/IEEE 802.3 interface(s)
2 Low-speed serial(sync/async) network interface(s)
32K bytes of non-volatile configuration memory.
63488K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x2102


Center#
Boaz Show Version
Boaz#sh version
Cisco Internetwork Operating System Software
IOS (tm) PT1000 Software (PT1000-I-M), Version 12.2(28), RELEASE SOFTWARE
(fc5)

34
Network Routing and Fundamentals Case Study 2

Technical Support: http://www.cisco.com/techsupport


Copyright (c) 1986-2005 by cisco Systems, Inc.
Compiled Wed 27-Apr-04 19:01 by miwang
Image text-base: 0x8000808C, data-base: 0x80A1FECC
ROM: System Bootstrap, Version 12.1(3r)T2, RELEASE SOFTWARE (fc1)
Copyright (c) 2000 by cisco Systems, Inc.
ROM: PT1000 Software (PT1000-I-M), Version 12.2(28), RELEASE SOFTWARE
(fc5)
System returned to ROM by reload
System image file is "flash:pt1000-i-mz.122-28.bin"
PT 1001 (PTSC2005) processor (revision 0x200) with 60416K/5120K bytes of
memory
Processor board ID PT0123 (0123)
PT2005 processor: part number 0, mask 01
Bridging software.
X.25 software, Version 3.0.0.
4 FastEthernet/IEEE 802.3 interface(s)
2 Low-speed serial(sync/async) network interface(s)
32K bytes of non-volatile configuration memory.
63488K bytes of ATA CompactFlash (Read/Write)
Configuration register is 0x2102

Boaz#

Eva Show Version


Eva#sh version
Cisco Internetwork Operating System Software
IOS (tm) PT1000 Software (PT1000-I-M), Version 12.2(28), RELEASE SOFTWARE
(fc5)
Technical Support: http://www.cisco.com/techsupport
35
Network Routing and Fundamentals Case Study 2

Copyright (c) 1986-2005 by cisco Systems, Inc.


Compiled Wed 27-Apr-04 19:01 by miwang
Image text-base: 0x8000808C, data-base: 0x80A1FECC
ROM: System Bootstrap, Version 12.1(3r)T2, RELEASE SOFTWARE (fc1)
Copyright (c) 2000 by cisco Systems, Inc.
ROM: PT1000 Software (PT1000-I-M), Version 12.2(28), RELEASE SOFTWARE
(fc5)
System returned to ROM by reload
System image file is "flash:pt1000-i-mz.122-28.bin"
PT 1001 (PTSC2005) processor (revision 0x200) with 60416K/5120K bytes of
memory
Processor board ID PT0123 (0123)
PT2005 processor: part number 0, mask 01
Bridging software.
X.25 software, Version 3.0.0.
4 FastEthernet/IEEE 802.3 interface(s)
2 Low-speed serial(sync/async) network interface(s)
32K bytes of non-volatile configuration memory.
63488K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x2102

Eva#

Appendix 5f

Center Show Hosts


Center#show hosts
Default Domain is not set
Name/address lookup uses domain service
Name servers are 0.0.0.0

36
Network Routing and Fundamentals Case Study 2

Codes: UN - unknown, EX - expired, OK - OK, ?? - revalidate


temp - temporary, perm - permanent
NA - Not Applicable None - Not defined

Host Port Flags Age Type Address(es)


Center#

Boaz Show Hosts


Boaz#sh hosts
Default Domain is not set
Name/address lookup uses domain service
Name servers are 0.0.0.0

37
Network Routing and Fundamentals Case Study 2

Codes: UN - unknown, EX - expired, OK - OK, ?? - revalidate


temp - temporary, perm - permanent
NA - Not Applicable None - Not defined

Host Port Flags Age Type Address(es)


Boaz#

Eva Show Hosts


Eva#sh hosts
Default Domain is not set
Name/address lookup uses domain service
Name servers are 0.0.0.0

38
Network Routing and Fundamentals Case Study 2

Codes: UN - unknown, EX - expired, OK - OK, ?? - revalidate


temp - temporary, perm - permanent
NA - Not Applicable None - Not defined

Host Port Flags Age Type Address(es)


Eva#

Appendix 5g

Center Show Startup-Config


Center#sh startup-config
Using 1173 bytes
!

39
Network Routing and Fundamentals Case Study 2

version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Center
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
ip name-server 0.0.0.0
!
interface FastEthernet0/0
description Link to Center Switch
ip address 172.17.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface Serial2/0
description Link to Eva Via Serial Cable
ip address 172.17.3.1 255.255.255.252
clock rate 64000
!
interface Serial3/0

40
Network Routing and Fundamentals Case Study 2

description Link to Boaz Via Serial Cable


ip address 172.17.3.5 255.255.255.252
clock rate 64000
!
interface FastEthernet4/0
no ip address
shutdown
!
interface FastEthernet5/0
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
passive-interface FastEthernet0/0
network 172.17.1.0 0.0.0.255 area 0
network 172.17.3.0 0.0.0.3 area 0
network 172.17.3.4 0.0.0.3 area 0
!
ip classless
!
banner motd ^C No Unauthorised Access ^C
!
line con 0
exec-timeout 0 0
password class
logging synchronous
login
line vty 0 4

41
Network Routing and Fundamentals Case Study 2

password class
login
!
end
Center#

Boaz Show Startup-Config


Boaz#show startup-config
Using 1046 bytes
!
version 12.2

42
Network Routing and Fundamentals Case Study 2

no service timestamps log datetime msec


no service timestamps debug datetime msec
no service password-encryption
!
hostname Boaz
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
ip name-server 0.0.0.0
!
interface FastEthernet0/0
description Link to Boaz Switch 1
ip address 172.17.0.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface Serial2/0
no ip address
shutdown
!
interface Serial3/0
description Link to Centre Via Serial Cable
ip address 172.17.3.6 255.255.255.252

43
Network Routing and Fundamentals Case Study 2

!
interface FastEthernet4/0
no ip address
shutdown
!
interface FastEthernet5/0
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
passive-interface FastEthernet0/0
network 172.17.3.4 0.0.0.3 area 0
network 172.17.0.0 0.0.0.255 area 0
!
ip classless
!
banner motd ^C No Unauthorised Access ^C
!
line con 0
exec-timeout 0 0
password class
logging synchronous
login
line vty 0 4
password class
login
!
end

44
Network Routing and Fundamentals Case Study 2

Boaz#

Eva Show Startup-Config


Eva#sh startup-config
Using 1044 bytes
!
version 12.2

45
Network Routing and Fundamentals Case Study 2

no service timestamps log datetime msec


no service timestamps debug datetime msec
no service password-encryption
!
hostname Eva
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
ip name-server 0.0.0.0
!
interface FastEthernet0/0
description Link to Eva switch
ip address 172.17.2.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface Serial2/0
description Link to Centre Via Serial Cable
ip address 172.17.3.2 255.255.255.252
!
interface Serial3/0
no ip address
shutdown

46
Network Routing and Fundamentals Case Study 2

!
interface FastEthernet4/0
no ip address
shutdown
!
interface FastEthernet5/0
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
passive-interface FastEthernet0/0
network 172.17.2.0 0.0.0.255 area 0
network 172.17.0.0 0.0.3.255 area 0
!
ip classless
!
banner motd ^C No Unauthorised Access ^C
!
line con 0
exec-timeout 0 0
password class
logging synchronous
login
line vty 0 4
password class
login
!
end

47
Network Routing and Fundamentals Case Study 2

Eva#

48