Sei sulla pagina 1di 22

Lo sharpening, i metodi: High Pass e Smart Sharpen

18/02/16 11:23

[ Home ] [ Bio ] [ I link ] [ Gallerie ] [ Tutorial ] [ Contattami ] [ Miscellanea ] [ Cartoline ]

Lo sharpening, i metodi: High Pass e Smart Sharpen


In questo terzo articolo della serie esporremo due metodi molto sofisticati per fare lo
sharpening. Entrambi si basano sul trovare i bordi dell'immagine, cio proprio quei punti che si
vogliono lavorare. I due metodi si chiamano:
High Pass
Smart Sharpen

High Pass
Questo metodo si basa su un filtraggio passa alto del file immagine. Filtrando in questo modo
unimmagine si evidenziano i particolari pi fini, cio proprio quelli che si vuole affilare.
Per prima cosa duplicate il livello dellimmagine.

http://www.aristidetorrelli.it/Articoli/sharpening/Sharpening_3.htm

Pagina 1 di 22

Lo sharpening, i metodi: High Pass e Smart Sharpen

18/02/16 11:23

Ora, con questo livello attivo, selezionate Filter / Other / High Pass. Impostate il raggio a 10 e
premete OK. Se ingrandite limmagine potete vedere meglio quello che state facendo.

http://www.aristidetorrelli.it/Articoli/sharpening/Sharpening_3.htm

Pagina 2 di 22

Lo sharpening, i metodi: High Pass e Smart Sharpen

http://www.aristidetorrelli.it/Articoli/sharpening/Sharpening_3.htm

18/02/16 11:23

Pagina 3 di 22

Lo sharpening, i metodi: High Pass e Smart Sharpen

18/02/16 11:23

A questo punto impostate il metodo di fusione a Hard Light.

http://www.aristidetorrelli.it/Articoli/sharpening/Sharpening_3.htm

Pagina 4 di 22

Lo sharpening, i metodi: High Pass e Smart Sharpen

18/02/16 11:23

ed il risultato unimmagine che, molto probabilmente, troppo affilata

http://www.aristidetorrelli.it/Articoli/sharpening/Sharpening_3.htm

Pagina 5 di 22

Lo sharpening, i metodi: High Pass e Smart Sharpen

18/02/16 11:23

Regolando lintensit delleffetto scegliendo unopacit appropriata, di solito tra 20% e 70%, si
ottiene un risultato naturale.

http://www.aristidetorrelli.it/Articoli/sharpening/Sharpening_3.htm

Pagina 6 di 22

Lo sharpening, i metodi: High Pass e Smart Sharpen

18/02/16 11:23

Questo loriginale non trattato, per un confronto.

http://www.aristidetorrelli.it/Articoli/sharpening/Sharpening_3.htm

Pagina 7 di 22

Lo sharpening, i metodi: High Pass e Smart Sharpen

18/02/16 11:23

Smart sharpen: lo sharpening intelligente


Il problema pi grande di USM che viene applicato a tutta limmagine, anche alle parti che non
ne hanno bisogno. Come fare per applicarlo solo dove serve, cio ai bordi?
Utilizziamo il filtro Find Edges (Trova bordi). Se potessimo applicare lo sharpening solo ai bordi,
che poi dove serve, e lasciare il resto dellimmagine inalterato, avremmo raggiunto il nostro
scopo.
Vediamo come fare.
Per prima cosa duplicare il livello e poi ...
Selezionate la palette Channels (Canali) e create un nuovo canale. E la terza icona da
sinistra in basso, come mostrato dallimmagine.
Questo canale sar una maschera che definir su quali parti dellimmagine faremo lo
sharpening.

http://www.aristidetorrelli.it/Articoli/sharpening/Sharpening_3.htm

Pagina 8 di 22

Lo sharpening, i metodi: High Pass e Smart Sharpen

18/02/16 11:23

Chiamatelo Sharpen e definite il colore per indicare le are mascherate (lasciate la scelta di
default, il rosso).

http://www.aristidetorrelli.it/Articoli/sharpening/Sharpening_3.htm

Pagina 9 di 22

Lo sharpening, i metodi: High Pass e Smart Sharpen

18/02/16 11:23

Ora copiamo limmagine nel canale maschera:


fate click sul canale RGB
selezionate tutto (Select -> Select All)
Copia (Edit -> Copy)

fate click sul canale Sharpen e selezionate incolla (Edit -> Paste).

http://www.aristidetorrelli.it/Articoli/sharpening/Sharpening_3.htm

Pagina 10 di 22

Lo sharpening, i metodi: High Pass e Smart Sharpen

18/02/16 11:23

Dovreste vedere uno schermo come il seguente, con limmagine in toni di grigio.

http://www.aristidetorrelli.it/Articoli/sharpening/Sharpening_3.htm

Pagina 11 di 22

Lo sharpening, i metodi: High Pass e Smart Sharpen

18/02/16 11:23

Ora utilizziamo il commando trova bordi per isolare I bordi dellimmagine che useremo come
base per selezionare su cosa fare sharpening e su cosa no.
Selezionate Filter -> Stylize -> Find Edges

http://www.aristidetorrelli.it/Articoli/sharpening/Sharpening_3.htm

Pagina 12 di 22

Lo sharpening, i metodi: High Pass e Smart Sharpen

18/02/16 11:23

Questo il risultato:

http://www.aristidetorrelli.it/Articoli/sharpening/Sharpening_3.htm

Pagina 13 di 22

Lo sharpening, i metodi: High Pass e Smart Sharpen

18/02/16 11:23

E importante capire cosa rappresenta questa immagine: una mappatura dei punti
dellimmagine dove verr applicato lunsharp mask. Le aree nere avranno lo sharpening
applicato, quelle bianche no. Le aree grigie avranno pi o meno sharpening a seconda di
quanto sono scure o chiare. E la maschera che abbiamo costruito e che non andr a modificare
limmagine originale ma solo a scegliere dove e quanto fare sharpening.
Ora aggiustiamo la tonalit in modo che dove vogliamo lo sharpening sia veramente nero e
dove non lo vogliamo sia bianco.
Image -> Adjustment -> Levels il commando da eseguire. Portate su il punto di nero e
gi il punto di bianco.

http://www.aristidetorrelli.it/Articoli/sharpening/Sharpening_3.htm

Pagina 14 di 22

Lo sharpening, i metodi: High Pass e Smart Sharpen

18/02/16 11:23

Ora applichiamo una sfumatura gaussiana per addolcire le transizioni tra le aree dove si
applicato lo sharpening e quelle dove non lo si applicato.
Scegliete voi quanto fare, io di solito scelgo il valore di 3 pixel. Un valore fino a 10 va comunque
bene,

http://www.aristidetorrelli.it/Articoli/sharpening/Sharpening_3.htm

Pagina 15 di 22

Lo sharpening, i metodi: High Pass e Smart Sharpen

18/02/16 11:23

Bene, ora dobbiamo trasformare il canale in una selezione dellimmagine originale, dove i punti
neri sono selezionati e i bianchi no..
Selezionate Select -> Load Selection e assicuratevi che il canale sia Sharpen e il
checkbox invert sia selezionato.

http://www.aristidetorrelli.it/Articoli/sharpening/Sharpening_3.htm

Pagina 16 di 22

Lo sharpening, i metodi: High Pass e Smart Sharpen

http://www.aristidetorrelli.it/Articoli/sharpening/Sharpening_3.htm

18/02/16 11:23

Pagina 17 di 22

Lo sharpening, i metodi: High Pass e Smart Sharpen

18/02/16 11:23

Fate click sul tab dei livelli e assicuratevi che limmagine originale sia visibile. Dovreste
vedere una selezione sullimmagine (quella specie di griglietta sulla tigre).

http://www.aristidetorrelli.it/Articoli/sharpening/Sharpening_3.htm

Pagina 18 di 22

Lo sharpening, i metodi: High Pass e Smart Sharpen

18/02/16 11:23

Se la selezione vi da fastidio nel giudicare lanteprima, potete renderla invisibile con View ->
Hide Extras (Ctrl-H).

Ci siamo: Filter -> Sharpen -> Unsharp Mask e inserite alcuni numeri. Potete arrivare ad
ammontare di 400% o 500% senza problemi.

http://www.aristidetorrelli.it/Articoli/sharpening/Sharpening_3.htm

Pagina 19 di 22

Lo sharpening, i metodi: High Pass e Smart Sharpen

18/02/16 11:23

Ecco limmagine con lo sharpen applicato

http://www.aristidetorrelli.it/Articoli/sharpening/Sharpening_3.htm

Pagina 20 di 22

Lo sharpening, i metodi: High Pass e Smart Sharpen

18/02/16 11:23

e quella originale

http://www.aristidetorrelli.it/Articoli/sharpening/Sharpening_3.htm

Pagina 21 di 22

Lo sharpening, i metodi: High Pass e Smart Sharpen

18/02/16 11:23

A video le differenze ci sono ma non sono eccessivamente visibili. Vi assicuro che sulla
stampa si vedono tutte!

Conclusioni
In questo terzo articolo abbiamo visto due metodi evoluti per affilare le immagini. La
padronanza di queste tecniche e la conoscenza dei loro punti di forza vi permetter di
stampare immagini con un aspetto veramente eccellente dal punto di vista della nitidezza.
2007 Aristide Torrelli

http://www.aristidetorrelli.it/Articoli/sharpening/Sharpening_3.htm

Pagina 22 di 22