Sei sulla pagina 1di 5

Redistribute BGP to EIGRP (Default route)

OK I have a lab set up for BGP and i can't seem to get the default route from
BGP in to EIGRP.
on the edge router i have
router eigrp 10
redistribute bgp 65010
network 10.30.1.1 0.0.0.0
network 192.168.0.0 0.0.255.255
no auto-summary
!
router bgp 65010
no synchronization
bgp log-neighbor-changes
bgp redistribute-internal
neighbor 10.30.2.2 remote-as 65010
neighbor 10.30.2.2 update-source Loopback1
neighbor 172.16.1.1 remote-as 65020
no auto-summary

172.16.0.0/24 is subnetted, 1 subnets


C 172.16.1.0 is directly connected, Serial0/0
D 192.168.4.0/24 [90/307200] via 192.168.2.2, 00:01:50, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
D 10.10.0.0/16 [90/409600] via 192.168.2.2, 00:01:50, FastEthernet0/0
D 10.30.2.2/32 [90/409600] via 192.168.1.2, 00:35:06, FastEthernet0/1
C 10.30.1.1/32 is directly connected, Loopback1
D 10.20.0.0/16 [90/435200] via 192.168.2.2, 00:01:49, FastEthernet0/0
[90/435200] via 192.168.1.2, 00:01:49, FastEthernet0/1
C 192.168.1.0/24 is directly connected, FastEthernet0/1
C 192.168.2.0/24 is directly connected, FastEthernet0/0

D 192.168.3.0/24 [90/307200] via 192.168.1.2, 00:01:49, FastEthernet0/1


B* 0.0.0.0/0 [20/0] via 172.16.1.1, 00:04:26

So i can see the default router comming in via BGP, and the redistribution
commands are there (narrowed it down to a single default route and got rid of
route maps to make it as simple as possible) on the down stream router i have

router eigrp 10
network 10.10.0.0 0.0.255.255
network 192.168.0.0 0.0.255.255
no auto-summary
172.16.0.0/24 is subnetted, 1 subnets
C 172.16.1.0 is directly connected, Tunnel0
C 192.168.4.0/24 is directly connected, FastEthernet0/1
10.0.0.0/8 is variably subnetted, 9 subnets, 3 masks
D 10.10.0.0/16 is a summary, 00:35:54, Null0
C 10.10.10.0/24 is directly connected, Loopback1
D 10.30.2.2/32 [90/435200] via 192.168.4.2, 00:02:33, FastEthernet0/1
[90/435200] via 192.168.2.1, 00:02:33, FastEthernet0/0
D 10.30.1.1/32 [90/409600] via 192.168.2.1, 00:02:34, FastEthernet0/0
C 10.10.20.0/24 is directly connected, Loopback2
D 10.20.0.0/16 [90/409600] via 192.168.4.2, 00:02:34, FastEthernet0/1
C 10.10.30.0/24 is directly connected, Loopback3
C 10.10.40.0/24 is directly connected, Loopback4
C 10.10.50.0/24 is directly connected, Loopback5
D 192.168.1.0/24 [90/307200] via 192.168.2.1, 00:02:36, FastEthernet0/0
C 192.168.2.0/24 is directly connected, FastEthernet0/0
D 192.168.3.0/24 [90/307200] via 192.168.4.2, 00:02:36, FastEthernet0/1

interface FastEthernet0/0
ip address 192.168.30.1 255.255.255.0
router eigrp 1
redistribute bgp 65002 route-map TEST
network 192.168.30.0
no auto-summary
router bgp 65002
no synchronization
bgp log-neighbor-changes
network 192.168.30.0
redistribute eigrp 1
neighbor 10.10.10.30 remote-as 7018
no auto-summary
route-map TEST permit 1
match ip address 100

Folks

I not understanding why this is happening I have 3 routers as in the


diagram above
whebn the link between Remote_SITE and RTR A , I would like the the path to
take RTR B to get to the network on RTR C
The problem is that at RTR B the route from BGP when distrubted into EIGRP
65001is not being advertided to the REMOTE SITE
RTR A
router eigrp 777

redistribute eigrp 65000 metric 10000 100 255 1 1500


network 172.21.128.1 0.0.0.0
no auto-summary
!
router eigrp 65000
redistribute eigrp 777 metric 10000 100 255 1 1500
network 172.17.1.2 0.0.0.0
network 172.17.255.2 0.0.0.0
no auto-summary
!
router bgp 65000
no synchronization
bgp router-id 172.17.255.2
bgp log-neighbor-changes
redistribute eigrp 65000 metric 28416
neighbor BGP_CORE_RENO peer-group
neighbor BGP_CORE_RENO remote-as 65001
neighbor BGP_CORE_RENO password *******
neighbor BGP_CORE_RENO next-hop-self
neighbor BGP_CORE_RENO soft-reconfiguration inbound
neighbor 172.17.222.2 peer-group BGP_CORE_RENO
no auto-summary
RTR B
router eigrp 777
redistribute eigrp 65001 metric 10000 100 255 1 1500
network 172.22.128.1 0.0.0.0
no auto-summary
!
router eigrp 65001
redistribute eigrp 777 metric 10000 100 255 1 1500
redistribute bgp 65001 metric 10000 100 255 1 1500
network 172.19.1.10 0.0.0.0
network 172.19.255.4 0.0.0.0
no auto-summary
!
router eigrp 6500
auto-summary
!
router bgp 65001
no synchronization
bgp router-id 172.19.255.4
bgp log-neighbor-changes
redistribute eigrp 65001 metric 28416

neighbor BGP_CORE_LASVEGAS remote-as 65000


neighbor BGP_CORE_LASVEGAS password *********
neighbor BGP_CORE_LASVEGAS next-hop-self
neighbor BGP_CORE_LASVEGAS soft-reconfiguration inbound
neighbor 172.17.222.1 peer-group BGP_CORE_LASVEGAS

Potrebbero piacerti anche