Sei sulla pagina 1di 20
ingegnere

ingegnere

Appunti per il corso ArcGIS for AutoCAD

ingegnere Appunti per il corso ArcGIS for AutoCAD Dott. ing. Antonio Barsottini e-mail: a.barsottini@tiscali.it
ingegnere Appunti per il corso ArcGIS for AutoCAD Dott. ing. Antonio Barsottini e-mail: a.barsottini@tiscali.it

Dott. ing. Antonio Barsottini e-mail: a.barsottini@tiscali.it

ESERCITAZIONE 16. In questa esercitazione definiremo delle feature class ed i relativi attributi relativi alle caratteristiche morfometriche ed idrologico-idrauliche di un bacino idrografico.

ed idrologico-idrauliche di un bacino idrografico. Il bacino in esame è costituito da 10 sottobacini, ciascuno

Il bacino in esame è costituito da 10 sottobacini, ciascuno dei quali è delimitato da una polilinea 2d chiusa. Occorre osservare che due sottobacini adiacenti hanno una porzione della linea spartiacque che si sovrappone, in quanto in AutoCAD non è possibile gestire la proprietà topologica di adiacenza.

Nella tabella seguente sono raccolte le caratteristiche morfometriche principali di ciascun sottobacino ed il valore del parametro CN. Tale ultima grandezza dipende dalla permeabilità e dall’uso del suolo del bacino, e viene calcolata secondo una procedura messa a punto dal Soil Conservation Service del Dipartimento dell’Agricoltura degli USA. Si tratta di una caratteristica che viene utilizzata durante la fase di studio idrologico - idraulica del bacino finalizzata alla modellazione afflussi-deflussi.

del bacino finalizzata alla modellazione afflussi-deflussi. Antonio Barsottini Appunti per il corso CAD + GIS Pag.
del bacino finalizzata alla modellazione afflussi-deflussi. Antonio Barsottini Appunti per il corso CAD + GIS Pag.
 

Superficie (km 2 )

Pendenza

CN

Sviluppo

 

bacino

media del

(-)

spartiacque

   

bacino (%)

(km)

1 Fosso del Fondo e Canale dei Mulini

6.13

70.17

70

9.8

 

2 Gora degli Opifici

4.85

9.29

80

16.4

3 Canale di Santa Maria

2.44

27.12

70

9.1

4 Solco di San Giovanni

0.91

45.31

70

5.8

 

5 Valdicastello

2.89

51.02

74

7.0

 

6 Rio di Carraietta

1.93

31.64

70

8.4

 

7 Cassa di espansione

0.09

0.42

76

1.8

8 Canale acque alte Teso

10.84

0

79

1.5

9

Cassa di espansione 2

0.38

0.27

72

2.8

 

10 Quadrellara

4.67

0

81

9.1

Tabella 1

Nella tabella seguente sono raccolte le portate massime defluenti in corrispondenza delle sezioni di chiusura dei sottobacini.

nodo

Q max (m 3 )

Conf. Fosso Fondo Canale Mulini (J7)

62.0

Imm. Solco di San Giovanni (J1)

103.4

Imm. Canale di Santa Maria (J2)

133.2

Imm. Rio di Carraietta (J3)

147.5

Imm. Comprensorio di bonifica (J6)

197.5

Tabella 2

L’ordine con cui sono elencati in tabella i nodi corrisponde a quello da monte verso valle.

Con questi dati è possibile definire le feature class raccolte nella tabella seguente; in essa, per ciascuna classe, è riportato il relativo tipo e le entità CAD che ne andranno a far parte.

feature class

fetaure

entità CAD

name

class tipe

sezione_chiusura

point

punto

bacino

polygon

closed polyline

Tabella 3

punto bacino polygon closed polyline Tabella 3 Antonio Barsottini Appunti per il corso CAD + GIS
punto bacino polygon closed polyline Tabella 3 Antonio Barsottini Appunti per il corso CAD + GIS

Nella tabella seguente sono raccolte le proprietà CAD principali delle entità facenti parte delle diverse feature class.

feature class

 

proprietà CAD principali

 

name

layer

colore

tipo linea

scala tipo linea

spessore

sezione_chiusura

sezione_chiusura

rosso

continua

1.0000

da layer

(default)

bacino

bacino

verde

continua

1.0000

da layer

(default)

Tabella 4

La tabella successiva riporta, infine, i campi di ciascuna feature class.

feature class name

 

field

nome

tipo

valore default

sezione_chiusura

id_sezione_chiusura

text

-

Qmax_sezione

real

-

bacino

id_bacino

text

-

superficie

real

-

pendenza

real

-

CN

integer

77

sviluppo_spartiacque

real

-

Tabella 5

Bisogna osservare che poter eseguire un’interrogazione che coinvolga le proprietà geometriche e quelle attributive delle entità presenti, può essere utile che le prime vengano caricate tra gli attributi. Come vedremo nell’esempio che segue, l’immissione dei dati può essere facilitata utilizzando alcuni strumenti di AutoCAD, quali l’esecuzione della misura di una distanza o lo sviluppo di operazioni aritmetiche mediante calcolatrice.

Apriamo il file esercitazione16.dwg contenente il disegno di un bacino idrografico costituito da 10 sottobacini (delimitati da polilinea appartenenti al layer “bacino”); in corrispondenza delle sezioni di chiusura sono disegnati dei punti utilizzando il layer “sezione_chiusura”.

dei punti utilizzando il layer “sezione_chiusura”. Antonio Barsottini Appunti per il corso CAD + GIS Pag.
dei punti utilizzando il layer “sezione_chiusura”. Antonio Barsottini Appunti per il corso CAD + GIS Pag.

Definizione delle feature class.

1. Definiamo la feature class bacino seguendo la seguente procedura: cliccare sull’icona New feature class: digitare il nome delle feature class che sintende creare (bacino), scegliere come tipo (type) quello polyline e lasciare in bianco la voce Copy fields from, poiché l’immissione dei campi avviene direttamente da tastiera;

2. Cliccare sulla freccina del menu a tendina e selezionare la voce layer, premere sul bottone Add e selezionare il layer bacino. In tal modo imponiamo che possano appartenere alla feature class bacino solo le entità che appartengono all’omonimo layer. Questa imposizione, congiuntamente alle omologhe per le altre feature class, impedisce che attributi relativi a classi diverse vengano condivisi. Ciò in quanto le entità CAD che possono far parte di una classe tipo polygon, possono costituire anche una classe di tipo polyline.

3. Cliccare sulla casella bianca in basso e digitare il nome del primo attributo (id), scegliere il tipo text e cliccare sul bottone Add Field. Ripetere per gli altri attributi specificando nella colonna Default Value il valore di default, ove presente. Volendo cancellare un attributo già definito è sufficiente cliccare sul suo nome e premere il tasto CANC sulla tastiera. Al termine dell’operazione la scheda degli attributi dovrebbe apparire come la seguente.

scheda degli attributi dovrebbe apparire come la seguente. 4. Selezionando ciascun bacino e richiamando il relativo

4. Selezionando ciascun bacino e richiamando il relativo pannello delle proprietà si osserva che è comparsa, nella parte bassa, una nuova sezione denominata bacino (il nome della feature class), che riassume gli attributi dell’entità selezionata. Le modifiche dei valori degli attributi dell’entità selezionata rispetto a quelli di default devono essere apportate da questo pannello, agendo direttamente sulle voci d’interesse. Operando in

agendo direttamente sulle voci d’interesse. Operando in Antonio Barsottini Appunti per il corso CAD + GIS
agendo direttamente sulle voci d’interesse. Operando in Antonio Barsottini Appunti per il corso CAD + GIS

questo modo provare a modificare tutti gli attributi secondo i dati della tabella 1. Per il campo denominato superficie è possibile eseguire il copia incolla dalla voce Area della sezione Geometry dello stesso pannello; per far questo è necessario cliccare sul simbolo della calcolatrice che compare nella riga dell’area e copiare il valore dalla relativa finestra.

dell’area e copiare il valore dalla relativa finestra. Nota. Al momento della creazione di una feature

Nota. Al momento della creazione di una feature class c’è la possibilità di importare la definizione dei campi di un’altra feature class che sia già stata definita. Per questo è sufficiente scegliere la voce Copy fields from e quindi selezionare la feature di riferimento.

fields from e quindi selezionare la feature di riferimento. 5. Ripetere il procedimento per l’altra feat

5. Ripetere il procedimento per l’altra feature class.

Nota. Per assegnare le coordinate ai punti della classe sezione_chiusuraè possibile cliccare prima sull’icona a forma di calcolatrice che compare nella finestra d’inserimento, quindi sul bottone Get Coordinates; occorre infine selezionare il punto

Get Coordinates ; occorre infine selezionare il punto Antonio Barsottini Appunti per il corso CAD +
Get Coordinates ; occorre infine selezionare il punto Antonio Barsottini Appunti per il corso CAD +

desiderato nella finestra grafica mediante il mouse e, nella finestrella d’inserimento, cancellare il simbolo della parentesi e la coordinata che non ci interessa tra le due che vengono inserite.

Selezione sugli attributi

Una volta disegnata la geometria ed inseriti gli attributi è possibile eseguire la selezione delle entità. In particolare la selezione può avvenire in base alle proprietà geometriche e grafiche, mediante il comando di AutoCAD QUICKPROPERTIES, già trattato nella prima parte del corso, ed in base agli attributi mediante gli strumenti del plug-in ArcGIS for AutoCAD. La selezione dal versante degli attributi produce come esito l’individuazione delle entità geometriche che hanno associati quegli attributi che soddisfano i criteri imposti nella selezione.

Per meglio comprendere il meccanismo di selezione in base agli attributi, possiamo pensare che gli attributi di ciascuna feature class vengano organizzati in tabelle, ciascuna riga delle quali corrisponde ad una entità e ciascuna colonna delle quali corrisponde ad un attributo. Le righe sono chiamate record e le colonne campi, column o field. Ai dati organizzati in questo modo si possono applicare gli strumenti di gestione dei database ed in particolare le cosiddette funzioni di ricerca.

Vediamo adesso quali sono gli strumenti disponibili per la selezione offerti dal plug-in. Il pannello Select della linguetta ArcGIS for AutoCAD presenta, nella parte superiore, un menu a tendina dal quale si può selezionare una feature class per renderla corrente; nel caso in cui non si esegua una scelta la finestra rimane bianca e si opera su tutte le feature. Nella sezione sottostante sono presenti delle icone che attivano i seguenti strumenti di interrogazione:

icone che attivano i seguenti strumenti di interrogazione: - Zoom to feature : seleziona ed esegue

- Zoom to feature: seleziona ed esegue uno zoom sulle entità della feature class corrente;

- Select All: seleziona le entità della feature class corrente;

- Select Objects: permette di selezionare tramite il mouse un’entità appartenente alla feature class corrente;

mouse un’entità appartenente alla feature class corrente; Antonio Barsottini Appunti per il corso CAD + GIS
mouse un’entità appartenente alla feature class corrente; Antonio Barsottini Appunti per il corso CAD + GIS

- Select by Attributes: seleziona le entità dal versante degli attributi, mediante la formulazione di un’espressione basata sullo Structured Query Language (SQL). Cliccando su questo bottone si apre la finestra seguente:

Cliccando su questo bottone si apre la finestra seguente: Nel menu a tendina della prima riga

Nel menu a tendina della prima riga bisogna selezionare la feature class sulla quale si vuole operare ed in quello della seconda riga la forma nella quale la selezione che andiamo ad eseguire si combina con eventuali precedenti selezioni. Le opzioni disponibili sono:

- Create new selection: crea una nuova selezione autonoma;

- Add to current selection: aggiunge il nuovo esito alle entità già selezionate;

- Remove from current selection: elimina dalla selezione corrente le nuove entità che andremo a selezionare;

- Select from current selection: estrae dalla selezione corrente gli elementi che soddisfano il nuovo criterio.

Nella terza sezione vengono elencati i campi della feature corrente; selezionando un campo e cliccando sul bottone Get Unique Values, vengono elencati tutti i valori assunti dalle entità presenti nel disegno. Questa funzione permette di avere sottomano il campo di variabilità della proprietà che stiamo esaminando.

Nella parte sottostante sono disponibili una serie di bottoni che attivano funzioni matematiche o logiche e che sono utili per costruire le espressioni attraverso le quali si ricercano i dati. La parte posta ancora più in basso permette di visualizzare l’espressione che andiamo a costruire. Infine la serie terminale di bottoni permette le seguenti operazioni:

- Clear: cancella l’espressione;

le seguenti operazioni: - Clear : cancella l’espressione; Antonio Barsottini Appunti per il corso CAD +
le seguenti operazioni: - Clear : cancella l’espressione; Antonio Barsottini Appunti per il corso CAD +

- Verify: verifica se l’espressione digitata soddisfa le regole sintattiche del linguaggio di ricerca e permette quindi di controllare se essa può essere interpretata dal programma; - Apply: lancia la ricerca;

- Close: chiude la finestra.

Vediamo a questo punto come possono essere composte le istanze di selezione. Lo Structured Query Language (SQL) è un linguaggio standard per accedere, interrogare e gestire i database; noi analizzeremo una sua funzione di ricerca dei dati, denominata SELECT, che prevede la formulazione, seconda una precisa sintassi, di interrogazioni dette query. Attraverso queste ultime vengono imposti uno o più criteri di ricerca all’interno delle tabelle in cui sono memorizzati gli attributi. È possibile eseguire interrogazioni molto semplici, quali ad esempio l’estrazione delle entità per le quali un attributo assume un valore prefissato (ad esempio la selezione dei sottobacini aventi un parametro CN = 82), oppure generare criteri più articolati, nei quali compaiono funzioni matematiche o che operano simultaneamente su più campi (ad esempio la selezione dei bacini aventi superficie inferiore a 3 km 2 e parametro CN>82). Secondo le convenzioni del linguaggio, i nomi dei campi sono rappresentati senza segni di delimitazione (virgolette), mentre le stringhe devono essere racchiuse da virgolette semplici. Per esempio CN identifica un campo e ‘Gora degli opifici’ una stringa di testo. Nella rappresentazione delle stringhe caratteri maiuscoli e minuscoli sono considerate entità diverse, così la stringa ‘gora degli opifici’ è considerata diversa dalla precedente. Come separatore decimale dei numeri viene utilizzato il punto e non la virgola.

Osservando la finestra Select by Attributes (vedi figura precedente) si può osservare la presenza dello statement SELECT*FROM WHERE, posto sopra la finestra inferiore. Analizziamone il significato: la sintassi del linguaggio prevede che dopo la proposizione SELECT vengano elencati gli attributi che si intendono estrarre; nel nostro caso è presente un asterisco, che è il simbolo identificativo del carattere jolly rappresentativo di un numero qualunque di caratteri qualunque. Ciò indica che si opera sulla totalità degli attributi della feature class selezionata. Ancora a seguire è presente la proposizione FROM, che permette di elencare i risultati della query. All’utente spetta il compito di costruire la parte dell’espressione che segue la proposizione WHERE, attraverso la quale si impone di includere nell’output solo le entità che soddisfano le condizioni di ricerca che verranno specificate.

Ad esempio per selezionare i bacini aventi un parametro CN pari a 70 è sufficiente operare nel seguente modo:

- Scegliere la Feature class bacino;

- Scegliere il metodo: Create a new selection;

- Fare doppio clic sul campo CN;

Create a new selection ; - Fare doppio clic sul campo CN ; Antonio Barsottini Appunti
Create a new selection ; - Fare doppio clic sul campo CN ; Antonio Barsottini Appunti

- Premere sul bottone dell’=;

- Digitare 70 da tastiera;

- Cliccare sul bottone Verify per controllare la correttezza della sintassi dell’espressione scritta;

- Cliccare sul bottone Apply per eseguire la selezione.

Alla fine di questa sequenza di operazioni risultano selezionate le polilinee a cui sono associati gli attributi che soddisfano il requisito richiesto, corrispondenti ai sottobacini 1,3,4,6 (vedi Tabella 1).

Dal punto di vista concettuale una funzione di ricerca come quella dell’esempio precedente, scorre tutte le righe della tabella degli attributi e seleziona quelle contenenti dati che soddisfano la condizione imposta, escludendo quelle contenti valori che non soddisfano la condizione o che hanno un valore NULL (sconosciuto o mancante) per almeno uno degli attributi interessati.

Un’espressione di ricerca può includere dei calcoli aritmetici che utilizzino gli operatori seguenti:

operatore

descrizione

+

addizione

-

sottrazione

*

moltiplicazione

/

divisione

Per esempio l’espressione: pendenza > 30/50*100 restituisce le entità per le quali il campo denominato pendenza contiene il numero 60, risultato dell’operazione di divisione (bacino 1).

Gli operatori di cui sopra possono essere applicati anche ai campi. Ad esempio può essere necessario eseguire un’interrogazione in base ai valori che assume la grandezza, caratteristica dei bacini, denominata rapporto di circolarità, che viene espressa dalla formula seguente:

Supponiamo quindi di voler individuare quei bacini per i quali R c >0.6. Il rapporto di circolarità non è un attributo esplicito della feature bacino, ma si può osservare come

esplicito della feature bacino , ma si può osservare come Antonio Barsottini Appunti per il corso
esplicito della feature bacino , ma si può osservare come Antonio Barsottini Appunti per il corso

esso possa venir calcolato in funzione dei due attributi superficie e sviluppo. L’operazione di calcolo e d’interrogazione possono essere eseguite congiuntamente, costruendo l’espressione di ricerca seguente:

4*3.14*superficie/(sviluppo_spartiacque*sviluppo_spartiacque)<0.3

Il risultato di questa selezione è il bacino n° 2.

Nell’assemblaggio delle espressioni è possibile utilizzare delle funzioni matematiche predefinite, alcune delle quali vengono riportate, a titolo di esempio, nella tabella seguente:

funzione

risultato

ABS(numeric_exp)

restituisce il valore assoluto di numeric_exp

CEILING(numeric_exp)

restituisce il più piccolo intero maggiore o uguale di numeric_exp

FLOOR (numeric_exp)

restituisce il più grande intero minore o uguale di numeric_exp

Per selezionare i valori degli attributi in base al loro ordinamento sono disponibili gli operatori

di

confronto seguenti:

 

operatore

descrizione

 

<

minore

<=

minore o uguale

<>

diverso

>

maggiore

>=

maggiore o uguale

=

uguale

 

Per esempio l’espressione: CN<80 ricerca le entità per le quali l’attributo CN assume un valore minore di 80 (tutti i bacini tranne il n° 2 ed il n° 10).

In

linea generale un test di comparazione che utilizzi uno degli operatori di tabella può fornire

tre possibili risultati:

- TRUE: corrisponde alla selezione di almeno un’entità;

- FALSE: corrisponde alla selezione di zero entità perché nessuna di esse soddisfa il criterio imposto;

perché nessuna di esse soddisfa il criterio imposto; Antonio Barsottini Appunti per il corso CAD +
perché nessuna di esse soddisfa il criterio imposto; Antonio Barsottini Appunti per il corso CAD +

- NULL: corrispondente alla selezione di zero entità in quanto almeno uno tra il valore di confronto e quello di un’entità è NULL (sconosciuto o mancante). Ciò implica che le entità aventi un attributo NULL non possono essere selezionate tramite questi operatori.

Oltre agli operatori di confronto sono disponibili anche quelli logici AND ed OR, che permettono di collegare più condizioni secondo una sintassi del tipo:

prima condizione - operatore (AND/OR) - seconda condizione.

L’operatore NOT corrisponde alla negazione di una condizione e può essere combinato con quelli AND ed OR (in tal caso conviene utilizzare le parentesi per stabilire l’ordine in cui vengono valutate le diverse parti di un espressione).

Nella tabella seguente viene descritto il significato degli operatori logici:

operatore

descrizione

AND

seleziona un’entità se entrambe le condizioni che esso collega sono soddisfatte

OR

seleziona un’entità se almeno una delle due condizioni che esso collega è soddisfatta

NOT

seleziona un’entità se quest’ultima non soddisfa la condizione a cui si riferisce

Nelle tabelle seguenti sono riportati i risultati dell’applicazione degli operatori AND ed OR, relativi ai diversi casi che si possono presentare per le due condizioni da essi collegate. Le tabelle si leggono scegliendo nella prima colonna lo stato della prima condizione e nella prima riga lo stato della seconda condizione; il risultato si legge nella casella d’incrocio della riga e della colonna selezionate. Ad esempio se la prima condizione è VERO, la seconda condizione

è NULL, l’operatore AND produce il risultato: NULL.

Tabella di verità dell’operatore AND:

 

VERO

FALSO

NULL

VERO

VERO

FALSO

NULL

FALSO

FALSO

FALSO

FALSO

NULL

NULL

FALSO

NULL

Tabella di verità dell’operatore OR:

FALSO NULL Tabella di verità dell’operatore OR: Antonio Barsottini Appunti per il corso CAD + GIS
FALSO NULL Tabella di verità dell’operatore OR: Antonio Barsottini Appunti per il corso CAD + GIS
 

VERO

FALSO

NULL

VERO

VERO

VERO

VERO

FALSO

VERO

FALSO

NULL

NULL

VERO

NULL

NULL

Nella tabella seguente sono riportati i risultati dell’applicazione dell’operatore NOT nei tre possibili casi.

Tabella di verità dell’operatore NOT:

VERO

FALSO

NULL

FALSO

VERO

NULL

Ad esempio l’espressione: CN >70 AND CN<79 ricerca le entità per le quali l’attributo CN assume un valore maggiore di 70 e minore di 79 (estremi esclusi), corrispondenti ai bacini n° 7,9; l’espressione: CN = 74 OR CN = 76 ricerca le entità per le quali l’attributo CN assume il valore 74 o il valore 76, corrispondenti ai bacini n° 5,7; infine l’espressione: NOT CN = 70 seleziona le entità per le quali il valore CN è diverso da 70 (bacini n° 2,5,7,8,9,10).

Selezione spaziale e combinata spaziale ed attributiva

Attraverso il comando AutoCAD QUICKPROPERTIES, che può essere lanciato cliccando sull’icona posta nella parte superiore destra del pannello delle proprietà, è possibile eseguire una selezione in base alla posizione delle entità. Richiamando questo comando dopo avere eseguito una selezione in base agli attributi e scegliendo di operare su quest’ultima, è possibile eseguire una selezione che risponde ad entrambi i tipi di criterio.

Le proprietà relative alla posizione che è possibile selezionare con il comando di cui sopra, sono riportate, suddivise per entità, nell’elenco seguente:

- point: position X, position Y, (position Z);

- closed polyline/open polyline: vertex X, vertex Y (coordinate del generico vertice);

- multiline text: position X, position Y, (position Z);

- block reference: position X, position Y, (position Z) (posizione del punto base);

X, position Y, (position Z) (posizione del punto base); Antonio Barsottini Appunti per il corso CAD
X, position Y, (position Z) (posizione del punto base); Antonio Barsottini Appunti per il corso CAD

Oltre alle proprietà relative alla posizione sono disponibili altre proprietà geometriche delle polilinee, tra le quali le più importanti sono: length, area, close (condizione di apertura o chiusura).

Negli esercizi seguenti eseguiremo una selezione spaziale ed una combinata spaziale ed attributiva.

Interrogazione in base alle proprietà geometriche Per individuare i bacini aventi superficie compresa tra 2'000000 m 2 (2km 2 ) e 5'000000 m 2 (5 km 2 ) si può procedere nel seguente modo: si lancia il comando QUICKPROPERTIES e si seleziona la totalità dei bacini in base al loro layer; si esegue poi una prima selezione relativa al limite inferiore di superficie e poi si completa imponendo la selezione relativa al limite superiore (vedi figure):

la selezione relativa al limite superiore (vedi figure): Interrogazione in base alle proprietà geometriche ed agli
la selezione relativa al limite superiore (vedi figure): Interrogazione in base alle proprietà geometriche ed agli
la selezione relativa al limite superiore (vedi figure): Interrogazione in base alle proprietà geometriche ed agli

Interrogazione in base alle proprietà geometriche ed agli attributi

Supponiamo di voler individuare le sezioni di chiusura nelle quali la portata defluente è superiore a 70 m 3 /s ed aventi posizione compresa nel seguente range di coordinate: E 1 = 1598974 m E 2 = 1600724 m N 1 = 4865530 m, N 2 = 4866000 m. Basandoci sui dati delle tabelle e controllando la posizione dei nodi della rete sul disegno, si può constatare l’esito

finale dell’interrogazione dovrà essere il solo nodo J3.

Occorre procedere nel seguente modo: dalla finestra Select by Attributes si impone la condizione sugli attributi:

by Attributes si impone la condizione sugli attributi: Antonio Barsottini Appunti per il corso CAD +
by Attributes si impone la condizione sugli attributi: Antonio Barsottini Appunti per il corso CAD +
Al termine di questa fase sono evidenziati a video i quattro nodi: J1, J2, J3,

Al termine di questa fase sono evidenziati a video i quattro nodi: J1, J2, J3, J6. A questo punto si clicca sul bottone Quick Select disponibile nel pannello delle proprietà e s’impone la prima condizione sulle coordinate come dalla figura seguente:

a condizione sulle coordinate come dalla figura seguente: Si ripete l’ultima operazione inserendo le altre tre

Si ripete l’ultima operazione inserendo le altre tre condizioni sulle coordinate e mantenendo gli stessi settaggi di ricerca. Al termine di questa operazione resta selezionato il solo nodo J3. Salvare il file e chiuderlo.

Le ultime due esercitazioni che seguono sono riepilogative sui diversi argomenti trattati.

ESERCITAZIONE 17 In questa esercitazione delimiteremo le aree scolanti e disegneremo la rete di una piccola fognatura urbana. Completeremo il disegno inserendo delle annotazioni e dei tratteggi. Collegheremo al file un’immagine raster, sovrapponendola in modo speditivo al modello. Eseguiremo delle operazioni di misura sul disegno ed infine imposteremo un layout di stampa. Caricheremo poi un file di georeferenziazione e definiremo degli attributi per alcune delle entità presenti, eseguendo infine delle semplici operazioni di selezione delle entità.

infine delle semplici operazioni di selezione delle entità. Antonio Barsottini Appunti per il corso CAD +
infine delle semplici operazioni di selezione delle entità. Antonio Barsottini Appunti per il corso CAD +

Aprire il file fognatura.dwg. Il disegno è impostato secondo la corrispondenza 1 ud =

1m.

I layer che utilizzeremo sono:

ausilio_bacino ausilio_fognatura bacino (da creare) catastale (da creare) ctr fognatura (da creare) impermeabile (inizialmente congelato) nodi (da creare) permeabile (inizialmente congelato) particolari (da creare) semipermeabile (inizialmente congelato) testo (da creare) tratteggio (da creare) vp (da creare)

Inserimento di un xref raster. Creare un layer “catastale” e renderlo corrente. Mediante il comando XREF (Home>Insert>Reference), caricare il file “catastale” in formato bitmap contenuto nella propria cartella. Eseguirne poi una sovrapposizione speditiva alla base cartografica (che si trova sul layer “ctr”). Per eseguire questa operazione si può ricorrere al comando ALIGN, utilizzando come riferimento due coppie di punti scelti, per comodità, sugli edifici posti su una diagonale dell’immagine. Il comando richiede di selezionare il primo punto sull’immagine ed il corrispondente sul disegno vettoriale, e di ripetere poi l’input per la seconda coppia di punti. Possiamo portare in secondo piano l’immagine mediante l’icona Send to Back situata in Home>Draworder. Possiamo inoltre migliorare la visibilità del modello, modificando, dal menu contestuale dell’immagine, il parametro Fade portandolo al valore 70.

il parametro Fade portandolo al valore 70. Antonio Barsottini Appunti per il corso CAD + GIS
il parametro Fade portandolo al valore 70. Antonio Barsottini Appunti per il corso CAD + GIS
il parametro Fade portandolo al valore 70. Antonio Barsottini Appunti per il corso CAD + GIS

Possiamo adesso disattivare la visualizzazione dell’immagine agendo sulla voce Show Image della tavolozza delle proprietà dell’xref. Delimitazione delle aree scolanti mediante il disegno di polilinee chiuse. Per facilitare il tracciamento è stato predisposto il layer “ausilio_bacino” contenente i vertici dei bacini da tracciare ed un tratteggio che li evidenzia, come si vede nella figura seguente:

che li evidenzia, come si vede nella figura seguente: Per semplificare il lavoro conviene regolare lo

Per semplificare il lavoro conviene regolare lo stile di visualizzazione dei punti scegliendo un simbolo qualunque con dimensione di 3 unità assolute (Home>Utilities>Point Style). Conviene inoltre creare il layer “bacino” sul quale disegnare le polilinee e controllare che sia attivo lo snap Node.

Inserimento di un tratteggio in corrispondenza dei bacini. Creare il layer “tratteggio” di colore verde e renderlo corrente; congelare tutti i layer tranne quello “bacino”. Inserire un tratteggio associativo con stile ANSI37 e scala 0.5, separato per ciascun sottobacino (Home>Draw>Hatch).

Editazione di tratteggi esistenti. I layer appartenenti al filtro “permeabilità” contengono dei tratteggi relativi alle diverse classi di permeabilità presenti nell’area di studio. Come si può osservare visualizzando solo tali layer, non sono presenti i bordi che delimitano le diverse aree tratteggiate; tali bordi possono essere ricreati ricorrendo al comando HATCHEDIT presente in Home>Modify>Edit Hatch. Dopo aver reso corrente il layer del tratteggio sul quale si sta’ operando, si può scegliere l’opzione Recreate boundary del comando di cui sopra, ed optare per la creazione di una polilinea associativa rispetto al tratteggio. Disegno della rete fognaria mediante polilinee aperte. Anche in questo caso sul layer “ausilio_fognatura” sono riportati i punti da collegare. Il disegno può avvenire tenendo acceso e bloccato il layer “ausilio_fognatura” e disegnando su quello “fognatura” che deve essere creato.

su quello “fognatura” che deve essere creato. Antonio Barsottini Appunti per il corso CAD + GIS
su quello “fognatura” che deve essere creato. Antonio Barsottini Appunti per il corso CAD + GIS
Definizione ed inserimento di un blocco per rappresentare i pozzetti di ispezione e di intersezione.

Definizione ed inserimento di un blocco per rappresentare i pozzetti di ispezione e di intersezione. Rendere attivo il layer 0 e congelare tutti i layer tranne quello “bacino”. Disegnare un quadrato di lato 0.9 m ed eseguirne poi un offset di 0.15 verso l’interno. Creare un blocco (Insert>Block>Create) delle due entità, scegliendo come punto base quello centrale (avvalendosi delle funzioni di Autotrack) ed assegnare ad esso il nome “pozzetto”. Rendere corrente il layer fognatura ed inserire (Insert>Block>Insert) il blocco in corrispondenza delle intersezione dei rami della fognatura; Misura di una superficie. Volendo misurare la superficie del bacino posto in alto a sinistra, al netto dell’area occupata dall’edificio, si può procedere nel seguente modo. Si rendono scongelati i soli layer “bacino” ed “impermeabile”. Si lancia il comando AREA (Home>Measure>Area), si sceglie l’opzione Add area e quindi l’opzione Object ed infine si seleziona la polilinea che rappresenta il perimetro esterno del bacino da misurare; al termine di questa operazione l’area in computo viene colorata di verde. Si seleziona poi l’opzione Subtract area e si seleziona per punti il perimetro del primo edificio, avvalendosi dello snap Endpoint e di quello Nearest; al termine di questa operazione l’area occupata dall’edificio appare colorata in marrone, ad indicare che essa è computata in sottrazione. Si ripete l’ultima operazione scegliendo nuovamente l’opzione Add area e quindi, a seguire, quella Subtract area, seguendo poi il perimetro del secondo edificio. Alla linea di comando compare, indicata come Total Area, la superficie netta che ci interessava calcolare; Inserimento di un’annotazione. Possiamo definire uno stile di testo denominato “testi” avente carattere Arial Narrow con dimensione 1.5. Definito un layer “testo”, aggiungiamo un testo multilinea “area per lo smaltimento delle acque provenienti dai bacini 1 e 2” in corrispondenza dell’area a verde posta nella parte superiore del bacino. Inserimento di un oggetto OLE. Vogliamo ora inserire il file “fognatura.xls”, contenuto nella cartella personale, come oggetto OLE collegato e visualizzato come icona. Occorre seguire il percorso Insert>Data>OLE Object e sfogliare le cartelle fino ad

Object e sfogliare le cartelle fino ad Antonio Barsottini Appunti per il corso CAD + GIS
Object e sfogliare le cartelle fino ad Antonio Barsottini Appunti per il corso CAD + GIS

individuare il file desiderato, quindi spuntare l’opzione di visualizzazione come icona. Dopo l’inserimento compare l’icona che rimanda al file selezionato. Impostazione di un layout. Il modello ha un’estensione di circa 260 m per cui, decidendo di stampare in scala 1:500, occorre una tavola che racchiuda uno spazio utile di circa 50 cm. Possiamo quindi utilizzare un formato ISO A2 (594x420). Volendo anche utilizzare un cartiglio, conviene definire un formato personalizzato, eliminando da quello standard la cornice. Dal Page Setup Manager scegliamo la stampante DWGtoPDF e definiamo quindi un formato personalizzato come sopra specificato. Creiamo poi un layer “vp” e rendiamolo corrente. Mediante il comando MVSETUP e la relativa opzione Title block, possiamo a questo punto inserire un cartiglio adeguato al nostro formato. Al di sotto del cartiglio può essere inserito un oggetto di ricoprimento, ricorrendo al comando WIPEOUT (Home>Draw>Wipeout). Questa entità è costituita da un’area poligonale che nasconde gli oggetti sottostanti utilizzando il colore dello sfondo (background) corrente. In questo modo il cartiglio diviene leggibile anche se ad esso si sovrappongono delle finestre mobili. Se necessario l’ordine di visualizzazione delle entità sovrapposte può essere regolato mediante i bottoni denominati Draworder presenti in Home>Modify. Possiamo inserire nella parte sinistra del foglio una finestra mobile avente una Standard scale 2:1 (che corrisponde ad una scala cartacea 1:500) ed in alto a destra un’altra finestra che inquadri i particolari delle caditoie, avente una Custom scale 1:20 (corrispondente ad una scala cartacea di 1:50).

scale 1:20 (corrispondente ad una scala cartacea di 1:50). L’anteprima di stampa può essere visualizzata scegliendo

L’anteprima di stampa può essere visualizzata scegliendo dal menu contestuale del layout (attivabile mediante clic destro sulla relativa linguetta) la voce Plot e quindi cliccando sul bottone Preview della finestra Plot Layout.

Georeferenziazione. Dopo aver caricato il plugin ArcGIS for AutoCAD mediante il comando NETLOAD e la scelta del file ArcGISforAutoCAD.dll, possiamo scegliere

del file “ ArcGISforAutoCAD.dll ” , possiamo scegliere Antonio Barsottini Appunti per il corso CAD +
del file “ ArcGISforAutoCAD.dll ” , possiamo scegliere Antonio Barsottini Appunti per il corso CAD +

l’opzione Assign Coordinate System dal pannello Manage della scheda ArcGIS for AutoCAD, quindi sfogliare le cartelle fino ad individuare il file Monte Mario (Rome) Italy 1 contenuto in: Projected Coordinate System>National Grid>Europe. Definizione delle classi di attributi e selezione delle entità. Come esercitazione sugli attributi possiamo definire una feature class relativa ai nodi di intersezione tra la fognatura del piano attuativo in esame e quella comunale preesistente. Gli attributi d’interesse sono riportati nella tabella seguente:

nodo

id_nodo

sollevamento_meccanico

manutenzione

(integer)

(text)

(integer)

1

1

no

2008

2

2

no

2006

3

3

no

2011

I nodi si intendono numerati procedendo dall’alto in basso. Creiamo il layer “nodi” e disegniamo dei punti in corrispondenza dei nodi (vedi layer “nodi_risolto). Definiamo una feature class “nodi” di tipo Point imponendo come filtro la condizione che il layer delle entità che la costituiranno appartengano al layer “nodi”. Definiamo poi i tre attributi descritti nella tabella precedente.

Possiamo poi eseguire un’interrogazione congiunta geometrica e semantica, per l’individuazione dei nodi che ricadono nell’ambito delimitato dalle seguenti coordinate (1598893, 4861046), (1598981,4861173) e che hanno ricevuto interventi di manutenzione precedenti al 2007. In questo caso occorre prima eseguire una selezione in base agli attributi: dalla finestra Select by Attributes formuliamo l’istanza seguente:

manutenzione < 2007. Per imporre le condizioni sulla posizione possiamo ricorrere al comando QUICKSELECT formulando quattro istanze consecutive, concatenate mediante la scelta dell’opzione Include in new selection set e controllando che non sia presente il segno di spunta alla voce Append to current selection set. Al termine dell’operazione resta selezionato il solo nodo n° 2.

dell’operazione resta selezionato il solo nodo n° 2. Antonio Barsottini Appunti per il corso CAD +
dell’operazione resta selezionato il solo nodo n° 2. Antonio Barsottini Appunti per il corso CAD +